Проверка наличия подписки ИТС по регистрационному номеру поставки

Опубликовал Андрей (smirnov.a) в раздел Обмен - Интеграция с WEB

Быстро, на коленке написал проверку наличия подписки ИТС по регистрационному номеру поставки через сайт 1С. Может быть изобрел велосипед, но готового решения не нашел.


Собственно код:

Функция РазборСтроки(знач Стр, Разделитель) Экспорт

    МассивЗначений = Новый Массив;

    Символ = Найти(Стр, Разделитель);
    Пока Символ > 0 Цикл

        МассивЗначений.Добавить(Лев(Стр, Символ - 1));
        Стр = Прав(Стр, СтрДлина(Стр) - Символ);

        Символ = Найти(Стр, Разделитель);
    КонецЦикла;
    МассивЗначений.Добавить(Стр);

    Возврат МассивЗначений;
КонецФункции

Функция ПроверитьПодпискуИТС(НомерДляПроверкиРегистрации)
URL = "1c.ru";

URLПроверки = "/rus/support/its/js-check-subscribe.jsp?rn="+НомерДляПроверкиРегистрации;
Коннект = Новый HTTPСоединение(URL);
ЧтениеТекста = Новый ТекстовыйДокумент;

СтруктураПараметров = Новый Структура;

ИмяВременногоФайла=ПолучитьИмяВременногоФайла("txt");
Коннект.Получить(URLПроверки,ИмяВременногоФайла);

ЧтениеТекста.Прочитать(ИмяВременногоФайла);
Для НомерСтроки=1 по ЧтениеТекста.КоличествоСтрок() Цикл

    Стр = ЧтениеТекста.ПолучитьСтроку(НомерСтроки);
    Если Найти(Стр,"ajaxCheck")>0 Тогда

        Стр = СтрЗаменить(Стр,"ajaxCheck","");
        Стр = СтрЗаменить(Стр,"(","");

        Стр = СтрЗаменить(Стр,")","");
        МассивСтроки = РазборСтроки(Стр,",");

        СтруктураПараметров.Вставить("РегНомер",МассивСтроки[0]);
        СтруктураПараметров.Вставить("ПодпискаАктивна",МассивСтроки[1]);

        СтруктураПараметров.Вставить("ТребуетсяПодписка",МассивСтроки[2]);
    КонецЕсли;
КонецЦикла;

   Возврат СтруктураПараметров;
КонецФункции

Процедура ОсновныеДействияФормыОсновныеДействияФормыВыполнить(Кнопка)

    ДанныеОПодписке = ПроверитьПодпискуИТС("1234567");

    Сообщить(ДанныеОПодписке.РегНомер);
    Сообщить(ДанныеОПодписке.ПодпискаАктивна);

    Сообщить(ДанныеОПодписке.ТребуетсяПодписка);


КонецПроцедуры

Как и обещал, выкладываю обработку.

Скачать файлы

Наименование Файл Версия Размер
Проверка наличия подписки ИТС
.epf 7,33Kb
01.07.11
152
.epf 7,33Kb 152 Скачать

См. также

Комментарии
0. Андрей (smirnov.a) 612 30.06.11 17:53 Сейчас в теме
Быстро, на коленке написал проверку наличия подписки ИТС по регистрационному номеру поставки через сайт 1С. Может быть изобрел велосипед, но готового решения не нашел.

Перейти к публикации

1. Артур Аюханов (artbear) 850 30.06.11 17:55 Сейчас в теме
ИМХО
1. Сразу бы выложил и готовую обработку.
2. код Выполнить не очень корректен, если подписки нет, будет ошибка выполнения :(
3. Я ни разу не пробовал так проверять, поэтому вопрос: ты юзаешь открытый ресурс, верно?
2. r_p (smirnov.a) 01.07.11 07:57 Сейчас в теме
1. Сделаю, не вопрос. Просто думал что как обработка она мало полезна, а как алгоритм напротив.
2. Соответственно поправлю.
3. Конечно открытый, все по данным http://1c.ru/rus/support/its/its.htm
3. г. Казань Рустем Гумеров (Rustig) 781 08.07.11 18:42 Сейчас в теме