gifts2017

Исправляем ошибку в документе Корректировка Остатков ОС В связи с вступлением норм НК (конфигурация 287 Бухгалтерии для Украины)

Опубликовал Serge Fox (sergefox) в раздел Управление - Практика учета

При проведении анализа переноса остатков на 1 апреля 2011 года в конфигурации 287 Бухгалтерии для Украины обнаружена некорректная работа документа КорректировкаОстатков ОС.
В сообщении - текст измененной процедуры модуля документа. (Если кому интересно - ошибка связана с использованием имени реквизита табличной части ПервСтоимость в модуле документа).
Процедура ПроводкиШапка()      
	
	ОстСтоимостьНУ = 0;
	Для НомерГруппы = 1 По 4 Цикл
		Ит = СоздатьОбъект("БухгалтерскиеИтоги");
		Ит.ИспользоватьРазделительУчета(Фирма);
		СчетГруппы = "ОС."+НомерГруппы;
		Ит.ИспользоватьСубконто(ВидыСубконто.НалогиОтчисления);
		Ит.ВыполнитьЗапрос(НачКвартала(ДатаДок),,СчетГруппы);
		//Возьмем остатки в целом по группе
		ОстСтоимостьГруппы = Ит.СНД("С");
		ОстСтоимостьНУ = ОстСтоимостьНУ + ОстСтоимостьГруппы;
	КонецЦикла;
	
	// НМА
	Ит = СоздатьОбъект("БухгалтерскиеИтоги");
	Ит.ИспользоватьРазделительУчета(Фирма);
	Ит.ИспользоватьСубконто(ВидыСубконто.НеоборотныеАктивы);
	Ит.ВыполнитьЗапрос(НачКвартала(ДатаДок),,"НА.1,НА.2");
	Ит.ВыбратьСубконто(1);
	Пока Ит.ПолучитьСубконто(1) = 1 Цикл
		тПервСтоимость = 0;
		Если Ит.ПолучитьСчет(,СчетПоКоду("НА.1")) = 1 Тогда
			тПервСтоимость = Ит.СНД("С");
		КонецЕсли;
		ОстСтоимость = тПервСтоимость;
		Если Ит.ПолучитьСчет(,СчетПоКоду("НА.2")) = 1 Тогда
			ОстСтоимость = тПервСтоимость - Ит.СНК("С");
		КонецЕсли;
		ОстСтоимостьНУ = ОстСтоимостьНУ + ОстСтоимость;
		
	КонецЦикла; 
	РазницаБУНУ = Итог("ОстаточнаяСтоимостьБУ") -  ОстСтоимостьНУ;
	
	СчетНУ = "Н" + НеобАктивРазница.Счет;
	глПровНУ(Контекст,СчетНУ,,,"Разница НУ корр. остат. необ. активов",, МестоХраненияРазн,НеобАктивРазница,,
	,,, ,,"НА",РазницаБУНУ);
	
КонецПроцедуры

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Анатолий (ABudnikov) 06.07.11 12:06
Там не только ошибка в использовании переменной
Ещё не правильно выполняются бухгалтерские запросы: Ит.ВыполнитьЗапрос(НачКвартала(ДатаДок),,"НА.1,НА.2");
При таком написании получается, что остаткочная стоимость берётся на начало 1кв, а надо на начало 2кв

я написал во всех бух запросах так: Ит.ВыполнитьЗапрос(НачКвартала(ДатаДок+1),,"НА.1,НА.2");
2. villy (vitaliy.ermolenko) 07.07.11 11:16
так вроде ошибка использования переменной ПервСтоимость на результат никак не влияет
3. Евгений (Semenyak) 08.07.11 23:41
Еще как влияет. Если не исправить то будет рвать на стоимость нематериальных активов.
Только похоже все забыли главную ошибку
РазницаБУНУ = ОстСтоимостьНУ - Итог("ОстаточнаяСтоимостьНУ");

Иначе все прочие исправления не имеют смысла. 8-)
4. anry mc (AnryMc) 09.07.11 10:17
Документ "НачислениеИзноса" Функция РассчитатьСрокИспользования не видит "ДатаНачНУ" и для старых ОС полный бред...
5. villy (vitaliy.ermolenko) 21.07.11 17:05
(3) по ходу в моем случае не было НА. а так ПервСтоимость не доступна для записи оказывается
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа