gifts2017

Гарантийный талон для УТ 10.3

Опубликовал Николай Клюкин (kolianus) в раздел Печать - Печатные формы документов

Понадобилось создать печатную форму гарантийного талона. За основу брал обработку которую нашел на сайте http://infostart.ru/public/15330/

Для работы нужно внести несколько изменений в конфигурацию:

В конфигураторе:

1) План видов характеристик - СвойстваОбьектов

2) Необходимо добавить предопределенные данные:

Имя: СрокГарантии

Наименование: Срок гарантии

Тип: Строка 

В базе:

1) Операции - План видов характеристик 

2) В назначении срока гарантии указать Справочник "Номенклатура"

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Гарантийны талон.epf
.epf 15,11Kb
15.07.13
212
.epf 15,11Kb 212 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Ожерельев (Поручик) 27.07.11 18:12
(0) Не свисти, что ссылку не помнишь, во-первых она легко находится поиском, во-вторых в оригинальной разработке курочить конфу не требовалось, просто добавлялся элемент свойства номенклатуры в режиме предприятия.
Находи оригинал, указывай в описании и исправляй обработку, тогда минус снимется.
halushka; +1 Ответить
2. Николай Клюкин (kolianus) 27.07.11 19:30
Изменил.
Но уточню, я делал именно с изменением в конфигурации, мне так было проще, за одно обезопасил себя от случайного удаления (Дурная привычка чистить все помеченные на удаленные данные)
К тому же выкладываю то что делал конкретно для себя
3. Денис Стюров (pitbul) 07.09.11 12:12
а где фаил для скачивания?
4. Александр Гарькин (agarkin) 06.12.11 13:46
я сам такое же писал, но попробую и вашу обработку
5. Денис К. (stellzzz) 23.12.11 09:37
попробуем эту обработку. предыдущая не подошла. смущает только что править руками надо.
6. Денис К. (stellzzz) 23.12.11 10:05
видимо у меня все же руки кривые. не хочет работать в Рознице ни при каких обстоятельствах. опять зря баллы потратил :(
Будем искать дальше
7. Николай Клюкин (kolianus) 23.12.11 10:06
(6) stellzzz, в чем именно проблема какая ошибка?
9. ProGramMoS ProGramMoS (ProGramMoS) 31.08.12 15:31
1с КА - как правильно установить печатную форму?
10. Сергей Ожерельев (Поручик) 03.09.12 13:09
11. Сергей Ожерельев (Поручик) 03.09.12 13:10
(9) Ты ещё и свою конфигурацию будешь курочить
12. Андрей Нагорный (AndreyNag) 04.01.13 12:31
Привет, Всем. С Новым Годом! Здоровья и успехов!
А теперь к делу. ВПФ подключил по инстукции, но как на скринах в посте, так и у меня не отображается товар. При выводе формы на экран в статусокне ругается, что не введены серийники для продаваемых позиций. Где и что надо допилить, чтобы получить искомый гарантийник хотя бы со списком товара из чека? А уж серийники кладовщики добавят со сканера вручную. Хотя для меня пока это тоже вопрос. Как происходит редактирование данных в ВПФ перед печатью.
Спасибо за внимание.
13. Андрей Нагорный (AndreyNag) 05.01.13 10:35
И снова здравствуйте.
Гарантийник никак не хочет печатать список товара. На выходной форме отображается только шапка и подвал.
Попробовал привести в соответствие названий реквизитов в форме гарантийника с формой ЧекаККМ = безрезультатно. Подскажите как отлаживать работу внешних печатных форм?
Спасибо за внимание.
14. Андрей Нагорный (AndreyNag) 10.01.13 12:22
После допиливания кода формы получил в печатной форме список товара из чека. Щас бодаюсь чтобы и срок гарантии брался из карточки товара. Встаёт концептуальный вопрос: как изменить печатную форму перед выводом на принтер, чтобы занести серийные номера в позиции со сканера штрихкодов?
Спасибо за внимание.
15. Андрей Нагорный (AndreyNag) 14.01.13 10:17
Здравствуйте Все.
Потихоньку продвигаюсь в пришивании Гарантийника к стандартной торговле. Добился вывода строк с наименованиями товара, однако, СрокГарантии не печатается. Он просто не берётся из характеристики товара, хотя цихры там присутствуют.
Выставляю на суд зрителей исправленный (под мои нужды) код

//Формирует табличный документ
Функция Печать() Экспорт
	ТабДокумент = Новый ТабличныйДокумент;
	ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_ГарантийныйТалон";		
	ТипДокумента = "РеализацияТоваровУслуг";
	//Определим тип документа
	Если ТипЗнч(СсылкаНаОбъект) = ТипЗнч(Документы.РасходныйОрдерНаТовары.ПустаяСсылка()) Тогда
		ТипДокумента = "РасходныйОрдерНаТовары";
	КонецЕсли;
	Если ТипЗнч(СсылкаНаОбъект) = ТипЗнч(Документы.ЧекККМ.ПустаяСсылка()) Тогда
		ТипДокумента = "ЧекККМ";
	КонецЕсли;	
	//Получим шапку документа
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	               |	Товары.Номенклатура Как Номенклатура,
				   |	Товары.ХарактеристикаНоменклатуры Как ХарактеристикаНоменклатуры,
	               |	СерийныеНомера.СерийныйНомер Как СерийныйНомер,
				   |	Товары.СерияНоменклатуры Как СерияНоменклатуры,
	               |	ЗначенияСвойствОбъектов.Значение КАК СрокГарантии,
	               |	Товары.Ссылка.Ссылка Как Ссылка,
	               |	Товары.Ссылка.Номер Как Номер,
	               |	Товары.Ссылка.Дата Как Дата,
	               |	Товары.Ссылка.Ответственный Как Ответственный
	               |ИЗ
	               |	Документ.РеализацияТоваровУслуг.Товары КАК Товары
	               |		ЛЕВОЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг.СерийныеНомера КАК СерийныеНомера
	               |		ПО Товары.КлючСвязи = СерийныеНомера.КлючСвязи И Товары.Ссылка = СерийныеНомера.Ссылка
	               |		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
	               |		ПО (ЗначенияСвойствОбъектов.Свойство = ЗНАЧЕНИЕ(ПланВидовХарактеристик.СвойстваОбъектов.СрокГарантии))
	               |			И Товары.Номенклатура = ЗначенияСвойствОбъектов.Объект
	               |ГДЕ
	               |	Товары.Ссылка = &Ссылка";
	Запрос.Текст = СтрЗаменить(Запрос.Текст, "РеализацияТоваровУслуг", ТипДокумента);
	Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект);
	Товары = Запрос.Выполнить().Выгрузить();
	
	Если Товары.Количество() = 0 Тогда Возврат ТабДокумент; КонецЕсли;
	Заголовок = Товары[0];
	

	Макет = ПолучитьМакет("ГарантийныйТалон");

	
	// Выводим логотип
	ОбластьМакета = Макет.ПолучитьОбласть("Логотип");
	Организация = СсылкаНаОбъект.Организация;
	Счет  = Организация.ОсновнойБанковскийСчет;
	ОбластьМакета.Параметры.Организация = Организация.НаименованиеПолное;	
	РеквизитыОрганизации = "ИНН " + Организация.ИНН +
							", КПП " + Организация.КПП +
							", ОГРН " + Организация.ОГРН +
							", р/с " + Счет.НомерСчета +
							" в " + Счет.Банк +
							", к/с " + Счет.Банк.КоррСчет +
							", БИК " + Счет.Банк.Код;
							//", тел " + Организация.НомерТелефона +
							//", телы " + Организация.Телефоны;
	ОбластьМакета.Параметры.РеквизитыОрганизации = РеквизитыОрганизации;
	ТабДокумент.Вывести(ОбластьМакета);	
	
	// Выводим заголовок
	ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
	ОбластьМакета.Параметры.Заполнить(Заголовок);
	ОбластьМакета.Параметры.Дата = Формат(Заголовок.Дата,"ДЛФ=DD");
	ТабДокумент.Вывести(ОбластьМакета);	
	// Выводим шапку таблицы
	ОбластьМакета = Макет.ПолучитьОбласть("ШапкаТаблицы");	
	ТабДокумент.Вывести(ОбластьМакета);	
	// Выводим строки
	НомерСтроки = 1;
	Для Каждого Строка Из Товары Цикл
		//Если НЕ ЗначениеЗаполнено(Строка.СерийныйНомер)  И НЕ ЗначениеЗаполнено(Строка.СерияНоменклатуры) Тогда
		//	 Сообщить("Для номенклатуры " + Строка.Номенклатура + " " + Строка.ХарактеристикаНоменклатуры + "не указан серийный номер." );
		//	 Продолжить;
		//КонецЕсли;	
//		Если СокрЛП(Строка.СрокГарантии) = "" Тогда
//			 Сообщить("Для номенклатуры " + Строка.Номенклатура + " " + Строка.ХарактеристикаНоменклатуры + "не указан срок гарантии." );
//			 Продолжить;
//		КонецЕсли;			 
		ОбластьМакета = Макет.ПолучитьОбласть("Строка");
		ОбластьМакета.Параметры.Заполнить(Строка);
		Если ЗначениеЗаполнено(Строка.СерияНоменклатуры) Тогда
			ОбластьМакета.Параметры.СерийныйНомер = Строка.СерияНоменклатуры;
		КонецЕсли;	
		ОбластьМакета.Параметры.НомерСтроки = НомерСтроки;
//		ОбластьМакета.Параметры.Номенклатура = Номенклатура;
//		ОбластьМакета.Параметры.СрокГарантии = СрокГарантии;
		ТабДокумент.Вывести(ОбластьМакета);
		 
		НомерСтроки = НомерСтроки + 1;
	КонецЦикла;	
//	ОбластьМакета = Макет.ПолучитьОбласть("Подпись");	
//	ОбластьМакета.Параметры.Заполнить(Заголовок);
//	ОбластьМакета.Параметры.Ответственный = ПараметрыСеанса.ТекущийПользователь;
//	ТабДокумент.Вывести(ОбластьМакета);

//	ОбластьМакета = Макет.ПолучитьОбласть("Адрес");	
//	ТабДокумент.Вывести(ОбластьМакета);	
	
	ОбластьМакета = Макет.ПолучитьОбласть("Условия");	
	ТабДокумент.Вывести(ОбластьМакета);		

	Возврат ТабДокумент;	
КонецФункции


Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)
	// Вставить содержимое обработчика.
КонецПроцедуры

...Показать Скрыть
16. Андрей Нагорный (AndreyNag) 14.01.13 21:23
Со сроком гарантии добадаюсь чуть позже, а сейчас встал ребром вопрос ввода серийных номеров в печатную форму перед выводом на принтер. Подключил сканер Eclips MS5145 и 1000CCD. В настройках всё нормально, тесты оба отрабатывают. Форму перевыводом на печать делаю редактируемой и в подтверждение правильности настроек я могу туда руками ввести текст. Однако сканер не хочет туда вставлять сканированные номера.
Сейчас сафсем нет времени вводить номера в базу. Поэтому выбрано полуручной способ выдачи гарантийников.
Спасибо за внимание.
17. agenttsmit agent (agenttsmit) 26.01.13 15:26
18. agenttsmit agent (agenttsmit) 26.01.13 15:44
19. Сергей Ожерельев (Поручик) 27.01.13 16:05
(17)(18) Написано же - для УТ 10.3. С какого перепугу она должна работать на УТ 11? Там совсем другие механизмы.
Для УТ 11 берите эту обработку http://infostart.ru/public/144575/
20. andr bat (zoytsa) 24.03.13 16:00
(19) Поручик, большое спасибо!
21. Сергей Ожерельев (Поручик) 24.03.13 16:16
(20) Проголосовать лень было?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа