gifts2017

Автосоздание ПользователейИБ в распределенной базе

Опубликовал Сергей Генералов (serg1c) в раздел Администрирование - Защита, права, пароли

Задолбала ситуация с распределенными базами - создаешь новую базу и надо опять всех пользователей распределенных
баз создавать ручками. Потому сделал следующее: добавил реквизит и табличную часть в справочник Пользователи. При первоначальном
запуске внедренного обновления программа при запуске собирает данные об интерфейсе по умолчанию и доступных ролях всех поьзователей,
находящихся в корневом каталоге (специально сделал папку "Неиспользуемые", а в коре только действующие Пользователи) и записывает
данные в справочники Пользователей.
Зато потом, когда открываешь только что выгруженную периферийную базу все эти данные преобразуются в ПользователейИБ.
Правда необходимо хранить все пароли в реквизите справочника Пользователей (не стал заморачиваться с дешифрацией паролей и прочее)
Работет в реальной базе 8.1 Управление торговлей 10.3, но думаю, что не проблема все это на 8.2 перенести.

Скачать файлы

Наименование Файл Версия Размер
Описание встройки в базу 20
.txt 7,10Kb
06.09.11
20
.txt 7,10Kb Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение
Комментарии
1. Владимир Ленгин (vlengin) 06.09.11 17:39
неуправляемое приложение :D :D :D
2. Сергей Генералов (serg1c) 07.09.11 00:01
(1)Ладно, согласен звучит смешно.
Дополнил в файле описания пару функций (сразу забыл)
Простите великодушно.

Перем СписокРолей Экспорт;
Перем СписокИнтерфейсов Экспорт;
//
Процедура ПриНачалеРаботыСистемы()

///

КонецПроцедуры

СписокРолей = Новый Массив;
Для Каждого СтрокаРолей Из Метаданные.Роли Цикл
Имя = СтрокаРолей.Имя;
СписокРолей.Добавить(Имя);
КонецЦикла;
СписокИнтерфейсов = Новый Массив;
Для Каждого СтрокаИнтерфейсов Из Метаданные.Интерфейсы Цикл
Имя = СтрокаИнтерфейсов.Имя;
СписокИнтерфейсов.Добавить(Имя);
КонецЦикла;
3. Евгений Сосна (pumbaE) 08.09.11 18:36
А обработка с ИТС "ВыгрузкаЗагрузкаПользователей.epf" чем не удовлетворила?
Периферия у вас размножается неконтролируемо?
Создали базу, с центра выгрузили список пользователей, в периферийную загрузили.
4. Сергей Генералов (serg1c) 09.09.11 17:55
(3) Наверное лень обуяла, решил сделать чтоб все было на автомате.
И потом на центральной базе часто меняются права пользователей и сами пользователи.
А периферия на 10-и ноутбуках, которые сразу не соберешь (всегда кто-нибудь в командировке)
А ноутбук берет не всегда один и тот же человек.
Вот и подумал, что может быть еще кому-нибудь полезной будет.
Ну нет, так нет.
Дело хозяйское :)