gifts2017

Вывод пустого номера ПФР (платформа 8.2)

Опубликовал Программулькин (Программулькин) в раздел Отчеты - Бухгалтерские

Примитивная обработка, которая покажет сотрудников с пустым номером СНИЛС.

Примитивная обработка, которая покажет сотрудников с пустым номером СНИЛС. Использование: Файл - Открыть - выбрать обработку - Выполнить

Но вот прошло время, и появился первый upd, и теперь это уже не обработка, как первый файл, а уже отчёт, хотя ещё с ним много чего можно сделать, но это зависит от спроса...

ЗЫ: Получилось очень даже забавненько для анализа:

  • Функция кнопки "Кто с пустым СНИЛС?" - показывает сотрудников,
    у которых поле "Номер ПФР" заполнено значениями  "   -   -      " и "".
  • Функция кнопки "Одинаковый СНИЛС по Сотрудникам" - проводит анализ поля "Номер ПФР" по сотрудникам.
  • Функция кнопки "Одинаковый СНИЛС по ФизЛицам" - проводит анализ поля "Номер ПФР" по физ. лицам.

история изменений:

25.10.11 Снилс v2.erf

- преобразование обработки в отчёт

- добавление функционала

- новый код

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
пустой ПФР
.erf 12,12Kb
26.11.14
55
.erf 12,12Kb 55 Скачать
пфр
.epf 6,02Kb
26.11.14
25
.epf 6,02Kb 25 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Vladimir (Boroda) 24.09.11 18:15
Обработка, может, и примитивная, но нужная и полезная, особенно через месяц это будет видно, когда отчёты начнём сдавать... Спасибо!
2. Роман Хусяинов (rom-x) 24.09.11 22:12
(1) По моему при формировании отчета, если у сотрудника нет СНИЛса, то выводится сообщение.
3. Программулькин (Программулькин) 25.09.11 07:23
(2) rom-x,
да именно так, показывает, но для этого необходимо формировать тот отчёт, а он шибко тяжёлый, и долго формируется. Вообще обработка была написана за 5 минут и как быстрый инструмент для решения чётко поставленный задачи, а задача была следующая: перенести данные из 8ки в 7ку, а точнее, синхронизировать сотрудников, проблема бы в том, что не было ни одного уникального поля, по которому можно было провести синхронизацию, а СНИЛС он должен быть и должен быть уникальным, вот таким образом и пришлось выкручиваться, прошу прощение за тупое оформление, некогда было возится. А сюда выложил по многим причинам, озвучивать все не буду, одна из них: примитивное готовое решение для начинающих, кстати, подобные задачи с подвохом есть на экзаменах, кстати вот аналог для 7ки http://infostart.ru/public/91724/
4. Галина (Beta) 26.09.11 04:30
вопрос к автору: для каких целей делаете синхронизацию с ЗиК ? Паралельно ведете учет в двух программах?
5. Программулькин (Программулькин) 26.09.11 05:15
Beta пишет:

вопрос к автору: для каких целей делаете синхронизацию с ЗиК ? Паралельно ведете учет в двух программах?

к сожалению я не могу ответить на это вопрос исходя из этических соображений.
6. Denis Elmanov (jack_nsk) 28.09.11 12:28
СНИЛС тоже не у всех есть. У военных, например, нет, насколько я помню.

p.s. писал давненько отчет для своих расчетчиков, который выводил не только физ.лиц. с пустым СНИЛСОМ, но и с некорректным (контрольная сумма неверная), аналогично с ИНН. также выводились люди со "странным" возрастом (до 16 и после 70) с намёком на проверку корректности даты рождения. Выложить? Кому-нибудь пригодится?
7. Роман Хусяинов (rom-x) 28.09.11 13:20
(6) jack_nsk, первый раз слышу о контрольной сумме в снилс, выкладывайте, посмотрим :)
8. Denis Elmanov (jack_nsk) 28.09.11 13:28
(7) rom-x, ну что ж вы так :) поищите в google "Правила расчета контрольной суммы СНИЛС"

отчет выложу немного позднее, оказывается проверки контрольной суммы в нём нет, видимо я её в код внедрял. добавлю в отчёт и выложу
9. Программулькин (Программулькин) 28.09.11 14:20
проверка происходит во время ввода СНИЛСА, поэтому тут эта проверка не особо нужна,конечно, обработка требует должного оформления, я так, для себя делал,но можно как исходник использовать, хотя и кадровикам себя "по-быстрому" проверить тоже могут
10. Роман Хусяинов (rom-x) 28.09.11 15:48
(8) jack_nsk, уже нашел, и даже написал проверку для 7-ки:
//*******************************************
Процедура ПриОткрытии()
	Перем сСотр;
	ОчиститьОкноСообщений();
	сСотр = СоздатьОбъект("Справочник.Сотрудники");
	сСотр.ПорядокКодов();
	сСотр.ВыбратьЭлементы();
	Пока сСотр.ПолучитьЭлемент() = 1 Цикл
		Кс = 0;
		Если Число(сСотр.СтраховойНомерПФР) = 0 Тогда
			Сообщить("У сотрудника " + сСотр.Наименование + " нет СНИЛС");
			Продолжить;
		Иначе
			Снилс =СтрЗаменить(СтрЗаменить(сСотр.СтраховойНомерПФР,"-",""), " ", "");
			КЧ = Число(Прав(Снилс, 2)); // Контрольное число
			ЦН = Лев(Снилс, 9); // Цифры номера
			Для Инд=1 По 9 Цикл
			   Кс = Число(Сред(ЦН, Инд, 1))*(10-Инд) + Кс; // Контрольная сумма.
			КонецЦикла;
			Если (Кс<100) И (Кс = КЧ) Тогда
				//Сообщить(сСотр.Наименование);
			ИначеЕсли (Кс>101) И (Кс%101 = КЧ) Тогда
				//Сообщить(сСотр.Наименование);
			ИначеЕсли (Кс = 100) ИЛИ (Кс = 101) ИЛИ (Кс%101 = 100) ИЛИ (Кс%101 = 101)    Тогда
				//Сообщить(сСотр.Наименование);
			ИначеЕсли Кс <> КЧ Тогда
				Сообщить("У сотрудника " + сСотр.Наименование + " не правильный снилс");
			КонецЕсли;
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры	
...Показать Скрыть

(9) Программулькин, добавьте проверку снилс в отчет для 7-ки и всем будет польза :).
11. Программулькин (Программулькин) 29.09.11 03:09
12. Программулькин (Программулькин) 29.09.11 07:46
Готово, добавил, плюс откорректировал (для 7ки), а для 8ки есть проверка? а то в самой конфе она больно мудрёная какая-то.
13. Владислав Слынько (Shumaher1870) 31.01.12 19:29
просто и удобно - спасибо
14. Маргарита Михайлова (margo_m09) 26.03.13 14:06
15. Марина Чирина (chmv) 16.09.13 10:10
интереснее с некорректным
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа