gifts2017

Остатки товара для Бухгалтерии 2.0 (Рабочее место работника склада)

Опубликовал Сергей Кнапнугель (segarega) в раздел Отчеты - Бухгалтерские

Обработка позволяет видеть текущие остатки с ценами. Отсюда же можно создать новый документ

При закрытии настройки сохраняются. При нажатии на кнопку "обновить" время и остатки обновляются на текущие. Сделано на базе подбора номенклатуры с возможностью просмотра всего справочника или только остатков по складу, с ирархией и без. В режиме справочника позволяет проводить все те же действия что и справочник список номенклатуры (добавление, изменение, и т.д). Возможность поиска по наименованию, полному наименованию, коду.

Кнопки - создание нового документа. При желании можно изменить на свои или убрать вовсе.

Есть возможность перетаскивания строк мышкой из обработки в документ для этого необходимо добавить в данные документы следующий код:

в модуль формы:

Процедура ОбщееПеретаскивание(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Колонка)

    СтандартнаяОбработка = Ложь;
    ПараметрыПеретаскивания.Действие = ДействиеПеретаскивания.Копирование;
    Если Тип(ПараметрыПеретаскивания.Значение) = Тип("Массив") Тогда    
        Для каждого ПеретаскиваемаяСтрока из ПараметрыПеретаскивания.Значение Цикл
            ДобавляемаяСтрока = ЭтотОбъект[Элемент.Имя].Добавить();
            ЗаполнитьЗначенияСвойств(ДобавляемаяСтрока, ПеретаскиваемаяСтрока);
        КонецЦикла;
    Иначе
        ДобавляемаяСтрока = ЭтотОбъект[Элемент.Имя].Добавить();
        ЗаполнитьЗначенияСвойств(ДобавляемаяСтрока, ПараметрыПеретаскивания.Значение);
    КонецЕсли;
КонецПроцедуры

Процедура ОбщаяПроверкаПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Колонка)

    СтандартнаяОбработка = Ложь;
    ПараметрыПеретаскивания.Действие                             = ДействиеПеретаскивания.Копирование;
    ПараметрыПеретаскивания.ДопустимыеДействия                     = ДопустимыеДействияПеретаскивания.Копирование;

КонецПроцедуры

В процедуру ПриОткрытии :

 ПодключитьВозможностьПеретаскивания(ЭтаФорма); 

В Основной модуль:

Процедура ПодключитьВозможностьПеретаскивания(НужнаяФорма) Экспорт

      Для каждого ЭлементФормы из НужнаяФорма.ЭлементыФормы Цикл
        Если ТипЗнч(ЭлементФормы) = Тип("ТабличноеПоле") Тогда
            ЭлементФормы.РазрешитьНачалоПеретаскивания     = Истина;
            ЭлементФормы.РазрешитьПеретаскивание         = Истина;
            ЭлементФормы.РежимВыделения                    = РежимВыделенияТабличногоПоля.Множественный;
            ЭлементФормы.УстановитьДействие("Перетаскивание", Новый Действие("ОбщееПеретаскивание"));
            ЭлементФормы.УстановитьДействие("ПроверкаПеретаскивания", Новый Действие("ОбщаяПроверкаПеретаскивания"));
        КонецЕсли;
    КонецЦикла;

КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
РМ_Склад.epf
.epf 37,04Kb
24.11.16
97
.epf 37,04Kb 97 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

0. Сергей Кнапнугель (segarega) 21.10.11 17:26
Обработка позволяет видеть текущие остатки с ценами. Отсюда же можно создать новый документ


Перейти к публикации

1. Samir Nuriyev (Samir_2011) 21.10.11 17:26
БП 2.0
Мне понравилась как идея, так в принципе и реализация, работает пока без глюков. Было бы совсем чудесно если бы она еще общие остатки показывала.
2. Наталья Власова (VNN21122006) 25.10.11 09:23
Прикольный отчет. Поставил на программу 1С:Бухгалтерия предприятия 8.2 работает 2.0.27.10. Хотелось бы чтоб был отбор по группам товаров. А так интересная работа. Спасибо.
3. Samir Nuriyev (Samir_2011) 25.10.11 15:39
При перемещении в документ - реализация товаров и услуг - не подставляются автоматом счета и прочие реквизиты номенклатуры. Это только у меня так?
4. Сергей Кнапнугель (segarega) 08.11.11 20:51
(3) Samir_2011
да это действительно так, и как это исправить пока не знаю, так и то что по двойному щелчку обработка закрывается изначально хотелось что бы шла обработка подбора в активное окно с подстановкой реквизитов по умолчанию... если кто подскажет буду благодарен :)
5. Дмитрий Титов (dtitov) 28.11.11 14:27
Вполне приличная обработка, для моего конкретного случая подошла весьма, т.к. самому некогда было заморачиваться. С удовольствием плюсую!
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа