gifts2017

Если вам надоело перезапускать конфигуратор

Опубликовал mixa_gr wer (mixa_gr) в раздел Программирование - Практика программирования

Эта методика кому-то покажется очевидной, кому-то спорной и даже неправильной, но если Вы также ленивы как я, тогда в самый раз. :)

Принцип прост. Если не хочешь перезапускать конфигуратор помести все свои модули во внешней обработке. Добавь в конфигурацию сразу подписки на все события и пропиши ссылки на процедуры во внешней обработке. Лучше всего создать глобальную переменную, к которой потом будешь обращаться для вызова разных процедур и функций. Плюсы такого подхода очевидны. Минусы: это не работает на стороне сервера.

Выкладываю все как есть на рабочей базе.

Также выкладываю обработки печати внешних форм и заполнения табличных частей. В типовых конфигурациях их необходимо просто зарегистрировать для нужных документов.

Еще выкладываю собственно внешний модуль.  В типовой конфигурации работать он не будет, но если повезет - найдете там что-нибудь для себя полезное. Размер модуля более 35000 строк. В нем есть около 40 различных печатных форм (типовых и не очень), куча обработок заполнения ТЧ и модулей проведения.  Типовая конфигурация для которой он написан - УТ 10.3 объединенная с Инталев Корпоративные финансы.

 


Процедура ОбновитьВнешнююОбработку() экспорт

   
#Если Клиент тогда

       
Попытка

           
ИмяФайла=СокрЛП(Константы.КаталогДополнительнойИнформации.Получить())+"МБИПКлиентБП16.epf";

        Исключение

           
ИмяФайла "\\server1\ВнешниеМодули1С\МБИПКлиентБП16.epf";

        КонецПопытки;

       
Файл=новый файл(ИмяФайла);

        Если
Файл.Существует() тогда

           
ДатаФайла=Файл.ПолучитьВремяИзменения();

            Если
ДатаОбновленияМБКлиент = неопределено или ДатаОбновленияМБКлиент<ДатаФайла тогда

                Попытка

                   
МБКлиент = ВнешниеОбработки.Создать("d:\ВнешниеМодули1С\МБИПКлиентБП16.epf");

                Исключение

                   
МБКлиент = ВнешниеОбработки.Создать(ИмяФайла);

                Конецпопытки;

               
ДатаОбновленияМБКлиент=ДатаФайла;

            КонецЕсли;

        Иначе

           
Сообщить("Файл "+Файл.Имя+" не существует");

        КонецЕсли;

   
#КонецЕсли

Конецпроцедуры



Процедура
ПередЗаписьюДокументов(Док, Отказ,РежимЗаписи, РежимПроведения) Экспорт

   
#Если Клиент тогда

       
ОбновитьВнешнююОбработку();

       
МБКлиент.ПередЗаписьюДокументов(Док, Отказ,РежимЗаписи, РежимПроведения);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ПередЗаписьюДокументов(Док, Отказ,РежимЗаписи, РежимПроведения);

   
#КонецЕсли

КонецПроцедуры



Процедура
ПриЗаписиДокументов(Док,отказ) Экспорт

   
#Если Клиент тогда

       
ОбновитьВнешнююОбработку();

       
МБКлиент.ПриЗаписиДокументов(Док,Отказ);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ПриЗаписиДокументов(Док,Отказ);

   
#КонецЕсли

КонецПроцедуры



Процедура
ОбработкаПроведения(Док, Отказ, РежимПроведения) Экспорт

   
#Если Клиент тогда

       
ОбновитьВнешнююОбработку();

       
МБКлиент.ОбработкаПроведения(Док, Отказ);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ОбработкаПроведения(Док, Отказ);

   
#КонецЕсли

КонецПроцедуры



Процедура
ОбработкаУдаленияПроведения(Док, Отказ) Экспорт

   
#Если Клиент тогда

       
ОбновитьВнешнююОбработку();

       
МБКлиент.ОбработкаУдаленияПроведения(Док, Отказ);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ОбработкаУдаленияПроведения(Док, Отказ);

   
#КонецЕсли

КонецПроцедуры



Процедура
ПередЗаписьюСправочников(Док, Отказ) Экспорт

   
#Если Клиент тогда

       
ОбновитьВнешнююОбработку();

       
МБКлиент.ПередЗаписьюСправочников(Док, Отказ);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ПередЗаписьюСправочников(Док, Отказ);

   
#КонецЕсли

КонецПроцедуры



Процедура
ПриЗаписиСправочников(Док, Отказ) Экспорт

   
#Если Клиент тогда

       
ОбновитьВнешнююОбработку();

       
МБКлиент.ПриЗаписиСправочников(Док, Отказ);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ПриЗаписиСправочников(Док, Отказ);

   
#КонецЕсли

КонецПроцедуры



Процедура
ПередЗаписьюРегистров(рег, Отказ, Замещение) Экспорт

   
#Если Клиент тогда

       
ОбновитьВнешнююОбработку();

       
МБКлиент.ПередЗаписьюРегистров(рег, Отказ, Замещение);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ПередЗаписьюРегистров(рег, Отказ, Замещение);

   
#КонецЕсли

КонецПроцедуры



Процедура
ОбработкаЗаполнения(Источник, Основание) Экспорт

   
#Если Клиент тогда

       
ОбновитьВнешнююОбработку();

       
МБКлиент.ОбработкаЗаполнения(ИсточникОснование);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ОбработкаЗаполнения(ИсточникОснование);

   
#КонецЕсли

КонецПроцедуры



Процедура
ПриУстановкеНовогоНомера(Док, СтандартнаяОбработка, Префикс) Экспорт

   
#Если Клиент тогда

       
ОбновитьВнешнююОбработку();

       
МБКлиент.ПриУстановкеНовогоНомера(Док, СтандартнаяОбработка, Префикс);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ПриУстановкеНовогоНомера(Док, СтандартнаяОбработка, Префикс);

   
#КонецЕсли

КонецПроцедуры



Процедура
ПередЗаписьюПВХ(Источник, Отказ) Экспорт

   
#Если Клиент тогда

       
ОбновитьВнешнююОбработку();

       
МБКлиент.ПередЗаписьюПВХ(Источник, Отказ);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ПередЗаписьюПВХ(Источник, Отказ);

   
#КонецЕсли

КонецПроцедуры



Процедура
ПриКопированииСправочника(Источник, ОбъектКопирования) Экспорт

   
#Если Клиент тогда

       
ОбновитьВнешнююОбработку();

       
МБКлиент.ПриКопированииСправочника(Источник, ОбъектКопирования);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ПриКопированииСправочника(Источник, ОбъектКопирования);

   
#КонецЕсли

КонецПроцедуры



Процедура
ПриОткрытииФормОбъектовОтИнталев(Форма) экспорт

   
#Если Клиент тогда

       
МБ.ОбновитьВнешнююОбработку();

       
МБКлиент.ПриОткрытииФормОбъектовОтИнталев(Форма);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ПриОткрытииФормОбъектовОтИнталев(Форма);

   
#КонецЕсли

Конецпроцедуры



Процедура
ПриЗаписиРегистров(Рег, Отказ, Замещение) Экспорт

   
#Если Клиент тогда

       
МБ.ОбновитьВнешнююОбработку();

       
МБКлиент.ПриЗаписиРегистров(Рег, Отказ, Замещение);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ПриЗаписиРегистров(Рег, Отказ, Замещение);

   
#КонецЕсли

КонецПроцедуры



Процедура
ПередУдалениемДокументов(Источник, Отказ) Экспорт

   
#Если Клиент тогда

       
МБ.ОбновитьВнешнююОбработку();

       
МБКлиент.ПередУдалениемСправочников(Источник,Отказ);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ПередУдалениемСправочников(Источник,Отказ);

   
#КонецЕсли

КонецПроцедуры



Процедура
ПередУдалениемСправочников(Источник, Отказ) Экспорт

   
#Если Клиент тогда

       
МБ.ОбновитьВнешнююОбработку();

       
МБКлиент.ПередУдалениемСправочников(Источник,Отказ);

   
#ИначеЕсли Сервер тогда

       
МБСервер.ПередУдалениемСправочников(Источник,Отказ);

   
#КонецЕсли

КонецПроцедуры



 

 

 

Скачать файлы

Наименование Файл Версия Размер
Внешний модуль 19
.epf 529,94Kb
07.10.13
19
.epf 529,94Kb Скачать
ЗаполнениеТЧ 8
.epf 6,84Kb
07.10.13
8
.epf 6,84Kb Скачать
Печать внешних форм 8
.epf 6,82Kb
07.10.13
8
.epf 6,82Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. afk afk (afk) 04.10.11 14:25
Была идея так устроить свой общий модуль, из-за чего отказался:
1) вопросы по быстродействию
2) печатные формы, обработки заполнения ТЧ и так нормально через внешние печатные формы реализуются
3) все задачи все равно не решаются - поведение форм, модули проведения полностью вывести не удастся
2. mixa_gr wer (mixa_gr) 04.10.11 15:04
отвечаю по пунктам
1. самое долгое это чтение файла с диска. т.е. если идет групповая обработка, то намучаешься читать каждый раз. для этого есть глобальная переменная ДатаОбновленияВнешнейОбработки сравниваешь с датой файла и читаешь, если нужно. проблемы с быстродействием снимаются. это реализовано в процедуре ОбновитьВнешнююОбработку()
2. Стандартные печ. формы и обработки заполнения нужно регистрировать в базе после любого изменения. Это долго. если использовать мой подход - этого не требуется.
3. не совсем понял третий вопрос. Не встречал ситуаций когда нельзя полностью вынести процедуру проведения в подписки на события. Можешь привести пример? Делал также полное или частичное удаление и замену типовых движений документов. Это чтобы не корявить типовую конфу для быстрого последующего обновления.

Также можно во внешнем файле сделать любые формы, служебные обработки, макеты. Вот только СКД не пробовал еще туда поместить.
3. Maxim Kolkin (the1) 04.10.11 16:25
Способ годный, еще в 7-ке его юзал (и юзаю). Но в 8-ке делать лень =)
4. afk afk (afk) 04.10.11 17:39
(2)
2. не нужно - сами обновляются, если при создании использовался правильный шаблон
3. надо пробовать
5. Александр Зубцов (iov) 05.10.11 15:47
была затея - отказался - одна из причин доступность модуля на чтение (подобный подход не оправдался тем что один из менеджеров оказался программистом 1С и очень быстро нашел способ делать то на что не нужно). Вторая проблема - быстренько написал - забыл закрыть кавычки или еще какая глупость - тут же гневные звонки- "все сломалось".
Подобное решение имеет место быть при активной разработке - а потом возвращаем на свои места.
6. mixa_gr wer (mixa_gr) 05.10.11 16:01
Согласен с тем, что неплохо бы потом отработанные участки кода перенести в конфигурацию.
А чтобы хоть как-то попытаться обезопасить себя от юзеров нужно дать им доступ только на чтение для этой обработки. От программиста 1с все равно не защитишься :).
А еще можно попробовать запустить 1cv8.exe от имени определенного пользователя и только ему дать дотуп на чтение обработки. Признаюсь, сам не пробовал, но мыслишки были. Если кто делал - подскажите как. Есть электронный каталог фоток. Одинаковый для четырех баз. Хочется хранить его на диске, а не в четырех базах сразу, но чтобы доступ можно было получить только через 1с, т.е. нельзя было скопировать все сразу.
7. Дмитрий Шерстобитов (DitriX) 05.10.11 17:32
(6) по поводу фоток - есть куча вариантов, все зависит от квалификации пользователей. Можно например сделать диск Е, который будет скрыт в системе, и туда залить фотки, но если при этом набрать путь вручную, то диск откроется, но это делать 5 минут.

Вобщем много ньюансов. Можно политикой настроить "только чтение" и т.д.
8. mixa_gr wer (mixa_gr) 05.10.11 17:47
Юзеры умнее, чем мы думаем. Нужна защита посерьезнее.
9. denisk (denisk37) 07.10.11 08:20
(6) mixa_gr, по фоткам мысль стандартная: в терминальную сессию и терминал защищать от выноса инфы...
10. mixa_gr wer (mixa_gr) 07.10.11 09:35
Можно и так, только лицензии на терминальные подключения надо покупать. У меняь тут все очень правильно :)
11. Роман Зиборов (RomanRomans) 07.10.11 09:53
Масса нюансов упрощающих разработку в одном флаконе..
С подписками на событие здорово придумал. Спасибо за идею
12. Олег Шалимов (CaSH_2004) 08.10.11 17:07
Где-то я подобное использовал таким образом: флажок (или версия) в конфигураторе или файле, и если например стоит флажок то берем из файла (или сравниваем версии - это дольше), иначе из конфигуратора. Т.е. после тестирования заливал в базу и снимал флаг и к файлу больше не было обращений
13. alexanderal (alexanderal) 10.10.11 12:55
Типа 1С++ в 77 баловался одно время
15. Наталья Колосницына (natnat) 17.10.11 08:50
16. Стас Веселов (StasssiK) 18.10.11 16:37
Спасибо, давно надоело перезапускать его.
17. Юлия Петрова (petrovaUL) 21.10.11 14:50
Попробую, потом отпишу. На 1С 77 делали.