IE2017

Заполнялка формы РСВ-1 в Документы ПУ (на основе prb-файла из 1С-ЗиК)

Обмен - Перенос данных из 1С7.7 в 1C8.X

Имеется: ЗиК + Документы ПУ.
Хочется: РСВ-1 без напряга.
Надоело заполнять РСВ-1 в Документы ПУ вручную? Выгрузи данные из ЗиКа и позволь программе ввести их за тебя.

Делал для себя, но может тоже кому-нибудь пригодится.

Имеется: 1С-ЗиК, Документы ПУ 5, обработка разблокирующая выгрузку РСВ-1 из ЗиК в файл .prb.

Если АДВ-6-2 в таком случае получить достаточно просто, то с РСВ все несколько сложнее. Можно загружать РСВ в 1С-Бух. а от туда уже получать .xml. Но что делать если бухгалтерии нет? Правильно - набивать форму РСВ-1 в Документах ПУ вручную. Но это ведь утомительно. Поэтому и была создана данная "заполняшка". Натравливаем ее на файл выгруженный из ЗиКа, открываем форму РСВ в Документах ПУ, жмем старт и вуаля - форма заполнена.

P.S.> ссылку на обработку для разблокировки выгрузки РСВ из ЗиК не нашел, но она была где-то здесь. напомните и допишем ее тут, чтобы не искать :)

Скачать файлы

Наименование Файл Версия Размер
Заполняшка
.rar 177,47Kb
09.07.13
67
.rar 177,47Kb 67 Скачать

См. также

Комментарии
1. Александр Лыткин (TrinitronOTV) 05.10.11 15:07 Сейчас в теме
2. Victor Nespyatin (victuan) 1538 05.10.11 15:23 Сейчас в теме
И как сие работает?
Механику можно в описании опубликовать?
3. Сергей Белянин (Ku3mi41) 18 05.10.11 17:25 Сейчас в теме
Натравливаем ее на файл выгруженный из ЗиКа, открываем форму РСВ в Документах ПУ, жмем старт и вуаля - форма заполнена.

Открываем ЗиК. Выгружаем РСВ-1 в файл .prb. Запускаем Документы ПУ. В разделе "Расчет взносов" жмем "Добавить". Открываем Раздел 2. Запускаем "Заполняшку". Указываем ей ранее выгруженный файл .prb. Возвращаемся в Документы ПУ и жмем F11. Форма заполнена. Открываем Раздел 1 и жмем F10. Форма заполнена. Дописываем имя руководителя, среднесписочную численность и прочие мелочи. Выгружаем РСВ-1 в .xml.

Да, не самый быстрый способ, но при использовании ЗиК+Документы ПУ (что-то мне подсказывает что такая схема не только в моей организации) позволяет прилично сэкономить время, не заполняя два эти раздела вручную, а ведь в них более 20 полей в каждом. Есть предложения? Если формировать сразу .xml то вводить придется больше чем Документах ПУ. Форму РСВ-1 в 1С-Бух не видел, а то можно и для нее подкорректировать.
4. Victor Nespyatin (victuan) 1538 05.10.11 17:28 Сейчас в теме
(3)Ты повторяешься, я это и раньше понимал.
Объясни механику своего метода. Эмулирует нажатие клавиш или чего еще?
5. Сергей Белянин (Ku3mi41) 18 05.10.11 21:18 Сейчас в теме
да, клавиши. ищем значения поля в prb, копируем в буфер, отправляем ctrl+v, потом tab.
по случаю решил ознакомиться с github'ом, собственно там все исходники кому интересно https://github.com/Ku3mi41/RSV.1C-to-PU собственно там же можно предложить свой вариант.
6. Vladimir (Boroda) 90 05.10.11 22:24 Сейчас в теме
Прикольная лялька, и, главное, очень своевременная: как раз к квартальным отчётам Думаю, что очень пригодится. Как я понял, заполняет РСВ по данным персучёта? Значит, не удет рассогласований... Это хорошо... Спасибо!
7. ninak (ninaK) 06.10.11 03:23 Сейчас в теме
А зачем это делать для ПУ? А нельзя было сделать для отчета РСВ-1 в Регламентированной отчетности?
8. Victor Nespyatin (victuan) 1538 06.10.11 04:53 Сейчас в теме
(7)В Рег.отчетности для РСВ-1 есть штатная загрузка из файлов *.prb (галочка "Заполнется по внешним данным"). Зачем делать что-то еще?
9. Victor Nespyatin (victuan) 1538 06.10.11 04:54 Сейчас в теме
(6)Ты полностью не понял суть обрабтки. Печально...
10. ninak (ninaK) 06.10.11 09:39 Сейчас в теме
(8)Я согласна, что в Рег.отчетности есть штатная загрузка, но... в ЗИК выгрузки-то РСВ-1 НЕТ.
11. Victor Nespyatin (victuan) 1538 06.10.11 10:59 Сейчас в теме
(10)У меня есть.

(0) За обработку плюс, однозначно!
12. Юрий В (UV2) 256 06.10.11 11:34 Сейчас в теме
(10) мадам, это легко самой исправить пошаманив в обработке РасчетСтраховыхВзносов в ЗиК -
в процедуре...
Процедура ОбработатьФормуПоГодуОтчета()

ГодПроверки = ДатаГод(ДатаРасширенияПеречняЛьготныхТарифовСтраховыхВзносов);

Если Год<ГодПроверки Тогда
Форма.ИспользоватьЗакладки(1);
Форма.Закладки.УдалитьВсе();
Форма.Закладки.ДобавитьЗначение("Постоянный,ПоСотрудникам","Состав сотрудников");
Форма.Закладки.ДобавитьЗначение("Постоянный,НастройкаВыводаЛистов","Разделы");
Форма.Закладки.ДобавитьЗначение("Постоянный,Перечисления","Задолженность по взносам");
Если ЕстьЛетчики=1 Тогда
Форма.Закладки.ДобавитьЗначение("Постоянный,ПеречисленияДоп","Перечисления доп. тариф");
КонецЕсли;
ЗаполнитьСписокРазделов();
Форма.ИспользоватьСлой("Постоянный,ПоСотрудникам",2);
Форма.ВыгрузкаВФайл.Видимость(1);
Иначе
// Форма.ИспользоватьЗакладки(0);
Форма.ИспользоватьЗакладки(1);
Форма.Закладки.УдалитьВсе();
Форма.Закладки.ДобавитьЗначение("Постоянный,ПоСотрудникам","Состав сотрудников");
Форма.Закладки.ДобавитьЗначение("Постоянный,НастройкаВыводаЛистов","Разделы");
// Форма.Закладки.ДобавитьЗначение("Постоянный,Перечисления","Задолженность по взносам");
ЗаполнитьСписокРазделов();
Форма.ИспользоватьСлой("Постоянный,ПоСотрудникам",2);
// Форма.ВыгрузкаВФайл.Видимость(0);
Форма.ВыгрузкаВФайл.Видимость(1);

КонецЕсли;

КонецПроцедуры //ОбработатьФормуПоГодуОтчета


как-то так было в последнем релизе зик...
13. Vladimir (Boroda) 90 06.10.11 19:44 Сейчас в теме
(9) Да, действительно, слишком уж бегло прочитал... Но ПУ не пользуюсь, поэтому больше импонирует предложение (12)
14. Любовь Жаткина (Полковник) 19.10.11 07:22 Сейчас в теме
Спасибо. Я ставлю плюс, т.к. гл.бух сказала, что будем вести отчетность в ПУ, никакой выгрузки из ЗиК. Аргументирует тем, что т.к. сопровождение 7.7 все хуже и хуже, неизвестно с чем и в какую отчетность мы можем остаться. 8-ку покупать не планируется. Может быть подскажите, как перетащить данные из формы СЗВ-6-1 ЗиК в ПУ?
15. Victor Nespyatin (victuan) 1538 19.10.11 07:29 Сейчас в теме
Полковник пишет:
как перетащить данные из формы СЗВ-6-1 ЗиК в ПУ?

Элементарно. Делаем выгрузку этих форм из ЗИК в xml-файлы (через встроенную обработку "Подготовка сведений для ПФР"). В ПУ-5 эти файлы импортируем через кнопку "Импорт".
16. marlen monro (marlen) 21.10.11 13:46 Сейчас в теме
спасибо, оказалась кстати, так как у буха рсв в документах пу в окно не влазеет, ползунков нет, разрешения тоже) а сдавать надо
17. Марина (ilyina) 28.10.11 15:01 Сейчас в теме
А 3 и 4 раздел нельзя также выгрузить в Документы ПУ? 2 раздел не выгружается с копейками. Это связано с Программой Документы ПУ или с Вашей программой?
18. Сергей Белянин (Ku3mi41) 18 28.10.11 15:24 Сейчас в теме
(17) ilyina, любой раздел можно добавить, нужно только прислать мне файл .prb содержащий сведения из этого раздела, и я добавлю его в программу. заливаем файл на http://www.zalil.ru, и сообщаем здесь ссылку.
программа вводит числа полученные из 1С в том виде как они из нее выгружены. в документах ПУ, в РСВ суммы без копеек.
19. Сергей Белянин (Ku3mi41) 18 28.10.11 15:29 Сейчас в теме
подумал тут на счет конфиденциальности... в .prb нет ни названия организации, ни руководителя, ни инн, только цифры из всех разделов. можно отправить ссылку и через личные сообщения)
20. irisha Климова (irisha) 06.11.11 07:55 Сейчас в теме
а можно прислать обработочку на почту? klimova1967@yandex.ru. Спасибо.
22. Kapitan911 Юрий (Kapitan911) 336 10.04.12 08:40 Сейчас в теме
Для 1 квартала 2012 года не нашли путей облегчения бухгалтерского труда?
Оставьте свое сообщение