gifts2017

Ошибка по инвалидам ЗиК 7.7 релиз 314

Опубликовал Евгений Нямцу (Nev1C) в раздел Программирование - Практика программирования

При вводе справки Справки об инвалидности сотруднику устанавливается статус Работник сельскохозяйственной организации - инвалид.

 

Перед изменениями просьба ВСЕГДА СОХРАНЯТЬ БАЗУ!!!!!!!!!!!!!!!!!!!

Необходимо произвести изменения в модуле документа СправкаМСЭК.

 

А именно в процедуре:

 

Процедура ОбработкаПроведения(ОбработчикСообщений)

Если Проверка(ОбработчикСообщений) = 0 Тогда

СтатусВозврата(0); Возврат

КонецЕсли;


Если глКатегорияПФР(,КонМесяца(Начало)) = Перечисление.КатегорияПлательщикаПФ.НР Тогда

УстановитьРеквизитСправочника(Сотрудник,"КатегорияПлательщикаПФР",Перечисление.КатегорияПлательщикаПФ.НРИВ, Начало);    

ПроверкаОкончанияПредыдущейИнвалидности(Перечисление.КатегорияПлательщикаПФ.НРИВ,ОбработчикСообщений);

Если ПустоеЗначение(Окончание) = 0 Тогда

УстановитьРеквизитСправочника(Сотрудник,"КатегорияПлательщикаПФР",Перечисление.КатегорияПлательщикаПФ.НР, Окончание+1);    

КонецЕсли;

Иначе

УстановитьРеквизитСправочника(Сотрудник,"КатегорияПлательщикаПФР",Перечисление.КатегорияПлательщикаПФ.НРИВ, Начало);    

ПроверкаОкончанияПредыдущейИнвалидности(Перечисление.КатегорияПлательщикаПФ.НРИВ,ОбработчикСообщений);

Если ПустоеЗначение(Окончание) = 0 Тогда

УстановитьРеквизитСправочника(Сотрудник,"КатегорияПлательщикаПФР",Перечисление.КатегорияПлательщикаПФ.НР, Окончание+1);    

КонецЕсли;

КонецЕсли; 

КонецПроцедуры

 

Если что - мдшник скачайте.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Обновить 314 релиз
.rar 5,18Mb
04.06.13
11
.rar 5,18Mb 11 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Александр Лыткин (TrinitronOTV) 07.10.11 05:51
2. Людмила Вальская (Вальская Людмила) 07.10.11 09:40
Там с инвалидами еще одна ошибка - за первый месяц база для начисления страховых взносов задваивается. В глобалке вместо строки 1460:

ДоходыВычетыНалогиСотрудников.УстановитьЗначение(НомерТекущейСтрокиСотрудника,2+НомерНачальнойКолонки,ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(НомерТекущейСтрокиСотрудника,2+НомерНачальнойКолонки)
+НачисленоВсего);

Стоит поставить

Если Сред(Инвалид,Сч,1)="0" Тогда

ДоходыВычетыНалогиСотрудников.УстановитьЗначение (НомерТекущейСтрокиСотрудника,2+НомерНачальнойКолонки,ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(НомерТекущейСтрокиСотрудника,2+НомерНачальнойКолонки)
+НачисленоВсего);

КонецЕсли;

т.к.именно здесь происходит ненужное добавление у инвалидов. Правда, это откровенная "заплата", что хотели сказать авторы, делая так, я так и не поняла.
Vital451; +1 Ответить
3. Евгений Нямцу (Nev1C) 07.10.11 12:47
(1) TrinitronOTV,Всегда рад помочь.
4. Александр Лыткин (TrinitronOTV) 07.10.11 19:38
Вальская Людмила пишет:

Там с инвалидами еще одна ошибка - за первый месяц база для начисления страховых взносов задваивается. В глобалке вместо строки 1460:

ДоходыВычетыНалогиСотрудников.УстановитьЗначение(НомерТекущейСтрокиСотрудника,2+НомерНачальнойКолонки,ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(НомерТекущейСтрокиСотрудника,2+НомерНачальнойКолонки)
+НачисленоВсего);

Стоит поставить

Если Сред(Инвалид,Сч,1)="0" Тогда

ДоходыВычетыНалогиСотрудников.УстановитьЗначение (НомерТекущейСтрокиСотрудника,2+НомерНачальнойКолонки,ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(НомерТекущейСтрокиСотрудника,2+НомерНачальнойКолонки)
+НачисленоВсего);

КонецЕсли;

т.к.именно здесь происходит ненужное добавление у инвалидов. Правда, это откровенная "заплата", что хотели сказать авторы, делая так, я так и не поняла.

и вам тоже спасибо за это сообщение
5. Vladimir (Boroda) 09.10.11 19:21
Спасибо всем за сообщения об ошибках! Лучше заренее о них узнать, а не ждать, когда они врасплох застанут, да ещё в самое неподходящее время...
6. Александр Лагунов (kit) 12.10.11 17:59
Да, сегодня тоже наткнулся на этот косяк. Сразу подумал, что кто-то уже её обнаружил. Спасибо автору и сайту за то, что можно поделиться информацией об ошибках и быстро найти решение.
7. Александр Лагунов (kit) 12.10.11 18:54
Ещё одно решение этой же проблемы, по-моему, более универсальное. Меняем только одну строчку в этой же процедуре.

Если глКатегорияПФР(,КонМесяца(Начало)) = Перечисление.КатегорииЗастрахованныхЛицПФР.НР Тогда

вместо

Если глКатегорияПФР(,КонМесяца(Начало)) = Перечисление.КатегорияПлательщикаПФ.НР Тогда
8. Любовь Жаткина (Полковник) 13.10.11 04:01
Огромное спасибо! С инвалидами всегда какие-нибудь да проблемы! Поэтому перед отчетностью, всегда приходиться тестировать.
9. Евгений Нямцу (Nev1C) 13.10.11 11:35
10. Евгений Нямцу (Nev1C) 13.10.11 11:35
(8) Полковник, всегда пожалуйста.
11. Viktor (kurvik) 13.10.11 15:04
Спасибо что помогли избавиться от хлопот
12. Евгений Нямцу (Nev1C) 13.10.11 15:11
(11) kurvik,А рад что моя публикация помогла вам.
13. Кирилл Кирилл (kivase) 13.10.11 22:50
Спасибо, как надоели эти ошибки(((((
14. Алексей (АлексейН) 14.10.11 10:33
Ну как всегда опять ошибки,
ОГРОМНОЕ СПАСИБО
15. Евгений Нямцу (Nev1C) 14.10.11 11:15
(13) kivase, Пожалуйста.Удачи при сдаче отчетности.
16. Евгений Нямцу (Nev1C) 14.10.11 11:16
(14) АлексейН, Пожалуйста.Удачи при сдаче отчетности.
17. Геннадий Соколов (GSokolov) 15.10.11 10:59
У автора темы альтернативное условие полностью повторяет основное, что вообще дезавуирует необходимость условия.
Более правильным представляется решение, предложенное в (7), но только после 01.01.2010, до этой даты нужно оставлять старое условие (вдруг придётся вводить или перепроводить МСЭК с датой до 2010 года). Поэтому следует проверять оба условия:
Если (глКатегорияПФР(,КонМесяца(Начало)) = Перечисление.КатегорииЗастрахованныхЛицПФР.НР) //после 01.01.2010 г.
или (глКатегорияПФР(,КонМесяца(Начало)) = Перечисление.КатегорияПлательщикаПФ.НР) Тогда //для ЕСН ...
18. Евгений Нямцу (Nev1C) 15.10.11 21:46
GSokolov пишет:

У автора темы альтернативное условие полностью повторяет основное, что вообще дезавуирует необходимость условия.

Более правильным представляется решение, предложенное в (7), но только после 01.01.2010, до этой даты нужно оставлять старое условие (вдруг придётся вводить или перепроводить МСЭК с датой до 2010 года). Поэтому следует проверять оба условия:

Если (глКатегорияПФР(,КонМесяца(Начало)) = Перечисление.КатегорииЗастрахованныхЛицПФР.НР) //после 01.01.2010 г.

или (глКатегорияПФР(,КонМесяца(Начало)) = Перечисление.КатегорияПлательщикаПФ.НР) Тогда //для ЕСН ...

Я не претендую на универсальность предложенного мною решения. Я своей публикацией только указал где возникает ошибка и мой вариант ее решения.Вам и всем кто предлагает боле точные исправления данной ошибки выражаю только благодарность.
19. Ирина (irina_ph) 18.10.11 08:33
20. Евгений Нямцу (Nev1C) 18.10.11 12:56
21. Ирина Нечаева (Arin) 26.10.11 03:39
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа