gifts2017

Отчет "Расчетные лиски организаций" с интервалами сумм, общей суммой, количеством листов и формированием платежной ведомости.

Опубликовал Петр Суренков (lord_soth) в раздел Отчеты - Бухгалтерские

Модификация отчета "Расчетные листки организаций". Позволяет формировать отчет в заданном интервале сумм (можно задавать интервал, как "суммы на руки", т.е. суммы за минусом удержаний и выплат, так и просто "начисленной суммы"). Также отчет показывает итоговую сумму всех расчетных листов, которые попали в отчет, и их количество. Присутствует возможность сформировать платежную ведомость.

Модификация отчета "Расчетные листки организаций". Позволяет формировать отчет в заданном интервале сумм (можно задавать интервал, как "суммы на руки", т.е. суммы за минусом удержаний и выплат, так и просто "начисленной суммы"). Также отчет показывает итоговую сумму всех расчетных листов, которые попали в отчет, и их количество. Присутствует возможность сформировать платежную ведомость.

Довавляем отчет во внешние отчеты, теперь необходимо устанавливить настройки отчета. Заходим в настройки вариантов отчета -> Панель пользователя.

 1. Видимость стандартных страниц - устанавливаем галки на "Период", "Параметры" и "Отбор", остальные галки снимаем.

 2. Период -   устанавливаем галки на "Предыдущий", "Текущий", остальные снимаем.

 3. Периодичность - "Год", "Полугодие", "Квартал", "Месяц".

 4. На вкладку "Быстрые отборы" добавляем отбор: "Поле" - Организация, "Вид отбора" - Значение", "Вид сравнения" - Равно, "Расположение" - горизонтальная панель, "Представление" - Организация.

 5. На вкладке "Параметры", заполним параметр "Вид расчетного лиска": "Выводить на" - Правая панель, "Отображать как" - Переключатель.

Все, нажимаем "ОК". Теперь добавим отборы.

На правой панели в разделе "Отбор" добавим отборы   (правой кнопкой мыши -> новый элемент) "Подразделение организации",  "Сотрудник", для отбора по фактической суммы "на руки", выбираем "Выплата на руки", для отбора по начисленной суммме, выбираем "Всего начислено". Для того, чтобы не выводились расчетные листки с пустыми суммами, можно установить вид сравнения "Больше или равно" 0.1.

Для формирования платежной ведомости установим галку "Формировать платежную ведомость" и нажмем кнопку "Сформировать".

Вот и все, если будут вопросы, спрашивайте.

Скачать файлы

Наименование Файл Версия Размер
Расчетные листки организаций с интервалом сумм.erf 119
.erf 125,98Kb
09.07.13
119
.erf 125,98Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Vladimir (Boroda) 11.10.11 22:20
Ну, судя по описанию - "крутые" расчётные листочки! Обязательно надо посмотреть, погонять их на "профпригодность". Спасибо за интересняй отчёт!
2. Петр Суренков (lord_soth) 11.10.11 22:44
3. Natalia Mankina (NMankina) 03.11.11 16:26
А у меня почему-то не выводится ФИО?
4. Петр Суренков (lord_soth) 03.11.11 19:16
А да, при выборе настойки "Кратко", выводится только его табельный номер, это сделано с целью, уменьшения персонификации сотрудника, при выдаче ему расчетного листка. Для вывода ФИО, поставьте любую из оставшихся настроек.
5. Ольга Доги (olgadogi) 11.11.11 12:35
Написано красиво, а в работе нет - не дает выбора и формирования
6. Петр Суренков (lord_soth) 11.11.11 13:25
olgadogi пишет:
Написано красиво, а в работе нет - не дает выбора и формирования


Пример Ваших настроек отчета.

И нашел у себя ошибочку - забыл убрать отбор по своей тестовой организации. Идем в модуль отчета, находим сточку 676 (
Запрос.УстановитьПараметр("Орг", Справочники.Организации.НайтиПоНаименованию("0/999 Управленческая организация"));
), заменяем ее на

Для каждого ЭлементОтбора из Настройки.Отбор.Элементы Цикл
    Имя = Строка(ЭлементОтбора.ЛевоеЗначение);
    Если Имя = "Организация" Тогда
	ВашаОрганизация = ЭлементОтбора.ПравоеЗначение;
    КонецЕсли;
КонецЦикла;	
Запрос.УстановитьПараметр("Орг", ВашаОрганизация);
...Показать Скрыть
7. Алексей (lisav) 31.05.12 08:51
После такого исправления заработало
Для каждого ЭлементОтбора Из Настройки.Отбор.Элементы Цикл
			  Если ЭлементОтбора.Представление = "Организация" Тогда
			     ВашаОрганизация = ЭлементОтбора.ПравоеЗначение;
			  КонецЕсли;
КонецЦикла;
Запрос.УстановитьПараметр("Орг", ВашаОрганизация);
...Показать Скрыть

Спасибо за отчет.
9. Петр Суренков (lord_soth) 23.11.12 09:41
10. Егор Гусев (EgorGGG) 23.11.12 10:06
Спасибо, но видимо не подойдет для ЗиК БУ.

Выкидывает ошибку.
"{ВнешнийОтчет.РасчетныеЛисткиОрганизацийНовые.МодульОбъекта(4192)}: Ошибка при установке значения атрибута контекста (Текст)
ПостроительОтчетов.Текст = ТекстПостроителя;
по причине:
{(393, 54)}: Неверные параметры "Перечисление.ХарактерВыплатыЗарплаты.Дивиденды"
КОГДА Взаиморасчеты.ХарактерВыплаты = ЗНАЧЕНИЕ(<<?>>Перечисление.ХарактерВыплатыЗарплаты.Дивиденды)
"
11. Петр Суренков (lord_soth) 23.11.12 10:30
Попробуйте открыть модуль отчета в конфигураторе и закомментировать строки 3213, 3214, 3283 и 3284.
12. Den (Dvornik) 19.04.16 12:48
Отчёт на любую конфигурацию? На УПП подойдёт?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа