gifts2017

Печать трудовых договоров и допсоглашений сотрудников из MS Word

Опубликовал Александр Инев (PipaOld) в раздел Печать - Печатные формы документов

Данная обработка предназначена для печати трудовых договоров и допсоглашений сотрудников в произвольной форме из шаблонов MS Word.

При выборе сотрудника автоматически подтягиваются документ прием на работу и кадровое перемещение, если оно есть. Возможна работа сразу с несколькими шаблонами на прием и допсоглашениями на перемещения.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Печать трудовых договоров и допсоглашений в MS Word
.rar 30,27Kb
13.10.11
172
.rar 30,27Kb 172 Скачать
Примерный шаблон трудового договора
.dot 43,00Kb
11.10.11
40
.dot 43,00Kb 40 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

0. Александр Инев (PipaOld) 11.10.11 22:31
Данная обработка предназначена для печати трудовых договоров и допсоглашений сотрудников в произвольной форме из шаблонов MS Word.

Перейти к публикации

1. Vladimir (Boroda) 11.10.11 22:31
А обработка сама по себе или встраивается в справочник или документ? И берёт она последний по дате автоматически или надо самому выбирать?
2. Александр Инев (PipaOld) 12.10.11 08:49
Обработка сама по себе. Добавляется в дополнительные обработки. При выборе сотрудника добавляет последний документ Кадровое перемещение, но можно и самому выбрать. В публикации присутствуют файлы шаблонов с готовыми полями для заполнения. Текст выделенный в шаблоне красным цветом можно заменить своим текстом, главное чтобы поля для автоматического заполнения вписывались в текст вашего договора и допсоглашения. Эти шаблоны помещаете в любую папку, выбираете их как показано на скриншоте. Чтобы каждый раз не выбирать путь к шаблонам их можно сохранить. кнопка сохранения внизу. После нажатия на кнопку Выполнить создается документ word для дальнейшего редактирования и сохранения, т. к. кадровики любят хранить их в этом формате.
3. Fomix (fomix) 12.10.11 10:37
Скачивать не стал, т.к. пользуюсь собственной обработкой, подключаемой как внешняя печатная форма в Приказу о приеме и документу Перемещение. Ваша обработка многофункциональна в плане печатных форм, однозначно "+".
4. Александр Инев (PipaOld) 12.10.11 10:46
Благодарю за оценку. У меня первоначально также были внешние печатные формы, но в связи с ростом вариантов договоров и допсоглашений пришлось собрать все в обработку. У каждого своя папка с шаблонами.
5. PVS73 12.10.11 17:24
ошибку выдаёт.
{Форма.Форма.Форма(118)}: Значение не является значением объектного типа (Ссылка)
ЗапросТарифнаяСтавка.УстановитьПараметр("ЗначСправочник", ТарифныйРазряд1.Ссылка);
6. Александр Федорович (Фред) 12.10.11 18:09
А с Бухгалтерией (базовой) работает? Никто не пробовал?
7. Программулькин (Программулькин) 13.10.11 05:51
я что-то не понял, скачал архив, там 3 шаблона и ридмик, а где сама обработка? у меня по другому сделано, сложнее, доп справочником,функциональность в разы выше, но не суть, зато у тебя без вмешательства в конфу. На сколько я понял, чтобы распечатать, нужно сначала обработку открыть? По-моему несколько не удобно, попробуй привязать обработку к форме сотрудники,что бы сразу открывалась обработка и подтягивался нужный сотрудник и .т.д. )
8. Denis Elmanov (jack_nsk) 13.10.11 06:11
(7) Программулькин, тогда уж не к сотруднику внешнюю печатную форму, а к кадровому документу :)
у нас так реализовано, шаблон один, но в коде обрабатываются разные варианты изменений условий ТД. Вобщем - с "глубоким" учетом специфики и собственно не так универсально как у автора этой обработки :)
9. Андрей Григорьев (Borisych) 14.10.11 23:57
Я не так делал - привязка печатной формы к документу (прием на работу или перемещению) и сотруднику - из документа печатается для каждой строки свой новый док в MS Word. Заложена возможность редактирования шаблона пользователем - открывает нужный элемент справочника (в ЗУП) "дополнительная информация", правит что надо, он будет использоваться при печати, но пользователи этим функционалом не пользуются :)
10. Anya Yakushina (Little-ann) 02.11.11 22:31
Однозначно плюс. Много их перепробовала, эта универсальнее многих.
11. Кирилл Ермошин (lafaaadka) 08.12.11 11:05
{Форма.Форма.Форма(121)}: Ошибка при вызове метода контекста (Выполнить)
Результат = ЗапросТарифнаяСтавка.Выполнить();
по причине:

по причине:
{(7, 60)}: Не задано значение параметра "ЗначСправочник"
РазмерТарифныхСтавокСрезПоследних.ТарифныйРазряд.Ссылка = <<?>>&ЗначСправочник
12. Кирилл Ермошин (lafaaadka) 08.12.11 11:06
ругается на тарифную ставку? Какк исправить?
13. Александр Инев (PipaOld) 08.12.11 11:47
Добрый день, lafaaadka!
В вашей организации скорее всего используется оклад суммой, а не от тарифного разряда. Пожалуйста, в режиме Конфигуратора в модуле формы обработки в процедуру КнопкаВыполнитьНажатие(Кнопка) необходимо внести следующие изменения, заменить соответствующий кусок кода на указанный ниже. Надеюсь это поможет Вам. С уважением, PipaOld. P.S. Шаблоны .dot изменению не подлежат.

////////////////////////// Начало фрагмента
ДатаТрудовогоДоговора = Формат(ВыбСотрудник.ДатаДоговора,"ДЛФ=ДД");
НомерТрудовогоДоговора = СокрЛП(ВыбСотрудник.НомерДоговора);

ТребуетВводаТарифногоРазряда = 0; //Добавлено
ОкладСуммой = 0; //Добавлено

Если ТрудовойДоговор1=1 или ТрудовойДоговор1=2 Тогда

Для Каждого ТекСтрока из ВыбПрием.РаботникиОрганизации Цикл

Если ТекСтрока.Сотрудник.Ссылка = Сотрудник.Ссылка Тогда
ДолжностьВ = СокрЛП(ТекСтрока.Должность.Наименование);
ПодразделениеОрганизации = СокрЛП(ТекСтрока.ПодразделениеОрганизации.Наименование);

ДолжностьВ = ДолжностьВ+" в "+нРег(Сред(ПодразделениеОрганизации,1,1))+Сред(ТекСтрока.ПодразделениеОрганизации,2);
ИспытательныйСрок=ТекСтрока.ИспытательныйСрок;
Ставка = ТекСтрока.ЗанимаемыхСтавок;
КонецЕсли;

КонецЦикла;

Для Каждого ТекСтрока из ВыбПрием.ОсновныеНачисления Цикл

Если ТекСтрока.Сотрудник.Ссылка = Сотрудник.Ссылка Тогда

Если ТекСтрока.ВидРасчета = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОкладПоДням Тогда

ТарифныйРазряд1 = ТекСтрока.ТарифныйРазряд1;
Если ТекСтрока.ВидРасчета.ТребуетВводаТарифногоРазряда=Истина Тогда //Добавлено
ТребуетВводаТарифногоРазряда = 1; //Добавлено
Иначе //Добавлено
ОкладСуммой = ТекСтрока.Показатель1; //Добавлено
КонецЕсли; //Добавлено

КонецЕсли;

КонецЕсли;

КонецЦикла;

ДатаПриемаНаРаботу = Сотрудник.ДатаПриемаНаРаботу;

ИначеЕсли ТрудовойДоговор1=3 или ТрудовойДоговор1=4 Тогда

ДатаПриемаНаРаботу = Сотрудник.ДатаПриемаНаРаботу;

Если ЗначениеЗаполнено(КадровоеПеремещение1) Тогда

Для Каждого ТекСтрока из КадровоеПеремещение1.ОсновныеНачисления Цикл

Если ТекСтрока.Сотрудник.Ссылка = Сотрудник.Ссылка Тогда

Если ТекСтрока.ВидРасчета = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОкладПоДням Тогда
ТарифныйРазряд1 = ТекСтрока.ТарифныйРазряд1;
Если ТекСтрока.ВидРасчета.ТребуетВводаТарифногоРазряда=Истина Тогда //Добавлено
ТребуетВводаТарифногоРазряда = 1; //Добавлено
Иначе //Добавлено
ОкладСуммой = ТекСтрока.Показатель1; //Добавлено
КонецЕсли;
КонецЕсли;

КонецЕсли;

КонецЦикла;
Для Каждого ТекСтрока из КадровоеПеремещение1.РаботникиОрганизации Цикл

Если ТекСтрока.Сотрудник.Ссылка = Сотрудник.Ссылка Тогда
ДатаПриемаНаРаботу = ТекСтрока.ДатаНачала;
ДолжностьВ = СокрЛП(ТекСтрока.Должность.Наименование);
ПодразделениеОрганизации = СокрЛП(ТекСтрока.ПодразделениеОрганизации.Наименование);
ДолжностьВ = ДолжностьВ+" в "+нРег(Сред(ПодразделениеОрганизации,1,1))+Сред(ПодразделениеОрганизации,2);
Ставка = ТекСтрока.ЗанимаемыхСтавок;
КонецЕсли;

КонецЦикла;

Иначе

Предупреждение("Не выбран документ кадрового перемещения");
Возврат;

КонецЕсли;

КонецЕсли;


Если ТребуетВводаТарифногоРазряда = 1 Тогда //Добавлено
//Вытаскиваем тарифную ставку
///////////////////////////////////////////////////////
ЗапросТарифнаяСтавка = Новый Запрос;
ЗапросТарифнаяСтавка.Текст =
"ВЫБРАТЬ
| РазмерТарифныхСтавокСрезПоследних.ТарифныйРазряд.Ссылка,
| РазмерТарифныхСтавокСрезПоследних.Размер
|ИЗ
| РегистрСведений.РазмерТарифныхСтавок.СрезПоследних(&ДатаСреза) КАК РазмерТарифныхСтавокСрезПоследних
|ГДЕ
| РазмерТарифныхСтавокСрезПоследних.ТарифныйРазряд.Ссылка = &ЗначСправочник
|";

ЗапросТарифнаяСтавка.УстановитьПараметр("ЗначСправочник", ТарифныйРазряд1.Ссылка);
ЗапросТарифнаяСтавка.УстановитьПараметр("ДатаСреза", ДатаПриемаНаРаботу);

Результат = ЗапросТарифнаяСтавка.Выполнить();
Оклад=0;
Выборка = Результат.Выбрать();
Пока Выборка.Следующий() Цикл

Оклад = Выборка.Размер;
Прервать;

КонецЦикла;
Иначе //Добавлено
Оклад = ОкладСуммой; //Добавлено
КонецЕсли; //Добавлено

формаОклад = Оклад;
//////////////////////////////////// Окончание фрагмента
14. Кирилл Ермошин (lafaaadka) 08.12.11 12:44
Спасибо. Сейчас попробую
15. Кирилл Ермошин (lafaaadka) 08.12.11 14:05
Все заработало. Огромное СПАСИБО, только это видимо как то с помощью макросов сделано? Я не могу туда свой шаблон подставить?
16. Александр Инев (PipaOld) 08.12.11 14:15
Рад, что у вас все получилось. Свой шаблон подставить можно, главное чтобы в нем обязательно присутствовали поля формы в которые передаются значения типа оклад или адрес. Причем все поля из шаблона к обработке должны быть продублированы в вашем шаблоне. Доступ к полям формы шаблона получается через панель Word формы, кнопка затенение полей. После этого дважды щелкаем на выделенные серым цветом поля, копируем название поля и создаем в нужном месте такое же поле с этим же именем в своем шаблоне. Если поля будут перенесены не все, то обработка будет завершать обработку с ощибкой типа {Форма.Форма.Форма(339)}: Ошибка при вызове метода контекста (SetFormResult). Удачи в экспериментах!
lafaaadka; +1 Ответить
17. Кирилл Ермошин (lafaaadka) 08.12.11 15:02
Да спасибо уже разобрался. Только Он вставляет красным) Как отключить красный свет?
18. Александр Инев (PipaOld) 08.12.11 15:08
Выделяем текст. Меню формат пункт шрифт на закладке открывшейся формы выбираем цвет текста черный или на панели форматирование выбираем кнопку подчеркнутую красной или черной линией, т. е. в обоих случаях меняем цвет шрифта.После этого не забываем убрать затенение полей формы шаблона(17) lafaaadka,
19. Кирилл Ермошин (lafaaadka) 09.12.11 16:04
А еще вопрос, если кто знает вот в CRMовской версии УТ вместо внешних печатных форм можно напрямую подключить .doc кий файл. Я пытаюсь его подцепить а он ругается на

{Справочник.ВнешниеОбработки.Форма.ФормаЭлемента(222)}: Значение не является значением объектного типа (Метаданные)
Если ЗначениеВозврата.ВнешняяОбработка.Метаданные().Макеты.Найти("Параметры_Авторегистрации")<> Неопределено Тогда


пытаюсь там поменять значение <> на = но все равно ошибка та же.
20. Кирилл Ермошин (lafaaadka) 23.12.11 16:32
А можно как нибудь чтобы допсоглашения сохранялись с привязкой к физлицу? У физлица есть вкладка ФАЙЛЫ вот туда хочу сохранять допсоглашения с именами в формате №_от_ЧИСЛО и чтоб номера не повторялись, автоматически проставлялись
21. Наталья Константиновна (bnk72) 08.11.13 10:44
Спасибо. Пригодится. В 7.7 делала такую штуку для кадров, сейчас будет хоть не с нуля...
22. Татьяна Акконен (медея) 14.04.14 11:28
Скачала, запустила в ЗУП (2.5.79.3)Исправила, как написано в комментарии 13, у меня вышло очень много ошибок! Прошу Вас сделать договора оплата по окладу. Заранее спасибо!
23. МАРИЯ Мария (mariya.y) 20.03.15 15:53
ВЫДАЕТ ОШИБКУ :-(
{Форма.Форма.Форма(132)}: Метод объекта не обнаружен (СформироватьСуммуПрописью)
ОкладПропись = ОбщегоНазначения.СформироватьСуммуПрописью(Оклад, Константы.ВалютаРегламентированногоУчета.Получить());
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа