gifts2017

Включение использования итогов

Опубликовал Андрей Юс (andreysc) в раздел Обработки - Универсальные обработки

Данная обработка автоматически для всех регистров накопления и регистров бухгалтерии, у которых использование итогов отключено включает использование итогов и пересчитывает итоги. В УПП по умолчанию использование итогов во всех регистрах включено.

Данная обработка автоматически для всех регистров накопления и регистров бухгалтерии, у которых использование итогов отключено включает использование итогов и пересчитывает итоги. В УПП по умолчанию использование итогов во всех регистрах включено.

Скачать файлы

Наименование Файл Версия Размер
Включить использование итогов 281
.epf 9,61Kb
20.10.11
281
.epf 9,61Kb Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. Лидия Бровкина (Ange-Lika) 03.06.12 10:08
Сколько по времени работает эта обработка? Клиент-серверный вариант 1С:Предприятие 8.2, 64.
2. Александр Коновалов (mpei198) 12.06.12 11:27
у меня быстро работает спасибо
3. Николай Железнов (koliaff) 03.01.13 18:17
Все работает как надо. Только вот вопрос. У меня УРБД. Запустил эту обработку в центральной базе, затем сделал обмен с периферийной. Ошибка в периферийной не исчезла. Пришлось в периферийной тоже запускать её. Почему ? )
4. Сергей Иванов (psa247) 08.07.13 11:15
Процедура КнопкаВыполнитьНажатие(Кнопка)
Для Каждого Рег Из РегистрыНакопления Цикл
Если Рег.ПолучитьИспользованиеИтогов()=Ложь Тогда
Рег.УстановитьИспользованиеИтогов(Истина);
Состояние("Идет пересчет итогов регистра накопления " + Рег);
Рег.ПересчитатьИтоги();
Сообщить("Для регистра накопления " + Рег + " включено использование итогов");
КонецЕсли;
КонецЦикла;
Для Каждого Рег Из РегистрыБухгалтерии Цикл
Если Рег.ПолучитьИспользованиеИтогов()=Ложь Тогда
Рег.УстановитьИспользованиеИтогов(Истина);
Состояние("Идет пересчет итогов регистра бухгалтерии " + Рег);
Рег.ПересчитатьИтоги();
Сообщить("Для регистра бухгалтерии " + Рег + " включено использование итогов");
КонецЕсли;
КонецЦикла;
КонецПроцедуры
adva; Salaman; Yakud3a; +3 Ответить
5. Андрей Смирнов (Asmir) 16.01.14 18:38
Можно использовать внешнюю обработку конфигурации "Конвертация данных" ВыгрузкаЗагрузкаДанныхXML82.
На закладке "загрузка" включить итоги.
6. Максим Литвинов (maksa2005) 11.11.14 10:58
Вместо обработки использовал:
Для каждого знач1 из РегистрыНакопления Цикл
знач1 .УстановитьИспользованиеИтогов(Истина);
КонецЦикла

Но все равно спс))
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа