Включение использования итогов

Опубликовал Андрей Юс (andreysc) в раздел Обработки - Универсальные обработки

Данная обработка автоматически для всех регистров накопления и регистров бухгалтерии, у которых использование итогов отключено включает использование итогов и пересчитывает итоги. В УПП по умолчанию использование итогов во всех регистрах включено.

Данная обработка автоматически для всех регистров накопления и регистров бухгалтерии, у которых использование итогов отключено включает использование итогов и пересчитывает итоги. В УПП по умолчанию использование итогов во всех регистрах включено.

Скачать файлы

Наименование Файл Версия Размер
Включить использование итогов
.epf 9,61Kb
20.10.11
290
.epf 9,61Kb 290 Скачать

См. также

Комментарии
1. Лидия Бровкина (Ange-Lika) 03.06.12 10:08 Сейчас в теме
Сколько по времени работает эта обработка? Клиент-серверный вариант 1С:Предприятие 8.2, 64.
2. Александр Коновалов (mpei198) 12.06.12 11:27 Сейчас в теме
у меня быстро работает спасибо
3. Николай Железнов (koliaff) 137 03.01.13 18:17 Сейчас в теме
Все работает как надо. Только вот вопрос. У меня УРБД. Запустил эту обработку в центральной базе, затем сделал обмен с периферийной. Ошибка в периферийной не исчезла. Пришлось в периферийной тоже запускать её. Почему ? )
4. Сергей Иванов (psa247) 08.07.13 11:15 Сейчас в теме
Процедура КнопкаВыполнитьНажатие(Кнопка)
Для Каждого Рег Из РегистрыНакопления Цикл
Если Рег.ПолучитьИспользованиеИтогов()=Ложь Тогда
Рег.УстановитьИспользованиеИтогов(Истина);
Состояние("Идет пересчет итогов регистра накопления " + Рег);
Рег.ПересчитатьИтоги();
Сообщить("Для регистра накопления " + Рег + " включено использование итогов");
КонецЕсли;
КонецЦикла;
Для Каждого Рег Из РегистрыБухгалтерии Цикл
Если Рег.ПолучитьИспользованиеИтогов()=Ложь Тогда
Рег.УстановитьИспользованиеИтогов(Истина);
Состояние("Идет пересчет итогов регистра бухгалтерии " + Рег);
Рег.ПересчитатьИтоги();
Сообщить("Для регистра бухгалтерии " + Рег + " включено использование итогов");
КонецЕсли;
КонецЦикла;
КонецПроцедуры
adva; Salaman; Yakud3a; +3 Ответить
5. Андрей Смирнов (Asmir) 118 16.01.14 18:38 Сейчас в теме
Можно использовать внешнюю обработку конфигурации "Конвертация данных" ВыгрузкаЗагрузкаДанныхXML82.
На закладке "загрузка" включить итоги.
6. Максим Литвинов (maksa2005) 88 11.11.14 10:58 Сейчас в теме
Вместо обработки использовал:
Для каждого знач1 из РегистрыНакопления Цикл
знач1 .УстановитьИспользованиеИтогов(Истина);
КонецЦикла

Но все равно спс))
Оставьте свое сообщение