gifts2017

Как программисту быстро загрузить данные из Excel

Опубликовал Андрей Акулов (DrAku1a) в раздел Обмен - Загрузка и выгрузка в Excel

Встала как-то разовая задача - загрузить данные из Excel в базу...
Идея не новая, на ИС имеются уже готовые подобные разработки, но предлагается сделать самостоятельно. Пригодится в будущем.

Идея не новая, на ИС имеются уже готовые подобные разработки, например

но предлагается сделать то же самое самостоятельно. Пригодится в будущем.

 

Пример из жизни: Принесли листик с именами клиентов и суммами зарплат - нужно внести в базу.

Как быть?

1. Взять чужую готовую разработку (плюс: ничего разрабатывать не надо, можно отдать бухгалтеру на растерзание, минус: как правило, бухгалтер придет к Вам с "просьбой" показать как и что делать... возможно, придется шаманить с настройками - особенно если обмен не удастся).

2. Написать "простенькую" обработку загрузки из Excel через OLE (тут ключевое слово "простенькую"... Помимо наладки обмена, нужно вкратце знать как устроен Excel - и как к нему обращаться. Скорее всего - нужен хотя бы минимальный опыт написания макросов. Хотя примеров более чем достаточно).

3. Простое решение:

Создаем внешнюю обработку, туда вставим табличное поле. Включим показывать заголовки колонок и строк и разрешить редактирование. При работе - нужную таблицу копируем из  Excel в буфер обмена и вставляем в табличный документ. При этом форматирование теряется, но оно нам не особо надо.

Далее на ту же форму кидаем кнопку "Выполнить" (хотя вообще-то эта кнопка уже должна быть создана автоматически) и в процедуре-обработчике описываем цикл по строкам с чтением и выполнением нужных действий:

Процедура КнопкаВыполнитьНажатие(Кнопка)

    ТабДок = ЭлементыФормы.ПолеТабличногоДокумента1;

    НачальнаяСтрока = 2;
    КонечнаяСтрока = ЭлементыФормы.ТабДок.ВысотаТаблицы;

    Док = Документы.КорректировкаЗаписейРегистровНакопления.СоздатьДокумент();
    НовСтр = Док.ТаблицаРегистровНакопления.Добавить();
    НовСтр.Имя = Метаданные.РегистрыНакопления.ВзаиморасчетыСРаботникамиОрганизаций.Имя;
    НовСтр.Представление = Метаданные.РегистрыНакопления.ВзаиморасчетыСРаботникамиОрганизаций.Представление();

    Рег = Док.Движения.ВзаиморасчетыСРаботникамиОрганизаций;

    Для сч=НачальнаяСтрока по КонечнаяСтрока Цикл

        СуммаВзаиморасчетов = СокрЛП(ТабДок.Область(сч, 2).Текст);
        СуммаВзаиморасчетов = Число(СуммаВзаиморасчетов);

        ИмяФизЛица = СокрЛП(ТабДок.Область(сч, 1).Текст);
        Если ИмяФизЛица="" Тогда

            Продолжить;

        КонецЕсли;

        ФизЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(ИмяФизЛица);
        Если ФизЛицо.Пустая() Тогда

            Сообщить("Физ. лицо не найдено: "+ИмяФизЛица);
            Продолжить;

        КонецЕсли;

        НовЗапись = Рег.ДобавитьПриход(); 
        НовЗапись.Активность = истина;
        НовЗапись.ФизЛицо = ФизЛицо;
        НовЗапись.СуммаВзаиморасчетов = СуммаВзаиморасчетов;

    КонецЦикла;

    Док.ПолучитьФорму().Открыть();

КонецПроцедуры

В принципе, этого достаточно чтобы загрузить данные в документ и показать форму - остальные поля в форме можно заполнить вручную. Можно доработать: вынести на форму поля для заполнения значений при создании конкретного документа, настройку начальной и конечной строк и т.п. Тут как говорится - нет предела совершенству.

Плюсы: пишем все сами - не надо изучать чужой код или что-то настраивать, не требуется знание макросов и устройства Excel (как и сам Excel), не заморачиваемся с OLE-подключением.

Минусы: Универсальностью данное решение не обладает, но как вариант - сделать "по-быстрому" и "на один раз".

Итог: у меня рядом с обработкой "ЗагрузкаИзExcel.epf" со временем накопились обработки, которые делал по-быстрому, копируя ее и изменяя тело цикла "Для"...

 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Мурат Жананов (murat_) 26.10.11 08:40
А чем не устроила универсальная обработка с ИТС-диска "ЗагрузкаДанныхИзТабличногоДокумента" ?
Для разовых задач она самое то и писать ничего не нужно.
WanGoff; Eugeneer; Craig; +3 Ответить 3
2. Андрей Акулов (DrAku1a) 26.10.11 08:57
Устраивает, но порой проще и быстрее - написать самому.
3. dka80 ~ (dka80) 26.10.11 09:25
4. Антон Котов (Attest) 30.10.11 00:04
5. Айрат (Craig) 02.11.11 08:15
(1) Тоже поддерживаю. Обработка с диска ИТС ЗагрузкаДанныхИзТабличногоДокумента универсальна, там возможности куда больше чем в "простенькой" обработке написанной быстро на коленях.
6. Евгений Конищев (kea35) 02.11.11 17:53
Обработка имеет шанс на жизнь
7. MICK77 Владислав (MICK77) 02.11.11 17:56
Craig пишет:

(1) Тоже поддерживаю. Обработка с диска ИТС ЗагрузкаДанныхИзТабличногоДокумента универсальна, там возможности куда больше чем в "простенькой" обработке написанной быстро на коленях.

этой обработкой с диска можно загрузить только в 1 документ. а если надо их много?
Karmerruk; b-dm; annak2980; +3 Ответить
8. Игорь (vikorn) 03.11.11 13:11
9. motherf 03.11.11 15:01
Вообще-то боян, но некоторые не знают, что так действительно удобнее.
Не нужно вводить имя файла.
10. motherf 03.11.11 15:02
(1) ей еще надо научить пользоваться пользователей. А тут можно просто написать простенькую обработку, научить пользователя в нее копировать данные и все.
11. Мурат Жананов (murat_) 03.11.11 21:27
(10) Автор вообще-то ясно указал "разовая задача" для "программиста", про повседневную работу пользователей речь здесь не шла.
12. Andrusha (Andrusha1) 04.11.11 11:52
Прикольно, идея копировать в буфер не приходила в голову. Хотя все оригинальное, просто.
13. Олег Сиваков (westx) 07.11.11 00:15
Да, как-то не дошло до мозга о такой возможности, спасибо автору.
14. Alexey26 (Alexey26) 09.11.11 22:39
15. Юлия Петрова (petrovaUL) 14.11.11 08:28
16. Александр М (Fruit83) 19.11.11 00:10
Спасибо за статью, для меня это сейчас самое то!:)
murat_ и Craig разница между обработкой и публикацией все-таки есть. :)
17. Alexandr (maloi_a) 21.11.11 10:41
Замечание.
Поправьте в примере "КонечнаяСтрока = ЭлементыФормы.ТабДок . ВысотаТаблицы ;"
на "КонечнаяСтрока = ТабДок.ВысотаТаблицы;"
18. Андрей Акулов (DrAku1a) 21.11.11 10:55
(17) Хорошо. Хотя оба варианта работоспособны.
19. K Anna (annak2980) 21.11.11 13:14
Спасибо автору за интересную идею, описанную полностью в виде статьи
20. Тамара Горбачева (GTV) 23.11.11 08:42
А мне понравилось! Автор - молодец!
21. Александр М (Fruit83) 24.11.11 13:21
У меня проблема возникла. Сперва система ругалась на СуммаВзаиморасчетов = Число(СуммаВзаиморасчетов); , писала что не может преобразовать к типу число. Теперь просто значение не присваивается.
22. Андрей Акулов (DrAku1a) 24.11.11 18:20
(21) Используйте СуммаВзаиморасчетов = Число(СокрЛП(СуммаВзаиморасчетов));, кроме того нужно проверять что сумма взаиморасчетов - не пустая строка, а также, если вы перекидываете данные из отчетов 8-ки - то учтите, что по-умолчанию 8-ка вставляет разделитель (пробел) между триадами числа, например код А = Число(Строка(1000)); вызовет в 8-ке ошибку.

Функция ВЧисло(знач Текст)
  ДопустимыеЗнаки = "0123456789,-";
  Текст = СокрЛП(""+Текст);
  Ответ = "";
  Для сч = 1 по СтрДлина(Текст) Цикл
    Символ = Сред(Текст, сч, 1);
    Если Найти(ДопустимыеЗнаки, Символ)>0 Тогда
      Ответ = Ответ + Символ;
    КонецЕсли;
  КонецЦикла
  Возврат ?(Ответ="", 0, Число(Ответ));
КонецФункции
...Показать Скрыть
23. Александр М (Fruit83) 24.11.11 19:19
СуммаВзаиморасчетов = Число(СокрЛП(СуммаВзаиморасчетов)) не помогло, а вот функция помогла. Добавил ее в форму и вызвал СуммаВзаиморасчетов = ВЧисло(СуммаВзаиморасчетов);
Спасибо!
24. Александр М (Fruit83) 24.11.11 19:41
Чем отличается Текст = СокрЛП(""+Текст) от Текст = СокрЛП(Текст)?
25. Андрей Акулов (DrAku1a) 25.11.11 02:49
(24) По-сути ничем, но есть один ньюанс:

ИМХО, проверено методом тыка: 1С при анализе выражений использует правило сложения переменных вариантного типа, как в Basic (результат выражения имеет такой же тип, как первая переменная (операнд) выражения, все остальные выражения приводятся к типу первого операнда).

Т.е. конструкция ""+Текст - это указание 1С, что если Текст не является строкой - то его нужно преобразовать в строку. Хотя 1С должна сама делать такое преобразование внутри СокрЛП() - я на это не полагаюсь и лишний раз перестраховываюсь от ошибок при выполнении кода.
26. Александр М (Fruit83) 25.11.11 23:21
А как обойти обойти проблему контроля уникальности кодов? При загрузке справочника их надо указывать, но, если идет совпадение по кодам, загрузка прерывается...Мне сейчас приходится страховаться и указывать коды, которые наверняка не встретятся в справочнике.
27. Андрей Акулов (DrAku1a) 26.11.11 04:06
(26) Сделайте предварительную выборку по справочнику (до цикла загрузки) на предмет максимального кода - можно запросом, можно вручную. Поместите в отдельную переменную. Затем при добавлении нового значения в справочник - увеличивайте эту переменную на 1 и присваивайте код новому элементу.
28. Нурислам Ямбаев (nurislam) 17.12.11 14:37
Спасибо.Иногда нужна такая.
29. Николай (Koles) 28.12.11 10:04
Интересный приемчик. Спасибо.
30. Илья Фамилия (Murom) 28.12.11 11:00
Очень интересный прием. Да и правда быстро и удобно.
Но я по-старинке пользуюсь универсальной "ЗагрузкаДанныхИзТабличногоДокумента". Хотя идея имеет место на жизнь. И еще удобно, если у клиента надо что-то загрузить, а "ЗагрузкаДанныхИзТабличногоДокумента" нет под рукой, то можно очень быстро набросать такую обработочку.
31. Сергѣй Батанов (baton_pk) 28.12.11 11:24
Да! Определённо наш метод!

Ещё можно табличный документ засунуть в макет внешней обработки и брать данные оттуда. Я использую это, когда мне надо одни и те же данные загрузить в пару тестовых баз по паре десятков раз, а потом отправить клиенту (ну или своими руками) для загрузки в рабочую. Единоразовый копипаст и дальше всё уже решается нажатием одной кнопки - товарищ Бух это любит.
32. Александр М (Fruit83) 10.01.12 12:01
(31) baton_pk, не могли бы вы по-подробнее рассказать о том, как засунуть макет внешней обработки?
33. Сергѣй Батанов (baton_pk) 10.01.12 12:07
(32) Fruit83!
Всё то же самое:
во внешней обработке добавляем новый макет - табличный документ и копипастом из Excel вставляем табличку в макет.
Потом в коде просто вызываем ПолучитьМакет("НашаТабличка") и пробегаемся по табличке.

Можно посмотреть типовые - заполнение первоначальных данных в пустой базе или подбор из классификатора валют, например.
34. Андрей Акулов (DrAku1a) 10.01.12 16:54
(33) Можно обойтись и без макета - а вставить данные из Excel в поле табличного документа на форме - в режиме конфигуратора. И они сохранятся с обработкой.
35. Сергѣй Батанов (baton_pk) 10.01.12 17:13
(34) DrAku1a.
Можно, но оно тогда наружу торчать будет. В моих случаях хотелось всё это дело скрыть: таблиц для загрузки было несколько да и на форме были другие элементы, более нужные пользователю.
А так, да, Ваш вариант на все 100% справедлив.
36. nshrek nshrek (nshrek) 23.01.12 23:25
спасибо, хоть и полно в инете аналогичных обработок но думаю пригодится и эта.
37. Иван Мелихов (ivn75) 23.01.12 23:30
Смысл темы? В инете полно примеров решений загрузки из Excel при помощи DCOM объектов, при помощи которых можно не только загружать из Excel и Open office, но и выгрузки обратно с форматированием, проставлением формул и гиперссылок.
38. Андрей Акулов (DrAku1a) 24.01.12 01:58
(37) Чтобы использовать имеющиеся в инете примеры - нужно вникать в чужой код, возможно - читать документацию... и еще - немао подводных камней встретится... Правда, есть у меня в арсенале функция, которая Excel-файл через OLE считывает в таблицу значений - но пользуюсь ей редко. А так - не выходя из комфортной среды 1С, без изучения доп. материалов можно сделать загрузку данных. Быстро просто и удобно.
39. Владимир Водин (BalVlad) 24.01.12 22:07
40. Юрий Зайцев (Yury1001) 24.01.12 22:29
Мысль верная (идея рабочая), дубовая (надёжная), помнится копирование документов между базами так писал, и даже из 8 в 7.7 было. Только я в многострочную строку вставлял, потом Список.ИзСтрокиСРазделителями() и вот готовое соответствие так сказать, пользуй не хочу.
+
41. Андрей Сериков (sai-2010) 07.02.12 15:30
Спасибо автору.
Очень четко и толково все написал.
Действительно выгрузка и загрузка справочников, это часто возникающая задача.
Надо срочно и именнно этот справочник.
Эта статья очень помогла мне.
Огромное спасибо.
Удачи.
42. Александр Киричков (Bezeus) 11.06.12 07:06
(38) DrAku1a, Вот именно из таких редко используемых функций и строятся "программерские запасы".
43. Владимир (vladismi) 12.07.12 09:36
Отличная идея. А то, как правило, начинаешь вспоминать, как подключиться к Ёкселю... :)
44. Олег Владимирович (olezhe) 09.10.12 16:00
Немедля использовал для загрузки множества документов из единой таблицы. Плюсанул. Спасибо за подсказку.
45. Татьяна Ситникова (ledogora) 12.11.12 21:26
Полезная статья.Спасибо.
46. BAZIL BAZIL (wbazil) 08.07.13 11:56
обычно копировал подключение к Excel из другой обработки, но часто бывало что потом в процессе отладки этих екселей плодиться много, приходиться прибивать процессы, а тут красиво и элегантно.
Спасибо за идею!
47. Евгений ' (WanGoff) 01.08.13 00:23
Ну как-то слишком уж несерьезно, на мой взгляд. Статья для тех, кто второй месяц занимается 1С.
48. Андрей Акулов (DrAku1a) 01.08.13 02:07
(47) Да, но... Посмотри сколько народу сказали что классная идея!..
49. Евгений ' (WanGoff) 01.08.13 03:54
(48) Сложно спорить. Видимо, многим и правда помогло. Ну что ж, и то хорошо.
50. Елена К (Ele1234567) 23.12.13 10:28
Все зависит от решаемой задачи. Но стоит взять на заметку
51. Демин Денис (Dionisy_nb) 14.02.14 12:15
Отличная идея, если нужно что-то одноразовое. Или редкоиспользуемое.
52. Andrey@ (Andrey@) 16.03.14 13:43
Как вариант можно использовать при разовой загрузке данных, а то и настроить загрузку номенклатуры из накладной в Excel от поставщика.Спасибо.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа