gifts2017

Как выбирали восьмерку

Опубликовал Александр Рытов (Арчибальд) в раздел Управление - Бизнес-процессы

Кусочек аналитической записки

Дискуссия в http://forum.infostart.ru/forum1/topic39396/ навела меня на мысль опубликовать мою старую аналитическую записку. Правда, когда я ее разыскал, выяснилось, что там слишком много конкретики. Когда же я конкретику, не интересную широкой публике, выбросил - осталась всего страничка. Привожу ее.

Учет в 2006 году

Предложения по переходу В 2006 году к корпоративному учету на платформе 1С:предприятие 8.0.

Критерии выбора информационно-учетной системы

При выборе информационной системы для ведения учета (ИС) необходимо оценивать финансовую, функциональную и инструментальную часть этих систем.

Основным моментом, на который следует обратить внимание при выборе системы, является ее возможность за расчетное время и выделенные на эти цели денежные средства решить определенный круг актуальных задач. Рассматриваемое программное решение должно продемонстрировать ряд основополагающих свойств:

  • гибкость (легкость в настройке и внесении изменений);
  • масштабируемость (возможность при необходимости распространить решение на филиалы, преобразовать систему в территориально-распределенную);
  • открытость (способность легко взаимодействовать с другими присутствующими в ИС предприятия программными продуктами - почтой, разнообразными БД и т. п.).

Информационная система должна иметь ограниченную функциональность, что не дает задаче выйти за рамки целесообразности. Ключевым моментом здесь является то, что если сложный продукт построен на верных принципах, то проблем с последующим наращиванием функциональности, как правило, не возникает.

Как обеспечивается адекватность учета специфике предприятия

Для предприятия необходимо при выборе ИС получить законченное решение. Оно принципиально отличается от универсальных («коробочных») продуктов тем, что автоматизируются не только общепринятые учетные процедуры, но и специфические, например, отраслевые, что предполагает наличие некоторых внутрифирменных технологий и стандартов.

Несомненно, заказные решения могут быть и более отточенными, чем тиражируемые, и более эффективными для конкретного этапа развития бизнеса в некоторый фиксированный момент времени. Но их развитие и поддержка окажется однозначно более дорогостоящей и более зависимой от разработчиков. В журнале «Сахар» №1’2003 г. так описывается модель поведения недобросовестного исполнителя:

«Короткое и "легкое" обследование предприятия и дальнейшее лоббирование одной из интегрированных систем …под красивыми лозунгами настройки и адаптации под конкретного заказчика (кстати, стоимость такой настройки может на порядок превышать стоимость модулей системы и требовать серьезных временных затрат, совместимых с затратами на разработку новой системы). При этом, как правило, фирма-исполнитель еще до проведения обследования (да и вообще, до появления заказчика на ее горизонте) знает, какую именно систему она будет внедрять…»

Результат применения данной модели иллюстрируется второй колонкой таблицы, приведенной ниже:

 

 В третьей колонке таблицы содержатся проверенные (документально подтвержденные) экспериментальные данные по реализации методики «неразрушающего конфигурирования» (Замечание: эта методика описана в http://infostart.ru/public/19784/Тогда она существовала в виде утвержденного документа). Таким образом, максимальное использование преимуществ тиражируемых решений (в первую очередь, имеются в виду решения 1С) – способ радикально удешевить и упростить процесс построения ИС.

Итак, создание ИС следует рассматривать как последовательную адаптацию и внедрение совокупности тиражируемых решений, способных вырасти до систем масштаба предприятия. Именно в таком направлении действует сейчас (в процессе перехода на платформу 8.0) фирма «1С», используя как позитивный, так и негативный свой многолетний опыт...

 ___________________________________________________

 Не правда ли, совсем не похоже на апологетику семерки, в которой можно меня заподозрить?

Ну и результат, к которому записка привела: на восьмерку до сих пор не перешли. Однако от услуг франча по сопровождению отказались. Сразу.

Можно пробить лбом стену. Но что ты будешь делать в соседней камере? © Станислав Ежи Лец

 

 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Аркадий Кучер (Abadonna) 27.10.11 09:37
Я-то плюс ставлю, и даже знаю, кто минус поставит :D
2. Александр Рытов (Арчибальд) 27.10.11 09:39
(1) Кто? Сто лет уж минусов не получал ;)
3. Сергей Рудаков (fishca) 27.10.11 09:49
(2)
Рука тянется поставить минус за оформление, если честно. Привести шрифты в порядок было очень неплохо!

Однако от услуг франча по сопровождению отказались. Сразу

Статья об этом?
4. Аркадий Кучер (Abadonna) 27.10.11 09:50
(2) hogik, как единственный в мире Хранитель Сакральных Знаний Его Же Собственной Системы :)))
5. Александр Рытов (Арчибальд) 27.10.11 09:52
(3) Сдерживание естественных желаний приводит к неврозам.
А что не так со шрифтами?
6. Аркадий Кучер (Abadonna) 27.10.11 09:54
(5) Учитывая твою любовь к "попугайским" формам, я даже и не возьмусь объяснять тебе, что не так ;)
7. Сергей Рудаков (fishca) 27.10.11 09:57
(5) Много разных по начертанию и размерам шрифтов, читать тяжело. В идеале когда в тексте используется один шрифт, минимум в 12 пунктов.
8. Александр Рытов (Арчибальд) 27.10.11 09:57
(3) А статья (точнее, записка) на тот момент была о том, что нанимая франча, скорее всего, попадешь на бабки, и если уж типовая семерочная конфа не устраивает, купи восьмерку.
9. Аркадий Кучер (Abadonna) 27.10.11 09:59
+(7) Например, такой как тут - в комментах
10. Александр Рытов (Арчибальд) 27.10.11 09:59
(7) А, я Гарамонд оставил... Сейчас поправлю.
11. dima (kdw) 27.10.11 12:15
если экономите - то и не парьтесь и сидите на 1С7
12. Anatolii Karasev (KapasMordorov) 27.10.11 13:47
1С решает проблему сравнения колонок 7.7,8.0 и платная поддержка 1С 7.7 скоро наступит.
13. Александр Рытов (Арчибальд) 27.10.11 14:01
(12) С учетом современного состояния 1-й строки, итог по последней колонке будет минимальным.
Кстати, интересно: 6 лет вообще без поддержки - и никто не подох...
14. Владимир (hogik) 27.10.11 18:18
(4)
Аркадий.
Ты - извращенец. :-)
Сам написал в "исходной" теме: "И мы строили производственный блок на 7.7 с нуля. От 7.7 - только движок + куча довесок наших же ВК."(с)
И я занимаюсь "производственным блоком"(ПБ). Вы сумели усмотреть в "платформе 7.7" инструменты для ПБ - молодцы. Лично, я их не обнаружил...
Ваши "Сакральные Знания"(с) еще "работают" в месте их вываливания. И мои работают.
С переходом тебя на 8.х, как средство ПРОГРАММИРОВАНИЯ не изменяет упрощенную формулу: ИС=ПБ+хУ в ИС=хУ для реальной жизни. Если эта жизнь не ограничивается лично твоим удобством программирования без лишних затрат ТВОЕЙ энергии.
P.S. Минус на публикацию от Александра не собираюсь ставить. Читаю, думаю... Задам вопросы, если чего не пойму. Буду спорить (в хорошем смысле этого слова), если захотим разобраться в сути темы.
P.P.S. Ставить минус - это упрощенный способ выражения собственного мнения с минимальными затратами мозгов. Ну, аналогично переходу на более "кубик-овые" средства программирования.
P.P.P.S. Извини, ничего личного. Я высказался не конкретно в твой адрес, а в "подход" - упрощения уплощения всего и вся... :-(
15. Александр Рытов (Арчибальд) 27.10.11 18:33
(14)
Вы сумели усмотреть в "платформе 7.7" инструменты для ПБ - молодцы. Лично, я их не обнаружил...
Ну, платформа-то универсальна. Другое дело, что в зависимости от контролируемых параметров производства она оказывается более удобной или менее удобной.
16. Владимир (hogik) 27.10.11 18:49
(15)
"Ну, платформа-то универсальна."(с)
В смысле операторов "Если ... Тогда ..." или ОткрытьФорму() - да, универсальная. ;-)
А в смысле "механизмов"© хранения и обработки информации - нет.
Да, и в смысле модульности-развития функционала в предметной области - ОченьНет. ;-)
Думаю, это и есть "основная тема" наших с Вами расхождений во взглядах на АвтоМехАнизацию. Для такого расхождения взглядов есть объективные причины.
Думаю, лет так через десять разберемся и придем к общему и НеПротиворичимому (между нами) взгляду на эТТо. Надеюсь...
17. Владимир (hogik) 27.10.11 19:06
(15)
P.S. к сообщению #16.
Вот, любопытная статья про "универсальность" платформы в част хУ:
http://www.ms-dynamics.ru/index.php/solutions/microsoft-dynamics-ax/146-microsoft-dynamics-ax-arc
18. Аркадий Кучер (Abadonna) 27.10.11 23:34
(14)
Ваши "Сакральные Знания"(с) еще "работают" в месте их вываливания

В наших "сакральных" пусть и не любой, но одноэснег разберется. Потому как написано на стандартном 1С языке.
Открыл Конфигуратор и все ясно: вот справочник, вот регистр, вот документ. Вот то-то этот документ двигает и т.д. и т.п. Надо добавить - жми кнопку "добавить" и нет проблем.
А ты, кстати, так до сих по и не обозначил: твоя система на чем писана? Каков принцип хранения/движений, в чем база хранится?
А в смысле "механизмов"© хранения и обработки информации - нет.

Лично меня хранение/обработка информации в скуль базах вполне устраивает, я тебе там хоть черта лысого сохраню.
Да, и в смысле модульности-развития функционала в предметной области - ОченьНет. ;-)

Без комментариев. Что ты под этим подразумеваешь - одному богу и тебе известно
19. Владимир (hogik) 28.10.11 00:46
(18)
1) "А ты, кстати, так до сих по и не обозначил: твоя система на чем писана?"(с)
На стандартном встроенном языке "1С 7.7". Плюс - ВК. Как и у тебя. ;-) Только мои ВК призваны обеспечивать взаимодействие с внешним оборудованием. И еще позволяют получить полноценный "навигационный" доступ к БД. Интерфейс описан и, даже, опубликован на данном ресурсе. Т.е. в моих ВК уделяется внимание не "внешней" форме (окон, кнопок, цвету и т.д.), а внутреннему содержанию системы. Это, типа, я тебя подколол... ;-)
2) " вот справочник, вот регистр, вот документ"(с)
У меня нет регистров. Документ (формы ввода информации) и справочник - есть.
3) "Вот то-то этот документ двигает и т.д. и т.п."(с)
Если ты говоришь об учете документов в "производственном блоке"(ПБ), то это не ПБ, а хУ документов. Документ ничего не может "двигать". Двигаются материальные ценности и деньги между объектами их "использования" - складами, контрагентами, цехами, людьми...
4) "Надо добавить - жми кнопку "добавить" и нет проблем. "(с)
Следует, конечно, уточнить - что "добавить". Отчет, форму ввода информации, справочник - аналогично стандартным возможностям "1С 7.7". Хотя, замечу, что за 11 лет приходилось это делать не часто. Например, была торговля - добавилось производство-ремонт. Всякие отчеты появляются чаще.
5) "Каков принцип хранения/движений, в чем база хранится? "(с)
В этом вопросе - два вопрос. ;-)
5.1) "Каков принцип хранения/движений"(с)
Фиксируются хозяйственные операции (ХО) по месту их возникновения. В "унифицированной" структуре на справочниках (в терминах 1С). Движение - см. выше.
5.2) "в чем база хранится"(с)
Хранится в БД. ;-) Поддерживается клиент-серверной СУБД. Информация опубликовано на данном ресурсе.
6) "Лично меня хранение/обработка информации в скуль базах вполне устраивает, я тебе там хоть черта лысого сохраню."(с)
Т.е. твои "Сакральные Знания(с)" глубже моих. :-) У меня описание схемы БД "укладывается" в стандартном 1CV7.DD. Хотя планирую сделать отдельную подсхему с прямым доступом через штатную ВК для хранения динамических итогов. Но, видимо, так и не доберусь до этой задачи. :-(
7) "Без комментариев. Что ты под этим подразумеваешь - одному богу и тебе известно "(с)
Да ты явно - не Бог. Элементарно. Например, у 1С есть конфигурации на все случае жизни нашей Родины. Каждая базируется на своей схеме базы данных. На самом деле БД (и схема) должна быть общая и добавляется в систему несколько модуле (без изменения ранее существующих) которые обеспечивают "предметное" расширение функционала. Основы информатики, 9-ый класс. Моя жена рассказывала деткам. И они, даже, понимали... :-)
20. Аркадий Кучер (Abadonna) 28.10.11 00:54
(19)
Документ ничего не может "двигать". Двигаются материальные ценности и деньги между объектами их "использования" - складами, контрагентами, цехами, людьми...

Демагогия. Либо мы слово "двинуть" понимаем по разному. Если документ установил свой статус, что он новый - это уже двинул. В моем понимании. Если статус "раз прочли" - еще раз двинул, статус "решение принято" - опять двинул.
Хотя планирую сделать отдельную подсхему с прямым доступом через штатную ВК для хранения динамических итогов.

Вопрос о хранении чего либо в сторонней скуль базе, с элементарным доступом в нее из 1С через тот же ADO у нас как-то и вопросов не вызывал. И никакие dd не помеха, и никаких ВК не надо.
А уж "сожрать" что-то из другой базы 1С - никто и не собирался никогда через всякие там файлы переноса.
Цепанулся к таблицам другой базы - и лопай - не хочу. Это настолько очевидно, что даже и неловко упоминать
21. Владимир (hogik) 28.10.11 01:15
(20)
Ну, хватит бросаться такими словами как "Демагогия". Не гневи меня, пожалуйста.
Посмотри внимательно на формулировку, что такое документ. Не у 1С, а вообще. Посмотри, что означает документ в хУ. Вот, например, определение:
http://forum.infostart.ru/forum24/topic44073/message477736/#message477736 (первый пункт).
И отвлекись, пожалуйста, от понятий: "ось времени, ТА, документ, последовательность, проведение, итоги на..." в трактовке 1С-продуктов. Эти понятия - полный бред. Эти понятия годятся только АвтоМехАнизации сбора в пачки документов. И переноса информации с бумажного носителя в БУ. Разработчики 1С-ов постепенно это осознают при появлении новых версий. Например, исчезло понятие ТА, появились регистры сведений, в регистрах накопления (вроде) теперь дата может отличаться от даты документа. Но, до полного понимания им еще далеко. Увы... :-( Они живут понятиями полувековой давности: бумажный документ -> перфокарта. Точнее эТТо они изобретают заново. Спираль, блин... :-)
22. Владимир (hogik) 28.10.11 01:19
(20)
"Это настолько очевидно, что даже и неловко упоминать "(с)
И не упоминай. Тебе, все представляется, что я еще не дошел до твоих знаний про SQL и ADO. Дорогой, Аркадий - я уже прошел это этап... :-) ОООО-очень давно. Ты еще школу не закончил тогда. ;-)
23. Аркадий Кучер (Abadonna) 28.10.11 01:19
(21)
Посмотри внимательно на формулировку, что такое документ. Не у 1С, а вообще.

да плевать я хотел на формулировки хоть 1С, хоть "вообще".
Есть нечто, что:
1. Хранит введенную изначальную иформацию
2. Может на основании неё что-то сделать с другой информацией
3. Наконец, напечатать что-то
Хоть документом назови, хоть "@@ёвиной" - какая разница?
Тебе, все представляется, что я еще не дошел до твоих знаний про SQL и ADO.

Да ничего мне не чудится! Чего там знать-то?
24. Владимир (hogik) 28.10.11 01:25
(23)
Совершенно верно. Не в названии дело. А в сути... ;-)
Осталось только почаще восстанавливать (и/или не нарушать) последовательность ...ээээ... этой т.н. "@@ёвиной"-ы.
25. Владимир (hogik) 28.10.11 01:28
(23)
"Да ничего мне не чудится! Чего там знать-то? "(с)
Элементарные знания. Угу. Нажал и играет. Ты, чо? Не понял, что нажимаешь на ту кнопку, которую Я для тебя "сделал". Заколебал ты меня.
26. Аркадий Кучер (Abadonna) 28.10.11 01:31
которую Я для тебя "сделал"
Заколебал ты меня

:))) Вот тут, на ИС, до фига кнопок, которые я "сделал". И их куча народа нажимает. Объективно!
Твоих кнопок я что-то не видал. Вот видишь, как всё просто ;)
а вся твоя электроника, кстати, работает на электричестве от угля (в том числе), который накопали роторные экскаваторы, которые Я "сделал". И что? :)))))))))))))))))))
27. Владимир (hogik) 28.10.11 01:39
(26)
Аркадий.
Перестань прикидываться "примитивом". Если ты не видал моих "кнопок", то может быть по двум причинам. Либо их нет, либо у тебя другая специальность. Хлынувший, ты наш... Извини, это грубо звучит. Но это, именно, так...
28. Аркадий Кучер (Abadonna) 28.10.11 01:42
(27)
Либо их нет, либо у тебя другая специальность.

Хм... ну фиг его знает. Может ты с Винером начинал... но мне-то про это неизвестно ;)
Вообще-то этот сайт для прикладных решений: как раз про то, как правильнее и лучше нажимать "кнопки", которые кто-то сделал. А не сайт для теоретизирования о путях развития человечества в сфере информационных технологий.
29. Владимир (hogik) 28.10.11 01:45
(26)
Разговор, то - о другом. Ты, бравируешь потребительским верхоглядством в "некой теме" и удивляешься - почему все, такие глупые, не делают это вместе с тобой. Ну - да. Глупые...
30. Аркадий Кучер (Abadonna) 28.10.11 01:47
Ты, бравируешь потребительским верхоглядством в "некой теме" и удивляешься

Просто даже забавно. Тема изначально была: что лучше - 7.7 или 8.2? Я как раз за рамки этой темы и не уходил.
А тебя все время в сторону несет.

- Вы ели в этом году сливы?
- Нет, но зато, говорят, что турецкий султан - весьма достойный человек.

Я. Гашек
31. Владимир (hogik) 28.10.11 01:51
(28)
"А не сайт для теоретизирования"(с)
Ну, если тебе тяжело заглянуть в мой "профайл" по конкретным (прикладным решениям), то загляни сюда: http://ru.wikipedia.org/wiki/1%D0%A1:%D0%9F%D1%80%D0%B5%D0%B4%D0%BF%D1%80%D0%B8%D1%8F%D1%82%D0%B8­%D0%B5
Тебя ткнуть в строчку (абзац), или сам найдешь? :-)
32. Владимир (hogik) 28.10.11 01:54
(30)
Блин. Слова "некая тема" написана в кавИчках. Чего, уж так конкретно трактуешь?
33. Аркадий Кучер (Abadonna) 28.10.11 02:02
(32) Если честно, никак не пойму чего ты от меня конкретно услышать хочешь?
Что IT - супер-сложно и не фиг там делать человеку без спецобразования? Или что?
А по мне ничего не сложно, хоть бы и ядерная физика. Были бы мозги и желание.
И доступ к информации, а его, благо, сейчас завались.
Ну, например, я знаю, как физически устроен p-n-p переход, почему в одну сторону "пущат", а другой не знает.
И что? Это помешает ему в 1С программить? И хорошо программить.
34. Владимир (hogik) 28.10.11 02:14
(33)
Аркадий.
Да ничего я от тебя не хочу услышать глобального.
Тебя эта тема не интересует. Ты в ней живешь для себя. И это - нормально, естественно.
Но, лично меня коробит твоё "энергичное верхоглядство" в том чем ты (ну хоть) зарабатываешь деньги. Но, это твое личное дело...
35. Аркадий Кучер (Abadonna) 28.10.11 02:18
(34)
Но, лично меня коробит твой "энергичное верхоглядство"

Опять-таки не понимаю. В чем верхоглядство?
На данном этапе я зарабатываю на 1С, в чем там мое верхоглядство? Если семерку местами даже на уровне движка и внутренних структур "расколупал".
Вопрос к тебе простой, как грабли: чего ж до меня никто из не верхоглядов не написал хотя бы вот это
http://infostart.ru/public/15043/ ?
Почему, на заре своего освоения 1С, я оказался первым, кто внедрил визуальные компоненты прямо на форму 7.7
vip не даст соврать.
36. Владимир (hogik) 28.10.11 02:26
(35)
Аркадий.
Ты "расколупал" средство (инструмент). Но, мне казалось (по собственной наивности), что человек у которого "Были бы мозги и желание"(с) может разобраться для чего эти средства существуют. Обидно... Но, моё уважение к тебе от этого не уменьшается.
P.S. Ладно. Завяжем пугать читателей темы. Пойду дослушаю Ozzy Osbourne. Открыл его для себя заново. Удивительно, как я раньше его так не понимал, как сейчас - понимаю. Старею видимо, или может - мудрею... :-)
Желаю тебе успехов.
37. Аркадий Кучер (Abadonna) 28.10.11 02:33
(36)
может разобраться для чего эти средства существуют

Наконец-то понял! Ты хочешь от меня услышать, что 1С -@овно?
Так я и не скрывал этого никогда :))))
P.S. Дослушаю-ка я Deep Purple - Concerto for Group and Orchestra :)
38. Александр Рытов (Арчибальд) 28.10.11 08:14
(16) Не думаю, что наши взгляды так уж расходятся. Структурирование и хранение данных - да, с этим тухляк. Хотя бы потому, что не очень-то 1С понимает даже в области документоучета. Модульность вообще ниже плинтуса - так это потому в частности, что УПП торговать выгоднее, чем (необходимыми) функциональными компонентами. Это как с десятком жестяных крышек по 3 копейки обязательно было купить крышковерт за 4 рубля. Сложность и в том, что весьма трудно потроить модель реальности напрямую, не построив промежуточную модель "документооборота".
Все эти сложности усугубились на восьмерке, поэтому-то я ее и критикую.
Расхождение у нас не во взглядах, а в путях преодоления препятствий...
39. Владимир (hogik) 28.10.11 20:51
(38)
Александр.
Да. Но. ;-)
Вы написали: "Сложность и в том, что весьма трудно построить модель реальности напрямую, не построив промежуточную модель "документооборота"."(с)
Напрямую - невозможно! А промежуточная модель "документооборота" уже давно построена и успешно работает в хУ. Надо строить другую модель. Мы, вроде, это понимаем. Но, упрямо пытаемся засунуть "бумажный документ" в лоток DVD диска.

Хотя, Аркадий прав: "...этот сайт для прикладных решений: как раз про то, как правильнее и лучше нажимать "кнопки",..."(с)

Спасибо Вам...
Арчибальд; +1 Ответить
40. Илья Фильчагов (fcsm220691) 02.11.11 14:28
Выбирай не выбирай,а кроме восьмёрки выбора больше нет.
41. Александр Федорович (Фред) 05.11.11 07:51
Abadonna пишет:
Хм... ну фиг его знает. Может ты с Винером начинал... но мне-то про это неизвестно ;) Вообще-то этот сайт для прикладных решений: как раз про то, как правильнее и лучше нажимать "кнопки", которые кто-то сделал. А не сайт для теоретизирования о путях развития человечества в сфере информационных технологий.


При всем интересе к теоретическим и философским изысканиям, пользоваться сайтом все сложнее. Все дальше и дальше он от народа, нажимающего кнопки.
А в данном случае научным языком описано, что новое дороже старого, и на заказ дороже, но не факт что лучше...
А минус или плюс.... Автор (как и все нормальные творческие люди) себе уже большой плюс поставил, раз опубликовал, а минусы необразованной толпы ему неинтересны...))
42. Аркадий Кучер (Abadonna) 05.11.11 09:48
(41)
а минусы необразованной толпы ему неинтересны...))

Слышал звон, не знаю где он? Абадонна полемизировал вовсе не с автором. А что касается образования - тебе рядом с моим полноценным советским и краснодипломным остается только два раза "ку" делать.
Даже лень почитать, кто на самом деле автор и какие выводы он сделал:
В третьей колонке таблицы содержатся проверенные (документально подтвержденные) экспериментальные данные по реализации методики «неразрушающего конфигурирования» (Замечание: эта методика описана в http://infostart.ru/public/19784/ Тогда она существовала в виде утвержденного документа). Таким образом, максимальное использование преимуществ тиражируемых решений (в первую очередь, имеются в виду решения 1С) – способ радикально удешевить и упростить процесс построения ИС.

Итак, создание ИС следует рассматривать как последовательную адаптацию и внедрение совокупности тиражируемых решений, способных вырасти до систем масштаба предприятия. Именно в таком направлении действует сейчас (в процессе перехода на платформу 8.0) фирма «1С», используя как позитивный, так и негативный свой многолетний опыт...

___________________________________________________

Не правда ли, совсем не похоже на апологетику семерки, в которой можно меня заподозрить?

А туда же:
в присутствии двух людей с университетским образованием, позволяете себе с развязностью совершенно невыносимой, подавать какие-то советы космического масштаба и космической же глупости
43. Александр Федорович (Фред) 05.11.11 13:14
Abadonna пишет:
А что касается образования - тебе рядом с моим полноценным советским и краснодипломным остается только два раза "ку" делать.
(42)
Конечно!! Простите!! Ку!Ку!!
Кстати и у меня советское, и 2 красных диплома...
А про необразованность я помянул, в том смысле, что не программер.
Выступление мое сводилось к тому, что в связи с новыми правилами народ иногда ( и все чаще) публикует, банальные, бесполезные и т.д. вещи. А такие, как я , чтобы иметь возможность скачать полезную диковинку, или проверить какие-то выводы авторов, вступают в дискуссии, и не всегда удачно... Однако, как говорил один из литгероев: если что-то есть, значит это кому-то надо...))(Вольная интерпретация С.Экзюпюри- а то еще и это начнем обсуждать)
44. Аркадий Кучер (Abadonna) 05.11.11 13:17
(43) Просто не надо всуе упоминать имя Великого Абадонны, как кое-кто меня тут величает. И я буду белый и пушистый;)

http://forum.infostart.ru/forum24/topic20800/
jhfrek 29.06.10 19:34 URL ↓Цитата ↓Ответить
А-а-а-а! Блин, супер вообще. Abadonna ГЕНИЙ!!! Ничего подобного не видел...

:)))))))))))))))))))))
45. Алекс Ю (AlexO) 02.12.11 17:04
(14) что есть xY??
_______________________________
Abadonna, позвольте в этой теме вас критиковать )
во многом не согласен, хоть всего лишь 10 лет с восьмеркой...
(18) >>Открыл Конфигуратор и все ясно: вот справочник, вот регистр, вот документ.
- ничего не ясно. Смысл справочника, регистра, документа? В 8-ке эти понятия уже давно потеряли свой первоначальный функциональный смысл и стали "вещью-в-себе": не они подстраиваются под учет, а учет подстраиваем под них.
>>Лично меня хранение/обработка информации в скуль базах вполне устраивает, я тебе там хоть черта лысого сохраню.
- ну какое отношение имеет хранение в SQL к самой 1С? такое жде, как и выражение "меня вполне устраивает хранить все в компе".
И много чего вы не сохраните и не возьмете из SQL: а разные типы данных? а ограничения на скорость записи? а встроенный оптимизатор расположения строк? а закрытая ссылочная структура самой 1С, построенная вне системы SQL, и оттого немогущая использовать преимущества SQL, но наследовавшая его недостатки? да много чего... компьютер не терпит хаоса, а 1с - это сама по себе структурированный хаос....
(19) hogik,
Если ты говоришь об учете документов в "производственном блоке"(ПБ), то это не ПБ, а хУ документов. Документ ничего не может "двигать". Двигаются материальные ценности и деньги между объектами их "использования" - складами, контрагентами, цехами, людьми...
- именно! это тот принцип идеальной учетной системы, который специально и последовательно нарушается в 1С.
в 1С не все подстраиватся под процессы/учет/хозоперации, а ХО-учет подстраиваются под документы и прочее.
И это жестко ограничивает логику работы. А должно быть - где возникло, там и учлось, где происходит, там и влияет.
А не как в 1с сказали...
(20) >> А уж "сожрать" что-то из другой базы 1С - никто и не собирался никогда через всякие там файлы переноса.
Цепанулся к таблицам другой базы - и лопай - не хочу. Это настолько очевидно, что даже и неловко упоминать
- вы не в 1С работаете ))
что вы "цепанете" напрямую из таблиц SQL? перечисление номенклатуры? Или вы написали механизм, замещающий 1С-сервер, и сами рулите невообразимой структурой 1С-баз??
Вы в такой эйфории, какая наступает на третьем месяце знакомства с 8-ой: вау! а это что? и так можно? ух ты!
Хотя большинство "вау" и не нужно, а нужны от платформы давным-давно известные вещи: 1. прозрачность происходящих процессов 2. четкая документирование 3. стабильность 4. гибкость и широта охвата языка.
46. Аркадий Кучер (Abadonna) 02.12.11 17:12
(45)
замещающий 1С-сервер, и сами рулите невообразимой структурой 1С-баз??

Представь себе- рулю.
Семилетней давности: в базе комплесной 7.7 создается документ "Поручение на платеж".
В базе обычной бухни цепляемся к скуль-таблицам комплексной, выбираем контрагентов со всеми потрохами, при надобности создаем нового в бухне и формируем платежки с нужным контриком, суммами и прочей фигней.
Пример 2: база проходная, ночью цепляется к скуль-таблицам зарплаты на "Камине", определяем какой сотр принят, какой уволен, соответственно перемещаем уволенных в папку "Уволенные" (в базе проходной), нового добавляем.
Что за проблемы разобраться что и как в скуле хранится? Если только для "одноэснегов"
Да на ДЗНВА у меня 80% запросов шло напрямую, в гробу я видал ублюдочные родные запросы от семерки. А 1С++ тогда и в помине не было.
47. Аркадий Кучер (Abadonna) 02.12.11 17:21
+(45) Чтобы не быть голословным, нашел какое-то старье свое под названием УниверсальныйSQL-запрос
Уж что делало и не помню ;)
//"SET LANGUAGE russian use nva SET IDENTITY_INSERT SC1439 ON insert into SC1439"
Перем ConnectionString;
Перем Connection;
Перем Cmd;
Перем Текст;
Перем ТЗТ;
Перем СтатусСтрока;
Процедура Выгрузить()
Если Поле.РазмерСписка()=0 Тогда
Предупреждение("Нет полей для выгрузки!");
Возврат;
КонецЕсли;

Команда="Select ";
// --- считываем первую запись для получения типов-----
Cmd.CommandText ="Select top 1 * from "+ СокрЛП(Таблица);
RST = СоздатьОбъект("ADODB.RecordSet");
RST= Cmd.Execute; // в RST одна строчка с полями=типы
Для А=1 По Поле.РазмерСписка() Цикл
Т=СокрЛП(Таблица);
Если Поле.Пометка(А)=0 Тогда Продолжить; КонецЕсли;
ID=Поле.ПолучитьЗначение(А);
Команда=Команда+" dbo."+Т+"."+ID+" as "+ID;
Команда=Команда+", ";
КонецЦикла;
Команда=Лев(Команда,СтрДлина(Команда)-2); // убрали последнюю запятую
Команда=Команда+" from "+Т;
Cmd.CommandText =Команда;
RST= Cmd.Execute; // список с типами (без преобразования строку)
Команда="Select ";
Для А=1 По Поле.РазмерСписка() Цикл
Т=СокрЛП(Таблица);
Если Поле.Пометка(А)=0 Тогда Продолжить; КонецЕсли;
ID=Поле.ПолучитьЗначение(А);
Команда=Команда+" Cast(dbo."+Т+"."+ID+" as char) as "+ID;
Команда=Команда+", ";
КонецЦикла;
Команда=Лев(Команда,СтрДлина(Команда)-2); // убрали последнюю запятую
Команда=Команда+" from "+Т;
Cmd.CommandText =Команда;
RS= Cmd.Execute;
Стр="";
НС=0;
RST.MoveFirst();
Кол=2;
Пока Rs.EOF() = 0 Цикл
Если (ВыгрЗаписей<>0) И (НС=ВыгрЗаписей) Тогда Прервать; КонецЕсли;
НС=НС+1;
Стр="";
Для А=0 По rs.Fields.Count-1 Цикл
Идентификатор=RST.Fields(А).Name;
Тип=RST.Fields(А).Type;
ТипЧ=Число(Тип);
Ст=0;
Если ТЗТ.НайтиЗначение(Тип,Ст,Кол)=1 Тогда
ТипСтр=СокрЛП(ТЗТ.ПолучитьЗначение(Ст,1));
КонецЕсли;
//Длина=RST.Fields(А).DefinedSize;
//ВсегоЗнаков=RST.Fields(А).Precision;
//ЗнаковПослеЗапятой=RST.Fields(А).Precision;
Стр=Стр+Идентификатор+","+rs.Fields(А).Value+","+ТипЧ+","+ТипСтр+";";
КонецЦикла;
Стр=Лев(Стр,СтрДлина(Стр)-1); // убрали последнюю точку с запятой
Текст.ДобавитьСтроку(Стр);
Rs.MoveNext();
КонецЦикла;
ИмяФайла="c:\ SQL_"+Т+".sql";
Текст.Записать(ИмяФайла);
RS.Close();
RST.Close();
Connection.Close();
Сообщить("Выгружено "+Строка(НС)+" строк в файл "+ИмяФайла);
КонецПроцедуры

Процедура Соединить()
Поле.УдалитьВсе();
Connection=СоздатьОбъект("ADODB.Connection");
Cmd=СоздатьОбъект("ADODB.Command");
ConnectionString="Provider=SQLOLEDB.1;Password="+СокрЛП(Пароль)+"; Persist Security Info=True; User ID="+
СокрЛП(Логин)+"; Initial Catalog="+СокрЛП(База)+"; Data Source="+СокрЛП(Сервер);
Connection.ConnectionTimeOut =30;
Connection.CursorLocation = 3;
Попытка
Если Connection.State=0 Тогда
Connection.Open(ConnectionString);
КонецЕсли;
Исключение
Предупреждение("Невозможно установить Соединение!"+РазделительСтрок+
"Проверте параметры соединения"+РазделительСтрок+
"(Возможно 1С включена в монопольном режиме)");
Возврат;
КонецПопытки;
Cmd.ActiveConnection = Connection;
// --- считываем первую запись для получения идентификаторов полей в таблице-----
Cmd.CommandText ="Select top 1 * from "+ СокрЛП(Таблица);
RS = СоздатьОбъект("ADODB.RecordSet");
RS= Cmd.Execute;
Поле.УдалитьВсе();
Для А=0 По rs.Fields.Count-1 Цикл
Поле.ДобавитьЗначение(RS.Fields(А).Name);
КонецЦикла ;
Cmd.CommandText ="Select count (*) from "+ СокрЛП(Таблица);
RSC = СоздатьОбъект("ADODB.RecordSet");
RSC= Cmd.Execute;
ВыгрЗаписей=rsc.Fields(0).Value;
СтатусСтрока="Всего записей: "+rsc.Fields(0).Value; Форма.Обновить();
RSC.Close();
КонецПроцедуры

Процедура ПриВыбореОбъекта()
Если ФС.СуществуетФайл(КаталогИБ()+"1Cv7.DDS")=0 Тогда
Сообщить("Файл 1Cv7.DDS в Каталоге бызы не обнаружен!","!");
Возврат;
КонецЕсли;
Т=СоздатьОбъект("Текст");
Т.Открыть(КаталогИБ()+"1Cv7.DDS");
ТекОбъект=Объект.ПолучитьЗначение(Объект.ТекущаяСтрока());
Для А=1 По Т.КоличествоСтрок() Цикл
ТекСтр=СокрЛП(Т.ПолучитьСтроку(А));
Если Найти(ТекСтр,": "+ТекОбъект)>0 Тогда
Стр=СокрЛП(Т.ПолучитьСтроку(А+2));
Стр=СтрЗаменить(Стр,"|",РазделительСтрок);
Стр=СокрЛП(СтрПолучитьСтроку(Стр,3));
Таблица=Стр;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Процедура ПриОткрытии()
Сервер="COUTCHER";
Логин="sa";
Пароль="";
База="nvalocal";
Текст=СоздатьОбъект("Текст");
Для А=1 По Метаданные.Справочник() Цикл
Объект.ДобавитьЗначение("Справочник "+Метаданные.Справочник(А).Идентификатор);
КонецЦикла;
Для А=1 По Метаданные.Документ() Цикл
Объект.ДобавитьЗначение("Документ "+Метаданные.Документ(А).Идентификатор);
Объект.ДобавитьЗначение("Документ (Мн.ч.) "+Метаданные.Документ(А).Идентификатор);
КонецЦикла;
Объект.ТекущаяСтрока(1);
ПриВыбореОбъекта();
ВыгрЗаписей=1;
КонецПроцедуры

Процедура ПометитьВсе(Как)
Если Поле.РазмерСписка()=0 Тогда Возврат; КонецЕсли;
Для А=1 По Поле.РазмерСписка() Цикл
Поле.Пометка(А,Как);
КонецЦикла ;
КонецПроцедуры

//----------------- таблица типов------------------
ТЗТ=СоздатьОбъект("ТаблицаЗначений");
ТЗТ.НоваяКолонка("Тип","Строка",50);
ТЗТ.НоваяКолонка("Знач","Число",3,0);
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adBigInt";
ТЗТ.Знач=20;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adBinary";
ТЗТ.Знач=128;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adBoolean";
ТЗТ.Знач=11;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adBSTR";
ТЗТ.Знач=8;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adChapter";
ТЗТ.Знач=136;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adChar";
ТЗТ.Знач=129;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adCurrency";
ТЗТ.Знач=6;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adDate";
ТЗТ.Знач=7;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adDBDate";
ТЗТ.Знач=133;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adDBTime";
ТЗТ.Знач=134;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adDBTimeStamp";
ТЗТ.Знач=135;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adDecimal";
ТЗТ.Знач=14;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adDoublel";
ТЗТ.Знач=5;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adEmpty";
ТЗТ.Знач=0;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adError";
ТЗТ.Знач=10;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adError";
ТЗТ.Знач=10;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adFileTime";
ТЗТ.Знач=64;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adGUID";
ТЗТ.Знач=72;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adIDispatch";
ТЗТ.Знач=9;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adInteger";
ТЗТ.Знач=3;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adIUnknown";
ТЗТ.Знач=13;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adLongVarBinary";
ТЗТ.Знач=205;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adLongVarChar";
ТЗТ.Знач=201;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adLongVarWChar";
ТЗТ.Знач=203;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adNumeric";
ТЗТ.Знач=131;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adPropVariant";
ТЗТ.Знач=138;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adSingle";
ТЗТ.Знач=4;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adSmallInt";
ТЗТ.Знач=2;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adTinyInt";
ТЗТ.Знач=16;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adUnsignedBigInt";
ТЗТ.Знач=21;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adUnsignedInt";
ТЗТ.Знач=19;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adUnsignedSmallInt";
ТЗТ.Знач=18;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adUnsignedTinyInt";
ТЗТ.Знач=17;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adUserDefined";
ТЗТ.Знач=132;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adVarBinary";
ТЗТ.Знач=204;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adVarChar";
ТЗТ.Знач=200;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adVariant";
ТЗТ.Знач=12;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adVarNumeric";
ТЗТ.Знач=139;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adVarWChar";
ТЗТ.Знач=202;
ТЗТ.НоваяСтрока();
ТЗТ.Тип="adWChar";
ТЗТ.Знач=130;

_______________________
И че тут, блин сложного? Для ПРОГГЕРА
48. Александр Рытов (Арчибальд) 02.12.11 17:27
(45) Мысли в посте в основном правильные. Только вот критика как-то не по адресу. Поскольку и hogik, и Abadonna относятся к семерке, восьмерке, и вообще к 1С как к навязанному на воспитание дауну, хотя смотрят на это с разных слегка позиций.
49. Модератор раздела Александр Рытов (Арчибальд) 02.12.11 17:30
(47) Вот забаню тебя, блин, за накрутку стартманей :))
50. Аркадий Кучер (Abadonna) 02.12.11 17:44
(49) Господа модераторы! :)))
Я вчера уж написал (хоть Ирина похохотала) на "причина редактирования" так:
Занимался я сексом в самом извращенном виде с вашими премодерациями!

А старт мани - займитесь, плиз, с ними анальным, т.е. запихайте куда положено
В общем - анализируйте :))))))))))))))))))))
51. Аркадий Кучер (Abadonna) 02.12.11 19:07
(45), (49) Вот из принципа и вредности нашел ту хрень, которая доки создавала в другой базе (бухне) без всяких файлов, OLE и прочей лабуды. Прямой скуль-коннект.
Перем Соединение,ConnectionString,cmd,спрКонтрагенты,спрРС,спрБанки,КонтрДЗНВА1,КонтрДЗНВА2;
Перем сзСтавкиНДС,спрСтавкиНДС,спрБанкСчета,ФирмаУП;

Функция НайтиКонтрагента(п_ИНН)
спрКонтрагенты.ВыбратьЭлементы();
Пока спрКонтрагенты.ПолучитьЭлемент()=1 Цикл
т_ИНН=спрКонтрагенты.ИНН;
Если т_ИНН=п_ИНН Тогда
рд_ТЗ.Контрагент2=спрКонтрагенты.ТекущийЭлемент();
Возврат 1;
КонецЕсли;
КонецЦикла;
// ТЗ.Статус="нет Контрагента";
// Сообщить(Строка(ТЗ.Номер)+": Не найден контрагент");
Возврат 0;
КонецФункции

Функция НайтиПП(п_Пар)
Запрос = СоздатьОбъект("Запрос");

ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с '01.01.2005' по '31.12.2025';
|ОбрабатыватьДокументы все;
|ПП = Документ.ПлатежноеПоручение.ТекущийДокумент;
|Основание = Документ.ПлатежноеПоручение.Основание;
|Группировка Документ;
|Условие(Основание = п_Пар);
|"//}}ЗАПРОС
;

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат ПолучитьПустоеЗначение("Документ.ПлатежноеПоручение");
КонецЕсли;

Док_=ПолучитьПустоеЗначение("Документ.ПлатежноеПоручение");
Пока Запрос.Группировка(1)=1 Цикл
Док_=Запрос.ПП;
КонецЦикла;
Возврат Док_;
КонецФункции


Функция НайтиРС()
спрРС.ИспользоватьВладельца(рд_ТЗ.Контрагент2);
Если спрРС.НайтиПоРеквизиту("Номер",рд_ТЗ.РС,0)=1 Тогда
рд_ТЗ.РасчетныйСчет=спрРС.ТекущийЭлемент();
Возврат 1;
КонецЕсли;
Возврат 0;
КонецФункции

Функция ПолучитьВидПлатежа(пар)
Если пар="8UJ" Тогда
Возврат Перечисление.ВидыПлатежа.Почтой;
ИначеЕсли пар="8UK" Тогда
Возврат Перечисление.ВидыПлатежа.Телеграфом;
ИначеЕсли пар="8UL" Тогда
Возврат Перечисление.ВидыПлатежа.Электронно;
Иначе
Возврат Null;
КонецЕсли;
КонецФункции

Функция ПолучитьАвтоПодст(пар)
Если пар="8VV" Тогда
Возврат Перечисление.ПодстановкаСуммыНДС.СуммаНДС;
ИначеЕсли пар="8VW" Тогда
Возврат Перечисление.ПодстановкаСуммыНДС.БезСуммыНДС;
ИначеЕсли пар="8VW" Тогда
Возврат Перечисление.ПодстановкаСуммыНДС.СуммаБезНДС;
ИначеЕсли пар="8VY" Тогда
Возврат Перечисление.ПодстановкаСуммыНДС.БезСуммыБезНДС;
Иначе
Возврат Null;
КонецЕсли;
КонецФункции

Функция ПолучитьСтавкуНДС(п_Н)
Перем t_str;
Если (п_Н>0) and (п_Н<7) Тогда
Возврат сзСтавкиНДС.Получить(п_Н,t_str);
Иначе
Возврат null;
КонецЕсли;
КонецФункции

Функция ПолучитьБанковскийСчет(п_БС)
спрБанкСчета.ИспользоватьВладельца(ФирмаУП);
Если спрБанкСчета.НайтиПоРеквизиту("Номер",п_БС,0)=1 Тогда
Возврат спрБанкСчета.ТекущийЭлемент();
Иначе
Возврат Null;
КонецЕсли;
КонецФункции

Процедура НайтиКонтрагентов()
спрКонтрагенты.ВыбратьЭлементы();
Пока спрКонтрагенты.ПолучитьЭлемент()=1 Цикл
Если спрКонтрагенты.ПометкаУдаления()=1 Тогда
Продолжить;
КонецЕсли;
Если ПустоеЗначение(спрКонтрагенты.ИНН)=1 Тогда
Продолжить;
КонецЕсли;
Состояние(спрКонтрагенты.Наименование);

т_ИНН=СокрЛП(спрКонтрагенты.ИНН);
Если Прав(т_ИНН,1)="/" Тогда
т_ИНН=Лев(т_ИНН,СтрДлина(т_ИНН)-1);
КонецЕсли;

рд_ТЗ.ВыбратьСтроки();
Пока рд_ТЗ.ПолучитьСтроку()=1 Цикл
Если ПустоеЗначение(рд_ТЗ.Контрагент2)=0 Тогда
Продолжить;
КонецЕсли;
Если т_ИНН=СокрЛП(рд_ТЗ.ИНН) Тогда
рд_ТЗ.Контрагент2=спрКонтрагенты.ТекущийЭлемент();
Если НайтиРС()=0 Тогда
рд_ТЗ.Контрагент2=Null;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЦикла;

спрКонтрагенты.ВыбратьЭлементы();
Пока спрКонтрагенты.ПолучитьЭлемент()=1 Цикл
Если спрКонтрагенты.ПометкаУдаления()=1 Тогда
Продолжить;
КонецЕсли;
Если ПустоеЗначение(спрКонтрагенты.ИНН)=1 Тогда
Продолжить;
КонецЕсли;
Состояние(спрКонтрагенты.Наименование);
рд_ТЗ.ВыбратьСтроки();
Пока рд_ТЗ.ПолучитьСтроку()=1 Цикл
Если ПустоеЗначение(рд_ТЗ.Контрагент2)=0 Тогда
Продолжить;
КонецЕсли;
н_ИНН=Найти(рд_ТЗ.ИНН,"/");

Если н_ИНН=0 Тогда
т_ИНН=СокрЛП(рд_ТЗ.ИНН);
Иначе
н_ИНН=н_ИНН-1;
т_ИНН=Лев(рд_ТЗ.ИНН,н_ИНН);
КонецЕсли;

Если СокрЛП(спрКонтрагенты.ИНН1)=т_ИНН Тогда
рд_ТЗ.Контрагент2=спрКонтрагенты.ТекущийЭлемент();
Если НайтиРС()=0 Тогда
рд_ТЗ.Контрагент2=Null;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЦикла;
КонецПроцедуры

Процедура Сформировать()
Перем стр;
Попытка
Если Соединение.State=0 Тогда
Соединение.Открыть(ConnectionString);
КонецЕсли;
Исключение
Предупреждение("Невозможно установить соединение");
КонецПопытки;
рд_ТЗ.УдалитьСтроки();
Cmd.ActiveConnection = Соединение;
Cmd.CommandText ="Select Дата_time_iddoc, substring(_1sjourn.Дата_TIME_IDDOC,1,8) as DataDoc,_1sjourn.DOCNO,
| sc97.sp73 as BankS4et, sc133.sp122 as KontrNaim, sc133.sp126 as INN,sc174.sp159 as Ras4etnyS4et,
| cast(sp12059 as char) as summa,cast(sp12061 as char) as nds, sp12060 as StavkaNDS,
| sp12063 as SrokPlatezha, sp12066 as Soderzhanie, sp12062 as VidPlatezha, cast(sp12064 as char) as O4erednost,
| sp12065 as AvtoPodst, cast(sp37063 as char) as PerNaloga, sp37064 as StatusSost, sp37065 as KodBK, sp37066 as KodOKATO,
| sp37067 as PokOsnovanija, sp37068 as PokPerioda, sp37069 as PokNomera, sp37070 as PokDaty,sp37071 as PokTipa,
| sp475 as Kom
| from dh12070 as d Лев outer join _1sjourn on d.idDOC=_1sjourn.IDDOC
| Лев outer join sc174 on d.sp12068=sc174.id
| Лев outer join sc133 on d.sp12058=sc133.id
| Лев outer join sc97 on d.sp12057=sc97.id
| where _1sjourn.isMark=0 and substring(_1sjourn.Дата_TIME_IDDOC,1,8)>='"+Формат(НачДата,"DYYYYMMDD")+"' and substring(_1sjourn.Дата_TIME_IDDOC,1,8)<='"+Формат(КонДата,"DYYYYMMDD")+"'";


Rs = СоздатьОбъект("ADODB.RecordSet");
Rs = Cmd.Выполнить;
Если rs.ВКонце()=0 Тогда
Ном=0;
Rs.MoveFirst();
Пока Rs.ВКонце() = 0 Цикл
рд_ТЗ.НоваяСтрока();
Ном=Ном+1;
рд_ТЗ.Номер=ном;
рд_ТЗ.IDDOC=Rs.Fields("Дата_time_iddoc").Значение;
рд_ТЗ.ДатаДок=Rs.Fields("DataDoc").Значение;
рд_ТЗ.НомерДок=Rs.Fields("DOCNO").Значение;
рд_ТЗ.Сумма=Rs.Fields("summa").Значение;
рд_ТЗ.НДС=Rs.Fields("nds").Значение;
рд_ТЗ.СтавкаНДС=Rs.Fields("StavkaNDS").Значение;
рд_ТЗ.СрокПлатежа=Rs.Fields("SrokPlatezha").Значение;
рд_ТЗ.РС=Rs.Fields("Ras4etnyS4et").Значение;
рд_ТЗ.Контрагент=Rs.Fields("KontrNaim").Значение;
рд_ТЗ.ИНН=Rs.Fields("INN").Значение;
рд_ТЗ.БС=Rs.Fields("BankS4et").Значение;
рд_ТЗ.БанковскийСчет=ПолучитьБанковскийСчет(рд_ТЗ.БС);
рд_ТЗ.СтавкаНДС=ПолучитьСтавкуНДС(Число(Rs.Fields("StavkaNDS").Значение));
рд_ТЗ.СрокПлатежа=?(ДатаГод(рд_ТЗ.СрокПлатежа)=1753,ПолучитьПустоеЗначение(),рд_ТЗ.СрокПлатежа);
рд_ТЗ.Содержание=Rs.Fields("Soderzhanie").Значение;
рд_ТЗ.ВидПлатежа=ПолучитьВидПлатежа(СокрЛП(Rs.Fields("VidPlatezha").Значение));
рд_ТЗ.Очередность=Rs.Fields("O4erednost").Значение;
рд_ТЗ.АвтоПодст=ПолучитьАвтоПодст(СокрЛП(Rs.Fields("AvtoPodst").Значение));
рд_ТЗ.ПеречислениеНалога=Rs.Fields("PerNaloga").Значение;
рд_ТЗ.СтатусСоставителяПлДок=Rs.Fields("StatusSost").Значение;
рд_ТЗ.КодБК=Rs.Fields("KodBK").Значение;
рд_ТЗ.КодОКАТО=Rs.Fields("KodOKATO").Значение;
рд_ТЗ.ПоказательОснования=Rs.Fields("PokOsnovanija").Значение;
рд_ТЗ.ПоказательПериода=Rs.Fields("PokPerioda").Значение;
рд_ТЗ.ПоказательНомера=Rs.Fields("PokNomera").Значение;
рд_ТЗ.ПоказательДаты=Rs.Fields("PokDaty").Значение;
рд_ТЗ.ПоказательДаты=?(ДатаГод(рд_ТЗ.ПоказательДаты)=1753,ПолучитьПустоеЗначение(),рд_ТЗ.ПоказательДаты);
рд_ТЗ.ПоказательТипа=Rs.Fields("PokTipa").Значение;
рд_ТЗ.Комментарий=Rs.Fields("Kom").Значение;
рд_ТЗ.ПП=НайтиПП("УП"+рд_ТЗ.IDDOC);
рд_ТЗ.Выбор=1;
Rs.MoveNext();
КонецЦикла;
КонецЕсли;
Rs.Close();
Соединение.Close();
НайтиКонтрагентов();
КонецПроцедуры

Процедура ПриОткрытии()
спрКонтрагенты=СоздатьОбъект("Справочник.Контрагенты");
спрРС=СоздатьОбъект("Справочник.РасчетныеСчета");
спрБанкСчета=СоздатьОбъект("Справочник.БанковскиеСчета");
спрСтавкиНДС=СоздатьОбъект("Справочник.СтавкиНДС");

сзСтавкиНДС=СоздатьОбъект("СписокЗначений");
спрСтавкиНДС.НайтиПоКоду(2);
сзСтавкиНДС.ДобавитьЗначение(спрСтавкиНДС.ТекущийЭлемент());
спрСтавкиНДС.НайтиПоКоду(3);
сзСтавкиНДС.ДобавитьЗначение(спрСтавкиНДС.ТекущийЭлемент());
спрСтавкиНДС.НайтиПоКоду(1);
сзСтавкиНДС.ДобавитьЗначение(спрСтавкиНДС.ТекущийЭлемент());
спрСтавкиНДС.НайтиПоКоду(4);
сзСтавкиНДС.ДобавитьЗначение(спрСтавкиНДС.ТекущийЭлемент());
спрСтавкиНДС.НайтиПоКоду(5);
сзСтавкиНДС.ДобавитьЗначение(спрСтавкиНДС.ТекущийЭлемент());
спрСтавкиНДС.НайтиПоКоду(6);
сзСтавкиНДС.ДобавитьЗначение(спрСтавкиНДС.ТекущийЭлемент());

спрФирмы=СоздатьОбъект("Справочник.Фирмы");
Если спрФирмы.НайтиПоКоду(3)=1 Тогда
ФирмаУП=спрФирмы.ТекущийЭлемент();
Иначе
Сообщить("Error");
Возврат;
КонецЕсли;
НачДата=РабочаяДата();
КонДата=РабочаяДата();


рд_ТЗ.НоваяКолонка("Выбор","Число",3,0, "Выбор",3,);
рд_ТЗ.НоваяКолонка("Номер","Число",3,0, "№",3,);
рд_ТЗ.НоваяКолонка("ПП","Документ.ПлатежноеПоручение",,,"ПлатежноеПоручение",8);
рд_ТЗ.НоваяКолонка("ДатаДок","Дата",8,0,"ДатаДок",10);
рд_ТЗ.НоваяКолонка("НомерДок","Строка",8,0,"НомерДок",8);
рд_ТЗ.НоваяКолонка("Контрагент","Строка",50,0,"Контрагент",50);
рд_ТЗ.НоваяКолонка("ИНН","Строка",20,0,"ИНН",20);
рд_ТЗ.НоваяКолонка("Контрагент2","Справочник.Контрагенты",50,0,"Контрагент в БД",50);
рд_ТЗ.НоваяКолонка("РасчетныйСчет","Справочник.РасчетныеСчета",50,0,"РасчетныеСчета",50);
// рд_ТЗ.НоваяКолонка("КПП","Строка",9,0,"КПП",11);
рд_ТЗ.НоваяКолонка("РС","Строка",20,0,"р/с",25);
рд_ТЗ.НоваяКолонка("БС","Строка",20,0,"б/с",25);
рд_ТЗ.НоваяКолонка("БанковскийСчет","Справочник.БанковскиеСчета",,,"Банковский Счет",30);
рд_ТЗ.НоваяКолонка("Сумма","Число",13,2,"Сумма",12);
рд_ТЗ.НоваяКолонка("НДС","Число",13,2,"НДС",10);
рд_ТЗ.НоваяКолонка("СтавкаНДС","Справочник.СтавкиНДС",,,"СтавкаНДС",15);
рд_ТЗ.НоваяКолонка("ВидПлатежа","Перечисление.ВидыПлатежа",,,"Вид платежа",9);
рд_ТЗ.НоваяКолонка("СрокПлатежа","Дата",8,0,"Срок платежа",8);
рд_ТЗ.НоваяКолонка("Очередность","Число",1,0,"Очередность",1);
рд_ТЗ.НоваяКолонка("АвтоПодст","Перечисление.ПодстановкаНДС",,,"АвтоПодст",9);
рд_ТЗ.НоваяКолонка("ПеречислениеНалога","Число",1,0,"ПеречислениеНалога",1);
рд_ТЗ.НоваяКолонка("СтатусСоставителяПлДок","Строка",2,,"СтатусСоставителяПлДок",2);
рд_ТЗ.НоваяКолонка("КодБК","Строка",20,,"КодБК",20);
рд_ТЗ.НоваяКолонка("КодОКАТО","Строка",11,,"КодОКАТО",11);
рд_ТЗ.НоваяКолонка("ПоказательОснования","Строка",2,,"ПоказательОснования",2);
рд_ТЗ.НоваяКолонка("ПоказательПериода","Строка",10,,"ПоказательПериода",10);
рд_ТЗ.НоваяКолонка("ПоказательНомера","Строка",18,,"ПоказательНомера",18);
рд_ТЗ.НоваяКолонка("ПоказательДаты","Дата",,,"ПоказательДаты",8);
рд_ТЗ.НоваяКолонка("ПоказательТипа","Строка",2,,"ПоказательТипа",2);
рд_ТЗ.НоваяКолонка("IDDOC","Строка",29,,"IDDOC",29);


рд_ТЗ.НоваяКолонка("Содержание","Строка",,0,"Содержание",100);
рд_ТЗ.НоваяКолонка("Комментарий","Строка",,0,"Комментарий",100);
рд_ТЗ.ВыводитьПиктограммы(1,1);

Соединение = СоздатьОбъект("ADODB.Connection");
Cmd = СоздатьОбъект("ADODB.Command");
ConnectionString = "Provider=SQLOLEDB.1;Password=password1C;Persist Security Info=True;User ID=login1C;Initial Catalog=sales;Data Source=SQLSERVER";
Соединение.ConnectionTimeOut =30;
Соединение.CursorLocation = 3;
КонецПроцедуры

Процедура ВыбратьВсе()
//ТЗ.ВыбратьСтроки();
//Пока ТЗ.ПолучитьСтроку()=1 Цикл
// Если (СокрЛП(ТЗ.Статус)="готово к переносу") Тогда
// ТЗ.Выбор=?((ТЗ.Выбор=1),2,1);
// Иначе
// ТЗ.Выбор=1;
// КонецЕсли;
//
//КонецЦикла;
//
рд_ТЗ.Заполнить(2,,,"Выбор");
КонецПроцедуры

Процедура ОтменитьВсе()
рд_ТЗ.Заполнить(1,,,"Выбор");
КонецПроцедуры

Процедура ПометитьСтроку()
Если рд_ТЗ.ТекущаяКолонка()="Контрагент2" Тогда
ОткрытьФорму(рд_ТЗ.Контрагент2,,1);

ИначеЕсли рд_ТЗ.ТекущаяКолонка()="РасчетныйСчет" Тогда
ОткрытьФорму(рд_ТЗ.РасчетныйСчет,,1);
Иначе
рд_ТЗ.Выбор=?((рд_ТЗ.Выбор=1),2,1);
КонецЕсли;
//Если (СокрЛП(ТЗ.Статус)="готово к переносу") Тогда
// ТЗ.Выбор=?((ТЗ.Выбор=1),2,1);
//ИначеЕсли (СокрЛП(ТЗ.Статус)="нет р/с") Тогда
// ДобавитьРС(ТЗ.Контрагент2);
// Если НайтиКонтрагента(СокрЛП(ТЗ.ИНН),СокрЛП(ТЗ.КПП))=1 Тогда
// ТЗ.Выбор=2;
// Иначе
// ТЗ.Выбор=1;
// КонецЕсли;
//ИначеЕсли (СокрЛП(ТЗ.Статус)="нет Контрагента") Тогда
// ДобавитьКонтр();
// Если НайтиКонтрагента(СокрЛП(ТЗ.ИНН),СокрЛП(ТЗ.КПП))=1 Тогда
// ТЗ.Выбор=2;
// Иначе
// ТЗ.Выбор=1;
// КонецЕсли;
//Иначе
// ТЗ.Выбор=1;
//КонецЕсли;
КонецПроцедуры

Процедура СоздатьПП()
рд_ТЗ.ВыбратьСтроки();
Пока рд_ТЗ.ПолучитьСтроку()=1 Цикл
Если рд_ТЗ.Выбор=2 Тогда
Если ПустоеЗначение(рд_ТЗ.Контрагент2)=1 Тогда
Сообщить("Не найден контрагент");
Продолжить;
КонецЕсли;
Если ПустоеЗначение(рд_ТЗ.БанковскийСчет)=1 Тогда
Сообщить("Не найден Банковский счет");
Продолжить;
КонецЕсли;

Если ПустоеЗначение(рд_ТЗ.РасчетныйСчет)=1 Тогда
Сообщить("Не найден Расчетный счет");
Продолжить;
КонецЕсли;

Если ПустоеЗначение(рд_ТЗ.ПП)=0 Тогда
Сообщить("Платежное Поручение "+Строка(рд_ТЗ.ПП)+"уже есть");
Продолжить;
КонецЕсли;

ДокПП=СоздатьОбъект("Документ.ПлатежноеПоручение");
НД=Строка(Число(рд_ТЗ.НомерДок));
Если СтрДлина(НД)>6 Тогда
Сообщить("Слишком длинный номер");
Продолжить;
КонецЕсли;

ДокПП.Новый();
глВводНового(ДокПП);

ДокПП.НомерДок="УП"+НД;
ДокПП.ДатаДок=рд_ТЗ.ДатаДок;
ДокПП.Фирма=ФирмаУП;
ДокПП.Основание="УП"+рд_ТЗ.IDDOC;;


ДокПП.РасчетныйСчет = рд_ТЗ.БанковскийСчет;
ДокПП.Контрагент=рд_ТЗ.Контрагент2;
ДокПП.Сумма=рд_ТЗ.Сумма;
ДокПП.СтавкаНДС=рд_ТЗ.СтавкаНДС;
ДокПП.ВидПлатежа = рд_ТЗ.ВидПлатежа;
ДокПП.СрокПлатежа = рд_ТЗ.СрокПлатежа;
ДокПП.Очередность = рд_ТЗ.Очередность;
ДокПП.АвтоПодстСуммыНДС = рд_ТЗ.АвтоПодст;
ДокПП.Содержание = рд_ТЗ.Содержание;
ДокПП.СчетКонтрагента = рд_ТЗ.РасчетныйСчет;
ДокПП.ПеречислениеНалога = рд_ТЗ.ПеречислениеНалога;
ДокПП.СтатусСоставителяПлДок = рд_ТЗ.СтатусСоставителяПлДок;
ДокПП.КодБК = рд_ТЗ.КодБК;
ДокПП.КодОКАТО = рд_ТЗ.КодОКАТО;
ДокПП.ПоказательОснования = рд_ТЗ.ПоказательОснования;
ДокПП.ПоказательПериода = рд_ТЗ.ПоказательПериода;
ДокПП.ПоказательНомера = рд_ТЗ.ПоказательНомера;
ДокПП.ПоказательДаты = рд_ТЗ.ПоказательДаты;
ДокПП.ПоказательТипа = рд_ТЗ.ПоказательТипа;
ДокПП.Комментарий = рд_ТЗ.Комментарий;
ДокПП.НомерДляБанка= НД;

Если глПриЗаписи(ДокПП)=0 Тогда
Возврат;
КонецЕсли;

ДокПП.Записать();
Сообщить(Строка(рд_ТЗ.Номер)+": ПлатежноеПоручение создано №"+Строка(ДокПП.НомерДок));
рд_ТЗ.Выбор=1;
рд_ТЗ.ПП=ДокПП.ТекущийДокумент();
КонецЕсли;
КонецЦикла
КонецПроцедуры

Процедура ОбновитьПП()
рд_ТЗ.ВыбратьСтроки();
Пока рд_ТЗ.ПолучитьСтроку()=1 Цикл
Если рд_ТЗ.Выбор=2 Тогда
ДокПП=СоздатьОбъект("Документ.ПлатежноеПоручение");
Если ПустоеЗначение(рд_ТЗ.ПП)=1 Тогда
Сообщить("Платежное Поручение не найдено");
Продолжить;
КонецЕсли;
Если ПустоеЗначение(рд_ТЗ.Контрагент2)=1 Тогда
Сообщить("Не найден контрагент");
Продолжить;
КонецЕсли;
Если ПустоеЗначение(рд_ТЗ.БанковскийСчет)=1 Тогда
Сообщить("Не найден Банковский счет");
Продолжить;
КонецЕсли;

Если ПустоеЗначение(рд_ТЗ.РасчетныйСчет)=1 Тогда
Сообщить("Не найден Расчетный счет");
Продолжить;
КонецЕсли;
НД=Строка(Число(рд_ТЗ.НомерДок));
Если СтрДлина(НД)>6 Тогда
Сообщить("Слишком длинный номер");
Продолжить;
КонецЕсли;
Если ДокПП.НайтиДокумент(рд_ТЗ.ПП)=1 Тогда
ДокПП.НомерДок="УП"+НД;
ДокПП.ДатаДок=рд_ТЗ.ДатаДок;
ДокПП.Фирма=ФирмаУП;
ДокПП.Основание="УП"+рд_ТЗ.IDDOC;


ДокПП.РасчетныйСчет = рд_ТЗ.БанковскийСчет;
ДокПП.Контрагент=рд_ТЗ.Контрагент2;
ДокПП.Сумма=рд_ТЗ.Сумма;
ДокПП.СтавкаНДС=рд_ТЗ.СтавкаНДС;
ДокПП.ВидПлатежа = рд_ТЗ.ВидПлатежа;
ДокПП.СрокПлатежа = рд_ТЗ.СрокПлатежа;
ДокПП.Очередность = рд_ТЗ.Очередность;
ДокПП.АвтоПодстСуммыНДС = рд_ТЗ.АвтоПодст;
ДокПП.Содержание = рд_ТЗ.Содержание;
ДокПП.СчетКонтрагента = рд_ТЗ.РасчетныйСчет;
ДокПП.ПеречислениеНалога = рд_ТЗ.ПеречислениеНалога;
ДокПП.СтатусСоставителяПлДок = рд_ТЗ.СтатусСоставителяПлДок;
ДокПП.КодБК = рд_ТЗ.КодБК;
ДокПП.КодОКАТО = рд_ТЗ.КодОКАТО;
ДокПП.ПоказательОснования = рд_ТЗ.ПоказательОснования;
ДокПП.ПоказательПериода = рд_ТЗ.ПоказательПериода;
ДокПП.ПоказательНомера = рд_ТЗ.ПоказательНомера;
ДокПП.ПоказательДаты = рд_ТЗ.ПоказательДаты;
ДокПП.ПоказательТипа = рд_ТЗ.ПоказательТипа;
ДокПП.Комментарий = рд_ТЗ.Комментарий;
ДокПП.НомерДляБанка= НД;

Если глПриЗаписи(ДокПП)=0 Тогда
Возврат;
КонецЕсли;

ДокПП.Записать();
Сообщить(Строка(рд_ТЗ.Номер)+": Платежное поручение исправлено №"+Строка(ДокПП.НомерДок));

КонецЕсли;
рд_ТЗ.Выбор=1;
КонецЕсли;
КонецЦикла

КонецПроцедуры

P.S. Кое-где мой переводчик на русский (были команды 1С на англ.) перестарался: заменил на русские аналоги и в скуль-командах
52. Владимир (hogik) 02.12.11 19:38
(46)
Аркадий.
Думаю, что фраза "замещающий 1С-сервер"(с) из (45) сообщения относится к "восьмерке".
А ты представил в (47) фрагмент программы из какой платформу? :-)
53. Аркадий Кучер (Abadonna) 02.12.11 19:42
(52) Какая разница из какой программы вызывать ADODB и строить там прямой скуль-запрос? Да хоть из бейсика!
Главное же - сам текст скуль-запроса, а вот для этого надо хотя бы ненамного стать не "чистым одноэснегом"
Как говорил Архимед:
Дайте мне логин-пароль к вашему скуль-серверу и я поставлю вашу базу 1С раком

;)
54. Аркадий Кучер (Abadonna) 02.12.11 19:54
+(53) Кстати, вот как 8-ка может уже последних навыков лишить. Семерочники хотя бы слегка представляли как и что в SQL хранится, а восьмерочники уже прикрылись занавеской под именем "1С-сервер"
55. Игорь Исхаков (Ish_2) 02.12.11 19:57
(49) Господин Модератор.

Это обращение прошу считать официальным доносом.
Пользователь Абадонна в (51) намеренно и нагло дискредитирует идею монетизации-профессионализации портала.
Прошу снять с счета пользователя Абадонна 1$m. В пользу доносчика.
56. Аркадий Кучер (Abadonna) 02.12.11 19:58
(55) А тебе оно зачем? Могу и так подарить, только не знаю КАК :)))
57. Игорь Исхаков (Ish_2) 02.12.11 19:59
(56) Не мешай. Я хочу добиться официальной реакции. И публичного снятия 1$m.
58. Аркадий Кучер (Abadonna) 02.12.11 20:00
(57)
Я хочу добиться официальной реакции.

Добейся лучше эрекции и займись более приятным делом, чем доносы :))))))))))
59. Игорь Исхаков (Ish_2) 02.12.11 20:02
(58) Ты в доносах ничего не понимаешь.
Тут, как и в эрекции, нужна твердость.
60. Аркадий Кучер (Abadonna) 02.12.11 20:10
(59) В доносах помимо твердости еще и точность нужна.
Нагло дискредитирую я не в (51), а в (50). Бе-бе-бе
А чтобы ты нагло не подправил задним числом, вот скрин
Так что:
Господин Модератор! Прошу привлечь за клевету пользователя Ish_2
:))))))))))
Прикрепленные файлы:
61. Игорь Исхаков (Ish_2) 02.12.11 22:12
(60) Меня не было 2 часа по уважительной причине. Я не испугался вовсе ,а ходил в туалет.

И теперь решительно настаиваю что нарушение в (51). Длинный пост позволил тебе заработать много $m.
Доносчику должен достаться первый старт-мани. Официально.
62. Алекс Ю (AlexO) 02.12.11 22:13
(52) hogik,
все правильно ))
Abadonna, вы так рьяно защищаете восьмерку, и ругаете семерку, что приводите примеры "прямых обращений к SQL" в защиту ВОСЬМЕРКИ прямиком из семерки ))
Где примеры создания документов напрямую в SQL из восьмерки?
Именно, что вы, возможно, глубоко не копались, оставшись с семеркой и SQL, поэтому вы упустили полную смену идеологии при переходе семерка-восьмерка.
Возможно, что упустили и новую смену перехода 8.1-8.2.
В семерке все данные - в доках. Это - основное хранилище.
В восьмерке все данные - в регистрах. В доках ничего не хранится, вернее, хранятся ссылки на таблицы доков, запутанные до невозможности.
Собственно, из-за перекручивания и переверчивания таблиц доков в восьмерке быстрее получать данные из регистров напрямую, для чего была придумана двойная запись - сначала оформляем в доках, потом - пихаем по всяческим регистрам, причем доходит до абсурда: новый разрез/отчет - требуется новый регистр, т.к. старый замусорен до невозможности обслуживанием множества документов, да еще и не содержит нужной аналитики/привязки-ссылки-объекта.
Мне эта система крайне не нравится, потому что в конечном итоге обслуживает только себя.
И если в SQL таблицы (порой избыточные, с ключами, индексами) служат для максимального управления и наибыстрейшего доступа к данным, то в 1С погнали прочь всю выпестованную десятилетиями иделогию хранения данных, и решили, что знают лучше, КАК хранить данные, вынеся порядок, простоту и четкость за скобки своей платформы.
И вы, Abadonna, в порыве игры своими знаниями, то и дело подменяете 1с-ку - эскуэлем, внутренне хранение 1с - внешним хранением где только удобней, и т.д.
Т.е. понятно ваше стремление выстроить стройную и "работоспособную" картину максимального эффекта от использования компьютера для целей обработки данных, однако, во многомиллионодолларовых СУБД (тот же оракл - конфетка при обработке и жонглировании десятками и сотнями миллионов записей) все давно уже решено, связано и сдано под ключ.
А пеньки к гнилому забору так и останутся пеньками, а забор все равно падает периодически до нового пинка и пенька.
63. Аркадий Кучер (Abadonna) 02.12.11 22:13
(61) А они там еще и буковки считают? :)))
Заставь... богу молиться....
64. Аркадий Кучер (Abadonna) 02.12.11 22:17
(62) Если ты так плохо видишь, продублирую:
(52) Какая разница из какой программы вызывать ADODB и строить там прямой скуль-запрос? Да хоть из бейсика!
Главное же - сам текст скуль-запроса, а вот для этого надо хотя бы ненамного стать не "чистым одноэснегом"
Как говорил Архимед:
Цитата
Дайте мне логин-пароль к вашему скуль-серверу и я поставлю вашу базу 1С раком

;)

Мне глубоко фиолетово, где и что хранит 1С. Раз хранит в скуле, я это оттуда достану. А как там себе одноэснеги это называют хоть "регистры", хоть "@уитсры" мне по барабану. Надо будет - все достану.
Я в советское время время джинсы "достать" умел, а уж тут то... :)))
65. Алекс Ю (AlexO) 02.12.11 22:22
(64) Abadonna,
в 8-ке главное - не достать, а понять, что ты достал, и правильно это интепретировать.
В том и дело, что подменяешь реляционное структурированное хранение SQL - безобразием 1с, по недоразумению хранящемуся в скуле.
Помни, что SQL сервер только СОБИРАЕТ все данные кучей, а обрабатывает их уже - 1с сервер.
А сиквел только так используется, подай-принеси, "кушать подано!" и "кони запряжены!"....
66. Аркадий Кучер (Abadonna) 02.12.11 22:25
(65)Вот я спокойно без прокладки и обойдусь.
Еще раз повторю: если надо будет, я сам скулю дам команды "кушать подать" и "коней запрячь".
Только на фиг мне это надо в 8-ке, если там и так приличный язык запросов? Про что я и талдычу постоянно апологетам семерки.
67. Алекс Ю (AlexO) 02.12.11 22:30
(66) Abadonna,
вы опять путаете T-SQL и нечто, похожее от него (только похожее) от 1с.
Abadonna, вы меня пугаете... своей шашко-махалкой и постоянными резкими взмахами ребром ладони ))
Или вы все-таки серьезно изучаете 8-ку, или не ругаете семерку.... по-крайней мере, по вопросам функциональности ))
68. Аркадий Кучер (Abadonna) 02.12.11 22:33
(67) Всякую одноэсовскую хрень я изучаю ровно настолько, чтобы она позволяла мне зарабатывать деньги.
В данном случаев моего знания восьмерки мне хватает. А для души - совсем другое программирование.
69. Алексей Константинов (alexk-is) 02.12.11 22:33
70. Ийон Тихий (cool.vlad4) 02.12.11 22:37
если я правильно понял - то утверждение такое, если надо, напишу 1С, но поскольку 1С 8.2 - это неплохой 1С, то не надо. Ну, как бы да, наверное)))
71. Алекс Ю (AlexO) 02.12.11 22:38
(68) Abadonna,
вот с этим соглашусь ))
только у 1с как всегда - даже хрень на хрень не похожа: хрень№1, хрень№2 и хрень№3 - три разных хрени на разных платформах (причем каждая претендовала на исключительность и Матрица.Революция), и все ни на йоту не приблизились к серьезному понимаю хранения данных в рамках неймановской архитектуры....
72. Ийон Тихий (cool.vlad4) 02.12.11 22:40
(67) да, ничего он не путает... разницу ORM и запросов к БД, - я думаю, всяко каждый знает...преувеличивает, пожалуй...
73. Алекс Ю (AlexO) 02.12.11 22:41
(70) cool.vlad4,
ну да, Abadonna так и говорит - "получу что угодно и запишу что угодно в скуль", причем все помимо 1с-сервера...
я уже отчаялся получить от апологетов СЕМЕРОШНОГО олдскуливания примеры прямой записи в базы SQL из 8-ки..
хотя на инфорстарте немало защитников "да все можно!".
Анархия, короче, это, а не программирование ... ))
74. Аркадий Кучер (Abadonna) 02.12.11 22:42
(72)
преувеличивает, пожалуй...

Не преувеличиваю, а просто утрирую. Для ясности
75. Ийон Тихий (cool.vlad4) 02.12.11 22:42
(71) а кто сказал, что их цель - приближение к пониманию хранения в рамках фон неймановской архитектуры?))) бабло постричь, да отряд накормить, на том и живем
76. Алекс Ю (AlexO) 02.12.11 22:44
(72) cool.vlad4,
если бы в носу росли грибы была прямая запись в SQL из 8-ки, то не пришлось бы оплачивать схему клиентские лицензии-сервер 1с-сервер SQL, а только - клиенты и СУБД.
И снятие половины проблем с БД от 1с.
77. Ийон Тихий (cool.vlad4) 02.12.11 22:47
(76) а что такое прямая запись? если запросы реляционные, то Abadonna показал как, ежели имеется виду пристройка объектная 1С, то это и есть 1С, за это они бабки и просят
78. Аркадий Кучер (Abadonna) 02.12.11 22:49
Кстати, а где вообще прозвучало, что я собрался что-то напрямую в базу записывать?
Лично меня хранение/обработка информации в скуль базах вполне устраивает, я тебе там хоть черта лысого сохраню.

Это раз.
Насчет прямой записи: опять таки не вижу смысла писать в базу 1С, а вот из той же 8-ки писать в стороннюю скуль-базу очень даже полезно иногда. Кучу доп. инфы можно хранить, не загружая рабочую.
То же версионирование объектов, например.
79. Алекс Ю (AlexO) 02.12.11 22:55
(77) cool.vlad4,
это семерка...
где восьмерка тут мимо проходила??
(78) Abadonna,
а это совсем другая история ))
чем же не устраивает версифицирование в 1с8 не устраивет? а? ))
а тем, что много чего в 8-ке не устраивает, и оставалась бы вся эта 1с в рамках бухбазы, и огородить проволокой колючей..
80. Игорь Исхаков (Ish_2) 02.12.11 22:58
(62)
В восьмерке все данные - в регистрах. В доках ничего не хранится, вернее, хранятся ссылки на таблицы доков, запутанные до невозможности.
Собственно, из-за перекручивания и переверчивания таблиц доков в восьмерке быстрее получать данные из регистров напрямую, для чего была придумана двойная запись - сначала оформляем в доках, потом - пихаем по всяческим регистрам,


Дальше читать не смог..

Начну осторожно :
"В восьмерке все данные - в регистрах. В доках ничего не хранится, вернее, хранятся ссылки на таблицы доков.."
Что имеется ввиду ? Как это "не хранится" ?
Документ есть совокупность записей различных таблиц SQL.
Регистр есть совокупность таблиц SQL. Доступ к информации таблиц осуществляется при помощи запросов SQL.
Информация извлекается как из регистров , так и из документов (суть таблиц SQL).

"в доках ничего не хранится "- Не могу-у-у-у...
81. Аркадий Кучер (Abadonna) 02.12.11 22:58
(79) Я не понял.. Ты меня за 8-ку агитируешь? А топик "Ура! 77 каюк" чей?
82. Ийон Тихий (cool.vlad4) 02.12.11 23:00
(79) чего семерка? честно, влом читать всю ветку, но смысл сказанного мной не меняется, хоть 7-ка, хоть 8-ка, - дело тут не в можешь, не можешь, не в красиво, некрасиво, а в том, что есть задачи, есть решения от 1С в виде конфигураций типовых, нате пользуйтесь, али меняйте, или новые пишите. Все это здорово экономит время<->деньги, а чего там неправильно, так оно везде неправильно, правильность она только для правильных, а мы все неправильные.
83. Аркадий Кучер (Abadonna) 02.12.11 23:04
чем же не устраивает версифицирование в 1с8 не устраивет? а?

Если бы я был обычный "одноэснег" меня бы все устраивало и спасибы за Миракл мне не писали.
И пользовался я бы убогими рабочими столами от 8.2, а не своим, с красивыми кнопками, на лету перестраивающимся, под каждого юзверя подстраивающимся. И печати народ бы в фотошопе (краденном!) обрабатывал.
Так что меня до фига чего не устраивает. Только, в отличие от других, я это не ругаю, а решаю проблемы. Под себя, любимого
84. Игорь Исхаков (Ish_2) 02.12.11 23:16
(69) Ты официально мне перечислил 1$m или просто по доброте душевной ?
А где публичное осуждение Абадонны ?
85. Алекс Ю (AlexO) 02.12.11 23:24
(80) Ish_2,
это вы со мной спорить будете?
ну давайте.. раз вам посприть дешевле, чем истину искать ))
>>Что имеется ввиду ? Как это "не хранится" ?
а так. Вы много по документам в 8-ке данные собираете? как часто, и во что вам это обходится?
в доках 1с8 не хранится НИЧЕГО, все в таблицах SQL при посредничестве барыги-монополиста-мафиози 1с-сервера...
>>Документ есть совокупность записей различных таблиц SQL.
есть совокупность. Только не "прямых" таблиц, а пропущенных через мясорубку 1с. Которая на выходе дает винегрет такой, что 1с-ники сами и ввели регистры и полную обработку всех данных по регистрам.
>>Регистр есть совокупность таблиц SQL.
да, логическое хранение записей в регистрах - это уже ближе к таблицам SQL. Так и везде и всюду в 8.х используются регистры... без этого - вообще 1с8 не полетела бы дальше ларька на три пользователя.
Попробуйте хоть одновременный доступ и работу пользователей к файловой базе - это аналог доступа к "чистой и незамутненной" никакими SQL-ми 1с8...
а уж нюанс, что 1с ставит как цель своего "развития" в области хранения функционал SQL, умиляется и превозносит в себе то, что в SQL уже давно реализовано - остается как-бы за кадром...
>>Доступ к информации таблиц осуществляется при помощи запросов SQL.
- информация в 1С8 (выделяю, а то многие уже начали путать 1с7 с 1с8) осуществляется при помощи 1с-сервера, осуществляющего запросы SQL. Равно как и чтение - по обратной схеме.
>>Информация извлекается как из регистров, так и из документов (суть таблиц SQL).
извлекается. да.
только либо с мучениями, либо немного побыстрей. И никак - вне 1с-сервера.
вам, как восьмерошнику, это прекрасно известно.
И документы в 1с - это не суть таблицы sql, а суть документы 1с, использующие ссылки, обрабатываемые 1с-сервером, на данные, хранящиеся в таблицах SQL.
Равно как и регистры 1с - это регистры в 1с-архитектуре, а не таблицы SQL. Другое дело, что в регистры 1с логически более приближены к таблицам SQL (а точнее, к реляционной СУБД - множеством таблиц, связанных между собой одним или несколькими полями-ключами и служебными полями-индексаторами; сравните документы 1с - таблицы, связанные между собой ЯЧЕЙКАМИ-ссылками (ссылка на сам документ-регистратор, e.c.), что позволяет ускорить их обработку + вводить всякую ахинею типа "виртуальных таблиц" - что позволяет реляционная структура данных, но практически мало помогает 1с-у обрабатывать свои всевдо-БД.
hogik; Арчибальд; +2 Ответить 1
86. Аркадий Кучер (Abadonna) 02.12.11 23:29
Ты хочешь сказать, что в структуре этого документа что-то так уж особо непонятно?
Оно мне на фиг не нужно, но если бы уж конкретно озадачился, создал бы документ прям тут, в скуле.
Только заниматься фигней я не привык.
Прикрепленные файлы:
87. Ийон Тихий (cool.vlad4) 02.12.11 23:34
(86) создай и огребешь от 1С-ки, там вся соль в индексах и целостности данных,
88. Алекс Ю (AlexO) 02.12.11 23:36
(86) Abadonna,
а что понятного? я уже неоднократно говорил - из SQL по объектам 1с вы получите только примитивные данные - навроде списка текстом названий номенклатуры.
и все.
все остальное - через ссылку через ссылку через ссылку, чем, собственно, и занимается 1с-сервер большую часть своей работы.
Хотите дублировать функции 1с-сервера - пожалуйста, может, получится и лучше, чем у 1с-ов.
Даже, думаю, наверняка лучше. Только вот затраты на создание обернутся трудо-годами работы...
А в релиционных СУБД это решается строгим разделением данных и индексированием. Пусть и при создании 1/3 дополнительных избыточных таблиц, которые прогрывают по занимаемому месту, но дают эффективный выигрыш по скорости поиска и обработки.
89. Аркадий Кучер (Abadonna) 02.12.11 23:36
А вот пока мы тут вату беспонтовую катали, я уже и в управляемое приложение кнопки рабочего стола привинтил.
Прикрепленные файлы:
90. Аркадий Кучер (Abadonna) 02.12.11 23:39
(88) Слушай. Я никак понять не могу: чего ты конкретно добиваешься? Я что призывал начхать на 1с-сервер и заниматься рукоблудием с прямой записью? Я только сказал: если Я захочу, Я сделаю.
91. Ийон Тихий (cool.vlad4) 02.12.11 23:40
(88) а 1С чем пользуется, не реляционными БД? че-то море было деятелей "2С" и ни у кого лучше не получилось...пока что слова
92. Алекс Ю (AlexO) 02.12.11 23:40
(89) Abadonna,
это другой вопрос, всегда рады новациям и идеям ))
что за рабочий стол в рабочем столе?
93. Аркадий Кучер (Abadonna) 02.12.11 23:41
(92)Надо не на ИСах ошиваться, а по правильным сайтам ходить :))))))))))))
А ссылка на правильный - в моем профиле
Вообще-то сам РС делался под толстого клиента. Это уж так.. для интереса
94. Алекс Ю (AlexO) 02.12.11 23:41
(91) cool.vlad4,
она ими не пользуется, а нагло насилует и выплевывает ))
95. Ийон Тихий (cool.vlad4) 02.12.11 23:43
(94) у каждого свой взгляд на то, как вести себя с женщинами)))
На женщину напал мужик и насилует её, а она орет - Помогите! Помогите!, он ей - Дура, че орешь, сам справлюсь...
96. Алекс Ю (AlexO) 02.12.11 23:45
(93) Abadonna,
как называется рабочий стол в рабочем столе по ссылке из профиля? ))
97. Аркадий Кучер (Abadonna) 02.12.11 23:47
(96) http://dev.1tsm.ru/project/135
Только там пока еще только под толстого. И ваще я спать пошел, у нас уж 4 утра
98. Алекс Ю (AlexO) 02.12.11 23:51
(97) Abadonna,
ну там опять вк фигурирует.. ))
эх... обидно за 1с... ))
ну спокойной ночи!!
99. Аркадий Кучер (Abadonna) 02.12.11 23:56
(98) 7.7 без ВК - полное уё..., а 8.2 - относительное не полное. Таки лучше, про что я и говорю
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа