gifts2017

Отчет "Обороты счета" (СКД) для Украины - выводит только кор.счета (без счетов групп)

Опубликовал anry mc (AnryMc) в раздел Отчеты - Бухгалтерские

Чуть подправленный стандартный отчет "Обороты счета" из "Бухгалтерии для Украины" (на СКД) в режиме "По субсчетам кор. счетов" можно выводить только субсчета самого нижнего уровня (без счетов "групп" / "Родителей")

За счет вывода колонок только по субсчетам увеличивается его "читаемость" и экономится бумага, т.к. не надо клеить "простыни" по ширине отчета.

Настройка в разделе "Группировка".

"Флажок" - "Кор счета без групп"

(Доступен когда выбран "По субсчетам кор. счетов")

 

Можно использовать как внешний отчет или заменить стандартный (Должен подходить ко всем стандартным Украинским конфигурациям, в которых используется план счетов).

Например при построении отчета в демо конфигурации "Бухгалтерия для Украины" по счету 301 за 11 месяцев 2011 года:

Стандартный отчет дает 25 колонок расшифровки (которые дублируют друг друга)

"Без групп" всего 13 колонок (без дублей)

Смотри рисунки.

Скачать файлы

Наименование Файл Версия Размер
ОборотыСчета.erf 40
.erf 64,07Kb
14.03.13
40
.erf 64,07Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Anatoliy (NOVOPRO) 09.11.11 03:34
2. eigen20 12.11.11 22:46
3. Дмитрий Тапол (DimitrT) 22.02.12 20:20
Еще бы добавить, чтобы даты стояли выше уровнем, а то стандартная по дням немного неудобно смотрится
4. anry mc (AnryMc) 22.02.12 21:23
(3) DimitrT,
Не совсем понятна просьба
5. Дмитрий Тапол (DimitrT) 23.02.12 01:05
Попробуйте сформировать стандартный в такой иерархии: день - статья затрат - субконто
6. anry mc (AnryMc) 23.02.12 10:57
(5) DimitrT,
Ну посмотрел...
И что?
7. Дмитрий Тапол (DimitrT) 24.02.12 14:36
Ошибка получения информации набора данных
по причине:
Ошибка в запросе набора данных
по причине:
{(115, 27)}: Неверно заполнена характеристика "{(115, 27)}: Поле не найдено "СвойствоОбъектов.Категория""
И (НЕ СвойстваОбъектов. <<?>>Категория))

Это так отрабатывает на УПП
8. anry mc (AnryMc) 24.02.12 14:54
(7) DimitrT,
Ну это точно не моя доработка.
У меня сейчас нет под рукой УПП, чтобы посмотреть отличается ли отчет в УПП от Бух. Я делал из Бух. Там всего нужно изменить всего пару строк чтобы "отключить" вывод счетов в иерархии. Правда пока я их нашёл (места) и проверил результат потратил часок.
уть подправленный стандартный отчет "Обороты счета" из "Бухгалтерии для Украины"

Можно сравнить мой с типовым и сделать аноалогично для УПП.
9. Дмитрий Тапол (DimitrT) 24.02.12 18:24
Наверное так и поступлю - потому что подправив эту ошибку понеслась гора других. Все таки они отличаются сильно (а жаль). Хотя логично: Бухгалтерию поддерживает Киев, а УПП - Харьков.
10. anry mc (AnryMc) 24.02.12 18:42
(9) DimitrT,
Там (для бухгалтерского отчета) для исправления функционала нужно подправить 2 или 3 строчки. Остальное интерфейсные приблуды
11. Дмитрий Тапол (DimitrT) 24.02.12 19:19
Получилось. Действительно все очень даже просто (учесть, что я не программист). Большое спасибо за подсказку и за идею - огромный плюс и еще 100 таких же. Просто много очень клиентов жалуются на это - приходилось выкручиваться на словах типа "Привыкайте")))
12. anry mc (AnryMc) 24.02.12 20:31
(11) DimitrT,
А "+" где ;-)

Выкладывай в пуюликацию...
13. Дмитрий Тапол (DimitrT) 25.02.12 00:20
А насчет формирования "По дням", но только чтобы день стоял вверху иерархии, т.е. День-Контрагент-Договор (это, например по 36 счетам). Я глянул, но это где-то очень глубоко в компановке данных. Есть идеи?
14. anry mc (AnryMc) 25.02.12 09:21
(13) DimitrT,
Если честно, то не совсем понимаю смысл. Зачем? Так Есть иерархия Контрагент - Договор (- Сделка) и она развернута по датам.

Развертка: Дата - Контрагент - Договор - Это "Анализ счета"

Для этого нужно менять схему компановки, а она там задается программно. Нужно хорошо поковыряться
15. anry mc (AnryMc) 25.02.12 09:48
(13) DimitrT,
Отчет "Обороты счета" - модуль объекта
Процедура ДоработатьКомпоновщикПередВыводом(ВнешниеНаборыДанных) (это для бух)
А) строки с 639:
//*************************
// Период
СтандартныеОтчеты.ДобавитьГруппировкуПоПериоду(ЭтотОбъект, Структура);

Для каждого ЭлементГруппировки Из Структура.ПоляГруппировки.Элементы Цикл
Если ЭлементГруппировки.Поле = Новый ПолеКомпоновкиДанных(?(Периодичность = 2, "Регистратор", "Период")) Тогда
Поле = УсловноеОформлениеАвтоотступа.Поля.Элементы.Добавить();
Поле.Поле = ЭлементГруппировки.Поле;
КонецЕсли;
КонецЦикла;
//========================
Б) строки с 612:
КоличествоГруппировок = ?(ПоСубсчетам, 1, 0);
Для Каждого ПолеВыбраннойГруппировки Из ДанныеОтчета.Группировка Цикл
Если ПолеВыбраннойГруппировки.Использование Тогда
Структура = Структура.Структура.Добавить();

ПолеГруппировки = Структура.ПоляГруппировки.Элементы.Добавить(Тип("ПолеГруппировкиКомпоновкиДанных"));
ПолеГруппировки.Использование = Истина;
ПолеГруппировки.Поле = Новый ПолеКомпоновкиДанных(ПолеВыбраннойГруппировки.Поле);

Если ПолеВыбраннойГруппировки.ТипГруппировки = Перечисления.ТипДетализацииСтандартныхОтчетов.Иерархия Тогда
ПолеГруппировки.ТипГруппировки = ТипГруппировкиКомпоновкиДанных.Иерархия;
ИначеЕсли ПолеВыбраннойГруппировки.ТипГруппировки = Перечисления.ТипДетализацииСтандартныхОтчетов.ТолькоИерархия Тогда
ПолеГруппировки.ТипГруппировки = ТипГруппировкиКомпоновкиДанных.ТолькоИерархия;
Иначе
ПолеГруппировки.ТипГруппировки = ТипГруппировкиКомпоновкиДанных.Элементы;
КонецЕсли;

Структура.Выбор.Элементы.Добавить(Тип("АвтоВыбранноеПолеКомпоновкиДанных"));
Структура.Порядок.Элементы.Добавить(Тип("АвтоЭлементПорядкаКомпоновкиДанных"));

ПолеОформления = УсловноеОформлениеАвтоотступа.Поля.Элементы.Добавить();
ПолеОформления.Поле = ПолеГруппировки.Поле;

КоличествоГруппировок = КоличествоГруппировок + 1;
КонецЕсли;
КонецЦикла;

Нужно поменять местами (например по "галочке" в настройках)
16. Дмитрий Тапол (DimitrT) 25.02.12 12:27
(14) AnryMc, Целиком с тобой согласен - тоже самое объснял и бухам, ноАнализ счета формируется по счетам вертикально, а их интересовала именно форма журнал-ордера, к которой они привыкли - под эту привычку подходит Обороты счета, но иерархия счетов и отсутствие построения по датам их "нервирует". Ну и теперь удалив иерархию хотелось сразу удовлетворить второе их желание)))
17. Дмитрий Тапол (DimitrT) 25.02.12 12:44
(14) AnryMc, Отработало - сразу невнимательно помотрел)))
18. anry mc (AnryMc) 25.02.12 13:30
(17) DimitrT,
Ну тогда жду "+" в 15 пост ;-)
19. Дмитрий Тапол (DimitrT) 25.02.12 14:49
Кстати, на посты даже и не подумал, что плюсы ставить - ставлю с удовольствием
20. Дмитрий Тапол (DimitrT) 25.02.12 14:53
Фигня вот только какая-то: на демке отрабатывает все замечатеьно - устанавливаю на рабочую базу: вылетают ошибки при обращении к общим модулям - самое интересное конфа практически без доработок. Но проблема явно присутствует что-то явно связано с клиент-сервером или что-то подобное. Хотя стоит рабочая в файловом варианте. Странно, пошел дергать знакомых программеров - нездоровая штука получается.
Просто нужно разобраться - а то потом ругать будут, если у кого-то подобные проблемы будут...
21. anry mc (AnryMc) 25.02.12 16:20
(20) DimitrT,
разберешься - отпишись
Удачи
22. Дмитрий Тапол (DimitrT) 25.02.12 18:05
Пересмотрели, но справиться не смогли. Связано что-то с хранилищем настроек, а точнее с информацией, которая связана с кешем. Очистить не рискнули - там много связано с существующеми настройками по пользователям.
Но как внешний отчет работает. Интересная ситуация - как ее побороть пока идей нет. Отчет обращается к настройкам стандартного отчета, т.е. можно предположить: если дорабатывать существующий типовой - проблем не будет, но если его подвешивать в конфигурацию как дополнительный - начинается конфликт.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа