Универсальная обработка для редактирования периодических реквизитов справочника (7.7)

Опубликовал Dmitry Anikin (panda-34) в раздел Обработки - Обработка справочников

Внешняя обработка для массового просмотра и редактирования периодических реквизитов справочника.

Обработка предназначена для просмотра, удаления, переноса на другую дату и изменения значений периодических реквизитов произвольного справочника. Обработка универсальная, работает в любой конфигурации.

Возможна обработка одновременно нескольких реквизитов у отобранных элементов справочника в заданном периоде. Для отбора элементов справочника используется универсальная обработка подбора объектов (УОПО, uchoice.ert).

Подробнее см. встроенное описание

Скачать файлы

Наименование Файл Версия Размер
PerRekv.zip
.zip 11,71Kb
27.11.11
205
.zip 11,71Kb 205 Скачать

См. также

Добавить вознаграждение
Комментарии
1. Pari (Pari) 16.11.11 13:54 Сейчас в теме
Посмотрел обработку. Менять реквизиты пока не пробовал, не было необходимости, но просмотр работает, табличка формируется.
Обнаружил забавный эффект. При снятии флага "Фиксировать" (ВыбФикс) ранее зафиксированные колонки Элемент (и Реквизит, если есть) пропадают из таблицы значений. Вроде недокументировано. Лечится несложно (установкой видимости колонок точно, и может как-то ещё). Думаю, что не лишним будет исправить этот момент
2. Александр Лыткин (TrinitronOTV) 16.11.11 14:06 Сейчас в теме
очень хорошая обработка, спасибо автору
3. Dmitry Anikin (panda-34) 38 16.11.11 14:29 Сейчас в теме
(1)
Они не пропадают, они оказываются слева, прокрученные за пределы видимой области. На них можно перейти, прокрутив таблицу в эту сторону. Это штатное поведение метода Фиксировать. К тому же, снятие фиксирования и означает, что вы не хотите эти колонки видеть, чтобы освободить больше места для просмотра значений. Если хотите исправить, можете заменить эту процедуру:
Процедура ИзмФикс()
	Если тб.КоличествоСтрок() <> 0 Тогда
		текКол = тб.ТекущаяКолонка();
		тб.Фиксировать(, фиксКол*ВыбФикс);
		Если ВыбФикс = 0 Тогда
			тб.ВидимостьКолонки(1, 1);
			тб.ВидимостьКолонки(фиксКол, 1);
		КонецЕсли;
		тб.ТекущаяКолонка(текКол);
	КонецЕсли;
КонецПроцедуры
...Показать Скрыть
4. Алексей Соколов (SAleks1982) 21.11.11 11:16 Сейчас в теме
5. Zakir (zakzai) 21.11.11 13:21 Сейчас в теме
6. Алексей Гришков (asg1975) 214 24.11.11 10:59 Сейчас в теме
Поглядим... Есть желание свернуть справочник цены номенклатуры при свертке базы быстрым способом (удалением определенных DBF)
7. Алексей Гришков (asg1975) 214 24.11.11 11:30 Сейчас в теме
Работает очень долго. Перебор ведется по владельцу. В результате если у меня цены подчинены справочнику номенклатура (более 100000 элементов) ждать результата заполнения таблицы можно до рождества христова. Это при условии что я выбрал период 1 день...
8. Dmitry Anikin (panda-34) 38 27.11.11 20:02 Сейчас в теме
(7)Никакого "перебора по владельцу" там нет, владелец при заполнении таблицы вообще никак не фигурирует. Впрочем, резервы для ускорения работы, действительно, имеются, я их использовал, обработку перезалил. Ускорение заполнения составило для вертикальных таблиц (20000 строк, 10 колонок) - в 5 раз, для горизонтальных (10 строк, 360 колонок) - в 25 раз. Добавил также вывод количества обработанных элементов в строку состояния.
9. Алексей Гришков (asg1975) 214 27.11.11 23:30 Сейчас в теме
(8) panda-34, ну значит почудилось. :) Главное результат! Хорошо когда критика на пользу.
10. Павел Кузнецов (Pavel_nv) 6 23.05.12 08:00 Сейчас в теме
Спасибо, быстро разобрался. Обработка очень помогла.
11. Андрей Макаров (XOCTEP) 110 02.02.16 18:23 Сейчас в теме
Спасибо, помогла для очистки периодических реквизитов справочника "Сотрудники"
Светлана_23; +1 Ответить
12. Сергей Суднев (melm) 27.02.16 08:09 Сейчас в теме
Здравствуйте! Можно ли с помощью данной обработки изменить реквизит "код" справочника "Номенклатура"? Мне нужно ко всем кодам номенклатуры добавить 1 цифру.
13. Ильдар Тагиров (pentanom) 9 22.04.16 12:41 Сейчас в теме
(12) melm, а код периодический реквизит ?
14. Ильдар Тагиров (pentanom) 9 22.04.16 12:42 Сейчас в теме
Обработка очень помогла. Спасибо.