gifts2017

Ошибка ПВД Фактические отпуска в правилах переноса из ЗиК 7 в ЗУП 2.5.41.4

Опубликовал Альберт АЙТАТ (al2ko) в раздел Программирование - Практика программирования

Если у сотрудника в ЗиК период отпуска разбивался на 2 месяца, то в ЗУП отпуск переносится двумя периодами. При этом продолжительность каждого перида равна количеству дней всего отпуска.

Например:

У сотрудника в ЗиК начислен отпуск в период с 20.09.2011 по 10.10.2011 на 22 календарных дня.

В ЗУП перенесется в документ Перенос данных Фактические отпуска за 2011г. двумя строчками: 

Период Количество Дата окончания
20.09.2011 22 30.09.2011
01.10.2011 22  10.09.2011

Правильно так:

Период Количество Дата окончания
20.09.2011 11 30.09.2011
01.10.2011 11 10.09.2011

 

Для правильной выгрузки необходимо подправить ПВД  ФактическиеОтпуска:

Если ЖрнЗарплата.ВидРасч = ВидРасчета.ОтпускДополнительный Тогда
       Если Метаданные.Документ(ДокОтпуск.Вид()).РеквизитШапки("КоличествоДнейДополнительногоОтпуска").Выбран() = 1 Тогда
              ФактическиеОтпуска.Количество = ДокОтпуск.КоличествоДнейДополнительногоОтпуска;
       КонецЕсли;

Иначе

        Если Метаданные.Документ(ДокОтпуск.Вид()).РеквизитШапки("КоличествоДнейОтпуска").Выбран() = 1 Тогда
// было ФактическиеОтпуска.Количество = ДокОтпуск.КоличествоДнейОтпуска;
                ФактическиеОтпуска.Количество = КалендарьОтпуска.Дней(ФактическиеОтпуска.Период, ФактическиеОтпуска.ДатаОкончания) * ?(ЖрнЗарплата.ВидРасч = ВидРасчета.УдержаниеЗаНеотработанныйОтпуск, -1, 1);

        КонецЕсли;
КонецЕсли;

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Владимир Б (antares_of) 02.12.11 14:43
Ух ты, спасибо! А то недавно переносил. Ни как не мог понять что за лажа такая.
2. Альберт АЙТАТ (al2ko) 03.12.11 08:37
Пользуйтесь на здоровье. Сам удивился после переноса. А учитывая что работников около 5000 ручками править было бесполезно.
Если перенос уже вполнен и ручкамии править неохода, то просто повторите выгрузку только по одному правилу "Фактические отпуска".
3. Александр Антоненко (alanto23) 03.12.11 11:47
Плюсую! Сейчас начнется массовый переполз с ЗиК 7.7 на ЗУП8, а штатные правила когда еще поправят... Так что весьма своевременно и полезно!
4. Сергей Жестовский (post279) 04.12.11 10:35
5. Владимир Б (antares_of) 07.12.11 15:14
А напишите пожалуйста подробнее где именно нужно это заменить.
6. Альберт АЙТАТ (al2ko) 08.12.11 07:18
antares_of пишет:
А напишите пожалуйста подробнее где именно нужно это заменить.

Если кратко:
1) Сохраняете правила выгрузки данных из ЗиК в ЗУП. Для этого в ЗУП идете в справочник "Конвертации из информационных баз 1С" и сохраняете правила на ПК. Файл правил будет иметь имя PrB.xml
2) Загружаете файл правил PrB.xml в конфигурацию "Конвертация данных"
3) В правилах выгрузки находите "Правило выгрузки данных ФАктические отпуска" и правите код как указано выше.
7. Владимир Б (antares_of) 08.12.11 13:32
Спасибо! а то я долго бы их искал)
8. rasswet (rasswet) 31.05.12 15:59
не вкурсе, в последних правилах сама 1с это не исправила?
9. Александр Антоненко (alanto23) 01.06.12 07:09
(8) rasswet, нет, насколько я знаю.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа