Как уменьшить количество заблокированных объектов

Публикация № 104397

Разработка - Практика программирования

История о том как я решил пересобрать форму справочника клиентов и чем это все закончилось...

После удачного упорядочения формы я решил добавить новые возможности или нечто подобное. Долго думать не пришлось, и идея родилась моментально.

Думаю многие из вас сталкивались с проблемой, когда элемент справочника заблокирован. В сети полно различных разработок, которые позволяют видеть, кто и когда заблокировал объект. Я решил пойти немного в другом направлении. В 90% случаев объект открывается только для того что бы уточнить какие то реквизиты. Но каждые такие открытия блокируют объект и как часто бывает человек заблокировавший объект не очень, то и торопится его освободить.

Что можно сделать ? Первая мысль была изменить пользователям параметр "Режим открытия объектов" с "Редактирование" на "Просмотр". Но тут, же появилась вторая мысль, а что делать, если нужно все-таки редактировать объект, а не смотреть на него. Не очень удобно.

Вот так и родилась моя идея. (Надеюсь, новый велосипед не изобрел :))

Суть состоит в том, что бы по умолчанию открывать объект на просмотр, а при необходимости нажать на соответствующую кнопку на форме для редактирования. При сохранении объекта сбрасывается режим редактирования, объект становится открытым только для чтения.

В итоге получилось: две переменки и три процедуры. Смотрим ниже. Алгоритм работает как для справочников, так и для документов.


Глобальный модуль:

//=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Перем гОбъект, гРежимОбъекта Экспорт;
//=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Процедура ОткрытьОбъект()

ОбъектОткрыто = 0;
ТипОбъекта = ТипЗначенияСтр(гОбъект);
Если ТипОбъекта = "Справочник" Тогда

ОбъектОткрыто = ОткрытьФорму(гОбъект.ТекущийЭлемент(),,гРежимОбъекта);

ИначеЕсли ТипОбъекта = "Документ" Тогда

ОбъектОткрыто = ОткрытьФорму(гОбъект.ТекущийДокумент(),,гРежимОбъекта);

КонецЕсли;

Если ОбъектОткрыто = 1 Тогда

гОбъект = 0;
ОбработкаОжидания("ОткрытьОбъект", 0);

КонецЕсли;

КонецПроцедуры
//=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Процедура РедактироватьОбъект(Кт) Экспорт

гОбъект = 0;
гРежимОбъекта = 0;
ТипОбъекта = "";
ВидОбъекта = Кт.Вид();

Попытка

Объект = Кт.ТекущийЭлемент();
ТипОбъекта = "Справочник";

Исключение

Объект = 0;

КонецПопытки;

Если Объект = 0 Тогда

Попытка

Объект = Кт.ТекущийДокумент();
ТипОбъекта = "Документ";

Исключение

Объект = 0;

КонецПопытки;

КонецЕсли;

Если Объект = 0 Тогда

Возврат;

КонецЕсли;

гОбъект = СоздатьОбъект(ТипОбъекта + "." + ВидОбъекта);
Если ТипОбъекта = "Справочник" Тогда

гОбъект.НайтиЭлемент(Объект);

ИначеЕсли ТипОбъекта = "Документ" Тогда

гОбъект.НайтиДокумент(Объект);

КонецЕсли;

Если гОбъект.Блокировка(1) = 0 Тогда

Предупреждение("Объект заблокирован другим пользователем.", 60);
Возврат;

Иначе

гОбъект.Блокировка(0);
Кт.Форма.Закрыть();

КонецЕсли;

ОбработкаОжидания("ОткрытьОбъект", 1);

КонецПроцедуры
//=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Процедура ПосмотретьОбъект(Кт) Экспорт

гОбъект = 0;
гРежимОбъекта = 1;
ТипОбъекта = "";
ВидОбъекта = Кт.Вид();

Попытка

Объект = Кт.ТекущийЭлемент();
ТипОбъекта = "Справочник";

Исключение

Объект = 0;

КонецПопытки;

Если Объект = 0 Тогда

Попытка

Объект = Кт.ТекущийДокумент();
ТипОбъекта = "Документ";

Исключение

Объект = 0;

КонецПопытки;

КонецЕсли;

Если Объект = 0 Тогда

Возврат;

КонецЕсли;

гОбъект = СоздатьОбъект(ТипОбъекта + "." + ВидОбъекта);
Если ТипОбъекта = "Справочник" Тогда

гОбъект.НайтиЭлемент(Объект);

ИначеЕсли ТипОбъекта = "Документ" Тогда

гОбъект.НайтиДокумент(Объект);

КонецЕсли;

Кт.Форма.Закрыть();

ОбработкаОжидания("ОткрытьОбъект", 1);

КонецПроцедуры
//=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=


Модуль "Справочника\Документа":

//=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Процедура кРедактировать()

РедактироватьОбъект(Контекст);

КонецПроцедуры

//=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Процедура ПриЗаписи()

ПосмотретьОбъект(Контекст);

КонецПроцедуры
//=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=


Теперь для того что б это все заработало нужно:

1. Установить параметр "Режим открытия объектов" = "Просмотр" для всех пользователей;

2. На форму "справочника\документа" повесить "кнопку\перехватчик сочетания клавиш" и привязать к процедуре кРедактировать();

3. В процедуру при призаписи добавляем ссылку на ПосмотретьОбъект(Контекст);

4. Наличи внешней компоненты "1ссрр\formex". (У меня 1срр версия 2.0.3.7) (Больше не требуется)

Вот собственно и все. Надеюсь этот алгоритм приглянется кому то еще.

1. В ближайшем будущем планирую добавить режим сброса блокировки если в объекте, открытом на редактирование, нажата кнопка записать. (Записал - освободил) (Выполнил)

2. В ближайшем будущем планирую добавить режим сброса блокировки если в объекте нет активности в течении N-минут.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Ёпрст 1044 13.01.12 11:16 Сейчас в теме
Ну, ты забыл в описалове, что нужен формекс, это раз.
Обработку ожидания надо прерывать в Процедура ОткрытьОбъект(), это два.
ShEvOvIcH; +1 Ответить
3. ShEvOvIcH 73 13.01.12 12:31 Сейчас в теме
(1) Ёпрст, обновил описание, перенес прерывание обработки ожидания.
Добавил снятие блокировки при записи элемента.
Ёпрст; +1 Ответить
9. kazna2011 22.01.12 15:34 Сейчас в теме
Процедура Выполнить()
Спр=СоздатьОбъект("Справочник.Номенклатура");
Если Парам=0 Тогда
Спр.ПорядокКодов();
Спр.ВыбратьЭлементы();
Спр.ПолучитьЭлемент();
Сообщить(Спр.Блокировка(1));
Иначе
НачатьТранзакцию();
Спр.ПорядокКодов();
Спр.ВыбратьЭлементы();
Спр.ПолучитьЭлемент();
Спр.Записать();
Предупреждение("Пауза...");
ОтменитьТранзакцию();
КонецЕсли;
КонецПроцедуры
Показать


Не понял, куда этот код прописать?
10. ShEvOvIcH 73 22.01.12 16:03 Сейчас в теме
Не понял, куда этот код прописать?
Смотря для чего вам этот код нужен. Автор, кода который вы процитировали, хотел показать что в старых версиях 1С метод Блокировка(1) вызывал исключение.
2. Ёпрст 1044 13.01.12 11:17 Сейчас в теме
П и з д е ц !, чтобы оставить первый камент нужно нажать на подписаться на комментарии.
Какой му-2 это придумал ?!
4. hogik 435 13.01.12 19:35 Сейчас в теме
(0)
"Надеюсь, новый велосипед не изобрел :))"(с)
Это первое, что сделал в "семерке" при первом с ней знакомстве в 2000 году. :-)
Без FormEx...
Рекомендую метод Блокировка() выполнять вот так:
Попытка Б=Объект.Блокировка(1); Исключение Б=0; КонецПопытки;
5. ShEvOvIcH 73 14.01.12 01:51 Сейчас в теме
(4) hogik, убрал необходимость использования внешней компоненты. Если честно, то я не помню почему я сразу не воспользовался стандартной процедурой обработки ожидания...
6. hogik 435 14.01.12 02:34 Сейчас в теме
(5)
Осталось воспользоваться вторым советом. ;-)
Не знаю как в SQL-ной версии, а в DBF-ной - поставить "попытка" надо обязательно.
7. ShEvOvIcH 73 14.01.12 11:48 Сейчас в теме
(6) hogik, SQL - полет нормальный, ДБФ - полет нормальный. Я специально после вашего комментария создал пустую конфигурацию и вставил свой код, все работает. Вы случайно ничего не меняли. А что пишет в исключении ?
8. hogik 435 14.01.12 21:37 Сейчас в теме
(7)
"Вы случайно ничего не меняли"(с)
Естественно, ничего не менял, т.к. у меня другой алгоритм. ;-)
Про метод Блокировка() - это общее замечание.
У меня сейчас не получилось написать (представить) алгоритм, где он заваливается.
Т.к. занимался этим в 2000 году. Уже все забыл... :-(
Заваливался он аналогично, например, методу Записать() если в другой сессии 1С-а выполнялось обращение к объекту в транзакции. Но, это было в 18 версии (или более ранней). Сейчас пробую в 25-ой - не получается завалить.
Вот, пробую на таком тексте:

Процедура Выполнить()
Спр=СоздатьОбъект("Справочник.Номенклатура");
Если Парам=0 Тогда
Спр.ПорядокКодов();
Спр.ВыбратьЭлементы();
Спр.ПолучитьЭлемент();
Сообщить(Спр.Блокировка(1));
Иначе
НачатьТранзакцию();
Спр.ПорядокКодов();
Спр.ВыбратьЭлементы();
Спр.ПолучитьЭлемент();
Спр.Записать();
Предупреждение("Пауза...");
ОтменитьТранзакцию();
КонецЕсли;
КонецПроцедуры

Запускаю с Парам=1 до выхода на сообщение "Пауза...", и потом запускаю с Парам=0 в другой сессии 1С-а. Метод Блокировка() возвращает единицу. А раньше заваливался. И это, думаю, было лучше чем возвращать признак успешного завершения. Т.е. хоть, через "Попытка" можно было выяснить, что объект заблокирован. Иначе говоря, если в старой версии была ошибка - метод заваливался. И разработчики исправили ошибку так, что он теперь не заваливается, а возвращает единицу, то они полные ко...ы. Или я - такой. ;-) Уже ничего не понимаю и не соображаю. :-(
P.S.
В моих разработках (в подобных алгоритмах) возвращается значение НОЛЬ.
http://infostart.ru/public/15211/
http://infostart.ru/public/14664/
11. pupkinSana 83 24.01.12 14:58 Сейчас в теме
Можно, как вариант, такое предложить: давать редактировать только распроведенные документы.

Тогда можно без изменения прав, а лишь нужным документам в модуль добавить для открытия без блокировки:
Процедура ПриОткрытии()
Если Проведен()=1 тогда
Если глПерем="123" Тогда
глПерем="";
Иначе
глПерем="123";
СтатусВозврата(0);
ОткрытьФорму(ТекущийДокумент(),"",1);
КонецЕсли;
КонецЕсли;
....

Если сильно нужно исправить - распроведите, и редактируйте.
12. denklu 02.02.12 11:11 Сейчас в теме
спасибо за идею, а я еще активно стареньким 1срр (1С++) пользуюсь
13. Гость 07.02.12 20:41
Спасибо,очень нужная вещь иногда бывает))
14. flash82 24.02.12 14:18 Сейчас в теме
спасибо иногда нужная вещь...
15. Rockman 14.03.12 16:29 Сейчас в теме
16. sergur66 26.03.12 13:16 Сейчас в теме
Спасибо!!! Идея полезная.
17. maxim305 18 13.11.13 06:59 Сейчас в теме
Спасибо, интересная идея!
Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    77273    Serginio    110    

Расчет страховых взносов в 1С 7.7 "Учет и отчетность предпринимателя, ред. 1.2" с апреля 2020

Бухгалтерский учет Практика программирования Зарплата v7.7 1cv7.md Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

В этой статье описано, какие небольшие изменения можно внести в модуль документа Начисление налогов с ФОТ, чтобы правильно рассчитывались страховые взносы с 1 апреля 2020 г.

09.04.2020    10210    Юджин58    39    

Маркировка лекарств - как передать код маркировки при продаже через ККТ Штрих-М

Практика программирования ККМ v7.7 Здравоохранение, медицина, стоматология Фармацевтика, аптеки Россия Бесплатно (free)

Пример программного кода для вывода чеков на ККМ Штрих-М с передачей информации о маркированных товарах (лекарства).

10.02.2020    8903    vovaapril    27    

Дистрибьюция 7.7. Часть 1. Жизненный цикл заявки покупателя. Одна заявка покупателя, много адресов доставки.

Практика программирования Адаптация типовых решений v7.7 1С7:Комплекс 1С7:ТиС УУ Бесплатно (free)

Описан способ работы с учетом расписания с приоритетными покупателями - торговыми сетями (основными покупателями) в торговой или комплексной учетной системе на 1С 7.7. Множественная заявка покупателя на несколько торговых точек.

14.10.2019    4673    ksnik    14    

.Net в 1С. На примере использования HTTPClient, AngleSharp. Удобный парсинг сайтов с помощью библиотеки AngleSharp, в том числе с авторизацией аля JQuery с использованием CSS селекторов. Динамическая компиляция Промо

Практика программирования WEB v7.7 v8 Бесплатно (free)

Часто приходится парсить сайты, в том числе с авторизацией, перескакивая со страницы на страницу по ссылкам. Тот, кто занимался вэб программированием, знает, как удобно использовать JQuery и CSS селекторы. На .Net написана очень удобная библиотека AngleSharp. Я покажу, как с её помощью можно значительно облегчить себе труд.

10.03.2016    56163    Serginio    33    

Заполнение реквизитов документов из предыдущего документа

Практика программирования Универсальные функции Разработка v7.7 1cv7.md Бесплатно (free)

Функция для автоматического заполнения реквизитов документов.

04.02.2019    5192    drevilo    1    

Проверка часового пояса

Практика программирования v7.7 Бесплатно (free)

При использовании терминалок для удаленных баз, иногда при входе в базу данных необходимо исключить возможность входа пользователей с компьютеров с другим часовым поясом. Например, работают в Новосибирской базе с временем UTC +6 и пытаются зайти в базу с UTC +3.

16.05.2016    11089    kudenzov    3    

[ПОЛЕЗНЯШКА, 7.7] Как посчитать итоги по документам черным запросом с изподвывертом?

Практика программирования v7.7 1cv7.md Бесплатно (free)

Мелкая полезняшка, считает запросом итоговую сумму документов и количество документов.

12.03.2016    19228    CheBurator    18    

1С:Предприятие 7.7. Оптимизация. Промо

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Разгоняем 1С:Предприятие 7.7. Выжимаем последние соки.

31.01.2009    47088    alexk-is    110    

.Net в 1С. Асинхронные HTTP запросы, отправка Post нескольких файлов multipart/form-data, сжатие трафика с использованием gzip, deflate, удобный парсинг сайтов и т.д.

Разработка внешних компонент Практика программирования WEB v7.7 v8 Бесплатно (free)

Очень часто нужно при работе с HTTP сервисами или сайтами использовать Асинхронные HTTP запросы, отправку на сервер нескольких файлов, использование сжатия трафика. Эта статья про то, как этого легко добиться.

09.03.2016    31974    Serginio    22    

Пример HTTP запроса к УТМ ЕГАИС на платформе 1С 7.7

Внешние источники данных Практика программирования Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v7.7 1cv7.md Россия Бесплатно (free)

Запрос реализован на объекте ServerXMLHTTP из встроенной в Windows библиотеки MSXML, результатом запроса является XML объект DOMDocument из той же библиотеки MSXML со встроенным интерфейсом его обработки

16.12.2015    25531    Palmer1976    3    

Экспорт нескольких MXL таблиц в один XLS файл, на отдельные листы. Простой алгоритм

Загрузка и выгрузка в Excel Практика программирования v7.7 v8 Бесплатно (free)

Статья посвящена распространённому вопросу - как сохранить несколько таблиц (отчетов) в формате MXL, с которым работает 1С, на отдельные листы одного Excel файла. Освещается простой алгоритм решения проблемы штатными средствами, без использования внешних модулей и библиотек (не относящихся к 1С и Excel).

23.11.2015    17497    etmarket    14    

Технология обновления нетиповых конфигураций 1С:Предприятия 7.7 Промо

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Данная статья рассчитана на уже подготовленного пользователя, владеющего некоторыми навыками программирования и работы в конфигураторе. Статью можно использовать как поэтапное руководство к действию. Статья была написана для повышения качества работ выполняемых сотрудниками компании Информ Сервис при обновлении нетиповых конфигураций. Я надеюсь, что эта информация окажется полезной и для вас.

12.12.2008    63019    alexk-is    25    

Процедура расшифровки ячейки таблицы в отчетах 1С 7.7

Практика программирования Универсальные функции v7.7 1cv7.md Бесплатно (free)

Хочу поделиться с вами универсальной процедурой для расшифровки ячеек печатной формы отчетов в 1С 7.7.

24.09.2015    17829    Anzhey    14    

Универсальный способ сравнения таблиц

Практика программирования v7.7 v8 Бесплатно (free)

На эту тему уже есть статьи, но этот способ нигде не описан. Хотя я его использую с тех пор, как занимаюсь программированием. Его преимущество в простоте и универсальности: можно применять на 1С, SQL, а также в любом другом языке программирования.

05.07.2015    19221    json    1    

Числа прописью в родительном падеже в 7.7? Легко!

Практика программирования v7.7 1cv7.md Бесплатно (free)

Вывод числительных прописью в родительном падеже штатными средствами в три строчки кода.

20.06.2015    12828    gimalaj    3    

Хитрости сохранения табличного документа в Excel для дальнейшей работы с ним

Загрузка и выгрузка в Excel Практика программирования v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Все пользователи 1С всех версий (начиная с 7-й) сталкиваются с проблемой нормальной работы с данными, сохраненными в Excel файл. Есть некоторые хитрости, которые позволяют облегчить работу с сохраненными данными из 1С в формат Excel.

16.01.2015    91671    shmellevich    38    

Отправка сообщения посредством почтового клиента Lotus Notes

Практика программирования v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Отправка сообщения посредством почтового клиента Lotus Notes из 1С 7,7 и 1с 8

21.08.2014    14669    iolko    8    

Исправление в типовой комплексной конфигурации глобальной функции глВсеРеквизитыДокументаЗаполнены()

Практика программирования v7.7 1С7:Комплекс Россия Бесплатно (free)

В типовых конфигурациях глобальная функция глВсеРеквизитыДокументаЗаполнены() не работает с реквизитами табличной части. Данная статья содержит текст исправленной функции, корректно проверяющей табличную часть.

20.08.2014    8187    hvv2002    0    

ЗаполнитьЗначенияСвойств - заставляем работать в 7.7

Практика программирования v7.7 1cv7.md Бесплатно (free)

Если вы используете в работе 1С:Предприятие 8.х, то наверняка знакомы и с замечательной системной процедурой, как ЗаполнитьЗначенияСвойств(). Ее использование помогает значительно упростить написание программного кода в ряде случае, делает его (код) более наглядным и простым. Но что же делать тем, кто до сих пор использует (постоянно или иногда) 1С:Предприятие 7.7?

24.07.2014    22190    tomvlad    5    

Контекстный поиск в 7.7

Инструментарий разработчика Практика программирования v7.7 1cv7.md Бесплатно (free)

Процедура контекстного поиска в журнале документов.

18.04.2014    9549    cushe    2    

Проверка ИНН v.7.7

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Проверка ИНН v.7.7

08.03.2014    9651    kras_71    1    

Полезные функции. Склонение (должность и фамилия подписантов). Любой язык

Практика программирования v7.7 v8 Бесплатно (free)

Уехал директор в командировку, отпуск... , оставил доверенность на хозяйственные операции на другого сотрудника. Все договора и другие документы в обмороке - "подписант" теперь другой, по тексту тоже много правок... Пересмотрел много публикаций, вариантов много, не приглянулось. Сделал свой "Баян" . У меня всего-то крутится пять фигурантов ... Нет простого, наглядного и всепогодного варианта без языкового барьера. Всем процессом управляет пользователь.

03.03.2014    18034    kompas-dm    5    

Реализация Ctrl+Z в 1С 7.7 (ТиС)

Практика программирования v7.7 1С7:ТиС Бесплатно (free)

В семерке отсутствует возможность отменять последнее действие в формах документов. В данной статье будет рассмотрен пример реализации данной функции. Возможно, кому-нибудь пригодится.

15.07.2013    8083    a.o.popova    10    

Копия напечатанного документа или как спрятать документ.

Журнал регистрации Практика программирования v7.7 Бесплатно (free)

Возникла необходимость, чтобы при печати определённого документа (даже потом не сохранённого), создавалась его копия, т.е. запись всех напечатанных документов. (В результате чего возникла такая потребность, полагаюсь на вашу фантазию). В итоге получилось два варианта решения, остановился на втором.

11.04.2013    15649    Dima_    8    

Чтение строк файла CSV в список значений с помощью метода ИзСтрокиСРазделителями

Практика программирования Внешние источники данных v7.7 Бесплатно (free)

Чтение строк файла CSV в список значений с помощью метода ИзСтрокиСРазделителями

04.04.2013    19529    ivisor_fil    11    

Автосохранение документа в 1С 7.7

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

В данной статье мы рассмотрим автосохранение документа в 1С 7.7!

22.03.2013    13577    aagubarev    25    

Конвертация данных 2.1 (2.1.3.1) 1С 7.7 - 1С 8.Х передача параметра ПКО

Практика программирования Перенос данных из 1С7.7 в 1C8.X v7.7 v8 КД Бесплатно (free)

Передача параметров по умолчанию доступна только для баз 1С 8.х -1С 8.х. Показан пример, как передать параметры из 1С 7.7 - 1С 8.х

10.12.2012    25517    serg_gres    6    

Устранение проблемы при работе с полем, которое ограничено маской ввода

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Для поля, у которого установлена маска ввода, перед программной инициализацией необходимо начальное значение преобразовать к значению в соответствии с маской, иначе буду потеряны символы в местах разделителях. В данной публикации приведена функция, которая универсально выполняет данное действие.

08.08.2012    16552    www2000    4    

Динамическая фильтрация в справочнике при вводе наименования

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Позволяет в открытой форме списка, выбора или подбора справочника производить динамическую фильтрацию по набранному наименованию.

02.07.2012    16447    maxpiter    62    

Обновление базы 1с 7.7. с помощью движка 1с 8.х

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Если Вас угораздило в стандартную типовую конфу внести правки, причем в самый большой модуль, а именно глобальный. Если к тому же Вы внесли изменение в какую-то стандартную функцию, в которой 1с сама регулярно чего-то меняет, то любое обновление начинает доставать. Используя возможности движка платформы 1с 8.х можно существенно сэкономить себе время и нервы.

28.04.2012    18693    Valerich    31    

Ошибка при формировании отчета Авансы по налогу на имущество. В 1С:Предприятие 7.7. Регламентированная отчетность за I квартал 2012 года Обновление 12q1009 от 18.04.2012 г.

Практика программирования v77::ОУ v77::БУ 1cv7.md Россия Бесплатно (free)

При формировании отчета NIMAVP1.ERT Авансы по налогу на имущество (версия 5.03) в разделе № 1-3 не сохраняет номера Страниц при выборе, что ведет к не сохранению и выводу печати двухмерного кода.

24.04.2012    9387    leo072    7    

Запуск внешней обработки по расписанию v7.7

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Неоднократно возникали задачи организовать, например ежедневную выгрузку и отправку отчетов по эл.почте, и вот…

20.03.2012    44457    Yury1001    17    

ЗиК 321, в отчетах пропадает проводка по ПФР_страховая

Практика программирования v77::ОУ v77::Расчет 1С7:ЗиК Россия ФОМС, ПФ, ФСС Бесплатно (free)

При формировании отчета "Свод проводок" с галкой "Учет начисления налогов с ФОТ, включаемых в состав расходов" в отчет не выходит ПФР_страх

10.02.2012    6897    filh    19    

Регистрация текста окна сообщений

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Для контроля работы пользователей потребовалось записывать текст окна сообщений в файл. Получился простейший механизм регистрации лог-файла. Удержать роста папки "Temp", в качестве рекомендации, может использование bat-файла, который будет чистить или архивировать получаемые логи. Таких батников в инете полным-полно. P.S. Особо по форуму не смотрел, может, есть уже такое.

28.11.2011    7933    sdin101    9    

Прямые запросы: ускорение получения цен для типовой ТиС 7.7

Практика программирования Разработка внешних компонент v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Бесплатно (free)

Первая статья из цикла статей "Прямые запросы:...". Рассказывается о применении класса ПрямойЗапрос и компоненты 1С++ для ускорения функции глВернутьЦену() в типовой конфигурации Торговля и склад. Платформа 7.7.

15.11.2011    15664    leshik    21    

1С:Торговля и Склад - ошибка во всех релизах, При использовании нескольких фирм и префиксов номеров документов.

Практика программирования v77::ОУ 1С7:ТиС Россия Бесплатно (free)

Собственно сегодня обнаружил ошибку, которая присутствует во всех релизах конфигурации Торговля и Склад 7.7 вплоть до текущего 7.70.969, при использовании нескольких фирм и префиксов документов для некоторых из них.

04.11.2011    15670    twilight5023    8    

Функция проверки валидности e-mail с использованием регулярных выражений RegExp (7.7)

Практика программирования openconf v77::БУ 1cv7.md Россия Бесплатно (free)

Функция проверки валидности e-mail с использованием регулярных выражений RegExp (7.7). Данную функцию можно вставить в Глобальный модуль и пользоваться, например, при вводе или сохранении e-mail.

30.10.2011    11126    zaursoft    11    

Компенсация отпуска, оплата дней доноров и оплата льготных дней родителей в ЗиК

Практика программирования Зарплата Зарплата v77::Расчет 1cv7.md 1С7:ЗиК Россия Бесплатно (free)

"Компенсация отпуска"," Оплата дней доноров" и "Оплата льготных дней родителей" - эти виды расчетов должны облагаться страховыми взносами с 01.01.2011 года.

04.10.2011    9296    maxim305    18    

7.7.: Готовим md-файл для публикации. В картинках.

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Вы доработали типовую конфигурацию: скажем, добавили новый Документ, и хотите им поделиться с обществом ИС. Но нельзя же выложить МД-шник целиком, это будет нарушением правил. И как тут быть?

14.09.2011    17464    Арчибальд    21