Простая выгрузка данных в универсальном формате Enterprise Data

Публикация № 1102730

Разработка - Системная интеграция - Обмен через XML

обработка обмен универсальный формат enterprise data конвертация данных КД БСП xml ED

Пошагово разобран текст процедуры, позволяющей выгрузить произвольный набор объектов в формате Enterprise Data (конечно, если это позволяет конфигурация). Приложена обработка, позволяющая выгружать произвольные объекты, в том числе запросом или по данным журнала регистрации.

В процессе изучения КД3 меня не оставляло ощущение, что выгрузка данных в этом формате должна делаться как-то очень просто. Тут же возникла потребность сделать нестандартную "догрузку" множества физлиц с паспортными данными в ЗУП 3. После отсечения всего лишнего получилась короткая процедура. Что же внутри?

Инициализация

1. Инициализация структуры КомпонентыОбмена

	ИмяФайлаПротоколаОбмена="";   // если заполнить - будет писаться лог в файл
	КомпонентыОбмена = ОбменДаннымиXDTOСервер.ИнициализироватьКомпонентыОбмена("Отправка");
	
	КомпонентыОбмена.ВедениеПротоколаДанных.ВыводВПротоколИнформационныхСообщений = Ложь;
	КомпонентыОбмена.КлючСообщенияЖурналаРегистрации = ОбменДаннымиСервер.СобытиеЖурналаРегистрацииОбменДанными();
	КомпонентыОбмена.ЭтоОбменЧерезПланОбмена = Ложь;

2. Определяем версию формата обмена.

Можно просто указать, скажем, "1.6", но в свежих версиях БСП есть соответствующая функция:

	Версии=ОбменДаннымиXDTOСервер.ВерсииФорматаОбменаМассив(ПланыОбмена.СинхронизацияДанныхЧерезУниверсальныйФормат.ЭтотУзел());
	КомпонентыОбмена.ВерсияФорматаОбмена=Версии[0]; // первой будет максимальная версия, которую поддерживает конфигурация
	КомпонентыОбмена.XMLСхема = "http://v8.1c.ru/edi/edi_stnd/EnterpriseData/"+КомпонентыОбмена.ВерсияФорматаОбмена;

3. Заканчиваем инициализацию

	КомпонентыОбмена.МенеджерОбмена = МенеджерОбменаЧерезУниверсальныйФормат;
	ОбменДаннымиXDTOСервер.ИнициализироватьТаблицыПравилОбмена(КомпонентыОбмена);
	ОбменДаннымиXDTOСервер.ИнициализироватьВедениеПротоколаОбмена(КомпонентыОбмена, ИмяФайлаПротоколаОбмена);

4. Разбираемся с файлами

	// Открываем файл обмена. Если вторым параметром файл не указывать - выгрузка будет в строку
	ОбменДаннымиXDTOСервер.ОткрытьФайлВыгрузки(КомпонентыОбмена,"");  	
	Если КомпонентыОбмена.ФлагОшибки Тогда
		КомпонентыОбмена.ФайлОбмена = Неопределено;
		ОбменДаннымиXDTOСервер.ЗавершитьВедениеПротоколаОбмена(КомпонентыОбмена);
		Возврат "";
	КонецЕсли;

Всё готово для собственно выгрузки объектов.

Выгрузка по сценарию

Сценарий выгрузки представляет собой таблицу значений, в строках которой написаны имена правил обработки данных. Выгрузка по сценарию на момент написания работает без отборов.

Пример сценария выгрузки физических лиц и их документов:

	КомпонентыОбмена.СценарийВыгрузки = новый ТаблицаЗначений;
	КомпонентыОбмена.СценарийВыгрузки.Колонки.Добавить("ИмяПОД");

	НоваяСтрока = КомпонентыОбмена.СценарийВыгрузки.Добавить();
	НоваяСтрока.ИмяПОД = "Справочник_ФизическиеЛица_Отправка";
	
	НоваяСтрока = КомпонентыОбмена.СценарийВыгрузки.Добавить();
	НоваяСтрока.ИмяПОД = "Справочник_ДокументыФизическихЛиц_Отправка";

Запускается сценарий совсем просто:

	 //ВЫГРУЗКА ДАННЫХ по сценарию. Работает но без отборов
	Попытка
		ОбменДаннымиXDTOСервер.ПроизвестиВыгрузкуДанных(КомпонентыОбмена);
	Исключение
		ОбменДаннымиXDTOСервер.ЗаписатьВПротоколВыполнения(КомпонентыОбмена, ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()));
		ОбменДаннымиXDTOСервер.ЗавершитьВедениеПротоколаОбмена(КомпонентыОбмена);
		КомпонентыОбмена.ФайлОбмена = Неопределено;
		Возврат "";
	КонецПопытки;

Произвольная выгрузка данных запросом

Гораздо интереснее самим определить, какие именно данные мы хотим выгрузить и заставить систему их отработать.

Прежде чем выгружать наши объекты, нужно запустить обработчик "ПередКонвертацией". Вдруг разработчики там спрятали что-то жизненно важное?

	Попытка
		КомпонентыОбмена.МенеджерОбмена.ПередКонвертацией(КомпонентыОбмена);
	Исключение
		ТекстОшибки = Символы.ПС + СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтр("ru = 'Событие: %1.
				|Обработчик: ПередКонвертацией.
				|
				|Ошибка выполнения обработчика.
				|%2.'"),
			КомпонентыОбмена.НаправлениеОбмена,
			ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()));
		ОбменДаннымиXDTOСервер.ЗаписатьВПротоколВыполнения(КомпонентыОбмена, СокрЛП(ТекстОшибки));
	КонецПопытки;

Выгрузка ссылочных объектов запросом, на примере физических лиц:

	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ РАЗЛИЧНЫЕ
		|	ФизическиеЛица.Ссылка КАК Ссылка
		|ИЗ
		|	Справочник.ФизическиеЛица КАК ФизическиеЛица
		|ГДЕ
		|	НЕ ФизическиеЛица.ПометкаУдаления";
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		ОбменДаннымиXDTOСервер.ВыгрузкаОбъектаВыборки(КомпонентыОбмена, Стр.Ссылка);
	КонецЦикла;

В свежих версиях обмена появились регистры сведений. С ними сложнее, но не намного:

	Запрос.Текст = 
		"ВЫБРАТЬ РАЗЛИЧНЫЕ
		|	ДокументыФизическихЛиц.Период КАК Период,
		|	ДокументыФизическихЛиц.ВидДокумента КАК ВидДокумента,
		|	ДокументыФизическихЛиц.Физлицо КАК Физлицо
		|ИЗ
		|	РегистрСведений.ДокументыФизическихЛиц КАК ДокументыФизическихЛиц
		|ГДЕ
		|	ДокументыФизическихЛиц.Физлицо В(&Физлицо)
		|	И НЕ ДокументыФизическихЛиц.ВидДокумента ЕСТЬ NULL";
	
	
	Рег=РегистрыСведений.ДокументыФизическихЛиц.СоздатьНаборЗаписей();
	Рег.Отбор.Физлицо.Использование=Истина;
	Рег.Отбор.ВидДокумента.Использование=Истина;
	Рег.Отбор.Период.Использование=Истина;
	Запрос.УстановитьПараметр("Физлицо", КомпонентыОбмена.ВыгруженныеОбъекты);
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаРесурсов=РезультатЗапроса.Выбрать();
	Пока ВыборкаРесурсов.Следующий() Цикл
		Если НЕ ЗначениеЗаполнено(ВыборкаРесурсов.ВидДокумента) Тогда
			Продолжить;
		КонецЕсли;
		Рег.Отбор.Физлицо.Значение=ВыборкаРесурсов.Физлицо;
		Рег.Отбор.ВидДокумента.Значение=ВыборкаРесурсов.ВидДокумента;
		Рег.Отбор.Период.Значение=ВыборкаРесурсов.Период;
		Рег.Прочитать();
		ОбменДаннымиXDTOСервер.ВыгрузкаОбъектаВыборки(КомпонентыОбмена, Рег);
	КонецЦикла;

В качестве отбора для документов в коде использован список ранее выгруженных физлиц из КомпонентыОбмена.ВыгруженныеОбъекты.

Завершение выгрузки

1. Запускаем обработчик "ПослеКонвертации"

	Попытка
		КомпонентыОбмена.МенеджерОбмена.ПослеКонвертации(КомпонентыОбмена);
	Исключение
		ТекстОшибки = Символы.ПС + СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтр("ru = 'Событие: %1.
				|Обработчик: ПослеКонвертации.
				|
				|Ошибка выполнения обработчика.
				|%2.'"),
			КомпонентыОбмена.НаправлениеОбмена,
			ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()));
		ОбменДаннымиXDTOСервер.ЗаписатьВПротоколВыполнения(КомпонентыОбмена, СокрЛП(ТекстОшибки));
	КонецПопытки;

2. Закрываем теги, протоколы и файлы.

	КомпонентыОбмена.ФайлОбмена.ЗаписатьКонецЭлемента(); // Body
	КомпонентыОбмена.ФайлОбмена.ЗаписатьКонецЭлемента(); // Message
	
	// Фиксация успешного завершения обмена.
	Если КомпонентыОбмена.СостояниеОбменаДанными.РезультатВыполненияОбмена = Неопределено Тогда
		КомпонентыОбмена.СостояниеОбменаДанными.РезультатВыполненияОбмена = Перечисления.РезультатыВыполненияОбмена.Выполнено;
	КонецЕсли;
	
	ДанныеВыгрузкиXML=КомпонентыОбмена.ФайлОбмена.Закрыть();
	ОбменДаннымиXDTOСервер.ЗавершитьВедениеПротоколаОбмена(КомпонентыОбмена);

Переменная ДанныеВыгрузкиXML содержит строку с данными, которыми дальше можно распорядиться как угодно.

Обработка

В результате вокруг вышеописанной процедуры образовалась обработка.

Функционал её заимствован у бестселлера Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ), за что отдельное спасибо ее автору.

Обработка умеет подбирать объекты для выгрузки:

  • вручную
  • запросом (результат должен содержать колонку "ссылка")
  • по выбранному периоду журнала регистрации

И выгружать их в выбранный файл.

Файл можно загрузить в любую базу (в том числе в облаке), командой:

Загрузка данных EnterpriseData

Обработка содержит полный текст описанной здесь процедуры. Код открыт.

Тестировалась на Бухгалтерия предприятия, редакция 3.0 (3.0.71.69).
Будет работать в любой конфигурации на БСП от 3.0.2.300.

P.S.

Собственно механизм и все правила выгрузки в универсальном формате содержаться в коде конфигурации. Обработка лишь предоставляет простой доступ к ним. Поэтому, все обращения типа "почему не выгружается..." следует направлять непосредственно разработчикам.

P.P.S.

Конечно, в составе конфигураций есть универсальная обработка "ВыгрузкаЗагрузкаEnterpriseData", которая делает то же самое. Но мне показалось более изящным решением реализовать программный доступ к самому механизму обмена, чем городить обертку для универсальной обработки.

Скачать файлы

Наименование Файл Версия Размер
Файл обработки

.epf 19,94Kb
44
.epf 1.0 19,94Kb 44 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. ids79 6051 26.08.19 18:05 Сейчас в теме
Спасибо, очень хороший пример работы с выгрузкой данных в ED. Я в своих по статьях по выгрузке и загрузке больше теорию описываю, а у Вас практический пример, это интересно.
starik-2005; user598128_able123; jif; +3 Ответить
2. Iyar 198 27.08.19 07:30 Сейчас в теме
(1) Спасибо на добром слове!
3. A_Max 18 30.08.19 10:21 Сейчас в теме
Лайк! Только на этой неделе сделал тоже самое для передачи одиночного объекта "сериализованного" по правилам КД3 и "десериализация" в объект при получении в другой ИБ опять же по правилам КД3. Делалось для онлайн отправки в МДМ систему через ВебСервис.

Думал причесать и тоже опубликовать. Но теперь не уверен в необходимости.

На самом деле КД 2 и 3 достаточно простые внутри и хорошо структурированы. Недостаток в реализации КД3, что не все необходимые процедуры объявлены экспортными в модуле ОбменДаннымиXDTOСервер :(
NoRazum; Iyar; acanta; +3 Ответить
Оставьте свое сообщение

См. также

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) Промо

Перенос данных из 1C8 в 1C8 Универсальные обработки Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Абонемент ($m)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    211079    4237    ekaruk    184    

Как сделать обмен данными через универсальный формат быстрее? Реализация многопоточного обмена данными

Обмен данными 1С Обмен через XML v8 1cv8.cf Бесплатно (free)

Предлагаю Вашему вниманию интересный кейс по реализации обмена данными через универсальный формат между современными типовыми конфигурациями в режиме многопоточности. Учитывая все тонкости механизмов обмена данными и сложности типовых правил конвертации, сделать это оказалось совсем не так просто.

31.12.2019    8561    ids79    17    

Получение XML файла с SQL Server средствами ADODB

Обмен через XML v8 1cv8.cf Россия Абонемент ($m)

В статье описано, как получать XML файл, сгенерированный SQL Server, средствами ADODB. Обработка написана на обычных формах, тестировалась на платформе 8.12.1685.

1 стартмани

08.07.2019    2772    saver77    0    

XDTO для чайников

Обмен через XML v8 1cv8.cf Абонемент ($m)

Пример использования XDTO пакетов для выгрузки документа с табличной частью.

1 стартмани

29.05.2019    32324    HAMMER_59    39    

Ошибка преобразования данных XDTO: Текст XML содержит недопустимый символ Промо

Практика программирования Обмен через XML v8 1cv8.cf Абонемент ($m)

Преобразование строкового значения к допустимому для XML. Типовое, нетиповое, RegExp.

1 стартмани

26.03.2013    84305    StepByStep    26    

1C + Python + Django Rest Framework + Vue.js. Опыт несложной full-stack разработки

Практика программирования Внешние источники данных Обмен через XML WEB Разработка v8 1cv8.cf Абонемент ($m)

В этой статье мы рассмотрим путь и основные моменты создания небольшого вэб-сервиса, который мы называем "Онлайн Прайс-лист". Выгрузка из 1С, бэкенд, фронтенд, получение заказов в 1С.

1 стартмани

22.04.2019    35121    riposte    66    

Перенос данных с использованием XDTO

Обмен через XML v8 Россия Абонемент ($m)

Использование объекта типа "ОбъектXDTO" для переноса данных из одной конфигурации в другую

1 стартмани

21.04.2019    11574    axae    11    

Заполнение справочника с изображениями элементами по умолчанию

Практика программирования Обмен через XML Универсальные функции v8 Абонемент ($m)

Пример одного из решений, как можно заполнить справочник с изображениями значениями по умолчанию включая сами изображения. Сами изображения взяты из программы MapSource 6.16.3. Данные для загрузки хранятся в макете в формате XML.

1 стартмани

26.03.2018    8783    Kim1C    0    

Сохранение реквизитов и табличных частей объектов в XML Промо

Обмен через XML Универсальные функции v8 1cv8.cf Абонемент ($m)

Пример того, как можно сохранять и загружать объекты 1С методами встроенных объектов ЗаписьXML и ЧтениеXML.

1 стартмани

25.11.2011    22103    saiten    21    

Организация обмена с базой филиала (розничного магазина) в торговой сети через XML (универсальный обмен)

Обмен через XML Перенос данных из 1C8 в 1C8 Розничная торговля Розничная торговля v8 КД УТ11 Розничная и сетевая торговля (FMCG) Абонемент ($m)

В статье по шагам рассматривается создание обмена между центральной базой и базами филиалов на базе конфигурации УТ 11. Для решения поставленной задачи было решено не использовать РИБ, т.к. требуется односторонний обмен ограниченным набором данных, к тому же по определенным условиям. Обмен реализован на основе типовой синхронизации на основе универсального обмена в формате EnterpriseData. Данная публикация может быть полезна внедренцам, которые работают с торговыми сетями, в том числе по модели франчайзинга.

1 стартмани

26.02.2018    37460    Kutuzov    18    

Пример заполнения/создания файла XML из XSD схемы, используя XDTO

Обмен через XML WEB v8 1cv8.cf Абонемент ($m)

Добрый день, коллеги! Наконец-то дошли руки написать сию статью. Хочу поделиться своим опытом по разбору xsd схемы используя Фабрику XDTO, а также связанным с этим XML файлом. Думаю, наверняка кому-то понадобится.

1 стартмани

21.12.2017    49207    sandybaev    25    

Механизмы и транспорт обмена данными. Пример создания в КД 2.1 правил обмена данными ЗУП 2.5 -> БП 3.0. Выгрузка ведомостей и банковских счетов. Передача параметров обмена из Источника в Приемник. ВыгрузитьПоПравилу(). ПередатьОдинПараметрВПриемник().

Обмен через XML Перенос данных из 1C8 в 1C8 v8 ЗУП2.5 КД БП3.0 Абонемент ($m)

В статье рассказываю: 1) о механизмах и транспорте обмена данными, где одной из сторон обмена выступает конфигурация на базе 1С, и о том, какой транспорт и в каких случаях лучше использовать 2) о решении задачи выгрузки данных документа «Зарплата к выплате организаций» (с выгрузкой банковский счетов физ лиц документа) из ЗУП 2.5.123.1 (далее Источник) в БП КОРП 3.0.52.39 (далее Приемник) путем создания правил обмена данными с использованием конфигурации «Конвертация данных» (далее просто КД) ред. 2.1.8.2. для (далее ЗкВО) 3) о тестирование полученных правил обмена данными.

1 стартмани

03.11.2017    33189    RailMen    5    

Использование SoapUi для работы с веб-сервисами. Часть1

Практика программирования Обмен через XML v8 Абонемент ($m)

Как работать с SoapUi для тестирования веб-сервисов .

1 стартмани

30.09.2016    125628    kiv1c    29