Ошибка в отчете "Справки по НДФЛ" в Комплексной р.517

Публикация № 118534

Учет и отчетность - Зарплата

Исправление ошибки расчета сумм вычетов (по кодам 311, 312, 318) в п. 4.1 отчета "Справки по НДФЛ".

При создании справок в п.4.1. "Суммы предоставленных налогоплательщику налоговых вычетов" по кодам вычетов 311, 312, 318 неверно формируются суммы вычетов, т.е. суммируются накопительные суммы.

Для наглядности:

должно быть: (Январь 4000) + (Февраль 4000) + (Март 4000) = 12000

в отчете: (Январь 4000) + (Февраль 8000) + (Март 12000) = 24000

надеюсь понятно.


Исправление:

в стр. 2128 модуля отчета "СправкиПоНДФЛ" в Функция СоздатьСправкиПоСотруднику2011(...)

Заменить код

//вычеты предоставленные
СписокВычетовПредоставленных=ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(1);
СписокВычетовПредоставленных.Выгрузить(СписокВычетов);

Вычеты311=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(3));
Вычеты312=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(4));
Вычеты318=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(9));

СписокВычетов.ДобавитьЗначение(Вычеты311,"311");
СписокВычетов.ДобавитьЗначение(Вычеты312,"312");
СписокВычетов.ДобавитьЗначение(Вычеты318,"318");

Если СчМесяцев>1 Тогда

//вычеты предоставленные
СписокВычетовПредоставленныхПрошлМесяц=ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(1);

Вычеты311=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(3));
Вычеты312=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(4));
Вычеты318=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(9));

СписокВычетовПредоставленныхПрошлМесяц.ДобавитьЗначение(Вычеты311,"311");
СписокВычетовПредоставленныхПрошлМесяц.ДобавитьЗначение(Вычеты312,"312");
СписокВычетовПредоставленныхПрошлМесяц.ДобавитьЗначение(Вычеты318,"318");

Для СчВычетов = 1 По СписокВычетовПраво.РазмерСписка() Цикл

КодВычета = "";
СписокВычетовПраво.ПолучитьЗначение(СчВычетов,КодВычета);

РазмерВычета = Число(СписокВычетов.Получить(КодВычета));

РазмерВычетаПрошлМесяц = Число(СписокВычетовПредоставленныхПрошлМесяц.Получить(КодВычета));
РазмерВычета = РазмерВычета - РазмерВычетаПрошлМесяц;
СписокВычетов.Установить(КодВычета,РазмерВычета);

КонецЦикла;

КонецЕсли;



на



//вычеты предоставленные
СписокВычетовПредоставленных=ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(1);
СписокВычетовПредоставленных.Выгрузить(СписокВычетов);

Вычеты311=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(3));
Вычеты312=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(4));
Вычеты318=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(9));

Если СчМесяцев>1 Тогда 


//вычеты предоставленные
СписокВычетовПредоставленныхПрошлМесяц=ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(1);

Вычеты311=Вычеты311-Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(3));
Вычеты312=Вычеты312-Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(4));
Вычеты318=Вычеты318-Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(9));

СписокВычетовПредоставленныхПрошлМесяц.ДобавитьЗначение(Вычеты311,"311");
СписокВычетовПредоставленныхПрошлМесяц.ДобавитьЗначение(Вычеты312,"312");
СписокВычетовПредоставленныхПрошлМесяц.ДобавитьЗначение(Вычеты318,"318");

Для СчВычетов = 1 По СписокВычетовПраво.РазмерСписка() Цикл

КодВычета = "";
СписокВычетовПраво.ПолучитьЗначение(СчВычетов,КодВычета);

РазмерВычета = Число(СписокВычетов.Получить(КодВычета));

РазмерВычетаПрошлМесяц = Число(СписокВычетовПредоставленныхПрошлМесяц.Получить(КодВычета));
РазмерВычета = РазмерВычета - РазмерВычетаПрошлМесяц;
СписокВычетов.Установить(КодВычета,РазмерВычета);

КонецЦикла;

КонецЕсли;

СписокВычетов.ДобавитьЗначение(Вычеты311,"311");
СписокВычетов.ДобавитьЗначение(Вычеты312,"312");
СписокВычетов.ДобавитьЗначение(Вычеты318,"318");



Буду рад если хоть кому-то статья окажется полезным.

Специальные предложения

Оставьте свое сообщение

См. также

Расчет страховых взносов в 1С 7.7 "Учет и отчетность предпринимателя, ред. 1.2" с апреля 2020

Бухгалтерский учет Практика программирования Зарплата v7.7 1cv7.md Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

В этой статье описано, какие небольшие изменения можно внести в модуль документа Начисление налогов с ФОТ, чтобы правильно рассчитывались страховые взносы с 1 апреля 2020 г.

09.04.2020    9200    Юджин58    36    

Доначисление страховых взносов на обязательное страхование от НС и ПЗ в Бухгалтерии 7.7 и УСН 7.7 для Договора подряда

Практика программирования Зарплата Зарплата v77::БУ 1С7:Бух 1С7:УСН Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Во всех источниках, которые мне встречались, написано, что Страховые взносы НС и ПФ нужно начислять, если это указано в Договоре подряда.

06.09.2017    10258    pentanom    0    

Записки на память. Зарплата и кадры 1С 7.7 (ЗиК 7.7 )

Бухгалтерский учет Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v77::Расчет 1С7:ЗиК Россия БУ НУ УУ Бесплатно (free)

ЗиК 7.7 постепенно сходит на нет. Но, возможно, кому-то из нас все-таки когда-либо еще не раз придется столкнуться с этой конфигурацией. Поскольку работы по ней и заказов всё меньше и меньше, знания о ней и опыт постепенно угасают. Мой опыт с ЗиК 7.7 длиной в 14 лет терять просто так неохота. В этой статье я запишу, чтобы не забыть, важные моменты об этой конфигурации, чтобы самому не забыть, и вдруг кто-то получит это в наследство на сопровождение и будет вынужден (иначе не скажешь) это обслуживать. Или еще можно рассматривать эту статью как модное нынче «Письмо самому себе в прошлое».

18.11.2014    40023    Lapitskiy    26    

Подготовка сведений для ПФР ЗиК Исправление ошибок

Адаптация типовых решений Зарплата Зарплата v77::Расчет 1С7:ЗиК БУ ФОМС, ПФ, ФСС Бесплатно (free)

Подготовка сведений для ПФР ЗиК Исправление ошибок. Для сотрудников, у которых во 2,3 или 4 квартале не было заработка, но есть стаж (например, декретницы) не заполняется «Сумма выплат с начала года».

30.07.2014    16291    Cvetic    4    

Выгрузка 6 раздела РСВ-1 в СПУ ОРБ из ЗИК 7.7

Внешние источники данных Зарплата Зарплата v7.7 Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Выгрузка индивидуальных сведений (раздел 6) РСВ-1 в СПУ ОРБ из ЗИК 7.7 начиная с обновления 346

16.07.2014    27090    aagubarev    3    

Подготовка сведений для ПФР ЗиК 339. СЗВ-6-4 две незначительные ошибки.

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Подготовка сведений для ПФР ЗиК 339. СЗВ-6-4 две незначительные ошибки: 1.При переносе сотрудника из одной пачки в другую у него теряются сведения о выплатах. 2.Неактивна кнопка сортировки сотрудников.

11.10.2013    12801    Cvetic    7    

Ошибка в 1С:Бух77 ред.533 Начисление ФФОМС при ЕНВД

Практика программирования Зарплата Зарплата v77::БУ 1С7:Бух Россия Бесплатно (free)

При начислении налогов с ФОТ (док.ЗакрытиеМесяца) не расчитываются налоги ФФОМС, если начисление зарплаты проводится как "облагаемые ЕНВД".

22.01.2012    10275    lelbraun    3    

Как заполнить справку 2-НДФЛ в Бухгалтерии 7.7?

Справки Зарплата Зарплата v77::БУ 1С7:Бух Россия БУ НДФЛ Бесплатно (free)

Многие при попытке сформировать справку 2 НДФЛ сталкиваются с ошибкой «Данных о доходах за 2011 год не обнаружено»

12.12.2011    35291    Myst_    18    

Перерасчет ФСС НС за предыдущий период в ЗиК 315

Адаптация типовых решений Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Если изменить базу вида расчета «ФСС НС», то в релизе 1С:Зарплата и Кадры 7.70.315, в текущем расчетном периоде не происходит перерасчет за предыдущие периоды.

02.11.2011    17678    Nicholas    13    

Неправильное изменение категории плательщика ПФР при проведении справки МСЭК

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

В ЗиК (релиз 314) при проведении документа "Справка МСЭК" вкралась ошибка: проведение некорректно изменяет категорию плательщика ПФР на "Работник сельскохозяйственной организации - инвалид", затем на "Работник колхоза, совхоза и другого сельскохозяйственного предприятия". Связано это с разными типами ожидаемого и возвращаемого перечисления в функции "глКатегорияПФР": "КатегорияПлательщикаПФ" и "КатегорииЗастрахованныхЛицПФР". Решение: изменить функцию "глКатегорияПФР" (около 2932-й строки).

17.10.2011    6360    Krokokot    3    

ЗиК: Заполнение данных о заработке у предыдущих работодателей в больничном

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ Бесплатно (free)

Доработка ЗиК 314. Заполнение данных в больничном за 2 предыдущих года у другого работодателя. Для работы необходимо добавить в конфигурацию новый справочник.

04.10.2011    11878    allexe    13    

Компенсация отпуска, оплата дней доноров и оплата льготных дней родителей в ЗиК

Практика программирования Зарплата Зарплата v77::Расчет 1cv7.md 1С7:ЗиК Россия Бесплатно (free)

"Компенсация отпуска"," Оплата дней доноров" и "Оплата льготных дней родителей" - эти виды расчетов должны облагаться страховыми взносами с 01.01.2011 года.

04.10.2011    9268    maxim305    18    

Отпуск по уходу за ребенком. Печать расчета среднего заработка

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ Бесплатно (free)

Печать расчета среднего заработка в документе "отпуск по уходу за ребенком" по старым/новым правилам, реализованная в ЗиК 7.70.313, содержит досадную ошибку - если вызвать печать в уже проведенном документе, всегда выдается отчет для новых правил.

23.09.2011    5638    Gr@nd@d    5    

1С 7.7 ЗиК. Доработка документа "Бригадный наряд" с возможностью увидеть часы в расчетном листке

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ Бесплатно (free)

Маленькая доработка модуля документа "Бригадный наряд" с возможностью увидеть часы в расчетном листке. Не забудьте, когда будете заполнять документ "Бригадный наряд", поставить галочку "Учитывать отработанные часы".

08.09.2011    7066    Ироида    14    

Расшифровка внутренних расчетов 1С:Зарплата

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

Трассировка (расшифровка) промежуточных расчетов документов в 1С:Зарплата

20.07.2011    10794    buhinfo    5    

Методика расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года (вариант)

Практика программирования Зарплата Зарплата v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Бесплатно (free)

В статье рассмотрен один из возможных вариантов расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года.

14.06.2011    22034    vkr    48    

Учет переплаты за прошлый период (персонифицированный учет в ПФР)

Практика программирования Зарплата Зарплата v77::ОУ 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Для того, чтобы в отчетности за текущий период учитывалась переплата по страховой/накопительной части, произведенная в прошлых отчетных периодах.

06.05.2011    5875    pavel_vrn    8    

Форма 1-НДФЛ для 2011 года (Зарплата и Кадры 7.7, релиз 310)

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ НДФЛ Бесплатно (free)

В прежних релизах была возможность из справочника "Сотрудники" сформировать форму 1-НДФЛ по кнопке "Ввод данных" (там была возможность расшифровки сумм). Вернём полезную функцию!

29.04.2011    6968    Q-Q    9    

ЗиК Расходы предприятия за счет ФСС. Реестр начисленных пособий за месяц.

Адаптация типовых решений Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Для больничных листов за 2010, проведенных в 2011, дни за счет работодателя = 3, вместо 2.

15.04.2011    16117    Cvetic    3    

Две простенькие функции для правильного учета сторно-записей и записей-перерасчетов

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ Бесплатно (free)

Часто при подсчете дней по записям журнала расчетов "Зарплата" берется знак "+" или "-" в зависимости от признака сторно-записи. Но рано или поздно результат получится ошибочным.

19.02.2011    11143    jack19    3    

Больничный лист по беременности и родам

Зарплата Бухгалтерский учет Зарплата v77::БУ 1С7:ЗиК Россия Бесплатно (free)

По новому законодательству можно теперь начислять пособия по беременности и родам, как по старым правилам, так и по новым, на усмотрение сотрудника. В ЗиК 306 и выше это не предусмотрено.

18.02.2011    11866    lel4ik    22    

Ошибки формата файла 2-НДФЛ в ЗиК релиз 306

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия НУ НДФЛ Бесплатно (free)

Ошибки 2НДФЛ в релизе: файл формируется как для ЮЛ, даже если работодатель ИП, опечатка "Отчетсвто", и указание имени файла с расширением. Нужно подправить отчет "СправкиПоНДФЛ".

02.02.2011    20202    1st    6    

ПФР за год

Зарплата Учет и отчетность v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Могу подсказать алгоритм, как надо заполнять документ "Расчеты по страховым взносам", чтобы отчет для ПФР сошелся в копеечку

29.01.2011    8849    Lika-Kalika    3    

ЗиК 305 ЗиК 306 Больничный лист.

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

Для переходящих больничных листов за счет работодателя оплачивается 2 дня, а не 3. Первоисточник: http://forums.kuban.ru/forum/viewtopi...669&page=2

25.01.2011    14922    Cvetic    26    

ЗиК 306 и ЗиК 305. Единовременные пособия из ФСС для организаций уплащивающих ЕНВД

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Возникла ошибка когда Единовременные пособия из ФСС неправильно вставали в "Карточку расчета страховых взносов" если были выплаченны после сентября месяца. и сотвественно неправильно формируеться РСВ-1

25.01.2011    10140    *Zed*    2    

Ошибка в ЗиК 300, 299, 298. Разные виды расчета имеют одинаковые синонимы.

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

В ЗиК 300, 299, 298 разные виды расчета имеют одинаковые синонимы. В следствие их неотличимости можно задать шаблон проводок не на тот вид расчета и получить ошибку "Некорректно сопоставляется проводка из подразделения сотрудника..."

19.09.2010    2977    safsn0    2    

Ускоритель СЗВ 2010 для ЗиК 2.99

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

Ускоряет формирование СЗВ примерно вполовину за счет уменьшения числа запросов. Реально полезно, когда надо часто и много заходить в редактирование форм СЗВ. ЗиК 2.99

20.07.2010    10045    aves    7    

ЗиК 298 Ошибка в исчислении стажа. Отчетность ПФР СЗВ-6.

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ Бесплатно (free)

Проблемы у сотрудников, имеющих Больничные листы, у которых либо Начало болезни = конец месяца либо Окончание болезни = начало месяца. В первом случае в СЗВ-6 началом болезни считается начало следующего месяца, во втором окончание болезни - конец месяца.

13.07.2010    12690    Cvetic    19    

ЗиК 7.7 заполнение данных по донорским дням в карточке "Сведения о стаже"

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

Сначала оговорюсь, что наша конфигурация неоднократно изменялась и от стандартной очень отличается, поэтому буду приводить куски кода без указания номеров строк. Документы по донорским дням вводятся в систему через документ «Оплата по среднему» вид расчета указывается «Дни доноров» (собственно добавленный нами вид расчета). Так как донорские дни не облагаются страховыми взносами, то и в стаж эти дни попадать не должны. Соответственно при сдачи отчетности в ПФР нужно заполнять карточку «Сведения о стаже». Это конечно можно было сделать вручную, когда документов не больше десятка, но когда их более 250, то бухгалтерам проблематично внести все отклонения в систему. Поэтому автоматизируем процесс :)

07.07.2010    4291    Zarema    3    

Ошибки при открытии форм отчета 4 ФСС в конфигурации УСН на платформе 7.7

Практика программирования Зарплата Зарплата v77::БУ 1С7:Бух Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Ошибки при открытии форм отчета 4 ФСС в конфигурации УСН на платформе 7.7, релиз 2010.1.004

07.04.2010    5562    Dr.ZIG    6    

Неприятная особенность налоговой декларации по НДС (раздел 3) v7. А также ошибка построения книг покупок и продаж.

Закрытие периода Налоговые Закрытие периода v77::БУ 1С7:Бух Россия БУ НДС Бесплатно (free)

Бухучет v77 ред. 4.5 - регламентированная отчетность Rp09q4.grp (релизы 09q4005/007) - Налоговая отчетность по НДС (раздел 3): в ячейке 130 (и некоторых других) может рассчитаться неверная сумма при перезаполнении уже сохраненного правильного варианта или первичного заполнения раздела 3, в таком случае в расшифровке этой ячейки некоторые документы ошибочно дублируются. Обновлено: книги покупок или продаж формируются с ошибочно задвоенными данными.

29.03.2010    10349    maxchaos    1    

НДФЛ удержанный

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия НДФЛ Бесплатно (free)

"НДФЛ исчисленный = НДФЛ удержанный" или как делать НЕЛЬЗЯ!

17.03.2010    13166    Nicholas    6    

Расчет среднего для переходящего больничного Зарплата и кадры 7.7 Релиз 293

Зарплата Практика программирования Зарплата v77::Расчет 1С7:ЗиК Россия БУ Бесплатно (free)

При расчете переходящего больничного (2009-2010) за 2010 год не выводятся данные при расчете среднего. Предлагаю обсудить решение проблемы для 293 релиза.

01.03.2010    6779    OlegAl    10