Значение текущей ячейки списка УФ

Публикация № 254906

Разработка - Практика программирования

Значение текущей ячейки управляемый список динамический список отбор в списке отбор в УФ

Получить значение из текущей ячейки списка в УФ - оказывается, не так-то просто. Особенно если хочется сделать универсальное решение. Предлагаю свой, достаточно общий способ. И до кучи - быстрый отбор по значению текущей колонки.

Как это было просто в обычном интерфейсе: ЭлементыФормы..ТекущиеДанные[ЭлементыФормы..ТекущаяКолонка.Имя]. И как это, оказывается, нетривиально для списков в УФ. Особенно в общем случае, который я и рассматривал, работая с ТекущимиДанными как с ДаннымиФормыбезотносительно их происхождения и наполнения. 

Как известно, колонки динамического списка могут являться разыменованиями колонок-полей основной таблицы/запроса, причём они могут быть добавлены как в Конфигураторе, так и пользователем либо программистом в режиме Предприятие. И вот тут 1С немного "поленились": если для "штатно" объявленных полей таблицы/запроса ещё работает ТекущиеДанные[ИмяКолонки] и для них ТекущиеДанные.Свойство(ИмяКолонки) возвращает истину, то вот уже полей, добавленных в Конфигураторе как разыменование, хоть на 1 шаг вперёд, нет возможности получить их значение. Видеть - видим, программно не получаем. Но это ещё терпимо, т.к. для таких полей есть свойство их реквизита ПутьКДанным, по которому можно, исходя из "штатно" объявленных полей, вытащить значение.

Дальше интереснее. Поля, добавленные в режиме "Предприятие" как разыменование имевшихся (и неважно, штатно-объявленных основных полей или разыменованных в конфигураторе), - эти поля вообще никак не ущучить. Для них свойство "ПутьКДанным" вообще не поддерживается, не говоря уж о ТекущиеДанные[ИмяКолонки]. Видеть - видим, общий отбор обычным образом поставить можем, а получить видимое невооружённым глазом значение ячейки программно - нет.

Да, у таких добавленных разыменованных полей есть имена. Говорящие имена. И на этом были основаны пара решений, которые на ИС появились ещё в лохматые времена. НО: у них есть один недостаток. Как известно, работая с путями к данным, которые надо преобразовать в валидные имена 1С, любая СКД в системном представлении заменяет точки на знак подчёркивания. И вот теперь у нас есть развлечение: мы знаем имя поля, но в общем виде мы не гарантированы, что разработчик не употреблял знак подчёркивания в своих целях, а значит, нам придётся отличать, который из знаков подчёркивания в имени поля, например, вида Главное_Событие_Тип_События_Код задан разработчиком, а который подсунут СКД при преобразовании пути. СКД динамического списка тут не исключение.

Заметим также, что СКД ещё и стандартные реквизиты именует латиницей (DeletionMark, а не ПометкаУдаления), притом что локализованная 1С при переборе коллекции метаданных СтандартныеРеквизиты в их свойстве "Имя" возвращает-таки русскоязычное написание.

Ничего не скажу плохого про другие варианты решений, но проблему подчёркиваний там, насколько видел, не решали. Мне пришлось решить. Выкладываю прямо тут. Некоторая странность функции ПолучитьЗначениеТекущейЯчейки объясняется желанием уконтрапупить всё в одну функцию, чтобы удобнее было таскать между модулями. При желании функцию ПолучитьЭлементыИРеквизитыДинамическогоСписка также можно засунуть внутрь, указав соответствующий РежимВызова. Словом, место для извращений есть.

// Получает массив структур, описывающих Имя,Путь,ТипЗначения (как описание типов) для реквизитов,
// входящих в реквизит списка (в первую очередь это надо для колонок, но на всякий случай там все).
// При ошибке возвращает Неопределено.
//
// Параметры:
//    рФорма - сериализованная (т.е. вызванная из &НаСервере) форма, где находится реквизит-список
//    рИмяРеквизитаСписка - имя реквизита формы, который рассматриваем
//

Функция ПолучитьЭлементыИРеквизитыДинамическогоСписка(рФорма,рИмяРеквизитаСписка) Экспорт
Попытка
   
рез=Новый Массив;
   
трек=Новый ТаблицаЗначений;
   
трек.Колонки.Добавить("Имя");
   
трек.Колонки.Добавить("Путь");
   
трек.Колонки.Добавить("ТипЗначения");
   
мрек=рФорма.ПолучитьРеквизиты(рИмяРеквизитаСписка);
    Для каждого
рек Из мрек Цикл
       
ЗаполнитьЗначенияСвойств(трек.Добавить(),рек);
    КонецЦикла;
   
//
   
Для каждого эл Из рФорма.Элементы[рИмяРеквизитаСписка].ПодчиненныеЭлементы Цикл
       
стротрек=трек.Найти(эл.Имя,"Имя");
        Если
стротрек=Неопределено Тогда
           
// ищем через разыменование его пути
           
мстро=ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(эл.ПутьКДанным,".");
            Если
мстро.Количество()<2 Тогда Продолжить КонецЕсли;
           
// поэтапно разыменовываем
           
рПутьВычисления=СокрЛП(мстро[0]);
            Для
й=1 По мстро.Количество()-2 Цикл
               
рИмяПредка=СокрЛП(мстро.Получить(й));
               
рИмяЗвена=СокрЛП(мстро.Получить(й+1));
               
стротрек=трек.Найти(рИмяПредка,"Имя");
                Если
стротрек=Неопределено Тогда
                   
Сообщить("Предыдущее звено "+рИмяПредка+" не найдено в таблице реквизитов!",СтатусСообщения.Важное);
                Иначе
                   
мТипов=Новый Массив; // массив возможных типов значений звена пути, разыменованного от кого-то исходного
                   
Для каждого рТипПредка Из стротрек.ТипЗначения.Типы() Цикл
                       
метадан=Метаданные.НайтиПоТипу(рТипПредка);
                        Если
метадан=Неопределено Тогда // возможно, это вообще значение атомарного типа
                            //Сообщить("Для типа "+Представления.ПредставлениеТипа(рТипПредка)+" не удалось найти метаданные!",СтатусСообщения.Важное);
                       
Иначе
                           
// ищем реквизит (ничем более, полагаем пока, оно являться не может, хоть при динамсписке, хоть статично)
                           
метарек=метадан.Реквизиты.Найти(рИмяЗвена);
                            Если
метарек=Неопределено Тогда
                               
// ищем среди стандартных
                               
Для каждого стандрек Из метадан.СтандартныеРеквизиты Цикл
                                    Если
стандрек.Имя=рИмяЗвена Тогда метарек=стандрек; Прервать КонецЕсли;
                                КонецЦикла;
                            КонецЕсли;
                            Если
метарек=Неопределено Тогда
                               
Сообщить("Для метаобъекта "+метадан.Представление()+" не найден реквизит "+рИмяЗвена+"!",СтатусСообщения.Важное);
                            Иначе
                               
рПутьВычисления=рПутьВычисления+"."+метарек.Имя;
                                Для каждого
рТип Из метарек.Тип.Типы() Цикл
                                   
мТипов.Добавить(рТип);
                                КонецЦикла;
                            КонецЕсли;
// если у метареквизитов предка есть такой
                       
КонецЕсли; // если в метаданных нашли метапредка по одному из типов
                   
КонецЦикла; // по типам значений предка
                   
Если мТипов.Количество()<>0 Тогда // вносим в таблицу реквизитов текущее звено
                       
рТекущееОписТипов=Новый ОписаниеТипов(мТипов);
                       
рПуть=""; разд="";
                        Для
ы=1 По й+1 Цикл
                           
рПуть=рПуть+разд+СокрЛП(мстро[ы]); разд=".";
                        КонецЦикла;
                        Если
трек.НайтиСтроки(Новый Структура("Имя,Путь",рИмяЗвена,рПуть)).Количество()=0 Тогда
                           
стротрек=трек.Добавить();
                           
стротрек.Имя=рИмяЗвена;
                           
стротрек.Путь=рПуть;
                           
стротрек.ТипЗначения=рТекущееОписТипов;
                        КонецЕсли;
                    КонецЕсли;
                КонецЕсли;
// если запись о предке нашли в таблице реквизитов
           
КонецЦикла; // по массиву кусков пути
            // если всё сделали верно, то теперь такое поле в таблице реквизитов есть, вносим
           
стру=Новый Структура;
           
стру.Вставить("Имя",эл.Имя);
           
стру.Вставить("Путь",рПуть);
           
стру.Вставить("ТипЗначения",рТекущееОписТипов);
           
рез.Добавить(стру);
        Иначе
           
стру=Новый Структура;
           
стру.Вставить("Имя",эл.Имя);
           
стру.Вставить("Путь",СтрЗаменить(эл.ПутьКДанным,"Список.",""));
           
стру.Вставить("ТипЗначения",стротрек.ТипЗначения);
           
рез.Добавить(стру);
        КонецЕсли;
    КонецЦикла;
   
//
   
Возврат рез;
Исключение
   
Сообщить("ПолучитьЭлементыИРеквизитыДинамическогоСписка, ошибка: "+ОписаниеОшибки(),СтатусСообщения.ОченьВажное);
    Возврат Неопределено;
КонецПопытки;
КонецФункции

 

&НаСервере
// Получение из динам.списка на форме того значения, что находится на пересечении текущей строки и текущей колонки.
// При ошибке возвращает Неопределено.
//
// Входные параметры:
//     рПараметры - структура, обязательно содержащая поля ТекущиеДанные (из списка) и ИмяПоля (строковое имя тек.колонки)
//          также можно передать массив структур "ЭлементыИРеквизиты", получаемый ПолучитьЭлементыИРеквизитыДинамическогоСписка();
//          поле "РежимВызова" можно не указывать, или указывать пустой строкой, или равным "Получение". Прочие варианты - служебные!
//
// Функция содержит внутри себя, по сути, 1 функцию и 1 процедуру, для удобства копипаста объединены, различаются Режимом.
// ВАЖНО: Функция работает, исходя из условия, что элемент динам.списка и реквизит динам.списка имеют одинаковые имена!!!
//

Функция ПолучитьЗначениеТекущейЯчейки(рПараметры)
   
рРежим=?(рПараметры.Свойство("РежимВызова"),СокрЛП(рПараметры.РежимВызова),"");
    Если
ПустаяСтрока(рРежим) Тогда рРежим="Получение" КонецЕсли;

    Если
рРежим="Получение" Тогда
       
текдан=рПараметры.ТекущиеДанные;
       
рИмяПоля=рПараметры.ИмяПоля; // имя текущей колонки
       
ЭиР=?(рПараметры.Свойство("ЭлементыИРеквизиты"),рПараметры.ЭлементыИРеквизиты,Неопределено);
       
//
       
Если ЭиР=Неопределено Тогда
           
ЭиР=ПолучитьЭлементыИРеквизитыДинамическогоСписка(ЭтаФорма,рПараметры.ИмяЭлементаИРеквизитаСписка);
           
рПараметры.Вставить("ЭлементыИРеквизиты",ЭиР);
        КонецЕсли;
       
//
        // здесь же, если надо, преобразование англоязычных служебных полей в русскую нотацию (вместо _Code делаем _Код)
       
Если текдан.Свойство(рИмяПоля) Тогда // штатно объявленное поле 1-го уровня
           
рЗначение=текдан[рИмяПоля];
           
рПараметры.Вставить("ПутьКДанным",рИмяПоля);
        Иначе
// разыменованное как-либо поле
            // ищем среди сведений об элементах и реквизитах
           
рНужное=Неопределено;
            Для каждого
эл Из ЭиР Цикл
                Если
Лев(рИмяПоля,СтрДлина(СокрЛП(эл.Имя)))=СокрЛП(эл.Имя) Тогда
                   
рНужное=эл; Прервать;
                КонецЕсли;
            КонецЦикла;
            Если
рНужное<>Неопределено Тогда // скорее всего, разыменованное как-либо
               
Если СокрЛП(рНужное.Имя)=рИмяПоля Тогда // точное совпадение - значит, разыменование было в конфигураторе
                   
Выполнить("рЗначение=текдан."+СокрЛП(рНужное.Путь));
                   
рПараметры.Вставить("ПутьКДанным",рНужное.Путь);
                Иначе
// скорее всего, разыменованное от разыменованного, в т.ч. добавленное динамически
                    // первый шаг надо делать от имеющихся полей текдан, и они возможны любые, поэтому привлекаем ЭиР,
                    // а далее возможны лишь их реквизиты, т.е. простые разыменования, и там вся задача лишь в преобразовании
                    // имеющегося сейчас пути (только знаки подчёркивания) в путь правильного формата, через точку (где надо).
                    //
                   
рПараметрыДалее=Новый Структура;
                   
рПараметрыДалее.Вставить("РежимВызова","Разыменование");
                   
рПараметрыДалее.Вставить("ИмяЭлементаИРеквизитаСписка",рПараметры.ИмяЭлементаИРеквизитаСписка);
                   
рПараметрыДалее.Вставить("ИмяПуть",рИмяПоля);
                   
рПараметрыДалее.Вставить("ОсталосьРазобрать",рИмяПоля);
                   
рПараметрыДалее.Вставить("ИмяИсходногоПоля",СокрЛП(рНужное.Имя));
                   
рПараметрыДалее.Вставить("ОписТиповИсходногоПоля",рНужное.ТипЗначения);
                   
ПолучитьЗначениеТекущейЯчейки(рПараметрыДалее);
                   
рИмяПуть=рПараметрыДалее.ИмяПуть;
                   
//
                   
рПараметрыДалее=Новый Структура("ТекущиеДанные,ИмяПоля,ЭлементыИРеквизиты",текдан,СокрЛП(рНужное.Имя),ЭиР);
                   
рЗначениеИсхПоля=ПолучитьЗначениеТекущейЯчейки(рПараметрыДалее);
                   
рПутьБезИсходного=СтрЗаменить(рИмяПуть,СокрЛП(рНужное.Имя)+".","");
                    Выполнить(
"рЗначение=рЗначениеИсхПоля."+СокрЛП(рПутьБезИсходного));
                   
рПараметры.Вставить("ПутьКДанным",рИмяПуть);
                КонецЕсли;
            Иначе
               
рЗначение=Неопределено; // такого имени не нашли по началу строки ни одного из имён элементов (некая неучтённая ситуация)
               
рПараметры.Вставить("ПутьКДанным","");
            КонецЕсли;
        КонецЕсли;
       
//
       
Возврат рЗначение;

    ИначеЕсли
рРежим="Разыменование" Тогда
       
рИмяПуть=рПараметры.ИмяПуть;
       
рОсталосьРазобрать=рПараметры.ОсталосьРазобрать;
       
рИмяИсходногоПоля=рПараметры.ИмяИсходногоПоля;
       
рОписТиповИсходногоПоля=рПараметры.ОписТиповИсходногоПоля;
       
//
       
рИмяПуть=СтрЗаменить(рИмяПуть,рИмяИсходногоПоля+"_",рИмяИсходногоПоля+".");
       
рПараметры.Вставить("ИмяПуть",рИмяПуть); // это должно меняться внутри процедуры
        //
       
Если Найти(рОсталосьРазобрать,рИмяИсходногоПоля+"_")<>0 Тогда
           
рОсталосьРазобрать=СтрЗаменить(рОсталосьРазобрать,рИмяИсходногоПоля+"_","");
        Иначе
            Если
рОсталосьРазобрать=рИмяИсходногоПоля Тогда Возврат Неопределено КонецЕсли; // уже всё
       
КонецЕсли;
        Если
ПустаяСтрока(рОсталосьРазобрать) Тогда Возврат Неопределено КонецЕсли; // уже всё
        //
        // и теперь от этого исходного ищем уже просто в реквизитах, перебирая все возможные типы исходного поля
       
рИмяНужногоРеквизита="";
       
мТиповИтого=Новый Массив;
        Для каждого
рТип Из рОписТиповИсходногоПоля.Типы() Цикл
           
#Если Клиент Тогда
               
ОбработкаПрерыванияПользователя();
           
#КонецЕсли
           
рНужныйРеквизит=Неопределено;
           
метадан=Метаданные.НайтиПоТипу(рТип);
            Если
метадан=Неопределено Тогда Продолжить КонецЕсли;
            Для каждого
метарек Из метадан.Реквизиты Цикл
                Если
Лев(рОсталосьРазобрать,СтрДлина(метарек.Имя))=метарек.Имя Тогда рНужныйРеквизит=метарек; Прервать КонецЕсли;
            КонецЦикла;
            Если
рНужныйРеквизит=Неопределено Тогда // ищем среди стандартных
               
Для каждого метарек Из метадан.СтандартныеРеквизиты Цикл
                    Если
Лев(рОсталосьРазобрать,СтрДлина(метарек.Имя))=метарек.Имя Тогда рНужныйРеквизит=метарек; Прервать КонецЕсли;
                КонецЦикла;
            КонецЕсли;
           
// у объектов с разными типами и метатипами могут быть одноимённые реквизиты с разными типами значений.
            // поэтому имя-то общее, а вот типы надо накопить, чтобы разыменовать все возможные варианты значений
           
Если рНужныйРеквизит<>Неопределено Тогда
               
рИмяНужногоРеквизита=рНужныйРеквизит.Имя;
                Для каждого
рТипРеквизита Из рНужныйРеквизит.Тип.Типы() Цикл
                   
мТиповИтого.Добавить(рТипРеквизита);
                КонецЦикла;
            КонецЕсли;
        КонецЦикла;
       
// если есть какие-то типы и имя для реквизита, можем рассмотреть следующий шаг
       
Если мТиповИтого.Количество()<>0 и не ПустаяСтрока(рИмяНужногоРеквизита) Тогда
           
рПараметрыДалее=Новый Структура;
           
рПараметрыДалее.Вставить("РежимВызова","Разыменование");
           
рПараметрыДалее.Вставить("ИмяПуть",рИмяПуть);
           
рПараметрыДалее.Вставить("ОсталосьРазобрать",рОсталосьРазобрать);
           
рПараметрыДалее.Вставить("ИмяИсходногоПоля",рИмяНужногоРеквизита);
           
рПараметрыДалее.Вставить("ОписТиповИсходногоПоля",Новый ОписаниеТипов(мТиповИтого));
           
ПолучитьЗначениеТекущейЯчейки(рПараметрыДалее);
           
рПараметры.Вставить("ИмяПуть",рПараметрыДалее.ИмяПуть); // это должно меняться внутри процедуры
       
КонецЕсли;

    КонецЕсли;
КонецФункции


 

 

Что ещё из интересного успел пронаблюдать:

1. В настройке формы поля с подчёркиванием и без штатных представлений ооочень забавно выглядят... Посмотрите сами ))
2. При изменении данных объявленные в конфигураторе обновляются, а добавленные динамически в 1С - нет. Приходится переоткрывать форму. Или это у меня релиз такой (19.83), или лыжи не совсем едут.
3. Несмотря на то, что стандартные реквизиты в служебных именах СКД списка даёт латиницей, в диалоге настройки списка установленные исходя из англоязычных термов отборы представлены по-русски.
4. Если разыменованное поле имеет тип Булево, но путь разыменования прерван пустым значением (т.е. до конечного значения просто нельзя дойти), показ псевдозначения поля в этой колонке всё равно будет, равный "нет", но при отборе по "Нет" он эту строку в удовлетворяющие отбору не включит. Спецэффект, вызывающий недоумение пользователей. 

И "до кучи" предлагаю процедуру установки "быстрого отбора" по значению текущей колонки. Да, есть отборы, вызываемые через "Настроить список", да, есть поиск с множественным отображением, но привычка пользователя - страшная штука, да и нажатий меньше.


&НаКлиенте
// Установка отбора по значению текущей колонки в текущей строке
// Параметры:
//    рИмяСписка - имя элемента формы списка, оно же имя реквизита списка
//
// ВАЖНО: Функция работает, исходя из условия, что элемент динам.списка и реквизит динам.списка имеют одинаковые имена!!!
//

Процедура УстановитьОтборПоЗначениюТекущейКолонки(рИмяСписка)
Попытка
   
текдан=Элементы[СокрЛП(рИмяСписка)].ТекущиеДанные;
    Если
текдан=Неопределено Тогда Возврат КонецЕсли; // вообще ничего не ставим и не сообщаем
   
теккол=Элементы[СокрЛП(рИмяСписка)].ТекущийЭлемент;

   
рПараметры=Новый Структура("ТекущиеДанные,ИмяПоля",текдан,теккол.Имя);
   
рПараметры.Вставить("ИмяЭлементаИРеквизитаСписка",СокрЛП(рИмяСписка));
   
рЗначение=ПолучитьЗначениеТекущейЯчейки(рПараметры);
    Если
рЗначение=Неопределено Тогда
       
Предупреждение("Отбор по текущей колонке невозможен, нельзя получить значение отбора!"); Возврат
    КонецЕсли;

   
мстро=ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(рПараметры.ПутьКДанным,".");
   
рИсходноеПоле=СокрЛП(мстро.Получить(0));
   
ЭиР=рПараметры.ЭлементыИРеквизиты;
   
рНачалоПути="";
    Для каждого
эл Из ЭиР Цикл
        Если
СокрЛП(эл.Имя)=рИсходноеПоле Тогда
           
рНачалоПути=СокрЛП(эл.Путь); Прервать;
        КонецЕсли;
    КонецЦикла;
    Если
ПустаяСтрока(рНачалоПути) Тогда
       
Предупреждение("Отбор по текущей колонке невозможен, нельзя определить путь отбора!"); Возврат
    КонецЕсли;
   
рИтоговыйПуть=СтрЗаменить(рПараметры.ПутьКДанным,рИсходноеПоле+".",рНачалоПути+".");

   
рПоле=Новый ПолеКомпоновкиДанных(рИтоговыйПуть);
   
//
    // У отбора динам.списка есть интересный глюк: он не может фигурировать в процедурах/функциях как
    // аргумент, если есть шансы, что он там изменится (т.е. не объявлен в параметрах через Знач), поэтому
    // в ПолучитьОтборСКД он определяется именно так; в результате элотб как элемент отбора хранит все
    // нужные данные, но НЕ наследуется от Список.Отбор и поэтому не реагирует на изменение свойств;
    // в частности, ему бесполезно ставить Используется=Истина; поэтому удаляем и заново создаём его.
    // поскольку это, как правило, отбор первого уровня (т.е. группы не используются), то чуть схалявим
     // и обойдёмся без рекурсии. При прямом поиске перебором элемент "наследуется".
   
элотб=Неопределено;
    Для каждого
эл Из ЭтаФорма[СокрЛП(рИмяСписка)].Отбор.Элементы Цикл
        Если
эл.ЛевоеЗначение=рПоле Тогда элотб=эл; Прервать КонецЕсли;
    КонецЦикла;
    Если
элотб<>Неопределено Тогда
       
ЭтаФорма[СокрЛП(рИмяСписка)].Отбор.Элементы.Удалить(элотб);
    КонецЕсли;
   
элотб=ЭтаФорма[СокрЛП(рИмяСписка)].Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
   
элотб.ЛевоеЗначение=рПоле;
   
элотб.ВидСравнения=ВидСравненияКомпоновкиДанных.Равно;
   
элотб.ПравоеЗначение=рЗначение;
   
элотб.Использование=Истина;
Исключение
   
Сообщить("УстановитьОтборПоЗначениюТекущейКолонки, ошибка: "+ОписаниеОшибки(),СтатусСообщения.ОченьВажное);
КонецПопытки;
КонецПроцедуры


&НаКлиенте
// Собственно отработка команды
Процедура ОтборПоТекущейКолонке(Команда)
   
УстановитьОтборПоЗначениюТекущейКолонки("Список");
КонецПроцедуры

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Рейтинг 1-го уровня
5. nixel 920 10.02.14 16:44 Сейчас в теме
Отбор по значению в текущей колонке добавят в одном из новых релизов 8.3 (возможно даже уже в 8.3.5).
А вот за методику текущей ячейки - спасибо :)
6. Bukaska 133 10.02.14 17:06 Сейчас в теме
Интересно... Хоть я ещё и плохо соображаю в динамических списках, но буду вникать))) Спасибо за информацию)))
1. Yashazz 3408 29.01.14 13:09 Сейчас в теме
Да, и ещё примечание для эстетов - во встроенной коллекции картинок 1С теперь отсутствуют иконки для быстрого отбора и для снятия отборов, придётся откуда-то брать; я из 8.1 вытаскивал.
2. Gendalf_beliy 29.01.14 13:33 Сейчас в теме
во встроенной коллекции картинок 1С теперь отсутствуют иконки для быстрого отбора и для снятия отборов, придётся откуда-то брать; я из 8.1 вытаскивал.

где-то тут, по-моему, видел подборку картинок для использования в 1с, но уже точно не помню. А вообще было бы неплохо создать ресурс, где можно было бы найти не кучу картинок, а пару-тройку и под необходимую тематику. Что на какую-либо функцию было с десяток картинок и можно было выбрать подходящую.
10. monkbest 109 07.08.14 15:36 Сейчас в теме
Если столько кода надо написать для отбора по текущему значеню, то в топку такой отбор)))
Еще не очень понял, почему нельзя штатно нажать Ctrl+F и сразу Enter. Это же и есть отбор по текущей ячейке? Зачем его программировать?
Или я не понял суть статьи, прокомментируйте пожалуйста на пальцах, какое действие (желание) пользователя тут автоматизируется.
4. Al-X 05.02.14 10:39 Сейчас в теме
Интересно. Надеюсь пригодится...
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37203    unichkin    72    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    25354    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    22857    John_d    22    

Последовательности событий. Шпаргалка

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    17430    kuzyara    33    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    30042    tormozit    100    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    16842    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8238    Sibars    19    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    32302    Yashazz    50    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    77785    tormozit    131    

Оповещения боту из 1С за 31 минуту

Практика программирования Интеграция v8::УФ 1cv8.cf Бесплатно (free)

Поделюсь опытом, как быстро сделать бота с оповещениями в Телеграмм из 1С без лишних затрат.

18.09.2019    16941    feva    41    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    48142    rpgshnik    63    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    48208    ids79    54    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    48148    tormozit    41    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    27801    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    25304    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    31066    ids79    16    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    44591    tormozit    74    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    79136    ids79    49    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    34235    avalakh    22    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    23173    json    13    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16006    m-rv    2    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    57885    ids79    11    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    35336    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    25817    YPermitin    14    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20125    m-rv    17    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19540    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    45205    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    51506    ids79    25    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    30445    m-rv    21    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    24797    dmurk    145    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    42309    YPermitin    30    

Выполнение внешней обработки в фоновом задании

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    29218    Eret1k    23    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28192    itriot11    34    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    35083    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27269    ellavs    88    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    31081    YPermitin    53    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76150    Serginio    108    

Добавление отчетов в типовые конфигурации 1С

Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем) v8::УФ v8::СКД 1cv8.cf Бесплатно (free)

Описание различных способов добавления общих и контекстных отчетов в конфигурации 1С, построенные на базе БСП. Основные моменты и нюансы.

07.03.2019    53079    ids79    45    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    38455    Смешной 1С    28    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    21737    Vladimir Litvinenko    27    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    34450    ids79    40    

Функциональные опции 1С 8.3 – все возможные варианты использования

Практика программирования Разработка v8::УФ 1cv8.cf Бесплатно (free)

Примеры использования функциональных опций для управления интерфейсом и элементами управляемых форм, с различными вариантами хранения значений: константа, реквизит справочника, ресурс регистра сведений.

22.02.2019    34088    ids79    14    

Информирование пользователя. Работа с объектом «СообщениеПользователю»

Практика программирования Разработка v8::УФ 1cv8.cf Бесплатно (free)

Различные варианты и нюансы использования объекта СообщениеПользователю и другие способы информирования пользователя: без привязки к какой-либо форме и с выводом сообщения в отдельном окне.

15.02.2019    50619    ids79    49    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29147    grumagargler    28    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    38776    ids79    9    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    26535    ids79    31    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    52448    m-rv    61    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    40954    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    36687    ids79    42