Рисунки табличного документа: вставить, куда надо

Публикация № 531533

Разработка - Практика программирования

прайс с картинками изображения в mxl рисунки рисунки в табличном документе табличный документ mxl xml-сериализация пример xpath

Надо вывести рисунки в некоторых ячейках таб.документа, но как эти ячейки и области найти? Всем прайс-листам с картинками товаров и тому подобному посвящается...

Тривиальная задача вывода в табличный документ рисунков, того или иного вида и формата, начиная с 7.7 и до сих пор не имеет красивого универсального решения. Да, существует несколько общеизвестных приёмов, но большинство их базируется либо на собственном, заранее подготовленном макете, и значит, неуниверсально, либо на обработке уже сформированного таб.документа путём его поячейного рассмотрения, что долго и не очень надёжно. Кроме того, сложностью является и размещение рисунка, т.к. однозначной привязки координат рисунка к областям таб.документа не существует, равно как и корреляции размеров рисунка, задаваемых в миллиметрах, с шириной области, задаваемой в условных символах, и особенно с высотой (задаваемой в пунктах). Учтём также, что, несмотря на заверения СП, при свойстве "АвтоВысота" = Истина высота строки всегда нулевая, и узнать её, реальную, невозможно. В этих условиях размещение рисунка превращается в стрельбу по тарелочкам ночью вслепую.

Идея, использованная в публикации, баянна и банальна - сериализовать табличный документ в строку, сделать те действия, которые минимально необходимы и/или единственно возможны только с xml-текстом, и сериализовать обратно, после чего уже с помощью языка 1С доустановить нужное. Как показали эксперименты, привязка рисунка к области ячейки всё же есть, но только в xml, поэтому она там и указывается. Там же создаётся сам рисунок, и выставляются основные свойства по умолчанию, которые потом уже можно переустановить, а также имя и тип, которые поменять позже нельзя.

Разумеется, можно добиться нужного формата прямо в тексте xml, но это более громоздко, менее надёжно и вообще для любителей - например, xml чувствителен к порядку блоков <format>, а рисунки ссылаются на них по их индексам как по порядку расположения в тексте, чуть перепутаете - съедет всё форматирование. В этом смысле приятно, что <namedItem> имеет чёткую привязку по индексу. Также, например, можно устанавливать картинку для "картинки", указав её Base64 в элементе <picture>, но там тоже важен порядок блоков, да и громоздко это.

Реализация ближе к парсингу готового документа, но всё-таки не по ячейкам в цикле, а с помощью XPath. Не стоит пугаться, в большинстве случаев XPath-запросы окажутся просты и понятны. Например, в приведённом примере я ищу вхождения ссылок на справочник "Номенклатура" в расшифровках ячеек (тег "d", атрибут "xsi:type"). Это позволяет быстро найти именно нужные узлы. Исходя из узлов, определяются № строки и № колонки, где таковая ячейка нашлась. А это значит, что мы не зависим от формата документа, и табличный документ может иметь любой вид, быть любым выходным результатом СКД - и неважно, какие там уровни, да группировки, да колонки, объёдинённые и не очень. Найти содержание в xml можно однозначно, если правильно составить запрос XPath.

Конечно, дальше могут начаться некоторые сложности. Например, высоту строки всё равно придётся либо подгонять, либо делать с запасом. Объединённые ячейки могут привнести свою специфику позиционирования. И, увы, то, что мне победить не удалось - размеры рисунка придётся всё так же подгонять методом тыка, зависимостей я не делал. Но хоть размещён рисунок будет правильно, уже что-то)

Итак, что может процедура: вставить рисунки нужных типов в нужные области табличного документа, установить свойства этих рисунков, и всё это с гораздо меньшей зависимостью от формата и наполнения этого таб.документа.

Зачем публикация - поделиться способом; а ещё продемонстрировать, что xml-ипостась привычных нам общих объектов 1С в некоторых случаях даёт интересные возможности, но не является панацеей, и что совместное применение разных приёмов очень даже нормальный способ решения задачи.

Сразу извиняюсь, что выкладываю без "разукрашки" кода, но она съедает теги.

 

Тестировалось под толстым клиентом, но, подозреваю, всё это спокойно компилится как на клиенте, так и на сервере во всех вариациях. Если только в параметрах попадётся нечто, непригодное к передаче на сервер, но это уж на ваше усмотрение.

// Выводит рисунки в табличный документ согласно указанным данным, позволяет вывести рисунки в те ячейки (области), которые, будучи сериализованы,
// удовлетворяют указанным условиям по XPath (т.е. найти по тексту и/или расшифровке, или по другим данным-тегам); не изменяет в формате документа
// ничего, кроме высоты строк (чтобы поместились рисунки).
// Процедура изменяет табличный документ внутри себя.
//
// Параметры:
// тд - обрабатываемый табличный документ произвольного вида;
// ОбрабатываемыеОбласти - массив структур,
// где обязательны ключи:
// ВыражениеXPath - строка, поисковое выражение XPath, позволяющее определить нужную область (ячейку) в сериализованном таб.документе,
// ко всем областям, удовлетворяющим выражению, будет применено добавление рисунка с соответственно указанными данными и свойствами;
// ВысотаСтроки - число, в пунктах, обязательно указывать так, чтобы добавляемый рисунок по высоте помещался в нужную область;
// НомерКолонки - число, от 1 до N, куда выводить рисунки; если не указано, то рисунки выводятся в колонки, где найдено по выражению поиска;
// КлючПолученияКлючаДанных - строка, имя атрибута найденного узла или "ТекстовоеСодержимое"), указание на источник сведений, которые
// будут использованы для поиска данных, соответствующих конкретному найденному узлу, чтобы установить свойства именно "его" рисунка;
// Данные - соответствие; в нём выполняется поиск по ключу, полученному с помощью КлючПолученияКлючаДанных; если данные не найдены,
// то рисунок не добавляется и обработка не происходит; в соответствии должны быть:
// ключи - некие уникальные данные, обычно это GUID той ссылки, которая сериализована как расшифровка, или строковое значение тех данных,
// что отображены в тексте ячейки;
// значения - причём значение соответствия это обязательно структура:
// * обязательно наличие ключей ЛевоВЯчейке, ПравоВЯчейке, ВерхВЯчейке, НизВЯчейке - они определяют размещение рисунка в его области;
// * прочие ключи этой структуры должны совпадать с именами свойств объекта "РисунокТабличногоДокумента", и будут ему установлены;
// * ПроизвольноеВыражение - строка, содержащая выполняемый код на 1С, пригодный для исполнения в "Выполнить"; на вход может получать
// любые сведения, которые доступны в контексте процедуры; в частности, "тд" как таб.документ, "рРисунок" как конкретный рисунок и т.д;
// может выполняться только в режимах, отличных от ВебКлиента.
// где необязательны ключи:
// СвойстваОбласти - структура с ключами, совпадающими с именами системных свойств Области,
// будет применено непосредственно к той области, для которйо выполнится поисковое выражение и куда будет помещён рисунок.
//
Процедура ВставитьРисункиВТабличныйДокумент(тд,рПараметры)
Попытка
// сериализуем табличный документ и получаем его DOM
хмлЗапись=Новый ЗаписьXML;
хмлЗапись.УстановитьСтроку("UTF-8");
СериализаторXDTO.ЗаписатьXML(хмлЗапись,тд); // можно без явного назначения типа
тдСтрокой=хмлЗапись.Закрыть();
//
тдСтрокой=СтрЗаменить(тдСтрокой,"xmlns=","xmlns:doit="); // иначе не будет работать XPath
//
хмлЧтение=Новый ЧтениеXML;
хмлЧтение.УстановитьСтроку(тдСтрокой);
постр=Новый ПостроительDOM;
докдом=постр.Прочитать(хмлЧтение);
//
рРазыменователь=Новый РазыменовательПространствИменDOM(докдом);

рШиринаТД=тд.ШиринаТаблицы;

стрВставляемых="";

мКОбработке=Новый Массив;
Для каждого обрОбласть Из рПараметры.ОбрабатываемыеОбласти Цикл
// разыскиваем согласно поисковому выражению
рВыражение=СокрЛП(СтрЗаменить(обрОбласть.ВыражениеXPath,"""","'"));
рРезультат=докдом.ВычислитьВыражениеXPath(рВыражение,докдом,рРазыменователь);
Пока Истина Цикл
#Если Клиент Тогда
ОбработкаПрерыванияПользователя();
#КонецЕсли
рУзелДанных=рРезультат.ПолучитьСледующий();
Если рУзелДанных=Неопределено Тогда Прервать КонецЕсли;
Если ТипЗнч(рУзелДанных)<>Тип("ЭлементDOM") Тогда Продолжить КонецЕсли;

// получаем рабочие ключевые данные (сведения из БД, связанные с рисунком)
рКлюч=СокрЛП(обрОбласть.КлючПолученияКлючаДанных);
рКлючДляДанных=Неопределено;
Если рКлюч="ТекстовоеСодержимое" Тогда
рКлючДляДанных=рУзелДанных.ТекстовоеСодержимое;
ИначеЕсли рУзелДанных.ЕстьАтрибут(рКлюч) Тогда // рассматриваем как атрибут
рКлючДляДанных=рУзелДанных.ПолучитьАтрибут(рКлюч);
КонецЕсли;
Если не ЗначениеЗаполнено(рКлючДляДанных) Тогда Продолжить КонецЕсли;
// ищем в данных (это соответствие)
рДанныеДляРисунка=обрОбласть.Данные.Получить(рКлючДляДанных);
Если ТипЗнч(рДанныеДляРисунка)<>Тип("Структура") Тогда Продолжить КонецЕсли;

// определяем вышестоящие рабочие узлы
рРодитель=рУзелДанных;
рДанныеКолонки=Неопределено; рДанныеСтроки=Неопределено;
Пока Истина Цикл
рТекущийУзел=рРодитель;
рРодитель=рРодитель.РодительскийУзел;
Если рРодитель.ИмяУзла="row" Тогда
рДанныеКолонки=рТекущийУзел;
рДанныеСтроки=рРодитель;
Прервать;
КонецЕсли;
Если ТипЗнч(рРодитель)<>Тип("ЭлементDOM") Тогда Прервать КонецЕсли;
КонецЦикла;
Если рДанныеКолонки=Неопределено или рДанныеСтроки=Неопределено Тогда Продолжить КонецЕсли;
//
рСтрока=рДанныеСтроки.РодительскийУзел; // rowsItem
Если ТипЗнч(рСтрока)<>Тип("ЭлементDOM") Тогда Продолжить КонецЕсли;
Если рСтрока.ИмяУзла<>"rowsItem" Тогда Продолжить КонецЕсли;
//
// к сожалению, у объекта СписокУзловДОМ нет метода Индекс...
рИндексСтроки=-1;
Для каждого рУзелСтроки Из рСтрока.ДочерниеУзлы Цикл
Если рУзелСтроки.ИмяУзла="index" Тогда
Попытка рИндексСтроки=Число(СокрЛП(рУзелСтроки.ТекстовоеСодержимое)) Исключение КонецПопытки;
Прервать;
КонецЕсли;
КонецЦикла;
//
Если обрОбласть.Свойство("НомерКолонки") и ЗначениеЗаполнено(обрОбласть.НомерКолонки) Тогда
рИндексКолонки=обрОбласть.НомерКолонки; // и это не обязательно будет та же колонка, в которой найдено поисковое значение
Иначе
рИндексКолонки=-1; й=0;
Для каждого кол Из рДанныеСтроки.ДочерниеУзлы Цикл
Если кол.ИмяУзла<>"c" Тогда Продолжить КонецЕсли;
Если кол.УзелИдентичен(рДанныеКолонки) Тогда рИндексКолонки=й; Прервать КонецЕсли;
й=й+1;
КонецЦикла;
КонецЕсли;
//
// смотрим, что получили
Если рИндексСтроки>-1 и рИндексКолонки>-1 Тогда
мКОбработке.Добавить(Новый Структура("Строка,Колонка,ДанныеДляРисунка",рИндексСтроки,рИндексКолонки,рДанныеДляРисунка));
//Сообщить("Строка "+рИндексСтроки+", колонка "+СокрЛП(рИндексКолонки));
КонецЕсли;
//
КонецЦикла; // по найденным узлам

// смотрим, какие координаты областей нашли по поисковому выражению XPath
// (случай обнаружения N колонок в одной строке не оптимизируем),
// собственно вставляем рисунки; все их свойства ставим по умолчанию (обработаем их потом)
//
Для й=0 По мКОбработке.Количество()-1 Цикл
коорд=мКОбработке.Получить(й);
стрй=СокрЛП(й+1);
//
рТипРисунка="";
Если коорд.ДанныеДляРисунка.Свойство("ТипРисунка") Тогда
рТипРисунка=СокрЛП(СериализаторXDTO.XMLСтрока(коорд.ДанныеДляРисунка.ТипРисунка));
КонецЕсли;
Если ПустаяСтрока(рТипРисунка) Тогда рТипРисунка="Text" КонецЕсли; // ну пусть так
//
стрВставляемых=стрВставляемых+"
|<drawing>
| <drawingType>"+рТипРисунка+"</drawingType>
| <id>"+стрй+"</id>
| <text>
| <v8:item>
| <v8:lang>#</v8:lang>
| <v8:content></v8:content>
| </v8:item>
| </text>
| <beginRow>"+Строка(коорд.Строка)+"</beginRow>
| <beginRowOffset>"+Строка(коорд.ДанныеДляРисунка.ЛевоВЯчейке)+"</beginRowOffset>
| <endRow>"+Строка(коорд.Строка)+"</endRow>
| <endRowOffset>"+Строка(коорд.ДанныеДляРисунка.ПравоВЯчейке)+"</endRowOffset>
| <beginColumn>"+Строка(коорд.Колонка)+"</beginColumn>
| <beginColumnOffset>"+Строка(коорд.ДанныеДляРисунка.ВерхВЯчейке)+"</beginColumnOffset>
| <endColumn>"+Строка(коорд.Колонка)+"</endColumn>
| <endColumnOffset>"+Строка(коорд.ДанныеДляРисунка.НизВЯчейке)+"</endColumnOffset>
| <autoSize>false</autoSize>
| <pictureSize>Stretch</pictureSize>
| <zOrder>0</zOrder>
|</drawing>
|<namedItem xsi:type=""NamedItemDrawing"">
| <name>AddPct"+стрй+"</name>
| <drawingID>"+стрй+"</drawingID>
|</namedItem>
|";
// текст, для рисунка-текста, сразу не вставляем, т.к. там могут оказаться несериализуемые символы
КонецЦикла; // по найденным координатам

обрОбласть.Вставить("ДанныеКОбработке",мКОбработке);
КонецЦикла; // по обрабатываемым областям

тдСтрокой=СтрЗаменить(тдСтрокой,"<defaultFormatIndex>",стрВставляемых+"<defaultFormatIndex>");

тдСтрокой=СтрЗаменить(тдСтрокой,"xmlns:doit=","xmlns="); // иначе не сработает десериализация

// преобразуем строку обратно в табличный документ
хмлЧтение=Новый ЧтениеXML;
хмлЧтение.УстановитьСтроку(тдСтрокой);
тд=СериализаторXDTO.ПрочитатьXML(хмлЧтение,Тип("ТабличныйДокумент"));

// устанавливаем свойства областей и рисунков уже в объектной технике 1С, так проще
рРисунки=тд.Рисунки;
Для каждого обрОбласть Из рПараметры.ОбрабатываемыеОбласти Цикл
мКОбработке=обрОбласть.ДанныеКОбработке;

Для й=0 По мКОбработке.Количество()-1 Цикл
коорд=мКОбработке.Получить(й);
//
// устанавливаем высоту всей строки, как сказано
облСтрока=тд.Область(коорд.Строка+1,1,коорд.Строка+1,рШиринаТД);
облСтрока.ВысотаСтроки=обрОбласть.ВысотаСтроки;
//
Если обрОбласть.Свойство("СвойстваОбласти") Тогда
облОбласть=тд.Область(коорд.Строка+1,коорд.Колонка+1,коорд.Строка+1,коорд.Колонка+1);
ЗаполнитьЗначенияСвойств(облОбласть,обрОбласть.СвойстваОбласти);
КонецЕсли;
//
рРисунок=рРисунки["AddPct"+СокрЛП(й+1)];
Если рРисунок<>Неопределено Тогда
ЗаполнитьЗначенияСвойств(рРисунок,коорд.ДанныеДляРисунка);
КонецЕсли;
//
#Если не ВебКлиент Тогда
Если коорд.ДанныеДляРисунка.Свойство("ПроизвольноеВыражение")
и не ПустаяСтрока(коорд.ДанныеДляРисунка.ПроизвольноеВыражение)
Тогда
Попытка
Выполнить(СокрЛП(коорд.ДанныеДляРисунка.ПроизвольноеВыражение));
Исключение
КонецПопытки;
КонецЕсли;
#КонецЕсли
//
КонецЦикла;
КонецЦикла;

Исключение
Сообщить("ВставитьРисункиВТабличныйДокумент, ошибка: "+ОписаниеОшибки());
КонецПопытки;
КонецПроцедуры

Я с помощью этой штуковины вывел текстовые подписи о скидках и картинки из карточек номенклатуры в УТ 10.3, пример вызова таков:

    // настраиваем свойства рисунка
   
рСвойстваРисунка1=Новый Структура;
   
рСвойстваРисунка1.Вставить("ТипРисунка",ТипРисункаТабличногоДокумента.Текст);
   
рСвойстваРисунка1.Вставить("Текст","СКИДКИ!!!");
   
рСвойстваРисунка1.Вставить("АвтоРазмер",Истина);
   
рСвойстваРисунка1.Вставить("ВертикальноеПоложение",ВертикальноеПоложение.Низ);
   
рСвойстваРисунка1.Вставить("ЛевоВЯчейке",140);
   
рСвойстваРисунка1.Вставить("ПравоВЯчейке",180);
   
рСвойстваРисунка1.Вставить("ВерхВЯчейке",60);
   
рСвойстваРисунка1.Вставить("НизВЯчейке",230);
   
рСвойстваРисунка1.Вставить("ГраницаСверху",Ложь);
   
рСвойстваРисунка1.Вставить("ГраницаСлева",Ложь);
   
рСвойстваРисунка1.Вставить("ГраницаСнизу",Ложь);
   
рСвойстваРисунка1.Вставить("ГраницаСправа",Ложь);
   
рСвойстваРисунка1.Вставить("ЦветТекста",WebЦвета.Коричневый);
   
//
   
соотТоваров1=Новый Соответствие;
   
соотТоваров2=Новый Соответствие;
    Для каждого
стротрез Из тРезультатНекоегоЗапроса Цикл
       
рТовар=стротрез.Товар;
       
гуид=Строка(рТовар.УникальныйИдентификатор());
       
соотТоваров1.Вставить(гуид,рСвойстваРисунка1);
        Если не
рТовар.ОсновноеИзображение.Пустая() Тогда
           
рСвойстваРисунка2=Новый Структура;
           
рСвойстваРисунка2.Вставить("ТипРисунка",ТипРисункаТабличногоДокумента.Картинка);
           
рСвойстваРисунка2.Вставить("АвтоРазмер",Истина);
           
рСвойстваРисунка2.Вставить("ЛевоВЯчейке",1);
           
рСвойстваРисунка2.Вставить("ПравоВЯчейке",280);
           
рСвойстваРисунка2.Вставить("ВерхВЯчейке",1);
           
рСвойстваРисунка2.Вставить("НизВЯчейке",230);
           
рСвойстваРисунка2.Вставить("Ширина",30);
           
рСвойстваРисунка2.Вставить("Высота",30);
           
рСвойстваРисунка2.Вставить("Картинка",рТовар.ОсновноеИзображение.Хранилище.Получить());
           
соотТоваров2.Вставить(гуид,рСвойстваРисунка2);
        КонецЕсли;
    КонецЦикла;
   
//
    // готовим прочие параметры
   
рСвойстваОбласти=Новый Структура;
   
рСвойстваОбласти.Вставить("ВертикальноеПоложение",ВертикальноеПоложение.Верх);
   
//
   
стру1=Новый Структура;
   
стру1.Вставить("ВыражениеXPath","//d[@xsi:type='d6p1:CatalogRef.Номенклатура']"); // ищем по участию ссылок в расшифровках
   
стру1.Вставить("ВысотаСтроки",90);
   
стру1.Вставить("СвойстваОбласти",рСвойстваОбласти);
   
стру1.Вставить("КлючПолученияКлючаДанных","ТекстовоеСодержимое");
   
стру1.Вставить("Данные",соотТоваров1);
   
//
   
стру2=Новый Структура;
   
стру2.Вставить("ВыражениеXPath","//d[@xsi:type='d6p1:CatalogRef.Номенклатура']"); // ищем по участию ссылок в расшифровках
   
стру2.Вставить("ВысотаСтроки",87);
   
стру2.Вставить("НомерКолонки",3);
   
стру2.Вставить("КлючПолученияКлючаДанных","ТекстовоеСодержимое");
   
стру2.Вставить("Данные",соотТоваров2);
   
//
   
мстру=Новый Массив;
   
мстру.Добавить(стру1);
   
мстру.Добавить(стру2);
   
пар=Новый Структура("ОбрабатываемыеОбласти",мстру);
   
//
   
ВставитьРисункиВТабличныйДокумент(ТабДокумент,пар);

 

Кому пригодится - велкам. Кто доведёт до ума привязку размеров - тому респект.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Дата
11. KAV2 14.08.17 05:37 Сейчас в теме
(6)
А, ну и естественно, речь не о подходе с использованием свойства "ПараметрКартинки"


А как можно с использованием свойства ПараметрКартинки не подскажите?
10. necropunk 8 23.06.16 12:40 Сейчас в теме
Вообще, идея интересная. поковыряю обязательно.
9. necropunk 8 23.06.16 12:40 Сейчас в теме
(8) проще потратить стартмани и быстро разобраться в коде с нормальной подсветкой и отладчиком. В любом случае, приятно когда есть выбор - хочешь, качаешь, хочешь - так читаешь.
8. Yashazz 3752 23.06.16 09:59 Сейчас в теме
(7) ivanov660, да в нём всё интересно с той или иной точки зрения, вот в чём дело. А за обработку стартмани тратить придётся... Впрочем, это мысль. Иллюстративный материал для применения попробую приложить как файлы.
7. ivanov660 2436 23.06.16 09:31 Сейчас в теме
Приложите обработку. Большое количество кода не читабельно, обычно выделяют интересные моменты.
6. Yashazz 3752 23.06.16 00:27 Сейчас в теме
А, ну и естественно, речь не о подходе с использованием свойства "ПараметрКартинки", или самой картинке ячейки, а именно о вставке объекта "Рисунок".
5. Yashazz 3752 22.06.16 13:36 Сейчас в теме
В итоге так и остался просто неразукрашенный текст. Но он хотя бы читабелен.
4. Yashazz 3752 21.06.16 10:40 Сейчас в теме
(3) ditp, спасибо. Сейчас выясняю, что можно с этим зелёным ужасом сделать.
3. ditp 53 21.06.16 09:04 Сейчас в теме
Интересная идея.
По ссылке http://pastebin.com/0W5UcTPr распарсенный текст.
2. Yashazz 3752 21.06.16 08:16 Сейчас в теме
(1) Makushimo, "спасибо" новому редактору Инфостарт ((( Я изначально хотел просто как текст выложить, т.к. старый редактор портит xml-теги, но модератор не пропустил; говорит, юзай новый редактор. Вот, поюзал... Приношу извинения.
1. Makushimo 157 21.06.16 05:45 Сейчас в теме
мешанина зеленого текста - это жестоко )))
Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    79378    Serginio    113    

Полезные примеры СКД, ч.2

Практика программирования v8 v8::СКД Бесплатно (free)

Еще несколько примеров решения задач в СКД.

06.04.2021    3968    Neti    7    

Неочевидные нюансы записи управляемой формы

Практика программирования v8 v8::УФ Платформа 1C v8.2 1cv8.cf Бесплатно (free)

Разберем несколько нюансов записи управляемой формы.

02.04.2021    5197    SeiOkami    49    

Обзор полезных методов БСП 3.1.4

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Библиотека стандартных подсистем (далее - БСП) является частью любой типовой конфигурации, поэтому умение применять готовые процедуры и функции повышает качество разработки и избавляет от написания лишнего кода. К сожалению, не у всех есть время и упорство овладеть всей документацией, поэтому я собрал воедино наиболее популярный функционал.

25.03.2021    15725    rayastar    47    

Звуковое управление в 1С 8.3 Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

В данной статье описано создание библиотеки для звукового управления (выполнение команд голосом) для платформы 1С 8.3. Задача была поставлена так, чтобы модуль функционировал непосредственно на клиенте 1С, осуществляя управление формами, и взаимодействовал с интерфейсом.

16.03.2021    3069    velemir    31    

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    5350    comol    31    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    13178    quazare    34    

Форма выбора (подбор) в управляемых формах

Практика программирования v8 v8::УФ 1cv8.cf Россия Бесплатно (free)

Разбор небольших примеров того, как правильно открывать форму выбора (подбора) в управляемых формах, не прибегая к модальным окнам.

08.05.2020    44684    user5300    17    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    39032    unichkin    74    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    45172    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    33399    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    25891    kuzyara    38    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    32858    tormozit    105    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    19996    YPermitin    61    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    10496    Sibars    19    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    34580    HostHost    41    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    79895    tormozit    131    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    43531    Yashazz    50    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    15906    budidich    29    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    75002    rpgshnik    70    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    50893    tormozit    49    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    62491    ids79    55    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    35800    YPermitin    25    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    27746    YPermitin    81    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    47811    tormozit    74    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    38438    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    117869    ids79    69    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    48008    avalakh    26    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16691    m-rv    3    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    32218    json    15    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    83535    ids79    14    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    41847    ids79    27    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    21320    m-rv    17    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    29697    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    20720    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    65476    ids79    17    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    33277    m-rv    22    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    64034    ids79    26    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    27953    dmurk    147    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    52814    YPermitin    30    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    29100    itriot11    34    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    39143    ellavs    127    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    29202    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    36078    YPermitin    53    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    39075    ids79    40    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    53193    Смешной 1С    32    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    25240    Vladimir Litvinenko    28