В «1С:ЗУП КОРП 3.1» тормоза (медленная работа) в журналах документов при использовании критериев отбора

Публикация № 722861 04.01.18

Администрирование - Производительность и оптимизация (HighLoad)

ЗУП 3.1 КОРП тормозит медленная оптимизация конструктор динамический запрос журнал документов критерии отбора доработка типовых RLS отбор динамический список избыточное

Статья для тех, у кого: 1) используете RLS (ограничение доступа на уровне записей и полей), 2) много документов (более 100 тысяч в одном журнале), 3) используете «Журналы документов», 4) отборы в динамическом списке (по сотруднику). Скорее всего, Вы испытали на себе, как отбор происходит минутами (жутко тормозит) – тогда Вам сюда.

Введение

В 1С когда то давно появился новый объект конфигурации «Критерий отбора» зачем он нужен и какой он хороший писали не раз, например, //infostart.ru/public/401743/

 

Вопросы производительно и особенности использования так же осуждали не раз, например, //infostart.ru/public/548778/

 

Но, например, в типовом «1С: Зарплата и Управление Персоналом КОРП, редакция 3.1» и многих других типовых конфигураций используют данный механизм критерия отборов не обращая внимания на вопросы производительности. ПОЧЕМУ?!

 

Ответ, наверное, очень прост: использование «Журналов документов» и «Критериев отбора» упрощает разработку типовых конфигураций, а вопросы производительности пусть потом решают специально обученные люди, как бы 1С намекает зачем нужны «1С:Эксперт по технологическим вопросам» да и вообще Франчайзинг или Консалтинг.

 

Более детально описание проблемы в «Журнале документов», например, «Кадровые документы» при установки отбора по сотруднику происходит зависание и после этого медленно работает пролистывание списка. Смотрим в код и что видим?! При установки/изменения отбора по сотруднику при помощи «Критерия отбора» «Документы сотрудников» происходит получение массива документов, где есть физ.лицо выбранного сотрудника, а затем этот массив устанавливается в отбор динамического списка в «Журнале документов» «Кадровые документы».

 

Вроде все «кашерно» и логично, но есть несколько но:

  1. Основная причина проблем. Список видов документов в «Журнале документов» «Кадровые документы» и «Критерия отбора» «Документы сотрудников» сильно различается. Скриншоты в конце статьи.
  2. Избыточные чтения ненужных таблиц документов при получении массива документов для отбора.
    В результате чего будет произведен поиск при помощи «Критерия отбора» «Документы сотрудников» по видам документов, которые не входят в «Журнале документов» «Кадровые документы».
  3. Избыточные данные в массиве документов для отбора.
    В результате чего в массив документов, который будет получен из «Критерия отбора» «Документы сотрудников» могут входить документы, которых нет в «Журнале документов» «Кадровые документы».
  4. Сам механизм «Критерии отбора» работает не идеально, то есть выполнения запроса ко всем документам из критерия отбора работает быстрее.

При попытке сделать динамический конструктор запроса, который эмулирует работу запроса, по критерию отбора получилась довольно универсальная функция «ПолучитьТекстЗапроса_ДокументыСотрудников()" (пример ниже по тексту).

Далее встал вопрос как «зарулить» все вызовы из журналов документов на нужный мне код, и о СПАСИБО функций которых надо поправить было всего ТРИ и изменения в одну строчку. Надо отдать должное разработчикам типовых конфигураций, которые сделали общие функции для работы отборов по сотрудникам - универсальными функциями и использовали их по максимум.

 

Вся доработка заключалась в том, что бы:

  1. В функции «ДокументыПоФизическомуЛицу()» заменить текст запроса на свой. Добавить новый параметр, для получения имени формы;
  2. В функциях «ПараметрКритерияОтбораНаФормеСДинамическимСпискомПриИзменении()» и «ОбновитьФормыСДинамическимСписком()» которые добавить параметр для вызова «ДокументыПоФизическомуЛицу()»;
  3. Добавить свою функцию конструктор запросов «ПолучитьТекстЗапроса_ДокументыСотрудников()» в общем модуле (с настройкой: повторное использование - «На время сеанса»);
  4. Добавить свою функцию переопределения текста запроса «ПереопределениеДокументыПоФизическомуЛицу()» в общем модуле.
  5. Исключения для журнала документов «Кадровые документы» в форме списка была ДВА вызова, которые почему то шли не через общий механизм «ПриСозданииНаСервере()» и «ОбновитьНаСервере()»

 

Итого при использовании журналов документов:

  1. скорость работы выросла примерно в 200 раз,
  2. количество чтений уменьшилось в 300 раз.

Думаю хороший результат.

Проверка и доработка проводилась на «Зарплата и управление персоналом КОРП, редакция 3.1 (3.1.3.224) (http://v8.1c.ru/hrmcorp)».

 

Листинг кода:

ОбщийМодуль.ЗарплатаКадры
Процедура ПараметрКритерияОтбораНаФормеСДинамическимСпискомПриИзменении(Форма, ИмяЭлемента) Экспорт
	
	НайденныеСтроки = Форма.ПараметрыКритерияОтбора.НайтиСтроки(Новый Структура("ИмяЭлементаФормыПараметра", ИмяЭлемента));
	Если НайденныеСтроки.Количество() > 0 Тогда
		// Изменение параметра, установим использование
		СтрокаПараметра = НайденныеСтроки[0];
		Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметраИспользование] = Истина;
	Иначе
		НайденныеСтроки = Форма.ПараметрыКритерияОтбора.НайтиСтроки(Новый Структура("ИмяЭлементаФормыПараметраИспользование", ИмяЭлемента));
		Если НайденныеСтроки.Количество() = 0 Тогда
			Возврат;
		КонецЕсли;
		// Изменение использования параметра
		СтрокаПараметра = НайденныеСтроки[0];
	КонецЕсли;
	
	МассивДокументов = Новый Массив;
	Если Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметраИспользование] Тогда
		// +++ замена критерии отбора на прямые запросы
		//МассивДокументов = ДокументыПоФизическомуЛицу(Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметра]);
		МассивДокументов = ДокументыПоФизическомуЛицу(Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметра], Форма.ИмяФормы);
		// --- 
	КонецЕсли;
	
	Список = Форма[Форма.НаименованиеРеквизитаФормыДинамическийСписок];
	ОбщегоНазначенияКлиентСервер.УстановитьПараметрДинамическогоСписка(
		Список,
		СтрокаПараметра.ИмяПараметра,
		МассивДокументов,
		Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметраИспользование]);
	
КонецПроцедуры

Процедура ОбновитьФормыСДинамическимСписком(Форма) Экспорт
	
	Список = Форма[Форма.НаименованиеРеквизитаФормыДинамическийСписок];
	Для Каждого СтрокаПараметра Из Форма.ПараметрыКритерияОтбора Цикл
		МассивДокументов = Новый Массив;
		Если Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметраИспользование] Тогда
			// +++ замена критерии отбора на прямые запросы
			//МассивДокументов = ДокументыПоФизическомуЛицу(Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметра]);
			МассивДокументов = ДокументыПоФизическомуЛицу(Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметра], Форма.ИмяФормы);
			// --- 
			
			ОбщегоНазначенияКлиентСервер.УстановитьПараметрДинамическогоСписка(
				Список,
				СтрокаПараметра.ИмяПараметра,
				МассивДокументов,
				Форма[СтрокаПараметра.ИмяРеквизитаФормыПараметраИспользование]);
		Иначе
			Для каждого ЭлементФормы Из Форма.Элементы Цикл
				Если ТипЗнч(ЭлементФормы) = Тип("ТаблицаФормы") И ЭлементФормы.ПутьКДанным = Форма.НаименованиеРеквизитаФормыДинамическийСписок Тогда
					ЭлементФормы.Обновить();
				КонецЕсли;
			КонецЦикла;
		КонецЕсли;
	КонецЦикла;
	
КонецПроцедуры

// +++ замена критерии отбора на прямые запросы
//Функция ДокументыПоФизическомуЛицу(ФизическоеЛицо) Экспорт
Функция ДокументыПоФизическомуЛицу(ФизическоеЛицо, ИмяФормы = "") Экспорт
// --- 
	
	
	МассивДокументов = Новый Массив;
	
	УстановитьПривилегированныйРежим(Истина);
	
	Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("ФизическоеЛицо", ФизическоеЛицо);
	
	Запрос.Текст =
	"ВЫБРАТЬ
	|	КритерийОтбораДокументыСотрудников.Ссылка
	|ИЗ
	|	КритерийОтбора.ДокументыСотрудников(&ФизическоеЛицо) КАК КритерийОтбораДокументыСотрудников";
	
	// +++ замена критерии отбора на прямые запросы
	add_ОбщийМодуль.ПереопределениеДокументыПоФизическомуЛицу(Запрос.Текст, ИмяФормы);
	// --- 
	
	Выборка = Запрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
		МассивДокументов.Добавить(Выборка.Ссылка);
	КонецЦикла;
	
	УстановитьПривилегированныйРежим(Ложь);
	
	Возврат МассивДокументов;
	
КонецФункции


ОбщийМодуль.add_ОбщийМодуль (* компиляция сервер)
Процедура ПереопределениеДокументыПоФизическомуЛицу(ТекстЗапроса, ИмяФормы) Экспорт 
	
	Если СтрНайти(ИмяФормы, "ЖурналДокументов.") > 0 И СтрНайти(ИмяФормы, ".Форма.ФормаСписка") > 0 Тогда 
		Поз = Найти(ИмяФормы, ".Форма.ФормаСписка");
		ИмяЖурнала = Сред(ИмяФормы, 18, Поз - 18);
	Иначе 
		Возврат;
	КонецЕсли;
	
	НовыйТекст = "";
	НовыйТекст = add_ОбщегоНазначенияПовтИсп.ПолучитьТекстЗапроса_ДокументыСотрудников(ИмяЖурнала);

	Если ЗначениеЗаполнено(НовыйТекст) Тогда 
		ТекстЗапроса = НовыйТекст;
	КонецЕсли;
КонецПроцедуры

ОбщийМодуль.add_ОбщегоНазначенияПовтИсп (* компиляция - «Сервер», повторное использование - «На время сеанса»)

Функция ПолучитьТекстЗапроса_ДокументыСотрудников(ИмяЖурналаДокументов) Экспорт 
	Попытка
		_СЗ = Новый СписокЗначений;	

		Для Каждого _Док Из Метаданные.Документы Цикл 
			Если НЕ Метаданные.ЖурналыДокументов[ИмяЖурналаДокументов].РегистрируемыеДокументы.Содержит(_Док) Тогда 
				Продолжить;
			КонецЕсли;
			
			Для Каждого _Рек Из _Док.Реквизиты Цикл 
				Если Метаданные.КритерииОтбора.ДокументыСотрудников.Состав.Содержит(_Рек) Тогда 
					_СЗ.Добавить(_Док.Имя, _Рек.Имя);			
				КонецЕсли;
			КонецЦикла;
			
			Для Каждого _ТЧ Из _Док.ТабличныеЧасти Цикл 
				Для Каждого _Рек Из _ТЧ.Реквизиты Цикл 
					Если Метаданные.КритерииОтбора.ДокументыСотрудников.Состав.Содержит(_Рек) Тогда 
						_СЗ.Добавить(_Док.Имя + "." + _ТЧ.Имя, _Рек.Имя);			
					КонецЕсли;
				КонецЦикла;
			КонецЦикла;
		КонецЦикла;
		
		Шаблон = "Выбрать Ссылка из Документ.#Документ# где #Поле# = &ФизическоеЛицо";
		Разделитель = Символы.ПС + "ОБЪЕДИНИТЬ ВСЕ" + Символы.ПС;
		Текст = "";
		ЭтоПервый = Истина;
		
		Для Каждого _Строка Из _СЗ Цикл 
			Если ЭтоПервый Тогда 
				СтрокаШаблон = СтрЗаменить("Выбрать Разрешенные Ссылка Из Документ.#Документ# Где #Поле# = &ФизическоеЛицо", "#Документ#", _Строка.Значение);
				СтрокаШаблон = СтрЗаменить(СтрокаШаблон, "#Поле#", _Строка.Представление);
				Текст = СтрокаШаблон;	
				ЭтоПервый = Ложь;
			Иначе 
				СтрокаШаблон = СтрЗаменить(Шаблон, "#Документ#", _Строка.Значение);
				СтрокаШаблон = СтрЗаменить(СтрокаШаблон, "#Поле#", _Строка.Представление);
				Текст = Текст + Разделитель + СтрокаШаблон;
			КонецЕсли;
		КонецЦикла;
	Исключение
		Сообщить(ОписаниеОшибки());
		Текст = "";
	КонецПопытки;
		
	Возврат Текст;
КонецФункции

Исключения
ЖурналДокументов.КадровыеДокументы.Форма.ФормаСписка.Форма.Модуль 	

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	// Пропускаем инициализацию, чтобы гарантировать получение формы при передаче параметра "АвтоТест".
	Если Параметры.Свойство("АвтоТест") Тогда
		Возврат;
	КонецЕсли;
	
	Если Параметры.Свойство("Заголовок") Тогда
		Заголовок = Параметры.Заголовок;
	КонецЕсли;
	
	Параметры.Свойство("СотрудникСсылка", СотрудникСсылка);
	
	Если ЗначениеЗаполнено(СотрудникСсылка) Тогда
		
		КадровыеДанныеСотрудников = КадровыйУчет.КадровыеДанныеСотрудников(Истина, СотрудникСсылка, "ГоловнаяОрганизация,ФизическоеЛицо,ТекущаяОрганизация");
		Если КадровыеДанныеСотрудников.Количество() > 0 Тогда
			
			ДанныеСотрудника = КадровыеДанныеСотрудников[0];
			
			Организация = ДанныеСотрудника.ТекущаяОрганизация;
			
			ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбораДинамическогоСписка(
				Список, "ГоловнаяОрганизация", ДанныеСотрудника.ГоловнаяОрганизация);
				
			// +++ замена критерии отбора на прямые запросы
			//МассивДокументов = ЗарплатаКадры.ДокументыПоФизическомуЛицу(ДанныеСотрудника.ФизическоеЛицо);
			МассивДокументов = ЗарплатаКадры.ДокументыПоФизическомуЛицу(ДанныеСотрудника.ФизическоеЛицо, ЭтаФорма.ИмяФормы);
			// --- 
			ОбщегоНазначенияКлиентСервер.УстановитьПараметрДинамическогоСписка(Список, "МассивДокументов", МассивДокументов, Истина);
			УстановитьТипыОбъектовОповещения();
			
			ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(
				Элементы,
				"Сотрудник",
				"Видимость",
				Ложь);
			
			Если Не ОбщегоНазначения.ЗначениеРеквизитаОбъекта(ДанныеСотрудника.ГоловнаяОрганизация, "ЕстьОбособленныеПодразделения") Тогда
				
				ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(
					Элементы,
					"Организация",
					"Видимость",
					Ложь);
				
			КонецЕсли;
			
		КонецЕсли;
		
	Иначе
		
		ОписаниеТипаФизическоеЛицо = Новый ОписаниеТипов("СправочникСсылка.ФизическиеЛица");
		СтруктураПараметраФизическоеЛицо = Новый Структура("ТипПараметра, ИмяПараметра", ОписаниеТипаФизическоеЛицо, "МассивДокументов");
		СтруктураПараметровОтбора = Новый Структура("Сотрудник", СтруктураПараметраФизическоеЛицо);
		ЗарплатаКадры.ПриСозданииНаСервереФормыСДинамическимСписком(ЭтотОбъект, "Список", "СписокНастройкиОтбора",
			СтруктураПараметровОтбора, "СписокКритерииОтбора");
		
	КонецЕсли;
	
	ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Элементы, "ФормаУтвердить", "Видимость", Пользователи.РолиДоступны("ДобавлениеИзменениеДанныхДляНачисленияЗарплатыРасширенная, ДобавлениеИзменениеНачисленнойЗарплатыРасширенная"));
	ЗарплатаКадрыРасширенный.УстановитьУсловноеОформлениеСпискаМногофункциональныхДокументов(ЭтаФорма);
	
	ЗарплатаКадрыРасширенный.СформироватьПодменюСоздатьФормыСпискаДокументов(ЭтаФорма, "ЖурналДокументов.КадровыеДокументы");
	
	// СтандартныеПодсистемы.ПодключаемыеКоманды
	ПараметрыРазмещения = ПодключаемыеКоманды.ПараметрыРазмещения();
	ПараметрыРазмещения.КоманднаяПанель = Элементы.КоманднаяПанельФормы;
	
КонецПроцедуры

&НаСервере
Процедура ОбновитьНаСервере()
	
	Если ЗначениеЗаполнено(СотрудникСсылка) Тогда
		// +++ замена критерии отбора на прямые запросы
		//МассивДокументов = ЗарплатаКадры.ДокументыПоФизическомуЛицу(ОбщегоНазначения.ЗначениеРеквизитаОбъекта(СотрудникСсылка, "ФизическоеЛицо"));
		МассивДокументов = ЗарплатаКадры.ДокументыПоФизическомуЛицу(ОбщегоНазначения.ЗначениеРеквизитаОбъекта(СотрудникСсылка, "ФизическоеЛицо"), ЭтаФорма.ИмяФормы);
		// --- 
		ОбщегоНазначенияКлиентСервер.УстановитьПараметрДинамическогоСписка(Список, "МассивДокументов", МассивДокументов, Истина);
	Иначе
		ЗарплатаКадры.ОбновитьФормыСДинамическимСписком(ЭтотОбъект);
	КонецЕсли;
	
КонецПроцедуры

Журнал документов

Критерий отбора

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Дата
1. PerlAmutor 124 04.01.18 18:56 Сейчас в теме
В ERP тоже есть критерии отборов и к счастью их мало, а в последней версии так еще меньше. На сертификационном экзамене по платформе есть следующие вопросы:

"1.9 Для включения отборов в списках (обычных форм) по содержимому табличных частей объектов и их свойств, не отображаемых в форме. ":
Ответ: "необходимо создать объект критерии отбора"

и точно такой же вопрос
"1.10 Для включения отборов в списках (управляемых форм) по содержимому табличных частей объектов и их свойств, не отображаемых в форме. ":
Ответ: "реализуется произвольным запросом динамического списка"

Из чего можно сделать вывод, что объект "критерий отбора" сам по себе - анахронизм, оставленный для совместимости со старыми конфигурациями под обычное приложение.
2. Nykyanen 349 04.01.18 21:04 Сейчас в теме
(1) да, у меня были мысли, что 1С:ЗУП 3 писали те же, что и 1С:ЗУП 2.5.
3. MrWonder 660 10.01.18 09:06 Сейчас в теме
Алексей! Результат, безусловно, хороший. Это видно на продуктивной среде. Но вопрос поведения остаётся непонятным.
Оставьте свое сообщение

См. также

Еще один тест 1C: Postgres SQL 11 Pro Enterpise против MSSQL 14 под Windows 2012 Server R2 Промо

Производительность и оптимизация (HighLoad) v8 Абонемент ($m)

Проработав 15 лет с MSSQL в 2017 начал активно СУБД Postgres SQL. За два года успел поработать в 9 версии Postgres и в 10-ой. И пришел к выводу, что существуют реальное замедление работы баз после перехода на Postgres. Недавно вышла 11 версия Postgres Pro Enterpise, которая обещает почти 2-х кратное ускорение над 11 Pro Standart и 10-ой версией. Закупив лицензию Postgres 11 Pro Enterpise Это я и решил проверить на 1С.

1 стартмани

05.09.2019    17931    Indgo    107    

Пример создания документа с движениями в ERP 2.5.7

БСП (Библиотека стандартных подсистем) Практика программирования v8 ERP2 Россия УУ Абонемент ($m)

Пример создания документа с движениями в ERP 2.5.7, а также включение документа в основные подсистемы, а именно по управлению доступом, датам запрета изменения, контролю остатков, использованию характеристик и серий и прочее.

1 стартмани

10.08.2021    1707    maraty    10    

Работа с абстрактным массивом

Практика программирования Математика и алгоритмы v8 Россия Абонемент ($m)

Абстрактные типы данных и алгоритмы уверенно набирают популярность в языках общего назначения. Встроенный язык 1С является предметно-ориентированным и не спешит развиваться в сторону поддержки абстракций. Однако потребность в них существует, т.к. задачи, решаемые на платформе, не уступают разнообразию из других ЯП. Предлагаю рассмотреть вариант реализации абстрактного массива в 1С.

1 стартмани

07.07.2021    3580    kalyaka    56    

Семеро одного не ждут? Асинхронное исследование асинхронности

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Все уже, наверное, знают о появлении в новых версиях платформы асинхронных функций и конструкций Асинх/Ждать. Многие, возможно, уже их используют. Но что будет, если создать свои асинхронные функции, запустить и не дожидаться окончания их выполнения? Неужели можно запустить несколько процессов параллельно?

1 стартмани

08.06.2021    5234    Alxby    45    

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    44653    tormozit    58    

Водопад из Техжурнала 1С

Технологический журнал v8 1cv8.cf Абонемент ($m)

Строим визуализацию в виде waterfall-графика по данным событий технологического журнала.

5 стартмани

23.12.2020    5214    VKislitsin    5    

СКД: все, что вы хотели знать о подмене схемы компоновки данных в отчетах и обработках

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Довольно часто на различных тематических форумах задается вопрос, можно ли использовать в отчете/обработке несколько схем компоновки данных, подменяя одну другой по мере надобности? При этом желательно, чтобы и пользовательские настройки при смене схемы менялись соответственно.

1 стартмани

07.12.2020    4844    user1502278    18    

Cбор и анализ ошибок при помощи Sentry, или как упростить жизнь себе и пользователям

Практика программирования Интеграция v8 Абонемент ($m)

Цель данной статьи - сделать процесс сбора и анализа ошибок, происходящих в базе, максимально простым, быстрым и удобным, собирать статистику по ошибкам, местам их возникновения и частоте их появления, а также в деталях разобрать все тонкости по интеграции 1С с Sentry.

1 стартмани

09.10.2020    7034    hexhoc    12    

Как выполнить отчет на СКД через COM и получить данные отчета? Промо

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    31058    wowik    3    

Программная корректировка при выводе отчета СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Большинство отчетов на СКД, требующих программной корректировки, реализуются с помощью программной настройки СКД или обработки табличного документа уже после вывода отчета. Но во многих случаях более оптимально будет выполнять программную корректировку в процессе вывода отчета. Для этого существуют программные объекты, о которых я расскажу в данной статье.

1 стартмани

08.10.2020    10315    dabu-dabu    16    

Загрузка, скачивание, удаление файлов с помощью НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера()

Практика программирования v8 1cv8.cf Абонемент ($m)

В платформе 8.3.15 появились новые методы НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера(). В данной статье рассмотрено готовое решение проверенное и прекрасно работающее на тонком и веб-клиенте.

1 стартмани

25.07.2020    11027    Flashill    15    

Запуск фонового задания во внешней обработке без регистрации в справочнике "Дополнительные отчеты и обработки"

Практика программирования v8::УФ ЗУП3.x Россия Абонемент ($m)

Описал, как показать прогресс выполнения длительной операции во внешней обработке, и при этом не регистрировать обработку в справочнике "ДополнительныеОтчетыИОбработки". Проверял на БСП версии "3.1.2.264".

1 стартмани

09.03.2020    7150    VinnieThePOOH    5    

Программное создание динамического списка на управляемой форме. (Динамическое создание динамического списка). Готовая процедура + обработка - демонстрационный пример Промо

Практика программирования Универсальные функции v8::УФ 1cv8.cf Абонемент ($m)

Если у вас возникает необходимость на форму влиять динамически и создавать элементы управляемой формы программно, а особенно хотите вывести программно (динамически) динамический список, вам будет интересна эта процедура. Процедура включает также возможность формирования своей командной панели (а-ля снятие галочки "Автозаполнение" у стандартной командной панели списка).

1 стартмани

19.01.2018    69082    rpgshnik    31    

Методика обновления формы объекта данных при изменении объекта

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В формах объектов данных часто встречаются элементы, косвенно связанные с объектом. Логику обновления этих элементов при изменении объекта обычно вызывают из обработчиков ПриСозданнииНаСервере и ПриОткрытии, забывая про наличие других способов изменения объекта. В статье предложена методика для обычных и управляемых форм, учитывающая все способы.

1 стартмани

09.03.2020    19368    tormozit    16    

Отправка уведомлений с помощью командной строки, Оповещения с сервера на клиент с помощью командной строки

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Отправка уведомлений с помощью команды командной строки msg. Оповестить пользователей из серверного модуля или регламентного задания, с помощью командной строки msg.

1 стартмани

05.03.2020    7967    user5300    3    

Zabbix: Мониторинг рабочих процессов

Zabbix v8 1cv8.cf Абонемент ($m)

Мониторинг памяти, потребляемой рабочими процессами, средствами Zabbix. Создание пользовательских LLD правил с помощью One Script

1 стартмани

07.02.2020    6940    EShchavleva    6    

Как нарисовать граф на 1С Промо

Практика программирования v8 Абонемент ($m)

Описывается реализация на языке запросов 1С метода расположения вершин графа на плоскости, основанного на использовании электромеханической аналогии. При этом вершины графа представляются одноименными электрическими зарядами, дуги - пружинками. Силы взаимодействия вершин в этой системе переводят их из случайного начального в нужное конечное положение. Приведена обработка рисования графов "ГрафОграф", реализующая данный подход, показывающая также динамику процесса. Граф можно задать списком ребер вручную, выбрать из нескольких предопределенных примеров или сформировать по данным информационной базы.

1 стартмани

09.08.2013    73280    ildarovich    117    

Вывод сообщений в HTML поле средствами 1С

Практика программирования v8 v8::УФ Абонемент ($m)

Пример использования вывода большого количества сообщений в поле HTML. С возможностью открывать ссылочные объекты и создавать новые объекты передавая параметры прямо из HTML поля. Протестировано на релизах 8.3.12 и 8.3.15+

2 стартмани

31.01.2020    9828    burni4    16    

Как в 1С создать паутинку "как на Инфостарте"

Практика программирования v8::УФ 1cv8.cf Россия Абонемент ($m)

Добрый день, уважаемы коллеги! В этой статье я расскажу, как в 1С создать отчет - "паутинку" на примере отчета по компетенциям сотрудника (разрабатывала на платформе 1С:Предприятие 8.3 (8.3.13.1865).

1 стартмани

15.01.2020    9734    user660153_aleks.pisanets    17    

Краткое руководство по внесению изменений в конфигурацию

Практика программирования v8 1cv8.cf Абонемент ($m)

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    22368    sapervodichka    41    

Простой способ индексирования интервалов Промо

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    41818    ildarovich    22    

Универсальные функции: разложение произвольной строки адреса в структуру

Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Процедуры и функции раскладывают произвольную строку адрес в структуру по ключевым словам.

1 стартмани

30.12.2019    5802    vik070777    10    

Тест серверного оборудования на допустимое количество пользователей: как это использовать?

Администрирование СУБД Нагрузочное тестирование Сервера v8 1cv8.cf Абонемент ($m)

Выполнил 3 разных теста для проверки серверного оборудования (тест 1С, тесты gilev) на возможное число 1С онлайн-пользователей одновременно работающих на нем и интерпретировал результаты тестов через легких, средних и тяжелых пользователей с помощью таблицы с профилями реальных пользователей.

3 стартмани

17.12.2019    13962    sapervodichka    3    

"Живые" картинки со Snap.SVG

Практика программирования WEB Работа с интерфейсом v8 Абонемент ($m)

В статье рассмотрен пример использования http-сервисов для визуализации данных

1 стартмани

24.10.2019    15027    blackhole321    7    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    38039    rpgshnik    53    

RLS - дубли условий в запросах к СУБД

Практика программирования Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

"Подводные камни", возникающие при бездумном копировании ролей с ограничениями RLS, как это отражается на производительности, разбор примера и инструмент для анализа.

1 стартмани

07.10.2019    9850    geron4    4    

Полное копирование одной формы в другую

Практика программирования Универсальные обработки Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Однажды я столкнулся с необходимостью открыть форму ЛЮБОГО документа с определенными изменениями, не зависящими от структуры объекта (например, заблокировать все кнопки). В интернете решения я не нашел. Обычно на форумах на запросы подобного рода отвечают чем-то вроде "покажи первоначальную задачу, а не спрашивай как реализовать то, что ты придумал". Тем не менее, мне стало интересно, как это можно сделать.

1 стартмани

03.10.2019    7774    nekit_rdx    25    

Многопоточная обработка данных на примере перепроведения документов

Обработка документов Практика программирования v8 ERP2 УТ11 КА2 Абонемент ($m)

Дальнейшее развитие темы фоновой обработки данных - проведение документов в потоках. Настройка параметров и запуск основного процесса (менеджера потоков). Разбивка документов для проведения на не связанные друг с другом наборы и запуск дополнительных фоновых заданий для отдельных потоков. Отслеживание выполнения каждого потока в родительском сеансе.

1 стартмани

17.09.2019    12579    ids79    46    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному Промо

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    53362    dsdred    44    

Отображение истории выполнения по всем задачам комплексного процесса в документообороте

Документооборот и делопроизводство Практика программирования v8 ДО УУ Абонемент ($m)

Коллеги, предлагаю вашему вниманию доработку для вывода полной истории в задачах комплексного процесса.

1 стартмани

15.09.2019    8644    pavelpribytkin96    8    

Кто круче: "ИЛИ" или "ОБЪЕДИНИТЬ ВСЕ" в запросе?

Производительность и оптимизация (HighLoad) v8 v8::СПР v8::Запросы ЗУП2.5 Абонемент ($m)

Реальный пример оптимизации запроса. Статья будет полезна людям, изучающим вопросы оптимизации запросов в 1С и для подготовки к экзамену "1С: Эксперт по технологическим вопросам", поскольку в статье описывается один их методов расследования причин неоптимальных запросов. UPD. Коллеги в комментариях заметили ошибку, она была исправлена и сейчас выложены данные с корректным решением.

1 стартмани

14.09.2019    6347    azazana    28    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    21599    Dementor    31    

Некоторая работа с данными через COM Промо

Практика программирования v8 Абонемент ($m)

В статье приведены примеры работы с Платформой 8.X через COM (точнее, через объект COMConnector). Примеры кода были использованы при реализации прикладных задач в процессе трудовой деятельности.

2 стартмани

05.12.2012    59815    wowik    32    

Удобный просмотр результата запроса с большим количеством временных таблиц

Практика программирования v8 Абонемент ($m)

Если Вам часто приходится просматривать в отладчике сложные пакетные запросы с большим количеством временных таблиц, то эта статья для Вас.

1 стартмани

27.08.2019    12716    ids79    22    

Запуск фонового задания во внешней обработке. Отключение предупреждений защиты от опасных действий в фоновом задании

Практика программирования v8 1cv8.cf Абонемент ($m)

Как запустить фоновое задание из модуля внешней обработки используя БСП. Как отключить безопасный режим и сообщения защиты от опасных действий независимо от профиля безопасности пользователя в фоновом задании во внешней обработке.

2 стартмани

24.08.2019    16661    BenGunn    22    

Изменяющееся контекстное меню в 1С 8.3

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ Абонемент ($m)

В одной практической задаче мне пришлось разрабатывать контекстное меню таблицы управляемой формы, которое должно было меняться в зависимости от данных, находящихся в этой таблице. Ниже приведен мой способ решения этой задачи.

1 стартмани

06.08.2019    21995    signum2009    16    

Работа со схемой запроса Промо

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    51579    kalyaka    41    

Менеджер потоков: реализация "любой" задачи в потоках

Производительность и оптимизация (HighLoad) Инструментарий разработчика v8 Абонемент ($m)

Менеджер потоков – один их новых инструментов, который упрощает работу разработчиков. Насколько легко с ним, на конференции Infostart Event 2018 Education показал начальник отдела автоматизации 1С Иван Филимонов компании «Трансстроймеханизация».

01.08.2019    11242    DarkAn    7    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    57520    vasilev2015    66    

10 способов получить модуль числа (а может, и больше)

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Пишем функцию вычисления модуля числа. Сколько способов существует? Давайте посчитаем!

1 стартмани

11.07.2019    13852    sam441    32    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов Промо

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    51280    DarkAn    86    

Ловец дедлоков СУБД

Производительность и оптимизация (HighLoad) Практика программирования ЦУП v8 Россия Абонемент ($m)

Анализ простейшего дедлока СУБД в рабочей базе с использованием ЦУП (центра управления производительностью) и profiler MS SQL (Microsoft SQL Server). Эта статья будет полезна людям, изучающим вопросы оптимизации работы 1С, или тем, у кого возникают дедлоки в рабочей базе. UPD 09.07.2019 добавлено воспроизведение блокировки в случае установки управляемой блокировки перед чтением набора записей регистра сведений. UPD 10.07.2019 добавлена тестовая база с примером.

1 стартмани

08.07.2019    12549    azazana    80    

Многоуровневая нумерация в отчете СКД (программный вывод)

Практика программирования v8::СКД 1cv8.cf Абонемент ($m)

Реализация многоуровневой нумерации при программном выводе отчета СКД основываясь на его структуре.

1 стартмани

01.07.2019    7760    lmnlmn    7    

Мониторинг производительности и искусственный интеллект

Производительность и оптимизация (HighLoad) Практика программирования Искусственный интеллект (AI) v8 Абонемент ($m)

Расскажем и покажем практически, как использовать искусственный интеллект на страже мониторинга производительности. У вас появится возможность создать собственного помощника Ларису, которая возьмет на себя вопросы по контролю и диагностике состояния обслуживаемой системы.

1 стартмани

01.07.2019    10249    ivanov660    28    

Новый запрос и новая таблица значений как функции Промо

Практика программирования v8 Абонемент ($m)

Предлагается две простые функции, использование которых уменьшает объем кода в конфигурациях на платформе «1С:Предприятие 8». Эти функции можно добавлять к своему общему модулю, что сделает процесс программирования более эффективным.

1 стартмани

27.11.2012    46323    ildarovich    49    

"Убер на складе": динамический расчет маршрутов с учетом реальных расстояний

Учет ТМЦ Практика программирования Учет ТМЦ v8 УУ Абонемент ($m)

Представляю методику и инструмент для динамического расчета маршрутов отбора на высоконагруженных складах для максимального повышения эффективности склада, ускорения проходимости и, как следствие, экономии денег. Это методика и обработка для интеграции в WMS решения. Тестировалось на 1С 8.3.14.1565.

3 стартмани

24.06.2019    19409    informa1555    17    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    33802    Evil Beaver    145    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    36302    Hatson    32    

Уровни, глубина, прародители, циклы и аналоги запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В продолжение публикации «Транзитивное замыкание запросом» [http://infostart.ru/public/158512/] добавлены другие варианты использования того же приема. Приведены запросы для быстрого определения уровней всех элементов справочника, максимальной глубины справочника, прародителей произвольных элементов справочника, запрос для быстрого определения циклов (на примере справочника спецификаций «1С:Управление производственным предприятием») и определения множеств аналогов номенклатуры (также на примере конфигурации «1С:Управление производственным предприятием»).

1 стартмани

13.11.2012    119680    ildarovich    102    

Картинки во внешней печатной форме (Шапка и табличная часть)

Печатные формы документов Практика программирования Разработка v8::ОУ v8::УФ УТ11 Россия Абонемент ($m)

Способы вывести на печать картинку в шапке и в табличной части внешней печатной формы. Управление торговлей, редакция 11 (11.4.7.150).

1 стартмани

27.05.2019    17698    Povinger    3    

Создание внешней печатной формы в формате документа Word

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье написано, как создать внешнюю печатную форму (для конфигураций с БСП) в формате Word.

1 стартмани

17.05.2019    23476    ВикторП    22    

Табличная часть из дополнительных реквизитов с обработкой событий в расширении

Практика программирования Работа с интерфейсом Разработка v8::УФ 1cv8.cf Абонемент ($m)

Эмуляция табличной части с помощью дополнительных реквизитов и расширения. Подход применим к любой конфигурации на управляемых формах с БСП и режимом совместимости, допускающим использование расширений. Весь код в статье.

1 стартмани

13.05.2019    13107    mvxyz    17