Диадок. Добавление кнопки создания Номенклатуры

29.03.23

Интеграция - ЭДО и ОФД

Позволяет сразу создавать Номенклатуру.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Диадок. Добавление кнопки создания Номенклатуры:
.epf 10,02Mb
4
4
1 SM
Скачать Купить за 1 850 руб.

Тестировалось на БП 3.0.133. Платформа 8.3.22.

Для примера выкладываю обработку Диадок 4.29.2.

Для пользователей. При входе в документ Диадок и нажатии кнопки Создать открывается форма синхронизация Номенклатуры в которую и была добавлена кнопка Создать номенклатуру. При нажатии кнопки будет создана Номенклатура с артикулом.

Для программистов. В форму обработки СопоставлениеНоменклатурыУправляемая добавлена кнопка Создать номенклатуру. Она ищет номенклатуру по Артикулу и если не находит, то создает.

Если не хотите скачивать обработку, то вот сам код:

&НаСервере
Процедура СоздатьНоменклатуруНаСервере()
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    Номенклатура.Артикул КАК Артикул
        |ИЗ
        |    Справочник.Номенклатура КАК Номенклатура
        |ГДЕ
        |    Номенклатура.Ссылка В (&ТабАртикулы)";     
    
    ТабАртикулы = РеквизитФормыВЗначение("СписокВариантыСопоставления");
    
    ТабАртикулы = ТабАртикулы.ВыгрузитьКолонку("Номенклатура"); 
    
    Запрос.Параметры.Вставить("ТабАртикулы", ТабАртикулы);
    
    РезультатЗапроса = Запрос.Выполнить().Выгрузить();
    
    Таб = РеквизитФормыВЗначение("ДеревоНоменклатуры");  
    
    Для Каждого СтрокаПервогоУровня Из Таб.Строки Цикл
        
        Для Каждого СтрокаВторогоУровня Из СтрокаПервогоУровня.Строки Цикл
            
            Если не ЗначениеЗаполнено(СтрокаВторогоУровня.Номенклатура) Тогда
                
                Если СтрНайти(Нрег(СтрокаВторогоУровня.Наименование),"услуг") = 0 Тогда
                    
                    Если РезультатЗапроса.Найти(СтрокаВторогоУровня.Код,"Артикул") = Неопределено Тогда
                        
                        Ном = Справочники.Номенклатура.СоздатьЭлемент();
                        Ном.Артикул = СтрокаВторогоУровня.Код;
                        Наименование = СтрЗаменить(СтрокаВторогоУровня.Наименование, СтрокаВторогоУровня.Код, "");
                        Наименование = СокрЛП(Наименование);
                        Ном.Наименование = Наименование;   
                        Ном.НаименованиеПолное = Наименование;   
                        Ном.ВидНоменклатуры = Справочники.ВидыНоменклатуры.НайтиПоНаименованию("Товары");  
                        Ном.ЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоНаименованию(СтрокаВторогоУровня.ЕдиницаИзмерения);   
                        Ном.ВидСтавкиНДС = Перечисления.ВидыСтавокНДС.Общая;
                        Ном.НоменклатурнаяГруппа = Справочники.НоменклатурныеГруппы.НайтиПоНаименованию("Основная номенклатурная группа");
                        Ном.Записать();
                        СтрокаВторогоУровня.Номенклатура = Ном.Ссылка; 
                        СтрокаВторогоУровня.Характеристика = Ном.Ссылка; 
                    Иначе
                        //Сообщить("Найден "+СтрокаВторогоУровня.Код);
                    КонецЕсли; 
                КонецЕсли; 
            КонецЕсли;    
        КонецЦикла;
        
    КонецЦикла; 
    
    Таб.Строки.Очистить();   

    ЗначениеВРеквизитФормы(Таб, "ДеревоНоменклатуры");


КонецПроцедуры

&НаКлиенте
Процедура СоздатьНоменклатуру(Команда)
    
    СоздатьНоменклатуруНаСервере();
    
    ЗаполнитьВариантыСопоставленияНоменклатуры();

    ЗаполнитьДеревоНоменклатуры();
    
КонецПроцедуры

 

Диадок

См. также

Регламентированный учет и отчетность ЭДО и ОФД Бухгалтер Платформа 1С v8.3 1С:Бухгалтерия 3.0 Пищевая промышленность Россия Бухгалтерский учет Налоговый учет Акцизы Платные (руб)

Расширение для Бухгалтерии предприятия 3.0 «Акцизы на сахаросодержащие напитки» предназначено для автоматизированного учета сумм акцизов по реализованным сахаросодержащим напиткам с 01 июля 2023 года. Позволяет выделить суммы акциза в первичных документах («Реализация товаров и услуг», «Корректировка реализации»), сформировать проводки по начислению акциза, а также сформировать и отправить корректные документы по ЭДО.

14400 руб.

16.10.2023    1500    15    0    

13

SALE! 50%

Кассовые операции Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Программист Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Россия Бухгалтерский учет Налоговый учет Управленческий учет Платные (руб)

В публикации размещены специализированные обработки для загрузки кассовых чеков в базах 1С (для локальных баз): '1С:Бухгалтерия предприятия, ред. 3.0', '1С:Управление нашей фирмой 8, ред. 3.0', '1С:Комплексная автоматизация, ред. 2.5', ‘1С:ERP Управление предприятием, ред. 2’ и ‘1С:Управление торговлей, ред. 11.5’. Вы просто сканируете QR коды с бумажных и электронных чеков c помощью мобильного приложения ФНС и чеки автоматически (без ручного ввода) загружаются в документы 'Авансовый отчет', 'Расходы предпринимателя', 'Путевой лист', 'Приходная накладная', 'Поступление (акты, накладные, УПД)', 'Приобретение товаров и услуг', 'Отчет о розничных продажах' и 'Поступление денежных документов'.

12960 9720 руб.

19.08.2020    66665    316    73    

215

ЭДО и ОФД Обмен с ГосИС Программист Бухгалтер Пользователь 8.3.14 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление холдингом 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Бухгалтерский учет Управленческий учет Платные (руб)

Рабочее место для работы с ЭДО из 1С : Диадок, СБИС, ЭДО Лайт (Lite), Такском, Signatura.pro, Астрал.ЭДО, ГИС МТ (Честный знак, ЦРПТ). Загрузка и отправка УПД, УКД, ТОРГ12, Акта в 1С (сохранение в файл и последующая загрузка через личный кабинет не требуется). Также поддерживается: отправка печатных форм, произвольных файлов, подписание, отклонение, аннулирование документов. Поддержка МЧД для СБИС и Диадок. Решение реализовано в виде расширения на управляемых формах. Для обычных форм - внешняя обработка. Поддержка Linux.

3600 руб.

16.12.2020    38892    248    199    

88

Регламентированный учет и отчетность Обмен с ГосИС ЭДО и ОФД Бухгалтер Пользователь Платформа 1С v8.3 1С:Управление торговлей 11 Оптовая торговля, дистрибуция, логистика Россия Управленческий учет Платные (руб)

Работаете по контрактной схеме, сталкивались с проблемой, что в контракте жестко указаны наименование, цена, единица измерения товара. И не все готовы создавать новую номенклатуру под каждый контракт или менять наименование и единицу измерения для уже имеющейся. Тем более, бывает так, что контракт - это формальность. Контракт не описывает жесткие условия поставки, нужно соблюсти правильность в предоставлении документов. Данное решение позволит вам оперировать своей номенклатурой при оформлении реализаций по государственному контракту в УТ 11.5 и КА 2.5.11, в то же время выводить на печать документы, соответствующие данным контракта. Реализована выгрузка для сайта госзакупок (ЕИС) по 44-ФЗ.

40800 руб.

19.12.2022    10870    21    19    

17

Документооборот и делопроизводство (СЭД) ЭДО и ОФД Учет документов Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Мощный, единый инструмент для решения всех проблем, связанных с переходом на ЭДО. Экономит бумагу и время - организует архив оригиналов первичных документов прямо в базе 1С, в прикрепленных файлах к соответствующим документам. С помощью комплексного отчета по ошибкам в ЭДО позволяет выявить и исправить все возможные ошибки - ошибочно сопоставленные документы, не подписанные документы, подписанные, но не загруженные в 1С документы. Автоматически сопоставляет не сопоставленные между собой документы. Может работать по расписанию и присылать отчет о состоянии архива/по ошибкам на почту. Взаимодействует напрямую с сервисами Диадок/СБИС, имеет интуитивно понятный интерфейс и учитывает 3-х летний опыт 40+ клиентов.

14880 руб.

17.12.2018    44969    62    51    

75

Кассовые операции ЭДО и ОФД Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Платные (руб)

Согласно 54-ФЗ по правилам ведения кассовых операций необходимо оформлять приходные кассовые ордера (ПКО) и расходные кассовые ордера (РКО) на основании чеков ККМ. Все данные о чеках, можно взять на сайте оператора фискальных данных (ОФД). Обработка загрузки данных из ОФД в 1С сделает за вас в 1С - ПКО и РКО, Операции по платежным картам или Отчет о розничных продажах (может создать номенклатуру в 1С, указать налоги и др. реквизиты в документах в зависимости от налогообложения ККМ в торговой точке). Проверено на: OFD.RU / Первый ОФД / Такском / Платформа ОФД / Ярус / ОФД Яндекс / ОФД Астрал /ОФД СБИС / Гарант ОФД / КОРУС ОФД / КОНТУР ОФД / ОФД АО Тандер / ИнитПро / Группа Элемент/

3600 руб.

09.08.2017    149482    878    372    

532

Оптовая торговля Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Бухгалтер Платформа 1С v8.3 Бухгалтерский учет Управляемые формы 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Бухгалтерский учет Управленческий учет Платные (руб)

Выгрузка УПД, товарной накладной ТОРГ-12, акта, счета-фактуры по реализации (в БП сч-ф на аванс) в xml-файл в формате ФНС приказ 820 от 19.12.2018. Выгрузка УКД и корректировочного счета-фактуры в xml-файл в формате ФНС приказ 736 от 12.10.2020. Выгрузка товарной накладной в xml-файл ФНС приказ 551 от 13.11.2015, редакция 08.04.2019. Выгрузка акта приемки-сдачи работ (услуг) в xml-файл ФНС приказ 552 от 13.11.2015, редакция 08.04.2019. Добавлена выгрузка счетов на оплату по документам ЗаказПокупателя и СчетНаОплатуПокупателю. Добавлена обработка Выгрузка УПД c документов реализации 1С в Контур.Диадок по API.

15600 руб.

22.03.2018    81699    213    13    

304
Оставьте свое сообщение