Imagius: конвертация PDF в картинку (Native Win 32/64)

Внешняя компонента для конвертации PDF файлов в картинки без использования дополнительных программ. Работает на сервере и в тонком клиенте.

Арт.: 2122606

Снимок экрана 2024-06-22 140615.png
Снимок экрана 2024-06-22 140615.png
Лицензии

2400 руб.

Техподдержка и обновления

3000 руб.

Услуга

3500 руб.

Область применения

Для рендеринга PDF в картинку в компоненту передаётся путь к файлу. В результате можно получить либо несколько файлов картинок в формате PNG (для каждой страницы), либо двоичные данные картинки для указанного номера страницы для обработки в оперативной памяти без записи на диск.

Технические требования

Компонента работает как на x86, так и x86_64 платформах, в режиме Сервера, Тонкого клиента. Распространяется в виде пакетного файла, который содержит в себе все версии компоненты.

Проверено на платформе 1С версий 8.3.20.2180, 8.3.24.1467

Функциональные возможности

Пример работы с компонентой на сервере и на клиенте:

 
#Область ТестДляКлиента

&НаКлиенте
Процедура ТестДляКлиента(Команда)
	Подключить(Истина);
КонецПроцедуры

&НаКлиенте 
Процедура Подключить(УстановитьЕслиНеПодключено) Экспорт
	Сообщить("Начинаем подключение ВК на клиенте.");
	
	НачатьПодключениеВнешнейКомпоненты(
       	Новый ОписаниеОповещения("ПослеПодключения", ЭтотОбъект, УстановитьЕслиНеПодключено),
       	"ОбщийМакет.Imagius",
       	"Imagius",
		ТипВнешнейКомпоненты.Native);
КонецПроцедуры

&НаКлиенте
Процедура ПослеПодключения(Подключено, УстановитьЕслиНеПодключено) Экспорт
	Если Подключено Тогда
		Сообщить("ВК успешно подключена на клиенте.");
		Тест();
		
	ИначеЕсли УстановитьЕслиНеПодключено Тогда
		Сообщить("Начинаем установку ВК...");
		
		НачатьУстановкуВнешнейКомпоненты(
           	Новый ОписаниеОповещения("Подключить", ЭтотОбъект, Ложь),
           	"ОбщийМакет.Imagius");
    Иначе
        Сообщить("Не удалось установить/подключить внешнюю компоненту.");
	КонецЕсли;
КонецПроцедуры

&НаКлиенте
Асинх Процедура Тест()
	ОбъектВК = Новый("Addin.Imagius.Imagius");
	
	НастройкиПрименены = Ждать ОбъектВК.НастройкиРендерингаАсинх(
	"{
	|	""target_width"": 2000,
	|	""maximum_height"": 3000
	|}");
	Сообщить("Настройки применены: " + НастройкиПрименены.Значение);
	
	Результат = Ждать ОбъектВК.PdfFile2ImgFileАсинх(Объект.ПутьФайлPDF, "password", "1-100");
	Результат = ОбработкаСтрокиXML.УдалитьНедопустимыеСимволыXML(Результат.Значение);
	Сообщить("Обработанные файлы: " + Результат);
	Сообщить("Обработка завершена.");
КонецПроцедуры

#КонецОбласти // ТестДляКлиента

#Область ТестДляСервера

&НаКлиенте
Процедура ТестДляСервера(Команда)
	ТестНаСервере();
КонецПроцедуры

&НаСервере
Процедура ТестНаСервере()
	Если Не ПодключитьВнешнююКомпоненту("ОбщийМакет.Imagius", "Imagius", ТипВнешнейКомпоненты.Native) Тогда
		Сообщить("Не удалось подключить ВК на сервере.");
		Возврат;
	Иначе
		Сообщить("ВК успешно подключена на сервере.");
	КонецЕсли;
	
	ОбъектВК = Новый("Addin.Imagius.Imagius");
	
	НастройкиПрименены = ОбъектВК.НастройкиРендеринга(
	"{
	|	""target_width"": 2000,
	|	""maximum_height"": 3000
	|}");
	Сообщить("Настройки применены: " + НастройкиПрименены);
	
	Данные = ОбъектВК.PdfFile2ImgData(Объект.ПутьФайлPDF, "", 1);
	Картинка = Новый Картинка(Данные, Истина);
	Сообщить("Получена картинка в формате: " + Картинка.Формат());
	
	ОбработкаКартинки = Новый ОбрабатываемаяКартинка(Картинка);
	ОбработкаКартинки.ВыделитьОбласть(100, 100, 860, 960);
	
	Картинка = ОбработкаКартинки.ПолучитьКартинку();
	Картинка.Записать("C:\...\label-crop.png");
	Сообщить("Обработка завершена.");
КонецПроцедуры

#КонецОбласти // ТестДляСервера

 

Методы

НастройкиРендеринга / ConfigPdfium

Параметры:

Настройки - Строка - настройки компоненты в формате JSON. Передаваться могут не все поля, а только необходимые. Например, передаём точную ширину картинки (target_width) и максимальную высоту (maximum_height). Фактическая высота картинки будет расчитана автоматически. Допустимые  поля структуры:

  • target_width - Число - ширина картинки в пикселях;
  • target_height - Число - высота картинки в пикселях;

  • scale_width_factor - Число - масштаб по ширине;

  • scale_height_factor - Число - масштаб по высоте;

  • maximum_width - Число - максимальный размер результата по ширине в пикселях;

  • maximum_height - Число - максимальный размер результата по высоте в пикселях.

Результат:

Булево - признак того, что настройки успешно установлены.

 

ФайлPdfВФайлКартинки / PdfFile2ImgFile

Параметры:

Путь - Строка - путь к PDF файлу.

Пароль - Строка - пароль к файлу, если установлен, или пустая строка.

Страницы - Строка - номера необходимых страниц в формате "1, 2, 5-7".

Результат:

Строка - массив в формате JSON с именами файлов-картинок.

 

ФайлPdfВДанныеКартинки / PdfFile2ImgData

Параметры:

Путь - Строка - путь к PDF файлу.

Пароль - Строка - пароль к файлу, если установлен, или пустая строка.

Страница - Число - номер страницы.

Результат:

ДвоичныеДанные - данные, из которых можно сформировать картинку и обработать, сохранить на диск.

Техническая поддержка и обновления

Бесплатный период техподдержки составляет 1 месяц со дня покупки.

Также после приобретения вы получаете 3 месяца бесплатных обновлений.

По окончании бесплатного периода вы можете приобрести услугу технической поддержки с доступом к обновлениям на платной основе.

Проверить наличие обновлений можно в личном кабинете. Если обновления недоступны - загрузить новую версию можно после покупки обновлений/технической поддержки.

Задать вопрос по программе можно по кнопке "Техподдержка" на странице описания.

При создании тикета необходимо предоставить:

  1. Номер заказа
  2. Описание вопроса. Если это ошибки - напишите порядок ваших действий с программой, которые к ней привели (приложите видео/скриншоты/отчеты об ошибке)
  3. Точную конфигурацию 1С, и версию платформы, на которой используете купленное решение (наименование и версию 1С можно взять из раздела "О программе"), версию купленной программы.

К созданной заявке подключается специалист. Дальнейшее обсуждение проблемы будет проходить в тикете техподдержки. Стандартный срок реакции - 24 часа в рабочие дни с момента обращения

Техподдержка
 

Проверено на следующих конфигурациях и релизах:

  • Управление торговлей, редакция 11, релизы 11.5.8.254
  • 1С:Деньги, релизы 2.0.44.28
Статистика:
Просмотры 425
Загрузки 0
Рейтинг 0
Создание 25.06.24 10:24
Обновление 25.06.24 10:24
№ Публикации 2122606
Характеристики:
Теги

PDF PNG конвертация обработка картинка

Рубрики Разработка внешних компонент
Кому Программист
Тип файла Архив с данными
Платформа Платформа 1С v8.3
Конфигурация Конфигурации 1cv8 ,
Не имеет значения ,
1С:Управление торговлей 11
Операционная система Windows
Страна Не имеет значения
Отрасль Не имеет значения
Налоги Не имеет значения
Вид учета Не имеет значения
Доступ к файлу Платные (руб)
Код открыт Нет

Оставьте свое сообщение

См. также

Внешняя компонента WebSocket для 1С (c поддержкой Authorization token bearer)

Внешняя компонента в виде библиотеки (.dll файл), позволяющая посылать команды и получать ответы по протоколу WebSocket из 1С. Компонента работает только на стороне "клиента".

4440 руб.

Внешняя компонента для сканирования (замена TWAIN-компоненты БСП) (Native Win 32/64)

Внешняя компонента позволяет работать c TWAIN-совместимым оборудованием (сканерами, камерами) . Полностью совместима со стандартной TWAIN-компонентой из БСП и может применяться как ее замена без изменения вызовов, при этом может работать с...

3000 руб.

Внешняя компонента печати PDF (Native Win 32/64)

Внешняя компонента позволяет печатать PDF файлы непосредственно из 1С, не используя при этом сторонних программ. Прекрасно работает на сервере, тонком клиенте и веб-клиенте. Основана на проекте PDFium из состава проекта Chromium/Chrome

1500 руб.

GGraphics - внешняя компонента для работы с картинками jpg (jpeg), png, bmp, gif, tif

Позволяет автоматизировать работу с картинками. С помощью компоненты можно измерять размер изображений, поворачивать их, наносить водяные знаки, конвертировать из одного формата в другой. Будет очень полезна для интернет-магазинов и всех, к...

3600 руб.

Asterisk API: внешняя компонента для подключения 1С к телефонии

Внешняя компонента выполнена по технологии Native API для 1С 8.х, обеспечивает доступ к программным АТС Asterisk (FreePBX, Elastix) через AMI интерфейс. Через него можно управлять многими функциями Asterisk (определение номеров, перевод зво...

2400 руб.

Мультитул - Инструменты для работы с оборудованием и возможности Python в 1С.

На текущий момент поддерживается tcp клиент и сервер, работа с COM портом(232, 485) в удобном для отладки варианте через HEX-строку и в неизмененном виде, создание modbus запроса через вышеуказанные интерфейсы и дешифровка ответа. Распознав...

6000 руб.

Внешняя компонента GraphQL клиент для 1С

Внешняя компонента, позволяющая посылать команды и получать ответы по GraphQL протоколу из 1С.Может быть использована при интеграции. В 1С работает на стороне "клиента".

4600 руб.

Компонента ExchangeStruc (Структура Обмена). Прямой обмен данными между потоками, сессиями и окнами.

Аддон "Структура Обмена" (ExchangeStruc) - это компонента, которая обеспечивает доступ к разделяемым процессом структурам, аналогичным структурам 1С. Обеспечивает прозрачную передачу данных примитивных типов, в том числе Двоичных ...

7200 руб.

«UniServer AUTO: WeightIndicator» - универсальный драйвер весового индикатора

Универсальный драйвер весового индикатора «UniServer AUTO: WeightIndicator» предназначен для подключения весовых индикаторов автомобильных, вагонных , платформенных весов любых производителей к различным конфигурациям 32-х или 64-х разрядны...

10800 руб.

COMNativeWrapper, COM-Диспетчер Native-компонент 1С (Аддонов), совместимый со всеми версиями 1С (7.7, 8.0, 8.1, 8.2, 8.3).

Обертка COM для компонент типа Native-Addin под разные версии 1С от 8.2 до 8.3 с поддержкой интерфейсов IMsgBox, IAttachInfo, IPlatformInfo. Поддержка свойств компонент имеющих тип Binary. Работает под любыми версиями 1С от 7.7 до 8.3. На п...

4500 руб.