Коцюра Сергей

3544
Рейтинг

Сергей Коцюра
CheBurator



  •   Регистрация: 05.03.2006 (12 лет назад)

  •   Был(а) на сайте: сегодня в 12:08


Группы

Партнер IS-SP

Профессиональный разработчик

IE 2012 Участник

Партнер IS-WP

IE 2013 EVO Докладчик

IE 2015 Участник

IE 2016 Участник

Модератор раздела

IE 2017 Участник

Рейтинг 3544

[ПОЛЕЗНЯШКА, 7.7] Как посчитать итоги по документам черным запросом с изподвывертом? 8

v7.7 1cv7.md Бесплатно (free)

Мелкая полезняшка, считает запросом итоговую сумму документов и количество документов.

12.03.2016    10396    18    

Практические вопросы внедрения и развития автоматизации склада. Часть 2 43

1С:Франчайзи, автоматизация бизнеса УУ Оптовая торговля Бесплатно (free)

Слайды к докладу на секции "Складские технологии" в малом зале на IEE-2013. Пример автоматизации склада по "бюджетному" варианту с использованием ТСД+RDP.

26.03.2015    22551    31    

Практические вопросы внедрения и развития автоматизации склада 129

Бесплатно (free)

Мне, как одинэснику, не приходилось заниматься какими-то узкими задачами «от сих до сих». Вся моя профессиональная деятельность, как одинэсника, была всегда связана с очень широким кругом вопросов. Наверное, потому, что я работал, в основном, в малых компаниях, где приходилось работать над всем спектром вопросов.

26.12.2014    32295    64    

[Шишки для мартышки] Упаковка/ускорение нулевых итогов регистров для файлового вариант 7.7 13

v77::ОУ 1С7:ТиС Россия Абонемент ($m)

По статье "Зачем в 1С нужно периодически пересчитывать итоги по регистрам?" http://infostart.ru/public/177171/ Обработка для 7.7, файловая, только для специалистов. Никаких гарантий и возмещений. Работает только в разделенном режиме (прямой запрос VFP). После выполнения - в обязательном порядке ТиИ (только упаковка), После ТиИ в обязательном порядке - принудительно переиндексировать. Родственная разработка для SQL: http://infostart.ru/public/177579/

1 стартмани

28.03.2013    39918    75    1    

Какого пола у вас компьютер? 50

Россия Абонемент ($m)

Какого пола у вас компьютер? 1) Откройте блокнот 2) Наберите сами или скопируйте CreateObject("SAPI.SpVoice").Speak"I love you" 3) Сохраните как xyz.vbs 4) Запустите Если вы услышите мужской голос, поздравляю, у вас мальчик, если женский девочка. . кому лень это все делать - может скачать и запустить на выполнение приложенный файл. данную фичку написал Олег Садовников http://forums.kuban.ru/forum/viewtopic_new.php?t=3762004&page=1#end

1 стартмани

08.02.2011    13175    169    26    

Mercurial — распределенная система контроля версий с открытым кодом... 16

Россия Бесплатно (free)

Mercurial — это современная распределенная система контроля версий с открытым кодом. Эта система — заманчивая замена для более ранних систем вроде Subversion. В этом простом учебном пособии в шести частях Джоэль Спольски (Joel Spolsky) рассказывает о ключевых принципах Mercurial.

15.01.2011    16748    5    

Логирование изменений средствами MS SQL 4

v77::ОУ v77::БУ v77::Расчет 1cv7.md Бесплатно (free)

В данной статье описывается вариант минимальной реализации, а конкретнее только “отлавливание” самого факта изменения реквизитов справочников и шапок документов. Спросите зачем?

03.10.2010    11584    6    

[ОБУЧАЛОВКА] Прямые запросы: практические примеры разработки 29

v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Бесплатно (free)

Пример прямого запроса для типовой 1С 7.7. ТиС для извлечения цен номенклатуры... тест

30.09.2010    54239    37    

АBC-XYZ анализ, описание и пояснения 10

Взаимоотношения с клиентами (СRM) Бесплатно (free)

Данные методы анализа вызывают большой интерес у представителей бизнеса. Размещены методики анализа с небольшими комментариями по поводу их применения.

30.08.2010    54692    5    

Oracle все сильнее отстает от «1С» 9

Россия Бесплатно (free)

Спад российского рынка ИСУП в 2009 г. зафиксировала IDC. По данным аналитиков общий объем этого сегмента сократился почти на 19%. Поставщики в первой пятерке рейтинга сохранили свои места. Находящейся на втором месте «1С» удалось еще дальше оторваться от Oracle. IDC в очередной раз оценила объем российского рынка интегрированных систем управления предприятием (ИСУП). В исследовании даются доли лидирующих поставщиков по результатам 2009 г. и прогноз до 2014 г. Общий объем данного сегмента сократился с $606,56 млн до $492,18 млн. Если в 2008 г. рост российского рынка ИСУП составлял 4,7% (с $579 млн в 2007 г.), то сейчас аналитики зафиксировали годовое падение на 18,9%.

29.08.2010    11825    4    

Нелицензионное программное обеспечение: угрозы и риски 15

Россия Бесплатно (free)

Интересная статья Игоря Слабых, зам. генерального директора ООО "Юридическая компания "Ваш правовой помошник"" о лицензировании программного обеспечения. В статье рассказывается когда и почему нужно лицензироваться, описываются виды ответственности за использование нелицензионного программного обеспечения, развенчиваются мифы использования нелегального программного обеспечения.

24.05.2010    11749    13    

Информационная безопасность: если пришла проверка 23

Россия Бесплатно (free)

Первоначально необходимо выяснить цель визита и полномочия сотрудников на совершение определённых действий. Данные полномочия могут быть выражены в различных документах (постановлениях начальника органа дознания, суда, следователя, дознавателя) в зависимости от того, каким законом регламентированы их действия (доследственная проверка в рамках ст. 144, 145 Уголовно-процессуального кодекса РФ или деятельность в рамках Законов «О милиции», «Об ОРД»). Убедитесь в том, что перед вами действительно сотрудники службы, которая уполномочена проводить проверки легальности ПО. Для этого проверьте служебные удостоверения пришедших и обязательно перепишите все данные из документов. Тех проверяющих, которые отказались предъявлять удостоверения, не допускайте к проверке. Уточните основания для проверки. Сотрудники милиции могут приходить только в целях проведения доследственной проверки. Не разрешайте проверяющим использовать софт-сканер (специальный программный продукт, позволяющий определять наличие тех или иных программ). Он не сертифицирован в России, и его использование является незаконным. Пусть проверяют визуально...

16.03.2010    12367    13    

[ПОЛЕЗНЯШКА] Указание номера платежно-расчетного документа в счет-фактуре выданном 11

v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Типовая ТиС 7.7 Руководство к исправлению типовой печатной формы для указания номера(ов) платежно-расчетного(ых) документа(ов) в выданном счет-фактуре.

1 стартмани

17.09.2009    15694    42    15    

Указание номера платежно-расчетного документа в счет-фактуре выданном 0

v77::ОУ 1С7:ТиС Россия НУ Оптовая торговля Бесплатно (free)

Типовая ТиС 7.7 Руководство к исправлению типовой печатной формы для указания номера(ов) платежно-расчетного(ых) документа(ов) в выданном счет-фактуре.

17.09.2009    7623    1    

Памятка при поиске работы: задай вопросы работодателю (внимение, бойан!) 14

Россия Бесплатно (free)

АНКЕТА Предоставляемая вами информация рассматривается как конфиденциальная и не передаётся третьим лицам без Вашего согласия. Заполнение анкеты не гарантирует вам моего трудоустройства, решение по поводу вашей вакансии принимается на основании интегральной оценки ваших бизнес-качеств, престижности, опыта, а также зависит от наличия конкурентоспособных вашей компании кандидатов, претендующих на меня в качестве сотрудника. Я обязательно свяжусь с Вами, если увижу в вас потенциального работодателя и при условии незанятости к тому моменту.

01.09.2009    10396    8    

[ОБУЧАЛОВКА] Полезное наблюдение: постоянное позиционирование на поле ввода 12

v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

Простое маленькое "наблюдение", получившееся в результате обсуждения вопроса на соседних форумах. Q: как установить курсор в поле ввода при нажатии энтера на этом же поле ввода? А: известно, что...

28.08.2009    13904    17    

[ОБУЧАЛОВКА] Позиционирование на последнем элементе списка справочника 5

v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

Для журналов можно задать режим отображения при открытии журнала (в режиме 1С:Предприятие): Меню - Сервис - Параметры-Журналы - "При открытии жирнала переходить в конец = вКл". Вопрос: почему нельзя задать такой вариант для справочников?

30.06.2009    15630    11    

[ПОЛЕЗНЯШКИ] Очистка номенклатуры от неиспользуемых элементов 64

v77::ОУ 1С7:ТиС Учет ТМЦ Абонемент ($m)

1C v.7.7 Готовое решение. Не требует настройки. Не требует допрограммирования. Обработка предназначена для автоматической "подчистки" базы типовой ТиС от "неиспользуемых" элементов номенклатуры.

29.06.2009    19212    824    57    

[РЕШЕНИЕ ПРОБЛЕМ] Частный (?) случай падения 1С 7.7 при загрузке v7plus.dll 16

v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

Рассматривается шаманский метод борьбы с причиной вылета 1С-ки...

24.06.2009    22021    13    

[ОБМЕН] Формирование файла заказа поставщику 8

v77::ОУ 1С7:ТиС Россия Монитор заказов Бесплатно (free)

1C v.7.7 Внешняя печатная форма, предназначена для формирования файла заказа поставщику и выполнения с ним простейших действий. Подключается как внешняя печатная форма к документу "Заказ поставщику". Обработка простая, представляет интерес для начинающих не особо продвинутых программистов 1С.

29.05.2009    10945    177    2    

[ОБУЧАЛОВКА] Некоторые особенности обработки печати отчетов при использовании Formex 4

Россия Бесплатно (free)

Обсуждается использование предопределенной процедуры ПриПечатиТаблицы(), которая отрабатывает в момент отправки печатной формы на принтер путем вызова штатного диалога печати или при использовании метода Таб.Напечатать(0)

26.03.2009    11267    12    

Унифицированная форма ИНВ-17: инвентаризации расчетов с покупателями, поставщиками и прочими дебиторами и кредиторами 50

v77::БУ 1С7:Бух Россия БУ Дебиторская и кредиторская задолженность Абонемент ($m)

1C v.7.7 Порядок использования отчета. 1. Задать дату акта. Все цифры выводятся на конец дня указанной даты. 2. Выбрать группу клиентов. Если выбрали не группу, а конкретного клиента - подставляется родительская группа. Можно группу не задавать вообще - акт будет формироваться по всем клиентам...

1 стартмани

22.11.2008    14185    948    13    

Акт приема на ответственное хранение: внешняя печатная форма МХ-1 28

v77::ОУ 1С7:ТиС Россия БУ Учет ТМЦ Абонемент ($m)

Внешняя печатная форма MX-1 для типовой ТиС

1 стартмани

30.10.2008    17360    672    25    

[ДОСТУП] 3П Охрана 1.0 - простой пропускной пункт 129

v77::ОУ v77::БУ v77::Расчет 1cv7.md Учет рабочего времени Абонемент ($m)

Как всегда - мы работаем для народа... Простое решение для организации Простого Пропускного Пункта (3П). Просто. Надежно. Нетребовательно. Первая неделя разработки в эфире - раздача нахаляву...

6000 руб.

01.10.2008    21564    1487    512    

[IMAGE] Просмотр, масштабирование и скроллинг картинок 38

v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Доработанный и исправленный рабочий пример к сабжу http://www.infostart.ru/profile/1782/projects/1747/

1 стартмани

08.07.2008    16225    302    37    

Теория ошибок 61

Россия Бесплатно (free)

Основные постулаты теории ошибок.

18.06.2008    10869    42    

[ОБУЧАЛОВКА] Моделирование роста численности популяции тараканов 34

v77::БУ 1cv7.md Россия Бесплатно (free)

Данная обработка демонстрирует рост численности популяции тараканов.

13.05.2008    11568    154    14    

Путевые заметки... 6

v7.7 1С7:ТиС Россия Бесплатно (free)

Облегчаем жизнь по восстановлению ГП...

12.05.2008    11604    47    

[ОБУЧАЛОВКА] Почему оплата не закрывает документ, на основании которого была выписана? 9

v7.7 1cv7.md Кадровые агентства, подбор персонала УУ Бесплатно (free)

Очень часто всплывает вопрос, аналогичный "Почему оплата не закрывает документ, на основании которого была выписана?" Уж сколько копий переломано по этому поводу, выдано объяснений и развернуто дискуссий... однако воз и ныне там... Вопросы и бредовые пожелания плодятся как кролики/тараканы (кстати, про тараканов у меня здесь: http://infostart.ru/profile/174/projects/1969/). Мой ответ простой: в рамках договора в типовой ТиС погашение долгов документами оплаты реализовано по ФИФО (документ-основание используется лишь для удобства заполнения документа оплаты), почему по ФИФО, а не, например, как описано в заголовке? ДА ОЧЕНЬ ПРОСТО!!! Бухгалтеры в принципе неспособны обеспечить закрытие документов-оснований документами оплаты по нескольким простым причинам: не учитывают взаимозачеты (дает сдвижку оплат); не учитывают возвраты (влияющие на долги по документам оплаты), частичные оплаты/переплаты добавляют геморроя... банальные ошибки как со стороны бухгалтеров при разноске платежей, так и со стороны клиентов при указании назначений платежей и т.д. Если это суммировать, то вывод простой - бухгалтера!!! ПРОСТО НЕСПОСОБНЫ ЦЕЛЕНАПРАВЛЕННО И АККУРАТНО ВЫПОЛНЯТЬ ВСЕ ТРЕБУЕМЫЕ ДЕЙСТВИЯ ПРИ ВЕДЕНИИ ВЗАИМОРАСЧЕТОВ ПО ПРИНЦИПУ ПОГАШЕНИЯ "ДОКУМЕНТОВ-ОСНОВАНИЙ"!!! (вдогонку: почему-то многие бухгалтера уверены, что они умеют ТУПО СЧИТАТЬ лучше, ЧЕМ ТУПО УМЕЕТ СЧИТАТЬ КОМПЬЮТЕР)

26.02.2008    13115    54    

[ОБУЧАЛОВКА] Каким макаром к номенклатуре привязать картинку...? 62

v7.7 1cv7.md Россия Бесплатно (free)

Последнее время, буквально в течение недели, выплывает постоянно один и тот же вопрос: как показать картинку в справочнике (товаров, сотрудников и т.д.)..? Странный вопрос... На дисках ИТС описано это наверное с начала 2000-х годов, плюс в ЗиК карточка сотрудника показывается... или я отстал от жизни...? Как всегда - парить себе мозги не будем, надо картинку - сделаем! Делаем - как всегда - без лишней головной боли (глубокое имхо)...

10.02.2008    28891    57    

Косил Ясь конюшину... 9

v7.7 1cv7.md Россия Бесплатно (free)

Часто непонятна логика разработчиков... Та же кнопочка "остатки" в форме списка номенклатуры - почему в режиме "по складам" - остатки и резервы показывает, а в режиме "по фирмам и складам" - нет...?

23.01.2008    10655    4    

Бот из Контры 7

Россия Бесплатно (free)

Фантазия на тему "Религия и программисты 1С". Исходный вариант здесь:

27.11.2007    10761    12    

[ОБУЧАЛОВКА] ZLOPUN или как меня достали неснимающиеся резервы... 11

v77::ОУ 1С7:ТиС Россия УУ Учет ТМЦ Бесплатно (free)

Решение проблемы которой не должно быть. Не должно быть, конечно же, проблемы... А она есть! Причем, имхо, проблема эта похожа на наглого суслика - вылазит в самый неподходящий момент. Поэтому - берем дуст и травим сусликов беспощадно...

14.11.2007    12371    26    

[IMAGE] Шоу "За лупой" (просмотр и установка привязки товар-изображение) 50

v77::ОУ 1С7:ТиС Россия Абонемент ($m)

(скачать и использовать можно бесплатно, т.е. ДАРОМ) Простая обработка, представляющая собой "минимальный" файловый менеджер для установки (назначения) товарам изображений, т.е. видим название товара - контролируем визуально по картинке товара...

5 стартмани

07.11.2007    20332    844    66    

[ОБУЧАЛОВКА] Как перестать парить себе мозги и не фанить тюльку... - 2 43

v7.7 1cv7.md Россия Бесплатно (free)

Статья продолжает описание полезностей, которые реализуем штатными средствами - вместо головной боли по написанию корявых доморощенных алгоритмов. ;-) В статье рассматривается расширение функционала по подбору объектов в штатной обработке Отчет.ПодборОбъектов (или внешней Uchoice.ert)

18.10.2007    14779    14    

[ОБУЧАЛОВКА] Как перестать парить себе мозги и не фанить тюльку... 53

v7.7 1cv8.cf Россия Бесплатно (free)

Секреты настоящего мастерства: не покупаем Камазов там, где можно проехать на велосипеде...

10.10.2007    15261    26    

[РЕШЕНИЕ ПРОБЛЕМ] "Медленные" базы и прочая.... 17

v77::ОУ 1cv7.md Россия Бесплатно (free)

Краткое описание приведения в порядок "тяжелой" базы... Простой пример выполненной работы.

07.10.2007    12428    24    

[ОБУЧАЛОВКА] Ликбез по сканерам ШК 23

v7.7 1cv7.md Россия УУ Розничная торговля Бесплатно (free)

Краткое описание основных принципов работы/настройки сканеров ШК в программе 1С (по мотивам ветки T1C)

22.09.2007    24332    20    

[ОБУЧАЛОВКА] Счет с разбивкой по основному свойству 9

v77::ОУ 1С7:ТиС Россия Оптовая торговля Бесплатно (free)

(скачать и использовать можно бесплатно, т.е. ДАРОМ) Внешняя печатная форма, идентичная типовому счету. Вместо одного большого счета печатает много маленьких... ;-), т.е. разбивает печать счета по значению основного свойства. Сделана в процессе "обучения" по http://infostart.ru/forum/read.php?21,10870,ref=174

01.09.2007    11474    101    7    

Статистика: Форма 1-автобензин (торг) срочная ОКУД 0614012 в виде стандартного регламентированного отчета. 4

v77::БУ 1С7:Бух Россия Бесплатно (free)

Статистика: Форма 1-автобензин (торг) срочная ОКУД 0614012 в виде стандартного регламентированного отчета. Устанавливается стандартно - Регламентированные отчеты\ Загрузить. При этом появляется доп.группа "Дополнительная отчетность"

01.07.2007    10376    14    6    

[ОБУЧАЛОВКА] Про сети (Ашан, Метро) и их заморочки... 16

v77::ОУ 1С7:ТиС Россия УУ Розничная торговля Бесплатно (free)

Демонстрируется подход к относительно безболезненному исправлению конфигурации ТиС для реализации сетевых заморочек (код сети в печатной форме ТОРГ12)

21.06.2007    13890    47    

Оф-ф-ф-ф-ф-ф-ф. Субботняя сага. 8

Россия Бесплатно (free)

Взгляд на процесс автоматизации с интересной стороны... Взято с "Территории 1С"

16.06.2007    10046    7    

[ОБУЧАЛОВКА] Многоуровневое меню своими руками 29

v7.7 1cv7.md Россия Бесплатно (free)

Описывается подход к созданию многоуровневого меню на основе списков значений. Никакого эксклюзива. Никаких секретов. Задача - минимум кодинга, максимум использования имеющихся наработок. Просто понадобилось - накидал минут за 20. Пользуйтесь... Исходный код и все необходимое - приведен.

27.05.2007    13030    22    

[MultiLevel] Многоуровневое меню штатными средствами 15

v77::ОУ v77::БУ v77::Расчет Россия Бесплатно (free)

Пример демонстрирует использование построения и использования многоуровневого меню штатными средствами на основе списка значений. При использовании рассмотренного подхода все что требуется - сформировать ТЗ с данными для меню.

27.05.2007    11673    8    

[NotaBene] Универсальный отчет по таблице значений 136

v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

1C v.7.7 Готовое решение. Не требует настройки. Не требует допрограммирования. Данная обработка решает часто встречающуюся задачу вывода в "красивом" виде таблицы значений (полученной, например, из запроса). Поддерживается произвольное группирование данных, отключение/включение группировок, в т.ч и создание "шахматок" (типа "продажи понедельно"). Обработка может использоваться как и в отладочных целях (для нормального просмотра ТЗ), так и в составе вполне рабочих отчетов. По крайней мере, я неоднократно клиентам данную обработку ставил вместо того, чтобы каждый раз писать замороченные выводы данных. И клиенты довольны, и мне - проще...

07.05.2007    19988    893    59    

[Pobrekito] Шаблон кнопок "Настройка" и "Обновить" для внешних отчетов/обработок 39

v7.7 1cv7.md Россия Бесплатно (free)

Обработка представляет собой шаблон программного кода для реализации функциональности кнопок "Настроить" и "Обновить" для печатных форм внешних отчетов/обработок. Выражается благодарность Побрекито с "Территории 1С" за предоставленный код.

05.05.2007    10168    109    9    

[Доступ] Сканер отпечатка пальца 57

v77::ОУ v77::БУ v77::Расчет 1cv7.md Бесплатно (free)

Осуществляет контроль доступа к системе путем сканирования отпечатка пальца. Для запуска обработки содержимое архива распаковать (можно поместить в папку ExtForms вашей информационной базы), перед коноцм процедуры ПриНачалеРаботыСистемы() вставить следующий код: ОткрытьФормуМодально("Отчет",,КаталогИБ()+"ExtForms\ScanFinger.ert" );

26.03.2007    19991    354    32    

[Делатель] Комплексная автоматизация вашей фирмы 64

v77::ОУ v77::БУ v77::Расчет 1cv7.md Бесплатно (free)

Данная обработка позволяет решить большинство ваших проблем (даже, возможно, все!) при комплексной автоматизации вашего предприятия. Для этого - скачайте данную обработку, в конфигураторе повесьте на панель кнопку, в команду кнопки впишите ОткрытьФорму("Отчет",,КаталогИБ()+"ExtForms\БКК.ert"). При возникновении новой (нерешенной) проблемы - нажмите эту кнопку на панели задач и ждите решения вашей проблемы/работы.

22.03.2007    17791    543    25    

[Agent007] "Большой брат следит за тобой" v.1f 45

v7.7 1cv7.md Абонемент ($m)

Вы - рядовой пользователь 1С (бухгалтер, менеджер)? У вас возникала проблема? Вам трудно объяснить ее суть (а она, суть, - на экране!) программисту, который на другом конце телефонного провода? Два клика мышью - и ваш программист получит изображение вашего экрана в программе 1С, увидит вашу проблему и быстро вам поможет! Да! Именно так! Решение ваших проблем - в 2-х кликах мышью! Качайте (бесплатно!) и голосуйте рейтингом!

1 стартмани

28.02.2007    14309    170    31    

Комментарии

Новости«Цифра» на службе у молока: Минпромторг протестирует новую маркировку молочной продукции#1 20.07.18 23:53
ХЗ что там творится, но в шаговой доступности от дома, Пятоерочка и Диски - уже несколько дней нет привычного пакетированного молока.
НовостиБлокнот в Windows впервые за почти 20 лет получит значимые обновления#7 20.07.18 16:20
Как мы все эти годы жили без обновлений блокнота...?! я только месяц назад из меню увидел что можно Ф5 нажать...
DevMetadata.js для построения дешевых высоконагруженных сервисов#92 19.07.18 23:44
(91) это хорошо, держите в курсе, интересно
DevMetadata.js для построения дешевых высоконагруженных сервисов#87 19.07.18 20:03
(86) НАРОДУ - нужен не инструмент, а готовые решения. Или инструмент "из коробки", по запуску которого из коробки получится готовое решение.
создавать еще один инструмент в довесок или как альтернативу или к уже существующей технологии - это интересно только для чистых программеров. В нашей (1Сной) области - чистым программеров предложенный инструмент - не интересен потому, что "чистые" 1С-программеры влияния на бизнес-процессы и выстраивание архитектуры - не имеют (нагружать себя лишним инструментарием, неприменяемым в области зарабатывания денег это или непродуктивно или только хобби). А бизнес-программисты 1С - им этот дополнительный инструмент вообще побоку. им хватает головняка и с платформой, и с конфами, и с бизнес-вопросами.

Итого: невнятное позиционирование для ШИРОКИХ масс не дало результата.
Как-то так я себе представляю.
НовостиУкраденные воспоминания: хакеры завладели данными облачного сервиса Timehop#1 14.07.18 22:54
По вакту - кормпания не понесла никакой ответсвенности.
как и положено. все пользуются всем - на свой страх и риск.
Devвывод на Печать таблицы значений#4 14.07.18 0:43
Этот вариант печати ТЗ у меня - основной. Обработка и простенький макет из двух секций у меня включен во все мои конфигурации. Печать - и как отладочная и простые отчеты.

Более продвинутый вариант, то что вам нужно смотри у меня в профайле, искать по "NotaBene" - у себя использую более продвинутый вариант с мелкми плюшками, но опубликованное - то что вам нужно. у меня эта разработка - основная, яне морочусь написанием вывода всяческих отчетов, кропаемых на быструю руку - подсовываю в обработку и ок.
Devвывод на Печать таблицы значений#3 14.07.18 0:36
Код
//****************************************
// Заголовок - заголовок таблицы и окна таблицы
// КолонкиПоНазваниям = 1 - в шапке выводятся представления колонок, 0 = идентификаторы колонок
// ИтогиПоКолонкам = -1 по всем числовым колонкам, "Колонка1,Колонка2"- по указанным колонкам, иначе не выводить
// ИтогиПоЦенам = 0 - колонки, начинающиеся с Цена суммироваться не будут, 1 - как и все остальные колонки
// РазделительРазрядов - разделитель разрядов в числовых значениях, по умолчанию пробел
// ФорматЧисловыхЗначений - форматная строка для чисел
// Таб - Таблица, в которую выводится результат. Если не задан - создается новая таблица
Функция ПечатьТЗ(Знач ТЗ, Заголовок = "",КолонкиПоНазваниям = 1, Знач ИтогиПоКолонкам = -1, 
            ИтогиПоЦенам = 0, ФорматЧисловыхЗначений = "", РазделительРазрядов = " ", 
            Таб = "",ВыводСетки=0,ВыводЗаголовков=0,ВыводНулевойТаблицы=1,ВыводЗаголовковПодвал=0) Экспорт
   ТипДанных = ТипЗначенияСтр(ТЗ);
   
   Если НЕ(ТипДанных = "ТаблицаЗначений") Тогда
      Если ТипДанных <> "Документ" Тогда
         Заголовок = ?(ПустаяСтрока(Заголовок) = 1, "", Заголовок+РазделительСтрок)+ "значения списка";
         ТТЗ = СоздатьОбъект("ТаблицаЗначений");
         ТЗ.Выгрузить(ТТЗ); 
         
         ТЗ = СоздатьОбъект("ТаблицаЗначений");
         ТТЗ.Выгрузить(ТЗ); ТЗ.УстановитьПараметрыКолонки(1,,,,"список");
      Иначе
         Заголовок = ?(ПустаяСтрока(Заголовок) = 1, "", Заголовок+РазделительСтрок)+ ТЗ.ПредставлениеВида()+ " №"+СокрЛП(ТЗ.НомерДок)+" от "+ТЗ.ДатаДок;
         // комментарий
         Если Метаданные.ОбщийРеквизитДокумента("Комментарий").Выбран() = 1 Тогда
            Если ПустаяСтрока(ТЗ.Комментарий) = 0 Тогда
               СтрЗаголовок = СтрЗаголовок + РазделительСтрок + ТЗ.Комментарий;
            КонецЕсли;
         КонецЕсли;
         // автор
         Если Метаданные.ОбщийРеквизитДокумента("Автор").Выбран() = 1 Тогда
            Если ПустаяСтрока(ТЗ.Автор) = 0 Тогда
               СтрЗаголовок = СтрЗаголовок + РазделительСтрок + ТЗ.Автор;
            КонецЕсли;
         КонецЕсли;
         
         ТТЗ = СоздатьОбъект("ТаблицаЗначений");
         ТЗ.ВыгрузитьТабличнуюЧасть(ТТЗ); 
         
         ТЗ = СоздатьОбъект("ТаблицаЗначений");
         ТТЗ.Выгрузить(ТЗ);
         ТЗ.УдалитьКолонку("НомерСтрокиДокумента");
      КонецЕсли;
   КонецЕсли;
   
   МаксШирина = 85;          // максимальная ширина колонки
   МаксШиринаЗаголовок = 20;    // максимальная ширина колонки, обусловленная шириной заголовка
   КоэффициентШрифт = 1.0;    // коэффициент пропорциональности зависимости ширины ячейки от количества символов в содержимом
   
   СписокИтоги = СоздатьОбъект("СписокЗначений"); // список названий колонок с итогами
   
   СпШирина = СоздатьОбъект("СписокЗначений"); // список ширин колонок по таблице
   СпШирина.ДобавитьЗначение(5); // Ширина колонки "Номер строки"
   
   // выбрать в список названия колонок по которым нужно выводить итоги
   Если ПустаяСтрока(ИтогиПоКолонкам) = 0 Тогда 
      Если Найти(ИтогиПоКолонкам, " ") <> 0 Тогда
         ИтогиПоКолонкам = СтрЗаменить(ИтогиПоКолонкам, " ", "");
      КонецЕсли;
      
      Для сч = 1 по ТЗ.КоличествоКолонок() Цикл
         ТипКолонки = "";
         ИмяКолонки = ТЗ.ПолучитьПараметрыКолонки(Сч, ТипКолонки);
         Если (ИмяКолонки = "НомерСтроки") ИЛИ (ИмяКолонки = "НомерСтрокиДокумента") Тогда Продолжить; КонецЕсли;
         
         Если ИтогиПоЦенам = 0 Тогда 
            Если Найти(ВРЕГ(ИмяКолонки), "ЦЕНА") = 1 Тогда Продолжить; КонецЕсли;
         КонецЕсли;
         
         Если ИтогиПоКолонкам = -1 Тогда // все числовые типизированные колонки
            Если (ТипКолонки = "Число")ИЛИ(ТипКолонки = "Number") Тогда
               СписокИтоги.ДобавитьЗначение(ИмяКолонки);
            КонецЕсли;
         ИначеЕсли Найти(","+ИтогиПоКолонкам+",", ","+ИмяКолонки+",") <> 0 Тогда // колонки в строковом виде,разделенные запятыми
            СписокИтоги.ДобавитьЗначение(ИмяКолонки);
         ИначеЕсли Найти(","+ИтогиПоКолонкам+",", ","+Сч+",") <> 0 Тогда // колонки по номерам разделенные запятыми
            СписокИтоги.ДобавитьЗначение(ИмяКолонки);
         КонецЕсли;
      КонецЦикла;
   КонецЕсли;
   
//[*]progadmin, 26.06.2015, ДОБАВЛЕНО НЕТИПОВОЕ
//   Если Таб = "" Тогда
//      Таб = СоздатьОбъект("Таблица");
//   КонецЕсли;
//   
//   Таб.ИсходнаяТаблица("ПечатьТЗ");
// -------------
   Если Таб = "" Тогда
      Таб = СоздатьОбъект("Таблица");
      Таб.ИсходнаяТаблица("ПечатьТЗ");
   КонецЕсли;
   
//[*]_progadmin, 26.06.2015, ДОБАВЛЕНО НЕТИПОВОЕ
   
//[+]progadmin, 26.06.2015, ДОБАВЛЕНО НЕТИПОВОЕ
   СчетчикВысотаТаблицы = 0;   
//[+]_progadmin, 26.06.2015, ДОБАВЛЕНО НЕТИПОВОЕ

   Если СокрЛП(Заголовок) <> "" Тогда
      СчетчикВысотаТаблицы = СчетчикВысотаТаблицы + 1;
      Таб.ВывестиСекцию("Шапка");
      Выс = Таб.ВысотаТаблицы();
      Обл = Таб.Область("R1C1:R"+Выс+"C1");
      Обл.Полужирный(1);
   КонецЕсли;
   
   // заголовки таблицы
   Таб.ВывестиСекцию("Строка|Общая");
   Выс = Таб.ВысотаТаблицы();
   
   Для сч = 1 по ТЗ.КоличествоКолонок() Цикл
      Если КолонкиПоНазваниям = 0 Тогда
         ИмяРек = ТЗ.ПолучитьПараметрыКолонки(сч);
      Иначе
         ИмяРек = "";
         Ном = "";
         ТЗ.ПолучитьПараметрыКолонки(сч,,,,ИмяРек,);
      КонецЕсли;
      Таб.ПрисоединитьСекцию("Строка|Столбец");
      
      Обл = Таб.Область("R"+Выс+"C"+(Сч+1));    // ячейка в которую поместили данные
      Обл.ГоризонтальноеПоложение(3);       // заголовки отцентрировать и установить признак переноса
      Обл.ВертикальноеПоложение(3);
      Обл.Контроль(4);
      Обл.Полужирный(1);
      
      Ширина = СтрДлина(ИмяРек) * КоэффициентШрифт;
      СпШирина.ДобавитьЗначение(Мин(Ширина, МаксШиринаЗаголовок));
   КонецЦикла;
   
   // вывести данные таблицы по строкам
   ТЗ.ВыбратьСтроки();
   Пока ТЗ.ПолучитьСтроку()=1 Цикл
      Ном = ТЗ.НомерСтроки;
      Таб.ВывестиСекцию("Строка|Общая");
      Выс = Таб.ВысотаТаблицы();
      Для сч = 1 по ТЗ.КоличествоКолонок() Цикл
         ИмяРек = ТЗ.ПолучитьЗначение(Ном,сч);
         ТипРек = ТипЗначения(ИмяРек);
         
         
         Если ТипРек = 1 Тогда // Форматировать числовые значения - с разделителями или переданной форматной строкой
            Если ПустаяСтрока(ФорматЧисловыхЗначений) = 0 Тогда
               ИмяРек = СокрЛП(Формат(ИмяРек, ФорматЧисловыхЗначений));
            ИначеЕсли РазделительРазрядов<>"" Тогда
               Стр    = СокрЛП(ИмяРек);
               Длина    = СтрДлина(Стр);
               Поз    = Найти(Стр, ".");
               Точность = ?(Поз = 0, 0, Длина - Поз);
               КоличествоРазделителей = Цел(Длина/3);
               Длина = Длина + КоличествоРазделителей;
               ИмяРек = СокрЛП(Формат(ИмяРек, "Ч0"+Длина+"."+Точность+","+РазделительРазрядов));
            КонецЕсли;
         ИначеЕсли ТипРек = 4 Тогда // форматировать даты стандартно, год полностью
            ИмяРек = Формат(ИмяРек, "ДДДММГГГГ");
         Иначе
            ИмяРек = СокрЛП(ИмяРек);
         КонецЕсли;
         
         Таб.ПрисоединитьСекцию("Строка|Столбец");
         Обл = Таб.Область("R"+Выс+"C"+(Сч+1)); // ячейка в которую поместили данные
         
         Если ТипРек = 1 Тогда
            Обл.ГоризонтальноеПоложение(2); // числа - вправо
         ИначеЕсли (ТипРек = 2) ИЛИ (ТипРек = 11) ИЛИ (ТипРек = 12) Тогда // строки 
            Обл.Контроль(4)
         КонецЕсли;
         // Расчет ширины по содержимому ячейки
         НачШирина = СпШирина.ПолучитьЗначение(Сч+1);
         Ширина = СтрДлина(ИмяРек) * КоэффициентШрифт;
         СпШирина.УстановитьЗначение(Сч+1, Макс(НачШирина,Ширина));
      КонецЦикла;
   КонецЦикла;
   
   Если ПустоеЗначение(ВыводЗаголовковПодвал)=0 Тогда
      //ЗАГОЛОВОК ТАБЛИЦЫ ВНИЗУ ТАБЛИЦЫ
      // заголовки таблицы
      Таб.ВывестиСекцию("Строка|Общая");
      Выс = Таб.ВысотаТаблицы();
      
      Для сч = 1 по ТЗ.КоличествоКолонок() Цикл
         Если КолонкиПоНазваниям = 0 Тогда
            ИмяРек = ТЗ.ПолучитьПараметрыКолонки(сч);
         Иначе
            ИмяРек = "";
            Ном = "";
            ТЗ.ПолучитьПараметрыКолонки(сч,,,,ИмяРек,);
         КонецЕсли;
         Таб.ПрисоединитьСекцию("Строка|Столбец");
         
         Обл = Таб.Область("R"+Выс+"C"+(Сч+1));    // ячейка в которую поместили данные
         Обл.ГоризонтальноеПоложение(3);       // заголовки отцентрировать и установить признак переноса
         Обл.ВертикальноеПоложение(3);
         Обл.Контроль(4);
         Обл.Полужирный(1);
         
         //Ширина = СтрДлина(ИмяРек) * КоэффициентШрифт;
         //СпШирина.ДобавитьЗначение(Мин(Ширина, МаксШиринаЗаголовок));
      КонецЦикла;
      СчетчикВысотаТаблицы = СчетчикВысотаТаблицы + 1;
   КонецЕсли;
   
   Если СписокИтоги.РазмерСписка()<>0 Тогда
      // Слово ИТОГО разместим или под номером строки или под первой колонкой, если по ней нет итогов
      ИтогВПервойКолонке = 1;
      Ном = "";
      Если ТЗ.КоличествоКолонок()> 0 Тогда
         ИмяРек = ТЗ.ПолучитьПараметрыКолонки(1);
         Если СписокИтоги.Принадлежит(ИмяРек) = 1 Тогда
            ИтогВПервойКолонке = 0;
            
            СпШирина.УстановитьЗначение(1, 9);
            Ном = "Итого:";
         КонецЕсли;
      КонецЕсли;
      
      Таб.ВывестиСекцию("Строка|Общая");
      Выс = Таб.ВысотаТаблицы();
      Обл = Таб.Область("R"+Выс+"C1"); 
      Обл.Полужирный(1);
      // Вывести итоговые колонки
      Для сч = 1 по ТЗ.КоличествоКолонок() Цикл
         ИмяКолонки = ТЗ.ПолучитьПараметрыКолонки(Сч);
         Если СписокИтоги.Принадлежит(ИмяКолонки) = 1 Тогда
            ИмяРек = ТЗ.Итог(ИмяКолонки);
         Иначе
            ИмяРек = "";
         КонецЕсли;
         
         Если ПустаяСтрока(ФорматЧисловыхЗначений) = 0 Тогда
            Если "" <> ИмяРек Тогда
               ИмяРек = СокрЛП(Формат(ИмяРек, ФорматЧисловыхЗначений));
            КонецЕсли;
         ИначеЕсли РазделительРазрядов<>"" Тогда
            Стр = СокрЛП(ИмяРек);
            Длина = СтрДлина(Стр);
            Поз = Найти(Стр, ".");
            Точность = ?(Поз = 0, 0, Длина - Поз);
            
            КоличествоРазделителей = Цел(Длина/3);
            Длина = Длина + КоличествоРазделителей;
            
            ИмяРек = СокрЛП(Формат(ИмяРек, "Ч0"+Длина+"."+Точность+","+РазделительРазрядов));
         КонецЕсли;
         
         Если (Сч = 1)И(ИтогВПервойКолонке = 1) Тогда
            ИмяРек = "ИТОГО: ";
         КонецЕсли;
         
         Таб.ПрисоединитьСекцию("Строка|Столбец");
         
         Обл = Таб.Область("R"+Выс+"C"+(Сч+1)); // ячейка в которую поместили данные
         Обл.ГоризонтальноеПоложение(2); // числа - вправо
         Обл.Полужирный(1);
         // Расчет ширины по содержимому ячейки
         НачШирина = СпШирина.ПолучитьЗначение(Сч+1);
         Ширина = СтрДлина(ИмяРек) * КоэффициентШрифт;
         СпШирина.УстановитьЗначение(Сч+1, Макс(НачШирина,Ширина));
      КонецЦикла;
      СчетчикВысотаТаблицы = СчетчикВысотаТаблицы + 1;
   КонецЕсли;

   // форматируем ширину столбцов таблицы в соответствии с содержимым
   Для сч = 1 по СпШирина.РазмерСписка() Цикл
      Обл = Таб.Область("R1C"+Сч);
      Ширина = Мин(МаксШирина, 1+СпШирина.ПолучитьЗначение(Сч));
      Обл.ШиринаСтолбца(Ширина);
   КонецЦикла;

//[+]progadmin, 26.06.2015, ДОБАВЛЕНО НЕТИПОВОЕ
   Если ВыводНулевойТаблицы = 0 Тогда
      Если (Таб.ВысотаТаблицы() - СчетчикВысотаТаблицы) = 1 Тогда Возврат 1; КонецЕсли;
   КонецЕсли;   
//[+]_progadmin, 26.06.2015, ДОБАВЛЕНО НЕТИПОВОЕ

   Таб.Опции(ВыводСетки,ВыводЗаголовков,2);
   Таб.Показать(Заголовок);
   Таб.ТолькоПросмотр(1);
   
КонецФункции //ПечатьТЗ()
О жизникуда исчез сайт 1cpp#3 10.07.18 3:48
Никуда не исчез.
висит где висел
http://www.1cpp.ru/index.php/Main
AdminДокумент Закрытие регистров для 1С: 7.7 Торговля и Склад#2 10.07.18 3:47
Инвентаризация:
- Где вагон растворимого кофе, который купили 90 дней назад?
- так - растворился...
БУДебиторская/Кредиторская задолженность по срокам долга#18 10.07.18 3:42
(17) очевидно, что в базе где-то должны быть указаны РЕАЛЬНЫЕ условия сделки. к которым относится срок платежа. отсутсвие такого срока в базе при его фактическом использовании менеджерами (где-то в уме, в комментариях, в книжечках записных) - говорит о том. что в компании автоматизация отсутсвует. вся мощь техники используется как печатная машинка..
.
даже в 77 была возможность указать - хоть с каждым клиентом отделдьные даты платежа, хоть на каждую отгрузку каждого клиента разные любые нужные даты платежа. В 8-ке тоже однозначно есть.