Bas Евгения

10
Рейтинг

Евгения Bas
Zhest



  •   Регистрация: 10.11.2011 (5 лет назад)

  •   Был(а) на сайте: вчера в 09:47

Рейтинг 10

Дополнительное соглашение к трудовому договору с выводом надбавок 1

Бухгалтер v8::СПР ЗУП2.5 Россия БУ Зарплата Персонал, кадры Абонемент ($m)

Внешняя печатная форма "Дополнительное соглашение к трудовому договору с выводом надбавок". Надбавки выводятся из документа "Кадровое перемещение организаций".

1 стартмани

13.09.2017    635    1    0    

Справка в Фонд занятости 0

Бухгалтер v8::СПР ЗУП2.5 Россия БУ Зарплата Абонемент ($m)

Данный отчет формирует справку по заработной плате в Фонд Занятости. В шапке отчета выведен логотип, который вы можете заменить на свой и прописать свои реквизиты.

1 стартмани

02.05.2017    1583    5    0    

Приказ об отзыве из отпуска работника 8

Бухгалтер v8 ЗУП2.5 Россия Персонал, кадры Абонемент ($m)

Данная печатная форма открывается из документа "Возврат на работу организаций".

1 стартмани

14.05.2013    4412    55    4    

Печатная форма "Т-1 внешняя" 1

Бухгалтер v8 ЗУП2.5 Россия БУ Персонал, кадры Абонемент ($m)

Доработанная печатная форма "Т-1" - ПриемНаРаботуВОрганизацию

1 стартмани

27.06.2012    6085    34    1    

Комментарии

БУДополнительное соглашение к трудовому договору с выводом надбавок#0 13.09.17 10:39
Внешняя печатная форма "Дополнительное соглашение к трудовому договору с выводом надбавок". Надбавки выводятся из документа "Кадровое перемещение организаций".
DevСклонение ФИО в СКД#12 08.09.17 13:51
(11), Спасибо! Сейчас попробую!
DevСклонение ФИО в СКД#10 08.09.17 13:41
Функция склонения и так уже есть. Вопрос, как ее вызвать в СКД?
DevСклонение ФИО в СКД#5 08.09.17 8:35
В СКД склонять совсем не обязательно. Но как тогда в модуле отчета получить результат ФИО и его просклонять? Текст модуля привожу

Код
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
   
   СтандартнаяОбработка = Ложь; // Отключаем стандартную обработку 
   Настройки = КомпоновщикНастроек.Настройки; // Получаем настройки отчета 
   
   // Изменяем отборы по пользовательским настройкам
   ТаблицаОтборов = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
   Для Каждого ЭлементОтбора Из КомпоновщикНастроек.Настройки.Отбор.Элементы Цикл      
      НайденнаяПользовательскаяНастройка = 
         ТаблицаОтборов.Найти(ЭлементОтбора.ИдентификаторПользовательскойНастройки);      
      Если НайденнаяПользовательскаяНастройка <> Неопределено Тогда
         ЭлементОтбора.ВидСравнения = НайденнаяПользовательскаяНастройка.ВидСравнения;
         ЭлементОтбора.Использование = НайденнаяПользовательскаяНастройка.Использование;
         ЭлементОтбора.ПравоеЗначение = НайденнаяПользовательскаяНастройка.ПравоеЗначение;
      КонецЕсли;      
   КонецЦикла;
      
   ДанныеРасшифровки = Новый ДанныеРасшифровкиКомпоновкиДанных;            
   КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;       
   
   // Создаем макет компоновки данных
   СхемаКомпоновкиДанных = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
   МакетКомпоновки = 
      КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
   
   // Инициализируем процессор компоновки
   ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
   ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, , ДанныеРасшифровки, Истина);
   
   ДокументРезультат.Очистить();
   
   // Получаем дополнительный макет с описанием вывода логотипа
   МакетЛоготип = ПолучитьМакет("Макет"); 
   
   // Получаем область логотипа
   Область = МакетЛоготип.ПолучитьОбласть("Логотип");
   ДокументРезультат.Вывести(Область);
   
   // Выводим результат отчета в табличный документ "ДокументРезультат"
   ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
   ПроцессорВывода.УстановитьДокумент(ДокументРезультат);      
   ПроцессорВывода.Вывести(ПроцессорКомпоновки);
            
КонецПроцедуры
DevСклонение ФИО в СКД#1 07.09.17 13:16
Добрый день! Знаю, что можно использовать стандартные функции общего модуля в СКД. Как правильно можно просклонять ФИО? В СхемеКомпановкиДанных заполнен макет с параметрами.
DevНахождение n-строки табличного документа в модуле 1с#11 01.09.17 14:56
Все получилось! Правда, пришлось перекроить всю печатную форму: разбить макет на области, прописать в модуле и т.д.... Но результат стоил свеч!
DevНахождение n-строки табличного документа в модуле 1с#9 01.09.17 13:37
Спасибо, сейчас попробую!
DevНахождение n-строки табличного документа в модуле 1с#1 01.09.17 13:30
Добрый день! Имеется печатная форма для документа "Кадровое перемещение" для ЗУП 2.5. Если выводится групповой приказ, то данная форма выводится отдельно на каждого сотрудника через горизонтальный разделитель страниц. Необходимо при определенных условиях скрывать 24-ю строку. Для одного сотрудника это решилось путем:
Макет.УдалитьОбласть(Макет.Область("R24"),ТипСмещенияТабличногоДокумента.ПоВертикали);

Но если выводить групповой приказ, то у следующих сотрудников строка "24" будем иметь уже другой номер, а, значит, приведенный выше метод не сработает.
Как можно получить в модуле каждую n-строку?