Абазин Антон

137
Рейтинг

Антон Абазин
anton.fly7



  •   Регистрация: 31.07.2008 (9 лет назад)

  •   Был(а) на сайте: 19.05.2018


Группы

Партнер IS-SP

Профессиональный разработчик

Рейтинг 137

Внешняя печатная форма на СКД для УТ 11 (управляемое приложение) 9

v8 УТ10 Россия УУ Абонемент ($m)

Внешняя печатная форма с использованием СКД для УТ 11.1.1.2

1 стартмани

31.01.2013    8395    123    3    

Отчет по проблемным перемещениям при ордерной схеме отгрузки/получения 8

v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Учет ТМЦ Абонемент ($m)

Отчет показывает, по каким документам Перемещение товаров (при ордерной схеме) не созданы Ордера, либо созданы лишние

1 стартмани

30.01.2012    6694    28    5    

Формирование документов Перемещение товаров 15

v8 Розница Учет ТМЦ Абонемент ($m)

Обработка позволяет оценить остатки, продажи по размерам по нескольким складам и оперативно переместить товар в другой магазин, где он лучше продается

1 стартмани

12.12.2011    9903    115    4    

Запись фото товаров 5

v8 УТ10 Розница Учет ТМЦ Абонемент ($m)

Обработка позволяет оперативно записать изображения для Номенклатуры

1 стартмани

10.11.2011    7646    57    4    

Обработка обслуживания ТСД Zebex 5

v8 УТ10 Розница Учет ТМЦ Абонемент ($m)

Обработка обслуживания ТСД Zebex PDL-20 для подключения к типовым конфигурациям.

1 стартмани

03.11.2011    14146    53    8    

Формирование документа "Перемещение товаров" 4

v8 Розница Розничная и сетевая торговля (FMCG) Россия БУ УУ Учет ТМЦ Абонемент ($m)

Формирование документа Перемещение товаров для 1с8 Розница 1

1 стартмани

22.09.2011    10916    63    5    

ВвестиПериод() для Управляемых форм 8

v8 1cv8.cf Абонемент ($m)

ВвестиПериод() для Управляемых форм как в 1С77

1 стартмани

01.11.2010    7946    78    12    

Рассылка SMS 17

v8 1cv8.cf 1cv7.md Абонемент ($m)

Простейшая конфигурация для рассылки SMS с помощью web-сервиса

1 стартмани

29.08.2010    10722    268    20    

1с77 + УРБД + DropBox 11

v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Удачное решение полуавтоматического обмена УРБД через DropBox

1 стартмани

02.07.2010    16583    42    8    

Простейший обмен Торговля77 -> Бух81 6

v8 БП2.0 1С7:ТиС Россия БУ Розничная торговля Абонемент ($m)

Самый простой обмен двумя видами документов между Торговлей77 и Бухгалтерией81.

1 стартмани

23.12.2009    6481    310    6    

Формирование прихода по товару на основе остатков и документов, которые сделали минусы на 41 счете. 18

БП2.0 Россия БУ Учет ТМЦ Абонемент ($m)

Обработка формирует приходные документы, закрывая отрицательные остатки по проданным товарам.

1 стартмани

26.10.2009    7607    189    22    

Закрытие отрицательных остатков 28

v77::БУ БП2.0 Россия БУ Оптовая торговля Учет ТМЦ Абонемент ($m)

Закрытие отрицательных остатков по 41 счету на основе остатков и документов, которые сделали эти минусы.

1 стартмани

31.07.2009    8438    260    41    

Комментарии

ВКОбработка обслуживания ТСД Zebex#9 05.04.18 9:52
(8) надо смотреть отладчиком.
сейчас у меня нет такого ТСД для тестов
DevПрошу помощи отправить файл через POST#4 31.01.18 15:31
сделал так, приходит ответ что не верная подпись. подозреваю что переменную POST передаю на подпись не ту

Код
   POST = "document=chek.jpg";
   
   Message = Nonce + Аккаунт.Key + "/" + Адрес + POST;
   
   Signature = ВРег(МодульСервер.ЗашифроватьSHA256(Message, Аккаунт.Secret));
   
   Boundary = СтрЗаменить(Строка(Новый УникальныйИдентификатор()), "-", "");
   
   ПотокТело = Новый ПотокВПамяти();
   ЗаписьДанных = Новый ЗаписьДанных(ПотокТело);
   ЗаписьДанных.ЗаписатьСтроку("==" + Boundary);
   ЗаписьДанных.Записать(СоздатьСообщение_Изображение("document", "chek.jpg", ПолучитьИзВременногоХранилища(АдресХран)));
   ЗаписьДанных.ЗаписатьСтроку("==" + Boundary + "==");
   ЗаписьДанных.Закрыть();
   
   ДвоичныеДанныеТело = ПотокТело.ЗакрытьИПолучитьДвоичныеДанные();
   
   HTTPЗапрос = Новый HTTPЗапрос;
   HTTPЗапрос.АдресРесурса = Адрес;
   HTTPЗапрос.Заголовки.Вставить("Accept-Language",    "ru-RU");
   HTTPЗапрос.Заголовки.Вставить("User-Agent",       "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393");
   HTTPЗапрос.Заголовки.Вставить("Accept",          "text/html, application/xhtml+xml, image/jxr, */*");
   HTTPЗапрос.Заголовки.Вставить("Content-Type",       "multipart/form-data; boundary=" + boundary + "");
   HTTPЗапрос.Заголовки.Вставить("Apiauth-Key",       Аккаунт.Key);
   HTTPЗапрос.Заголовки.Вставить("Apiauth-Nonce",       Nonce);
   HTTPЗапрос.Заголовки.Вставить("Apiauth-Signature",    Signature);
   HTTPЗапрос.УстановитьТелоИзДвоичныхДанных(ДвоичныеДанныеТело);
   
   Соединение = Новый HTTPСоединение(Хост, 443,,,, 15, Новый ЗащищенноеСоединениеOpenSSL(Новый СертификатКлиентаWindows(), Новый СертификатыУдостоверяющихЦентровWindows()));
   
   ОтветHTTP = Соединение.ОтправитьДляОбработки(HTTPЗапрос);
   
   Ответ = ОтветHTTP.ПолучитьТелоКакСтроку();


Функция СоздатьСообщение_Изображение(ИмяСообщения, ИмяФайла, ДвоичныеДанные)
   
   Поток = Новый ПотокВПамяти();
   ЗаписьДанных = Новый ЗаписьДанных(Поток);
   
   ЗаписьДанных.ЗаписатьСтроку("Content-Disposition: form-data; name=" + ИмяСообщения + "; filename=" + ИмяФайла);
   ЗаписьДанных.ЗаписатьСтроку("Content-Type: image/jpeg");
   ЗаписьДанных.ЗаписатьСтроку("");

   ЗаписьДанных.Записать(ДвоичныеДанные);
   
   ЗаписьДанных.Закрыть();
   
   Возврат Поток.ЗакрытьИПолучитьДвоичныеДанные();
   
КонецФункции
DevПрошу помощи отправить файл через POST#2 31.01.18 15:12
пробовал так (2 варианта) не работает :(

Код
   POST = "document=chek.jpg";// + Base64Строка(ПолучитьИзВременногоХранилища(АдресХран));
   
   Message = Nonce + Аккаунт.Key + "/" + Адрес + POST;
   
   Signature = ВРег(МодульСервер.ЗашифроватьSHA256(Message, Аккаунт.Secret));
   
   Boundary = "----" + СтрЗаменить(Строка(Новый УникальныйИдентификатор()), "-", "");
   
   ФайлОтправки = ПолучитьИмяВременногоФайла("txt");
   ЗаписьТекста = Новый ЗаписьТекста(ФайлОтправки);
   ЗаписьТекста.ЗаписатьСтроку(Boundary);
   ЗаписьТекста.ЗаписатьСтроку("Content-Disposition: form-data; name=""document""; filename=chek.jpg");
   ЗаписьТекста.ЗаписатьСтроку("Content-Type: image/jpeg");
   ЗаписьТекста.ЗаписатьСтроку("");
   ЗаписьТекста.Записать(Base64Строка(ПолучитьИзВременногоХранилища(АдресХран)));
   ЗаписьТекста.ЗаписатьСтроку("");
   ЗаписьТекста.ЗаписатьСтроку(Boundary);
   ЗаписьТекста.Закрыть();   
   
   HTTPЗапрос = Новый HTTPЗапрос;
   HTTPЗапрос.АдресРесурса = Адрес;
   HTTPЗапрос.Заголовки.Вставить("Accept-Language",    "ru-RU");
   HTTPЗапрос.Заголовки.Вставить("User-Agent",       "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393");
   HTTPЗапрос.Заголовки.Вставить("Accept",          "text/html, application/xhtml+xml, image/jxr, */*");
   HTTPЗапрос.Заголовки.Вставить("Content-Type",       "multipart/form-data; boundary=" + boundary + "");
   HTTPЗапрос.Заголовки.Вставить("Apiauth-Key",       Аккаунт.Key);
   HTTPЗапрос.Заголовки.Вставить("Apiauth-Nonce",       Nonce);
   HTTPЗапрос.Заголовки.Вставить("Apiauth-Signature",    Signature);
   //HTTPЗапрос.УстановитьТелоИзСтроки(POST);
   HTTPЗапрос.УстановитьИмяФайлаТела(ФайлОтправки);
   
   ssl = Новый ЗащищенноеСоединениеOpenSSL(Новый СертификатКлиентаWindows(), Новый СертификатыУдостоверяющихЦентровWindows());
   Соединение = Новый HTTPСоединение(Хост, 443,,,, 15, ssl);
DevПрошу помощи отправить файл через POST#1 31.01.18 15:10
Прошу помочь с отправкой файла (jpg) на сервер через POST запрос за вознаграждение (в рублях на карту)

в описании API такой хелп https://yadi.sk/i/moOyJ18I3Rx6tH

дополнительно POST должен быть зашифрован

простой тест отправляю нормально (аргумент msg)
картинку никак отправить не могу

Код
Адрес = "api/contact_message_post/16235613/";
POST = "msg=text";

Message = Nonce + Аккаунт.Key + "/" + Адрес + POST;
   
Signature = ВРег(ЗашифроватьSHA256(Message, Аккаунт.Secret));
      
HTTPЗапрос = Новый HTTPЗапрос;
HTTPЗапрос.АдресРесурса = Адрес;
HTTPЗапрос.Заголовки.Вставить("Accept-Language", "ru-RU");
HTTPЗапрос.Заголовки.Вставить("User-Agent", "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393");
HTTPЗапрос.Заголовки.Вставить("Accept", "text/html, application/xhtml+xml, image/jxr, */*");
HTTPЗапрос.Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded; charset=UTF-8");

HTTPЗапрос.Заголовки.Вставить("Apiauth-Key", Аккаунт.Key);
HTTPЗапрос.Заголовки.Вставить("Apiauth-Nonce", Nonce);
HTTPЗапрос.Заголовки.Вставить("Apiauth-Signature", Signature);

HTTPЗапрос.УстановитьТелоИзСтроки(POST);

Соединение = Новый HTTPСоединение(Хост, 443,,, Прокси, 11, ssl);

ОтветHTTP = Соединение.ОтправитьДляОбработки(HTTPЗапрос);
AdminСравнение профилей групп доступа в 1С:УТ 11, 1С:ERP 2, 1С:КА 2#1 08.02.17 12:44
Пригодилось )
еще бы добавить перетаскивание недостающей роли из одной таблички в другую ))
DevЗаполнение табличной части документа (8.3 УФ) через ОткрытиеФормы#17 29.07.16 11:37
ВОТ ТАК РАБОТАЕТ!!!! :)

Код
&НаКлиенте
Процедура ФормаДоставкаЗавершение(Результат, ДополнительныеПараметры) Экспорт 
   
   ЗаполнитьЗаказНаСервере(Результат);
   
   КопироватьДанныеФормы(ЗаказКлиентаОбъект, ВладелецФормы.Объект);
   
   ВладелецФормы.Модифицированность = Истина;
   ВладелецФормы.Элементы.СтраницыДоставки.ТекущаяСтраница = ВладелецФормы.Элементы.СтраницаДоставкаПеревозчиком;
   
   ОбновитьОтображениеДанных();
   
КонецПроцедуры
DevЗаполнение табличной части документа (8.3 УФ) через ОткрытиеФормы#16 29.07.16 11:10
(14) dj_serega, не, не обновляет ((

пробовал и так
Код
&НаКлиенте
Процедура ФормаДоставкаЗавершение(Результат, ДополнительныеПараметры) Экспорт 
   
   Форма = ПолучитьФорму("Документ.ЗаказКлиента.ФормаОбъекта", ДополнительныеПараметры);
   
   ЗаполнитьЗаказНаСервере();
   
   КопироватьДанныеФормы(ЗаказКлиентаОбъект, Форма.Объект);
   
   Сообщить(Форма.Объект.Номер);
   Сообщить(Форма.Объект.СпособДоставки);
   Сообщить(Форма.Объект.ПеревозчикПартнер);
   Сообщить(Форма.Объект.ДополнительнаяИнформацияПоДоставке);
   
   Форма.ОбновитьОтображениеДанных();
   
КонецПроцедуры


и так

Код
&НаКлиенте
Процедура ФормаДоставкаЗавершение(Результат, ДополнительныеПараметры) Экспорт 
   
   Форма = ПолучитьФорму("Документ.ЗаказКлиента.ФормаОбъекта", ДополнительныеПараметры);
   
   ЗаполнитьЗаказНаСервере();
   
   КопироватьДанныеФормы(ЗаказКлиентаОбъект, Форма.Объект);
   
   Сообщить(Форма.Объект.Номер);
   Сообщить(Форма.Объект.СпособДоставки);
   Сообщить(Форма.Объект.ПеревозчикПартнер);
   Сообщить(Форма.Объект.ДополнительнаяИнформацияПоДоставке);
   
   ОбновитьОтображениеДанных();
   
КонецПроцедуры

DevЗаполнение табличной части документа (8.3 УФ) через ОткрытиеФормы#15 29.07.16 11:07
(13) при том вот эти сообщения показывают что Форма.Объект изменен, а Форма не перерисовывается

Код
&НаКлиенте
Процедура ФормаДоставкаЗавершение(Результат, ДополнительныеПараметры) Экспорт 
   
   Форма = ПолучитьФорму("Документ.ЗаказКлиента.ФормаОбъекта", ДополнительныеПараметры);
   
   ЗаполнитьЗаказНаСервере();
   
   КопироватьДанныеФормы(ЗаказКлиентаОбъект, Форма.Объект);
   
   Сообщить(Форма.Объект.Номер);
   Сообщить(Форма.Объект.СпособДоставки);
   Сообщить(Форма.Объект.ПеревозчикПартнер);
   Сообщить(Форма.Объект.ДополнительнаяИнформацияПоДоставке);
   
КонецПроцедуры
DevЗаполнение табличной части документа (8.3 УФ) через ОткрытиеФормы#13 29.07.16 10:43
(10) подскажите пож, как после КопироватьДанныеФормы(ЭтотОбъект.ОбъектПриходныйОрдерНаТовары,Форма.Объект); обновить Форма ? у меня она остается в старом виде, до измениня

вот мой код

Код
&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт
   
   Для Каждого ОбъектНазначение из ОбъектыНазначенияМассив Цикл
      
      ПараметрыФормы = Новый Структура("Ключ", ОбъектНазначение);
       Форма = ПолучитьФорму("Документ.ЗаказКлиента.ФормаОбъекта", ПараметрыФормы);
      
      КопироватьДанныеФормы(Форма.Объект, ЭтотОбъект.ЗаказКлиентаОбъект);
      
      ОткрытьФорму("ВнешняяОбработка.ShopLogisticsОтправка.Форма.ФормаДоставка", 
         ПолучитьПарамНаСервере(), 
         ЭтаФорма, 
         Истина,,, 
         Новый ОписаниеОповещения("ФормаДоставкаЗавершение", 
            ЭтаФорма, 
            ПараметрыФормы), 
         РежимОткрытияОкнаФормы.БлокироватьВесьИнтерфейс);
         
      Прервать;
         
   КонецЦикла;
   
КонецПроцедуры

&НаКлиенте
Процедура ФормаДоставкаЗавершение(Результат, ДополнительныеПараметры) Экспорт 
   
   Форма = ПолучитьФорму("Документ.ЗаказКлиента.ФормаОбъекта", ДополнительныеПараметры);
   
   ЗаполнитьЗаказНаСервере();
   
   КопироватьДанныеФормы(ЗаказКлиентаОбъект, Форма.Объект);
   
КонецПроцедуры
ВКОбработка обслуживания ТСД Zebex#7 21.06.16 8:47
(6) документации нет, как и терминала. уже давно