Горшенин Сергей

2768
Рейтинг

Сергей Горшенин
GSoft



  •   Регистрация: 14.03.2007 (10 лет назад)

  •   Был(а) на сайте: 20.09.2017


Группы

Партнер IS-SP

Профессиональный разработчик

Партнеры ТОП-100 продаж

Партнер IS-WP

IE 2013 REV Докладчик

IE 2014 Участник

IE 2015 Участник

IE 2016 Участник

Карта покупателя GOLD

IE 2017 Участник

Рейтинг 2768

GSoft: Мастер Active Directory 4

Администратор Программист v7.7 1cv7.md Платные (руб)

Вам необходимо навести порядок в Active Directory? Требуется загрузка данных пользователей? Используете 1С как средство хранения данных об учетных записях? В этом и многом другом Вам поможет обработка GSoft: Мастер Active Directory

1000 руб.

21.03.2016    4560    12    1    

Поиск контрагентов по списку ИНН, переноса в группу и формирования оборотов 1

Бухгалтер v77::БУ 1cv7.md Абонемент ($m)

Поиск контрагентов по списку ИНН, переноса в группу и формирования оборотов по счетам с субконто "Контрагенты"

1 стартмани

16.08.2014    5536    2    1    

[INFOSTART EVENT REVOLUTION] Секция "Организация командной работы (Системы класса HelpDesk, стандарты ITIL)" 32

Абонемент ($m)

Вот и закончилась конференция. По многочисленым просьбам выкладываем в открытый доступ презентации докладчиков на секции "Организация командной работы (Системы класса HelpDesk, стандарты ITIL)"

13.11.2013    13743    127    16    

Инструментарий: Конвертор табличных документов в графику и pdf 24

v7.7 1cv7.md Платные (руб)

Конвертор - это обработка для конвертирования ваших табличных документов в графические файлы и файлы формата PDF. Конвертор позволяет конвертировать как внешние табличные документы так и документы формируемые информационной базой. Если Ваша работа связана с отсылкой большого количества документов формируемых в информационной базе, то Конвертор для Вас. Поддерживаемые форматы: bmp, png, jpg, pdf Режимы выгрузки: одной страницей, постранично Поддерживаемые форматы внешних файлов: mxl, xls Отличительная особенность - использование как отдельно от конфигурации так и в ее составе. При это интеграция проходит быстро и просто

1000 руб.

09.04.2012    8209    86    29    

Конфигурация: Партнерский (агентский) документооборот 0

Аналитик Бухгалтер Директор v77::ОУ 1cv7.md Недвижимость, риэлторская деятельность Связь, сети и телекоммуникации Гостиничный бизнес Россия БУ УУ Делопроизводство и документооборот Платные (руб)

Конфигурация “Партнерский документооборот ” (Далее конфигурация) предназначена для документарного обеспечения процесса взаимодествия с партнерами, например операторами связи в рамках партнерских или агентских договоров. Она позволяет оптимизировать учётный процесс, как в разрезе услуг оказываемых (предоставляемых) партнерами так и в разрезе договорных отношений и бухгалтерских документов.

9000 руб.

25.10.2011    8694    20    6    

Инструментарий: Универсальная обработка поиска информации в базе данных 16

v7.7 1cv7.md Платные (руб)

Для чего: поиск информации по базе знаний. Данные: справочники, документы Поля: все Обработка ищет в базе заданную информацию в справочниках и документах во всех полях. Универсальна и выполняет поиск на основе реквизитов полученных за счет перебора метаданных текущей конфигурации.

1000 руб.

17.08.2011    6796    0    3    

Help Desk 22

Аналитик Бухгалтер Директор v77::ОУ 1cv7.md Россия Взаимоотношения с клиентами (СRM) Платные (руб)

Help Desk позволит вам вывести техническую поддержку ваших клиентов и пользователей на качественно новый уровень с минимальными затратами. Система предельно проста в настройке и использовании, совместима с ITIL и опробована на практике, может быть внедрена за короткое время.

40000 руб.

18.10.2010    13783    329    38    

С праздником: 22 апреля и 256 день в году - День программиста 7

Россия Бесплатно (free)

День программиста — Официальный праздник программистов, отмечаемый на 256-й день года (255-й с нуля). Число 256 (2 в степени 8) выбрано потому, что это количество чисел, которое можно выразить с помощью одного байта. Так же "256" - это "100" в шестнадцатиричной системе счисления ("0x100"). И так же это максимальная степень числа 2, которая меньше 365. В невисокосные этот праздник попадает на 13 сентября, a в високосные годы — на 12 сентября.

13.09.2010    12742    0    12    

С праздником: 9 сентября - день тестировщика 18

Россия Бесплатно (free)

9 сентября 1945 года ученые Гарвардского университета, тестировавшие вычислительную машину Mark II Aiken Relay Calculator, нашли мотылька, застрявшего между контактами электромеханического реле.

09.09.2010    7453    0    2    

Что общего между 1С и BMW 29

Россия Абонемент ($m)

Взяв два листа бумаги, я начал рисовать. На первом рисунке я изобразил трехзвенную структуру «1С:Предприятие 7.7», где на нижнем уровне находится платформа, которая предоставляет базовые объекты, механизмы работы с ними и средства программирования, на втором — компоненты, расширяющие набор базовых объектов, третий же, в свою очередь, представляет набор конечных решений для автоматизации — конфигураций. Я также добавил к конфигурациям пользовательские данные, что, в свою очередь, привело к появлению информационных баз, т.е., конфигураций, автоматизирующих конкретные экономические задачи в отдельно взятой организации. Подобно первой я нарисовал и вторую схему. На первом уровне — шасси или платформа, например автомобиля третьей серии. Второй относился к типу кузова — купе, кабриолет, седан и т.д. Третий включал в себя «начинку» — мотор, правый или левый руль, тканевый или кожаный салон, акустика и прочее. В довершение был нарисован человечек, которому вместе с машиной мы дали название «Владелец конкретного автомобиля BMW». Чувствуете всю прелесть данной ассоциации?! Платформа «1С» и шасси BMW дают базовые свойства. Компоненты, так же как и кузов, привносят дополнительные свойства — например, план счетов у компоненты «Бухгалтерский учет» или возможность езды с откинутой крышей у кабриолета. Для каждого конкретного заказчика собирают свой, индивидуальный автомобиль, так же, как делают конкретную конфигурацию для автоматизации отдельной области или конкретного предприятия. И только в конце, приобретя готовый продукт, мы начинаем им пользоваться и получать от этого удовольствие.

1 стартмани

27.07.2010    7259    51    36    

Конфигурация: Документооборот и делопроизводство организации 15

v77::ОУ 1cv7.md Россия Взаимоотношения с клиентами (СRM) Делопроизводство и документооборот Учет рабочего времени Платные (руб)

Конфигурация “Документооборот и делопроизводство” (далее конфигурация) является системой электронного документооборота и предназначена для автоматизации процесса делопроизводства и документооборота в организации. Конфигурация является универсальной и легко может быть настроена и адаптирована под специфику конкретного коммерческого предприятия или бюджетного учреждения Конфигурация решает задачи учета документов, автоматизации взаимодействия сотрудников, контроля исполнительской дисциплины и анализа документооборота: - учет входящих, исходящих и внутренних документов; - хранение файлов в составе информационной базы, их коллективное редактирование и контроль версий; - поддержка бумажного делопроизводства и документооборота; - учет и анализ рабочего времени сотрудников; - полнотекстовый поиск любых данных. - учет контрагентов и взаимодействия с ними

2000 руб.

02.03.2010    11817    495    19    

Полезняшка: Архиватор 28

Администратор v7.7 1cv7.md Россия Абонемент ($m)

Обработка для создания архива всех файлов базы данных. Проста в использовании и настройках удобна в работе.

10 стартмани

09.12.2009    10365    450    9    

Программа возврата стоимости операционной системы семейства MS Windows 8

Россия Бесплатно (free)

О чудо, оно свершилось - начали возвращать деньги за предустановленную операционную систему. А так ли все сладко как задумывалось...

06.12.2009    7189    0    13    

Система Автоматизации Управления Недвижимостью и Арендой 9

Аналитик v77::ОУ 1cv7.md Недвижимость, риэлторская деятельность УУ Дебиторская и кредиторская задолженность Платные (руб)

Конфигурация «Система Автоматизации Управления Недвижимостью и Арендой» (далее "САУНА") предназначена для ведения оперативного учета наличия объектов недвижимости, как согласно ведомостям ПИБ в разрезе зданий, так и внутренним ведомостям в разрезе корпусов. Также ведется учет движения объектов недвижимости в разрезе потребителей объектов недвижимости, таких как внутренние подразделения организации и внешние арендаторы. Конфигурация «САУНА» ориентирована на работу в реальном времени. Поэтому все, кто пользуется ею, в любой момент могут получать актуальную информацию практически по всем направлениям, связанным с учетом объектов недвижимости, которыми располагает их организация. Программа построена интуитивно понятно, начать вести учет в ней очень просто. Конфигурация является полностью оригинальной и предназначена для работы на базе платформы “1С: Предприятие 7.7” в небольших и средних предприятиях.

9303 руб.

01.12.2009    10280    311    21    

Обучение: Методическое пособие "Оперативный учет" 105

Программист v77::ОУ 1cv7.md Россия Абонемент ($m)

Методическое пособие по компоненте "Оперативный учет" и примеры конфигураций по методическому пособию

10 стартмани

24.11.2009    8600    1615    31    

Год 2002: Моя первая база))) 3

Программист v7.7 Россия Абонемент ($m)

Простейшая база по фильмам с возможностью прикрепления картинок

1 стартмани

21.11.2009    5572    106    11    

Круглый стол: Рифы и мели эксплуатации ERP-систем 2

Администратор Программист Россия Бесплатно (free)

Если бы кто-то отважился написать художественное произведение, посвященное ERP-системе, оно врят ли бы заканчивалось словами «и жили они долго и счастливо». а все потому что у такого произведениея в принципе не может быть конца, поскольку ERP-система существует и развивается, пока существует и развивается бизнес компании.

1 стартмани

06.10.2009    7542    13    113    

Полезняшка: Отсортированная библиотека иконок в формате PNG 128х128 (более 7500 пиктограм) 132

Администратор Программист Россия Абонемент ($m)

7500 иконок в формате PNG отсортированных по алфавиту. Иконки имеют прозрачный фон, что позволяет накладывать на основу Общий архив 100 Мб Можно скачать как целиком так и по отдельным частям

1 стартмани

03.07.2009    16925    994    52    

Краткая концепция по наступанию на грабли 34

Директор Россия Абонемент ($m)

Практический материал для статьи. Подробности внутри... Посвящается всем нам))

08.06.2009    7310    1674    10    

7 Граблей или история одного IT-директора 58

Программист Директор Россия Бесплатно (free)

Прежде, получая новую должность, первую неделю я тратил на переезд в новый офис, обустройство кабинета и встречи с новыми подчиненными. Я постепенно входил в курс. Но сейчас не было площадки для разбега. В первый же день, придя на работу, я был ИТ-директором.

08.06.2009    20042    0    82    

Обучение: Учимся строить запросы 132

Программист v77::ОУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Маленькая обработка для желающих изучить (если таковые остались)))) программирование запросов в 1С:Предприятие 7.7, а также понять принципы их работы

1 стартмани

21.05.2009    11429    2082    42    

Полезняшка: Библиотека пиктограмм для кнопок v.2 114

Программист Россия Абонемент ($m)

По заявкам выкладываю библиотеку пиктограмм для формы В библиотеке содержатся пиктограмки которые можно использовать для оформления форм и кнопок на форме. Пример использованияможно увидеть тут: - "Аристотель" ("Автоматизация работы ИТ-отдела") http://aristotel.biz (http://infostart.ru/profile/8784/projects/1693/) - Учет домашних финансов http://infostart.ru/projects/2976/ - Конфигурация: Органайзер для всех (простой и функциональный) http://infostart.ru/projects/3745/ Возможно кому пригодится.

1 стартмани

19.05.2009    24138    1503    64    

ИТ-бюджет: диалог с бизнесом 8

Администратор Программист Россия Бесплатно (free)

Бюджет. Википедия говорит, что это, ставшее привычным для нас слово, произошло от старонормандского bougette — "кожаный кошелек". Этимологический русскоязычный словарь Фасмера дает следующее описание: "предварительная смета доходов и расходов". Так чем же все-таки является бюджет – сметой или кожаным кошельком?

15.04.2009    8036    0    8    

Конфигурация "Органайзер для всех (простой и функциональный)" 86

v77::ОУ Россия УУ Производство готовой продукции (работ, услуг) Абонемент ($m)

Первоапрельский подарок - не просто органайзер, а органайзер на регистрах, для многопользовательской работы. Наверно http://infostart.ru/projects/3683 посмотрел, что людям интересно, да и вытащил блок управление делами из http://infostart.ru/projects/1693/ в отдельную конфигурацию. Пиктограммки к менюшкам берем тут: http://infostart.ru/projects/2373/. Пользуйтесь на здоровье.

10 стартмани

31.03.2009    12169    924    38    

Теория:Формирование ИТ-бюджета: элементарный ликбез 5

Директор Россия Бесплатно (free)

Деятельность любой организации направлена на получении прибыли, величину которой необходимо оценить до начала работы. Для этого производится прогнозирование доходов, расходов и денежных средств. Финансовая структура в организации определяет, кто и за какие показатели отвечает на различных уровнях. Но для этого необходим инструмент, с помощью которого можно делегировать ответственность и спросить за достижение целевых показателей. В качестве такого инструмента выступает система бюджетов предприятия (бюджетная структура). Система бюджетов может быть представлена как, сначала, в укрупненном виде, так и, потом, очень подробно, по всем видам дохода и по каждой статье затрат на любой период времени. Поскольку бюджет это плановые показатели, то их необходимо отслеживать по факту и корректировать принимая управленческие решения для того, чтобы эти корректировки были реальны и прибыль была обеспечена при любом развитии событий в будущем. Давайте рассмотрим на что следует обращать внимание при формировании ИТ-бюджета

30.01.2009    6503    0    2    

Полезняшка: быстрое открытие внешних отчетов в базе (v7.7) 8

Администратор Программист v7.7 1cv7.md Россия Абонемент ($m)

Программа предназначена для запуска внешних отчетов и обработок в уже ОТКРЫТЫХ конфигурациях 1С:Предприятия версии 7.7 Для открытия достаточно нажать на Enter (двойной клик левой кнопки мыши) окне проводника. Если открыто несколько конфигураций показано окно выбора конфигурации. Также в контекстном меню проводника появляются команды открытия текущего md - файла во всех четырех режимах 1С:Предприятие 7.7

1 стартмани

26.01.2009    7519    224    11    

Конфигурация: Учет домашних финансов (проста и удобна в использовании, полезна в хозяйстве;-) 168

v77::ОУ Домашние учет и финансы Россия Абонемент ($m)

Программа управления домашней бухгалтерией или личными финансами, сочетающая надежность, простоту и чрезвычайную гибкость при организации движения средств. Имеет простой продуманный интерфейс. Домашние финансы это гораздо больше, чем просто программа для ведения домашней бухгалтерии, это то, что позволит Вам всегда быть в курсе, увидеть слабые места личного или семейного бюджета, организовать оптимальное движение средств, почувствовать уверенность и свободу.

1 стартмани

26.11.2008    18705    7309    231    

Автоматизация: Построение оргструктуры организации в два клика 24

Программист v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Казалось бы что может быть проще.... Но проще если делать это самостоятельно, при помощи visio или на худой конец excel. А как автоматизировать этот процесс имея на руках уже заполненный справочник подразделений? В этом поможет данный отчет формирующий полную структуру подразделений организации при минимуме изменений в конфигурации. Для формирования не требуется разработки системы идентификации уровней! Можно использовать для любой конфигурации 1С 7.7 имеющий справочник подразделений

1 стартмани

28.10.2008    6779    1329    17    

Теория: Методология учета "Блока расходные материалы" конфигурации "Автоматизация работы руководителя ИТ-отдела" 16

v77::ОУ 1cv7.md Информационные технологии, веб-сервисы Россия Учет ТМЦ Бесплатно (free)

Методология учета "Блока учет расходных материалов" конфигурации "Автоматизация работы руководителя ИТ-отдела" http://infostart.ru/profile/8784/projects/1693/

13.08.2008    6353    0    3    

Полезняшка: Библиотека пиктограмм (более 1500 пиктограм) 275

Программист v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Библиотека пиктограмм содержит порядка 1500 пиктограм, как родных 1С так и нет. Пример использованияможно увидеть тут: - "Аристотель" ("Автоматизация работы ИТ-отдела") http://aristotel.biz (http://infostart.ru/profile/8784/projects/1693/) - Учет домашних финансов http://infostart.ru/projects/2976/ Возможно кому пригодится.

1 стартмани

12.08.2008    22999    3446    41    

Автоматизация: Поздравления с ИТ-праздниками. 4 декабря - день информатики 25

v7.7 1cv7.md Россия Бесплатно (free)

Международный День Интернета пытались ввести несколько раз в разные даты, но ни одна из них так и не стала традиционной. В России прижилась дата 30 сентября. А все началось с того, что московская фирма «IT Infoart Stars» разослала фирмам и организациям предложение поддержать свою инициативу, состоящую из двух пунктов: назначить 30 сентября «Днем Интернета», ежегодно его праздновать и провести «перепись населения русскоязычного Интернета». На тот момент количество пользователей достигло 1 млн. человек. 11 сентября 2009 года Президент России Дмитрий Медведев Президент России Дмитрий Медведев подписал указ, подготовленный Министерством связи и массовых коммуникаций Российской Федерации, который устанавливает в России новый официальный праздник - День программиста, который будет отмечаться 13 сентября (в 256-й день года), если год високосный - 12 сентября - сообщает ИТАР-ТАСС, ссылаясь на пресс-службу Кремля. Простенькая обработка поздравляющая айтишников со следующими праздниками 17 мая - Всемирный день электросвязи и информационного общества Последняя пятница июля - День системного администратора 9 сентября - День тестировщика 256 день в году (12 или 13 сентября) и 22 апреля - День программиста и день программиста в России 30 сентября - Всемирный день электросвязи и информационного общества 26 ноября - Всемирный день информации 4 декабря - День информатики Просто открыть в пользовательском режиме любой конфигурации 1С: Предприятие 7.7

25.07.2008    8991    131    12    

Практика: Пример сложения времени 37

Программист v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

Демонстрации алгоритма пересчета времени Маленький пример показывающий каким образом можно складывать время. Для простоты при выводе в строковом виде числа и обозначения не переводятся в строку с учетом склонений. Вдруг кому пригодится

24.07.2008    6212    362    14    

Обучение: Пример сложения времени 10

Программист v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

Демонстрации алгоритма пересчета времени Маленький пример показывающий каким образом можно складывать время. Для простоты при выводе в строковом виде числа и обозначения не переводятся в строку с учетом склонений. пример тут http://infostart.ru/projects/2274/

24.07.2008    6553    0    4    

Инструментарий: Просмотр остатков произвольного регистра ver. double click 205

Администратор Программист v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Коллеги не пожалейте несколько секунд нажав на плюсик, вам мелочь, а мне приятно))))) Также оставляйте замечания, комментарии и пожелания. Обработка предназначена для просмотра остатков произвольного регистра. Особенно полезна при поиске \"непонятных\" движений в конфигурациях. Обработка не претендует на новизну и уникальность. Просто маленькая полезняшка из тех которые удобно иметь при себе. Обработка писалась в свое время для обучения слушателей премудростям программирования в семерке:-), потом потихоньку перерастала в что-то красивое и удобное. При желании можно добавить туда вывод на печать таблицы значений из формы диалога Демонстрацию работы отчета можно увидеть здесь http://infostart.ru/profile/8784/projects/1693/ Ver. double click по просьбе одного хорошего человека добавлена возможность по даблклику открывать объекты в таблице значений.

1 стартмани

20.07.2008    8905    546    29    

Конфигурация: Автоматизация работы ИТ-отдела 492

Администратор Программист Директор v77::ОУ Информационные технологии, веб-сервисы УУ Бюджетирование и финансовое планирование Взаимоотношения с клиентами (СRM) Делопроизводство и документооборот Персонал, кадры Консолидация отчетности Учет ОС и НМА Учет рабочего времени Платные (руб)

Конфигурация предназначенная для автоматизации работы ИТ-отдела. На данный момент реализованы блоки учета бюджетирования, оборудования, кадровый учет, учет расходных материалов и программного обеспечения и т.д. Программный комплекс "Аристотель" предназначен для автоматизации деятельности подразделений информационных технологий, и ориентирован в первую очередь на руководителей ИТ–подразделений малого и среднего бизнеса, но также может использоваться для решения определенных задач и в рамках более крупных организаций. На основе ролей для каждого сотрудника, как ИТ–подразделения так и внешнего бизнес-подразделения организуется полноценное рабочее место со своим уровнем доступа. Програмный комплекс построен на широко распространенной платформе 1С:Предприятие.

3000 руб.

18.02.2008    32404    2029    233    

Обучение: Методическое пособие "Бухгалтерский учет" 50

Администратор Программист Бухгалтер v77::БУ 1С7:Бух Банк БУ Госбюджет НУ УУ Платные (руб)

в продолжение тем с методичками ПавлаЧистова http://infostart.ru/articles/103/index.php?id=103&ref=1437/?ref=8784 http://infostart.ru/articles/115/index.php/?ref=8784 Для тех, кто читал методичку по "ОУ" данная методичка будет понятна, ибо за основу взята та же задача простого количественного учета. Выкладываю методичку из этой же серии по обучению программированию и работе в компоненте "БУ" Методичка в бета-варианте, так как времени на ее окончание совсем нет Буду весьма признателен за комментарии по существу. Пособие в формате PDF Скачать http://infostart.ru/projects/826

1000 руб.

14.03.2007    7246    1    8    

Обучение: Методичка "Программирование в 1С:Бух учет 7.7" + практические задания 495

Программист v77::БУ 1С7:Бух Россия БУ Платные (руб)

Коллеги, не пожалейте несколько секунд, нажав на плюсик, вам мелочь, а мне приятно))))) Также оставляйте замечания, комментарии и пожелания. Разбирается задача простого количественного учета. Методичка из этой же серии по обучению программированию и работе в компоненте "Оперативный учет" http://infostart.ru/public/61437/ Формат файла - PDF.

500 руб.

14.03.2007    21265    3502    80    

Практика: Использование рекурсии при обращении к результатам выполнения запроса 44

Программист v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

Коллеги не пожалейте несколько секунд ,нажав на плюсик, вам мелочь, а мне приятно))))) Также оставляйте замечания, комментарии и пожелания. Подробности тут http://infostart.ru/articles/156/?ref=8784

14.03.2007    7725    191    5    

Обучение: Использование рекурсии при обращении к результатам выполнения запроса 27

Программист v7.7 1cv7.md Россия Бесплатно (free)

Коллеги! Не пожалейте несколько секунд нажав на плюсик, вам мелочь, а мне приятно))))) Также оставляйте замечания, комментарии и пожелания. В продолжение темы от O-Planet Мастер класс «O-Planet»: использование рекурсивных вычислений в 1С - http://infostart.ru/articles/82/?ref=8784 Пару лет назад столкнулся с тем, что в ПУБе в некоторых отчетах количество группировок ограничено 5 уровнями и это при списке из позиций кажется 12. Честно говоря, как-то не вдохновило описывать 12 реальных циклов, решил написать рекурсию. Потом функция переросла в практический пример, который я привожу своим слушателям для демонстрации того, как реализовывать рекурсию при использовании запроса. пример отчета с рекурсией вот тут - http://infostart.ru/projects/827/?ref=8784 в примере также дана обучающая обработка по работе с запросом, очень будет полезна тем кто только начинает знакомится с таким объектом как "запросом"

14.03.2007    7601    0    23    

Комментарии

О жизниС праздником: 22 апреля и 256 день в году - День программиста#12 19.09.17 15:56
надо же))) 6 лет сюда никто не заглядывал)))) а тут бац и оживились))
DevХитрости сохранения табличного документа в Excel для дальнейшей работы с ним#28 10.08.17 11:32
(27) и как после этого с ними в ворде работать?
суммировать, вычитать и т.д.?
копировать потом в xls?)
О жизниГотовые решения: Олег Фогель#34 23.06.17 15:59
(32)
Николай, в том виде как написано, уж простите выглядит не как предложение
О жизниГотовые решения: Олег Фогель#28 23.06.17 12:05
(16)
Цитата
Как бы то ни было интервью это
хотите попробовать?)))

могу дать дружеский комментарий - всю жизнь мы учимся что-то делать))
надеюсь сделаете правильный вывод)))

а вообще меня удивляет позиция некоторых "граждан")

есть хорошая поговорка
не нравится - предлоди
предложил-сделай


не спорю, иногда есть замечания по делу, но иногда встречаются такие инфантильные комменты. На них разве что только поулыбаться можно, так как вступать с их авторами в полемику просто бесполезно.

это 14 выпуск.
"недовольных" комментов набралось, но при этом никто почему то не предложил (сделал) - а давайте сделаем тему со списком хотелок по гостям студии, никто не предложил помощь в поисках контактов, никто не задумался сколько времени/денег уходит на съемку/монтаж/выпуск одной передачи даже в таком не вылизанно-первоканально-медийном формате.
Господа ау. позврослейте))
О жизниГотовые решения: Олег Фогель#15 22.06.17 13:56
(10)
спасибо конечно за одинэсника))) по прошествии 10 лет управленческой работы и ухода от программирования это вдвойне приятно)))
DevХитрости сохранения табличного документа в Excel для дальнейшей работы с ним#26 14.04.17 17:09
(24) уберите выравнивание по правому краю, иначе excel будет такую ячейку воспринимать как число

я несколько изменил процедуру описанную в (13)

теперь это выглядит так

Код
//_____________________________________________________________________________
//Функция открывает таблицу в MS Excel
//Таблица         - печатная форма 1С
//ИмяЛиста         - имя, которое будет присвоено листу книги MS Excel (если не задано, то остается "Sheet1")
//ОтображатьЯрлычки   - показывать/скрыть ярлычки листов в MS Excel
//ОтображатьСетку   - показывать/скрыть линии сетки в MS Excel
//УдалитьСтроки      - позволяет удалить указанное количество верхних строк таблицы
//УдалитьСтроки      - позволяет удалить указанное количество левых столбцов таблицы
Функция глОткрытьТаблицуВExcel(Таблица, ИмяЛиста = "", ОтображатьЯрлычки = 1, ОтображатьСетку = 1, УдалитьСтроки = 0, УдалитьСтолбцы = 0, пИмяФайла="", пКаталог = "", ОткрытьФайл = 1, ВыровнятьЧисла = 0) Экспорт
   Перем Excel, ExcelWB, ExcelSh, ExcelPS, ИмяФайла, Рез, Зн, Зн1;
   
   Если ТипЗначенияСтр(Таблица) <> "Таблица" Тогда 
      Возврат 0; 
   КонецЕсли;    
            
      // Пробежимся по всем ячейкам и поменяем положение по горизонтали для чисел на выравнивание по правому краю
      Для Выс = 1 По Таблица.ВысотаТаблицы() Цикл
         Для Шир = 1 По Таблица.ШиринаТаблицы() Цикл
            Обл = Таблица.Область(Выс,Шир,Выс,Шир);
            
            Если глПроверкаНаличияТолькоЦифр(Обл.Текст) = 1 Тогда
               // цифры только 
               Если Обл.ГоризонтальноеПоложение() <> 2 Тогда
                  Обл.ГоризонтальноеПоложение(2);
               КонецЕсли;                   
            ИначеЕсли ВыровнятьЧисла = 1 Тогда            
               //программно указываем что надо выравнивать числа с запятой и знаками после запятой
               Если глПроверкаНаличияБукв(Обл.Текст) = 1 Тогда
                  //есть буква кириллицы или латиницы
                  Продолжить;
               ИначеЕсли СтрЧислоВхождений(Обл.Текст, ".") > 1 Тогда
                  //дата - так как имеется более одной "."
                  Продолжить;
               КонецЕсли;
               
               Если (СокрЛП(Обл.Текст) = "0") или (Число(Обл.Текст) > 0) или (Число(Обл.Текст) < 0) Тогда
                  //число
                  Если Обл.ГоризонтальноеПоложение() <> 2 Тогда
                     Обл.ГоризонтальноеПоложение(2);
                  КонецЕсли;
               КонецЕсли;
            КонецЕсли;            
         КонецЦикла;
      КонецЦикла;
   
   //// Чтобы параметры печати не путались с другими - даем им имя
   //Таблица.Опции(,,,,"Excel",,,);

   Попытка 
      Excel = СоздатьОбъект("Excel.Application") 
   Исключение 
      Сообщить("Не удалось открыть MS Excel","!"); 
      Возврат 0; 
   КонецПопытки;
   
   Пока 1=1 Цикл
      //Подберем уникальное имя для временного файла
       
      Если ПустоеЗначение(пКаталог) = 1 Тогда
          пКаталог = КаталогВременныхФайлов();
      КонецЕсли;
      
      Если ПустоеЗначение(пИмяФайла) = 1 Тогда
         ИмяФайла = пКаталог + "1c" + СтрЗаменить(ТекущееВремя(), ":", "");    
      Иначе
         ИмяФайла = пКаталог + СокрЛП(пИмяФайла);
      КонецЕсли;
      
      Если (ФС.СуществуетФайл(ИмяФайла+".tmp") = 1) или (ФС.СуществуетФайл(ИмяФайла+".xls") = 1) Тогда 
         ФС.УдалитьФайл(ИмяФайла+".tmp"); 
         ФС.УдалитьФайл(ИмяФайла+".xls") 
      Иначе 
         Прервать; 
      КонецЕсли
   КонецЦикла;
   
   Таблица.Записать(ИмяФайла+".tmp", "XLS");
   
   Если ФС.СуществуетФайл(ИмяФайла+".tmp") = 0 Тогда 
      Сообщить("Ошибка записи файла """ + ИмяФайла + "tmp""","!"); 
      Excel = ""; 
      Возврат 0; 
   КонецЕсли;    
   
   Рез = 1;
   
   Попытка
      ExcelWB = Excel.Workbooks.Add(ИмяФайла+".tmp");   //Откроем временный файл в Excel в режиме шаблона (чтобы не блокировать файл)
      Попытка                                 //Если на клиентской машине не установлен принтер, обращение к настройкам страницы вызывает ошибку. Поэтому работаем в "Попытка ... КонецПопытки"
         ExcelPS = ExcelWB.Sheets(1).PageSetup;      //Исправим спецсимволы в колонтитулах
         Зн = ExcelPS.LeftHeader;   Зн1 = СтрЗаменить(СтрЗаменить(СтрЗаменить(СтрЗаменить(Зн, "#P", "&P"), "#Q", "&N"), "#T", "&T"), "#D", "&D"); Если Зн <> Зн1 Тогда ExcelPS.LeftHeader   = Зн1 КонецЕсли;
         Зн = ExcelPS.CenterHeader;   Зн1 = СтрЗаменить(СтрЗаменить(СтрЗаменить(СтрЗаменить(Зн, "#P", "&P"), "#Q", "&N"), "#T", "&T"), "#D", "&D"); Если Зн <> Зн1 Тогда ExcelPS.CenterHeader   = Зн1 КонецЕсли;
         Зн = ExcelPS.RightHeader;   Зн1 = СтрЗаменить(СтрЗаменить(СтрЗаменить(СтрЗаменить(Зн, "#P", "&P"), "#Q", "&N"), "#T", "&T"), "#D", "&D"); Если Зн <> Зн1 Тогда ExcelPS.RightHeader   = Зн1 КонецЕсли;
         Зн = ExcelPS.LeftFooter;   Зн1 = СтрЗаменить(СтрЗаменить(СтрЗаменить(СтрЗаменить(Зн, "#P", "&P"), "#Q", "&N"), "#T", "&T"), "#D", "&D"); Если Зн <> Зн1 Тогда ExcelPS.LeftFooter   = Зн1 КонецЕсли;
         Зн = ExcelPS.CenterFooter;   Зн1 = СтрЗаменить(СтрЗаменить(СтрЗаменить(СтрЗаменить(Зн, "#P", "&P"), "#Q", "&N"), "#T", "&T"), "#D", "&D"); Если Зн <> Зн1 Тогда ExcelPS.CenterFooter   = Зн1 КонецЕсли;
         Зн = ExcelPS.RightFooter;   Зн1 = СтрЗаменить(СтрЗаменить(СтрЗаменить(СтрЗаменить(Зн, "#P", "&P"), "#Q", "&N"), "#T", "&T"), "#D", "&D"); Если Зн <> Зн1 Тогда ExcelPS.RightFooter   = Зн1 КонецЕсли;
      Исключение 
      КонецПопытки;
      
      ExcelWB.SaveAs(ИмяФайла+".xls", -4143);         //Сохраним, чтобы обновить формат файла до текущего (xlNormal = -4143)
      ExcelWB.Close(0);                        //Закроем книгу ...
      ExcelWB = Excel.Workbooks.Add(ИмяФайла+".xls");   //... и вновь откроем в режиме шаблона

      Попытка
         ExcelSh = ExcelWB.Sheets(1);
         
         Если ПустаяСтрока(ИмяЛиста) = 0 Тогда         //Зададим имя ярлычка
            ExcelSh.Name = ИмяЛиста
         КонецЕсли;
         
         Если ОтображатьЯрлычки = 1 Тогда            //Сделаем видимыми ярлычки листов
            ExcelWB.Windows(1).DisplayWorkbookTabs = 1;
            ExcelWB.Windows(1).TabRatio = 0.6         //... и отодвинем горизонтальную полосу прокрутки от левого края
         КонецЕсли;
         
         Если ОтображатьСетку = 0 Тогда               //Скроем линии сетки
            ExcelWB.Windows(1).DisplayGridlines = 0
         КонецЕсли;
         
         Если УдалитьСтроки > 0 Тогда               //Удалим верхние строки
            ExcelSh.Range(ExcelSh.Rows(1), ExcelSh.Rows(УдалитьСтроки)).Delete()
         КонецЕсли;
         
         Если УдалитьСтолбцы > 0 Тогда               //Удалим левые столбцы
            ExcelSh.Range(ExcelSh.Columns(1), ExcelSh.Columns(УдалитьСтолбцы)).Delete()
         КонецЕсли;
      Исключение 
      КонецПопытки;
      
      ExcelWB.Saved = 0;
   Исключение
      Сообщить("Ошибка открытия файла в MS Excel","!"); 
      Рез = 0
   КонецПопытки;
   
   Если ОткрытьФайл = 1 Тогда
      Попытка 
         Excel.Visible = 1; 
      Исключение 
      КонецПопытки;  
   Иначе                 
      Excel.Visible = 0; 
      
         ФС.УдалитьФайл(ИмяФайла + ".xls");
      ExcelWB.SaveAs(ИмяФайла+".xls", -4143);         //Сохраним, чтобы обновить формат файла до текущего (xlNormal = -4143)
      ExcelWB.Close(0);                        //Закроем книгу ...
   КонецЕсли;                      
   
   //описание метода сохранить
   //Sub SaveAs([Filename], [FileFormat], [Password], [WriteResPassword], [ReadOnlyRecommended], [CreateBackup], [AccessMode As XlSaveAsAccessMode = xlNoChange], [ConflictResolution], [AddToMru], [TextCodepage], [TextVisualLayout], [Local])
    //Member of Excel.Workbook

   ExcelWB = ""; ExcelSh = ""; ExcelPS = ""; Excel = "";
   ФС.УдалитьФайл(ИмяФайла + ".tmp");
   
   Если ОткрытьФайл = 1 Тогда
      ФС.УдалитьФайл(ИмяФайла + ".xls");
   ИначеЕсли ОткрытьФайл = 2 Тогда                                         
      //не надо открывать каталог
      Сообщить("Файл сохранен по адресу: " + СокрЛП(ИмяФайла) + ".xls");  
   Иначе
      Сообщить("Файл сохранен по адресу: " + СокрЛП(ИмяФайла) + ".xls");  
      ЗапуститьПриложение(пКаталог);
   КонецЕсли;
   
   Возврат Рез
КонецФункции //глОткрытьТаблицуВExcel



плюс две доп функции проверяющие есть ли буквы/цифры в ячейке
Код
//_____________________________________________________________________________
// глПроверкаНаличияТолькоЦифр(Стр)
//
// Параметры: 
//  Стр - текстовая строка
//
// Возвращаемое значение:
//  1 - если в строке только цифры, иначе 0
Функция глПроверкаНаличияТолькоЦифр(Знач Стр) Экспорт
   ТолькоЦифры = 1;  
   Цифры = "1234567890";
   
   Для Сч = 1 По СтрДлина(Стр) Цикл
      Символ = Сред(Стр, Сч, 1);
      
      Если Найти(Цифры, Символ) = 0 Тогда
          ТолькоЦифры = 0;
         Прервать;
      КонецЕсли;
   КонецЦикла;
   
   Возврат ТолькоЦифры;
КонецФункции // глПроверкаНаличияТолькоЦифр()


//_____________________________________________________________________________
// глПроверкаНаличияБукв(Стр)
//
// Параметры: 
//  Стр - текстовая строка
//
// Возвращаемое значение:
//  1 - если в строке есть буквы, иначе 0
Функция глПроверкаНаличияБукв(Знач Стр) Экспорт
   ЕстьБуквы = 0;
   БуквыКирилица = "АБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯ";
   БуквыЛатиница = "ABСDEFGHIJKLMNOPQRSTUVWXYZ";
   
   Для Сч = 1 По СтрДлина(Стр) Цикл
      Символ = Сред(Стр, Сч, 1);
      
      Если Найти(БуквыКирилица, Символ) > 0 Тогда
          ЕстьБуквы = 1;
         Прервать;
      ИначеЕсли Найти(БуквыЛатиница, Символ) > 0 Тогда
          ЕстьБуквы = 1;
         Прервать;
      КонецЕсли;
   КонецЦикла;
   
   Возврат ЕстьБуквы;
КонецФункции // глПроверкаНаличияБукв()

DevHELP: Ищу красивое решение по формированию запроса#6 06.12.16 19:52
(2) так не прокатит из-за синтаксиса

Код
Условие (Количество  <<?>> Резерв <> 0);
Запрос[13] : Ожидается ')' перед 'Резерв'


(4) когда в семерке есть и работает)) но не всегда понятно))

(3)
Код
|Функция Остаток = Сумма(Запрос.фКоличество - Запрос.фРезерв) КОГДА (Запрос.фКоличество <> Запрос.фРезерв);


так тоже не вариант не все будет счиать, даже ради интереса попробовал))
поучилось что по позициям где есть бронь "задваивает" остатки (на остатках - 3 шт, в брони - 1 шт, на выходе дает 5)))

даже не могу понять почему так

вариант
Код
|Функция Остаток = Сумма(Запрос.фКоличество - Запрос.фРезерв) КОГДА ((Запрос.фКоличество - Запрос.фРезерв) > 0);


даже тот же "эффект"



вдогонку - до этого попробовал такой вариант

Код
|Функция Остаток      = Сумма(Запрос.фКоличество - Запрос.фРезерв) КОГДА ((Количество - Резерв) > 0);
//|Условие ((Количество > 0) или (Резерв > 0));


в остатке не учитывается резерв

Частично можно решить путем
Код
|Функция Ошибка            = Сумма(ПроверкаШтрихкода(Штрихкод)) КОГДА ((Количество - Резерв) > 0); 


при этом по "нулевым" позиция (остаток-бронь = 0) проверка правильности штрихкода считаться не будет
однако это никак не решает проблему с наличия "нулевых" строк в результирующей таблице
DevHELP: Ищу красивое решение по формированию запроса#1 05.12.16 15:30
Есть два регистра: ОстаткиНоменклатуры и ЗаказыПокупателей в каждом из которых есть реквизит Количество

Суть задачи достаточно простая - получить запросом текущий остаток с учетом резерва.

соответственно задача решается следующим куском кода


Код
            ТекстЗапроса = 
         "//{{ЗАПРОС(Сформировать)
         //|с ДатаНач по ДатаКон;
         |Количество               = Регистр.ОстаткиНоменклатуры.Количество;  
         |";
         
         Если ТабНастрОстДоговоры.ОстБезРезерва = 0 Тогда
            //считаем только остатки на складе
            ТекстЗапроса = ТекстЗапроса + "   
            |Номенклатура         = Регистр.ОстаткиНоменклатуры.Номенклатура;
            |ШтрихКод            = Регистр.ОстаткиНоменклатуры.ПозицияНоменклатуры.ШтрихКод;
            |Артикул            = Регистр.ОстаткиНоменклатуры.Номенклатура.Артикул;  
            |Склад               = Регистр.ОстаткиНоменклатуры.МестоХранения;
            |Статус               = Регистр.ОстаткиНоменклатуры.Номенклатура.Статус;
            |Функция Остаток      = КонОст(Количество); 
            |Условие (Количество > 0);
            |";
         Иначе
            //при подсчете остатков считаем сколько забронировано
            ТекстЗапроса = ТекстЗапроса + "
            |Номенклатура         = Регистр.ОстаткиНоменклатуры.Номенклатура, Регистр.ЗаказыПокупателей.Номенклатура;
            |ШтрихКод            = Регистр.ОстаткиНоменклатуры.ПозицияНоменклатуры.ШтрихКод, Регистр.ЗаказыПокупателей.ПозицияНоменклатуры.ШтрихКод;
            |Артикул            = Регистр.ОстаткиНоменклатуры.Номенклатура.Артикул, Регистр.ЗаказыПокупателей.Номенклатура.Артикул;
            |Склад               = Регистр.ОстаткиНоменклатуры.МестоХранения, Регистр.ЗаказыПокупателей.МестоХранения;
            |Статус               = Регистр.ОстаткиНоменклатуры.Номенклатура.Статус,  Регистр.ЗаказыПокупателей.Номенклатура.Статус;
            |Резерв               = Регистр.ЗаказыПокупателей.Количество;   
            |Функция фКоличество   = КонОст(Количество); 
            |Функция фРезерв      = КонОст(Резерв); 
            |Функция Остаток      = Сумма(Запрос.фКоличество - Запрос.фРезерв);
               |Условие ((Количество > 0) или (Резерв > 0));
            |";
         КонецЕсли;
         
         ТекстЗапроса = ТекстЗапроса + "   
         |Функция Ошибка            = Сумма(ПроверкаШтрихкода(Штрихкод)); 
         |Группировка Артикул;
         |Группировка Номенклатура упорядочить по Номенклатура.Артикул без групп;
         |Группировка ШтрихКод;
         |Условие(Статус в сзЗапроса);
         |"//}}ЗАПРОС
         ;           


Все бы ничего, однако в тоже время в запросе введена допфункция Ошибка которая проверяет правильность формирования запроса и на выходе выдает значение для номера иконки в ТЗ.

И вот в этом то как раз загвоздка - когда имеем кол-во из остатков и кол-во из брони то итоговый остаток считается однако значение функции ошибка суммируется применительно к значению каждого регистра. Например - "правильное значение иконки" - 8, а результат по функции может быть - 24. Это для комбинации 3 шт в остатках и 2 штуки в брони.


К тому же вариант
Код
            |Функция фКоличество   = КонОст(Количество); 
            |Функция фРезерв      = КонОст(Резерв); 
            |Функция Остаток      = Сумма(Запрос.фКоличество - Запрос.фРезерв);

приводит к тому что на выходе в результате работы запроса выводятся строки с "нулевым остатком", т.е. по которым текущий остаток = забронированному количеству.

Не могу найти красивого решения чтобы обойти этот косяк сразу в тексте запроса.


Единственное что приходит в голову это переписать конфу так чтобы изначально "сменить знак с + на -" в реквизите Количество регистра ЗаказыПокупателей . То есть когда мы туда заносим бронь - количество пишется с -, а не с + как сейчас. Правда это геморно. Зато позволит написать конструкцию
Код
|Количество = Регистр.ОстаткиНоменклатуры.Количество, Регистр.ЗаказыПокупателей.Количество;


и использовать сразу одну функцию для остатка, что позволит в том числе уйти от строк с "нулевыми остатками".


Может кто подскажет более красивое решение, а?
повторюсь - хочу сделать все внутри запроса, перебор в ТЗ не предлагать.
НовостиНаградной лист: кому и за что были вручены призы на Infostart Event 2016#303 14.11.16 17:56
(281) a.babenko,
2all

Ребят вы поймите что предмодерация докладчика это непосредственно просмотр его выступления вживую. А это достаточно затратно)))

на самом деле это проблематика всех конференций - всегда очень тяжело оценить кто и как будет выступать

может быть хорошая преза - но никаких навыков публичных выступлений, а может быть наоборот - 2-3 слайда и харизматичное выступление которое можно слушать часами
О жизниГотовые решения: Михаил Харитонов#2 02.06.16 18:15
Смотрите, слушайте и скачивайте интервью с Михаилом Харитоновым на:
youtube
PodFM.ru и Itunes

Хотите быть в курсе свежих выпусков передачи подписывайтесь на каналы
PodFM.ru.
Для этого откройте rss-ленту и нажмите кнопку "Подписаться"

iTunes