Горшенин Сергей

2802
Рейтинг

Сергей Горшенин
GSoft



  •   Регистрация: 14.03.2007 (11 лет назад)

  •   Был(а) на сайте: 09.07.2018


Группы

Партнер IS-SP

Профессиональный разработчик

Партнеры ТОП-100 продаж

Партнер IS-WP

IE 2013 REV Докладчик

IE 2014 Участник

IE 2015 Участник

IE 2016 Участник

Карта покупателя GOLD

IE 2017 Участник

Рейтинг 2802

Поиск контрагентов по списку ИНН, переноса в группу и формирования оборотов 1

v77::БУ 1С7:Бух Абонемент ($m)

Поиск контрагентов по списку ИНН, переноса в группу и формирования оборотов по счетам с субконто "Контрагенты"

10 стартмани

16.08.2014    8182    2    1    

[INFOSTART EVENT REVOLUTION] Секция "Организация командной работы (Системы класса HelpDesk, стандарты ITIL)" 32

Абонемент ($m)

Вот и закончилась конференция. По многочисленым просьбам выкладываем в открытый доступ презентации докладчиков на секции "Организация командной работы (Системы класса HelpDesk, стандарты ITIL)"

13.11.2013    17768    171    16    

С праздником: 22 апреля и 256 день в году - День программиста 7

Россия Бесплатно (free)

День программиста — Официальный праздник программистов, отмечаемый на 256-й день года (255-й с нуля). Число 256 (2 в степени 8) выбрано потому, что это количество чисел, которое можно выразить с помощью одного байта. Так же "256" - это "100" в шестнадцатиричной системе счисления ("0x100"). И так же это максимальная степень числа 2, которая меньше 365. В невисокосные этот праздник попадает на 13 сентября, a в високосные годы — на 12 сентября.

13.09.2010    17831    12    

С праздником: 9 сентября - день тестировщика 18

Россия Бесплатно (free)

9 сентября 1945 года ученые Гарвардского университета, тестировавшие вычислительную машину Mark II Aiken Relay Calculator, нашли мотылька, застрявшего между контактами электромеханического реле.

09.09.2010    10566    2    

Что общего между 1С и BMW 29

Россия Абонемент ($m)

Взяв два листа бумаги, я начал рисовать. На первом рисунке я изобразил трехзвенную структуру «1С:Предприятие 7.7», где на нижнем уровне находится платформа, которая предоставляет базовые объекты, механизмы работы с ними и средства программирования, на втором — компоненты, расширяющие набор базовых объектов, третий же, в свою очередь, представляет набор конечных решений для автоматизации — конфигураций. Я также добавил к конфигурациям пользовательские данные, что, в свою очередь, привело к появлению информационных баз, т.е., конфигураций, автоматизирующих конкретные экономические задачи в отдельно взятой организации. Подобно первой я нарисовал и вторую схему. На первом уровне — шасси или платформа, например автомобиля третьей серии. Второй относился к типу кузова — купе, кабриолет, седан и т.д. Третий включал в себя «начинку» — мотор, правый или левый руль, тканевый или кожаный салон, акустика и прочее. В довершение был нарисован человечек, которому вместе с машиной мы дали название «Владелец конкретного автомобиля BMW». Чувствуете всю прелесть данной ассоциации?! Платформа «1С» и шасси BMW дают базовые свойства. Компоненты, так же как и кузов, привносят дополнительные свойства — например, план счетов у компоненты «Бухгалтерский учет» или возможность езды с откинутой крышей у кабриолета. Для каждого конкретного заказчика собирают свой, индивидуальный автомобиль, так же, как делают конкретную конфигурацию для автоматизации отдельной области или конкретного предприятия. И только в конце, приобретя готовый продукт, мы начинаем им пользоваться и получать от этого удовольствие.

1 стартмани

27.07.2010    10167    51    36    

Полезняшка: Архиватор 28

v7.7 1cv7.md Россия Абонемент ($m)

Обработка для создания архива всех файлов базы данных. Проста в использовании и настройках удобна в работе.

10 стартмани

09.12.2009    13612    451    9    

Программа возврата стоимости операционной системы семейства MS Windows 8

Россия Бесплатно (free)

О чудо, оно свершилось - начали возвращать деньги за предустановленную операционную систему. А так ли все сладко как задумывалось...

06.12.2009    11315    13    

Обучение: Методическое пособие "Оперативный учет" 105

v77::ОУ 1cv7.md Россия Абонемент ($m)

Методическое пособие по компоненте "Оперативный учет" и примеры конфигураций по методическому пособию

10 стартмани

24.11.2009    12574    1615    31    

Год 2002: Моя первая база))) 3

v7.7 Россия Абонемент ($m)

Простейшая база по фильмам с возможностью прикрепления картинок

1 стартмани

21.11.2009    8435    106    11    

Круглый стол: Рифы и мели эксплуатации ERP-систем 2

Россия Бесплатно (free)

Если бы кто-то отважился написать художественное произведение, посвященное ERP-системе, оно врят ли бы заканчивалось словами «и жили они долго и счастливо». а все потому что у такого произведениея в принципе не может быть конца, поскольку ERP-система существует и развивается, пока существует и развивается бизнес компании.

1 стартмани

06.10.2009    11989    13    113    

Полезняшка: Отсортированная библиотека иконок в формате PNG 128х128 (более 7500 пиктограм) 132

Россия Абонемент ($m)

7500 иконок в формате PNG отсортированных по алфавиту. Иконки имеют прозрачный фон, что позволяет накладывать на основу Общий архив 100 Мб Можно скачать как целиком так и по отдельным частям

1 стартмани

03.07.2009    22445    994    52    

Краткая концепция по наступанию на грабли 33

Россия Абонемент ($m)

Практический материал для статьи. Подробности внутри... Посвящается всем нам))

08.06.2009    10967    1688    10    

7 Граблей или история одного IT-директора 59

Россия Бесплатно (free)

Прежде, получая новую должность, первую неделю я тратил на переезд в новый офис, обустройство кабинета и встречи с новыми подчиненными. Я постепенно входил в курс. Но сейчас не было площадки для разбега. В первый же день, придя на работу, я был ИТ-директором.

08.06.2009    26422    82    

Обучение: Учимся строить запросы 132

v77::ОУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Маленькая обработка для желающих изучить (если таковые остались)))) программирование запросов в 1С:Предприятие 7.7, а также понять принципы их работы

10 стартмани

21.05.2009    15316    2082    42    

Полезняшка: Библиотека пиктограмм для кнопок v.2 114

Россия Абонемент ($m)

По заявкам выкладываю библиотеку пиктограмм для формы В библиотеке содержатся пиктограмки которые можно использовать для оформления форм и кнопок на форме. Пример использованияможно увидеть тут: - "Аристотель" ("Автоматизация работы ИТ-отдела") http://aristotel.biz (http://infostart.ru/profile/8784/projects/1693/) - Учет домашних финансов http://infostart.ru/projects/2976/ - Конфигурация: Органайзер для всех (простой и функциональный) http://infostart.ru/projects/3745/ Возможно кому пригодится.

10 стартмани

19.05.2009    30181    1506    64    

ИТ-бюджет: диалог с бизнесом 9

Россия Бесплатно (free)

Бюджет. Википедия говорит, что это, ставшее привычным для нас слово, произошло от старонормандского bougette — "кожаный кошелек". Этимологический русскоязычный словарь Фасмера дает следующее описание: "предварительная смета доходов и расходов". Так чем же все-таки является бюджет – сметой или кожаным кошельком?

15.04.2009    11232    8    

Теория:Формирование ИТ-бюджета: элементарный ликбез 5

Россия Бесплатно (free)

Деятельность любой организации направлена на получении прибыли, величину которой необходимо оценить до начала работы. Для этого производится прогнозирование доходов, расходов и денежных средств. Финансовая структура в организации определяет, кто и за какие показатели отвечает на различных уровнях. Но для этого необходим инструмент, с помощью которого можно делегировать ответственность и спросить за достижение целевых показателей. В качестве такого инструмента выступает система бюджетов предприятия (бюджетная структура). Система бюджетов может быть представлена как, сначала, в укрупненном виде, так и, потом, очень подробно, по всем видам дохода и по каждой статье затрат на любой период времени. Поскольку бюджет это плановые показатели, то их необходимо отслеживать по факту и корректировать принимая управленческие решения для того, чтобы эти корректировки были реальны и прибыль была обеспечена при любом развитии событий в будущем. Давайте рассмотрим на что следует обращать внимание при формировании ИТ-бюджета

30.01.2009    9181    2    

Полезняшка: быстрое открытие внешних отчетов в базе (v7.7) 8

v7.7 1cv7.md Россия Абонемент ($m)

Программа предназначена для запуска внешних отчетов и обработок в уже ОТКРЫТЫХ конфигурациях 1С:Предприятия версии 7.7 Для открытия достаточно нажать на Enter (двойной клик левой кнопки мыши) окне проводника. Если открыто несколько конфигураций показано окно выбора конфигурации. Также в контекстном меню проводника появляются команды открытия текущего md - файла во всех четырех режимах 1С:Предприятие 7.7

1 стартмани

26.01.2009    10335    224    11    

Автоматизация: Построение оргструктуры организации в два клика 24

v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Казалось бы что может быть проще.... Но проще если делать это самостоятельно, при помощи visio или на худой конец excel. А как автоматизировать этот процесс имея на руках уже заполненный справочник подразделений? В этом поможет данный отчет формирующий полную структуру подразделений организации при минимуме изменений в конфигурации. Для формирования не требуется разработки системы идентификации уровней! Можно использовать для любой конфигурации 1С 7.7 имеющий справочник подразделений

1 стартмани

28.10.2008    10000    1329    17    

Теория: Методология учета "Блока расходные материалы" конфигурации "Автоматизация работы руководителя ИТ-отдела" 16

v77::ОУ 1cv7.md ИТ-компания Россия Учет ТМЦ Бесплатно (free)

Методология учета "Блока учет расходных материалов" конфигурации "Автоматизация работы руководителя ИТ-отдела" http://infostart.ru/profile/8784/projects/1693/

13.08.2008    9316    3    

Полезняшка: Библиотека пиктограмм (более 1500 пиктограмм) 275

v7.7 1cv7.md Россия Абонемент ($m)

Библиотека пиктограмм содержит порядка 1500 пиктограм, как родных 1С так и нет. Пример использованияможно увидеть тут: - "Аристотель" ("Автоматизация работы ИТ-отдела") http://aristotel.biz (http://infostart.ru/profile/8784/projects/1693/) - Учет домашних финансов http://infostart.ru/projects/2976/ Возможно кому пригодится.

10 стартмани

12.08.2008    28218    3449    41    

Автоматизация: Поздравления с ИТ-праздниками. 4 декабря - день информатики 26

v7.7 1cv7.md Россия Бесплатно (free)

Международный День Интернета пытались ввести несколько раз в разные даты, но ни одна из них так и не стала традиционной. В России прижилась дата 30 сентября. А все началось с того, что московская фирма «IT Infoart Stars» разослала фирмам и организациям предложение поддержать свою инициативу, состоящую из двух пунктов: назначить 30 сентября «Днем Интернета», ежегодно его праздновать и провести «перепись населения русскоязычного Интернета». На тот момент количество пользователей достигло 1 млн. человек. 11 сентября 2009 года Президент России Дмитрий Медведев Президент России Дмитрий Медведев подписал указ, подготовленный Министерством связи и массовых коммуникаций Российской Федерации, который устанавливает в России новый официальный праздник - День программиста, который будет отмечаться 13 сентября (в 256-й день года), если год високосный - 12 сентября - сообщает ИТАР-ТАСС, ссылаясь на пресс-службу Кремля. Простенькая обработка поздравляющая айтишников со следующими праздниками 17 мая - Всемирный день электросвязи и информационного общества Последняя пятница июля - День системного администратора 9 сентября - День тестировщика 256 день в году (12 или 13 сентября) и 22 апреля - День программиста и день программиста в России 30 сентября - Всемирный день электросвязи и информационного общества 26 ноября - Всемирный день информации 4 декабря - День информатики Просто открыть в пользовательском режиме любой конфигурации 1С: Предприятие 7.7

25.07.2008    12732    131    12    

Практика: Пример сложения времени 37

v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

Демонстрации алгоритма пересчета времени Маленький пример показывающий каким образом можно складывать время. Для простоты при выводе в строковом виде числа и обозначения не переводятся в строку с учетом склонений. Вдруг кому пригодится

24.07.2008    9737    365    14    

Обучение: Пример сложения времени 10

v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

Демонстрации алгоритма пересчета времени Маленький пример показывающий каким образом можно складывать время. Для простоты при выводе в строковом виде числа и обозначения не переводятся в строку с учетом склонений. пример тут http://infostart.ru/projects/2274/

24.07.2008    9448    4    

Инструментарий: Просмотр остатков произвольного регистра ver. double click 205

v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Коллеги не пожалейте несколько секунд нажав на плюсик, вам мелочь, а мне приятно))))) Также оставляйте замечания, комментарии и пожелания. Обработка предназначена для просмотра остатков произвольного регистра. Особенно полезна при поиске \"непонятных\" движений в конфигурациях. Обработка не претендует на новизну и уникальность. Просто маленькая полезняшка из тех которые удобно иметь при себе. Обработка писалась в свое время для обучения слушателей премудростям программирования в семерке:-), потом потихоньку перерастала в что-то красивое и удобное. При желании можно добавить туда вывод на печать таблицы значений из формы диалога Демонстрацию работы отчета можно увидеть здесь http://infostart.ru/profile/8784/projects/1693/ Ver. double click по просьбе одного хорошего человека добавлена возможность по даблклику открывать объекты в таблице значений.

10 стартмани

20.07.2008    12631    546    29    

Практика: Использование рекурсии при обращении к результатам выполнения запроса 44

v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

Коллеги не пожалейте несколько секунд ,нажав на плюсик, вам мелочь, а мне приятно))))) Также оставляйте замечания, комментарии и пожелания. Подробности тут http://infostart.ru/articles/156/?ref=8784

14.03.2007    11118    192    5    

Обучение: Использование рекурсии при обращении к результатам выполнения запроса 27

v7.7 1cv7.md Россия Бесплатно (free)

Коллеги! Не пожалейте несколько секунд нажав на плюсик, вам мелочь, а мне приятно))))) Также оставляйте замечания, комментарии и пожелания. В продолжение темы от O-Planet Мастер класс «O-Planet»: использование рекурсивных вычислений в 1С - http://infostart.ru/articles/82/?ref=8784 Пару лет назад столкнулся с тем, что в ПУБе в некоторых отчетах количество группировок ограничено 5 уровнями и это при списке из позиций кажется 12. Честно говоря, как-то не вдохновило описывать 12 реальных циклов, решил написать рекурсию. Потом функция переросла в практический пример, который я привожу своим слушателям для демонстрации того, как реализовывать рекурсию при использовании запроса. пример отчета с рекурсией вот тут - http://infostart.ru/projects/827/?ref=8784 в примере также дана обучающая обработка по работе с запросом, очень будет полезна тем кто только начинает знакомится с таким объектом как "запросом"

14.03.2007    10414    23    

Комментарии

Dev7.7.: Групповая печать документов. Даже без ВПФ.#108 30.01.18 15:05
(106)
Цитата
. Помнится, там противопоказаны длинные и русские имена.

а ты не помнишь ссылку на механизм упаковки компоненты внутрь обработки - будет время допилю и выложу с обновленным формексом
Dev7.7.: Групповая печать документов. Даже без ВПФ.#105 26.01.18 0:38
(104) еще как актуальная. Я вот поленился 20 документов пере открывать и печатать. И полез искать готовое. Еще полчаса на разбор и дописывавшие кода выше. И вуаля - лучше день потерять но потом за 5 минут долететь)))))

Саша. Кстати, не сталкивался с тем что почему не идет печать на сетевой принтер. На локальных все норм. В деталях правда еще не разбирался. Формекс используется последней версии с сайта Альфа а не тот который вит в обработку.

обработку немножко допилил под встройку в конфигурацию и вызов ее из журнала. Могу скинуть - выложишь в теме
Dev7.7.: Групповая печать документов. Даже без ВПФ.#103 25.01.18 18:16
тема старая но все же

внес небольшие изменения если при печати документа формируется не одна а несколько печатных форм. В исходном варианте будет печататься только последняя открытая форма так как она будет активной.

Далее обновленный вариант процедуры напечатать
для совместимости оставил старый вариант если в зашитой внутри версии компоненте Formex нет еще метода СписокТаблиц()

Код
//_____________________________________________________________________________
Процедура Напечатать()  
   //для инфы
        //Сообщить("===========ТАБЛИЦЫ=============");
   //СписокТаблиц = FormExСервис.СписокТаблиц();
   //Для Инд  =  1 По СписокТаблиц.РазмерСписка() Цикл
   //   ИмяТаблицы = "";
   //   Объект = СписокТаблиц.ПолучитьЗначение(Инд,ИмяТаблицы);   
   //   ИмяТаблицы = СтрЗаменить(ИмяТаблицы,"  *","");
   //   Сообщить("Имя таблицы - " + ИмяТаблицы);
   //КонецЦикла;
    //           
   //
   //Сообщить("===========ОКНА=============");
   //СписокВсехОткрытыхОкон = FormExСервис.СписокВсехОткрытыхОкон();
   //Для Инд  =  1 По СписокВсехОткрытыхОкон.РазмерСписка() Цикл
   //   ИмяОкна = "";
   //   Объект = СписокВсехОткрытыхОкон.ПолучитьЗначение(Инд,ИмяОкна);   
   //   //ИмяОкна = СтрЗаменить(ИмяОкна,"  *","");
   //   Сообщить(ИмяОкна);
   //КонецЦикла;
   
                             
   //предусмотрим случай когда в документе по умолчанию формируются несколько печатных форм
   СписокТаблиц = FormExСервис.СписокТаблиц();
   
   Если ТипЗначенияСтр(СписокТаблиц) = "СписокЗначений" Тогда
      Для Инд  =  1 По СписокТаблиц.РазмерСписка() Цикл
         ИмяТаблицы = "";
         Activ = "";
         Activ = СписокТаблиц.ПолучитьЗначение(Инд,ИмяТаблицы);   
         //ИмяТаблицы = СтрЗаменить(ИмяТаблицы,"  *","");
         //Сообщить("Имя таблицы - " + ИмяТаблицы);    
         
         Если FormExСервис.ActiveContext(Activ) = 1 Тогда
            Если ТипЗначенияСтр(Activ) = "Таблица" Тогда
               Если ПустаяСтрока(ИмяПринтера) = 0 Тогда
                  Activ.ПараметрыСтраницы(,,,,,,,,,,,ИмяПринтера);
               Иначе
                  Activ.ПараметрыСтраницы(,,,,,,,,,,,1);
               КонецЕсли;
               
               Activ.КоличествоЭкземпляров(?(рдКопий = 0, 1, рдКопий));
               Activ.Напечатать(0);
               Activ.Показать("", "", -1);
            КонецЕсли;
         КонецЕсли;         
      КонецЦикла;
   Иначе
      Activ = "";
      
      Если FormExСервис.ActiveContext(Activ) = 1 Тогда
         Если ТипЗначенияСтр(Activ) = "Таблица" Тогда
            Если ПустаяСтрока(ИмяПринтера) = 0 Тогда
               Activ.ПараметрыСтраницы(,,,,,,,,,,,ИмяПринтера);
            Иначе
               Activ.ПараметрыСтраницы(,,,,,,,,,,,1);
            КонецЕсли;
            
            Activ.КоличествоЭкземпляров(?(рдКопий = 0, 1, рдКопий));
            Activ.Напечатать(0);
            Activ.Показать("", "", -1);
         КонецЕсли;
      КонецЕсли;         
   КонецЕсли;
КонецПроцедуры //Напечатать
DevКак программно задать размеры (ширина*высота) диаграммы 1С 7.7#1 24.01.18 15:53
Друзья, помогите, весь мосх себе сломал

Есть отчет в котором выводится динамика показателя по месяцам в виде их присоединения. Ниже строится диаграмма.

При большом периоде выборке - колонок много а ширина диаграммы фиксированная.

Есть kb варианты как нибудь программно изменить ширину диаграммы?

Прикрепленные файлы:

диаграмма.png
УчетКакую систему выбрать для автоматизации ресторана#1 04.10.17 15:12
Коллеги, поделитесь отзывами объективными и субъективными о работе системы для автоматизации ресторанов iiko

Задали сегодня вопрос - а я даже не слышал о таком софте.

отдельно буду признателен за сравнение например с трактиром от софтбаланса или возможно еще чем то аналогичным.

Постановка задачи
1. у заказчика предполагается две точки
2. хочется видеть как бухгалтерскую часть (бухам)
3. так и управленческую (собственнику), причем желательно чтобы удаленно (ios, android и т.д.)
НовостиПодведены итоги конференции INFOSTART EVENT 2017 COMMUNITY#330 28.09.17 13:18
(184)
Цитата
1С:ERP - обещал заплатить. Всё-таки Инфостарт творит чудеса! :)

Коля так это твой был 313 номер???)
НовостиПодведены итоги конференции INFOSTART EVENT 2017 COMMUNITY#318 28.09.17 11:01
Говорят семь раз отмерь, один раз отрежь.В этот раз, при организации уже седьмой по счету конференции были учтены все нюансы предыдущих.
Супер
О жизниС праздником: 22 апреля и 256 день в году - День программиста#12 19.09.17 15:56
надо же))) 6 лет сюда никто не заглядывал)))) а тут бац и оживились))