Зленко Владимир

376
Рейтинг

Владимир Зленко
ZLENKO



  •   Регистрация: 30.03.2007 (11 лет назад)

  •   Был(а) на сайте: 18.06.2018


Группы

Профессиональный разработчик

Партнер IS-WP

Рейтинг 376

Версионирование объектов. Сжатие регистра "ВерсииОбъектов" 9

v8 1cv8.cf Абонемент ($m)

Cжимаем версии объектов в регистре сведений "ВерсииОбъектов". Экономия занимаемого версиями объектов объема более 50% !!!

1 стартмани

30.12.2014    17538    42    14    

Универсальный отчет "[П]: Анализ Продаж" [УТ, УПП, КА, Розница] 63

v8 КА1 УТ10 УПП1 УУ Оптовая торговля Абонемент ($m)

Отчет позволяет анализировать продажи (прирост/убыль) по контрагентам и номенклатуре по данным регистра "Продажи". Рассчитывается доля (%) от общего итога, абсолютное (Δ) и относительное (%) отклонение для выбранных периодов. Уникальные возможности Универсального отчета ! Не забываем "плюсовать" и писать комментарии :-)

10 стартмани

07.03.2013    40754    447    55    

Универсальный отчет "[П]: Дебиторка & Кредиторка" [УТ, УПП, КА] 121

v8 КА1 УТ10 УПП1 Украина Россия УУ Дебиторская и кредиторская задолженность Абонемент ($m)

Уникальные возможности Универсального отчета ! Готовое решение по постановке управленческого учета дебиторской и кредиторской задолженности: - отсроченная и просроченная задолженность; - платежный календарь (поставщики и покупатели); - структура задолженности по интервалам; - структура задолженности по срокам. В настоящее время достаточно распространенной формой отгрузки товаров является отсрочка оплаты. Компания получает отсрочку оплаты от поставщика и предоставляет отсрочку покупателям. Таким образом у компании возникает необходимость организовать учет отсроченной кредиторской и дебиторской задолженностей. Типовые конфигурации 1С: ПРЕДПРИЯТИЕ 8 предоставляют возможность вести такой учет только при условии, что в договоре контрагента установлено «Вести по документам расчетов с контрагентами». Такая детализация ведения взаиморасчетов удобна далеко не всем компаниям. Не забываем "плюсовать" и писать комментарии :-)

5 стартмани

17.02.2012    41223    1354    90    

[Z]: Голосовой Информатор.PRO (Торговое Оборудование) 12

v8 Розница Абонемент ($m)

Технология "Голосовой информатор": Позволяет информировать покупателя о чем-либо в процессе обслуживания без участия кассира - синтезированный голос произносит персонифицированные сообщения. Подключается к конфигурациям как обработка торгового оборудования с видом "Дисплей покупателя". Не забываем "плюсовать" и писать комментарии :-)

1 стартмани

07.10.2009    13472    27    6    

Универсальный отчет "[П]: Контрагенты & Контакты" [УТ, УПП, КА] 56

v8 КА1 УТ10 УПП1 Взаимоотношения с клиентами (СRM) Абонемент ($m)

Управление клиентской базой = Управление прибылью! Уникальные возможности Универсального отчета ! Не забываем "плюсовать" и писать комментарии :-)

1 стартмани

28.07.2009    21724    691    39    

1C 8.1: Потоковая загрузка документов из Excel ( универсальная, xls dbf txt mxl ) 115

v8 1cv8.cf Абонемент ($m)

Настраиваемая потоковая загрузка документов из "плоской" (денормализованной) таблицы (xls, dbf, txt, mxl)

1 стартмани

16.02.2009    27964    1800    58    

Комментарии

DevКак мы универсально заштриховали документы#59 12.01.18 16:32
Сделал штрихкодирование документов на нативных компонентах из БСП (ОбщиеМакеты.КомпонентаПечатиШтрихкодов и ОбщиеМакеты.Драйвер1ССканерШтрихкода). Удобно что не нужно регистрировать никаких DLL. Механизмы работы с торговым оборудованием не стал использовать, т.к. много лишнего кода тянуть нужно. Сделал просто несколько процедур, например подключение сканера ШК:

Код
// Функция выполняет подключение внешней компоненты и ее первоначальную настройку.
// Возвращаемое значение: НЕОПРЕДЕЛЕНО - компоненту не удалось загрузить.
Функция ПодключитьВнешнююКомпонентуСканераШтрихкода() Экспорт
   
   ПодключениеВыполнено = ПодключитьВнешнююКомпоненту("ОбщийМакет.Драйвер1ССканерШтрихкода", "СканерШтрихкода", ТипВнешнейКомпоненты.Native);
   
   // Создадим объект внешней компоненты.
   Если ПодключениеВыполнено Тогда
      ВнешняяКомпонента = Новый("AddIn.СканерШтрихкода.Scanner");
   Иначе
      Возврат Неопределено;
   КонецЕсли;
   
   ВнешняяКомпонента.УстройствоВключено = 0;
   ВнешняяКомпонента.ПосылкаДанных = 0;
      
   // Подсоединим компоненту
   Попытка
      ВнешняяКомпонента.Подсоединить("Scanner");
   Исключение
      Возврат Неопределено;
   КонецПопытки;
   
   // Установим основные параметры компоненты.   
   ВнешняяКомпонента.Порт = 0;            
   ВнешняяКомпонента.ИмяСобытия = "BarCode";
   ВнешняяКомпонента.ПрефиксСтрока = Символ(0);
   ВнешняяКомпонента.СуффиксСтрока = Символ(13);      
   
   ВнешняяКомпонента.УстройствоВключено = 1;
   ВнешняяКомпонента.ПосылкаДанных = 1;   
   
   // Займем компоненту   
   Если ВнешняяКомпонента.Занять(1) = 0 Тогда
      ВнешняяКомпонента.ОчиститьВход();
      ВнешняяКомпонента.ОчиститьВыход();         
   Иначе      
      Возврат Неопределено;      
   КонецЕсли;
      
   Если ВнешняяКомпонента.УстройствоВключено = 1 
      И ВнешняяКомпонента.УстройствоЗанято = 1 Тогда
      Возврат ВнешняяКомпонента;
   Иначе      
      Возврат Неопределено;
   КонецЕсли;
      
КонецФункции


Код
// Функция выполняет подключение внешней компоненты и ее первоначальную настройку.
// Возвращаемое значение: НЕОПРЕДЕЛЕНО - компоненту не удалось загрузить.
Функция ПодключитьВнешнююКомпонентуПечатиШтрихкода() Экспорт
   
   ПодключениеВыполнено = ПодключитьВнешнююКомпоненту("ОбщийМакет.КомпонентаПечатиШтрихкодов", "КартинкаШтрихкода", ТипВнешнейКомпоненты.Native);
   
   // Создадим объект внешней компоненты.
   Если ПодключениеВыполнено Тогда
      ВнешняяКомпонента = Новый("AddIn.КартинкаШтрихкода.Barcode");
   Иначе
      Возврат Неопределено;
   КонецЕсли;
   
   // Если нет возможности рисовать.
   Если НЕ ВнешняяКомпонента.ГрафикаУстановлена Тогда
      // То картинку сформировать не сможем.
      Возврат Неопределено;
   Иначе
      // Установим основные параметры компоненты.
      // Если в системе установлен шрифт Tahoma.
      Если ВнешняяКомпонента.НайтиШрифт("Tahoma") Тогда
         // Выбираем его как шрифт для формирования картинки.
         ВнешняяКомпонента.Шрифт = "Tahoma";
      Иначе
         // Шрифт Tahoma в системе отсутствует.
         // Обойдем все доступные компоненте шрифты.
         Для Сч = 0 По ВнешняяКомпонента.КоличествоШрифтов -1 Цикл
            // Получим очередной шрифт, доступный компоненте.
            ТекущийШрифт = ВнешняяКомпонента.ШрифтПоИндексу(Сч);
            // Если шрифт доступен
            Если ТекущийШрифт <> Неопределено Тогда
               // Они и будет шрифтом для формирования штрихкода.
               ВнешняяКомпонента.Шрифт = ТекущийШрифт;
               Прервать;
            КонецЕсли;
         КонецЦикла;
      КонецЕсли;
      // Установим размер шрифта
      ВнешняяКомпонента.РазмерШрифта = 12;
      
      Возврат ВнешняяКомпонента;
   КонецЕсли;
   
КонецФункции
Личная эффективностьКлуб 0 децибел или тишина спасет мир#4 11.01.18 18:12
(3)
Цитата
Можно взять клавиатуру с красными свичами, она самая тихая.

Есть еще такое http://klavogonki.ru/wiki/%D0%9D%D0%BE%D0%B6%D0%BD%D0%B8%D1%87%D0%BD%D1%8B%D0%­B9_%D0%BC%D0%B5%D1%85%D0%B0%D0%BD%D0%B8%D0%B7%D0%BC

Я до сих пор пользуюсь такой https://www.ixbt.com/peripheral/benq-x530.shtml уже более 10 лет... Это нечто среднее между чисто мембранными (меня они просто бесят) и шумной (недавно купил сыну razer blackwidow ultimate 2014) механикой.
Личная эффективностьКлуб 0 децибел или тишина спасет мир#1 11.01.18 16:55
Не сочтите за рекламу, т.к. это то чем я сам пользуюсь - корпуса, блоки питания, процессорные кулеры https://www.bequiet.com/ru/
Не смотря на наличие вентиляторов они практически бесшумные, но стоят недешево. Самая большая проблема - шум HDD :-(
DevКак мы универсально заштриховали документы#13 28.12.17 19:46
Почему то в конфигураторе все нормально работает в макете, но при выполнении в 1С 8.3.9
ОбластьШК.Рисунки.Штрихкод.Объект содержит значение Неопределено
На 8.3 не работает компонент ?
ФинансыУниверсальный отчет "[П]: Дебиторка & Кредиторка" [УТ, УПП, КА]#93 26.12.17 13:52
(92) Первый отчет содержит такой же запрос как и остальные 3 отчета. Отчеты отличаются стандартными настройками "зашитыми" в код.
ВКAndroid Штрихкод сканер + драйвер устройства для 1С#92 22.12.17 11:18
Мое видение использования смартфона в качестве ТСД:

1) на Andriod смартфоне запущен RDP клиент с запущенной в нем 1С;
2) 1С использует стандартный драцвер сканера штрихкода (клавиатурный);
3) сканер штрихкодов с блутус интерфейсом передает штрихкод по блутусу в смартфон;
4) на смартфоне утилита перенаправляет сосканированный штрихкод в порт клавиатуры.

Проблемка в отсутствии утилиты на Android смартфоне перенаправляющей штрихкод с блутуса в клавиатуру :-(
ВКAndroid беспроводной Bluetooth сканер 1D/2D штрихкода и терминал сбора данных для 1С#28 22.12.17 11:18
Мое видение использования смартфона в качестве ТСД:

1) на Andriod смартфоне запущен RDP клиент с запущенной в нем 1С;
2) 1С использует стандартный драцвер сканера штрихкода (клавиатурный);
3) сканер штрихкодов с блутус интерфейсом передает штрихкод по блутусу в смартфон;
4) на смартфоне утилита перенаправляет сосканированный штрихкод в порт клавиатуры.

Проблемка в отсутствии утилиты на Android смартфоне перенаправляющей штрихкод с блутуса в клавиатуру :-(
DevОптимизация типовых функций из кода 1с в 1С:Предприятие 8.Х#32 28.11.17 19:06
Реализовано в версии 8.3.6.1977 функции: СтрРазделить(), СтрСоединить()
Читаем тут: https://infostart.ru/public/366865/
БУНачисление зарплаты в УНФ#16 24.11.17 13:54
(15)
Цитата
если вы хотите автоматические начисления, то они производятся помесячно.
При использовании оклада за месяц я так и предполагал, но я могу сделать 4 начисления за месяц за каждую неделю и использовать ставку за день или за час и вводить отработанное за неделю количество дней или часов?
HighLoad"Убираем блокировки" в 1С. Заставляем MS SQL работать как Oracle.#121 24.11.17 10:59
(120)
Цитата
И узнавал о проблеме только когда SQL сервер привет присылал. Короче плюнул на эти все эксперименты с блокировками в 1С, получается конфликт ну и фиг с ним.
Зря плюнули... переход на версионный режим решает проблему блокировок.