Раздел "Тендеры" находится на стадии бета-тестирования. Условия и правила работы для заказчика и исполнителя смотрите при создании проекта или заявки на выполнение.
В список проектов
Название: Поправить код для удаления присоединенных файлов из карточек номенклатуры
Предполагаемый бюджет: 1 000 руб.
Конфигурация: 1С:Управление торговлей 11
Бюджет: 1 000 руб.
Статус: Поиск исполнителя

1. Оценка проекта
и выбор
исполнителя
Претенденты
отправляют оценку стоимость и сроков выполнения проекта. Заказчик ведет переговоры и выбирает одного исполнителя.
2. Создание
этапов проекта со
стоимостью и сроками
Исполнитель
создает этап проекта,
в котором указаны стоимость, срок выполнения работ и список задач, которые необходимо
выполнить.
3. Депонирование
оплаты
Заказчик
перечисляет денежные средства на депонент. После получения депонента, исполнитель приступает к выполнению
работ.
4. Выполнение
работ и
сдача-приемка работ
заказчику
Исполнитель
выполняет работы по каждому этапу проекта. После сдачи-приемки этапа заказчику, исполнитель получает оплату
с депонента.
5. Рейтинг и отзывы
об исполнителе
и заказчике
Заказчик
оставляет отзыв об исполнителе. Исполнитель
оставляет отзыв о заказчике.

О проекте

К каждой номенклатурной единице подвязан файл *.txt, хранящийся на внешнем томе. Возникла задача от всего этого избавиться. Файлы удалили. Всем присоединенным файлам поставлена пометка на удаление, вот только реально удалить их не получается. 1С сообщает о том, что файлы используются в карточках номенклатуры. Выходит сначала нужно почистить ссылки в каждой карточке, а уж потом удалить файлы?

Вариант кода, используемого для этой цели (поправьте или предложите свой вариант):
Запрос = Новый Запрос;
   Запрос.Текст = "ВЫБРАТЬ
                  |    НоменклатураПрисоединенныеФайлы.Ссылка
                  |ИЗ
                  |    Справочник.НоменклатураПрисоединенныеФайлы КАК НоменклатураПрисоединенныеФайлы";
   Таб = Запрос.Выполнить().Выгрузить();
   МассивПрисоединенныхФайлов = Таб.ВыгрузитьКолонку("Ссылка");

   ТабСсылок = НайтиПоСсылкам(МассивПрисоединенныхФайлов);
   Для Каждого Ссылка из ТабСсылок Цикл
             Индекс = Найти(Ссылка[0], ".txt");
             Если Индекс>0 Тогда
                  НоменклатураОбъект = Ссылка[1].ПолучитьОбъект();
                  Набор = РегистрыСведений.ПрисоединенныеФайлы.СоздатьНаборЗаписей();
                  Набор.Отбор.ПрисоединенныйФайл.Установить(Ссылка[0]);
                  Набор.Прочитать();
                  
                  Для Каждого Стр Из Набор Цикл
                         //Вот в этот цикл мы не заходим, ибо у меня совершенно нет понимания, что за объект такой Набор и что с ним делать вообще. А честно стыренный код из сети почему-то не работает!
                       Набор.Удалить(Стр);
                     КонецЦикла;
                  Набор.Записать();

                  Вывести(НоменклатураОбъект);
             КонецЕсли
   КонецЦикла;
Откликнуться на проект

Заявки на проект:

Дата Оценка исполнителя Исполнитель Рейтинг Действия
28.09.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10
21.09.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10
09.09.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10
07.09.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10
07.09.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10
01.09.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10
01.09.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10
01.09.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10
31.08.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10
31.08.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10
31.08.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10
31.08.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10
31.08.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10
31.08.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10
31.08.17

0 руб. за 0 ч.

Коммуникация 0/10
Качество разработки0/10
Точность сроков 0/10
Скорость 0/10
Интерфейс 0/10