КД 2.0. Перенос документов 7.7 - 7.7. Передача параметра "Проведен"

Публикация № 100514

Разработка - Системная интеграция - Обмен через XML

15
1С:Конвертация данных 2.0. Решение проблемы проведения документов при переносе между базами 7.7

При использовании конфигурации "Конвертация данных 2.0" для переноса документов между базами 7.7 не переносится статус документа, а именно: "Проведен", "Помечен на удаление".

Все документы при переносе стандартным механизмом "садятся" непроведенными.

При использовании ПКС "Проведен" появляется ошибка "Не верное имя реквизита Документ.ХХХ.Проведен".

Для решения данной проблемы нам придется:

  1. Добавить код в процедуру ПКО "ПриВыгрузке":


УзелПараметра = DOMDocument.СоздатьУзел(1, "ЗначениеСтатуса", "");
УзелПараметра.УстановитьАтрибут("ИмяПараметра", "Статус");
Если
Источник.Проведен()=1 тогда
    
Статус = "Проведен";
ИначеЕсли
Источник.ПометкаУдаления()=1 тогда
    
Статус = "ПомеченНаУдаление";
Иначе
    
Статус = "НеПроведен";
КонецЕсли;
УзелПараметра.УстановитьАтрибут("ЗначениеПараметра", Статус);
Приемник.ДобавитьПодчиненный(УзелПараметра);

  1. "Подправить" модуль загрузки в процедуре "ЗагрузитьДокументV8()". В конце добавляем:


УзелСтатус
= Объект.ВыбратьУзел("ЗначениеСтатуса");

Статус      =   УзелСтатус.ПолучитьАтрибут("ЗначениеПараметра");

Если
Статус = "Проведен" Тогда
   Если
ОбъектБД.ПометкаУдаления() = 1 Тогда
        
ОбъектБД.СнятьПометкуУдаления();
   КонецЕсли;

   Попытка
       
ОбъектБД.Провести();
   Исключение
      
Сообщить(""+ОписаниеОшибки());
   КонецПопытки;

ИначеЕсли
Статус = "ПомеченНаУдаление"  Тогда
   
ОбъектБД.Удалить(0);
Иначе
   Если
ОбъектБД.Проведен()=1 Тогда
        
ОбъектБД.СделатьНеПроведенным();
   ИначеЕсли
ОбъектБД.ПометкаУдаления() =1 Тогда
        
ОбъектБД.СнятьПометкуУдаления();
   КонецЕсли;
КонецЕсли;

15

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. fancy 21.12.11 07:33 Сейчас в теме
"1. Добавить код в процедуру ПКО "После загрузки":" - Может быть "После выгрузки" документа - я так понимаю добавляем подчиненный узел "ЗначениеСтатуса" в xml?
2. xazrad 15 21.12.11 09:53 Сейчас в теме
(1) Совершенно верно. только в ПКО "ПриВыгрузке". Исправил в публикации. Спасибо за замечание
3. Alav 13 21.12.11 11:49 Сейчас в теме
В принципе если совесть позволяет править конфигу и обмен будет постоянный, то можно добавить 2 общих реквизита Проведен и ПометкаУдаления. Тогда КД при переносе их автоматом будет заполнять и после загрузки уже можно анализировать их и делать телодвижения в документе.


Автору плюс однозначно, просто привел альтернативу решению автора
4. Boroda 90 21.12.11 18:51 Сейчас в теме
Интересно, надо попробовать. Автору спасибо.
5. fomix 26 22.12.11 12:51 Сейчас в теме
А что мешает использовать в обработчике "ПослеЗагрузки" ПКО любого документа волшебные слова "РежимЗаписи = "Проведение""????
9. Alav 13 24.12.11 11:26 Сейчас в теме
(5) если не ошибаюсь для 7-ки это не работает. Но в любом случае речь идет о передачи всех документов, а не только проведенных, поэтому так без условно проводить нельзя (например в источнике документ сняли с проведения или пометили на удаления, нужно в получателе сделать тоже самое, иначе данные будут расходиться, ведь мы уже выгрузили этот документ, так как он был проведен)
6. Модератор раздела artbear 23.12.11 15:42 Сейчас в теме
Аналогичная разработка давно есть на ИС
http://infostart.ru/public/21069/
Детали уже особо не помню.
У автора сабжа юзается другой подход, верно?
7. xazrad 15 23.12.11 17:27 Сейчас в теме
(6) другой. как мне известно параметры при переносу из 7.7 в 7.7 не передаются а в http://infostart.ru/public/21069/ используются параметры
8. Модератор раздела artbear 24.12.11 11:06 Сейчас в теме
(6) Параметры передать для 77 несложно. я в свое время как раз решал задачу проведения документов и решил проблему передачи параметров.
10. mig2k 27.12.11 11:27 Сейчас в теме
Однако, не работает:
Ошибка исполнения обработчика: ПКО_ПриВыгрузке_ПоступлениеТМЦ
- Поле агрегатного объекта не обнаружено (СоздатьУзел)
Говорит, у этого объекта нет такого метода:
УзелПараметра = DOMDocument.СоздатьУзел(1, "ЗначениеСтатуса", "");
11. xazrad 15 27.12.11 17:34 Сейчас в теме
(10) попробуй так
УзелПараметра = DOMDocument.createNode(1, "ЗначениеСтатуса", "");
УзелПараметра.setAttribute("ИмяПараметра", "Статус");
Если Источник.Проведен()=1 тогда
Статус = "Проведен";
ИначеЕсли Источник.ПометкаУдаления()=1 тогда
Статус = "ПомеченНаУдаление";
Иначе
Статус = "НеПроведен";
КонецЕсли;

УзелПараметра.setAttribute("ЗначениеПараметра", Статус);
Приемник.appendChild(УзелПараметра);
12. ChessCat 13.02.12 14:41 Сейчас в теме
Пара моментов

>2 "подправить" модуль загрузки в процедуре "ЗагрузитьДокументV8()"
В ПКО есть обработчики "При загрузке" и "После загрузки". При чем тут процедура "ЗагрузитьДокументV8()" если речь идет о конвертации между 7.7 и 7.7 ?

Момент второй. Бросается в глаза

Если ОбъектБД.ПометкаУдаления() = 1 Тогда
ОбъектБД.СнятьПометкуУдаления();
КонецЕсли;

По всей видимости же не ОбъектБД а Объект
13. K_Andrey 09.05.12 11:45 Сейчас в теме
Выдает ошибку при загрузке:

Статус = УзелСтатус.ПолучитьАтрибут("ЗначениеПараметра");
(2958)}: Значение не представляет агрегатный объект (ПолучитьАтрибут)
14. K_Andrey 09.05.12 12:36 Сейчас в теме
15. Vigor06 07.11.12 11:27 Сейчас в теме
Не получается подправить под конвертацию 8.2 УТ -> 7.7 Учет и отчетность предпринимателя
Во 2м шаге,как я правильно понял,меняем
	ЗаписатьОбъект(ОбъектБД);
	
	Если ПустоеЗначение(ПометкаУдаления) = 1 Тогда
		Если Объект.ПометкаУдаления() = 1 Тогда    ОбъектБД.СнятьПометкуУдаления();  КонецЕсли;
	Иначе
		Если Объект.ПометкаУдаления() = 0 Тогда    ОбъектБД.Удалить(0);  КонецЕсли;
	КонецЕсли

на
ЗаписатьОбъект(ОбъектБД);
УзелСтатус = Объект.ВыбратьУзел("ЗначениеСтатуса");
Статус      =   УзелСтатус.ПолучитьАтрибут("ЗначениеПараметра");

Если Статус = "Проведен" Тогда
   Если ОбъектБД.ПометкаУдаления() = 1 Тогда
        ОбъектБД.СнятьПометкуУдаления();
   КонецЕсли;

   Попытка
       ОбъектБД.Провести();
   Исключение
      Сообщить(""+ОписаниеОшибки());
   КонецПопытки;

ИначеЕсли Статус = "ПомеченНаУдаление"  Тогда
   ОбъектБД.Удалить(0);
Иначе
   Если ОбъектБД.Проведен()=1 Тогда
        ОбъектБД.СделатьНеПроведенным();
   ИначеЕсли ОбъектБД.ПометкаУдаления() =1 Тогда
        ОбъектБД.СнятьПометкуУдаления();
   КонецЕсли;
КонецЕсли;
Показать


А вот как правильно прописать в правилах конвертации шаг1 - ну никак не могу((
16. Nik777x 14.11.13 21:31 Сейчас в теме
(15) Vigor06, Также пытаюсь перенести документы из УТ 8.2 11.1 в Тис 7.7. Примеров переноса из 7.7 в 7.7 и из 8.2 в 8.2 достаточно, а как правильно описать из 8.2 в 7.7 пока не нашел. Vigor06 если разобрался подскажи как сделал.
17. Xershi 792 27.11.14 15:18 Сейчас в теме
Как решить вопрос проведения документов в конвертации 8.2 -> 7.7 кто разобрался?
Оставьте свое сообщение

См. также

Доработка конвертации данных КД2 (версии 2.1). Расширенная диагностическая информация при выгрузке по правилам из 1С 7.7 и при загрузке в 1С 7.7 3

Статья Программист Нет файла v7.7 v8 КД Бесплатно (free) Обмен данными 1С Перенос данных из 1С7.7 в 1C8.X Обмен через XML

Есть очень неприятная особенность при настройке обмена по правилам КД2 в момент отладки на стороне 1С 7.7, как при выгрузке из 1С 7.7, так и при загрузке в 1С 7.7. Непонятно, в каком конкретно месте формирования или разбора данных XML файла в какой именно момент споткнулась программа (произошел сбой). Я нашел способ вывода дополнительной диагностики, теперь точно известно, на каком элементе данных XML споткнулся модуль выгрузки V77Exp.ert (модуль загрузки V77Imp.ert). Теперь отладка правил обмена на стороне 1С 7.7 стала простой, выполняется на порядок проще.

18.10.2019    2610    ksnik    0       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Читаем реквизиты по ИНН в 1С:7.7 18

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Обмен через XML

Чтение реквизитов контрагентов по ИНН при оформленной подписке на сервис 1С:Контрагенты

17.01.2017    16516    kudenzov    14       

Проблемы переноса данных бухгалтерского учета 7

Статья Программист Нет файла v77::БУ 1С7:Бух Россия БУ Windows Бесплатно (free) Обмен через XML

Спецы 1С для удобства конечного пользователя создали специальные решения, позволяющие по нажатию кнопки выгрузить данные. Попробовал и я...

03.02.2016    23623    lvictor58    5       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Оптимизация выгрузки из 1С 7.7 по правилам обмена большого объема данных 25

Статья Программист Нет файла v7.7 1cv7.md Windows Бесплатно (free) Перенос данных из 1С7.7 в 1C8.X Обмен через XML 1С7.7<->1C7.7

При выгрузке из 1С 7.7. большого справочника программа завершалась примерно с таким сообщением: "msxml6.dll: Недостаточно памяти для завершения операции". Вариант выгрузки порциями меня не устраивал. Поэтому немного оптимизировал обработку выгрузки. Возможно кому-то сэкономит время.

24.09.2014    28719    Just4Fun    28       

"Конвертер деклараций (XLS) от поставщиков для загрузки в Декларант Алко (XML), 11/12 форма" для 7.7 17

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v7.7 1cv7.md Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Windows Акцизы Бесплатно (free) Внешние источники данных Обмен через XML

"Конвертер деклараций (XLS) для загрузки в Декларант Алко (XML)" Конвертирует 11/12 форму декларации полученную от поставщиков (в экселе) в файлы импорта (xml) для загрузки в Декларант Алко.

07.10.2013    40046    335    Ёпрст    4       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.130.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

Посчитать людей по XML-файлам, выгруженным для ПФ 2010 7

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК БУ НУ Windows Управление персоналом (HRM) ФОМС, ПФ, ФСС Бесплатно (free) Обмен через XML Универсальные функции

Обработка считает и выводит людей, которые находятся в xml-файлах для пенсионного фонда. Также может служить "рыбой" для дополнительной обработки данных в файлах пенсионного фонда

24.01.2011    11060    81    kserdyukov    1       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Конвертация данных 2 - Отмена проведения документов в 7.7 при повторной загрузке 17

Статья Программист Нет файла v7.7 1cv7.md КД Windows Бесплатно (free) Обработка документов 1С7.7<->1C7.7

При повторной загрузке данных в 1С бывает необходимо отменить проведение у существующих документов.

21.10.2010    17046    nicxxx    7       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Переброска из ТиС в Бухгалтерию 7.7 26

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ 1С7:Бух 1С7:ТиС Россия Оптовая торговля Бесплатно (free) 1С7.7<->1C7.7

Переброска документов прихода, расхода, выписок, ПКО и РКО. Для программистов свободного распространения, желательно не в Пензе :). Проверено и доработано многократно. Версия 5.2 (исправлено совпадение элементов и групп справочников по наименованию)

09.09.2009    7754    243    fisgen    18       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Формирование остатков 2 17

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия Бесплатно (free) Бухгалтерские 1С7.7<->1C7.7

Обработка выполняет расчет остатков по выбранным счетам и формирует операцию с остатками. Есть возможность выгрузки по OLE.

31.05.2009    8531    236    int18h    6       

PgConf.Russia 2020. 3-5 февраля 2020 г. Москва. Промо

PGConf.Russia – международная техническая конференция по открытой СУБД PostgreSQL, ежегодно собирающая более 700 разработчиков, администраторов баз данных и IT-менеджеров для обмена опытом и профессионального общения. Для участников сообщества infostart.ru скидка 5% на участие в конференции.

от 12350 рублей

Загрузка правил обмена в КД 1.0 7

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v7.7 КД Windows Бесплатно (free) Инструментарий разработчика Обмен через XML 1С7.7<->1C7.7

Обработка позволяет загрузить правила конвертации, сформированные в конфигурации Конвертация Данных 1.0 обратно в конфигурацию

27.05.2009    12440    182    Ctrl P    14       

Анализатор изменений:Справочники 12

Инструменты и обработки no Внешняя обработка (ert,epf) v7.7 1cv7.md Windows Бесплатно (free) Анализ учета 1С7.7<->1C7.7

Обработка позволяет сравнить справочники в идентичных базах (например у архивной и актуальной копии).

27.04.2009    6822    208    petro_fm    2       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

22 января состоится вебинар "Использование технологии блокчейн в 1С" Промо

На вебинаре вы узнаете как использовать современную технологию блокчейн при проектировании и создании учетных систем, почему эту технологию следует рассматривать как одну из базовых. Ведущий Михаил Калимулин поделится своими знаниями основ технологии и опытом внедрения.

990 рублей

Импорт для всех конф семерки! 89

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v7.7 1cv7.md Windows Бесплатно (free) Файловые протоколы обмена, FTP Загрузка и выгрузка в Excel 1С7.7<->1C7.7

Переносит любые справочники, документы и т.д. Работаю с ней уже год - все отлично при любом количестве строк.

06.02.2009    14043    1907    floraukraine    21       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 17 февраля по 13 марта 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Универсальная обработка: Выгрузка и загрузка справочников с фильтрацией 15

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v7.7 1cv7.md Windows Бесплатно (free) Обработка справочников 1С7.7<->1C7.7

Универсальная обработка: Выгрузка и загрузка справочников с фильтрацией. Есть вариант с библиотекой V7PLUS.DLL, который не требует прав администратора, что делает данную обработку максимально независимой.

16.01.2009    10107    1257    nikolka75    9