Подключаемые команды [расширение] УТ 11

Публикация № 1032025

Программирование - Работа с интерфейсом

7
Расширение позволяет добавлять команды (кнопки, гисперссылки) на управляемую форму.

Параметры команды

  • Идентификатор - Уникальное имя
  • Представление - заголовок команды (кнопки)
  • Подсказка - описание не требуется :)
  • Размещение - указывается имя элемента формы (группа, или командная панель) в\на которой будет размещена кнопка, по умолчанию (если ничего не указано) кнопка будет размещена на форме произвольно.
  • Имя модуля - имя общего модуле в котором находится процедура выполнения команды:
Процедура ВыполнитьПодключеннуюКоманду(стрКоманда, Форма, Источник) Экспорт
	Если стрКоманда="Напоминание" Тогда
		ОткрытьФорму("РегистрСведений.lab33_НапоминанияПользователя.Форма.Напоминание", Новый Структура("Источник", Источник));

	ИначеЕсли стрКоманда="Обсуждение" Тогда
		ОткрытьФорму("РегистрСведений.lab33_Обсуждения.Форма.ФормаОбсуждения", Новый Структура("Источник", Источник));		
	КонецЕсли; 
КонецПроцедуры

 

Типы параметров

  • Тип параметра команды - указываются объекты метаданных (из справочников идентификаторы объектов метаданных\расширений) для которых действует создание команды
  • Размещение - тоже самое, что размещение в шапке - если не указано берется из шапки (можно указать возможные размещения через запятую например "Список.ГруппаБыстрыеОтборы" и т.д.)

Свойства

  • Описание свойств кнопки

Пользователи

  • Указываются пользователи ля которых действует настройка (если не указано, то для всех)

Группы пользователей

  • Указываются группы пользователей (если включено использование) для которых действует настройка (если не указано, то для всех)

Результат

 

Р.S. При подключении к расширениям в модулях объектом расширения должна быть процедура:

&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
	ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Источник);
КонецПроцедуры

где "Источник" - Элементы[ИмяДинамическогоСписка] для форм списков или Объект - для форм объектов.

Требования: Платформа 8.3.12

7

Скачать файлы

Наименование Файл Версия Размер
Подключаемые команды [расширение] УТ11:
.cfe 30,69Kb
01.04.19
3
.cfe 30,69Kb 3 Скачать

См. также

Специальные предложения

Избранное Подписка Сортировка: Дата
В этой теме еще нет сообщений.
Оставьте свое сообщение