Автоматическое подтверждение легальности обновления базы или как обновить 80 типовых баз 1С за 5 часов

Публикация № 1057624

Администрирование - Администрирование данных 1С - Сервисные утилиты

Автоматическая легальность обновления баз

Расширение для конфигураций 1С для автоматического подтверждения легальности обновления и выполнения обработчиков обновления при пакетном автоматическом обновлении большого числа баз 1С. А также сам модуль обработки по автоматическому обновлению баз.

Досталось мне по наследству выполнение обновления баз 1С  Бухгалтерии 3 в количестве 80 шт  и ЗУП 3 - 80 шт(измененные, но не сильно. Обновлять только из хранилища).  У нас конечно написана конфа по обслуживанию такого количества баз и даже пакетное обновление реализовано, в том числе и из хранилища для измененных конфигураций, но ...  все этапы этого варианта обновления заточены на участие Админа. 

1) Сначала надо зайти на сервер и завершить все сеансы оставленные пользователями.

2) Запустить написанную предшественниками не знаю на чем программку по блокировке регламентных заданий на сервере

3) Скачать новый  *.cfu файл обновления для типовых баз 

3а) Обновить изменную базу в хранилище из скачанного cfu файла

4) Сформировать пакетные bat файлы (обычно делим на 4 потока - 4 файла)

5) Запустить  пакетные файлы и дождаться их завершения.

6) Запустить каждый экземпляр базы в режиме Предприятия, подтвердить легальность и закрыть базу.

7) Запустить программку по разблокировке регламентных заданий.

Готово !!!  Мы провели незабываемое время у компа и обновили 80 типовых баз, потратив на это все выходные. 

Проделав дважды такую операцию, мне стало грустно и начал искать пути полной автоматизации этого процесса.   В итоге было обнаружено пару достойных наработок по пакетному обновлению в открытом доступе и начался процесс их переработки и адаптации под мои нужды.  Но у всех найденных вариантов был один существенный недостаток -  подтвердить легальность и закончить обновление они не могли.  Поэтому моя задача не автоматизируется на 100 % без этого.  

Начал изучать механизм завершения обновления через отладчик и искать пути решения моей задачи. В итоге были найдены точки перехвата событий при первом открытии обновленной конфигурации и  мои труды и старания вылились в расширение для конфигурации, которое умеет само подтверждать легальность обновления, дожидаться выполнения обработчиков и закрывать 1с Предприятие.  Выполнено это в виде расширения что бы не вскрывать типовые БУХи . Со вскрытой конфигурацией, в частности  ЗУП 3, это расширение тоже работает, т.к. используются точки входа и выхода типовых процедур.

В итоге, собрав все в одну разработку и дополнив ее механизмом  отрубания пользователей от текущей базы через COM соединение с агентом сервера 1С перед стартом обновления, получил полностью 100% автоматический механизм обновления типовых баз 1С.   Теперь процесс обновления выглядит так :

1)  В обработке обновления выбираем тип базы ( Бухгалтерия ) и номер потока  (все базы в конфе обслуживания уже поделены на потоки )

2) Нажимаем кнопку "Выполнить"  

и ...  ложимся спать.    Все базы выбранного потока обновлены, Легальность обновления подтверждена, Обработчики обновления выполнены. 

Что делает обработка автоматически сама:

1) Определяет текущий релиз базы

2) Скачивает с сайта 1с файл с информацией об обновлении данного типа конфигурации. (Бух, ЗУП, УТ...)

3) Проверяет наличие в каталоге конфигураций доступного обновления из списка.

4) Если нужного обновления нет, скачивает его автоматически с сайта 1С (нужен логин и пароль для доступа на сайт 1С) и размещает его в каталог обновлений.

5) Отрубает на сервере 1С все сеансы пользователей от текущей базы

6) Запускает обновление конфигурации и базы данных.

7) Если обновились до последнего релиза и больше обновлять не надо, запускает 1С в режиме Предприятия для подтверждения легальности обновления и выполнения отложенных обработчиков обновления

и так по кругу пока не кончится список баз. 

Расширение подтверждения легальности протестировано на БП 3 релиз 3.0.69.32 , ЗУП 3 релиз 3.1.9.159 работающих на MS-SQL сервере. Для файловых вариантов баз тоже должно работать, но мною не тестировалось, т.к. у нас таких баз нет. 

Не сомневаюсь что для Торговли, Розницы и других типовых конфигураций от 1С это расширение будет работать. 

Дополнительно прилагаю модуль обработки по автоматическому обновлению информационных баз, в котором реализованы все вышеописанные автоматические процедуры обновления. Его с легкостью можно адаптировать под собственные нужды и вариант работы (только для программистов) т.к. написан на родном языке 1С.

Данная обработка работает в самописной конфигурации по обслуживанию  информационных баз. 

P.S. Да я знаю про "Обновлятор". В бесплатной версии он не работает с таким количеством баз, были мысли приобрести полную версию, но было интересно решить данную задачу самому, т.к. половина функционала уже было в нашей базе обслуживания.

 

Кусок основного кода из обработки обновления

        // Прверка наличия обновлений
        МассивОбновлений = ВыполнитьЗагрузкуСпискаОбновлений(ПараметрыComБазы.ТекущаяВерсия);
        Если МассивОбновлений = Неопределено Тогда 
            Возврат;
        КонецЕсли;     

        КоличествоДоступныхОбновлений = МассивОбновлений.Количество(); 
        Если КоличествоДоступныхОбновлений = 0 Тогда
            Если ОбновлениеБыло Тогда
                СообщитьПользователю(НСтр("ru = 'Обработчики обновления информационной базы.'"));
                КомандаПакетногоОбновления = СтрШаблон("""%1"" ENTERPRISE %2 /RunModeManagedApplication",
                ПараметрыComБазы.ПутьКПлатформе, СтрокаСоединения);
                ЗапуститьПриложение(КомандаПакетногоОбновления, , Истина, КодВозврата);
                Если КодВозврата = 0 Тогда
                    СообщитьПользователю(НСтр("ru = 'Обработчики выполнены.'"));
                Иначе
                    СообщитьПользователю(НСтр("ru = 'Ошибка при выполнении обработчиков.'"));
                 //   Возврат;
                КонецЕсли;
            КонецЕсли; 
            
            СообщитьПользователю(СтрШаблон(НСтр("ru = 'Текущая версия: %1. Обновление не требуется.'"), ПараметрыComБазы.ТекущаяВерсия));
            Прервать;
        КонецЕсли;
        
        ЗагруженноеОбновлениеНайдено = Ложь;
        Для Сч = 1 По КоличествоДоступныхОбновлений Цикл
            ВерсияДляОбновления = МассивОбновлений[КоличествоДоступныхОбновлений - Сч]; 
            ФайлОбновленияВерсии = СтрШаблон("%1\%2\%3\1cv8.cfu", ПараметрыОбновления.КаталогФайловОбновления, ТипКонфигурации, ВерсияДляОбновления.Версия);
            ФайлОбновленияВерсииОбъект = Новый Файл(ФайлОбновленияВерсии);
            Если ФайлОбновленияВерсииОбъект.Существует() Тогда
                ЗагруженноеОбновлениеНайдено = Истина;
                СообщитьПользователю(СтрШаблон(НСтр("ru = 'Текущая версия: %1. Доступна для обновления версия: %2.'"), 
                    ПараметрыComБазы.ТекущаяВерсия, ВерсияДляОбновления.Версия));
                Прервать;
            КонецЕсли;
        КонецЦикла;
        
        // Загрузка файлов обновления
        Если Не ЗагруженноеОбновлениеНайдено Тогда
            ВерсияДляОбновления = МассивОбновлений[КоличествоДоступныхОбновлений - 1]; 
            ФайлОбновленияВерсии = СтрШаблон("%1\%2\%3\1cv8.cfu", ПараметрыОбновления.КаталогФайловОбновления, ТипКонфигурации, ВерсияДляОбновления.Версия);
            СообщитьПользователю(СтрШаблон(НСтр("ru = 'Текущая версия: %1. Доступна для загрузки версия: %2 (Поставщик %3, размер %4).'"), 
            ПараметрыComБазы.ТекущаяВерсия, ВерсияДляОбновления.Версия, ВерсияДляОбновления.Поставщик, ВерсияДляОбновления.РазмерФайлаОбновления));
            Если НЕ ПолучитьФайлыОбновлений(ТипКонфигурации, ВерсияДляОбновления) Тогда
                Возврат;
            КонецЕсли;
        КонецЕсли;
        
        
        // Отрубим сеансы пользователей для серверной базы 
        Если ПараметрыПодключения.ВариантРаботыИнформационнойБазы = 1 Тогда
            Попытка
                СообщитьПользователю(НСтр("ru = 'Отрубаем все сеансы пользователей с информационной базой.'"));
                Коннектор = Новый COMОбъект("v83.COMConnector");
                Если СтрНайти(ИмяСервера1СПредприятия,":")>0 Тогда    // Если используется не стандартный порт 1541 или он передан в имени сервера, то в номере порта "1" надо заменить на "0"
                      Конект = Лев(ИмяСервера1СПредприятия,СтрДлина(ИмяСервера1СПредприятия)-1) + "0";
                Иначе
                    Конект = строка(ИмяСервера1СПредприятия);
                КонецЕсли; 
                Агент = Коннектор.ConnectAgent(Конект);

                Кластеры = Агент.GetClusters();
                Для каждого Кластер из Кластеры Цикл
                    Агент.Authenticate(Кластер,,);
                    Процессы = Агент.GetWorkingProcesses(Кластер);
                    
.......

.......

        
        // Создание резервной копии выгрузкой DT
        // В нашем варианте нет смысла в использовании
                    //СообщитьПользователю(СтрШаблон(НСтр("ru = 'Создание резервной копии информационной базы (%1).'"), ИмяВременногоФайла));
                    //КомандаПакетногоАрхивирования = СтрШаблон("""%1"" CONFIG %2 /DumpIB %3 /OUT %4 -NoTruncate",
                    //ПараметрыComБазы.ПутьКПлатформе, СтрокаСоединения, СтрокаДампа, СтрокаЛогов);
                    //ЗапуститьПриложение(КомандаПакетногоАрхивирования, , Истина, КодВозврата);
                    //Если КодВозврата = 0  Тогда
                    //    СообщитьПользователю(НСтр("ru = 'Резервная копия информационной базы успешно создана.'"));
                    //Иначе
                    //    СообщитьПользователю(НСтр("ru = 'Ошибка при создании резервной копии информационной базы.'"));
                    //    Возврат;
                    //КонецЕсли;
        
        // Обновление информационной базы                                                                                                                                                              
        СообщитьПользователю(НСтр("ru = 'Обновление информационной базы.'"));
        КомандаПакетногоОбновления = СтрШаблон("""%1"" CONFIG %2 /UpdateCfg ""%3"" /UpdateDBCfg /DisableStartupMessages /OUT %4 -NoTruncate",
        ПараметрыComБазы.ПутьКПлатформе, СтрокаСоединения, ФайлОбновленияВерсии, СтрокаЛогов);
        ЗапуститьПриложение(КомандаПакетногоОбновления, , Истина, КодВозврата);
        Если КодВозврата = 0 Тогда
            СообщитьПользователю(НСтр("ru = 'Информационная база успешно обновлена.'"));
            ОбновлениеБыло = Истина;
        Иначе
            СообщитьПользователю(НСтр("ru = 'Ошибка при обновлении информационной базы.'"));
            Возврат;
        КонецЕсли;
        
    КонецЦикла;
    
КонецПроцедуры

 

 

Другие мои публикации:

1) Прибыль от продаж в УТ без закрытия месяца

2) УТ 11. Автоматическое перемещение товаров между складами и организациями

3) Исправляем пересортицу на 41 счете, легко и быстро. Для Бухгалтерии 3.0 и Бухгалтерии 2.0

4) Отчет по уплаченным налогам с разбивкой по бюджетам и ИФНС

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом в течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

Скачать файлы

Наименование Файл Версия Размер
Расширение "Легальность" за $m

.cfe 10,41Kb
4
.cfe 10,41Kb 4 Скачать
Модуль обработки

.txt 55,91Kb
4
.txt 55,91Kb 4 Скачать

1.0 0 1500 руб.

Моментальная
доставка


0 1000 руб.

Специальные предложения

Лучшие комментарии
5. Техподдержка 08.05.19 14:19
(4) Так вот как раз "Кто то должен поставить галочку и начать ОК" меня и не устраивало при обновлении 80 баз. Мое расширение активируется только при первом запуске в режиме Предприятия после обновления конфигурации, перехватывает событие подтверждения легальности, подтверждает его и запускает процедуры обновления. И все это происходит автоматически и без участия человека. А потом закрывает 1С Предприятие.
Остальные комментарии
В избранное Подписаться на ответы Сортировка: Древо свернутое
1. Sedaiko 405 08.05.19 13:30 Сейчас в теме
я без расширений все провернул https://infostart.ru/public/1041193/
просто в после обновления и принятия изменений запустил внешнюю обработку в командной строке (через пользователя с отключеной защитой от опасных действий) с вызовом процедуры глобального модуля "обновить" и последующем закрытием формы. И ни какого расширения не нужно.
2. Sedaiko 405 08.05.19 13:31 Сейчас в теме
Кстати, для управление кластером есть целый модуль в БСП
9. Mx00 234 26.07.19 20:11 Сейчас в теме
я остановился на программе Обновлятор-1С, не бесплатно, но экономит кучу времени, плюс всякие регламентные процедуры делает и отчет высылает. Программа поддерживается разработчиком и можно попробовать попросить сделать настройки под себя, в общем рекомендую :-)
davdykin; wolfalan; +2 Ответить 2
14. Mx00 234 30.07.19 03:02 Сейчас в теме
Спросил автора Обновлятора 1С - настройка называется "Не выполнять обработчики обновления", т.е. по умолчанию всё выполняется и только по желанию пользователя можно отключить все процессы после обновления.
https://helpme1c.ru/obnovlyator-1s-chto-takoe-sluzhebnye-dejstviya-v-baze-zachem-oni-nuzhny-i-v-kakix-sluchayax-i-kak-ix-luchshe-otklyuchit
wolfalan; +1 Ответить
15. Техподдержка 30.07.19 07:32
Спасибо что заморочился с архивом.
Такую настройку "Не выполнять обработчики обновления" видел и она доступна в бесплатной версии. И при обновлении бесплатным Обновлятором обработчики тоже выполняются, но почему то после обновления через Обновлятор с выполнением обработчиков, база при первом запуске просит подтвердить легальность получения обновлений. Неужели это "фишка" бесплатной версии ?
Надо мне проверить на своем бесплатном Обновляторе какую нибудь базу еще раз.
16. sinops 18.11.19 23:24 Сейчас в теме
В последних релизах можно запускать с параметром /C"ВыполнитьОбновлениеИЗавершитьРаботу"
база стартует, сама автоматом проставляет легальность обновления и выполняет обработку обновления .
20. Техподдержка 01.04.20 11:06
Извини, но нет. Я привык что мой труд хоть сколько то но стоит, какие то жалкие 69 руб не ради наживы.
Оставьте свое сообщение

См. также

SALE! 50%

PowerTools Промо

Универсальные обработки Администрирование данных 1С Поиск данных Распределенная БД (УРИБ, УРБД) Сервисные утилиты Обработка документов Обработка справочников Чистка базы Консоль запросов Прочие инструменты разработчика Структура метаданных v8 v8::УФ 1cv8.cf Россия Платные (руб)

Универсальный инструмент программиста для администрирования конфигураций. Сборник наиболее часто используемых обработок под единым интерфейсом.

2000 1000 руб.

14.01.2013    124799    634    0    

Штрихкод мне в Приход.

Оптовая торговля Розничная торговля Учет ТМЦ Ценообразование, анализ цен Сканер штрих-кода v8 Розница УУ Платные (руб)

Расширение для конфигурации Розница 2.3. Автоматическое и ручное создание и присвоение штрихкодов номенклатуре непосредственно в документе Поступления товаров. Поддерживается ввод штрихкода через сканер.

1500 руб.

30.03.2021    1771    4    6    

Платформа 8.3.18 Обновление ИБ в пакетном режиме поломалось? Решено

Администрирование СУБД v8 Бесплатно (free)

Уже давно работаем с большим количеством ИБ и обновляем, естественно, в пакетном режиме, но с переходом на новую платформу 8.3.18.1208 этот пакетный режим поломался. Стало появляться окно конфигуратора и спрашивать вопросы, раньше такого не было. Решение найдено.

24.12.2020    4920    VPanin56    14    

Загрузка продаж из R-Keeper 7 в 1С: Бухгалтерию 3.0

Обмен данными 1С v8 v8::БУ БП3.0 Рестораны, кафе и фаст-фуд БУ Абонемент ($m)

Пример автоматизации переноса данных о продажах из системы R-Keeper 7 в типовую Бухгалтерию 3. И не просто продаж, а еще и разбирание проданной продукции на составляющие ингредиенты и все это в рамках типовой Бухгалтерии. Минимум трудозатрат - максимум результата. Погнали знакомиться с тем, что вышло ...

1 стартмани

28.11.2019    4651    14    VPanin56    25    

Прибыль от продаж в УТ и КА без закрытия месяца Промо

Оптовая торговля Учет доходов и расходов Оптовая торговля Ценообразование, анализ цен Финансовые Управление торговлей v8 УТ11 КА2 УУ Платные (руб)

Данный отчет позволяет сформировать и оценить среднюю прибыль от продаж товаров в УТ 11 и КА 2 без закрытия месяца. Что не возможно сделать типовыми отчетами, т.к. себестоимость товаров рассчитывается только при закрытии месяца. Позволяет быстро и эффективно оценить продажи какого товара приносят большую прибыль для организации, а какой товар менее прибыльный, а может, даже и в убыток торгуется.

2000 руб.

15.05.2019    17925    77    63    

Автоматическое массовое создание штрих кодов номенклатуры в Рознице

Обработка справочников v8 Розница Абонемент ($m)

Обработка предназначена для автоматического массового создания своих штрих кодов номенклатуре в конфигурации Розница

1 стартмани

30.10.2019    26482    12    VPanin56    6    

Замена счетов Учета, Дохода и Расхода в расходной накладной

Обработка документов v8 БП3.0 БУ Абонемент ($m)

Когда нужно поменять счета учета, дохода или расхода в  документе Расходная накладная, а строк много или лень делать это руками, то можно этот процесс немного упростить. 

1 стартмани

30.10.2019    5588    1    VPanin56    0    

УТ 11. Автоматическое перемещение товаров между складами и организациями

Обработка документов Закрытие периода Оптовая торговля Розничная торговля Учет ТМЦ Закрытие периода Оптовая торговля Розничная торговля Учет ТМЦ v8 v8::ОУ УТ11 УУ Платные (руб)

Менеджер забывает перемещать товар между складами, а в УТ отключен контроль остатков ? Бухгалтер готов застрелиться при закрытии месяца и выравнивании отрицательных остатков по складам и фирмам ? Используй автоматическое перемещение товаров.

2500 руб.

30.05.2019    10939    8    5    

Система хранения присоединенных файлов в томах на диске Промо

Сервисные утилиты Администрирование данных 1С v8 КА1 УПП1 Платные (руб)

Конфигурация Комплексная автоматизация 1.1 (и УПП 1.3 тоже) хранит файлы и изображения в справочнике Хранилище дополнительной информации в реквизите Хранилище типа ХранилищеЗначений. Та же история с ВложениямиЭлектроннойПочты. Но при этом присоединенные файлы в Электронном документообороте хранит в томах на диске. Эта доработка позволяет использовать стандартный механизм хранения файлов, изображений и вложений электронных писем в томах на диске. При этом можно разделить тома хранения по объектам конфигурации.

3500 руб.

10.11.2015    47624    69    49    

Отчет по уплаченным налогам с разбивкой по бюджетам и ИФНС

Бухгалтерские Налоговые v8 v8::БУ БП3.0 БУ НУ Платные (руб)

Отчет для БП 3.0 позволяет быстро узнать, в какую ИФНС и сколько перечислено налога.

1200 руб.

30.05.2019    10538    2    0    

Исправляем пересортицу на 41 счете, легко и быстро. Для Бухгалтерии 3.0 и Бухгалтерии 2.0

Обработка документов Учет ТМЦ Учет ТМЦ v8::БУ БП2.0 БП3.0 БУ Абонемент ($m)

В жизни так иногда случается, что в справочнике Номенклатуры неизвестным образом появляются дубликаты некоторых позиций номенклатуры. И однажды бухгалтер видит печальную картину в Анализе 41 счета - Оприходован один товар из справочника, а списывается  другой. Да, он точно так же называется и они оба имеют одинаковые Артикулы, но в системе это два разных элемента Справочника и ..... надо исправлять, говорит Бухгалтер. 

5 стартмани

14.05.2019    9885    16    VPanin56    4    

Версионирование регистров сведений (необъектных данных) - история изменений по версиям записей регистров сведений - ВНОД

Сервисные утилиты Журнал регистрации v8 v8::УФ 1cv8.cf Платные (руб)

ВНОД – отдельная (дополнительная) подсистема, которая построена на основе типовой подсистемы «Версионирование объектов». Предназначена для сохранения и анализа изменений независимых (периодических и непериодических) регистров сведений, с точностью до состава измерений, ресурсов и реквизитов записей.

2800 руб.

11.02.2019    13900    34    16    

Заполнение документа "Корректировка регистров" произвольными данными Промо

Закрытие периода Сервисные утилиты Закрытие периода v8 v8::СКД УНФ ERP2 УТ11 УУ Платные (руб)

Внешняя обработка, позволяющая произвольным образом заполнять документ "Корректировка регистров" Предназначена для использования в конфигурациях "Управление торговлей 11", "Управление небольшой фирмой", "ERP Управление предприятием", а также в других конфигурациях, в состав которых входит библиотека стандартных подсистем (БСП) версии 2.2+ и указанный выше документ.

1000 руб.

13.07.2015    33812    133    12    

Сжатие таблиц SQL (УФ)

Сервисные утилиты Администрирование данных 1С v8::УФ 1cv8.cf Платные (руб)

Обработка позволяет уменьшить размер базы данных SQL путем сжатия её таблиц. Разработана для работы в управляемых формах.

1000 руб.

14.04.2017    21203    8    4    

Управление присоединенными файлами

Сервисные утилиты v8 v8::УФ 1cv8.cf Платные (руб)

Комбинированное хранение файлов в базе и на жестком диске

5000 руб.

18.01.2017    43658    2    5    

Версионирование объектов для Альфа-авто, ред 4 и 5.

Сервисные утилиты Журнал регистрации Управление услугами и сервисом Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Автомобили, автосервисы УУ Платные (руб)

Подсистема версионирования объектов для конфигураций Рарус: Альфа-авто на базе типовой подсистемы от 1С. Позволяет хранить историю изменений документов и справочников, кто, что, когда и какие данные изменял, а так же вернуться к предыдущим версиям объекта.

4000 руб.

03.09.2016    31430    23    17    

Альфа-Ника:Администратор - конфигурация для управления базами 1С:Предприятие 8

Сервисные утилиты v8 1cv8.cf Россия Платные (руб)

Конфигурация под Такси предназначена в основном для автоматического обновления и автоматической генерации большого количества баз на основе типовых конфигураций 1С:Предприятия 8. Главная цель создания этой конфигурации - дать максимально простой и понятный инструмент для обновления большего количества баз. В результате получился абсолютно непохожий на другие подобные конфигурации инструмент. Он реально работает на нескольких серверах и заместил другие подобные конфигурации, в том числе ранее скачанные с Инфостарта. Управляемые базы могут быть как в файловом, так и клиент-серверном варианте. Добавлена возможность на прямую скачивать новые релизы с сервера обновлений фирмы 1С http://downloads.v8.1c.ru/tmplts.

2000 руб.

05.06.2016    15508    0    1    

Подсистема "Корректировка движений документов"

Обработка документов Универсальные обработки Сервисные утилиты v8 v8::УФ 1cv8.cf Платные (руб)

Универсальная подсистема, позволяющая просматривать и корректировать движения документа по учетным регистрам конфигурации прямо из его формы. Подсистема актуальна для тех конфигураций, в которых подобный функционал не предусмотрен (например, типовая конфигурация "Управление торговлей 11").

1000 руб.

10.03.2016    23201    43    31    

"2iS:Администратор" - центр управления инфраструктурой 1С

Сервисные утилиты Архивирование (backup) Журнал регистрации v8 1cv8.cf Платные (руб)

Без изменения конфигураций инфобаз Вы получаете: - Из единой точки регистрацию и обслуживание баз, серверов 1С и СУБД - Мониторинг и контроль любых заданий - Контроль за аппаратными ресурсами и анализ производительности - Централизованные контроль за версиями и авто обновления конфигураций - Отчеты по работе SQL и многое другое... Как следствие: - Снижение затрат на ИТ-поддержку - Снижение влияния “человеческого фактора” - Улучшение качества обслуживания - Увеличение производительности Ваших систем При покупке бесплатно установим программу и в режиме демонстрации настроим любую одну из заявленных функций.

20000 руб.

05.03.2016    43464    8    25    

Обновление однотипных конфигураций, работа с SQL и другие регламентные операции

Сервисные утилиты Архивирование (backup) v8 1cv8.cf Россия Платные (руб)

Обновить 20 баз на 20 релизов? - Легко! Конфигурация для последовательного обновления однотипных конфигураций баз на произвольное количество релизов обновлений. Работает как со списком баз справочника, так и с произвольными файловыми базами из папки на диске. Архивирование баз по расписанию. Редактирование списка баз пользователей. Работа с SQL. (Обновление 21.03.2016).

8800 руб.

01.02.2016    28451    3    27    

[Расширения] Динамическое управление видимостью и доступностью элементов форм (УФ) (8.3.6+)

Сервисные утилиты Универсальные обработки Работа с интерфейсом v8 v8::УФ 1cv8.cf Платные (руб)

Механизм «Динамическое управление доступом к элементам форм объектов 1С8» предназначен для обеспечения возможности оперативного управления видимостью и доступностью элементов форм документов и справочников продуктов фирмы «1С» «1С:Предприятие 8». Решение универсальное, встраивается в любую конфигурацию с минимальными доработками, что позволяет без проблем обновлять типовые решения.

5000 руб.

14.01.2016    41901    11    12