Универсальная Форма для внешней печатной формы документа

Публикация № 1058808

Разработка - Печать - Печатные формы документов

ПечатьДокументов Печать ОбщаяФорма Документ Справочник УправлениеПечатью ТабличныйДокумент ПечатнаяФорма Отладка Программирование КоллекцияПечатныхФорм велосипед ВнешняяОбработка СведенияОВнешнейОбработке

9
Универсальная форма вызова процедуры "Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыПечати)", чтобы каждый раз не изобретать велосипед! Реализация протестирована на 1С 8.3.12.1714 (x64).

Warning

Данная статья не претендует на оригинальность и не является конечным решением.

Подходы решения задач и примеры программного кода несут исключительно обучающий характер.

 

Часто возникает ситуация, когда нужно взять стандартную печатную форму конфигурации и модифицировать ее. В таком случае ее делают внешней и уже потом модифицируют, добавляя некоторую приставку к представлению команды печати.

Но сама по себе процедура выноса печатной формы во внешнюю, почти всегда несколько проблематична и сопровождается  изобретением очередного велосипеда для вызова стандартной процедуры печати,чтоб ее отлаживать во время модификации:

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыПечати) Экспорт
	
	ПечатнаяФорма = УправлениеПечатью.СведенияОПечатнойФорме(КоллекцияПечатныхФорм, "DefaultMXL");
	Если ПечатнаяФорма <> Неопределено Тогда
		ПечатнаяФорма.ТабличныйДокумент = ПолучитьТаблиныйДокументПоУмолчанию(МассивОбъектов, ОбъектыПечати);
	КонецЕсли;
	
КонецПроцедуры

Думаю не только мне надоело изобретать велосипеды для ее вызова.

Это вдохновило меня на разработку следующей стандартной формы:

Программная реализация:


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	// получим сведения о внешней обработке
	СведенияОВнешнейОбработке = РеквизитФормыВЗначение("Объект").СведенияОВнешнейОбработке();
	
	// загрузим все идентификаторы и представления команд в таблицу формы
	ТаблицаКоманд.Загрузить(СведенияОВнешнейОбработке.Команды);
	// заполним список выбора команд внешней обработки
	Элементы.КомандаПечати.СписокВыбора.ЗагрузитьЗначения(СведенияОВнешнейОбработке.Команды.ВыгрузитьКолонку("Представление"));
	
	// установим тип списка значений - что печтает эта форма
	ТипыОбъектовПечати = СтрЗаменить(СтрСоединить(СведенияОВнешнейОбработке.Назначение, ","), ".", "Ссылка.");
	ОбъектыПечати.ТипЗначения = Новый ОписаниеТипов(ТипыОбъектовПечати);
	
	// если эту форму открыли из формы документа - заполним документ и выбранную команду печати
	Если Параметры.ОбъектыНазначения <> Неопределено Тогда
		ОбъектыПечати.ЗагрузитьЗначения(Параметры.ОбъектыНазначения);
		КомандаПечати = СведенияОВнешнейОбработке.Команды.Найти(Параметры.ИдентификаторКоманды).Представление;
	ИначеЕсли ТаблицаКоманд.Количество() = 1 Тогда
		КомандаПечати = ТаблицаКоманд[0].Представление;
	КонецЕсли;
	
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПодготовитьКоллекциюПечатныхФорм(Знач Идентификатор)
	
	Результат = Новый ТаблицаЗначений;
	Для Каждого ИмяКолонки Из УправлениеПечатьюКлиентСервер.ИменаПолейКоллекцииПечатныхФорм() Цикл
		Результат.Колонки.Добавить(ИмяКолонки);
	КонецЦикла;
	ПечатнаяФорма = Результат.Добавить();
	ПечатнаяФорма.ИмяМакета = Идентификатор;
	ПечатнаяФорма.ИмяВРЕГ = ВРег(Идентификатор);
	ПечатнаяФорма.Экземпляров = 1;
	Возврат Результат;
	
КонецФункции

&НаСервере
Функция СформироватьИЗаполнитьКоллекциюПечатныхФорм()
	// получим выбранный идентификатор
	ИдентификаторКоманды = ТаблицаКоманд.Выгрузить().Найти(КомандаПечати).Идентификатор;
	// создадим новую коллекцию ПФ
	КоллекцияПечатныхФорм = ПодготовитьКоллекциюПечатныхФорм(ИдентификаторКоманды); // раньше была экспортной в УправлениеПечатью
	// установим новые парметры вывода по умолчанию
	ПараметрыВывода = УправлениеПечатью.ПодготовитьСтруктуруПараметровВывода();
	// выполним заполнение коллекции
	РеквизитФормыВЗначение("Объект").Печать(ОбъектыПечати.ВыгрузитьЗначения(), КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода);
	// вернем коллекцию на клиент
	Возврат ОбщегоНазначения.ТаблицаЗначенийВМассив(КоллекцияПечатныхФорм);
	
КонецФункции

&НаКлиенте
Процедура ВыполнитьПечать(Команда)
	
	// проверим не забыли ли ввести все данные
	Если НЕ ОбъектыПечати.Количество() ИЛИ ПустаяСтрока(КомандаПечати) Тогда
		Возврат;
	КонецЕсли;
	
	КоллекцияПечатныхФорм = СформироватьИЗаполнитьКоллекциюПечатныхФорм();
	
	// подготовим параметры открытия общей формы ПечатьДокументов
	ПараметрыОткрытия = Новый Структура;
	ПараметрыОткрытия.Вставить("ПараметрыПечати", Неопределено);
	ПараметрыОткрытия.Вставить("КоллекцияПечатныхФорм", КоллекцияПечатныхФорм);
	ПараметрыОткрытия.Вставить("ПараметрКоманды", ОбъектыПечати.ВыгрузитьЗначения());
	
	// откроем форму
	ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия, ЭтаФорма);
	//ЭтаФорма.Закрыть();
	
КонецПроцедуры

 

Описание:

  • Гибкая реализация, которая подойдет для внешней печатной формы любого документа;
  • Поддерживает вызов из формы документа (вдруг нужно будет заполнять какие-то реквизиты из этой формы печати);
  • Для отображения табличного документа используется стандартная общая форма печати.

Зависимости:

  • Наличие БСП v3;
  • Управляемое приложение.

 

9

Специальные предложения

Лучшие комментарии
1. ildary 13.05.19 07:46 Сейчас в теме
Я бы поменял строку
Если Параметры.ОбъектыНазначения <> Неопределено Тогда

на
Если Параметры.Свойство("ОбъектыНазначения") И Параметры.ОбъектыНазначения <> Неопределено Тогда


чтобы обработку можно было открывать через Файл-Открыть


Ещё вопрос - скажите пожалуйста, для чего вы написали свою реализацию ПодготовитьКоллекциюПечатныхФорм(), когда такая функция есть в общем модуле УправлениеПечатью? Для совместимости со старыми БСП?


P.S. За образец большое спасибо, схоронил себе на будущее.
Остальные комментарии
Избранное Подписка Сортировка: Древо
1. ildary 13.05.19 07:46 Сейчас в теме
Я бы поменял строку
Если Параметры.ОбъектыНазначения <> Неопределено Тогда

на
Если Параметры.Свойство("ОбъектыНазначения") И Параметры.ОбъектыНазначения <> Неопределено Тогда


чтобы обработку можно было открывать через Файл-Открыть


Ещё вопрос - скажите пожалуйста, для чего вы написали свою реализацию ПодготовитьКоллекциюПечатныхФорм(), когда такая функция есть в общем модуле УправлениеПечатью? Для совместимости со старыми БСП?


P.S. За образец большое спасибо, схоронил себе на будущее.
2. Eret1k 607 13.05.19 22:18 Сейчас в теме
(1)
для чего вы написали свою реализацию ПодготовитьКоллекциюПечатныхФорм()

В последней БСП она перестала быть экспортной.
4. e-lexa 153 15.09.19 10:18 Сейчас в теме
(2)
УправлениеПечатьюКлиентСервер.ИменаПолейКоллекцииПечатныхФорм() тоже перестала быть экпортной в последних релизах.
3. ah7777777 398 17.05.19 06:47 Сейчас в теме
На бух 3.0.70.39 не сработало. Видимо писалось для устаревшей БСП
&НаСервереБезКонтекста
Функция ПодготовитьКоллекциюПечатныхФорм(Знач Идентификатор)
	
	Результат = Новый ТаблицаЗначений;
	Для Каждого ИмяКолонки Из УправлениеПечатьюКлиентСервер.ИменаПолейКоллекцииПечатныхФорм() Цикл
		Результат.Колонки.Добавить(ИмяКолонки);
	КонецЦикла;
	ПечатнаяФорма = Результат.Добавить();
	ПечатнаяФорма.ИмяМакета = Идентификатор;
	ПечатнаяФорма.ИмяВРЕГ = ВРег(Идентификатор);
	ПечатнаяФорма.Экземпляров = 1;
	Возврат Результат;
	
КонецФункции
Показать


Переделал:
&НаСервереБезКонтекста
Функция ПодготовитьКоллекциюПечатныхФорм(Знач Идентификатор)
	
	Результат =УправлениеПечатью.ПодготовитьКоллекциюПечатныхФорм(Идентификатор);

	//ПечатнаяФорма = Результат.Добавить();
	//ПечатнаяФорма.ИмяМакета = Идентификатор;
	//ПечатнаяФорма.ИмяВРЕГ = ВРег(Идентификатор);
	//ПечатнаяФорма.Экземпляров = 1;
	Возврат Результат;
	
КонецФункции
Показать
Оставьте свое сообщение

См. также

Реализация интерактивного редактирования макета Microsoft WORD из 1С для пользователя 9

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Печатные формы документов Практика программирования Разработка

Пользователь сам сможет редактировать макет Microsoft Word и в последствии использовать его для печати документа, справочника и т.д. Реализация протестирована на 1С 8.3.12.1714 (x64).

23.04.2019    2405    Eret1k    6       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    46499    bugtester    43       

БСП. Настраиваемый комплект документов. Внешние печатные формы 96

Статья Программист Нет файла v8::СПР v8::УФ ЗУП3.x Бесплатно (free) Печатные формы документов

В демо-конфигурации "БСП" есть пример реализации механизма "Настраиваемый комплект документов", использующий встроенные печатные формы. Эта статья - развитие темы в сторону использования в своей обработке других внешних печатных форм.

09.06.2017    18345    WhiteOwl    12       

Подход к организации печати одного макета документа из обычной и управляемой форм документа (интерфейс Такси) 32

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Универсальные печатные формы Печатные формы документов Математика и алгоритмы

В статье описывается подход к реализации печати одного макета из управляемой и обычной формы документа. Описанная методика близка к преподаваемой в учебных центрах 1С.

10.10.2013    34433    RailMen    9       

Видео. Автозаполняемые шаблоны документов в «1С:Документооборот 8» 16

Статья Программист Нет файла v8 ДО Windows Бесплатно (free) Печатные формы документов

В этом видеокурсе будет рассмотрен пример подготовки автозаполняемых шаблонов документов в «1С:Документооборот». Автозаполняемые шаблоны могут существенно сократить время пользователей на подготовку печатных форм типовых документов за счет автоматического создания файлов с уже подставленными данными из карточки документа.

13.11.2012    19159    ИТ-Терминал    3       

Подписанты - "Указание в первичных документах подписывающих лиц" 7

Статья Системный администратор Программист Нет файла v8 КА1 УПП1 БУ НУ УУ Бесплатно (free) Печатные формы документов

Хотелось бы обратить внимание, добавленный функционал. УПП Версия 1.3.29 и КА Версия 1.1.25 Указание в первичных документах подписывающих лиц, т.е. кто подписывает, на основании чего.

01.10.2012    25814    Константин С.    6       

Решение: Универсальный счет с логотипом, печатью и отправкой в формате PDF 22

Отчеты и формы Бухгалтер Пользователь Архив с данными v8 КА1 УТ10 Россия Оптовая торговля Бесплатно (free) Печатные формы документов

Внешняя печатная форма счета для Комплексная автоматизация, редакция 1.1 и Управление торговлей, редакция 10.3 с использованием дополнительного регистра сведений ЛоготипыИПечатиОрганизаций и возможностью оправки по email как PDF-вложение

08.08.2012    16069    260    Abadonna    11       

Сканируем без сканера или MXL to JPG 137

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Печатные формы документов Внешние источники данных Универсальные функции

Хотите конвертировать документы в формат изображения менее чем за минуту, не имея сканера? Тогда эта статья для вас.

24.05.2012    29782    shakmaev    47       

Простой способ экономии бумаги при работе с типовыми конфигурациями на примере "Бухгалтерии предприятия" 2.0 33

Статья Программист Нет файла v8 БП2.0 Россия Бесплатно (free) Печатные формы документов

Предлагается простая альтернатива разработке дополнительных печатных форм, если стоит задача разместить на одном листе 2 экземпляра печатной формы

09.05.2012    14830    mrd2008    11       

Печать на больничных бланках 19

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 УПП1 Управление персоналом (HRM) Бесплатно (free) Печатные формы документов Внешние источники данных

Печатная форма для печати на больничных листках с использованием "OpenOffice Writer". Применяется для УПП. Печатается из документа "Начисление по больничному листу", либо как внешняя обработка.

09.08.2011    9281    153    ialex2008    19       

Печатная форма КМ-3 для Управления торговлей 10.3 12

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 УТ10 Кассовые операции Бесплатно (free) Печатные формы документов

Внешняя печатная форма Акта возврата денежных сумм для Управления торговлей 10.3, подключается к Расходному кассовому ордеру

16.06.2011    6093    205    warbird88    4       

Акт выполненных работ за поставщика 14

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 УТ10 Россия БУ Производство готовой продукции (работ, услуг) Бесплатно (free) Печатные формы документов

Акт выполненных работ за поставщика. Печатная форма для документа "Поступление товаров, услуг"

09.02.2011    11831    336    antowka    4       

Сканирование, сохранение и печать документов 29

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Печатные формы документов Сканер штрих-кода

Сканирование с использованием WIA, хранение в справочнике "Хранилище дополнительной информации" и печать из документов и справочников.

01.02.2011    26897    596    anig99    16       

Внешние печатные формы М-2, М-2а 2

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 КА1 БП2.0 УПП1 Россия БУ Бесплатно (free) Печатные формы документов

Стандартные печатные формы. Модули без паролей. Могут использоваться как обработки (удобно для отладки) и могут как внешние печатные формы. Делалось под КА, скорее всего подойдет и для БП.

12.01.2011    4395    136    SergN77    1       

Внешние печатные формы кадровых документов Т-6, Т-6а 3

Отчеты и формы Бухгалтер no Внешняя обработка (ert,epf) v8 КА1 ЗУП2.5 Россия Управление персоналом (HRM) Бесплатно (free) Печатные формы документов

Стандартные печатные формы. Модули без паролей. Могут использоваться как обработки (удобно для отладки) и могут как внешние печатные формы. Делалось под КА, скорее всего подойдет и для ЗУП.

12.01.2011    4073    151    SergN77    7       

Трудовой договор для ЗУП 2.5 31

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 ЗУП2.5 Россия Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Печатные формы документов

Внешняя печатная форма Трудового договора для ЗУП2.5, подключаемая типовым механизмом внешних печатных форм к справочнику Сотрудники.

23.12.2010    31851    1764    milov.aleksey    17       

Справка А и Б 2

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 УПП1 Россия БУ Оптовая торговля Бесплатно (free) Печатные формы документов

Справка А и Б для УПП 8.1 Добавлена возможность выбора подписывающего лица от продавца... правда, есть некоторые "корявые" аспекты, должность вводится руками...

13.12.2010    5150    80    spyryty-santyum    4       

ТОРГ-2 для документа "Возврат товаров от покупателя" (УПП) 12

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 УПП1 Учет ТМЦ Бесплатно (free) Печатные формы документов

ТОРГ-2 модерн, выводится на основании документа "Возврат товаров от покупателя".

07.12.2010    5161    183    spyryty-santyum    6       

АЦРК: Акт списания материалов для БП 2.0, БП 1.6 (Требование-накладная и Отчет производства за смену) - форма 0504230 15

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 БП1.6 Россия БУ Учет ТМЦ Бесплатно (free) Печатные формы документов

Внешняя печатная форма "Акт списания материалов" для конфигурации БП 1.6 подключается к документам "ТребованиеНакладная" и "ОтчетПроизводстваЗаСмену". Печатная форма предназначена для использования с обработкой "Актив-ИТ: Подписи".

28.11.2010    18704    230    acrk    10       

Ручная запись версии объекта (для снеговика) 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Документооборот и делопроизводство Бесплатно (free) Печатные формы документов Универсальные функции

Печатная форма для УПП 1.3.6.1 и алгоритм создания для любых других конфигураций с существующей системой версионирования.

07.11.2010    14395    28    anig99    1       

Да, еще одна ТТН (1-Т) с сохранением 46

Отчеты и формы no Внешняя обработка (ert,epf) v8 УТ10 Россия Учет ТМЦ Бесплатно (free) Печатные формы документов

Внешняя печатная форма ТТН для УТ 10.3 сохраняет введенных водителей во внешний файл в каталоге базы, что позволяет без изменений в базе вести список водителей и параметров автомобилей. Ориентирован на файловую базу.

28.10.2010    20611    646    lazy    24       

Печатные формы для некоторых кадровых документов 8.1 ЗУП 2.5 14

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 ЗУП2.5 Россия Управление персоналом (HRM) Бесплатно (free) Печатные формы документов

Печатные формы для кадровых документов "ОплатаПраздничныхИВыходныхДнейОрганизаций" и "ОплатаСверхурочныхЧасов" Самый новый вариант, все вылизано до запятой. :-) Спасибо кадровикам.

19.05.2010    6477    83    Sasha_1200    1       

Акт выполненных работ за поставщика 38

Отчеты и формы no Внешняя обработка (ert,epf) v8 БП2.0 БУ Производство готовой продукции (работ, услуг) Бесплатно (free) Печатные формы документов

Акт выполненных работ за поставщика. Печатная форма для документа "Поступление товаров, услуг".

11.05.2010    19267    558    SvetaTsp    26       

Печать акта доработки на основании документа "Списание ТМЦ" 2

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 БУ Бесплатно (free) Печатные формы документов

Многие производственные фирмы на ряду со "Списанием ТМЦ" оформляют и "Акт доработки", который бухгалтер подшивает вместе с накладной и счет-фактурой на реализацию товаров.

07.04.2010    7509    64    d_vit    2       

Возврат товара поставщику, форма Торг-2 сжатая 4

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 УТ10 Россия БУ УУ Учет ТМЦ Бесплатно (free) Печатные формы документов

Акт об установленном расхождении по количеству и качеству при приемке товарно-материальных ценностей. Форма ужата для печати на 2 стр.

25.03.2010    19344    230    Altez    9       

Формы Т-11, Т-11а 31

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 ЗУП2.5 Зарплата Бесплатно (free) Печатные формы документов

Внешние подключаемые печатные формы Т-11, Т-11а для ЗУП 8.

02.03.2010    16443    355    daulberg    9       

Внешняя печатная форма счет-фактуры и ТОРГ-12 для Бухгалтерии КОРП (Для филиалов) 5

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 Россия БУ Оптовая торговля Бесплатно (free) Печатные формы документов

Исправлено несоответствие печатной формы счета-фактуры и ТОРГ-12, выписываемого обособленным подразделением, действующему законодательству.

11.02.2010    5023    204    kns    4       

Внешняя печатная форма счета на оплату покупателю для УТ 10.3 31

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 УТ10 Бесплатно (free) Печатные формы документов

Создана на основе стандартной печатной формы с целью правки макета без изменения конфигурации.

21.01.2010    14958    1171    skorin    14       

Внешняя печатная форма к документу "Оплата сверхурочных часов" 28

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 ЗУП2.5 Россия БУ Зарплата Бесплатно (free) Печатные формы документов

Наряд на работу в праздничные, выходные дни и сверхурочные работы. На авторство не претендую, но, может, кому пригодится.

22.12.2009    4261    215    savant    1       

ТОРГ-12 в рублях для договоров в у.е. заточена под требования налоговиков (УТ 10.3.8.9) (с услугами) 6

Отчеты и формы no Внешняя обработка (ert,epf) v8 УТ10 Учет ТМЦ Бесплатно (free) Печатные формы документов

ТОРГ-12 в рублях для договоров в у.е. (с услугами) В продолжение темы http://infostart.ru/public/62917/ (Счет-фактура с тем же алгоритмом) и http://infostart.ru/public/62943/ (ТОРГ-12 без услуг с тем же алгоритмом). Берет данные в у.е. и пересчитывает их по курсу валюты на дату документа.

21.12.2009    9077    113    oleg1233    3       

ТОРГ-12 в рублях для договоров в у.е. заточена под требования налоговиков (УТ 10.3.8.9) (без услуг) 3

Отчеты и формы no Внешняя обработка (ert,epf) v8 УТ10 Учет ТМЦ Бесплатно (free) Печатные формы документов

ТОРГ-12 в рублях для договоров в у.е. (без услуг). В продолжение темы http://infostart.ru/public/62917/ (Счет-фактура с тем же алгоритмом) и http://infostart.ru/public/62947/ (ТОРГ-12 с услугами с тем же алгоритмом). Берет данные в у.е. и пересчитывает их по курсу валюты на дату документа.

21.12.2009    10336    142    oleg1233    6       

Счет-Фактура в рублях для договоров в у.е. заточена под требования налоговиков (УТ 10.3.8.9) 11

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 УТ10 БУ НУ НДС Бесплатно (free) Печатные формы документов

Счет-фактура в рублях для договоров в у.е. В продолжение темы http://infostart.ru/public/62917/ (ТОРГ-12 с услугами с тем же алгоритмом) и http://infostart.ru/public/62943/ (ТОРГ-12 без услуг с тем же алгоритмом) В бухгалтерии такая есть, а в УТ почему-то нету - берет данные в у.е. и пересчитывает их по курсу валюты на дату документа. 1С выпустило для УТ внешнюю (правда 283, которая без краткого наименования), ее-то и переделал под требования заказчика (ну и плюс 451 ее сделал).

20.12.2009    10059    195    oleg1233    6       

Внешняя печатная форма "Акт на передачу прав" 14

Отчеты и формы no Внешняя обработка (ert,epf) v8 УТ10 Россия Оптовая торговля Бесплатно (free) Печатные формы документов

Внешняя печатная форма "Акт на передачу прав" для Управление торговлей 8.1

05.12.2009    11111    284    ulen    5       

Внешняя печатная форма "Лицензионный договор" 35

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 ИТ-компания Россия Оптовая торговля Бесплатно (free) Печатные формы документов

Внешняя печатная форма для "Бухгалтерии предприятия" документа "Расходная накладная". Формирует печатную форму в том виде как ее предполагает фирма "1С".

18.11.2009    13405    299    solntsasvet    15       

Начисление материальной помощи. Приказ о поощрении работника (Форма Т-11) 23

Отчеты и формы Бухгалтер no Внешняя обработка (ert,epf) v8 ЗУП2.5 Россия БУ Зарплата Управление персоналом (HRM) Бесплатно (free) Печатные формы документов

В стандартной конфигурации ЗУП отсутствует Форма Т-11. Предлагается внешняя печатная форма, с описанием подключения и порядком расчета материальной помощи работнику предприятия.

03.11.2009    29767    480    daulberg    9       

Печатная форма Реализации с штрих-кодом для УТ 10.3 9

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 УТ10 Россия БУ УУ Оптовая торговля Бесплатно (free) Печатные формы документов

Печатная форма Реализации с штрих-кодом для УТ 10.3. Требует наличие компоненты (1CBARCOD.DLL).

30.10.2009    8568    287    andrew.ab    1       

Перемещение с выводом Штрихкода для УТ 10.3 8

Отчеты и формы no Внешняя обработка (ert,epf) v8 УТ10 Учет ТМЦ Бесплатно (free) Печатные формы документов

Печатная форма документа "Перемещение" с выводом штрихкода товарной позиции.

27.10.2009    9724    246    andrew.ab    13