Базомер (показывает количество записей в таблицах)

Публикация № 1070411

Администрирование - Администрирование данных 1С - Статистика базы данных

Количество записей таблицы таблицах Базомер объем базы

Базомер показывает количество записей во всех регистрах сведений, регистрах накопления, документах и справочниках.

Есть возможность сформировать список всех объектов метаданных и отметить нужные к замеру. Результат замера выводится в таблицу. Имеется возможность сортировки объектов по количеству записей и вывода результата в Excel. Обработка легко подключается к базе в качестве дополнительной глобальной обработки. Работает в небезопасном режиме (для чтения объектов метаданных без права администрирования).

Писалась для ERP 2.4.7.151, платформу 8.3.13.1644. Работает в ЗУП 3.1.9.159. По идее должна работать и в других конфигурациях на БСП.

 

&НаСервере
Процедура НачатьЗамерНаСервере()
	
	УстановитьПривилегированныйРежим(Истина);
	
	Для каждого ОбъектКЗамеру Из Объект.ВыбранныеОбъектыМетаданных Цикл
		Если Не ОбъектКЗамеру.Отметка Тогда
			Продолжить;
		КонецЕсли;
		
		ТипЗнчВыбранныйСтрокой 	= ОбъектКЗамеру.ПолноеИмяОбъектаМетаданных;
		МетаданныеКЗамеру 		= Метаданные.НайтиПоПолномуИмени(ТипЗнчВыбранныйСтрокой);
		
		Если СтрНайти(МетаданныеКЗамеру.ПолноеИмя(), "РегистрСведений") > 0 Тогда
			Попытка
				НаборЗаписей = РегистрыСведений[МетаданныеКЗамеру.Имя].СоздатьНаборЗаписей();
				НаборЗаписей.Прочитать();
				КоличествоЗаписей = НаборЗаписей.Количество();
				
				Строка = Объект.Результат.Добавить();
				Строка.ОбъектМетаданных 	= ОбъектКЗамеру.ПолноеИмяОбъектаМетаданных;
				Строка.КоличествоЗаписей	= КоличествоЗаписей;
			Исключение
				Сообщить("ОшибкаОбработкиОбъекта "+МетаданныеКЗамеру.ПолноеИмя()+" "+ОписаниеОшибки());
				Продолжить;
			КонецПопытки;
		КонецЕсли;
		
		Если СтрНайти(МетаданныеКЗамеру.ПолноеИмя(), "РегистрНакопления") > 0 Тогда
			Попытка
				НаборЗаписей = РегистрыНакопления[МетаданныеКЗамеру.Имя].СоздатьНаборЗаписей();
				НаборЗаписей.Прочитать();
				КоличествоЗаписей = НаборЗаписей.Количество();
				
				Строка = Объект.Результат.Добавить();
				Строка.ОбъектМетаданных 	= ОбъектКЗамеру.ПолноеИмяОбъектаМетаданных;
				Строка.КоличествоЗаписей	= КоличествоЗаписей;
			Исключение
				Сообщить("ОшибкаОбработкиОбъекта "+МетаданныеКЗамеру.ПолноеИмя()+" "+ОписаниеОшибки());
				Продолжить;
			КонецПопытки;
		КонецЕсли;
		
		Если СтрНайти(МетаданныеКЗамеру.ПолноеИмя(), "Документ") > 0 Тогда
			Попытка
				ВыборкаДокументов = Документы[МетаданныеКЗамеру.Имя].Выбрать();
				КоличествоЗаписей = 0;
				Пока ВыборкаДокументов.Следующий() Цикл
					КоличествоЗаписей = КоличествоЗаписей + 1;
				КонецЦикла;
				
				Строка = Объект.Результат.Добавить();
				Строка.ОбъектМетаданных 	= ОбъектКЗамеру.ПолноеИмяОбъектаМетаданных;
				Строка.КоличествоЗаписей	= КоличествоЗаписей;
			Исключение
				Сообщить("ОшибкаОбработкиОбъекта "+МетаданныеКЗамеру.ПолноеИмя()+" "+ОписаниеОшибки());
				Продолжить;
			КонецПопытки;
		КонецЕсли;

		Если СтрНайти(МетаданныеКЗамеру.ПолноеИмя(), "Справочник") > 0 Тогда
			Попытка
				ВыборкаСправочников = Справочники[МетаданныеКЗамеру.Имя].Выбрать();
				КоличествоЗаписей = 0;
				Пока ВыборкаСправочников.Следующий() Цикл
					КоличествоЗаписей = КоличествоЗаписей + 1;
				КонецЦикла;
				
				Строка = Объект.Результат.Добавить();
				Строка.ОбъектМетаданных 	= ОбъектКЗамеру.ПолноеИмяОбъектаМетаданных;
				Строка.КоличествоЗаписей	= КоличествоЗаписей;
			Исключение
				Сообщить("ОшибкаОбработкиОбъекта "+МетаданныеКЗамеру.ПолноеИмя()+" "+ОписаниеОшибки());
				Продолжить;
			КонецПопытки;
		КонецЕсли;

	КонецЦикла;
	
	УстановитьПривилегированныйРежим(Ложь);
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Базомер (показывает количество записей в таблицах):

.epf 10,53Kb
13
.epf 10,53Kb 13 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Дата
1. alex-l19041 8 31.05.19 17:11 Сейчас в теме
вот это
ВыборкаДокументов = Документы[МетаданныеКЗамеру.Имя].Выбрать();
КоличествоЗаписей = 0;
Пока ВыборкаДокументов.Следующий() Цикл
КоличествоЗаписей = КоличествоЗаписей + 1;
КонецЦикла;


лучше заменить на Запрос который вернет количество

"ВЫБРАТЬ
		|	КОЛИЧЕСТВО(ТаблицаДанных.Ссылка) КАК Количество,
			|ИЗ
		|	Документ." + ИмяТаблицы + " КАК ТаблицаДанных
2. alex-l19041 8 31.05.19 17:19 Сейчас в теме
и для справочников можно аналогично

"ВЫБРАТЬ
		|	КОЛИЧЕСТВО(ТаблицаДанных.Ссылка) КАК Количество,
		|ИЗ
		|	Справочник." + ИмяТаблицы + " КАК ТаблицаДанных
3. cool99 03.06.19 08:11 Сейчас в теме
"Рука лицо" - в то время как наши кОрабли бороздят просторы вселенной, в 2019 году мы считаем количество записей в таблицах через чтение набора записей и выборки, а если там миллионов 10 записей?
Писалась для ERP 2.4.7.151

Бедная ERP
4. ВикторП 261 05.06.19 12:42 Сейчас в теме
(3) зачем ? уже написали в (1) и (2) , не на мисте .
5. cool99 05.06.19 16:55 Сейчас в теме
(4) Просто с таким уровнем представляю, что в ЕРП они нашкодили - эта мысль основная (Как говорил Штирлиц, запоминается только последняя часть разговора, а у вас наоборот :))
С ее требованиями и подобными разработками никаких серверов не хватит. И Вас не смущает, что автор мало того, что "денюшку" просит, да еще и не отписался по комментариям 1/2? Вот зайдет какой-нибудь неокрепший ум и возьмет данный код (не читая комментов) на вооружение и пополнит ряды сами знаете кого.
6. ВикторП 261 06.10.19 12:28 Сейчас в теме
Подарок
Прикрепленные файлы:
БазомерНовый.epf
jatu; ActionBlog; +2 Ответить 1
7. ActionBlog 28.12.19 10:43 Сейчас в теме
Оставьте свое сообщение

См. также

Виды заполненных документов и справочников, УФ Промо

Статистика базы данных v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Количество документов и справочников в любой базе. Отборы, переход в журнал с отбором.

1 стартмани

04.05.2008    28264    214    MaxS    12    

Отчет по структуре базы данных 1С (обычные и управляемые формы)

Статистика базы данных v8 1cv8.cf Абонемент ($m)

Отчет по структуре базы данных 1С показывает количество записей во всех таблицах базы данных с группировкой по типу таблицы и названию объекта.

1 стартмани

04.08.2020    2223    15    Denr83    0    

Сведения об информационной базе (обычные и управляемые формы)

Статистика базы данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка показывает сведения об информационной базе.

1 стартмани

17.02.2020    3415    2    Denr83    0    

Статистика количества записей базы данных (ссылочные объекты и регистры)

Статистика базы данных v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Простой отчет, который выводит в таблицу значений на форму данные о количестве объектов и записей регистров. Работает на управляемых формах, от конфигурации не зависит. Можно зарегистрировать как внешний отчет в базе и вывести в меню.

1 стартмани

29.01.2020    3570    5    user1286683    1    

Список объектов информационной базы

Статистика базы данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка по получению списка объектов информационной базы. Для обычных и управляемых форм.

1 стартмани

23.01.2020    3409    13    Mike1978    0    

Статистика документов на СКД для любой конфигурации

Статистика базы данных v8 v8::СКД 1cv8.cf Абонемент ($m)

Отчет формирует статистику документов. Делает это быстро даже на больших объемах. Работает в любых конфигурациях на платформах 8.*. Полезен для оценки объемов документов. Использует СКД со всеми вытекающими возможностями отбора, сортировки, группировки, представления и т.д. ...

1 стартмани

21.01.2020    3808    24    bme    0    

Анализ трудозатрат пользователей. Подсчет количества введенных документов с учетом табличных частей

Анализ учета Учет рабочего времени Учет рабочего времени Статистика базы данных v8 БП2.0 БП3.0 Россия БУ Абонемент ($m)

Данный внешний отчет предназначен для подсчета введенной информации работниками организации. Будет полезна руководителю организации, главному бухгалтеру.

1 стартмани

04.01.2020    5053    11    kj6370    6    

Количество документов (каждого вида) в базе и элементов справочников (каждого вида)

Статистика базы данных v8 v8::УФ УПП1 КА2 Россия Абонемент ($m)

Обработка показывает количество элементов справочников и документов каждого вида с отбором по организации или по всей базе, обычное и управляемое приложение.

1 стартмани

24.12.2019    3768    17    user1233211    3    

Данные в хранилище значений

Статистика базы данных v8 v8::СКД 1cv8.cf Россия Абонемент ($m)

Обработка, показывающая размер, занимаемый данными типа Хранилище значения.

1 стартмани

11.12.2019    5427    11    kosmo0    0    

Статистика подключений пользователей за период

Статистика базы данных v8::УФ Розница БП3.0 Россия Абонемент ($m)

Доработка формирует отчет по сеансам пользователей в разрезе выбранных баз.

1 стартмани

14.10.2019    4465    1    VslavKup    0    

Статистика объектов информационных баз 1C 8.x (обычные и управляемые формы, СКД)

Статистика базы данных v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Внешний универсальный отчет по статистике объектов информационных баз 1C 8.x для обычных и управляемых форм с возможностью группировки по периодам.

1 стартмани

08.08.2019    5678    44    as.1c.nik    3    

Количество активных пользователей

Статистика базы данных v8 v8::СКД 1cv8.cf Абонемент ($m)

Отчет СКД в форме таблицы на основе регистров сведений ЗамерыВремени, ЗамерыВремениТехнологические.

1 стартмани

07.08.2019    4594    1    Mari_Kuznetzova    1    

Количество документов за период

Статистика базы данных v8 v8::УФ v8::СКД 1cv8.cf Россия Абонемент ($m)

Отчет показывает типы используемых документов в информационной базе за выбранный период и их количество по месяцам. Есть отбор по признаку документа ("проведен"/"распроведен"/"помечен на удаление"). Отчет универсальный подойдет для любой конфигурации.

2 стартмани

12.07.2019    6104    40    trntv    4    

Количество элементов в базе по метаданным и их размер для файловой информационной базы

Статистика базы данных v8 1cv8.cf Абонемент ($m)

В версии платформы 8.3.15, вышедшей 26.06.2019 (8.3.15.1489), была реализована возможность получить (оценить) размер данных, которые они занимают в таблицах СУБД - метод глобального контекста ПолучитьРазмерДанныхБазыДанных(). В данной обработке реализована данная возможность.

1 стартмани

27.06.2019    7246    131    BurlakovIvan    0    

Статистика по присоединенным файлам. Бухгалтерия 3

Статистика базы данных v8 v8::СКД БП3.0 Россия Абонемент ($m)

Формирует статистику загруженных в базу файлов в Бухгалтерии 3

1 стартмани

23.06.2019    5644    6    shurubchik    0    

Количество документов за период (Управляемые + Обычные формы, все конфигурации)

Статистика базы данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Представляю вашему вниманию маленькую но быструю и полезную обработку. Эта обработка выводит количество документов за произвольный период. Берутся все документы конфигурации. В сообщения выводятся: Представление документа, имя документа (в конфигураторе), количество документов за выбранный период. Обработка работает в обычных формах и управляемых формах. Для запуска в обычном приложении, а также в управляемом приложении (толстый клиент) достаточно открыть файл обработки. Для запуска в тонком клиенте, обработку необходимо регистрировать в конфигурации как встроенную обработку.

1 стартмани

20.06.2019    5298    7    pvlunegov    1    

Размер файлов хранилища

Статистика базы данных v8 1cv8.cf Абонемент ($m)

Обработка предназначена для вычисления объема информации, расположенного в справочнике ХранилищеДополнительнойИнформации для обычных форм.

1 стартмани

11.06.2019    6920    8    needmic    4    

Количество документов и справочников с отбором по организации для обычных и управляемых форм

Статистика базы данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет вывести количество документов и справочников информационной базы с отбором по организации для обычных и управляемых форм.

1 стартмани

08.06.2019    5909    16    Dadriel619960    3    

Обороты по документам для 1С: Бухгалтерия предприятия ред.3

Анализ учета Статистика базы данных Управленческие Документооборот и делопроизводство Документооборот и делопроизводство v8::СКД БП3.0 Россия БУ Абонемент ($m)

Отчет позволяет быстро получить данные для анализа в целом по компании и в динамике с произвольной периодичностью: день, неделя, месяц, квартал, год. Отчет написан на СКД и позволяет произвольно менять настройки, а также получать расшифровки вплоть до конкретного документа и в различных разрезах: по контрагентам, по видам операций, по организациям, подразделениям, складам, физическим лицам.

4 стартмани

23.05.2019    5999    7    rusmil    7    

Количество элементов в справочниках и документах системы

Статистика базы данных v8 v8::СКД 1cv8.cf Россия Абонемент ($m)

Отчет для любой конфигурации на платформе 8.х по количеству элементов в справочниках и документах системы Открывается как внешний файл (меню Файл - Открыть) на любом релизе платформы 8.х Формируется по кнопке Сформировать - см. скриншот

1 стартмани

21.05.2019    5299    7    denis_r    0    

Размеры таблиц SQL

Статистика базы данных v8::СКД 1cv8.cf Россия Абонемент ($m)

Сколько места занимает справочник? Почему такая большая база? Отчет покажет!

1 стартмани

15.05.2019    10031    143    SnubbyAston    11    

Подсчёт общего количества объектов (справочников и документов) в базе данных

Статистика базы данных v8 1cv8.cf Россия Абонемент ($m)

Обработка подсчитывает количество всех типов документов и справочников в базе 1С и выводит в таблицу. Ведёт подсчёт общего количества документов, проведённых, не проведённых и помеченных на удаление. Подсчитывает общее количество элементов каждого справочника, помеченные на удаление и предопределённые элементы. Предназначена для общих целей анализа базы, особенно для прогнозирования времени свёртки/тестирования/обновления/синхронизации базы данных, а также для сравнения двух баз по количеству объектов (например, источник и приёмник при конвертации). Есть возможность выбора периода, выбора сортировки по количеству/наименованию и скрывать/показывать нулевые.

1 стартмани

22.04.2019    6374    14    Aleksandr55555    3    

Сбор статистики базы данных

Статистика базы данных v8::УФ 1cv8.cf Россия Абонемент ($m)

Обработка собирает данные о количестве элементов справочников и документов за выбранный период. Отдельно показывается количество помеченных на удаление элементов.

1 стартмани

27.03.2019    4277    7    Sharaa    3    

Количество элементов справочников и документов для 1С 8.x (обычные и управляемые формы)

Статистика базы данных v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Отчет позволяет быстро оценить количество элементов справочников и документов в базах 1С 8.x (обычные и управляемые формы).

1 стартмани

26.03.2019    5526    6    black.nik    0    

Отчет по метаданным. Количество элементов справочников, документов, регистров. Отбор по периоду

Статистика базы данных v8 v8::СКД 1cv8.cf Россия Абонемент ($m)

Отчет по метаданным. Количество элементов справочников, документов, регистров. Есть отбор по периоду для периодических метаданных. Можно использовать для анализа при переносе данных. 8.3.13.1644.

1 стартмани

27.02.2019    7074    14    serg.7x    0    

Подсчет количества документов в конфигурации

Статистика базы данных v8 1cv8.cf Украина Абонемент ($m)

Как-то всё руки не доходили, но вот написал для себя, и делюсь с другими, обработку для подсчета количества документов в конфигурации. Может, кому-то будет полезной.

1 стартмани

23.02.2019    6035    5    forwork1c    1    

Анализ документов базы по пользователям

Статистика базы данных v8 1cv8.cf Россия Абонемент ($m)

Анализ документов, введённых пользователями: внешний отчёт, позволяющий увидеть количество документов каждого вида, введённых каждым пользователем (количественные показатели работы).

1 стартмани

16.02.2019    5286    4    Fantasisto    0    

Статистика ролей пользователей

Статистика базы данных Информационная безопасность v8 1cv8.cf Россия Абонемент ($m)

Обработка формирует отчет по ролям пользователей в разрезе выбранных баз.

1 стартмани

26.01.2019    6304    0    VslavKup    0    

Анализ количества элементов справочников и документов (управляемые формы)

Статистика базы данных v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет получить количество ссылок на документы и справочники с разделением по типам.

1 стартмани

25.01.2019    4779    4    Bubuyka    0    

Статистика по количеству документов и проводок в базе в разрезе организации и типов документов

Статистика базы данных v8 v8::БУ БП3.0 Абонемент ($m)

Данный отчет будет полезен для анализа производительности пользователей в базе.

2 стартмани

23.01.2019    4846    6    gvsgvs    0    

Отчет по базе данных

Статистика базы данных v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Внешний отчет по содержимому базы данных, формирует структуру базы данных, а также по конкретным объектам конфигурации можно посмотреть поля СУБД и индексы. (УФ)

1 стартмани

12.01.2019    6678    14    user5300    0    

Отчет "Всего объектов"

Статистика базы данных v8 1cv8.cf Россия Абонемент ($m)

Отчет показывает количество документов и справочников в разрезе метаданных с отбором по организации. Протестировано: на платформе 1С:Предприятие 8.3 (8.3.12.1616).

1 стартмани

25.12.2018    4900    3    birk    1    

Анализ максимального количества пользователей в базах средствами 1С (БСП)

Статистика базы данных v8 ДО ERP2 БП3.0 УТ11 КА2 ЗУП3.x Россия Абонемент ($m)

Подсистема для хранения и анализа количества подключений пользователей к указанным базам. Данные хранятся в отдельном регистре сведений, подключение выполняется средствами БСП.

1 стартмани

13.12.2018    6414    9    DarkPinch222    1    

Универсальный реестр документов (обычные и управляемые формы)

Статистика базы данных v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Обработка для вывода списка ВСЕХ документов (всех видов) за указанный период.

1 стартмани

28.11.2018    6152    11    DarkPinch222    1    

Замер производительности. КА 2, УТ 11

Статистика базы данных Производительность и оптимизация (HighLoad) v8 УТ11 Абонемент ($m)

Отчет позволяет замерять на актуальных базах КА2 и УТ11 (в том числе на демо-базах) три параметра: время выборки данных, время передачи с клиента на сервер, время вывода данных. Тестировал на релизах КА 2.4.1.240 и УТ 11.4.5.32.

1 стартмани

22.11.2018    8316    6    FarFar    9    

Считаем количество элементов объекта

Статистика базы данных v8 1cv8.cf Беларусь Украина Россия Абонемент ($m)

Обработка подсчета количества элементов в справочники, документе, регистре сведений.

1 стартмани

25.10.2018    6816    6    kaliuzhnyi    6    

Как узнать, какие типы документов в базе рабочие и сколько документов каждого типа?

Статистика базы данных v8 v8::УФ 1cv8.cf Абонемент ($m)

При разработке правил обмена необходимо определить, какие типы документов используются последние 2 года или 1 год.

1 стартмани

14.09.2018    6975    8    wowik    0    

Количество пользователей программы за период (по журналу регистрации)

Статистика базы данных v8 1cv8.cf Абонемент ($m)

Обработка родилась от необходимости оценки реального количества пользователей систем. Расчет выполняется на основании данных журнала регистрации.

1 стартмани

12.09.2018    5035    5    Kaavan    4    

Статистика работы с документами в базе

Статистика базы данных v8::БУ БП3.0 Россия БУ Абонемент ($m)

Статистика по документам в базе. Пригодится для анализа объема работ бухгалтерии, в т.ч. и аутсерсинговым организациям, у которых стоимость услуг зависит от объема документооборота.

1 стартмани

15.08.2018    5517    15    lvk74    0    

Отчет по количеству документов и строк в ТЧ (по видам документов, с заданной периодичностью)

Статистика базы данных v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Предлагаю вашему вниманию отчет, который выводит информацию о количестве документов в информационной базе в разрезе видов документов с заданной периодичностью.

1 стартмани

30.07.2018    9276    37    Tavalik    3    

Размер данных в базе 1С

Статистика базы данных v8 1cv8.cf Россия Абонемент ($m)

Оценка размера данных в байтах. Отчёт не предназначен для точной оценки размеров данных, т.к. для многих типов размер вычисляется в попугаях. Этот отчёт не является верхом совершенства и работает крайне медленно. Но именно этот отчёт позволяет наглядно увидеть, как просто вывести данные через СКД и насколько это проще, нежели вывод обычным способом. В то же самое время данный отчёт показывает наглядно, как просто создавать инструменты одновременно и под обычные формы, и под управляемые. Также можно очень наглядно увидеть распределение данных по различным объектам метаданных.

1 стартмани

03.04.2018    9284    33    strange2007    3