Сканирование изображений, используя TWAIN компоненту WIA

Публикация № 1128189 27.09.19

Управление - Документооборот и делопроизводство

Универсальная обработка сканирование управляемые формы прикрепление файлов БП 3.0 УНФ УТ ЗКГУ

Универсальная обработка заполнения объектов для сканирования изображений сохранения в любом формате и прикрепления его к документу. Можно использовать как самостоятельную обработку, так и добавить через "Администрирование" во "Дополнительные обработки и отчеты". Протестирована на БП 3.0, УНФ 1.6, ЗКГУ 3.1, УТ 11.4, Розница 2.2. Не требуется установка дополнительных программ и компонентов (кроме драйвера сканера, естественно)

Данная обработка использует компоненту Twain которая хранится в макете обработки, никакие внешние процедуры из конфигурации ей не нужны что делает ее универсальной. Единственное только возможны изменения в процедурах регистрации обработки

	Если Метаданные.ОбщиеМакеты.Найти("ПрисоединенныеФайлы")<>Неопределено ТОгда
		Для каждого Спр Из Метаданные.Справочники Цикл
			Если ПрисоединенныеФайлы.КОбъектуМожноПрисоединятьФайлы(Справочники[Спр.Имя].ПустаяСсылка()) Тогда
				ПараметрыРегистрации.Назначение.Добавить("Справочник." + Спр.Имя);
			КонецЕсли;
		КонецЦикла;
		Для каждого Спр Из Метаданные.Документы Цикл
			Если ПрисоединенныеФайлы.КОбъектуМожноПрисоединятьФайлы(Документы[Спр.Имя].ПустаяСсылка()) Тогда
				ПараметрыРегистрации.Назначение.Добавить("Документ." + Спр.Имя);
			КонецЕсли;
		КонецЦикла;
	КонецЕсли;

Для работы со сканерами мы используем Windows Image Acquisition (WIA)-это полнофункциональный компонент для обработки изображений, обеспечивающий сквозные возможности обработки изображений. Уровень автоматизации WIA позволяет легко получать изображения с цифровых камер, сканеров или веб-камер, а также вращать, масштабировать и аннотировать файлы изображений https://docs.microsoft.com/en-us/previous-versions/windows/desktop/wiaaut/-wiaaut-wiadevicetype

 
.....
	КодВозврата = ПодключитьВнешнююКомпоненту("ВнешняяОбработка.СканированиеДокументов.Макет.КомпонентаTWAIN", "twain");
.....
	Соответсвие = Новый Соответствие;
	
	Соответсвие.Вставить("DeviceManager", Новый COMОбъект("WIA.DeviceManager"));
	Соответсвие.Вставить("ImageFile", Новый COMОбъект("WIA.ImageFile"));
	Соответсвие.Вставить("CommonDialog", Новый COMОбъект("WIA.CommonDialog"));
	Соответсвие.Вставить("ImageProcess", Новый COMОбъект("WIA.ImageProcess"));
.....

Для определения списка устройств:

Функция ПолучитьУстройства() Экспорт
	
	Массив = Новый Массив;
	
	Если Не ПроинициализироватьКомпоненту() Тогда
		Возврат Массив;
	КонецЕсли;
	
	Для Каждого DeviceInfo Из Обработка_ПараметрыПриложения["СтандартныеПодсистемы.ИнтерфейсWIA"]["DeviceManager"].DeviceInfos() Цикл
		Массив.Добавить(DeviceInfo.Properties("Name").Value);
	КонецЦикла;
	
	Возврат Массив;
	
КонецФункции

Получить нужное устройство для работы и обработки:

 
Функция ПолучитьУстройство(ИмяУстройства)
	
	Для Каждого DeviceInfo Из Обработка_ПараметрыПриложения["СтандартныеПодсистемы.ИнтерфейсWIA"]["DeviceManager"].DeviceInfos() Цикл
		Если ВРЕГ(DeviceInfo.Properties("Name").Value) = ВРЕГ(ИмяУстройства) Тогда
			Возврат DeviceInfo;
		КонецЕсли;
	КонецЦикла;
	
	Возврат Неопределено;
	
КонецФункции

Для работы с диалоговыми окнами необходимо определить несколько переменных:

Типы файлов:

	СоответствиеФорматID = Новый Соответствие;
	СоответствиеФорматID.Вставить(-1, "{B96B3CAF-0728-11D3-9D7B-0000F81EF32E}");
	СоответствиеФорматID.Вставить("BMP", "{B96B3CAB-0728-11D3-9D7B-0000F81EF32E}");
	СоответствиеФорматID.Вставить("PNG", "{B96B3CAF-0728-11D3-9D7B-0000F81EF32E}");
	СоответствиеФорматID.Вставить("GIF", "{B96B3CB0-0728-11D3-9D7B-0000F81EF32E}");
	СоответствиеФорматID.Вставить("JPG", "{B96B3CAE-0728-11D3-9D7B-0000F81EF32E}");
	СоответствиеФорматID.Вставить("JPEG", "{B96B3CAE-0728-11D3-9D7B-0000F81EF32E}");
	СоответствиеФорматID.Вставить("TIFF", "{B96B3CB1-0728-11D3-9D7B-0000F81EF32E}");
 

Типы изображений:

	СоответствиеЦветностьID = Новый Соответствие;
	СоответствиеЦветностьID.Вставить(-1, 0);	//Не задано
	СоответствиеЦветностьID.Вставить(0, 4);		//Монохромное (текст)
	СоответствиеЦветностьID.Вставить(1, 2);		//Чернобелое
	СоответствиеЦветностьID.Вставить(2, 1);		//Цветное

Для запуска сканера в нужном режиме без диалога:

 
  Image = CommonDialog.ShowAcquireImage(WiaDeviceType, WiaImageIntent, WiaImageBias, СоответствиеФорматID.Получить(ФорматКартинки));

Для запуска помощника сканирования:

 
....
 objDevice=CommonDialog.ShowSelectDevice(WiaDeviceType,false,false);
 Image = CommonDialog.ShowAcquisitionWizard(objDevice); //ПолучитьУстройство(ИмяУстройства));		
....

Если желаем полностью настроить сканер программно и запустить сканирование без диалогов:

 
РазмерГоризонтально = Окр(210 / 25.4 * Разрешение, 0);
РазмерВертикально = Окр(296 / 25.4 * Разрешение, 0);

Device =  Обработка_ПараметрыПриложения["СтандартныеПодсистемы.ИнтерфейсWIA"]["DeviceManager"]; //Новый COMОбъект("WIA.DeviceManager");
DeviceInfo = Device.DeviceInfos();
Если DeviceInfo.Count() > 0 Тогда
	objDevice = CommonDialog.ShowSelectDevice(WiaDeviceType, Ложь, Ложь);

	Сканер = objDevice.Items(1);
	СканерПараметры = Сканер.Properties();
	СканерПараметры.Item("6146").Value = Цветность;
	СканерПараметры.Item("6147").Value = Разрешение;
	СканерПараметры.Item("6148").Value = Разрешение;

	СканерПараметры.Item("6149").Value = 0;
	СканерПараметры.Item("6150").Value = 0;

	СканерПараметры.Item("6151").Value = РазмерГоризонтально;
	СканерПараметры.Item("6152").Value = РазмерВертикально;

	Image = Сканер.Transfer();

КонецЕсли;

Весь список свойств можно получить через отладку

И последнее - это как и где получить возможные разрешения для сканера. Они также хранятся в свойствах каждого элемента.

В принципе, для работы со сканером как бы все есть, даже более. 

Также данную библиотеку можно использовать и для получения видео и для обработки изображений. Например, вот так с помощью нее можно конвертировать изображение в нужный формат данных:

 
ImageProcess = Обработка_ПараметрыПриложения["СтандартныеПодсистемы.ИнтерфейсWIA"]["ImageProcess"];
	
Если  ImageProcess.Filters.Count = 0 ТОгда
	ImageProcess.Filters.Add(ImageProcess.FilterInfos("Convert").FilterID);
Конецесли;
ImageProcess1 = ImageProcess.Filters(1);
Для К = 1 По ImageProcess1.Properties.Count Цикл
	Если ImageProcess1.Properties(К).Name = "FormatID" Тогда
		ImageProcess1.Properties(К).Value = СоответствиеФорматID.Получить(ФорматКартинки);
		Прервать;
	КонецЕсли;
КонецЦикла;
	
Image = ImageProcess.Apply(Image); //применяем фильтр на изображение

Обработка тестировалась на платформе 1С:Предприятие 8.3 (8.3.15).

Проверено на конфигурациях БП 3.0, ЗКГУ 3.1, УНФ 1.6, УТ 11.4, Розница 2.2.

Скачать файлы

Наименование Файл Версия Размер
Сканирование изображений используя TWAIN компоненту WIA:

.epf 120,73Kb
28
.epf 120,73Kb 28 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Рейтинг всех уровней
1. amd1986 27.09.19 11:18 Сейчас в теме
Компонента работает на 64 битной платформе 1С? Ранее то не работала..
2. vik070777 268 27.09.19 12:12 Сейчас в теме
Щас проверю на ВебКлиенте точно не работает
3. vik070777 268 27.09.19 12:36 Сейчас в теме
Работает
Прикрепленные файлы:
4. texnik1994 23.01.20 14:57 Сейчас в теме
Сообщение было скрыто модератором.
...
5. AlexWhite 193 14.05.20 17:28 Сейчас в теме
На снимках не увидел формат pdf - отсутствует или поддерживается?
6. vik070777 268 14.05.20 17:40 Сейчас в теме
к сожалению нет
Прикрепленные файлы:
7. vik070777 268 14.05.20 17:41 Сейчас в теме
есть отдельно конвертер можно доработать при необходимости
Оставьте свое сообщение

См. также

Рабочее место менеджера по продажам. УТ 11.3, 11.4, ERP 2.4 Промо

Рабочее место Оптовая торговля Оптовая торговля v8 v8::ОУ ERP2 УТ11 УУ Абонемент ($m)

Рабочее место менеджера по продажам УТ, ЕРП. Удобный инструмент в 1С для менеджеров по продажам для повседневной работы с клиентами. Все самое необходимое под рукой для оперативного создания заказа или реализации!

10 стартмани

17.08.2018    18972    60    Ivan90    36    

[Расширение] Временное отключение онлайн-эквайринга в РМК (УТ 11.4, Розница 2.3)

Розничная торговля Рабочее место Эквайринг v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Расширение предназначено для исправления исключительных ситуаций, когда оплата по эквайринговому терминалу с подключением оборудования прошла успешно, но чек на ККТ не был фискализирован. Расширение позволит временно отключить онлайн-эквайринг непосредственно из формы РМК.

1 стартмани

14.12.2020    7190    33    RocKeR_13    12    

Вставка штампа в файлы PDF

Документооборот и делопроизводство v8 ДО УУ Абонемент ($m)

Как неправильно регистрировать входящие документы? Надо распечатать сопроводительное письмо, зарегистрировать документ в программе, на бумажном носителе поставить штамп, вписать номер и дату и заново отсканировать документ в карточку входящего письма. А как правильно?

1 стартмани

11.11.2020    6424    33    soulner    10    

Настраиваемые печатные формы для Word

Документооборот и делопроизводство v8 1cv8.cf Абонемент ($m)

Разработка, позволяющая оперативно создавать печатные формы из файлов Word, редактировать их в режиме Предприятия и формировать результат также в формате Microsoft Word.

1 стартмани

14.09.2020    3808    17    FatPanzer    7    

Список заказов покупателей (новый взгляд) Промо

Рабочее место Монитор заказов Оптовая торговля Монитор заказов Оптовая торговля v8 v8::ОУ КА1 УТ10 УУ Абонемент ($m)

Внешняя обработка "Список заказов покупателей". Фишка в том, что на одной форме отображается структура связанных документов с указанием контрагента. В этом окне также есть список товаров по заказу. Видны статусы заказов: исполнен, выполняется, черновик.

2 стартмани

16.08.2017    34777    72    Rustig    60    

Выгрузка XML-файла УПД для отправки через ЭДО СБИС, Диадок и т.п.

Оптовая торговля Документооборот и делопроизводство Обмен через XML v8 v8::БУ БП3.0 Оптовая торговля, дистрибуция, логистика Россия БУ Абонемент ($m)

С помощью этой обработки для документа "Реализация товаров и услуг" формируется XML-файл УПД, который можно отправить через ЭДО СБИС, Диадок и пр.

1 стартмани

17.08.2020    13117    91    vasilievil    14    

Панель избранного на основе bootstrap (обычное приложение, webkit)

Рабочее место v8 1cv8.cf Абонемент ($m)

Рабочий стол для быстрого доступа к формам объектов (отчеты, документы, внешние отчеты/обработки). Представляет из себя небольшой сайт, содержащийся в обработке (на основе bootstrap) и отображающийся в поле HTML документа (Webkit).

1 стартмани

23.07.2020    7809    14    akpaevj    18    

Загрузка из XML файла ЭДО в документ поступления для конфигураций 1С: Розница 2.2/2.3, Управление торговлей 10.3/11.4

Розничная торговля Обработка документов Документооборот и делопроизводство Обмен через XML v8 УТ10 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Внешние обработки загрузки данных из XML файлов формата ON_NSCHFDOPPRMARK ЭДО в документы поступления 1С Розница версия 2.2.10.19 и выше, Управление торговлей 10.3.52.2 и выше, Управление торговлей 11.4.5.63 и выше

1 стартмани

04.06.2020    24176    275    independ    130    

Печать конвертов из 1С Промо

Пакетная печать Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf Россия Абонемент ($m)

Внешняя печатная форма для печати конвертов формата C4 и C5. Печать с полной разметкой почтового конверта и размещением адресов отправителя и получателя, включая индекс.

1 стартмани

07.12.2015    32524    14    sashs1980    7    

[Расширение] БП 3.0. Список счетов от поставщиков / Список поступлений + Связанные документы

Оптовая торговля Рабочее место v8 v8::БУ БП3.0 БУ УУ Абонемент ($m)

Список счетов от поставщиков и список поступлений товаров и услуг + Структура подчиненности в одном окне. Расширение для программы БП 3.0.

2 стартмани

20.05.2020    7208    6    Rustig    13    

Кассовая программа "АрсКасса" на C# - без ограничений

Розничная торговля Кассовые операции Рабочее место v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Кассовая программа "АрсКасса" предназначена для автоматизации рабочего места кассира, без дополнительных затрат на покупку лицензий ПО.

1 стартмани

03.05.2020    8772    20    coolseo    9    

[Расширение] УНФ. Список заказов + Структура подчиненности

Монитор заказов Рабочее место v8 УНФ УУ Абонемент ($m)

Список заказов покупателей + Структура подчиненности в одном окне. Расширение для программы Управление нашей фирмой, редакция 1.6.

1 стартмани

05.04.2020    16864    14    Rustig    9    

Обработка "Распознавание штрихкода с помощью утилиты Zbar" для Документооборот ред. 2 Промо

Универсальные обработки Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Абонемент ($m)

В связи с тем, что стандартный функционал программы «Документооборот» ред. 2.1 дает возможность распознавания штрихкодов только форма EAN-13, данная обработка - альтернативный способ для распознавания штрихкода в программе 1С: Документооборот ред. 2 с помощью утилиты Zbar, которая распознает в том числе и в формате Code 128 (один из стандартных штрихкодов кодирования документов, например, «Управление торговлей» ред. 11), а также с возможностью поэтапно проследить все действия от распознавания до прикрепления к документу или простой загрузки в каталоги файлов в базе 1С.

5 стартмани

05.09.2016    25354    170    SEOAngels    11    

Настройка политики повторного согласования в 1С: Документооборот

Документооборот и делопроизводство v8 ДО УУ Абонемент ($m)

Большинству компаний хочется организовать процессы согласования максимально удобно и сократить количество лишних итераций, логично, что возникает требование исключать на втором и последующих циклах согласования тех, кто уже установил свою визу. Стандартный функционал программы 1С: Документооборот, при маршрутизации процесса на повторное согласование, предлагает пользователю вручную скорректировать список согласующих. Но если запрещено изменение процесса по шаблону, корректировка состава согласующих пользователю будет недоступна. Расширение добавляет опциональную настройку в шаблоны процессов согласования, определяющую логику формирования списка согласующих при повторе согласования одним из трёх вариантов: При повторе согласовывается всеми / При повторе согласовывают только отклонившие / При повторе согласовывают отклонившие и согласовавшие с замечанием.

5 стартмани

26.02.2020    10682    47    st_Etlau    8    

Дополнительные функции для 1С:Документооборот

Практика программирования Документооборот и делопроизводство v8 ДО УУ Абонемент ($m)

В данной публикации я хочу поделиться расширением, которое содержит дополнительные функции (доработки) для 1С:Документооборот.

1 стартмани

24.01.2020    12795    107    pavelpribytkin96    36    

Помощник подготовки данных для СЗВ-ТД

Зарплата Обработка документов Документооборот и делопроизводство v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

С 1 января 2020 г. начался переход на электронные трудовые книжки. Работодателям в 2020 г. предстоит выполнить ряд мероприятий для перехода на ЭТК, а также ежемесячно отчитываться в ПФР обо всех кадровых изменениях по форме СЗВ-ТД. В этой публикации размещена обработка, которая поможет быстро подготовить кадровые документы для заполнения СЗВ-ТД в программе 1С ЗУП 3.1, 1С ЗКГУ 3.1.

1 стартмани

23.01.2020    12954    113    Kaval88    62    

Список заказов поставщикам (новая форма) + два ноу-хау для разработчиков Промо

Рабочее место Дебиторская и кредиторская задолженность Оптовая торговля Дебиторская и кредиторская задолженность Оптовая торговля v8 v8::ОУ КА1 УТ10 УУ Абонемент ($m)

Представлена внешняя обработка - "Список заказов поставщикам (новая форма)". Удобство заключается в том, что в одном окне списка отображается структура всех связанных документов с указанием контрагента (заказ поставщику - поступление товаров - заказ покупателя - реализация товаров - оплата товара покупателем). В этом же окне отображается список товаров с заказанным количеством и ценами. Имеется возможность видеть статусы заказов по цветам (исполнен, выполняется, черновик). Форму легко встроить в типовую конфигурацию.

2 стартмани

31.08.2017    27095    17    Rustig    18    

Отключение создания задачи ознакомления для бизнес-процесса "Согласование" в 1С: Документооборот

Практика программирования Документооборот и делопроизводство v8 v8::Бизнес-процессы ДО Абонемент ($m)

В данной публикации я хочу поделиться расширением, с помощью которого можно отключить создание задачи ознакомления для бизнес-процесса "Согласование" в 1С: Документооборот.

1 стартмани

30.11.2019    15152    41    pavelpribytkin96    5    

Очень быстрый поиск номенклатуры в РМК

Розничная торговля Работа с интерфейсом Рабочее место v8 Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Расширение для конфигурации Розница 2.2, ну очень быстрый поиск товара в РМК.

1 стартмани

19.11.2019    6911    41    Vyacheslide    45    

Несколько касс ККМ в РМК Розница 2.3 с выбором кассы для каждой строки

Розничная торговля ККМ Рабочее место v8 Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Расширение позволяет подключить несколько касс ККМ к одному рабочему месту, по одной организации. Выбор кассы осуществляется на каждую строку товара. При добавлении позиции товара, автоматически выбирается касса по умолчанию. Определение кассы по умолчанию осуществляется в настройках пользователя. Расширение можно подключить в Рознице 2.3 версии ПРОФ.

3 стартмани

13.11.2019    16532    68    SerGray    120    

Расширение "Интерфейс Плюс" Промо

Розничная торговля Рабочее место Розничная торговля v8 v8::ОУ Розница УТ11 Россия УУ Абонемент ($m)

Расширение для 1С:Розница 2.2/2.3 и 1С:Управление Торговлей 11, которое позволит повысить удобство работы!

1 стартмани

22.09.2018    33699    170    RocKeR_13    133    

Рабочее место логиста

Оптовая торговля Рабочее место v8 Абонемент ($m)

Обработка умеет отображать адреса доставки на карте Гугл, позволяет вручную разбивать их по маршрутам (машинам и водителям) , в том числе и зрительно, раскрашивая точки на карте в цвета машин, строить по каждой машине подробный маршрут, оптимизированный по порядку посещения точек доставки (решая "задачу коммивояжера" для каждого маршрута). Обработка не использует никаких метаданных конфигураций - адреса доставки и данные машин и водителей загружаются из файлов экселя, итоговые маршруты также выгружаются в эксель. В архиве находятся -- сама обработка, примеры экселевских файлов с адресами и данными водителей и машин, а также один файл итоговой выгрузки получившегося маршрута.

10 стартмани

12.11.2019    15416    16    Torin99    43    

Как быстро восстановить утерянное рабочее место УТ11, Розница 2 без повторного добавления оборудования. РМК Кассира, пропало оборудование

Торговое оборудование Рабочее место v8 Розница БП3.0 УТ11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Розница 2 и Управление торговлей 11 временами (при аварийном завершении работы) любят терять рабочие места. Восстанавливать работу добавляя заново оборудование и плодя лишние элементы в справочнике рабочих мест не TRUE way. Всё решается проще, GUID рабочего места находится в файлике %LocalAppData%\1C\1cv8\1cv8u.pfl

1 стартмани

26.09.2019    16489    18    agent00mouse    11    

Аналоги номенклатуры для УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Расширение

Рабочее место Оптовая торговля Розничная торговля Управление торговлей Оптовая торговля Розничная торговля v8 Розница ERP2 УТ11 КА2 Автомобили, автосервисы Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Расширение для работы с аналогами номенклатуры. Отлично подходит для работы с кроссами запчастей и товаров с аналогичными свойствами. Поддерживаемые конфигурации: УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Лёгкое подключение, без изменения конфигурации.

1 стартмани

30.08.2019    27802    56    AleSSandre    34    

Работа с картой. Кадастровый учет (Росреестр). Тематические карты Промо

WEB Рабочее место v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка для работы с картами в 1С. Получения изображения с публичной кадастровой карты России, построения тематических карт

1 стартмани

31.08.2017    23195    13    vipchep    1    

Подписание электронной подписью большого количества прикрепленных файлов. Документооборот

Документооборот и делопроизводство Универсальные обработки Документооборот и делопроизводство v8 ДО БУ Абонемент ($m)

Обработка пакетного подписания (не асинхронная) электронной подписью большого количества прикреплённых файлов для Документооборота.

1 стартмани

14.08.2019    5839    13    rmIvanT    0    

ERP 2.4 "Рабочее место работника склада" на ТСД + Android 7

Терминал сбора данных Рабочее место Мобильная разработка Учет ТМЦ Учет ТМЦ v8 ERP2 УУ Абонемент ($m)

Решение задачи использования терминала сбора данных в режиме онлайн при помощи типовой обработки ERP 2.4 "Рабочее место работника склада", запуском ERP на мобильном клиенте 1С. Для настройки использовался ТСД Urovo V5100 на ОС Андроид 7.

1 стартмани

07.08.2019    17956    26    chemezov    10    

Интерактивный интерфейс Промо

Рабочее место Работа с интерфейсом v8 1cv8.cf Россия Абонемент ($m)

Обработка (отдельная панель меню), позволяющая настраивать интерфейс пользователя интерактивно (права не настраивает). Мне очень пригодилось, так как приходится прописывать индивидуальный интерфейс, каждому пользователю (а их уже сотни). Выложил 2 версии одна в виде таблицы, вторая в виде выпадающего меню

1 стартмани

29.10.2011    20612    65    Vin_Tik    9    

Почта России - отправка и отслеживание, интеграция с Документооборот 8

Внешние источники данных Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Россия УУ Абонемент ($m)

Выгрузка почтовых отравлений в личный кабинет отправки Почты России; отслеживание почтовых отправлений через Почту России; расширение для интеграции Документооборот 8 с Почтой России

5 стартмани

04.06.2019    15766    110    wtlz    58    

Нумератор документов для ЗУП 3.1, ЗУП 3.1 КОРП, ЗИК 3.1, ЗИК 3.1 КОРП, ЗиКГУ 3.1, ЗиКГУ 3.1 КОРП

Обработка документов Документооборот и делопроизводство Документооборот и делопроизводство v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Абонемент ($m)

Очень часто в организациях требуется специфическая нумерация документов и стандартные возможности не позволяют без доработки достичь этого. Данная доработка позволяет без изменения конфигураций получать всевозможную нумерацию.

3 стартмани

28.05.2019    9705    42    pogroleg    33    

Доработки УТ 10.3, улучшающие работу пользователей

Оптовая торговля Обработка документов Рабочее место Оптовая торговля v8 v8::ОУ УТ10 УУ Абонемент ($m)

Как показать прибыль по заказу, как показать прикрепленные файлы к документам - когда документов по заказу много, как показать расчет процентов по менеджерам - и все в одном окне УТ 10.3.

2 стартмани

26.04.2019    15180    14    Rustig    26    

Подбор товаров по характеристикам (свойствам и значениям)

Оптовая торговля Розничная торговля Рабочее место Оптовая торговля Розничная торговля v8 КА1 УТ10 УНФ УУ Абонемент ($m)

Быстрый фильтр и отбор товаров (номенклатуры) по свойствам. Готовый механизм для УТ 10.3 и УНФ 1.6.

2 стартмани

14.04.2019    14504    24    Rustig    8    

Иерархический список быстрых товаров в рабочем месте кассира (УНФ 1.6.25)

Рабочее место Розничная торговля Розничная торговля v8 УНФ Россия УУ Абонемент ($m)

Модификация рабочего места кассира (РМК) в 1С "Управление нашей фирмой" (УНФ): произвольно настраиваемое меню быстрых товаров. Реализовано в виде расширения конфигурации.

1 стартмани

08.04.2019    7810    29    asorozhkin    6    

Доработка функционала отправки дополнительных реквизитов 1С: ЭДО для Татнефть

Внешние источники данных Документооборот и делопроизводство Документооборот и делопроизводство v8 ERP2 БУ Абонемент ($m)

Подключаемое расширение к конфигурации ERP с функционалом отправки дополнительных реквизитов 1С ЭДО для Татнефть (№ и дата договора, подразделение, автор, примечание) в электронных документах Счет-фактуры и ТОРГ-12 Проверялось на 1С:ERP Управление предприятием 2.4.6.160.

2 стартмани

07.04.2019    12676    17    sapervodichka    12    

Формирование xml файла ЭДО (СБИС, Диадок, Такском и т.п.) для типовых документов (счета-фактуры, накладные)

Внешние источники данных Обмен через XML Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf Абонемент ($m)

Не все типовые документы типовых конфигураций 1С можно выгрузить в файл формата xml ЭДО. Например счет-фактуру, на текущий момент момент это не предусмотрено. Обработка позволяет сделать это.

4 стартмани

30.03.2019    64042    378    capitan    125    

Подписи для 1С

Мобильная разработка Документооборот и делопроизводство Документооборот и делопроизводство v8 Россия Абонемент ($m)

Получение подписей в Мобильной платформе 1С с помощью приложения.

1 стартмани

28.02.2019    10018    8    Grivba    7    

1С Документооборот: Создание связанных документов по настройкам связей

Обработка документов Документооборот и делопроизводство Документооборот и делопроизводство v8 v8::УФ ДО Абонемент ($m)

Типовой механизм "Создания на основании" в 1С Документооборот обеспечивает лишь базовую потребность ввода документов на основании. Например типовой механизм не позволяет создать документ с видом документа, у которого нет ни одного введенного шаблона документа (т.е. прийдется создать пустой и выбрать вид документа). С другой же стороны, если общее количество шаблонов по видам внутренних документов превышает 50 штук - выбор нужного шаблона из типовой формы создания на основании "внутреннего документа" может занимать драгоценное время и быть не оптимальным.

1 стартмани

28.02.2019    14431    16    Bin42    4    

Визуализация электронной подписи на исходящих документах в соответствии с ГОСТ Р 7.0.97-2016. Полная автоматизация

Печатные формы документов Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Россия Абонемент ($m)

Визуализация ЭЦП по ГОСТу Р 7.0.97-2016, предложенная в предыдущей статье (https://infostart.ru/public/931674/) на данную тему, очень прижилась у меня в организации. Начальник часть писем повелел подписывать ЭЦП и не тревожить его по пустякам. Но механизм подписи требовал некоторого количества ручных действий, а хочется полной автоматизации. Итак, постановка задачи: штамп должен позиционироваться сам, pdf-файл со штампом ЭЦП должен создаваться сам и в карточку исходящего документа тоже должен сам загружаться.

1 стартмани

19.02.2019    26523    63    soulner    48    

Групповая отправка документов по электронной почте (Счет на оплату покупателя, Реализация товаров и услуг, Счет фактура выданный, Акт сверки)

Email Документооборот и делопроизводство Документооборот и делопроизводство Оптовая торговля v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка "Групповая отправка документов по электронной почте" для конфигурации Бухгалтерия 3.0. Позволяет гибко выбирать документы и отправлять их контрагентам.

6 стартмани

29.01.2019    14240    93    MaxxiMiliSan    97    

СМС2 - эрзац-мессенджер в вашей конфигурации 1С

Практика программирования Работа с интерфейсом Рабочее место v8 v8::УФ Абонемент ($m)

Обработка предоставит вам некоторый функционал мессенджера внутри используемой конфигурации. Вложения с файлами и ссылками, аватары у пользователей, всё это можно и в 1С.

1 стартмани

17.12.2018    9564    8    semagin@gmail.com    15    

[Расширение] Бухгалтерия государственного учреждения 2.0 (с версии 2.0.78.32)

Рабочее место Бухгалтерский учет v8 v8::БУ БГУ Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Расширение конфигурации для программного продукта 1С Бухгалтерия государственного учреждения 2.0. Расширение содержит более 20 различных дополнений для справочников, документов, отчетов и обработок, не требует изменения конфигурации. Протестировано на версии 2.0.78.32 (на предыдущих релизах работа не гарантируется).

1 стартмани

29.10.2018    10923    22    scanner1980    6    

Мобильный сканер документов

Обработка документов Пользователю системы Обработка справочников Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО ERP2 БП3.0 Россия Абонемент ($m)

Если под рукой нет обычного сканера, то можно воспользоваться собственным телефоном в качестве сканера для документов 1С.

3 стартмани

29.09.2018    11377    14    RSConsulting    17    

Планирование заявок на оплату (для руководителя отдела закупок, на основе платежного календаря) для УТ 11, КА 2, ERP 2.

Обработка документов Рабочее место Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 v8::ОУ ERP2 УТ11 КА2 Россия УУ Абонемент ($m)

Обработка позволяет планировать заявки на расходование денежных средств без распределения по счетам/кассам, с группировкой по менеджерам и лимитом платежей на день.

1 стартмани

04.09.2018    10173    25    UstinovVA    7    

Рабочее место кассира с возможностью продажи по нескольким складам

Рабочее место Розничная торговля Розничная торговля v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Расширение для УТ 11 в режиме совместимости 8.3.11 для возможности розничной продажи с нескольких складов.

5 стартмани

09.08.2018    11336    25    yokko    12