Удаление организаций из информационных баз 1С

Публикация № 1155114

Администрирование - Администрирование данных 1С - Чистка базы

Обработка удаление организации

Обработка предназначена для удаления организаций из любых информационных баз 1С, имеющих в своем составе справочник "Организации". Работает на обычных и управляемых формах, на базах любого формата и размера. Обработка проверялась на следующих типовых релизах 1С: БП 2.0.66.84, БП 3.0.71.77, БГУ 1.0.59.3, БГУ 2.0.65.17, УТ 10.3.55.3, УТ 11.4.10.57, ЗУП 3.1.11.106, ЗГУ 3.1.11.106, КА 2.4.9.98, УПП 1.3.126.1, УНФ 1.6.18.168, но должна работать и на более старых, так как обработке нужен только справочник "Организации".

Довольно часто возникает задача разделения информационных баз по организациям. Одним из способов решения этой задачи является удаление ненужных организаций.

Традиционный способ – пометка на удаление организаций и всех связанных с ними данных с последующим удалением помеченных объектов – является трудоёмким, затратным по времени и ресурсам, а, значит, не эффективным.

Предлагаемая обработка по удалению организаций является простой в использовании и очень быстрой, так как удаляет связанные данные непосредственно, без контроля ссылочной целостности. Единственным условием работоспособности обработки является наличие в информационной базе справочника «Организации». Обработка работает как на обычных, так и на управляемых формах.

Так выглядит обработка на управляемых формах:

Управляемая форма

Так выглядит обработка на обычных формах:

Обычная форма

Перед удалением организаций полезно убедиться, что связанные с организациями данные используются правильно. Под правильностью использования понимается следующее: если в каком-нибудь объекте используется некая организация, то связанные с ней данные не должны принадлежать другим организациям. Например, если в документе начисления зарплаты указана одна организация, а подразделение – другой организации, то такое использование связанных данных считается неправильным.

Почему так важно соблюдать правильность использования связанных данных? Дело в том, что при удалении организации будут удалены все связанные с ней справочники, документы и так далее. Если связанные с удаляемой организацией данные будут использованы неправильно, например, присутствовать в документах других организаций, то эти документы также будут удалены, что неминуемо исказит картину по оставшимся организациям.

Для проверки правильности использования связанных данных служит специальная кнопка. При её нажатии обработка проверяет правильность использования связанной информации по выбранным организациям. Если будут обнаружены объекты, в которых связанные данные используются неправильно, они будут выведены в специальную таблицу в правой части обработки. Колонка «Ссылка на объект» будет содержать ссылку на объект с неправильными данными, колонка «Имя владельца» будет содержать имя реквизита объекта, который является «владельцем» связанной информации. Как правило, этот реквизит называется «Организация», но могут быть и другие имена. Колонка «Значение владельца» будет содержать ссылку на значение реквизита-владельца. Колонка «Имя подчиненного» будет содержать имя реквизита объекта, который «подчинён» реквизиту-владельцу, а колонка «Значение подчиненного» будет содержать ссылку на значение подчинённого реквизита. У этого реквизита, как правило, другой владелец.

Сами организации удаляются по кнопке «Удалить отмеченные организации». Так как операция удаления является необратимой, настоятельно рекомендуется перед удалением сделать архивную копию информационной базы. Удаление происходит в монопольном режиме, поэтому с базой не должны работать другие пользователи. Так же в базе не должно быть запущенных фоновых заданий.

Если обработка смогла перейти в монопольный режим, начинается процесс удаления. В этот момент обработка не реагирует на действия пользователя. Это сделано сознательно, чтобы ничего не могло помешать удалению. Данные из базы удаляются непосредственно, без проверки ссылочной целостности. Процесс удаления может длиться от нескольких минут до нескольких часов и даже суток. Всё зависит от объёма удаляемой информации и производительности техники. Прерывать работу обработки путём аварийного завершения программы нельзя, так как данные будут удалены частично, а база будет непригодна для дальнейшего использования.

После того, как обработка завершит свою работу, необходимо обязательно запустить процесс тестирования и исправления информационной базы через меню «Администрирование» в режиме конфигуратора. Параметры тестирования и исправления показаны на следующем рисунке:

Тестирование и исправление информационной базы

Код обработки открыт всем желающим. Буду признателен за отзывы, замечания и предложения.

История изменений:

24.12.2020. Доработан алгоритм поиска неправильно используемых данных.

10.01.2020. Исправлена ошибка, возникавшая при обработке табличных частей объектов с количеством строк более 1000.

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом в течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Alien_RS_Forever 10.12.19 17:16 Сейчас в теме
Даа, "хорошо" что есть подобные разработки. Благодаря им у нас есть работа. Клиентов конечно жалко..
3. Техподдержка 11.12.19 03:57
(1) Поконкретнее, пожалуйста. Что Вас не устраивает?
11. alex_4x 81 16.06.20 12:05 Сейчас в теме
Мои пять копеек. Эту обработку эту не использовал, ничего плохого или хорошего сказать не могу.
Нужно было "срочно" удалять организации из разных очень больших баз.
Вопрос был решен достаточно просто. Обработка получилась в стиле "сделано на коленке" и распространять её опасно на мой взгляд, но если интерес будет - обращайтесь.
Принцип работы такой: Автоматом проверяются все документы и справочники, имеющие в шапке реквизит Организация, формируются запросы по выборке объектов к удалению, эти объекты удаляются без контроля ссылочной целостности. Это нехорошо конечно, но быстро. Далее такие справочники как физлица, сотрудники, контрагенты - проверяются на наличие ссылок на них в базе (так как реализации, поступления, договора контрагентов с организацией и т.д. - уже удалены) и если ссылок нет или ссылки только в регистрах "соответсвия объектов для обмена" и "версии объектов" - то они тоже удаляются. Примерно так же проверятся номенклатура, но там и документы "установки цен номенклатуры" не считаются важными, если движений номенклатуры по остающимся в базе организациям нет - то номенклатуру удаляем. Всё это делать можно не монопольно, так как используется штатный механизм Объект.Удалить()

Процедура КнопкаУдалитьДокументыОтмеченныхОрганизацийНажатие(Элемент)
	// Организации - таблица значений с колонками Организация, Удалять
	Для Каждого СтрОрганизации Из Организации Цикл
		Если СтрОрганизации.Удалять Тогда
			ВыбОрганизация = СтрОрганизации.Организация;
			Сообщить("Начали поиск и удаление документов по организации "+ВыбОрганизация.Код+" "+ВыбОрганизация.Наименование);
	
			ДатаНачала = Дата("00010101");
			ДатаКонца = ТекущаяДата();
		    
			Для Каждого Документ Из Метаданные.Документы Цикл
				ОбработкаПрерыванияПользователя();
				Если НЕ Документ.Реквизиты.Найти("Организация") = Неопределено Тогда
					Сообщить("Производится отбор документов """+Документ.Синоним+""" за период с "+ДатаНачала+" по "+ДатаКонца+" по Организации "+ВыбОрганизация);
					ТипДок = Документ.Имя;
					Запрос = Новый Запрос();
					Запрос.Текст = "ВЫБРАТЬ
					               |	Док.Ссылка,
								   |	Док.Проведен
					               |ИЗ
					               |	Документ."+ТипДок+" КАК Док
					               |ГДЕ
					               |	Док.Дата >= &ДатаНачала
					               |	И Док.Дата <= &ДатаКонца
					               |	И Док.Организация = &Организация";
					Запрос.УстановитьПараметр("ДатаНачала",ДатаНачала);
					Запрос.УстановитьПараметр("ДатаКонца",ДатаКонца);
					Запрос.УстановитьПараметр("Организация",ВыбОрганизация);
					ТЗ = Запрос.Выполнить().Выгрузить();
					Количество = ТЗ.Количество();
					ТекНомер = 0;
					Для Каждого СтрТЗ Из ТЗ Цикл
						ОбработкаПрерыванияПользователя();
						ТекНомер = ТекНомер + 1;
						Процент = Окр(ТекНомер/Количество*100,2);
						
						Док = СтрТЗ.Ссылка.ПолучитьОбъект();
						Попытка
							Док.Удалить();
						Исключение
							Сообщить("не удалось удалить документ ("+Документ.Синоним+")	"+Док);
							ОбработкаПрерыванияПользователя();
						КонецПопытки;
						Если ТекНомер % 100 = 0 Тогда
							Состояние ("Удаление документов """+Документ.Синоним+""" по Организации "+ВыбОрганизация+" Обработано "+ТекНомер+" из "+Количество+" ("+Процент+"%)");	
							ОбработкаПрерыванияПользователя();
						КонецЕсли;
					КонецЦикла;
				КонецЕсли;
			КонецЦикла;
		КонецЕсли;
	КонецЦикла;
	Сообщить("ЗАКОНЧИЛИ удаление документов отмеченных организаций");
КонецПроцедуры
Показать




Функция УдалитьЭлементыСправочникаБезСсылокВДокументах(СтрТипСправочника)
	Запрос = Новый Запрос();
	Найден = Ложь;
	
	Для Каждого Справочник Из Метаданные.Справочники Цикл
		Если Справочник.Имя = СтрТипСправочника Тогда
			Если Справочник.Иерархический И Справочник.ВидИерархии = Метаданные.СвойстваОбъектов.ВидИерархии.ИерархияГруппИЭлементов Тогда
				Запрос.Текст = "ВЫБРАТЬ
	               |	Спр.Ссылка
	               |ИЗ
	               |	Справочник."+СтрТипСправочника+" КАК Спр
	               |ГДЕ
	               |	Спр.ЭтоГруппа = ЛОЖЬ";
			Иначе
				Запрос.Текст = "ВЫБРАТЬ
	               |	Спр.Ссылка
	               |ИЗ
	               |	Справочник."+СтрТипСправочника+" КАК Спр";
			КонецЕсли;
			Найден = Истина;
		КонецЕсли;
	КонецЦикла;
	
	Если НЕ Найден Тогда
		Сообщить("Справочник "+СтрТипСправочника+" не найден");
		Возврат Ложь;
	КонецЕсли;
	
	ТЗ = Запрос.Выполнить().Выгрузить();
	Ссылки = Новый Массив(1);
	ВсегоОбъектов = ТЗ.Количество();
	ТекущийОбъект = 0;
	ПоследнееДействие = "";
	Для Каждого СтрТЗ из ТЗ Цикл
		ОбработкаПрерыванияПользователя();
		ТекущийОбъект = ТекущийОбъект+1;
		Проц = Окр(ТекущийОбъект/ВсегоОбъектов*100,2);
		Состояние("Обрабатывается "+СтрТипСправочника+" "+Проц+"%	"+ПоследнееДействие);
		Ссылки[0] = СтрТЗ.Ссылка;
		ТабСсылок = НайтиПоСсылкам(Ссылки);
		НеУдалять = Ложь;
		Для Каждого Ссылка из ТабСсылок Цикл
			Если Документы.ТипВсеСсылки().СодержитТип(ТипЗнч(Ссылка[1])) Тогда
				Если СокрЛП(ТипЗнч(Ссылка[1])) = "Установка цен номенклатуры" ИЛИ
					 СокрЛП(ТипЗнч(Ссылка[1])) = "Условия поставок по договорам контрагентов" Тогда
					//Сообщить("НЕНУЖНЫЙ ДОКУМЕНТ 	"+ТипЗнч(Ссылка[1])+" // "+Ссылка[1]);
				Иначе
					НеУдалять = Истина;
					//Сообщить("ВАЖНЫЙ ДОКУМЕНТ   	"+ТипЗнч(Ссылка[1])+" // "+Ссылка[1]);
					Прервать;
				КонецЕсли;
			Иначе
				//Сообщить("НЕ ДОК!                  "+ТипЗнч(Ссылка[1])+" // "+Ссылка[1]);
			КонецЕсли;
		КонецЦикла;
		Если НеУдалять Тогда
			// Оставляем
			ПоследнееДействие = "Оставляем "+СтрТЗ.Ссылка;
		Иначе
			// Удаляем
			//Сообщить("Удаляем "+СтрТЗ.Ссылка);
			ОбъектСправочника = СтрТЗ.Ссылка.ПолучитьОбъект();
			ПоследнееДействие = "Удаляем "+СтрТЗ.Ссылка;
			Попытка
				ОбъектСправочника.Удалить();
			Исключение
				Сообщить("Не удалось удалить "+СтрТипСправочника+" "+ОбъектСправочника);
				ОбработкаПрерыванияПользователя();
			КонецПопытки;			
		КонецЕсли;
	КонецЦикла;
	Сообщить("ЗАКОНЧИЛИ Удаление "+СтрТипСправочника);
	Возврат Истина;
КонецФункции
Показать
2. nomad_irk 52 10.12.19 17:32 Сейчас в теме
(0)в чем выйгрыш по сравнению с типовым корректным удалением?

Потратить время на удаление данных из базы и потом еще на ТиИ, которое доудалит данные и для своего выполнения может потребовать времени, гораздо больше, чем процесс удаления данных? А оно реально надо за 3000р. весь этот геморрой?
4. Техподдержка 11.12.19 04:05
(2) Вы когда-нибудь удаляли организацию из базы? А две? А несколько, когда собственники расходятся и делят конторы? И не просто нажать "удаление помеченных объектов", а сначала пометить удаляемые данные на удаление, а потом ещё почистить их, чтобы следа не осталось. Вот это геморрой не на один день и не за 3000 р. Или может Вас цена смущает?
5. nomad_irk 52 11.12.19 06:13 Сейчас в теме
(4) https://infostart.ru/public/1125435/ - вот здесь ответ на ваш вопрос про удаление данных по организациям из баз.

По поводу конкретно вашего способа очистки БД от данных по организации(-ям) могу дать идею как ускорить процесс удаления: просто удалите выбранные организации, остальное удалится при ТиИ.
6. Техподдержка 11.12.19 06:41
(5) Согласен, опыт есть. Особенно впечатлило:

После примерно месяца мытарств с типовым удалением, которое так и не выполнилось до конца, мне пришлось создать данную обработку.


Ваша обработка реашет ту же задачу, что и моя, но работает ли она на файловых базах? И каков будет результат, если имеется неправильное использование данных?

Ну, а по поводу Вашего совета, боюсь он не сильно поможет. ТиИ во многих случаях очистит в объектах ссылки на удалённую организацию, вместо того, чтобы их удалить. Кстати, в моём случае ТиИ как раз очищает ссылки, например, в справочнике "Контрагенты" на договоры по умолчанию.
7. nomad_irk 52 11.12.19 07:22 Сейчас в теме
(6)моя обработка решает задачу многократно быстрее, чем типовой механизм и ваш - в этом вся ее прелесть.

В файловой базе она сгененирует скрипт, но нужен "эмулятор" СУБД, который сможет выполнить скрипт и применить это к файлу БД.

Я предусмотрел вариант очистки договоров по-умолчанию, но потестить особо не где, поэтому не знаю на сколько корректно работает.

В общем, вопрос остается открытым: в чем именно заслуга этой обработки, т.к. подобных обработок вагон и маленькая тележка причем за меньшую цену.
8. Техподдержка 11.12.19 07:55
(7) Значит дело, всё-таки в деньгах.

Хорошо, отвечу на Ваш вопрос так: моя обработка - очередной велосипед, только другой модели. Обработка функционирует в рамках лицензионных ограничений 1С и не требует "эмуляторов" СУБД.

Обработка корректно справляется с договорами по умолчанию и с более изощрёнными зависимостями (проверял на специально созданной для этого конфигурации).

Возможно, обработка не стоит таких денег, но за решение задач разделения баз по организациям заказчики платят гораздо больше. В любом случае, спасибо Вам за комментарии.
9. suhoi 30 29.05.20 07:29 Сейчас в теме
Заинтересовала обработка. Есть вопрос - а как получать новые версии - Только покупкой техподдержки?
10. Техподдержка 29.05.20 07:56
(9) Здравствуйте! Новые версии пока не планируются. Покупка техподдержки обязывает отвечать на вопросы покупателя. Ошибки обработки устраняются бесплатно.
12. user1502168 09.12.20 12:52 Сейчас в теме
Добрый день, при проверки вылезают счета фактуры с "значением подчиненного"- договора, и ни одно поле ни в документе СЧ\ф ни в договоре не имеет отношение к искомой организации.
Единственный момент который имеет место быть незаполненное поле в сч\ф "ДокументОснование".
13. Техподдержка 10.12.20 04:19
Здравствуйте! Назовите, пожалуйста, конфигурацию и номер её релиза.
14. user1502168 10.12.20 09:39 Сейчас в теме
(13)1С:Предприятие 8.3 (8.3.16.1224)
Бухгалтерия предприятия КОРП, редакция 3.0 (3.0.84.31)
15. Техподдержка 10.12.20 10:44
(14) Обработка проверяет не только "ближайшие" ссылки (в с/ф указана одна организация, а в договоре - другая), но и цепочки ссылок. Возможно, недопустимая связь между с/ф и договором, которая может привести к ошибочному удалению либо с/ф, либо договора, лежит где-то в глубине цепочки. К сожалению, не видя самой базы, я не могу сказать - стоит обращать внимание на данную связь или нет.

До Вашего случая, алгоритм проверки связей не давал сбоев, хотя допускаю, что он может содержать ошибки. Попробуйте проследить цепочки ссылок на с/ф и договор, используя, например, операцию "Поиск ссылок на объекты" (Функции для технического специалиста / Стандартные / Поиск ссылок на объекты).
16. user1502168 10.12.20 10:59 Сейчас в теме
(15)
учая, алгоритм проверки связей не давал сбоев, хотя допускаю, что он может содержать ошибки. Попробуйте проследить цепо

На сколько длинная может быть цепочка?
В описании сказано: "обработка проверяет правильность использования связанной информации по выбранным организациям." точно ли по выбранным? В данном случае такое ощущение, что по всем возможным некорректным связям организаций.
17. Техподдержка 10.12.20 11:04
(16) Что-то я засомневался. Скажите, какая версия обработки у Вас?
18. user1502168 10.12.20 12:20 Сейчас в теме
19. Техподдержка 10.12.20 12:29
Номер заказа сообщите, пожалуйста.
20. user1502168 10.12.20 12:37 Сейчас в теме
22. user945368 21.12.20 20:44 Сейчас в теме
Добрый день!
С КОРП работает? Бухгалтерия предприятия КОРП, редакция 3.0 (3.0.78.54)
23. Техподдержка 22.12.20 04:12
(22) Работает с любой базой, где есть справочник "Организации".
Оставьте свое сообщение

См. также

Универсальная обработка удаления данных Промо

Универсальные обработки Чистка базы v7.7 v8 1cv8.cf 1cv7.md Россия Платные (руб)

Универсальная обработка удаления как помеченных, так и не помеченных объектов конфигураций 1С 7.7, 8.2, 8.3.

1000 руб.

05.02.2019    10065    10    0    

Удаление дублей объектов

Универсальные обработки Чистка базы v8 1cv8.cf Платные (руб)

Обработка "Удаление дублей объектов" предназначена для поиска дублированных объектов по набору реквизитов и последующему слиянию найденных дублей в единый элемент. Имеет ряд преимуществ по сравнению с типовой обработкой: допускается поиск дублей по нескольким реквизитам, возможность слияния/замены всех ссылочных объектов (не только справочники, например документы, планы видов характеристик, задачи и т.д.), обработка общих реквизитов конфигурации, исправлены выявленные ошибки типовой обработки. Применима для конфигураций на обычных формах, для толстого клиента 1С версии 8.2.

3000 руб.

26.12.2019    4434    1    0    

Универсальное выборочное удаление данных из базы 1С (любые конфигурации на упр.формах: БП 3.0, УТ 11, КА 2, ERP, УНФ, ЗУП 3, Розница и т.д.)

Чистка базы Универсальные обработки v8 v8::УФ Розница УНФ ERP2 ЗКГУ3.0 БП3.0 УТ11 КА2 ЗУП3.x Платные (руб)

Обработка позволяет удобно выборочно удалить данные из базы 1С. Это могут быть как неиспользуемые элементы справочников, так и неактуальные организации. При этом есть возможность провести анализ пересечений документов с другими организациями и таким образом уберечься от того, что при удалении обороты по другой организации изменятся.

3000 руб.

28.11.2019    6972    15    8    

Расширение для очистки дублей в синхронизированных базах (УТ, БП, РТ, УНФ)

Чистка базы v8::УФ 1cv8.cf Россия Платные (руб)

Решение по удалению дублей позволяет определить связанные элементы в двух синхронизированных базах в качестве оригиналов и избежать необходимости ручного сравнения объектов в базах перед синхронизацией.

1000 руб.

27.06.2018    9845    3    0    

SALE! 30%

Комплекс подготовки к свертке базы (удаление данных 8.1, 8.2, 8.3, обычные формы)

Чистка базы v8 1cv8.cf Платные (руб)

Удаление данных прямыми SQL-запросами объектов ссылочного типа и регистров, в том числе с контролем ссылочной целостности.

6000 руб.

13.11.2017    11576    1    3    

Удаление документов организаций из 1С под управляемыми формами

Чистка базы v8 v8::УФ 1cv8.cf Россия Платные (руб)

Удаляет из БД 1С совсем или помечает на удаление документы выбранных в списке организаций. Проверено на БП3, УТ11, УПП, Розница.

2400 руб.

04.08.2017    14133    101    6    

Устранение расхождений между регистрами РАУЗ (регл) и регистрами учета ТМЦ, НЗП в УПП 1.3 и КА 1.1

Чистка базы Поиск данных Закрытие периода Производство готовой продукции (работ, услуг) Закрытие периода Производство готовой продукции (работ, услуг) v8 КА1 УПП1 Россия БУ НУ УУ Платные (руб)

Наведите порядок в остатках номенклатуры и НЗП в УПП Устраните расхождения в остатках номенклатуры Устраните расхождения в остатках НЗП Устраните отрицательные остатки в учете ТМЦ и НЗП

6000 руб.

08.09.2015    39491    6    13    

Свертка базы SQL + Альтернативный контроль удаления помеченных Промо

Свертка базы Чистка базы Производительность и оптимизация (HighLoad) v8 1cv8.cf Платные (руб)

Свертка базы 1с 8.1, 8.2, 8.3 (может использовать прямые запросы к MSSQL, PostgreSQL). Сворачивает документы, регистры накопления, сведений, бухгалтерии (но не регистры расчета). Универсальна, подойдет к любой конфигурации (обратите внимание на известные ограничения). Включает в себя нестандартный быстрый контроль удаления помеченных объектов и удаление помеченных объектов прямыми запросами. Поставляется с исходными кодами.

6500 руб.

13.06.2012    76764    76    102    

Замена Номенклатуры+Характеристики

Чистка базы Обработка справочников Обработка документов Учет ТМЦ Учет ТМЦ v8 v8::ПВХ КА1 УПП1 ERP2 УТ11 КА2 Платные (руб)

Настраиваемая обработка, позволяющая заменить пару: Номенклатура+Характеристика в документах, их движениях и независимых регистрах сведений. Без перепроведения. Поможет, если вы по каким-то причинам решили отказаться от характеристик

3000 руб.

04.08.2015    27766    72    58    

Выборочное удаление организаций из баз (управляемые формы), с удалением всех ссылающихся на эти организации данных

Чистка базы v8 v8::УФ 1cv8.cf Платные (руб)

Позволяет удалить организации из любых программ на управляемых формах (БП 3.0, УТ 11, КА 2, ERP 2, ЗУП 3.0, УНФ, Розница 2.0 и пр.). Главное требование - программа должна содержать справочник "Организации". Реализован самый быстрый алгоритм непосредственного удаления объектов. Работает даже на базах большого размера.

2985 руб.

16.03.2015    75329    233    46    

Удаление данных с отбором и построением дерева ссылок в базах 1С 8.1-8.3 (УТ 10.3, БП 2, ЗУП 2.5, КА 1.1, УТ 11, БП 3, УНФ 1.6, КА 2, ЗУП 3 и т.д.)

Чистка базы Универсальные обработки Обработка документов Поиск данных Обработка справочников v8 v8::УФ 1cv8.cf Платные (руб)

Данные обработки помогут Вам легко и, главное быстро, выполнить удаление любых данных в Ваших базах 1С на платформах 8.1-8.3. Обработки помогут легко просмотреть связи ссылок в виде дерева, выбрать что удалять, а что нет, используя любые отборы. Это позволит уменьшить объем лишней и не нужной информации в справочниках и документах, планах видов характеристик и др. объектах и облегчит работу с данными пользователям и Вам. Понятное расположение команд и настроек, в сочетании с описанием и справкой, еще упростят процесс. Если что-то будет неясно по работе с обработками – я готов Вам помочь. А так же обновления Вы получаете бесплатно в течение года с момента приобретения данных обработок! Данные обработки входят в ТОП-100 продаж за все время, что является залогом популярности, надежности в работе, и признанием других покупателей. (Обновление от 05.04.2020, версия 3.5)

5990 руб.

22.02.2013    105070    198    131    

Правильная свертка или свертка базы по правилам Промо

Свертка базы Чистка базы v8 1cv8.cf Россия Платные (руб)

Обработка "Свертка базы по правилам" предназначена для свертки информационных баз системы программ "1С:Предприятие" версии 8.2. Основой обработки являются специальные правила свертки, которые создаются индивидуально для каждой конфигурации информационной базы. Встроенный в обработку генератор правил позволяет быстро создать правила свертки для любой конфигурации. Например, для конфигурации "1С:Бухгалтерия 8, ред. 3.0" правила свертки были созданы за 15 минут!

2000 руб.

22.07.2013    132294    515    486    

Выборочное удаление помеченных объектов с отображением иерархии ссылок (с возможностью немонопольного удаления, порционного удаления, быстрой очистки регистров сведений для управляемых форм 1С 8.2)

Чистка базы Поиск данных Универсальные обработки v8 v8::УФ 1cv8.cf Россия Платные (руб)

Обработка для выборочного удаления помеченных на удаление объектов с возможностью отображения дерева ссылок на помеченный объект,а также последующего удаления объектов по данным найденным ссылкам в этой иерархии из-за чего первоначальный объект удалить невозможно (так называемый "рекурсивный обход"). Обработка позволяет вручную проставить пометки на удаление, включая записи регистров сведений. Также она позволяет производить т.н. "порционное удаление" объектов, то есть порциями с настраиваемым количеством штук в одной порции и периодом повторных запусков удаления следующих порций. Также в обработке можно устанавливать период для документов, из которого обработка начнет искать помеченные на удаление.

3990 руб.

23.08.2012    46622    24    15    

Очистка базы от документов УУ, версия на SQL

Чистка базы v8 УПП1 Россия Платные (руб)

Если вам нужно быстро очистить базу от документов и их движений, которые проведены только в УУ, то эта обработка для вас.

1000 руб.

22.11.2011    12809    0    9    

Быстрый поиск дублей с четким/нечетким поиском по любому сочетанию реквизитов/реквизитов таб. частей с отбором и быстрой заменой значений в ЛЮБЫХ базах 8.1-8.3 (УТ 10.3, БП 2, ЗУП 2.5, КА 1.1, УТ 11, БП 3, УНФ 1.6, КА 2, ЗУП 3 и т.д.) Промо

Чистка базы Поиск данных Универсальные обработки Обработка справочников Обработка документов v8 v8::УФ 1cv8.cf Платные (руб)

Данные обработки помогут Вам легко и, главное, быстро (в 5 раз и более быстрее штатной обработки 1С), выполнить поиск дублирующих данных в Ваших базах 1С на платформах 8.1-8.3. Это позволит уменьшить объем лишней информации в справочниках и документах, планах видов характеристик и др., упростит работу с данными пользователям. А так же можно, одним нажатием, узнать в каких ссылочных объектах есть вообще дубли! Понятное расположение команд и настроек, в сочетании с описанием и справкой, еще упростят процесс. Если что-то будет неясно по работе с обработками – я готов Вам помочь. А так же обновления Вы получаете бесплатно в течение года с момента приобретения данных обработок! Данные обработки входят в ТОП-100 продаж за все время, что является залогом популярности, надежности в работе, и признанием других покупателей. (Обновление от 23.08.2019, версия 6.20, 6.30)

5990 руб.

14.05.2012    115443    259    221