Удаление спящих сеансов

Публикация № 1169066

Администрирование - Администрирование СУБД

УПП спящие зависшие сеансы сервер блокировки

Удаление сеансов, имеющих статус "спящий".

Иногда возникает ситуация, когда настроенные ограничения спящих сеансов не срабатывают, и сервер 1С не только их "копит", даже по прошествии отведенного времени не закрывает, но и открывает их вновь "спящими" после полной перезагрузки сервера! Как бороться - есть разные способы, с перезапуском службы и очисткой кеша перед запуском, есть какие-то исполняемые файлы здесь на Инфостарте (но убивают все сеансы!).  Так или иначе, иногда хочется освободить память, и выкинуть таких "демонов". Пускать любого в админские права не хочется, поэтому сделал такую кнопку в самой УПП. Запускаем - все зависшие сеансы завершаются. Может, кому-то пригодится такая внешняя обработка...

Тестировалось на УПП 1.3.123.3, Платформа/сервер 8.3.15.1700.

Скачать файлы

Наименование Файл Версия Размер
Удаление спящих сеансов:

.epf 8,00Kb
16.12.19
11
.epf 8,00Kb 11 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо свернутое
1. cherva 96 18.12.19 11:09 Сейчас в теме
На платформе 8.3.14.1779 не работает
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(31)}: Метод объекта не обнаружен (ConnectAgent)
АгентСервера = COMСоединитель.ConnectAgent(ИдентификаторАгентаСервера);
2. &-rey 71 18.12.19 14:50 Сейчас в теме
COM не зарегистрирован, странно, может подключаетесь через тонкий клиент и пытается не на самом сервере искать подключение к серверу 1С?
3. cherva 96 18.12.19 16:09 Сейчас в теме
Предыдущую ошибку победили теперь это:


{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(31)}: Ошибка при вызове метода контекста (ConnectAgent)
АгентСервера = COMСоединитель.ConnectAgent(ИдентификаторАгентаСервера);
по причине:
Произошла исключительная ситуация (V83.COMConnector.1): server_addr=tcp://mos1csrv:1540 descr=192.168.1.142:1540:10061(0x0000274D): Подключение не установлено, т.к. конечный компьютер отверг запрос на подключение. ;
line=1056 file=d:\jenkins\ci_builder\windowsbuild2\platform\src\rtrsrvc\src\d­ataexchangetcpclientimpl.cpp


У нас сервер на портах 17ХХ
4. &-rey 71 19.12.19 08:51 Сейчас в теме
порт у вас вроде бы стандартный 1540, все верно определилось, на 17хх у вас не сервер 1с наверное? Это видно по строке
"C:\Program Files\1cv8\8.3.15.1700\bin\ragent.exe" -srvc -agent -regport 1541 -port 1540 -range 1560:1591 -d "C:\Program Files\1cv8\srvinfo"
в свойствах службы агента сервера 1с, строка запуска....
тут вобщем то код пятиминутный, почти полностью дернут из общего модуля СоединенияИБКлиентСервер, функция ПолучитьАктивныеСеансыИБ. Затем из полученных перебираю и закрываю только спящие...


Процедура КнопкаВыполнитьНажатие(Кнопка)
	ПараметрыАдминистрированияИБ = СоединенияИБ.ПолучитьПараметрыАдминистрированияИБ(); 
	НастройкаБлокировки = ПараметрыАдминистрированияИБ;
	ВсеКромеТекущего = Истина;
	Результат = Новый Структура("АгентСервера,КластерСерверов,Сеансы", Неопределено, Неопределено, Новый Массив);
	
	ПодстрокиСтрокиСоединения = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(
	СтрокаСоединенияИнформационнойБазы(), ";");	
	ИмяСервера = СтроковыеФункцииКлиентСервер.СократитьДвойныеКавычки(Сред(ПодстрокиСтрокиСоединения[0], 7));
	ИмяИБ      = СтроковыеФункцииКлиентСервер.СократитьДвойныеКавычки(Сред(ПодстрокиСтрокиСоединения[1], 6));
	COMСоединитель = Новый COMОбъект(ОбщегоНазначения.ИмяCOMСоединителя());	
	РазделительПорта = Найти(ИмяСервера, ":");
	Если РазделительПорта > 0 Тогда
		ИмяИПортСервера = ИмяСервера;
		ИмяСервера = Сред(ИмяИПортСервера, 1, РазделительПорта - 1);
		НомерПортаКластера = Число(Сред(ИмяИПортСервера, РазделительПорта + 1));
	ИначеЕсли НастройкаБлокировки.ПортКластераСерверов <> 0 Тогда
		НомерПортаКластера = НастройкаБлокировки.ПортКластераСерверов;
	Иначе
		НомерПортаКластера = COMСоединитель.RMngrPortDefault;
	КонецЕсли;
	
	ИдентификаторАгентаСервера = ИмяСервера;
	Если НастройкаБлокировки.ПортАгентаСервера <> 0 Тогда
		ИдентификаторАгентаСервера = ИдентификаторАгентаСервера + ":" + 
			Формат(НастройкаБлокировки.ПортАгентаСервера, "ЧГ=0");
	КонецЕсли;
	
	// Подключение к агенту сервера
	АгентСервера = COMСоединитель.ConnectAgent(ИдентификаторАгентаСервера);
	Результат.АгентСервера = АгентСервера; 
	
	// Найдем необходимый нам кластер
	Для каждого Кластер Из АгентСервера.GetClusters() Цикл		
		Если Кластер.MainPort <> НомерПортаКластера Тогда
			Продолжить;
		КонецЕсли;		
		Результат.КластерСерверов = Кластер; 
		АгентСервера.Authenticate(Кластер, НастройкаБлокировки.ИмяАдминистратораКластера, 
			НастройкаБлокировки.ПарольАдминистратораКластера);		
		// Получаем список сеансов
		НомерТекущегоСеанса = СоединенияИБПовтИсп.ПараметрыОтключенияСеансов().НомерСеансаИнформационнойБазы;
		СписокСеансов = АгентСервера.GetSessions(Кластер);
		Для Каждого Сеанс из СписокСеансов Цикл
			Если ВРег(Сеанс.InfoBase.Name) <> ВРег(ИмяИБ) Тогда
				Продолжить;
			КонецЕсли;
			Если НЕ ВсеКромеТекущего ИЛИ (НомерТекущегоСеанса <> Сеанс.SessionID) Тогда
				Результат.Сеансы.Добавить(Сеанс);
			КонецЕсли;
		КонецЦикла;		
	КонецЦикла;

   //Теперь пройдемся по сеансам и если он спящий - выкинем
   Для каждого сеанс из Результат.Сеансы цикл
	   Если Сеанс.Hibernate тогда
		    СоединенияИБКлиентСервер.ОтключитьСеанс(сеанс.SessionID, "Злой админ послал вас на ...")
	   КонецЕсли;
   КонецЦикла;
   Предупреждение("ВСЕ ДЕМОНЫ УБИТЫ!!!", 5,"Удаление зависших сеансов");
   ЭтаФорма.Закрыть();
КонецПроцедуры
Показать
5. cherva 96 19.12.19 12:42 Сейчас в теме
нет сервер 1с у нас на портах 17Х. И в строка запуска 1С
\\ххххххх\1ce\1cestart.exe enterprise /Sхххххх:1741\gsiupp1 /RunModeOrdinaryApplication

Просто на 15ХХ стоит сервер 1С 8.2 , но он не запущен. А сервер 8.1 стоит именно на 17ХХ портах, может ваша обработка неправильно цепляет не тот сервер?
6. nomad_irk 49 19.12.19 12:50 Сейчас в теме
(0)Чем не устраивает типовой настраиваемый механизм завершения сеансов?
Оставьте свое сообщение

См. также

Легкое и гибкое управление списком доступных баз 1С у пользователей Промо

Стартеры 1С Сервисные утилиты Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Когда в локальной сети много пользователей, а еще большое количество различных баз и при этом каждому нужны свои, то администрирование этого зоопарка превращается в АД! Этот комплекс позволяет централизованно управлять списком доступных баз в разрезе пользователей. За пару кликов можно добавить или убрать базу у всех пользователей.

7 стартмани

05.12.2018    15534    16    RomikR    9    

Шаблон обработки для выполнения по областям данных

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Нередко приходится передавать команде по эксплуатации обработки по настройке или миграции данных, которые нельзя вшить в процедуру обновления информационной базы. Задача заключается в том, чтобы это была обработка с кнопкой "Сделать хорошо" и не требовала от эксплуатации каких либо дополнительных действий. Для решения подобных задач был сделан этот шаблон.

24.09.2020    535    0    pallid    0    

Автозавершение работы пользователей

Администрирование СУБД v8 v8::БУ БП3.0 БАУ Россия Абонемент ($m)

Расширение выбрасывает активных пользователей из БД в заданный промежуток времени.

1 стартмани

23.09.2020    450    2    maksa2005    0    

Значения по умолчанию для пользователей (Расширение)

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

При заполнении документов и справочников пользователи часто сталкиваются с необходимостью ввода одних и тех же реквизитов. Заполнение в документах некоторых из них, таких как: Организация, Склад и т.п. - выполняется реализованным в 1С механизмом подстановки значения из последних 3-5 введенных документов. Если же вы хотите заполнять все реквизиты шапки (и даты, и флажки, и другие поля, включая дополнительные реквизиты), то вам поможет данный механизм.

2 стартмани

21.09.2020    3761    17    sapervodichka    26    

Мастер создания копии информационной базы для отчетности

Производительность и оптимизация (HighLoad) Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Прототип инструмента для подготовки реплики в режиме только для чтения к использованию. Позволяет использовать "read-only" реплики как обычные информационные базы 1С.

10 стартмани

28.08.2020    3925    1    YPermitin    9    

Подключение к другой базе по OLE с выбором базы для 8.3 (через COMОбъект("V83.Application"))

Администрирование СУБД v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка демонстрирует методику подключения к другой базе 1С v8.3 с возможностью выбора базы из привычного окна выбора баз и с вводом имени пользователя и пароля. Также приведен пример работы с HTML документом, и созданием и заполнением дерева значений в управляемых формах.

1 стартмани

17.08.2020    957    3    bayce    2    

Размер таблиц 1С в базе данных MS SQL

Статистика базы данных Администрирование СУБД v8 Абонемент ($m)

Данная обработка позволяет получить структуру БД 1С и размер таблиц без использования механизма ADODB соединения с БД MSSQL.

1 стартмани

14.08.2020    1207    6    donpadlo    4    

Копирование базы без конфигуратора

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Продолжаем нарушать правила, рвать шаблоны и делать невозможное!

1 стартмани

15.07.2020    3684    7    m-rv    36    

Переход с ERP на КА 2 или УТ 11

Администрирование СУБД Обмен данными 1С Перенос данных из 1C8 в 1C8 v8 УТ11 КА2 УУ Абонемент ($m)

Как известно сейчас 1С реализует программные продукты «1С:ERP Управление предприятием 2», «1С:Комплексная автоматизация 2» и «1С:Управление торговлей 11» одним блоком. Именно благодаря этому подходу на текущий момент во всех решениях есть переход на решения более высокого уровня. Ну как говорится если можно вперед, значит можно и назад. Хотя данный подход нигде и не задокументирован.

1 стартмани

13.07.2020    2164    1    user923728    0    

Сравнение пометок удаления в текущей и архивной копии базы

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Эта обработка подключается к указанному архиву базы и сравнивает его с текущей конфигурацией на пометку удаления. При необходимости можно отменить привести к соответствию эти базы нажатием всего на одну кнопку.

2 стартмани

13.07.2020    1552    1    nurligaianov    0    

Подбор последовательности обновления

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Обработка позволяет найти самый короткий путь для обновления древнего релиза.

1 стартмани

08.07.2020    1661    0    Dmitr033    9    

Система контроля действий пользователя / Employee Monitoring Software (СКДП, EMS)

Администрирование СУБД v8 ERP2 Россия Абонемент ($m)

Подсистема для сбора информации об активности пользователей.

1 стартмани

29.06.2020    2569    3    PerlAmutor    0    

Получение списка необновлённых баз напрямую из SQL

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Обработка будет полезна в организациях с большим числом баз. Позволяет быстро сформировать список тех баз, у которых редактируемая конфигурация отличается от конфигурации БД.

1 стартмани

01.06.2020    1237    1    cvsbook    0    

Обслуживание базы данных на PostgreSQL

Администрирование СУБД v8 Россия Абонемент ($m)

Предысторией создания данного продукта был перевод одного из своих клиентов на PostgreSQL. Серверная платформа не позволяла установить там pgAdmin. А скриптами и планировщиками пользоваться неудобно. Поэтому пришла идея реализовать обслуживание баз данных PostgreSQL средствами 1С.

1 стартмани

27.05.2020    2723    7    andrewbc    9    

Включение отладки на сервере

Администрирование СУБД v8 Абонемент ($m)

Два простых VBS скрипта для автоматического включения отладки на сервере для x32 и x64 систем.

1 стартмани

20.05.2020    1494    2    Andy_NTG    0    

Оптимизация и работа с системными представлениями

Администрирование СУБД v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка сделана для понимания работы системных представлений. В принципе, вы можете написать целую систему мониторинга ресурсов. Основа для этого, как раз, и дана в этой обработке. Внешний вид особо не шлифовался. Считаю, что это не так критично. Использовал обращение только к MS SQL, но при желании, такое же можно написать и для Postgres, и для Oracle. Тестировал на платформе 1С 8.2.19.90.

1 стартмани

12.05.2020    1596    1    darkdan77    1    

Ошибка "Для одного ссылочного кода существует более одной таблицы в базе данных" - как проще исправить

Администрирование СУБД Тестирование и исправление v8 v8::УФ 1cv8.cf Абонемент ($m)

При обновлении платформы 1с 8.3.6.2100 на платформу 8.3.16.224 под УПП 1.3.138.1 возникла ошибка "Для одного ссылочного кода существует более одной таблицы в базе данных...". В интернете много есть информации по этой проблеме, в частности в публикации https://infostart.ru/public/1126277/ приведено ее решение, но оно довольно громоздкое. Есть вариант более простой

2 стартмани

28.04.2020    2716    2    Ион    3    

Проверка подписки ИТС

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Проверка подписки ИТС по регистрационным номерам, логинам. Практическое применение API по интеграции с Порталом 1С:ИТС.

1 стартмани

17.03.2020    2495    7    kostik_love    0    

История работы пользователей (отчет на СКД)

Администрирование СУБД v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Отчет для просмотра истории работы пользователей (СКД, просмотр для любого пользователя).

2 стартмани

14.03.2020    5781    56    YPermitin    26    

Ограничение доступа в базу по количеству сеансов или дате

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Расширение позволяет ограничить доступ в базу по количеству активных сеансов или дате. Не затрагивает объекты типовой конфигурации. Сделано и протестировано на БП 8.3 версий 3.0.65.84 и выше. Требует платформу не ниже 8.3.16. Представлены версии расширения для конфигураций с режимом совместимости 8.3.12, 8.3.14 и 8.3.15.

2 стартмани

12.03.2020    1990    2    folo    0    

Очистка хранилища настроек пользователей (обычные и управляемые формы)

Администрирование СУБД v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка очищает хранилище настроек пользователей.

1 стартмани

10.02.2020    2390    20    Denr83    0    

Изменение имени домена для выбранных пользователей информационной базы

Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Предлагаю Вашему вниманию обработку используемую в реальном производственном процессе на нашем предприятии. Задача переименования доменов возникла при реорганизации предприятия, имена некоторых доменов для удобства решено было изменить, но при таком количестве пользователей изменение имен доменов штатными средствами выглядело нереально. Было решено создать обработку для изменения имен доменов Информационной базы. Обработка предназначена для работы в клиент-серверных базах и тестировалась на платформе 8.3.14.1854. Работает в режиме внешней обработки.

1 стартмани

30.01.2020    2047    0    bryantsev.yury    0    

Транслятор запросов 1С в SQL

Производительность и оптимизация (HighLoad) Администрирование СУБД v8 v8::Запросы 1cv8.cf Абонемент ($m)

Инструмент для трансляции запросов платформы 1С в SQL, а также их диагностики.

10 стартмани

07.01.2020    13394    106    YPermitin    89    

Проверка SQL базы данных 1С 8.1, 8.2, 8.3

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Обработка предназначена для проверки SQL базы данных 1С. Используется только для клиент-серверной версии 1С, у которой база данных хранится под управлением MS SQL Server. Конфигурация 1С значения не имеет.

2 стартмани

25.12.2019    7049    39    dgonson    19    

Очистка кэша нескольких баз прямо из 1С

Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Обработка предназначена для очистка кэша нескольких баз непосредственно из 1С (только в обычном режиме).

1 стартмани

04.12.2019    3805    17    r.moschenskiy    2    

Работа с базами данных 1С в SQL Server Management Studio (Расширение для SSMS)

Администрирование СУБД Производительность и оптимизация (HighLoad) Администрирование данных 1С Структура метаданных v8 Абонемент ($m)

Расширение позволяет просматривать связи объектов метаданных и таблиц БД, сгруппированные данные (по группам метаданных) об используемом дисковом пространстве и выполнять трансляцию SQL текста запроса в термины 1С. И бонусом - при наведении курсора мыши на таблицу или поле показывает назначение объекта в терминах 1С.

10 стартмани

27.11.2019    11581    41    akpaevj    46    

Запуск внешних обработок по списку пользователей

Роли и права Администрирование СУБД v8 БП3.0 Абонемент ($m)

Создает командный файл для запуска пользователей по списку.

1 стартмани

07.11.2019    4681    2    Mari_Kuznetzova    0    

Монитор показателей и лицензий с графиками

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Онлайн диаграмма лицензий 1С и показателей сервера 1С в различных измерениях и отборах.

1 стартмани

07.10.2019    13586    140    sapervodichka    17    

CF & SQL : конструктор прямых запросов к БД 1С

Инструментарий разработчика Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Программа для чтения и анализа внутренней структуры данных 1С V8.х, Содержит конструктор прямых SQL запросов, позволяет обрабатывать и редактировать тексты SQL-запросов, выполнять прямые запросы к базе данных 1С и обрабатывать полученные результаты.

1 стартмани

02.10.2019    18638    198    dmitrydemenew    45    

Закрытие незавершенных сеансов

Сервисные утилиты Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Как удалять потерянные сеансы пользователей, чтобы они не мешали работе. Обработка протестирована на платформе версии 8.3.13.1644.

1 стартмани

20.09.2019    13233    59    AnatolPopov    8    

Создание пользователей системы взаимодействия

Обработка справочников Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Простенькая команда по созданию пользователей в системе взаимодействия на базе всех пользователей информационной базы 1С.

1 стартмани

12.12.2018    3963    8    da_1c    0    

Анализ настроек кластеров 1С (+ менеджер файлов на сервере)

Сервисные утилиты Администрирование СУБД v8::УФ 1cv8.cf Абонемент ($m)

Итак, у вас количество баз давно перевалило за десяток. Все эти базы раскиданы по кластерам. К тому же и версии платформы 1С у этих баз разные. Ну а вы, к несчастью - администратор всего этого хозяйства. К несчастью, потому что вы администратор 1С. А это необычный администратор. Случается так, что вы не имеете прав локального администратора, а консоль сервера приложений на вашем рабочем месте не установлена. Но не беда, поставить ее вам готовы уже завтра-послезавтра.

10 стартмани

26.12.2015    26670    65    zenechka    33    

Скрипт для выгрузки информационной базы

Архивирование (backup) Скрипты автоматизации Администрирование СУБД v8 Россия Абонемент ($m)

Скрипт позволяет произвести выгрузку информационной базы 1С клиент-серверного варианта.

1 стартмани

06.11.2015    30426    14    bashirov.rs    23