Ошибка в отчете "Справки по НДФЛ" в Комплексной р.517

Публикация № 118534

Учет и отчетность - Зарплата

Исправление ошибки расчета сумм вычетов (по кодам 311, 312, 318) в п. 4.1 отчета "Справки по НДФЛ".

При создании справок в п.4.1. "Суммы предоставленных налогоплательщику налоговых вычетов" по кодам вычетов 311, 312, 318 неверно формируются суммы вычетов, т.е. суммируются накопительные суммы.

Для наглядности:

должно быть: (Январь 4000) + (Февраль 4000) + (Март 4000) = 12000

в отчете: (Январь 4000) + (Февраль 8000) + (Март 12000) = 24000

надеюсь понятно.


Исправление:

в стр. 2128 модуля отчета "СправкиПоНДФЛ" в Функция СоздатьСправкиПоСотруднику2011(...)

Заменить код

//вычеты предоставленные
СписокВычетовПредоставленных=ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(1);
СписокВычетовПредоставленных.Выгрузить(СписокВычетов);

Вычеты311=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(3));
Вычеты312=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(4));
Вычеты318=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(9));

СписокВычетов.ДобавитьЗначение(Вычеты311,"311");
СписокВычетов.ДобавитьЗначение(Вычеты312,"312");
СписокВычетов.ДобавитьЗначение(Вычеты318,"318");

Если СчМесяцев>1 Тогда

//вычеты предоставленные
СписокВычетовПредоставленныхПрошлМесяц=ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(1);

Вычеты311=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(3));
Вычеты312=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(4));
Вычеты318=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(9));

СписокВычетовПредоставленныхПрошлМесяц.ДобавитьЗначение(Вычеты311,"311");
СписокВычетовПредоставленныхПрошлМесяц.ДобавитьЗначение(Вычеты312,"312");
СписокВычетовПредоставленныхПрошлМесяц.ДобавитьЗначение(Вычеты318,"318");

Для СчВычетов = 1 По СписокВычетовПраво.РазмерСписка() Цикл

КодВычета = "";
СписокВычетовПраво.ПолучитьЗначение(СчВычетов,КодВычета);

РазмерВычета = Число(СписокВычетов.Получить(КодВычета));

РазмерВычетаПрошлМесяц = Число(СписокВычетовПредоставленныхПрошлМесяц.Получить(КодВычета));
РазмерВычета = РазмерВычета - РазмерВычетаПрошлМесяц;
СписокВычетов.Установить(КодВычета,РазмерВычета);

КонецЦикла;

КонецЕсли;



на



//вычеты предоставленные
СписокВычетовПредоставленных=ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(1);
СписокВычетовПредоставленных.Выгрузить(СписокВычетов);

Вычеты311=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(3));
Вычеты312=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(4));
Вычеты318=Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев,3).ПолучитьЗначение(9));

Если СчМесяцев>1 Тогда 


//вычеты предоставленные
СписокВычетовПредоставленныхПрошлМесяц=ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(1);

Вычеты311=Вычеты311-Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(3));
Вычеты312=Вычеты312-Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(4));
Вычеты318=Вычеты318-Число(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1+СчМесяцев-1,3).ПолучитьЗначение(9));

СписокВычетовПредоставленныхПрошлМесяц.ДобавитьЗначение(Вычеты311,"311");
СписокВычетовПредоставленныхПрошлМесяц.ДобавитьЗначение(Вычеты312,"312");
СписокВычетовПредоставленныхПрошлМесяц.ДобавитьЗначение(Вычеты318,"318");

Для СчВычетов = 1 По СписокВычетовПраво.РазмерСписка() Цикл

КодВычета = "";
СписокВычетовПраво.ПолучитьЗначение(СчВычетов,КодВычета);

РазмерВычета = Число(СписокВычетов.Получить(КодВычета));

РазмерВычетаПрошлМесяц = Число(СписокВычетовПредоставленныхПрошлМесяц.Получить(КодВычета));
РазмерВычета = РазмерВычета - РазмерВычетаПрошлМесяц;
СписокВычетов.Установить(КодВычета,РазмерВычета);

КонецЦикла;

КонецЕсли;

СписокВычетов.ДобавитьЗначение(Вычеты311,"311");
СписокВычетов.ДобавитьЗначение(Вычеты312,"312");
СписокВычетов.ДобавитьЗначение(Вычеты318,"318");



Буду рад если хоть кому-то статья окажется полезным.

Специальные предложения

Оставьте свое сообщение

См. также

Записки на память. Зарплата и кадры 1С 7.7 (ЗиК 7.7 )

Бухгалтерский учет Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v77::Расчет 1С7:ЗиК Россия БУ НУ УУ Бесплатно (free)

ЗиК 7.7 постепенно сходит на нет. Но, возможно, кому-то из нас все-таки когда-либо еще не раз придется столкнуться с этой конфигурацией. Поскольку работы по ней и заказов всё меньше и меньше, знания о ней и опыт постепенно угасают. Мой опыт с ЗиК 7.7 длиной в 14 лет терять просто так неохота. В этой статье я запишу, чтобы не забыть, важные моменты об этой конфигурации, чтобы самому не забыть, и вдруг кто-то получит это в наследство на сопровождение и будет вынужден (иначе не скажешь) это обслуживать. Или еще можно рассматривать эту статью как модное нынче «Письмо самому себе в прошлое».

18.11.2014    39477    0    Lapitskiy    26    

Подготовка сведений для ПФР ЗиК Исправление ошибок

Адаптация типовых решений Зарплата Зарплата v77::Расчет 1С7:ЗиК БУ ФОМС, ПФ, ФСС Бесплатно (free)

Подготовка сведений для ПФР ЗиК Исправление ошибок. Для сотрудников, у которых во 2,3 или 4 квартале не было заработка, но есть стаж (например, декретницы) не заполняется «Сумма выплат с начала года».

30.07.2014    16105    0    Cvetic    4    

Подготовка сведений для ПФР ЗиК 339. СЗВ-6-4 две незначительные ошибки.

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Подготовка сведений для ПФР ЗиК 339. СЗВ-6-4 две незначительные ошибки: 1.При переносе сотрудника из одной пачки в другую у него теряются сведения о выплатах. 2.Неактивна кнопка сортировки сотрудников.

11.10.2013    12578    0    Cvetic    7    

Перерасчет ФСС НС за предыдущий период в ЗиК 315

Адаптация типовых решений Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Если изменить базу вида расчета «ФСС НС», то в релизе 1С:Зарплата и Кадры 7.70.315, в текущем расчетном периоде не происходит перерасчет за предыдущие периоды.

02.11.2011    17401    0    Nicholas    13    

Неправильное изменение категории плательщика ПФР при проведении справки МСЭК

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

В ЗиК (релиз 314) при проведении документа "Справка МСЭК" вкралась ошибка: проведение некорректно изменяет категорию плательщика ПФР на "Работник сельскохозяйственной организации - инвалид", затем на "Работник колхоза, совхоза и другого сельскохозяйственного предприятия". Связано это с разными типами ожидаемого и возвращаемого перечисления в функции "глКатегорияПФР": "КатегорияПлательщикаПФ" и "КатегорииЗастрахованныхЛицПФР". Решение: изменить функцию "глКатегорияПФР" (около 2932-й строки).

17.10.2011    6126    0    Krokokot    3    

ЗиК: Заполнение данных о заработке у предыдущих работодателей в больничном

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ Бесплатно (free)

Доработка ЗиК 314. Заполнение данных в больничном за 2 предыдущих года у другого работодателя. Для работы необходимо добавить в конфигурацию новый справочник.

04.10.2011    11568    0    allexe    13    

Компенсация отпуска, оплата дней доноров и оплата льготных дней родителей в ЗиК

Практика программирования Зарплата Зарплата v77::Расчет 1cv7.md 1С7:ЗиК Россия Бесплатно (free)

"Компенсация отпуска"," Оплата дней доноров" и "Оплата льготных дней родителей" - эти виды расчетов должны облагаться страховыми взносами с 01.01.2011 года.

04.10.2011    8953    0    maxim305    18    

Отпуск по уходу за ребенком. Печать расчета среднего заработка

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ Бесплатно (free)

Печать расчета среднего заработка в документе "отпуск по уходу за ребенком" по старым/новым правилам, реализованная в ЗиК 7.70.313, содержит досадную ошибку - если вызвать печать в уже проведенном документе, всегда выдается отчет для новых правил.

23.09.2011    5370    0    Gr@nd@d    5    

1С 7.7 ЗиК. Доработка документа "Бригадный наряд" с возможностью увидеть часы в расчетном листке

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ Бесплатно (free)

Маленькая доработка модуля документа "Бригадный наряд" с возможностью увидеть часы в расчетном листке. Не забудьте, когда будете заполнять документ "Бригадный наряд", поставить галочку "Учитывать отработанные часы".

08.09.2011    6795    0    Ироида    14    

Расчет сверхурочной работы

Зарплата Учет рабочего времени Бухгалтерские Зарплата Учет рабочего времени v77::Расчет 1С7:ЗиК 1С7:Комплекс Россия БУ Бесплатно (free)

Сверхурочной работой считается работа, производимая работником по инициативе работодателя сверх нормального числа рабочих часов за учетный период (п.1 ч.2 ст. 99 ТК РФ). Данная обработка позволяет автоматически по итогам учетного периода (месяц, квартал, год) расчитать переработку сотрудников и расчитать им доплату за сверхурочную работу.

31.08.2011    21482    0    victuan    29    

Расшифровка внутренних расчетов 1С:Зарплата

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

Трассировка (расшифровка) промежуточных расчетов документов в 1С:Зарплата

20.07.2011    10545    0    buhinfo    5    

Регистр учета удержанных и перечисленных сумм по исполнительным документам

Печатные формы документов Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ Бесплатно (free)

Заполните банковские реквизиты получателя и выберите способ - перечисление на банковский счет, тогда будут выводится банковские данные. Если в текущем месяце выплачена ЗП, тогда Фактически удержано = Следовало удержать.

04.07.2011    7570    0    fisgen    3    

Методика расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года (вариант)

Практика программирования Зарплата Зарплата v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Бесплатно (free)

В статье рассмотрен один из возможных вариантов расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года.

14.06.2011    21759    0    vkr    48    

Ошибка Выгрузки проводок из ЗиК 311 в Бухгалтерию бюджетного учреждения

Зарплата Перенос данных из 1С7.7 в 1C8.X Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

При формировании свода проводок и выгрузке проводок из ЗиК 311 в Бухгалтерию бюджетного учр. используется как "новый" 401.20 так и "старый" счет 401.01 ( там собираются "копейки"). Бухгалтерия ред6.2 отказывается грузить такие проводки.

07.06.2011    8477    0    RUS63    6    

Лицевой счет для ЗиК 7.7

Универсальные печатные формы Бухгалтерские Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v77::Расчет 1С7:ЗиК Бесплатно (free)

В ЗиКе есть отчет Лицевые счета и карточки-справки. Для хозрасчетных организаций печатная форма только одна Т-54а, для бюджетных организаций имеется еще 2 печатных формы довольно удобных. В обработке сохранен отчет с установленным флагом бюджетной организации. Может кому пригодится.

12.05.2011    9811    0    VladB50    7    

Форма 1-НДФЛ для 2011 года (Зарплата и Кадры 7.7, релиз 310)

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ НДФЛ Бесплатно (free)

В прежних релизах была возможность из справочника "Сотрудники" сформировать форму 1-НДФЛ по кнопке "Ввод данных" (там была возможность расшифровки сумм). Вернём полезную функцию!

29.04.2011    6718    0    Q-Q    9    

ЗиК Расходы предприятия за счет ФСС. Реестр начисленных пособий за месяц.

Адаптация типовых решений Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Для больничных листов за 2010, проведенных в 2011, дни за счет работодателя = 3, вместо 2.

15.04.2011    15910    0    Cvetic    3    

Форма 4-ФСС с автозаполнением за 1 кв. 2011 г. + Исправление количества знаков после запятой в Разделе 1

Регламентированная отчетность Зарплата Зарплата v77::БУ 1С7:Бух 1С7:Комплекс 1С7:ПУБ Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Форма 4-ФСС с автозаполнением за 1 кв. 2011 г. + Исправление количества знаков после запятой в Разделе 1. Видимы и работоспособны кнопки Заполнить, Расшифровать и Заполняется по внешним данным.

05.04.2011    18078    0    911service    27    

Две простенькие функции для правильного учета сторно-записей и записей-перерасчетов

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ Бесплатно (free)

Часто при подсчете дней по записям журнала расчетов "Зарплата" берется знак "+" или "-" в зависимости от признака сторно-записи. Но рано или поздно результат получится ошибочным.

19.02.2011    10898    0    jack19    3    

Ошибки формата файла 2-НДФЛ в ЗиК релиз 306

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия НУ НДФЛ Бесплатно (free)

Ошибки 2НДФЛ в релизе: файл формируется как для ЮЛ, даже если работодатель ИП, опечатка "Отчетсвто", и указание имени файла с расширением. Нужно подправить отчет "СправкиПоНДФЛ".

02.02.2011    19943    0    1st    6    

ПФР за год

Зарплата Учет и отчетность v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Могу подсказать алгоритм, как надо заполнять документ "Расчеты по страховым взносам", чтобы отчет для ПФР сошелся в копеечку

29.01.2011    8633    0    Lika-Kalika    3    

ЗиК 305 ЗиК 306 Больничный лист.

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

Для переходящих больничных листов за счет работодателя оплачивается 2 дня, а не 3. Первоисточник: http://forums.kuban.ru/forum/viewtopi...669&page=2

25.01.2011    14672    0    Cvetic    26    

ЗиК 306 и ЗиК 305. Единовременные пособия из ФСС для организаций уплащивающих ЕНВД

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Возникла ошибка когда Единовременные пособия из ФСС неправильно вставали в "Карточку расчета страховых взносов" если были выплаченны после сентября месяца. и сотвественно неправильно формируеться РСВ-1

25.01.2011    9943    0    *Zed*    2    

Перечисление зарплаты на пластиковые карты банка УралСиб

Обработка документов Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

Дополнительный документ в конфигурацию ЗиК 7.7 для перечисления зарплаты на пластиковые карты банка УралСиб

23.01.2011    6492    0    vladb50@mail.ru    5    

Бух 2011 (ставки ФОМС)

Обработка справочников Зарплата Зарплата v77::БУ 1С7:Бух Россия БУ НУ ФОМС, ПФ, ФСС Бесплатно (free)

Обработка устанавливает в типовых конфигурациях "1С:Бухгалтерия 7.7" (релиз 521) и "1С:Упрощенная система налогообложения 7.7" (релиз 177) ставки страховых взносов, измененные с 1 января 2011 года Федеральным законом от 16.10.10 № 272-ФЗ.

11.01.2011    14119    0    Antia    7    

ЗиК 2011 (ставки ФОМС)

Обработка справочников Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v77::Расчет 1С7:ЗиК Россия БУ НУ ФОМС, ПФ, ФСС Бесплатно (free)

Обработка устанавливает в типовой конфигурации "Зарплата и Кадры 7.7" (релиз 305) ставки страховых взносов, измененные с 1 января 2011 года Федеральным законом от 16.10.10 № 272-ФЗ.

09.01.2011    13906    0    Antia    11    

Ошибка в ЗиК 300, 299, 298. Разные виды расчета имеют одинаковые синонимы.

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

В ЗиК 300, 299, 298 разные виды расчета имеют одинаковые синонимы. В следствие их неотличимости можно задать шаблон проводок не на тот вид расчета и получить ошибку "Некорректно сопоставляется проводка из подразделения сотрудника..."

19.09.2010    2813    0    safsn0    2    

Форма для сдачи отчета по застрахованным лицам, приобретающим право на пенсию, в том числе и досрочную

Регламентированная отчетность Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Форма для сдачи отчета по застрахованным лицам, приобретающим право на пенсию, в том числе и досрочную

01.09.2010    9681    0    апостол    10    

ЗиК.300 Загогулина

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия ФОМС, ПФ, ФСС Бесплатно (free)

В конфигурации ЗиК.300 при использовании при расчетах любого единовременного пособия из соцстраха (рождение, погребение…) - возможна ошибка в своде проводок...

24.08.2010    15176    0    UV2    14    

Список сотрудников с особыми условиями труда для ПФР. (Версия от 16.07.2011)

Зарплата Управление персоналом (HRM) Бухгалтерские Зарплата Управление персоналом (HRM) v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

Формирование и выгрузка списка сотрудников с особыми условиями труда в xml-файл под версию 1.9 Отчет переписан почти заново. Обновление 16.07.2011.

23.07.2010    18787    0    rechvladmir    22    

Отчетность в ПФР для 1С: 7.7 ЗиК

Регламентированная отчетность Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

В списке застрахованных лиц для особых условий труда и выслуги добавлены строки.

22.07.2010    11643    0    Hla    1    

Ускоритель СЗВ 2010 для ЗиК 2.99

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

Ускоряет формирование СЗВ примерно вполовину за счет уменьшения числа запросов. Реально полезно, когда надо часто и много заходить в редактирование форм СЗВ. ЗиК 2.99

20.07.2010    9843    0    aves    7