INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Шишкина Ирина | Консультант, PM | Студия креативного консалтинга Не просто ИДЕЯ

«Эмоциональный интеллект в управлении ИТ-командами»

- Эмоциональный интеллект - почему это сейчас так важно? Обзор сложностей управления ИТ-командами - Грядущий кризис по Гоулману: "коэффициент умственного развития все выше, а коэффициент эмоционального развития все хуже" - Умение владеть собой для ИТ-Директора. Риски для команды, связанные с низким эмоциональным интеллектом руководителя. Инструмент для оценки своих эмоций. - Эмпатия ИТ-Директора: влияние на стейкхолдеров проекта - "Ненастроенный программист" или как определить уровень эмоционального интеллекта команды. Простые инструменты - как понять, что движет командой?

Алкогольная декларация, формат 4.31

Печать - Регламентированная отчетность

63
Конфигурация "Декларант алко 2.5.26" + обработка выгрузки из Управление торговлей 10.3.

Конфигурация "Декларант алко 2.5.14". Функционал:

  • справочник "Контрагенты"
  • справочник "Лицензии контрагентов"
  • документ "Регламентированные данные" (отражение форм 5, 6, 7, 8, 11, 12)
  • выгрузка данных в файл xml по формату 4.20
  • печать отчетности на основании сформированного файла.
  • импорт данных из xml файла.

Абсолютно бесплатно!)

 

Использовались некоторые обработки с данного сайта:

Обязательно создать пользователя с ролью " ПолныеПрава" и интефрейсом "Основной"

 - Добавил инструкцию для пользователя.

- исправил выявленные ошибки (релиз 2.3.8):

  • указание квартала с лидирующим 0 (03,06,09,00)
  • печать формы 12 не заполнялись поля КПП производителя, ИНН и КПП поставщика.

- исправил выявленные ошибки (релиз 2.3.9):

  • в печатных формах 11,12 добавлен адрес производителя
  • в печатных формах 11,12 неверно выводился адрес обособленного подразделения

исправил выявленные ошибки (релиз 2.4.1):

  • появилась возможность формировать формы 5,6,7 для организаций, торгующих пивом в опт!

исправил выявленные ошибки (релиз 2.4.2):

  • исправлены ошибки при формировании xml-файла формы 5, если имеются обособленные подразделения.

исправил выявленные ошибки (релиз 2.4.10):

  • исправлены ошибки;
  • добавлен импорт из xml файла 5,6,7 формы. Также импорт с преобразованием 6 формы в 11 (12).
  • добавлена новая схема видов алкогольной продукции.

исправил выявленные ошибки (релиз 2.5.3):

  • исправлены ошибки;
  • добавлена выгрузка в xml алкогольной и пивной продукции (все вместе) по формам 5,6,7.

исправил выявленные ошибки (релиз 2.5.4):

  • Изменение схемы выгрузки формы 11,12. Теперь секция Продукция и Движение выгружаются в одном блоке Обороты.

исправил выявленные ошибки (релиз 2.5.8):

  • Добавлена форм 8. Печать и выгрузка.

исправил выявленные ошибки (релиз 2.5.12):

  • исправление ошибок;
  • добавил возможность подключать внешние печатные формы и обработки.

исправил выявленные ошибки (релиз 2.5.14):

  • исправление ошибок;
  • Поддержка печати данных свыше 100 000 строк в одном документе. В обработке печати новый параметр "Количество строк в транзакции". На экране появятся печатные формы из расчета: количество строк в документе / Количество строк в транзакции. Чем меньше параметр «Количество строк в транзакции», тем быстрее вывод на печать.

исправил выявленные ошибки (релиз 2.5.21):

  • исправление ошибок;
  • Добавлена поддержка формата 4.30.

исправил выявленные ошибки (релиз 2.5.22):

исправил выявленные ошибки (релиз 2.5.26): Новый формат 4.31

  • Добавлена поддержка формата 4.31 в связи с постановлением от 25 сентября 2015 г..
PS. Уважаемые пользователи, кто скачивает данную конфигурацию, - не будете плюсовать, сниму с публикации!
63

Скачать файлы

Наименование Файл Версия Размер
Файл конфигурации
.rar 471,79Kb
10.05.18
102
.rar 2.5.22 471,79Kb 102 Скачать
Обработка выгрузки из Управление торговлей 10.3 в Декларант алко 2.5.26
.rar 56,18Kb
10.05.18
0
.rar 2.3 56,18Kb Скачать

См. также

Вознаграждение за ответ
Показать полностью
Комментарии
Сортировка: Древо
1. demon_infernal 30 28.08.12 11:00 Сейчас в теме
Спасибо. Очень нужная вещь.
Есть вопрос по форме 11.
По документу http://fsrar.ru/files/structure/1396.pdf в первом разделе формы 11 есть поля "Вид продукции" и "код вида продукта". Ну, код вида продукта - это понятно, 010, 020 и так далее. а "Вид продукции"? наименование вида продукции? И что-то не похоже, что в итоговый файл выгрузки это наименование попадает. Да и в сабже его вроде ввести некуда, там можно только код вида продукта написать.
Разъясните, пожалуйста.
P.S. Просто заметочка. Имхо, было бы удобнее, если бы выгрузка ФИО руководителя и ГлавБуха не обязательно была привязана к наличию двух пробелов в них.

В обработке "ВыгрузкаАлкогольнойДекларации420" строки 94-95
ФИОСписком = Разложить(ЗначЭл, " ");
Для Индекс = 0 По 2 Цикл

лучше бы так
ФИОСписком = Разложить(ЗначЭл, " ");
КоличествоПробелов = СтрЧислоВхождений(ЗначЭл, " ");
Для Индекс = 0 По КоличествоПробелов Цикл
2. andrew.ab 193 28.08.12 11:17 Сейчас в теме
(1) demon_infernal, Про "Вид продукции" вопрос у меня возникал, но если выгружать данные показатель в файл, то тестер Декларанта выдает ошибку. Поэтому сделал без данного реквизита.
4. Модератор раздела artbear 28.08.12 11:37 Сейчас в теме
(2) Тестер Декларанта - это что за программа?
зы только начинаем вникать в выгрузку Алко, вопросов море :(
5. andrew.ab 193 28.08.12 11:43 Сейчас в теме
(4) artbear, Программа "Декларант алко" от официалов (fsrar), есть на форуме forum.fsrar.ru. На данный момент релиз 4.20.5
6. espero2000 12 28.08.12 11:47 Сейчас в теме
(4) а в программе "Декларант алко" есть функция Тестирование
3. andrew.ab 193 28.08.12 11:19 Сейчас в теме
(1) demon_infernal, Про 2 пробела в ФИО. Кому как удобней)... нам для порядка удобней чтобы ФИО укзывали жестко через 2 пробела.
7. andrew.ab 193 28.08.12 12:01 Сейчас в теме
8. demon_infernal 30 28.08.12 12:49 Сейчас в теме
Еще вопрос: здесь есть четыре типа строк отчетности: Приход, Расход, Таблица1 и Таблица2. Ну, "таблица1" и "таблица2" понятно, это разделы 11й и 12й форм. А Приход и Расход для чего? Для других форм?
9. andrew.ab 193 28.08.12 12:52 Сейчас в теме
(8) demon_infernal, в таблицах 6,7 есть "Поставка" и "Возврат" продукции, соответственно для возврата продукции указываем тип "Возврат", для отгрузки/поставки "Поставка".
10. Модератор раздела artbear 28.08.12 15:18 Сейчас в теме
Кто-нибудь знает, нужны ли данные по производителям ? если нужны, то какие данные помимо наименования, ИНН, КПП?
и где все эти данные взять?
Наши поставщики нифига не знают, все говорят, что только начали заниматься этими вопросами, ничего определенного :(
Опту пока хорошо, а розницу уже нужно сдавать.
Кто что знает?
11. ДмитрийС 28.08.12 16:58 Сейчас в теме
(10) artbear,
Опту так же плохо как и рознице. Постановление 815 всех обязывает сдать декларации за 1-2 квартал до 20 сентября.
13. andrew.ab 193 29.08.12 05:55 Сейчас в теме
(10) artbear, данные по производителю обязательны. Официально они указаны в справке А или сертификатах на продукцию. Данные должны быть у поставщиков!
12. ДмитрийС 28.08.12 17:10 Сейчас в теме
Конфигурация очень полезная (на мой взгляд), пробую в ней работать. Пока есть вопрос один по программе. При выгрузке в xml не создается узел "Кварт" в адресе, а при загрузке он проверяется как необходимый реквизит. Для себя я закомментировал и при загрузке. В офиц. формате выгрузки эл. деклараций этот узел есть, но заполнять его не обязательно. Вот собственно и вопрос: была какая то существенная причина отмена выгрузки "Кварт" ?
14. andrew.ab 193 29.08.12 05:58 Сейчас в теме
(12) ДмитрийС, все что не обязательно для заполнения, я "опускал" в файле. Так же есть "Дата уведомления о поставке" в формах 6,7 заполняются датой "01,01,1980". Если поле оставлять пустым, то тестер ругается! На форуме разъяснения от официалов так и не было...
63. sdwggg 26.09.12 14:18 Сейчас в теме
(14) andrew.ab,
можно не заполнять эти данные "левыми" датами, а просто не выгружать эти поля в XLS!
то же самое, когда оптовик продает ИП-шнику пиво - у ИП нет КПП!
поэтому если выгружать КПП, равное "", то тестер ругается. а если открыть xls блокнотом и удалить эти поля с пустым КПП, то проверка проходит
15. katunya88 18 29.08.12 09:29 Сейчас в теме
При печати формы 5 по обособленному подразделению ставится адрес не от подразделения, а из константы. При том что выгружает верно.
16. andrew.ab 193 29.08.12 10:00 Сейчас в теме
(15) katunya88, по печати ничего сказать не могу, т.к. обработку взял уже готовую http://infostart.ru/public/138557/
17. Forrest_Gump 29.08.12 10:35 Сейчас в теме
Спасибо разработчику! Хорошее дело сделал!!!
Но в платформе есть ограничение на кол-во строк в табличной части... 99 999....
а последняя 6-ка у меня была 156т.строк.... новая будет еще больше :(
18. andrew.ab 193 29.08.12 11:07 Сейчас в теме
(17) Forrest_Gump, про ограничение знал), но для себя не видел смысла делать обработку выгрузки в xml. Как вариант можно переделать обработку выгрузки в xml сливанием из нескольких документов "Регламентированные данные"...
19. Forrest_Gump 29.08.12 13:07 Сейчас в теме
вторая недоработка... как я думаю.... у клиента может быть несколько точек, соответственно несколько адресов. А в справочнике можно указать только один адрес...
20. ДмитрийС 29.08.12 16:52 Сейчас в теме
(19) Forrest_Gump,
Наверняка вариант выхода из ситуации - создать 2х контрагентов с разными адресами и КПП (если нужно) и одинаковыми ИНН. У нас к примеру так и ведется в УТ.
21. andrew.ab 193 29.08.12 18:04 Сейчас в теме
(19) Forrest_Gump, Дмитрий правильно подметил. По новым "правилам", если контрагент имеет несколько адресов, соответственно это разные обособленные подразделения, разные КПП. Создаете нового контрагента в справочнике!
22. Forrest_Gump 06.09.12 05:09 Сейчас в теме
Добрый день, господа!
"Классное" у нас государство. :) приняли постановление о порядке заполнения и опа.... а оно отличается от последнего проекта. :) Адрес производителя теперь надо указывать :) вот розница сейчас попрыгает...
23. andrew.ab 193 06.09.12 06:59 Сейчас в теме
(22) Forrest_Gump, можно ссылку на оф.пост по теме адреса производителя?
24. demon_infernal 30 06.09.12 12:57 Сейчас в теме
25. andrew.ab 193 06.09.12 13:39 Сейчас в теме
(24) demon_infernal, все описание формата перерыл, где указано что выгружается адрес производителя. Позвонил в ФСРАР, дали разъяснение: адрес производителя указывается в печатной форме вместе с наименованием производителя.
26. demon_infernal 30 06.09.12 13:53 Сейчас в теме
В формате 4.20 больше изменений никаких по сравнению с форматом 4.02?
27. andrew.ab 193 06.09.12 17:06 Сейчас в теме
(26) demon_infernal, это и есть формат 4.20. Сорри, в шапки публикации не верно указал...
28. ДмитрийС 10.09.12 13:57 Сейчас в теме
В обработке выгрузки в функции ПризПериодОтч(ДатаКвартала) необходимо внести изменение: по правилам формирования именя файла номер квартала указывается 2мя символами (03, 06, 09, 00)
29. mikm 11.09.12 11:46 Сейчас в теме
А для 8.2 подходит обработка?
Нельзя-ли получить её отличным от системы Инфостарт (например на e-Mail) образом?
30. rhtr 56 12.09.12 19:36 Сейчас в теме
- Добавил инструкцию для пользователя.

Где инструкция, что то не пойму
34. andrew.ab 193 14.09.12 18:52 Сейчас в теме
31. demon_infernal 30 12.09.12 22:03 Сейчас в теме
Не пойму, в таблице 11 есть поля P213 - P216, но в схеме для формы 11 их нет. Либо у меня старые схемы.
Поясните, пожалуйста, в какой форме - 11 или 12, нужно указывать дату закупки, номер ТД, ТТН и объем продукции.
Спасибо.
35. andrew.ab 193 14.09.12 18:53 Сейчас в теме
(31) demon_infernal, у Вас устаревшие схемы, указывать поля в формах 11 и 12
37. demon_infernal 30 14.09.12 23:43 Сейчас в теме
(35)
я просто не разобрался, как заполнять формы)
Нужно отдельно добавлять строки с типом строки "Таблица2", заполнять в ней код вида продукции, поставщика, производителя, лицензию, и эти четыре колонки (по факту нужно только две - дата закупки и объем продукции, мы для упрощения решили номер ТТН не указывать, он же необязательный, как и номер ТД). Если просто указывать дату закупки и объем в той же строке, где тип строки "Таблица1", то ничего не получается.
где руководство пользователя, о котором говорилось выше? я тоже не нашел.
38. andrew.ab 193 15.09.12 08:03 Сейчас в теме
(37) demon_infernal, скачай свежий архив (релиз 2.4.2), в архиве мануал!
32. ДмитрийС 14.09.12 11:09 Сейчас в теме
А можно получить обновления на почту? А то я скачал давно самый первый вариант. Кое что у себя исправлял, но что-то мог и не заметить.
33. kns77 71 14.09.12 18:30 Сейчас в теме
Добрый день Импорт из XML или из бухгалтерии 2.0 есть ?
36. andrew.ab 193 14.09.12 18:55 Сейчас в теме
(33) kns77, Вы что-то путаете. Это отдельная конфигурация! Если нужна выгрузка в xml из бухгалтерии 2.0 - обновите до последнего релиза, компания 1С формат уже даааавно интегрировала в бухгалтерию!
39. kns77 71 15.09.12 11:55 Сейчас в теме
(36) andrew.ab, Я понял что это отдельная конфигурация, просто у меня в бухгалтерии есть часть документов для выгрузки (приходные накладные), я их уже выгрузил, недостающее хотел в этой конфе добить, а чтобы не забивать и спросил про загрузку.
42. _df_ 15.09.12 13:59 Сейчас в теме
(39)
если сделаешь загрузку из xml и выложишь - будем благодарны :) тоже часть форм уже набиты в декларанте

и еще просьба - инструкцию для пользователя сделать общедоступной
43. andrew.ab 193 15.09.12 17:53 Сейчас в теме
(42) _df_, в понедельник поправлю баги. Инструкция в свежем архиве! Загрузку из xml делать не буду, нет времени.
45. Sergik_D 18 17.09.12 23:15 Сейчас в теме
(43) andrew.ab, Привет. Спасибо за разработку. Обработку выгрузки не вышлешь ? Ту, которая в инструкции ?
49. _df_ 18.09.12 09:19 Сейчас в теме
(43) andrew.ab,
да я и не вам писал, вы и так большое дело сделали

после 20-го может и напишу загрузку. тем более половина работы наверняка сделано в ПечатиАлкогольнойДекларации :)
40. _df_ 15.09.12 13:51 Сейчас в теме
Обработка ПечатьАлкогольнойДекларации, модуль объекта, строка 1726 (процедура Печать12)
вместо
КолГруппировок = "П000000000003,ИдПроизвИмп,ИдПоставщика,ИдЛицензии," +
"П200000000013,П200000000014,П200000000015";
надо
КолГруппировок = "П000000000003,ИдПроизвИмп,ИдПоставщика," +
"П200000000013,П200000000014,П200000000015";

иначе при печати формы 12 ругается т.к. в 12-й форме лицензий нет
41. _df_ 15.09.12 13:56 Сейчас в теме
Обработка ВыгрузкаАлкогольнойДекларации, модуль объекта, строка 707
вместо
ВремТаблицаДанныхПоПодразделению.Сортировать("vidCode, producer, Contragent");
надо
ВремТаблицаДанныхПоПодразделению.Сортировать("vidCode, producer, Contragent,TTYPE Убыв");

иначе то ли в 6-й то ли в 7-й форме, если от одного контрагента есть и поставка и возврат при проверке Декларант ругается - ему надо чтобы возвраты всегда шли в конце секции
44. s_uu 20 17.09.12 10:58 Сейчас в теме
Импорт из xml формата очень пригодился бы!))
46. demon_infernal 30 17.09.12 23:26 Сейчас в теме
а что делать, когда у нас, например, не предусмотрен бухгалтер? что писать в обязательные (по схемам) поля для главбуха?
50. GreatDen 19.09.12 10:37 Сейчас в теме
Спасибо выручил!!!
В выгрузке вроде как вместо кода региона встает Наименование региона
51. ДмитрийС 19.09.12 12:40 Сейчас в теме
Мы еще у себя во всех местах, где выгружается ИД контрагента (Клиент, Поставщик, Производитель) заменили строки вида СокрЛП(..Код), на СтрЗаменить(СокрЛП(..Код),Символы.НПП,""). Потому как при количестве контрагентов больше 1000, 1С-ка СокрЛП делает 1 000 (вставляет неразрывный пробел). А Декларант потом на это ругается, т.к. формат этих полей должен быть числовым, и он не идентифицирует контрагента.
52. Forrest_Gump 19.09.12 14:42 Сейчас в теме
Все доброго времени суток.
Вопрос вот такой.... кто-нибудь знает что делать с КПП поставщика, если поставщик ИП? по пиву например...
55. _df_ 19.09.12 18:28 Сейчас в теме
(52) Forrest_Gump,
вы бы как нить конкретизировали, какая форма, где ентот КПП
вот только седня копал 12-ю - там в случае физ лица (ИП) не надо вообще выгружать КПП. и декларант не ругается и в формате заполнения указано что это необязательный узел
56. Forrest_Gump 20.09.12 05:45 Сейчас в теме
(55) _df_, у меня версия была от 29 августа.... я копаюсь с оптовой 6-кой, мой человек с 11 формой. выгрузка в документ неправильно выгружала 11 форму. сегодня обновили, посмотрим что и как...
53. Forrest_Gump 19.09.12 15:01 Сейчас в теме
И еще вопрос. ктонить сталкивался с Белорусскими производителями или Казахстаном. у них КПП то нету.... и вообще ИНН тоже нет, есть какойто идентификационный номер. как его кто выгружает....
57. demon_infernal 30 20.09.12 07:51 Сейчас в теме
(53) Декларант то не ругается на пустой КПП, а вот при загрузке на региональный сайт декларация не принимается. Вопрос все еще актуален
54. demon_infernal 30 19.09.12 15:07 Сейчас в теме
Последние схемы вроде бы понимают ИНН Белоруссии и Казахстана
58. Forrest_Gump 20.09.12 19:08 Сейчас в теме
Декларант много на что не ругается!! :)
Например, если НачОстаток + ВсегоПриход - ВсегоРасход НЕ= КонОстаток. Декларант не с ругался, на сайте нашлась эта ошибка.
Второе. Обработка при выгрузке в файл, если на обособленном подразделении есть остаток по виду, но нет движения (прихода/расхода) ставит признак оборота в False. сайт считает это ошибкой...

остальное не помню....
59. _df_ 21.09.12 10:38 Сейчас в теме
фуф. вчера с трудом, но сдал декларацию... сайт фсрара конечно вчера отжигал

(58) Forrest_Gump,
ну насчет начостаток - оборот неравно коностаток это вы отожгли :))) вы декларацию глазами совсем не проверяете перед сдачей?! О_о
А вот второе оформите пож в виде кода - разработчик думаю поправит - всем нам польза будет

to all:
если находите косяки - постите сюда решение, всем миром допилим конфу
60. _df_ 21.09.12 10:50 Сейчас в теме
сам следую своему воззванию:
косяк - в адрес контрагента не выгружается номер кватиры, по формату он есть (актуально для ИП-шников)
решение:
обработка Выгрузка....... строка 144 (процедура АдресХМЛ)
вместо
	
        	Для Индекс = 1 По 9 Цикл
			//Если НЕ ПустаяСтрока(АдресСписком[Индекс]) Тогда
				
			Если ВидЭлем[Индекс] = "Кварт" Тогда
				Продолжить;
			КонецЕсли;
			
			хмлДок.ЗаписатьНачалоЭлемента(ВидЭлем[Индекс]);
			хмлДок.записатьТекст(АдресСписком[Индекс]);
			хмлДок.ЗаписатьКонецЭлемента();
				
			//КонецЕсли;
		КонецЦикла;
		
		хмлДок.ЗаписатьНачалоЭлемента("Литера");
		хмлДок.записатьТекст("");
		хмлДок.ЗаписатьКонецЭлемента();
Показать

пишем
		ДобавитьКвартиру=ложь;
		Для Индекс = 1 По 9 Цикл
			//Если НЕ ПустаяСтрока(АдресСписком[Индекс]) Тогда
				
			Если ВидЭлем[Индекс] = "Кварт" Тогда
				ДобавитьКвартиру=Истина;
				ИндексКвартиры=Индекс;
				Продолжить;
			КонецЕсли;
			
			хмлДок.ЗаписатьНачалоЭлемента(ВидЭлем[Индекс]);
			хмлДок.записатьТекст(АдресСписком[Индекс]);
			хмлДок.ЗаписатьКонецЭлемента();
				
			//КонецЕсли;
		КонецЦикла;
		
		хмлДок.ЗаписатьНачалоЭлемента("Литера");
		хмлДок.записатьТекст("");
		хмлДок.ЗаписатьКонецЭлемента();
		
		// добавил в выгрузку номер квартиры
		Если ДобавитьКвартиру Тогда
			хмлДок.ЗаписатьНачалоЭлемента(ВидЭлем[ИндексКвартиры]);
			хмлДок.записатьТекст(АдресСписком[ИндексКвартиры]);
			хмлДок.ЗаписатьКонецЭлемента();
		КонецЕсли; 
Показать

грубо, но мозги после сдачи декларации в авральном режиме не работают
61. _df_ 21.09.12 10:56 Сейчас в теме
косяк - в 12 форме не помню уже в каком узле для ИП-шников и физ лиц (короче инн 12 символов) выгружается узел "ИНННЮЛ" а надо "ИННФЛ"
решение:
обработка Выгрузка....... строка 1018 (процедура ВыгрузитьДанные)
вместо
						Если ВидОрганизации = Перечисления.ВидыОрганизаций.ЮридическоеЛицо Тогда
							ХМЛФайлДанных.ЗаписатьНачалоЭлемента("ЮЛ");
								ХМЛФайлДанных.ЗаписатьАтрибут("ИННЮЛ",ИННЮЛ);
								ХМЛФайлДанных.ЗаписатьАтрибут("КППЮЛ",КППЮЛ);
							ХМЛФайлДанных.ЗаписатьКонецЭлемента();//ЮЛ
						Иначе
							ХМЛФайлДанных.ЗаписатьНачалоЭлемента("ФЛ");
								ХМЛФайлДанных.ЗаписатьАтрибут("ИННЮЛ",ИННЮЛ);
							ХМЛФайлДанных.ЗаписатьКонецЭлемента();//ФЛ
						КонецЕсли;	
Показать

пишем
						Если ВидОрганизации = Перечисления.ВидыОрганизаций.ЮридическоеЛицо Тогда
							ХМЛФайлДанных.ЗаписатьНачалоЭлемента("ЮЛ");
								ХМЛФайлДанных.ЗаписатьАтрибут("ИННЮЛ",ИННЮЛ);
								ХМЛФайлДанных.ЗаписатьАтрибут("КППЮЛ",КППЮЛ);
							ХМЛФайлДанных.ЗаписатьКонецЭлемента();//ЮЛ
						Иначе
							ХМЛФайлДанных.ЗаписатьНачалоЭлемента("ФЛ");
								ХМЛФайлДанных.ЗаписатьАтрибут("ИННФЛ",ИННЮЛ); // было  ХМЛФайлДанных.ЗаписатьАтрибут("ИННЮЛ",ИННЮЛ);
							ХМЛФайлДанных.ЗаписатьКонецЭлемента();//ФЛ
						КонецЕсли;	
Показать
62. andrew.ab 193 24.09.12 09:19 Сейчас в теме
Всем спасибо за Ваши замечания! Сорри, был в отъезде. Все баги поправил. Выложил свежий релиз 2.4.7
64. Skimen 234 03.10.12 02:09 Сейчас в теме
Суперская вещ!
Респект автору!!!

Кстати, в моей компании очень много операций и поначалу бухгалтера думали что программа виснет при печати формы 6, тогда сделал счетчик строк:
В модуле обработки печать алкогольной декларации
в функции ПечатьРаздела6(...)
строка 1188 (перед циклом)
//определения переменных для счетчика:
Итерратор1=0;
Итерратор2=1;
КоличествоСтрок = ТзОбороты.Количество();
Состояние("Обработка строк: 1 из "+КоличествоСтрок);
Строка 1201 (в теле цикла)
Если Итерратор1 >999 Тогда
Состояние("Обработка строк: "+Итерратор2+" из "+КоличествоСтрок);
Итерратор1=0
КонецЕсли;
Итерратор1=Итерратор1+1;
Итерратор2=Итерратор2+1;
Если кому-то раз в 1000 строчек обновление статуса сильно редко можно 999 поменять например на 99 тогда статус каждые 100 строчек обновляется
65. demon_infernal 30 03.10.12 17:47 Сейчас в теме
Важное дополнение:
В Форме списка документа "Регламентированные данные" используется событие "ПриВыводеСтроки", в обработчике которого каждый раз из БД вынимается весь объект (документ) только ради того, чтобы получить реквизит "ОтчетныйПериод". Когда документов много и каждый из них большой - форма списка начинает очень заметно тормозить. Не обратил внимания сразу, не было заметно, пока количество форм в списке не перевалило за 50.
В качестве решения предлагаю вобще отказаться от события "ПриВыводеСтроки" и использовать вместо него событие "ПриПолученииДанных", в модуль формы поместить следующий код:

Перем гЗапросПриПолученииДанных;

//Процедура ДокументСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)()
//КонецПроцедуры

Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)
	
	Массив = Новый Массив; // для передачи в параметр запроса 
	Соответствие = Новый Соответствие; // для заполнения строк табличного поля 

	Для Каждого ОформлениеСтроки из ОформленияСтрок Цикл 
		Объект = ОформлениеСтроки.ДанныеСтроки.Ссылка;
		Массив.Добавить(Объект); 
		Соответствие.Вставить(Объект, ОформлениеСтроки); 
	КонецЦикла; 

	гЗапросПриПолученииДанных.УстановитьПараметр("Массив", Массив); 

	выборка = гЗапросПриПолученииДанных.Выполнить().Выбрать(); 

	Пока выборка.Следующий() Цикл
		ОформлениеСтроки = Соответствие.Получить(Выборка.Ссылка);
		ОформлениеСтроки.Ячейки.ОтчетныйПериод.Значение = ПредставлениеПериода(Выборка.НачалоКвартала, Выборка.КонецКвартала);
    КонецЦикла;
КонецПроцедуры

Процедура ПриОткрытии()
	гЗапросПриПолученииДанных = Новый Запрос;
	гЗапросПриПолученииДанных.Текст = "ВЫБРАТЬ
	                                  |	РегламентированныеДанные.Ссылка,
	                                  |	НАЧАЛОПЕРИОДА(РегламентированныеДанные.ОтчетныйПериод, КВАРТАЛ) КАК НачалоКвартала,
	                                  |	КОНЕЦПЕРИОДА(РегламентированныеДанные.ОтчетныйПериод, КВАРТАЛ) КАК КонецКвартала
	                                  |ИЗ
	                                  |	Документ.РегламентированныеДанные КАК РегламентированныеДанные
	                                  |ГДЕ
	                                  |	РегламентированныеДанные.Ссылка В(&Массив)";
КонецПроцедуры
Показать
cultib; _df_; +2 Ответить
66. _df_ 04.10.12 10:10 Сейчас в теме
(65)
только не забыть события слинковать :)
67. andrew.ab 193 04.10.12 12:59 Сейчас в теме
(65) demon_infernal, в новом релизе убрал этот кусок кода, считаю что и без него нормально).
68. andrew.ab 193 04.10.12 13:01 Сейчас в теме
выложил свежий релиз 2.4.10. В обработке печати, появился импорт из файла xml форм 5,6,7 (11, 12 не успел сделать). Также импорт из файла формы 6 с преобразованием в 11,12 (аля импорт данных по файлам поставщиков :) )
69. ДмитрийС 04.10.12 13:08 Сейчас в теме
А 8ю форму не планируете реализовать?
70. Sergik_D 18 06.10.12 14:49 Сейчас в теме
Тоже нужна 8-я форма. Есть два варианта скинемся автору и он сделает. Если не захочет давайте вместе сделаем. По блокам разнесем. Кто-то таб.часть, кто-то выгрузку и т.д.
71. Skimen 234 09.10.12 10:16 Сейчас в теме
8 форма была бы реально полезна
72. andrew.ab 193 09.10.12 10:40 Сейчас в теме
чтобы написать 8 форму, необходим "живой" клиент на ком можно было бы тестировать. У меня таких нет(. Кто напишет, тому РЕСПЕКТ!). Обновил релиз: закрыл ошибки, добавил выгрузку в один файл xml и алкогольной и пивной продукции по формам 5,6,7 (у некоторых клиентов ФСРАР просит, чтобы все данные были в одном файле).
75. ДмитрийС 10.10.12 16:06 Сейчас в теме
(72) andrew.ab,
А как у вас получилось протестировать 5,6,7 форму? Ведь по сути все оптовики пользуются транспортном, хоть своим, хоть привлеченным. Это просто вопрос, а не претензия))
76. andrew.ab 193 11.10.12 07:50 Сейчас в теме
(75) ДмитрийС, наши оптовики пока не просили 8 форму. Хотя в регламенте четко написано, что обязаны сдавать 8 форму. Я, с своей стороны, пока молчу об этом (у них свои юристы, которые "мониторят" законодательство))) ).
80. ДмитрийС 11.10.12 09:09 Сейчас в теме
(76) andrew.ab,
Нам пришлось сдать пустышку, так для галочки.
73. demon_infernal 30 09.10.12 18:36 Сейчас в теме
Автор, алярма!
Судя по схемам форм 11 и 12, выдернутым обработкой с инфостарта из ДА 4.20.32, элементы "Продукция" и "Движение" теперь должны находиться внутри одного элемента "Поставщик", который, в свою очередь, находится внутри элемента "СведПроизвИмпорт", который, в свою очередь, находится внутри элемента "Оборот". В данный момент для этих двух элементов ("Продукция" и "Движение") создаются различные узлы "Оборот".
Прикрепленные файлы:
12-о.xsd
11-о.xsd
74. andrew.ab 193 10.10.12 07:52 Сейчас в теме
(73) demon_infernal, изменил выгрузку 11,12 формы. Выложил свежий релиз 2.5.4.
77. Forrest_Gump 11.10.12 08:20 Сейчас в теме
вопрос к тем кто сдал 6-ку, 7-ку что делали с ИП? А точнее что делали с лицензией на покупателей пива....
Желательно кусок XML-файла из действительно сданного файла.

я уже пробовал разные варианты: удалял секцию Лицензии, оставлял пустую эту секцию.... ругается файл не проходит...

остался вариант пихнуть туда левую лицензию... но наверно это не вариант...
78. andrew.ab 193 11.10.12 08:34 Сейчас в теме
(77) Forrest_Gump, оставляешь <Лицензии></Лицензии> и должно прокатить. Хотя не уверен, наши 6 форму только сегодня сдают
81. Forrest_Gump 11.10.12 09:11 Сейчас в теме
(78) andrew.ab, Это не прокатывает.... проверял....
79. ДмитрийС 11.10.12 09:08 Сейчас в теме
(77) Forrest_Gump,
Мы делали так: вместо номера и серии писали "НЕТ", Дата начала - начало отчетного года, Дата окончания - окончание отчетного года (т.е. 01.01.12 и 31.12.12), Лицензиат - "Не выдавалась". И все прокатило. Это еще прокатило и в первую сдачу, которая до 20 сентября.
82. Forrest_Gump 11.10.12 09:12 Сейчас в теме
(79) ДмитрийС, Спасибо за подсказку.... проверим :)
83. sdwggg 11.10.12 09:13 Сейчас в теме
мы вчера сдали ОПТ 5,6,7,8 формы
пивняки (ИП-шники) у нас тоже есть
поле Лицензия для ИП вообще не нужен! в общем, у меня код такой

Если ЭтоИП = 0 Тогда
Лицензии = Резидент.СоздатьПодчиненныйЭлемент("Лицензии");
Лицензия = Лицензии.СоздатьПодчиненныйЭлемент("Лицензия");
Лицензия.УстановитьАтрибут("ИдЛицензии", ТЗ_Покупатели._24);
Лицензия.УстановитьАтрибут("П000000000011", ЛицСерНом);
Лицензия.УстановитьАтрибут("П000000000012", Формат(ДатаОт,"Д ДДММГГГГ"));
Лицензия.УстановитьАтрибут("П000000000013", Формат(ДатаДо,"Д ДДММГГГГ"));
Лицензия.УстановитьАтрибут("П000000000014", КемВыдана);
КонецЕсли;
91. andrew.ab 193 11.10.12 10:19 Сейчас в теме
(83) sdwggg, а у нас без блока <лицензия></лицензия> не загружался файл(.
92. sdwggg 11.10.12 10:34 Сейчас в теме
(91) andrew.ab, а для ИП вы меняли тип контрагента на ФизЛицо?

Если ЭтоИП = 0 Тогда
ЮЛ = Резидент.СоздатьПодчиненныйЭлемент("ЮЛ");
ЮЛ.УстановитьАтрибут("П000000000009", ЛицИНН);
ЮЛ.УстановитьАтрибут("П000000000010", ЛицКПП);
ИначеЕсли ЭтоИП = 1 Тогда
ЮЛ = Резидент.СоздатьПодчиненныйЭлемент("ФЛ");
ЮЛ.УстановитьАтрибут("П000000000009", ЛицИНН);
КонецЕсли;
93. Forrest_Gump 11.10.12 10:43 Сейчас в теме
(92) sdwggg, у меня тоже не загрузился без Лицензии, и да, стоит ФЛ
94. sdwggg 11.10.12 11:59 Сейчас в теме
(93) Forrest_Gump, а Декларант-Алко тоже выдает ошибку при тестировании?

и номер формы какой у вас?
98. Forrest_Gump 11.10.12 13:18 Сейчас в теме
(94) sdwggg, формы 7-ка, 6-ка.....
поставил как тут посоветовали...
<Лицензии>
<Лицензия ИдЛицензии="42056" П000000000011="НЕТ" П000000000012="01.01.2012" П000000000013="31.12.2012" П000000000014="Не выдавалась"/>
</Лицензии>

Прокатило в 7-ке....
84. sdwggg 11.10.12 09:15 Сейчас в теме
кстати, перед тем, как загружать XML-файлы на сайт, проверяйте их с помощью Декларант-Алко!
я так делал, и методом проб и ошибок отладил свои выгрузки. и на сайт всё загрузилось с первого раза)))
85. demon_infernal 30 11.10.12 09:24 Сейчас в теме
(84) sdwggg, ДА вобще не понятно по каким принципам проверяет. Далеко не все ошибки находит. Допустим, файлы, сделанные до (73), успешно проходят проверку в ДА 4.20.32. Лучшая проверка - при загрузке на региональный сайт)
87. sdwggg 11.10.12 09:30 Сейчас в теме
(85) demon_infernal, тем не менее, у нас всё хорошо получилось! отправлял файлы вчера на фсрар почти до 22ч вечера. они отправлялиьсь, но не отображались в загруженных файлов, вообще был не понятен их статус. и когда бы я исправлял ошибки и заново выгружал?
ошибки, которые встречались у меня, на которые ругался ДА:
- адреса не соответствуют КЛАДР
- пустое поле КПП для ИП-шников
- пустые лицензии у ИП-шников.

остальное - мелочи. когда выгрузку 6й формы переделывал под форму 7,- названия некоторых реквизитов отличается
88. demon_infernal 30 11.10.12 09:41 Сейчас в теме
(87) я же не осуждаю. просто дополнил.
> на фсрар
а на региональный не отправляли? у меня ошибки отображались уже при загрузке на региональный, а региональный сайт, в отличии от фсрар, работал и работает нормально.
Ошибки по КЛАДРу обработка выгрузки декларации сообщает уже на этапе выгрузки. Действительно, не помешали бы простейшие проверки при выгрузке, на наличие лицензии, заполненность КПП...
Для форм 11 и 12 может помочь это http://infostart.ru/public/155286/
89. sdwggg 11.10.12 09:46 Сейчас в теме
(88) demon_infernal, я не знаю, что такое региональный..
мы - оптовики, торгущие алкоголем, и немного пивом.
загружаем всё на service.fsrar.ru
90. andrew.ab 193 11.10.12 10:18 Сейчас в теме
(88) demon_infernal, конфа делалась для всех, штатных средств в 1С валидации по схеме xsd нет (вернее они есть, но криво работают), а "прикручивать" в конфигурацию msxml 6.0 не хочется(
86. _df_ 11.10.12 09:27 Сейчас в теме
(84)
декларант алко проверять конечно нужно, но это не панацея - он отлавливает намного меньше чем сайт.
к примеру мне вчера было лень выгрузку в 12-ю форму переписывать (согласно посту (73)) - так новый декларант (вчера обновил, 4.20.34) сожрал старую форму и не ругнулся, а сайт не пропустил, пришлось таки переписывать
95. rhtr 56 11.10.12 12:21 Сейчас в теме
Может кто в курсе что значит эта ошибка?
"Значение элемента "Код вида продукции" должно быть уникальным внутри оборота."
Декларация 12 пиво

Уже незнаю что с ней делать
ПОМОЖИТЕ !!!
96. demon_infernal 30 11.10.12 13:01 Сейчас в теме
(95) эта ошибка возникает при проверке файлов, сформированных софтом образца примерно недельной давности. фсрар поменяло схему файла, но никому ничего не сказала) чинится либо обновлением обработки выгрузки (скачайте текущий релиз), или же вручную в файле, как именно - написано в (73)
97. _df_ 11.10.12 13:15 Сейчас в теме
(95)
я лично делал так: скачал новую конфу, сделал базу, в модуле объекта ВыгрузкаАлкогольнойДекларации в процедуре ВыгрузитьДанные поменял всю ветку если для 12-й формы - а именно начиная со строк
	ИначеЕсли (ИндексОтчета = 11)
				ИЛИ (ИндексОтчета = 12) Тогда

и до конца процедуры
99. rhtr 56 11.10.12 18:20 Сейчас в теме
(97) _df_, а на что поменял скинь пожалуйста свою обработку, конфигурация последний релиз но ошибка всё тажа.
100. rhtr 56 11.10.12 18:51 Сейчас в теме
ОШИБКА

2012-10-10 18:04:03.397 Проверка декларации по схеме Значение элемента "Код вида продукции" должно быть уникальным внутри оборота.
2012-10-10 18:04:03.410 Проверка декларации по схеме Значение элемента "Код вида продукции" должно быть уникальным внутри оборота.
2012-10-10 18:04:03.423 Проверка декларации по схеме Значение элемента "Код вида продукции" должно быть уникальным внутри оборота.

Как быть товарищи???
101. demon_infernal 30 11.10.12 19:17 Сейчас в теме
(100) Конфу обновил? я лично проверял, обновленная обработка выгрузки выгружает правильно. Если файл небольшой - открой в каком-нибудь редакторе и вручную перенеси элемент "Движение" рядом к элементу "Продукция"
Оставьте свое сообщение