Добавляем новый документ в обработку Диадок

Публикация № 1737685 07.10.22

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Диадок

Добавляем новый документ для подписания и отправки в обработку Диадок (через подключаемый модуль). Отправлять его будем, как неформализованный (внешняя печатная форма в формате pdf).

Для начала сгенерируем нужные нам события

 

 

 

Выбираем обработать типовой результат. Можно и переопределить полностью, но тогда придется описывать все документы, с которыми мы работаем.

 

 

Получаем шаблон с событиями, которые нам нужно обработать

 

 

1. ПолучитьТаблицуИспользуемыхПакетов()

 

 

Функция ПолучитьТаблицуИспользуемыхПакетов(Параметры)

	Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда 
		
		//ТЗ = ТаблицаЗначенийСКолонками("ID, Наименование, СоставПакета, КатегорияПакета, НаименованиеКатегории, Шаблон");

		ТЗ  = Параметры.Результат_ИМ;
		ОсновнойМодуль.ЭДО_Служебные_ДобавитьСтрокуВТаблицуЗначений(ТЗ, "ID_Приложение", "Приложение" , "ID_Приложение", "ЗаказКлиента", "ЗаказКлиента");  
					
		Возврат ТЗ;

	КонецЕсли;

КонецФункции 

 

2. ПолучитьТаблицуИспользуемыхВидовДокументов()

 

 

Функция ПолучитьТаблицуИспользуемыхВидовДокументов(Параметры)

	Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда  
		
		ТЗ  = Параметры.Результат_ИМ;
		ОсновнойМодуль.ЭДО_Служебные_ДобавитьСтрокуВТаблицуЗначений(ТЗ, "ID_Приложение", "Приложение", "Nonformalized", "");   

		Возврат ТЗ;

	КонецЕсли;

КонецФункции 

 

3.ПолучитьТекстЗапросаДляСпискаПакетовНаОтправкуПоМассивуВидовПакетов()

 

 

Функция ПолучитьТекстЗапросаДляСпискаПакетовНаОтправкуПоМассивуВидовПакетов(Параметры)

	Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда 
				
		Если Параметры.МассивВидовПакетов.Найти("ID_Приложение") <> Неопределено Тогда
		
			ОписаниеВидаПакета = ОсновнойМодуль.ЭДО_СправочникМенеджер_ПолучитьЭлемент("ВидыПакетов", "ID_Приложение");
			     
			Параметры.ПараметрыЗапроса.Вставить("ВидПакетаID_ID_Приложение","ID_Приложение");
			
			Если Параметры.МассивВидовПакетов.Количество() = 1 Тогда
				Результат = ТекстЗапроса_Приложение(ОписаниеВидаПакета);   
				Результат = "ВЫБРАТЬ РАЗРЕШЕННЫЕ" + Сред(Результат, СтрДлина("ВЫБРАТЬ") + 1);
				Результат = ТекстЗапроса_ВременныеТаблицыДляСпискаПакетовНаОтправку_1С() + "
							|;
							|
							|//////////////////////////
							|" + Результат + "
							|УПОРЯДОЧИТЬ ПО
							|	ДатаДокумента, НомерДокумента";    
				Параметры.Результат_ИМ = Результат;

			Иначе	
				Результат = ДобавитьОбъединениеВТекстЗапроса() + ТекстЗапроса_Приложение(ОписаниеВидаПакета);
				ТекстДляЗамены = "
							|" + Результат + " 
							|
							|УПОРЯДОЧИТЬ ПО 
							|";
				Параметры.Результат_ИМ = СтрЗаменить(Параметры.Результат_ИМ, "УПОРЯДОЧИТЬ ПО" , ТекстДляЗамены); 
			КонецЕсли;
						
			Возврат Параметры.Результат_ИМ;
    	КонецЕсли;
	КонецЕсли;

КонецФункции

 

В функции ПолучитьТекстЗапросаДляСпискаПакетовНаОтправкуПоМассивуВидовПакетов нужно определить, запрос идет ко всем документам, с которыми мы работаем, или только к новому документу. Если ко всем, то запрос просто дописываем в конец основного запроса, а если только к новому документу, то нужно написать весь запрос (со всеми временными таблицами).

 
 Запрос к новому документу

 Если у вас модуль Диадока встроен в конфигурацию, то у вас будут другие временные таблицы. Их можно будет взять из запроса, когда мы добавляем наш запрос к основному запросу.

 
 Временные таблицы

4. ПодготовитьПакет()

 

 

Функция ПодготовитьПакет(Параметры)

	Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда
		
		Если Параметры.ВидПакетаРазвернутый.ID = "ID_Приложение" Тогда	
			ОсновнойМодуль.ЭДО_ДокументМенеджер_ПодготовитьИДобавитьДокументВПакет(Параметры.Пакет, Параметры.СтрокаСписка.Документ, "ID_Приложение");     
			Возврат Истина;
		КонецЕсли;	

	КонецЕсли;

КонецФункции

 

Далее подключаем модуль и жмем сохранить

 

 

Заходим в настройки организации.

Ставим галочку на новый документ

 

 

 

 

Там же выбираем нужную печатную форму (желательно, чтобы в печатной форме была одна команда), которую будем отправлять и подписывать

 

 

 

готово

 

 

 

Тестировал: 

  • 1С:Комплексная автоматизация 2 (2.4.13.209)
  • Платформа 1С:Предприятие 8.3 (8.3.19.1467)

Диадок:

  • Версия модуля: 4.21.2.2018
  • Версия плагина: 1.4.5.286
  • Расположение модуля: ВСправочнике
  • Модуль интеграции: ПМ_УТ_11

Скачать файлы

Наименование Файл Версия Размер
ДиадокПодключаемыйМодуль.epf

.epf 7,31Kb
12
.epf 7,31Kb 12 Скачать

Специальные предложения

Вознаграждение за ответ
Показать полностью
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. bavkyz 3 07.10.22 10:54 Сейчас в теме
Добрый, спасибо за труд +1, Маленько не понял, в вашем решении пользователь с ЭЦП или пользователь по логин/пароль, создает документ и передать на подписание руководителю?

И еще вопрос, где вы нашли описание по работе с универсальной обработкой диадока?
2. John_d 4395 07.10.22 11:23 Сейчас в теме
(1) -Только пользователи с ЭЦП могут подписать документ, но просматривать документы в обработке могут все.
-Документы после создания и проведения сами появляются в обработке. Пользователь их выбирает подписывает и отправляет.
https://developer.kontur.ru/Docs/Diadoc_UM/
sapervodichka; +1 Ответить
3. bavkyz 3 07.10.22 11:28 Сейчас в теме
(2)
пользователи с ЭЦП могут подписать документ
- это логично), в вашем решении обязательно ли пользователю иметь ЭЦП для создания документа?

P.S. мне надо чтоб пользователь мог создать документ, а руководитель "потом" подпишет
4. tricolor 21 07.10.22 11:34 Сейчас в теме
(3) у нас пользователи заходят по логину и паролю, и отправляют документ на согласование, далее руководитель подписывает и отправляет документы.
6. John_d 4395 07.10.22 11:40 Сейчас в теме
(3) не обязательно. Пользователь вообще может не заходить в обработку Диадок создать документ, как обычно создает в 1с.
5. stsasha87 135 07.10.22 11:40 Сейчас в теме
Зная, насколько сложно там всё реализовано, понимаешь сколько времени и трудов ушло на эту доработку.

Тоже сижу разбираюсь с подключаемым модулем. Пытаюсь решить задачу автоматического получения подписанных файлов и прикрепления их к документам 1с. Очень хитро всё сделано. Не попадалось случайно ничего подобного?
tricolor; mrChOP93; KRIHA; +3 Ответить
7. John_d 4395 07.10.22 11:42 Сейчас в теме
(5) решал, через диадок API. Чтобы подключаться к API Диадока нужно оплатить данную услугу отдельно.
8. bavkyz 3 07.10.22 11:48 Сейчас в теме
(6) Спасибо, понял.


(5) Полностью согласен, сложно все там на первый взгляд и нормальной инструкции нет ... то что есть мне мало.


Я маленько изменил алгоритм создание документа "поступление товара" (создание новой ном-ры, создание СФ и документ Измен. цены), но так и не решил вопрос с сопоставлением ном-ры... вроде все сопоставлено, т.е. сообщения о не сопоставленной ном-ры нет.... но документ не создается, пишет что не сопоставлено. Нужно обязательно нажать кнопку "Сопоставить", а потом кнопку "Ок".
12. Razyiller 10.10.22 04:49 Сейчас в теме +2 $m
(5)
м модулем. Пытаюсь решить задачу автоматического получения подписанных файлов и прикрепления их к документам 1с. Очень

попробуйте плагины использовать.
Настройки - Системные.

В Плагинах есть "Плагин для выгрузки архива документов".
14. stsasha87 135 19.10.22 16:15 Сейчас в теме
(12) Добрался, попробовал, спасибо! Честно говоря, не знал, что он там есть. Вроде всё указал, галки установил. Но в 1С присоединенных файлов у подписанных документов почему-то не вижу... Может не там смотрю или этот плагин надо как-то отдельно запускать?

Попробовал в подключаемом модуле запускать в событии ПослеОбновленияСпискаДокументов что-то типа
АрхивДокументооборота = ОсновнойМодуль.ЭДО_ПолучитьАрхивДокументооборота(boxId, letterId, documentId);

и получаю ошибку авторизации...

В прошлой версии обходился финтом ушами - в основном модуле на клиенте дёргал метод SaveAllContentZipAsync() при формировании списка документов, тут же всё иначе... Весь мозг уже сломал.
Если есть где подсмотреть, поделитесь, плиз ))
15. Razyiller 19.10.22 17:17 Сейчас в теме
(14)
Плагин это всего лишь конструктор с примерами, доработать все равно приходится.
Там помоему и пример авторизации есть.

Примера нет, просто изучал этот генератор ПМ и видел что там такое есть. для целей добавление в пакет своих печатных форм и отправку своих видов документов.
17. Razyiller 22.11.22 10:03 Сейчас в теме
(14)
Функция ОбработатьСобытие(ИмяСобытия, Параметры) Экспорт
............................
ИначеЕсли ИмяСобытия = "ВыполнитьРегламентныеДействия" Тогда

		Возврат ВыполнитьРегламентныеДействия(Параметры); 
................................
КонецФункции

Функция ВыполнитьРегламентныеДействия(Параметры)

	// Имя шаблона: Авторизация под логином (РЗ)
	АвторизоватьсяПодЛогином();

КонецФункции 

Функция УчетнаяЗапись()
    
    Результат = Новый Структура;

    Результат.Вставить("Логин"	, ОсновнойМодуль.ЭДО_Модуль_ОбщиеНастройки().СлужебнаяУчетнаяЗаписьЛогин);
    Результат.Вставить("Пароль"	, ОсновнойМодуль.ЭДО_Модуль_ОбщиеНастройки().СлужебнаяУчетнаяЗаписьПароль);
    
    Возврат Результат;
    
КонецФункции

Процедура АвторизоватьсяПодЛогином()
ДанныеУчетнойЗаписи = УчетнаяЗапись();

	ЗаписатьВЖурналРегистрацииИнформацию("Диадок.АвторизацияПодЛогином", ДанныеУчетнойЗаписи.Логин);

	ОсновнойМодуль.ЭДО_АвторизоватьсяПодЛогином(ДанныеУчетнойЗаписи.Логин, ДанныеУчетнойЗаписи.Пароль);		
	ОсновнойМодуль.ЭДО_ЗаполнитьКонтекстСеансаДляСлужебнойУчетнойЗаписи();
        МассивВидовДокументов = Новый Массив;
	МассивВидовДокументов.Добавить("ID_УПД_НаАванс");
	МассивВидовДокументов.Добавить("ID_СФ_НаАванс");
	МассивВидовДокументов.Добавить("ID_УПД_раздельно");
	МассивВидовДокументов.Добавить("ID_КСФ");
	МассивВидовДокументов.Добавить("ID_АктСверки");
	МассивВидовДокументов.Добавить("ID_УКД");
	МассивВидовДокументов.Добавить("ID_УКД_раздельно");
	МассивВидовДокументов.Добавить("ID_ИУПД_БезНДС");
	МассивВидовДокументов.Добавить("ID_УКД_БезНДС");
	МассивВидовДокументов.Добавить("ID_ТОРГ12_Акт_БезНДС");
	МассивВидовДокументов.Добавить("ID_Счет");
	МассивВидовДокументов.Добавить("ID_ИСФ_НаАванс");
	МассивВидовДокументов.Добавить("ID_ИУПД_НаАванс");
	МассивВидовДокументов.Добавить("ID_УПД_БезНДС");
	МассивВидовДокументов.Добавить("ID_ИКСФ");
	МассивВидовДокументов.Добавить("ID_ОсновнойПакет");
	МассивВидовДокументов.Добавить("ID_ИУКД");
	МассивВидовДокументов.Добавить("ID_ИУКД_раздельно");
	МассивВидовДокументов.Добавить("ID_ИСФ");
	МассивВидовДокументов.Добавить("ID_АктСверкиТара");
	МассивВидовДокументов.Добавить("ID_СчетФормализованный");
	МассивВидовДокументов.Добавить("ID_УПД" );
	МассивВидовДокументов.Добавить("ID_АктСверкиОборудование");
	МассивВидовДокументов.Добавить("ID_ИУПД_раздельно");
	МассивВидовДокументов.Добавить("ID_ИУПД");
	
	
	МассивСтатусов = Новый Массив;
	МассивСтатусов.Добавить("Подписан");
	//Результат.Добавить("Отказано в подписи контрагенту");
	МассивСтатусов.Добавить("Документооборот завершен");
	//Результат.Добавить("Аннулирован");
	//Результат.Добавить("Контрагент отказал в подписи");
	МассивСтатусов.Добавить("Подписан контрагентом");
	МассивСтатусов.Добавить("Подписан с разногласиями");

	
	
	
	ПараметрыОбновленияСписка = Новый Структура;
	ПараметрыОбновленияСписка.Вставить("Режим", "ОтправленныеДокументы");
	ПараметрыОбновленияСписка.Вставить("НачалоПериода", Дата('2019.04.01 00:00:00'));
	ПараметрыОбновленияСписка.Вставить("КонецПериода", Дата('2019.08.01 00:00:00'));
	ПараметрыОбновленияСписка.Вставить("МассивВыбранныхВидов", Неопределено);
	ПараметрыОбновленияСписка.Вставить("ОтборПоОрганизации ", Неопределено);
	ПараметрыОбновленияСписка.Вставить("ОтборПоКонтрагенту ", Неопределено);
	ПараметрыОбновленияСписка.Вставить("ОтборПоПакету ", Неопределено);
	//ПараметрыОбновленияСписка.Вставить("ОтборПоСтатусу ", МассивСтатусов);
	                                                        
	
	ПараметрыОбновленияСписка.Вставить("ВключитьОтборПоКонтрагенту ", ЛОЖЬ);
	ПараметрыОбновленияСписка.Вставить("ВключитьОтборПоОрганизации ", ЛОЖЬ);
	ПараметрыОбновленияСписка.Вставить("ВключитьОтборПоСтатусу ", ЛОЖЬ);
	ПараметрыОбновленияСписка.Вставить("ПоказыватьЗавершенные ", ИСТИНА);
	ПараметрыОбновленияСписка.Вставить("РежимОтбораПоПериоду ", "ПоДатеДокумента");
	
	
	ОсновнойМодуль.ЭДО_Модуль_ОбновитьСписокДокументов(ПараметрыОбновленияСписка);
               Для Каждого Стр Из ОсновнойМодуль.СписокДокументов Цикл
                                BoxId = ОсновнойМодуль.ЭДО_Модуль_ТаблицаОрганизацийПользователя()[0].BoxId;
				Архив = ОсновнойМодуль.ЭДО_ПолучитьАрхивДокументооборота(BoxId,Стр.LetterId,Стр.DocumentId);
                                Если Архив<>Неопределено Тогда
				
				   Каталог = "каталог куда сохранять будем" ;
				   Каталог = ЗаменитьНедопустимыеСимволыИмениФайла(Каталог);
				   ПроверитьСуществованиеКаталога(Каталог);
				   Архив.Записать(Каталог + Стр.ПредставлениеДокументаДиадок + ".zip");	
			        КонецЕсли;
			//сохранение архива ДО

		
		
	          КонецЦикла;
Показать


как то так сохраняю ДО. в настройках обработки Диадок необходимо указать логин пароль для авторизации
tricolor; John_d; +2 Ответить
9. ZOMI 430 07.10.22 12:21 Сейчас в теме
API для Диадока стоит 18 000 в год и я посмотрев на решение Контура для 1С взялся и написал свое решение. Дорабатывать обработку Контура - которую несколько десятков разработчиков видоизменяли - то еще удовольствие. Простейшие доработки вызывают боль.
10. bavkyz 3 07.10.22 12:36 Сейчас в теме
(9)
написал свое решение.


Поделитесь решением )
13. Razyiller 10.10.22 04:54 Сейчас в теме
Тоже реализовал такой функционал, только еще к каждому виду документов заказчик попросил отдельные пакеты печатных форм, причем пакет динамический. сделал через ПМ.

текущий релиз обработки Диадока намного удобнее в доработке нежели предыдущий))))
11. ZOMI 430 07.10.22 12:51 Сейчас в теме
(10)сейчас сложно назвать сроки... но видимо в течение месяца выложу
tambu; prestige; Evgenij1990; Dach; bavkyz; +5 Ответить
16. user954261 19.11.22 09:03 Сейчас в теме
Здравствуйте. Прошу помощи.
1С:УПП 1.3.190, настраиваю универсальный модуль КонтурДиадокИнтеграция 4.24.
Задача:
сопоставлять номенклатуру поставщика с нашей номенклатурой в соответствии с алгоритмом (на лету, без хранения таблицы соответствия, т.к. хранить не целесообразно). Это актуально, например, для услуг, когда каждый раз от поставщика прилетает уникальное наименование услуги. Это уникальное наименование нужно транслировать в нашу номенклатуру (примитивно, по вхождению подстроки).
При загрузке входящего док-та Накладная в док-т 1С:ПоступлениеТоваровУслуг сопоставление происходит дважды (как я понял). Первый этап удалось победить: в ПодключаемомМодуле добавил "Функция ПрочитатьСопоставлениеНоменклатуры(Параметры)". Сопоставление проходит успешно, далее нажимаю "Создать документы", после чего модуль второй раз пытается сопоставить номенклатуру (предположительно из РегистраСведений.НоменклатураКонтрагентов и из Справочник.ХранилищеДополнительнойИнформации).
Вопрос:
как победить второй этап сопоставления (при создании док-та ПоступлениеТоваров) ? Или есть решение, которое поможет пройти сразу два этапа сопоставления?
18. Vo-Va 470 26.11.22 13:36 Сейчас в теме
Кто бы написал еще статью как добавить выгрузку счет фактуры сделанной по отчету комиссионера. Только формализованную по стандарту фнс.
19. kai068 5 05.12.22 10:51 Сейчас в теме
Друзья, никто не сталкивался с добавлением документа Реализации(УПД) в Диадок со статусом "Отправлено на подпись"?
т.е чтобы не заходить в обработку Диадока, а программно отправить нужную накладную по "кнопке" сразу в обработку с нужным статусом.
Буду признателен, если направите куда копать.
20. kai068 5 05.12.22 10:53 Сейчас в теме
21. charushkin 78 27.03.23 13:56 Сейчас в теме
Привет!

Спасибо за хороший пример работы с модулем Диадока. В вашем кейсе документы на отправку выводятся в отдельном пакете. Я подготовил статью с примерами кейса, когда нужно добавить документы в уже готовый пакет Программное добавление документа в исходящий пакет (Контур.Диадок).Надеюсь, будет полезно вам или читателям вашей статьи
Оставьте свое сообщение

См. также

Программное добавление документа в исходящий пакет (Контур.Диадок)

Документооборот и делопроизводство (СЭД) ЭДО и ОФД Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В статье описана механика добавления произвольного неформализованного документа в стандартный исходящий пакет для модуля Диадок ("Универсальный модуль").

1 стартмани

27.03.2023    129    charushkin    0    

6

Удаление дублирующихся файлов в томах на диске

Адаптация типовых решений Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Типовой механизм хранения файлов позволяет один и тот же файл прикреплять несколько раз. Это бесит наших админов, и по их просьбе был реализован следующий алгоритм.

1 стартмани

05.10.2022    3146    5    human_new    19    

29

Параметризация печатных форм под контрагентов (подключаемое расширение)

Печатные формы Адаптация типовых решений Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Расширение добавляет возможности параметризации печати для контрагентов. Подробнее описано здесь https://infostart.ru/1c/articles/1510459/

10 стартмани

05.08.2022    6956    10    sapervodichka    4    

51

Просмотр объектов очереди сообщений в 1С:Документооборот

Адаптация типовых решений Документооборот и делопроизводство (СЭД) Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В базах с бесшовной интеграцией с 1С:Документооборот есть Регистр сведений "Очередь сообщений в 1С:Документооборот". Для пользователя он мало информативен. Расширение позволяет просматривать сообщение в человеческом виде. И понимать проблему до объекта.

2 стартмани

02.08.2022    7144    18    sapervodichka    4    

45

Конвертация данных 2 и JSON

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Описание минимально необходимых изменений, которые нужно внести в обработку "УниверсальныйОбменДаннымиXML" для того, чтобы реализовать конвертацию объектов конфигурации в произвольный формат JSON.

1 стартмани

01.07.2022    6892    18    zhichkin    19    

67

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Критерии отбора в расширении. 16+

Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Связываем критерии отбора расширения с типовой структурой подчиненности в универсальных решениях 1С.

3 стартмани

09.06.2022    6673    52    Ankare    25    

32

Пульт управления телевизором LG Smart TV

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Абонемент ($m)

Пульт LG телевизором smart TV (2014 года). Цель - управлять телевизором из 1С. Может быть полезна тем, кто потерял и не может найти пульт ДУ, кто смотрит телевизор и сидит за ноутбуком одновременно, для изучения обмена xml с внешними устройствами, в данном случае телевизором.

1 стартмани

11.01.2022    10118    6    confer2003@mail.ru    52    

66

Защита объектов от изменения обменом

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Расширение позволяет пользователю заблокировать объект 1С (документ, справочник) от изменения последующими загрузками данных или обменами.

5 стартмани

05.01.2022    14610    55    sapervodichka    52    

95

Формирование фида XML для СберМегаМаркет и СДЭК

Розничная торговля Файловый обмен (TXT, XML, DBF), FTP Маркетплейсы Платформа 1С v8.3 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Россия Управленческий учет Абонемент ($m)

Разработка, которая в автоматическом режиме выгружает фид для СберМегаМаркет в формате XML на FTP. Далее путь к файлу указывается в настройках магазина в партнерском кабинете СберМегаМаркет. Также этот фид работает и с маркетплейс СДЕК маркет (условие, что код категорий только цифры).

1 стартмани

14.10.2021    12492    0    BARDER    18    

16

Работа с 1С:Аналитика Промо

Онлайн-курс предусматривает изучение возможностей системы “1С:Аналитика”, которая работает как составная часть платформы “1С:Предприятие” и обеспечивает оперативный просмотр и анализ необходимых данных.

4500 рублей

Декларации по формам 7 и 8 алкогольной продукции, перенос данных из Декларант-Алко, импорт данных из файлов XML форм 11,12,7,8

Розничная торговля Регламентированный учет и отчетность Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Управляемые формы Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Акцизы Абонемент ($m)

Конфигурация на управляемых формах, платформа 1С 8.3.10.2667 и выше, с помощью которой можно сформировать Декларации по формам 7 и 8 алкогольной продукции, выполнить перенос данных из ПО Декларант-Алко версии 4.31.05 и выше, импорт и загрузку из файлов XML форм 11,12,7,8. Есть возможность автоматического подписания и шифрации файла выгрузки.

1 стартмани

15.04.2021    16351    56    independ    41    

33

Настройка обмена с любой устаревшей конфигурацией на базе 8.2 через обработку "Универсальный обмен данными в формате XML" и "Конвертацию данных 2.0"

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1C v8.2 Конфигурации 1cv8 Бухгалтерский учет Управленческий учет Абонемент ($m)

Разберем кейс, как настроить простенький обмен с любой устаревшей конфигурацией на базе 8.2 через обработку "Универсальный обмен данными в формате XML" и Конвертацию данных 2.0 с возможностью настройки гибких отборов по периоду, организации и списку документов.

1 стартмани

23.11.2020    26906    23    orfos    14    

66

Улучшенная обработка универсального обмена данными в формате XML (УФ)

Универсальные обработки Внешние источники данных Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Улучшенная обработка "Универсальный обмен данными" с полноценными возможностями СКД для выборки данных (не только для отборов).

1 стартмани

23.06.2020    22257    208    Lem0n    1    

67

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Печать, создание XML и сохранение в базу 1С кодов маркировки

Пакетная печать Розничная торговля Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Внешняя обработка для печати кодов марок, полученных из системы "Честный знак".

1 стартмани

14.01.2020    51468    456    user635667    343    

39

Односторонний файловый обмен с сайтом по ftp (1C 2 Web)

Файловый обмен (TXT, XML, DBF), FTP WEB-интеграция Платформа 1С v8.3 1С:Розница 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Абонемент ($m)

Подходит под любую конфигурацию на управляемом интерфейсе на базе БСП 2.4.4 и выше. Позволяет гибко настроить выгрузку, практически любых, данных по расписанию на сервер ftp вашего ресурса. Ведение лога процесса выгрузки также предусмотрено.

3 стартмани

09.12.2019    21555    25    LamerSoft    0    

19

Отключение создания задачи ознакомления для бизнес-процесса "Согласование" в 1С: Документооборот

Документооборот и делопроизводство (СЭД) Адаптация типовых решений Платформа 1С v8.3 Бизнес-процессы 1С:Документооборот Абонемент ($m)

В данной публикации я хочу поделиться расширением, с помощью которого можно отключить создание задачи ознакомления для бизнес-процесса "Согласование" в 1С: Документооборот.

1 стартмани

30.11.2019    28454    90    pavelpribytkin96    10    

34

Выгрузка и загрузка XML для управляемых форм 8.3 (с отбором)

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

В работе постоянно приходится разделять в различные базы или объединять несколько организаций в одну базу, долгое время пользовался стандартной обработкой выгрузка-загрузка из UNIREPS 8.2, в режиме обычного приложения, но, к сожалению, для управляемого приложения стандартная обработка из UNIREPS 8.3 (Диск ИТС) не позволяет нормально сделать выгрузку с отбором, поэтому ей никогда не воспользовался. Решил что напишу обработку, которая позволит делать отборы в различных вариациях, кроме того, в обработках из UNIREPS (8.2 и 8.3) существенно отличается процесс загрузки предопределенных, что не всегда удобно при больших объемах данных. Обработка написана на базе UNIREPS 8.3, но есть существенные изменения. Но интерфейс доработан так, чтобы обработка была похожа на старую добрую обработку из UNIREPS 8.2, к которой все так привыкли.

1 стартмани

05.11.2019    25010    412    o.kovalev    41    

27

Правила обмена УТ 11.5 (11.4) БП 3.0 для обработки "Универсальный обмен данными в формате XML"

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Бухгалтерский учет Управленческий учет Абонемент ($m)

Правила обмена УТ 11.5 (11.4) БП 3.0 для обработки "Универсальный обмен данными в формате XML". Для быстрой или частичной выгрузки справочников и документов, без настройки синхронизации данных.

1 стартмани

23.10.2019    25929    435    RAV38574    81    

27

1СПАРК РИСКИ. Сервис оценки благонадежности контрагентов. Промо

СПАРК помогает предотвратить мошенничество со стороны компаний и предпринимателей, благодаря актуальным сведениям о компаниях и системе выявления факторов риска.Сервис позволяет управлять налоговыми рисками и комплексно оценивать благонадежность контрагентов.

АРМ "Касса-Лом". Обмен между 1С и учетной системой по оплате с физическими лицами за сдачу металлолома

Оптовая торговля Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

АРМ "КАССА-ЛОМ" предназначено для проведения безналичных взаиморасчетов между физическими лицами-сборщиками металлолома и предприятиями, являющимися членами НП НСРО «РУСЛОМ.КОМ» и осуществляющими деятельность в области обращения с ломом и отходами металлов.

5 стартмани

23.09.2019    16230    24    vik070777    0    

6

Преобразование XML файла в переменную структура, Загрузка в дерево значений

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка, демонстрирующая работу процедур и функций по преобразованию XML файла в дерево значений, а также в переменную типа структура.

1 стартмани

14.09.2019    24603    41    vik070777    19    

31

ЗУП 3.1.10 или когда пропадают элементы в отборах списком

Адаптация типовых решений Зарплата Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x Бухгалтерский учет Абонемент ($m)

ЗУП 3.1.10 значительно изменил функционал формы отчетов по сравнению с 3.1.9, 3.1.8 и т.д.. В отчетах в отборах с видом сравнения: В списке, В группе из списка - неприятно, но стали пропадать из списков не отмеченные флажком элементы. Данное расширение решает проблему, не изменяя типовой функционал.

1 стартмани

31.07.2019    19135    7    sapervodichka    6    

28

Документы и Справочники в JSON

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Пример выгрузки всех данных Документа или Справочника в JSON

1 стартмани

20.06.2019    35316    49    Teut_Vlad    22    

81

Универсальный обмен данными XML (с гибкими отборами и сохранением вариантов настроек)

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Обработка предназначена для загрузки и выгрузки данных по правилам обмена в любых конфигурациях, реализованных на платформе 1С:Предприятие 8.3. Преимуществом перед типовой обработкой является добавленный функционал: #1. Установка произвольных фильтров на выгружаемые объекты при помощи механизма системы компоновки данных #2. Сохранение различных вариантов настроек (сохраняются правила обмена, фильтры выгрузки, параметры, настройки обработки) - что позволяет гибко настроить в базе-источнике фильтры для выгрузки объектов по различным правилам обмена для различных баз-приемников, сохранить выполненные настройки и в будущем уже пользоваться этими вариантами настроек. Проверялась на 1С:ERP Управление предприятием 2.4.7.141.

1 стартмани

29.04.2019    46355    700    sapervodichka    20    

67

Распознавание и загрузка документов в 1С Промо

Универсальная программа-обработка для распознавания любых сканов или фото первичных документов в 1С (счета-фактуры, УПД, ТТН, акты и тд). Точность распознания до 98%.

от 11 рублей

Выгрузка и загрузка данных XML с гибкими отборами

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка выгрузки и загрузки данных через XML между идентичными конфигурациями с возможностью установки произвольных отборов на выгружаемые объекты.

1 стартмани

07.04.2019    50475    1301    sapervodichka    54    

74

Перенос данных КА 1.1 -> КА 2

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Перенос данных КА 1.1 => КА 2 с помощью правил обмена данными в формате XML КД 2 (переносятся остатки, документы, справочная информация).

5 стартмани

20.03.2019    30478    330    gudogu    150    

28

Выгрузка данных из Бухгалтерии ред. 3.0 в Управление небольшой фирмой, ред. 1.6

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 Россия Управленческий учет Абонемент ($m)

Выгрузка данных из 1С БП 3.0 в УНФ 1.6. Обработка переносит документы по банку, кассе, движения ТМЦ + справочники контрагентов, номенклатуры и другие связанные справочники. Полный список документов на скриншоте.

1 стартмани

08.02.2019    37917    534    dinarz    225    

37

FTP-Клиент на 1С

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

FTP-Клиент на 1С для тех, кто все еще работает с FTP...

1 стартмани

04.02.2019    19531    105    frkbvfnjh    20    

59

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Редактор объектов информационной базы 8.3

Универсальные обработки Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Абонемент ($m)

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.69 от 12.03.2023

2 стартмани

23.01.2019    56496    668    ROL32    85    

126

Перенос данных КА 1.1.115.1 => БП 3.0.75.104 (перенос остатков, документов, зарплатный блок и справочной информации)

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 3.0 Россия Абонемент ($m)

Переносятся: остатки по счетам 01, 02, 10, 20, 41, 60, 62, 71, 97 и их субсчетам; документы; отдельно можно перенести справочники (номенклатура, контрагенты, договоры контрагентов, организации, склады, физические лица, сотрудники).

5 стартмани

22.12.2018    27950    499    gudogu    169    

26

Видеокурс-практикум: как подготовить и написать ТЗ, ЗНР, ЧТЗ. Промо

В курсе обобщен опыт работы аналитика на проектах в течение пяти лет, в нескольких фирмах. Подходы к написанию документов унифицированы и по возможности не привязаны к конфигурациям 1С.

3 500 рублей

SOAP для чайников

WEB-интеграция Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Немножко про SOAP сервис. И пример работы с подключением и получением данных по SOAP за 5 минут.

1 стартмани

05.09.2018    110854    73    dusha0020    25    

115

Создание в 1С 7.7 XML в формате EnterpriseData (универсальный формат обмена), версия 1.5. Инструкции и примеры переноса данных из устаревшей конфигурации 1С 7.7 в любую современную 1С 8.3, поддерживающую EnterpriseData, через Конвертацию данных 3

Файловый обмен (TXT, XML, DBF), FTP Обмен между базами 1C Платформа 1С v7.7 Платформа 1С v8.3 Конфигурации 1cv7 Россия Абонемент ($m)

Воспользоваться современным средством переноса данных "Конвертация данных 3.0.5.3" можно только выгрузив из системы - источника данных XML в формате обмена данными EnterpriseData. В этой публикации можно скачать приемы выгрузки из 1С 7.7 универсального формата обмена для Конвертации данных 3. Выполняем перенос данных из «1С:Предприятие 7.7» в «1С:Предприятие 8.3». Используем Конвертацию данных КД 3.0 из 1c 7.7 --> 1С 8.3. На первой стадии еще не опубликовано иного способа подложить файл для Конвертации данных 3 кроме как сформировать его вручную, постараемся решить данную проблему.

1 стартмани

26.02.2018    59750    66    ksnik    5    

40