Перенос документов между идентичными конфигурациями для платформы не ниже 8.2.18.82

Публикация № 195701

Разработка - Обмен данными 1С - Перенос данных из 1C8 в 1C8

38
Обработка выполняет перенос документов между идентичными конфигурациями на платформе не ниже 8.2.18.82. Тестирование выполнялось для конфигурации "Бухгалтерия предприятия версия 2.0.49.15"

Синхронизация объектов конфигураций выполняется по уникальным идетификаторам.

38

Скачать файлы

Наименование Файл Версия Размер
Перенос между идентичными конфигурациями
.epf 31,14Kb
09.08.13
866
.epf 5 31,14Kb 866 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. paulpit 19 30.07.13 00:30 Сейчас в теме
Обработка переносит измененные документы?
А чем не устроила универасльная обработка с ИТС-а?
2. XSlava 136 30.07.13 07:50 Сейчас в теме
Этой обработке все равно изменен или не изменен документ, т.к. в качестве основного правила обмена используется сама структура конфигурации (метаданные). Почему не с ИТС, искать, затем разбираться и проверять, тоже самое по времени, что и написать. Скорее всего для типовой обработки нужны еще и правила.
Надеюсь, что ответил на ваши вопросы.
10. apostal86 213 08.08.13 13:45 Сейчас в теме
(2) XSlava, Стандартную ИТС-кую проверять не нужно, с ней все ОК, работает во всех идентичных конфигурациях. Для типовой правила не нужны. То что у Вас выложено практически то же самое, что и в обработке с ИТС. Какое у Вашей обработки принципиальное отличие?
3. awbyk 77 01.08.13 11:14 Сейчас в теме
Попробовал перенос для БГУ из редакции 1.0.14.2 в редакцию 1.0.20.6

Пришлось слегка подправить модуль формы:
- Организации изменил на Учреждения;
- Обошел попыткой, исключением, поскольку в редакции 1.0.14.2 нет константы.ЗаголовокСистемы строку
ЭтаФорма.Заголовок = ЭтаФорма.Заголовок + " " + константы.ЗаголовокСистемы.Получить();
- Список видов документов отсортировал по представлению.

В принципе удобнее, чем универсальный перенос.
4. Жискар 10 05.08.13 12:39 Сейчас в теме
Запускал в «Зарплата и кадры бюджетного учреждения, редакция 1.0 (1.0.60.3)» ,
«Бухгалтерия предприятия, редакция 2.0 (2.0.49.11)».
Платформа 1С:Предприятие 8.2 (8.2.18.109).
Получал сообщение «Обработка завершена».
Ни одной записи в результат не перенесено.
Может что-то ещё надо установить, чтобы обработка работала?
5. XSlava 136 05.08.13 14:36 Сейчас в теме
На закладке "Настройки переноса" нужно выбрать вид документа, затем нажать кнопку "Заполнить", за указанный период будет заполнена таблица переносимых документов. Затем переносить.
6. Жискар 10 05.08.13 15:16 Сейчас в теме
Брал один вид документа "Начисление зарплаты" по одной организации и за период с февраля по апрель.
Вибиралось штук 5. Нажал выполнить. Обработка завершена.
Перенесено 0 документов. Все гладко, только результата нет.
7. XSlava 136 05.08.13 15:28 Сейчас в теме
Значит при переносе есть ошибки, их можно посмотреть создав файл отладки.
8. Жискар 10 05.08.13 16:13 Сейчас в теме
Файл отладки не создается вообще, даже пустой. Машина домашняя, доступно всё.
15. XSlava 136 09.08.13 13:41 Сейчас в теме
16. Жискар 10 09.08.13 15:32 Сейчас в теме
(15) XSlava, Все прекрасно работает. Спасибо.
Началась новая жизнь.
17. XSlava 136 09.08.13 15:35 Сейчас в теме
(16) Жискар, Хорошо. Пишите, если будут идеи по улучшению.
9. XSlava 136 05.08.13 16:44 Сейчас в теме
Странно. "Начисление зарплаты" говорите. Посмотрю.
11. XSlava 136 08.08.13 14:15 Сейчас в теме
Видимо отличается формой.
12. Жискар 10 08.08.13 15:27 Сейчас в теме
apostal86. Извиняюсь за серость. Стандартная ИТС-кая это ВыгрузкаЗагрузкаДанныхXML82.epf
или что-то другое?
13. XSlava 136 08.08.13 15:43 Сейчас в теме
Я не знаю, никогда не пользовался. Возникла необходимость, написал свою.
14. Slater_7 09.08.13 09:35 Сейчас в теме
Таже ерудна что и у Жискар. Говорит что Завершено, но ничего не переносит и отладка не создаётся. Конфа - Бухгалтерия для Казахстана(2.0.11.8) 1С:Предприятие 8.2 (8.2.18.102). Где копать хотябы - есть идеи?
18. hawl 12.08.13 13:05 Сейчас в теме
Спасибо большое, всё работает хорошо.
19. ilsijar 61 23.09.13 10:38 Сейчас в теме
Не очень универсален, но доработать для себя можно.Спасибо,сэкономила время.
20. silver-747 17.10.13 19:58 Сейчас в теме
Спасибо. выручила обработка.
21. Felix1 10.11.13 21:14 Сейчас в теме
Выдает ошибку "
{ВнешняяОбработка.ПереносМеждуИдентичнымиКонфигурациями.МодульОбъекта(46)}: Ошибка при вызове метода контекста (Записать)
о.Записать();
по причине:
Произошла исключительная ситуация (1C:Enterprise 8.2.16.368): Не удалось записать "Счет на оплату покупателю ДПб00000365 от 23.08.2013 16:23:45"!
"
22. Felix1 10.11.13 21:16 Сейчас в теме
не понимаю в чем проблема ? переношу документы за 4 кв 2013 г, в базе приемнике установил дату запрета редактирования по 30.09.2013 ? вопрос причем тут счет от23.08.2013
23. XSlava 136 11.11.13 08:42 Сейчас в теме
Скорее всего в каком нибудь переносимом документе есть ссылка на данный счет, вот он его и переносит.
24. Felix1 11.11.13 08:57 Сейчас в теме
А что с этим делать ???, если я сниму дату запрета редактирования, то у меня поедет прошлый период ?
25. XSlava 136 11.11.13 10:04 Сейчас в теме
(24) Felix1, Один из вариантов очистить ссылку на данный документ в переносимом документе. Решение данной проблемы зависит от задач которые вы решаете.
26. Felix1 11.11.13 11:21 Сейчас в теме
хорошо , а как мне найти тот самый документ,
на который ссылается на счет ???
27. XSlava 136 11.11.13 11:40 Сейчас в теме
(26) Felix1, Написать запрос, затем обработку.
28. Felix1 11.11.13 11:46 Сейчас в теме
(27) XSlava, А для бухгалтера, есть вариант по проще ???
32. likan 27.11.13 08:52 Сейчас в теме
(26)а найти счет и посмотреть подчиненные документы, религия не позволяет?
33. Felix1 27.11.13 12:47 Сейчас в теме
(32) likan, 1.Вопрос уже решен стандартной обработкой с ИТС
2. Если есть конкретные предложения, или желаете помочь, пишите по делу, религия тут не причем.
29. XSlava 136 11.11.13 12:01 Сейчас в теме
30. Felix1 11.11.13 12:39 Сейчас в теме
(29) XSlava, Тогда у меня оборотно-сальдовая ведомость не изменится ??? и вообще все показатели ???
31. XSlava 136 11.11.13 12:50 Сейчас в теме
(30) Felix1, Сделайте резервную копию, проверьте сначала на копии. У вас очень серьезные вопросы, для ответа на которые нужно знать гораздо больше о ваших задачах, чем выпи пишете.
34. imarok 30.11.13 15:22 Сейчас в теме
при выполнение обработки в ут 10.3.15.9 ошибка
{Обработка.ПереносМеждуИдентичнымиКонфигурациями.МодульОбъекта(139)}: Ошибка при вызове метода контекста (СоздатьЭлемент)
ОЭлемент = Открытие.Справочники[ВидСпр].СоздатьЭлемент();
по причине:
Произошла исключительная ситуация (1C:Enterprise 8.2.18.109): {Справочник.Номенклатура.МодульОбъекта(122,33)}: Переменная не определена (РаботаСТорговымОборудованием)
35. imarok 30.11.13 15:34 Сейчас в теме
Разобрался, прошу прощения
36. tanselja 4 30.11.13 16:04 Сейчас в теме
Вроде и стандартная хорошо работает.
37. yalo 03.12.13 09:42 Сейчас в теме
А в чем отличие от стандартной обработки? Использую ее, переносит все необходимые документы и справочники и т.д.
38. Natuhai 3 20.01.14 18:39 Сейчас в теме
Спасибо. Пригодилась обработка. Бухи потерли полтора десятка документов с табличной частью этак в 3000 строк ... Перенес им из бекапа.
39. Alister 9 23.01.14 15:33 Сейчас в теме
Спасибо за работу, все что нужно перенесла.
40. if56 19.02.14 14:52 Сейчас в теме
Есть ошибка.
Если не устанавливать флаг Перезаписывать документы, то таб части документов , перенесенных ранее , задваиваются. Ошибка в функции ПолучитьДокумент(ТекДок)

Кусок кода:

Если ФлПерезаписыватьДоки и не ЭтоНовый тогда
инфа("Документ уже переносился!!! Изменяем документ "+ВидДока+" № "+ТекДок.Номер+" от "+ТекДок.Дата,0);
//Очистим табличные части
Для каждого ТЧ из Открытие.Метаданные.Документы[ВидДока].ТабличныеЧасти цикл
ДокБух[ТЧ.Имя].Очистить();
КонецЦикла;
ИначеЕсли не ФлПерезаписыватьДоки и не ЭтоНовый тогда // Все равно пишем
инфа("Документ уже переносился!!! Пропускаем документ "+ВидДока+" № "+ТекДок.Номер+" от "+ТекДок.Дата,0);
//////////////////////////////////////// надо бы Возврат Неопределено;

Иначе
инфа("Создаем документ "+ВидДока+" № "+ТекДок.Номер+" от "+ТекДок.Дата,0);
КонецЕсли;
Возврат ДокБух;
КонецКуска
41. arjuna 26.03.14 00:43 Сейчас в теме
(40) if56.ru,
Есть ошибка.
Если не устанавливать флаг Перезаписывать документы, то таб части документов , перенесенных ранее , задваиваются. Ошибка в функции ПолучитьДокумент(ТекДок)

У меня упорно задваивает все документы. Уже всю голову сломал, не видет он УникальныйИдентификатор в удаленной базе.
42. sps02 14.08.14 15:21 Сейчас в теме
Извините, если вопрос глупый(( Могу ли я перенести документы из одинаковых конфигураций, но если это разные контрагенты?
Спасибо заранее
43. sps02 14.08.14 17:39 Сейчас в теме
Закачала, но выдает такую ошибку. подскажите как решить: Не смог записать элемент справочника Номенклатура Набор для кофе "Бернадот 0000" 110 мл на 6перс.12пред {ВнешняяОбработка.ПереносМеждуИдентичнымиКонфигурациями.МодульОбъекта(405)}: Ошибка при вызове метода контекста (Записать): Произошла исключительная ситуация (1C:Enterprise 8.2.19.90): Ошибка при выполнении обработчика - 'ПередЗаписью'
Заранее спасибо
44. sps02 15.08.14 11:40 Сейчас в теме
Скажите, пожалуйста почему номенклатура не загружается?
45. makas 44 08.10.14 18:15 Сейчас в теме
Обработка в 1С:Предприятие 8.2 (8.2.19.106) "Управление торговлей", редакция 10.3 (10.3.29.1) пишет сообщение "База данных не открыта !!!"

В чем может быть моя ошибка?

46. XSlava 136 09.10.14 08:01 Сейчас в теме
В чем угодно. Нет доступа к каталогу или еще чего.
47. SvetlanaP 27.02.15 12:57 Сейчас в теме
Спасибо за обработку! С ней намного легче работать. Сначала все время появлялось сообщение "База данных не открыта!!!", но потом все получилось. У меня все переносится идеально.
48. Evrey.biysk 11.03.15 06:33 Сейчас в теме
Одна из причин почему база данных не открыта, пробелы в логине или пароле
Если таковые имеются то
v8=Новый COMОбъект("v8"+Прием+".COMConnector");
	Состояние("Подключение к базе");
	строкаЗапуска="";
	Если ФлБазаНаСервере тогда  
		строкаЗапуска = "Srvr="""+ СокрЛП(ф.Сервер) + """;"+"Ref="""+СокрЛП(ф.ИмяБазы)+ """;Usr=" + СокрЛП(ф.ИмяПользователя) + ";Pwd=" + СокрЛП(ф.Пароль);
	иначе	
		строкаЗапуска = "File="""+ СокрЛП(ф.Каталог) + """;Usr=" + СокрЛП(ф.ИмяПользователя) + ";Pwd=" + СокрЛП(ф.Пароль);
		Если не ЗначениеЗаполнено(ф.ИмяПользователя) тогда
			строкаЗапуска = "File="""+ СокрЛП(ф.Каталог) + """";
		КонецЕсли;	
	конецесли;
	
	Сообщить(строкаЗапуска);
	Попытка   		
		Открытие = V8.Connect(строкаЗапуска); 
		Состояние("Подключились"); 
	Исключение 
		Предупреждение("База данных не открыта!!!"); 
		Возврат Ложь; 
	КонецПопытки;
	Возврат Истина;
Показать


Надо заменить следующим:

v8=Новый COMОбъект("v8"+Прием+".COMConnector");
	Состояние("Подключение к базе");
	строкаЗапуска="";
	Если ФлБазаНаСервере тогда  
		строкаЗапуска = "Srvr="""+ СокрЛП(ф.Сервер) + """;"+"Ref="""+СокрЛП(ф.ИмяБазы)+ """;Usr=""" + СокрЛП(ф.ИмяПользователя) + """;Pwd=""" + СокрЛП(ф.Пароль)+"""";
	иначе	
		строкаЗапуска = "File="""+ СокрЛП(ф.Каталог) + """;Usr=""" + СокрЛП(ф.ИмяПользователя) + """;Pwd=""" + СокрЛП(ф.Пароль)+"""";
		Если не ЗначениеЗаполнено(ф.ИмяПользователя) тогда
			строкаЗапуска = "File="""+ СокрЛП(ф.Каталог) + """";
		КонецЕсли;	
	конецесли;
	
	Сообщить(строкаЗапуска);
	Попытка   		
		Открытие = V8.Connect(строкаЗапуска); 
		Состояние("Подключились"); 
	Исключение 
		Предупреждение("База данных не открыта!!!"); 
		Возврат Ложь; 
	КонецПопытки;
	Возврат Истина;
Показать
49. LavinVadik 111 22.10.15 23:35 Сейчас в теме
на 8.3 тоже работает
маленько код надо тока поправить

еще момент если не ставить флажок "перезаписывать документы" и в базе приемники такой документ уже есть,
табличные части дублируются.
вот тут надо добавить что то типа "Если ФлПерезаписыватьДоки тогда"
Функция ПеренстиДокумент(ТекДок)
	ВидДокумента 	= Метаданные.НайтиПоТипу(ТипЗнч(ТекДок));
	ТипДокумента	= ВидДокумента.Имя;
	Синоним			= ВидДокумента.Синоним;
	ОДок = ПолучитьДокумент(ТекДок);
	
	Если ФлПерезаписыватьДоки тогда	
		Для каждого Реквизит из Метаданные.Документы[ТипДокумента].Реквизиты цикл
			Если Открытие.Метаданные.Документы[ТипДокумента].Реквизиты.Найти(Реквизит.Имя) = неопределено тогда
				Продолжить;
			КонецЕсли;	
			ОДок[Реквизит.Имя] = ЗаменитьЗначение(ТекДок[Реквизит.Имя]);
		КонецЦикла;	
		
		
		Для каждого ТабличнаяЧасть из Метаданные.Документы[ТипДокумента].ТабличныеЧасти цикл
			Если Открытие.Метаданные.Документы[ТипДокумента].ТабличныеЧасти.Найти(ТабличнаяЧасть.Имя) = неопределено тогда
				Продолжить;
			КонецЕсли;	
			Для каждого Строка из ТекДок[ТабличнаяЧасть.Имя] цикл
				НоваяСтрока = ОДок[ТабличнаяЧасть.Имя].Добавить();
				Для каждого Реквизит из ТабличнаяЧасть.Реквизиты цикл
					Если Открытие.Метаданные.Документы[ТипДокумента].ТабличныеЧасти[ТабличнаяЧасть.Имя].Реквизиты.Найти(Реквизит.Имя) = неопределено тогда
						Продолжить;
					КонецЕсли;	
					НоваяСтрока[Реквизит.Имя] = ЗаменитьЗначение(Строка[Реквизит.Имя]);
				КонецЦикла;	
			КонецЦикла;
		КонецЦикла;	
	КонецЕсли;	
	
	Если не ВидДокумента.КонтрольУникальности тогда
		ОДок.Номер 	= ТекДок.Номер;
	ИначеЕсли не НайтиДокументПоКоду("Документ", ТипДокумента, ТекДок.Номер, ТекДок.Дата, ВидДокумента.ПериодичностьНомера) тогда
		ОДок.Номер 	= ТекДок.Номер;
	КонецЕсли;	
	
	ОДок.Дата 	= ТекДок.Дата;
	
	ЗаписатьДокумент(ОДок,ТекДок,Синоним);
	Возврат ОДок.Ссылка;
КонецФункции
Показать



//v8=Новый COMОбъект("v8"+Прием+".COMConnector");
v8=Новый COMObject("V83.COMConnector");
или добавить в список выбора "Прием"


и не предусмотрено если в базе приемники такой документ уже есть и он помечен на удаление то документ не проводится, вот пример
надо добавить
Если ДокБух.ПометкаУдаления Тогда
ДокБух.УстановитьПометкуУдаления(Ложь);
КонецЕсли;



Функция ПолучитьДокумент(ТекДок)
	ВидДока = Метаданные.НайтиПоТипу(ТипЗНЧ(ТекДок)).Имя;
	УИ = открытие.NewObject("УникальныйИдентификатор",СокрЛП(""+ТекДок.УникальныйИдентификатор()));
	ЭтоНовый = Ложь;
	ЕстьСсылка = Открытие.Документы[ВидДока].ПолучитьСсылку(УИ);
	Если не ПустаяСтрока(ЕстьСсылка.Номер) тогда
		ДокБух=ЕстьСсылка.ПолучитьОбъект();
		Если ДокБух.ПометкаУдаления Тогда
			ДокБух.УстановитьПометкуУдаления(Ложь);
		КонецЕсли;	

	Иначе
		ДокБух = Открытие.Документы[ВидДока].СоздатьДокумент();
		НоваяСсылка = Открытие.Документы[ВидДока].ПолучитьСсылку(УИ);
		ДокБух.УстановитьСсылкуНового(НоваяСсылка);
		ЭтоНовый = Истина;
	КонецЕсли;
	Если ФлПерезаписыватьДоки и не ЭтоНовый тогда	
		инфа("Документ уже переносился!!! Изменяем документ "+ВидДока+" № "+ТекДок.Номер+" от "+ТекДок.Дата,0);
		//Очистим табличные части
		Для каждого ТЧ из Открытие.Метаданные.Документы[ВидДока].ТабличныеЧасти цикл
			ДокБух[ТЧ.Имя].Очистить();
		КонецЦикла;	
	ИначеЕсли не ФлПерезаписыватьДоки и не ЭтоНовый тогда	
		инфа("Документ уже переносился!!! Пропускаем документ "+ВидДока+" № "+ТекДок.Номер+" от "+ТекДок.Дата,0);	
	Иначе	
		инфа("Создаем документ "+ВидДока+" № "+ТекДок.Номер+" от "+ТекДок.Дата,0);
	КонецЕсли;	
	Возврат ДокБух;
КонецФункции
Показать
Светлый ум; +1 Ответить
50. Доня 274 02.03.17 16:06 Сейчас в теме
(49)
Вы в комментариях написали :
<<< 49. Вадик Лавин (LavinVadik) 57 22.10.15 23:35
на 8.3 тоже работает
маленько код надо тока поправить ...>>>
не могли бы Вы скинуть поправленный на мою почту tathr@mail.ru
Я сделала все Ваши добавки, но не работает на 8.3
51. XSlava 136 03.03.17 12:08 Сейчас в теме
Пришлите мне файл который вы доработали, я его проверю на 8.3 и поправлю если не будет работать.
Оставьте свое сообщение

См. также

Отладка правил обмена КД2 для подсистемы БСП Обмен данными 41

Статья Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Перенос данных из 1C8 в 1C8

Уже давно нельзя отлаживать правила обмена при помощи внешних файлов. Попробуем исправить это.

1 стартмани

27.05.2019    3541    4    fenixnow    5       

Выгрузка и загрузка данных XML с гибкими отборами 34

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

Обработка выгрузки и загрузки данных через XML между идентичными конфигурациями с возможностью установки произвольных отборов на выгружаемые объекты.

1 стартмани

07.04.2019    4053    108    sapervodichka    7       

Перенос данных КА 1.1 -> КА 2 19

Инструменты и обработки Программист Документ XML v8 КА1 КА2 Россия Абонемент ($m) Перенос данных из 1C8 в 1C8 Обмен через XML

Перенос данных КА 1.1 => КА 2 с помощью правил обмена данными в формате XML КД 2 (переносятся остатки, документы, справочная информация).

5 стартмани

20.03.2019    5329    103    gudogu    107       

Ручная выгрузка и загрузка данных через универсальный обмен данными с настройками (расширение, платформа 8.3+) 45

Инструменты и обработки Программист Архив с данными v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m) Обработка документов Обработка справочников Обмен через XML Перенос данных из 1C8 в 1C8

Данное расширение (не требует изменения конфигураций) служит как надстройка для конфигураций, у которых обмен между базами происходит через универсальный формат (EnterpriseData), с использованием стандартных правил конвертации, которые уже есть в конфигурации. Интерфейс адаптирован для простых пользователей, сделан общий отбор по Организации для всех документов, имеется пару настроек для передачи в параметры конвертации, которые расположены в общем модуле конфигураций, а так же есть возможность выбора запуска - в фоне или в текущем сеансе. Теперь не нужно настраивать обмен между базами, для того чтоб просто перенести нужные документы. Подходит точно для УТ 11.4, БП 3.0.67, КА 2.4.5, Розница 2.2.9 (Обновление 1.2 от 02.03.2019)

2 стартмани

19.01.2019    7105    84    hakerxp    8       

Обмен без правил. От простого к сложному 128

Статья Программист Архив с данными v8 1cv8.cf Абонемент ($m) Перенос данных из 1C8 в 1C8

Пишем обмен с нуля, разбираемя с разными способами сериализации, учимся редактировать XML документы, создаем XDTO и Web service, осваиваем Script variant - English.

1 стартмани

16.01.2019    12122    7    fr13    26       

Выполнение запроса в другой базе 1С без com-соединения. HTTP-сервис 66

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Перенос данных из 1C8 в 1C8

Выполнение любого запроса с параметрами из одной базы 1С в другую. Используя HTTP-сервис. Посредством POST-запроса и JSON.

1 стартмани

30.11.2018    8314    16    John_d    19       

Пример получения данных из другой базы 1С через Web-сервис 99

Инструменты и обработки Программист Архив с данными v8 Россия Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

В данной статье описан пример получения данных справочника из другой базы 1С через Web-сервис.

1 стартмани

11.11.2018    12178    13    flyDrag    28       

Способы оптимизации переносов данных 55

Статья Программист Нет файла v8 КД Абонемент ($m) Перенос данных из 1C8 в 1C8

Хочу рассказать вам про способы оптимизации разработки правил обмена в программе «Конвертация данных» второй редакции. Казалось бы, про эту программу и разработку в ней правил конвертации уже сказано все, что можно. Появились уже более современные и быстрые технологии. Почему же все еще она? Дело в том, что «Конвертация данных» второй редакции все еще актуальна для огромного круга задач. Она имеет очень широкую функциональность и позволяет реализовывать сложные алгоритмы. Годы идут, а люди продолжают ей пользоваться и у них возникает много вопросов по этой программе. Возможно, в будущем вы тоже будете заниматься такими проектами и столкнетесь с задачами, похожими на те, про которые я собираюсь рассказать. Мне хочется вам в этом помочь.

1 стартмани

02.08.2018    9624    93    primat    7       

Опыт проведения сложных переносов данных на 1С 166

Статья Программист Архив с данными v8 КД Абонемент ($m) Перенос данных из 1C8 в 1C8

В статье я расскажу про опыт сложных переносов на платформе 1С:Предприятие. Она будет адресована в первую очередь разработчикам 1С, которые уже имеют опыт использования методики «Конвертация данных» (как второй, так и третьей редакции) – я думаю, это большинство из нас. • Я расскажу про различные методики организации переносов данных. • Мы рассмотрим рекомендуемые способы оптимизации правил конвертации, которые позволят вам быстрее выполнять свои переносы. • Также мы разберем, какие могут возникнуть сложности в ходе переноса данных. • Я покажу сравнительный анализ по ряду параметров инструментов «Конвертация данных» второй редакции и третьей, которая вышла уже более года назад.

30.07.2018    21888    44    primat    12       

Конвертация данных 2.1. Как реквизит справочника конвертировать в регистр сведений? 18

Статья Программист Архив с данными v8 КД Россия Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

В публикации рассмотрен пример конвертации реквизита справочника в регистр сведений.

2 стартмани

28.06.2018    8210    wowik    0       

Синхронизация (выгрузка) данных ЗУП 3.1 - БП 2.0, УПП 1.3 47

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ v8::СПР БП2.0 ЗУП3.x Россия БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Перенос данных из 1C8 в 1C8

Подобная выгрузка не была предусмотрена разработчиками 1С, поэтому и существует эта публикация. Поддерживается выгрузка оценочных обязательств и резервов отпусков. Непосредственная выгрузка в базу Бухгалтерии.

3 стартмани

22.03.2018    26696    516    diso    160       

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1 44

Инструменты и обработки Системный администратор Программист Бухгалтер Документ XML v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Зарплата Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1. Позволяют вести параллельную работу в базах ЗУП редакций 2,5 и 3.1.

10 стартмани

06.03.2018    24271    123    kostya_whiskas    23       

Организация обмена с базой филиала (розничного магазина) в торговой сети через XML (универсальный обмен) 70

Статья Программист Архив с данными v8 КД УТ11 Розничная и сетевая торговля (FMCG) Розничная торговля Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

В статье по шагам рассматривается создание обмена между центральной базой и базами филиалов на базе конфигурации УТ 11. Для решения поставленной задачи было решено не использовать РИБ, т.к. требуется односторонний обмен ограниченным набором данных, к тому же по определенным условиям. Обмен реализован на основе типовой синхронизации на основе универсального обмена в формате EnterpriseData. Данная публикация может быть полезна внедренцам, которые работают с торговыми сетями, в том числе по модели франчайзинга.

1 стартмани

26.02.2018    24875    14    Kutuzov    18       

[УТ 11][БП 3.0] Перенос данных из БП 3.0 в УТ 11 (начальное заполнение УТ 11 по данным БП 3.0) 32

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 БП3.0 УТ11 Россия УУ Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Перенос данных из БП 3.0 в Ут 11 для первоначального заполнения УТ данными из БП. 26.02.2019 Версия 2.8.5.5 БП 3.0.68.58.72 УТ 11.4.6.230 платформа 8.3.13.1690. Исправлен (по возможности) перенос остатков взаиморасчетов в части формирования типов расчетных документов и типа операции документов ВНО. Вопрос к знатокам УТ 11, остатки по субсчетам 76 счета (не 76.05 или 76.06) каким типом операции ввода остатков должны переноситься?

1 стартмани

29.01.2018    25983    371    Alex_E    122       

Проверка данных после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1 18

Отчеты и формы Бухгалтер Архив с данными v8 v8::СПР ЗУП3.x Россия БУ Зарплата Абонемент ($m) Бухгалтерский учет Перенос данных из 1C8 в 1C8

Описаны данные, которые необходимо проверить после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1. Описано, на что необходимо обратить внимание, где найти перенесенные данные, что НЕ переносится, где найти настройки.

1 стартмани

17.01.2018    15819    137    btydj    3       

Правила переноса документов из ЗУП 2.5 в ЗУП 3.1 33

Инструменты и обработки Программист Документ XML v8 v8::СПР ЗУП3.x Россия БУ Windows Зарплата Управление персоналом (HRM) Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

Перенос документов из ЗУП 2.5 в ЗУП 3.1 - позволяет снизить объем работ при опытной эксплуатации ЗУП 3.1 параллельно с ЗУП 2.5.

1 стартмани

04.12.2017    23161    486    AntonH851    38       

Пример создания в КД 2.1 правил выгрузки данных регистра «Лицевые счета работников» из ЗУП 2.5 в справочник «Банковские счета» БП 3.0. Подробно, ясно и просто. 20

Статья Программист Архив с данными v8 КД Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Эту статью я написал для тех, кто хочет максимально быстро и эффективно научиться создавать правила выгрузки данных в конфигурации 1С Конвертация данных редакции 2.1. Разберем практическую несложную задачу создания правил выгрузки данных регистра «Лицевые счета работников организаций» ЗУП 2.5 в справочник «Банковские счета» БП КОРП 3.0. Поделюсь некоторыми эффективными приемами: ВыгрузкаПоПравилу(…), работа с глобальными параметрами конвертации и передача их с Источника в Приемник методом ПередатьОдинПараметрВПриемник(…), приемы ускорения и оптимизации конвертации данных. Кому эта статья покажется простой и/или захочется продолжения: рекомендую другую мою публикацию, в которой разобран более сложный пример : https://infostart.ru/public/695916/

1 стартмани

17.11.2017    24428    12    RailMen    1       

1С:Конвертация данных 2.0. Анализ состава выгруженных данных из базы источника до загрузки в базу-приемник 30

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 КД БП3.0 ЗУП3.x Россия Windows Абонемент ($m) Перенос данных из 1C8 в 1C8 Перенос данных из 1С7.7 в 1C8.X

Обработка анализирует файл выгрузки данных конвертации и формирует дерево выгруженных объектов по категориям с возможностью просмотра выгруженных реквизитов (свойств). Идеально подходит для анализа выгруженных данных при переходе на ЗУП 3.1 или Бухгалтерия 3.0 с ранних версий.

1 стартмани

16.11.2017    10421    77    leosoft    4       

Механизмы и транспорт обмена данными. Пример создания в КД 2.1 правил обмена данными ЗУП 2.5 -> БП 3.0. Выгрузка ведомостей и банковских счетов. Передача параметров обмена из Источника в Приемник. ВыгрузитьПоПравилу(). ПередатьОдинПараметрВПриемник(). 37

Статья Программист Документ XML v8 ЗУП2.5 КД БП3.0 Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

В статье рассказываю: 1) о механизмах и транспорте обмена данными, где одной из сторон обмена выступает конфигурация на базе 1С, и о том, какой транспорт и в каких случаях лучше использовать 2) о решении задачи выгрузки данных документа «Зарплата к выплате организаций» (с выгрузкой банковский счетов физ лиц документа) из ЗУП 2.5.123.1 (далее Источник) в БП КОРП 3.0.52.39 (далее Приемник) путем создания правил обмена данными с использованием конфигурации «Конвертация данных» (далее просто КД) ред. 2.1.8.2. для (далее ЗкВО) 3) о тестирование полученных правил обмена данными.

1 стартмани

03.11.2017    20598    7    RailMen    5       

Перенос данных УПП/КА в ЕРП и КА2, что таит этот чудный процесс 20

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 КА1 УПП1 ERP2 КА2 Россия Абонемент ($m) Перенос данных из 1C8 в 1C8

По итогам нескольких переносов УПП/КА в ЕРП и КА появилась данная статья. Не так счастлив этот процесс и его результаты.

1 стартмани

20.09.2017    17745    56    Константин С.    16       

Синхронизация данных по правилам КД2.0 112

Инструменты и обработки Системный администратор Программист Бизнес-аналитик Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Новый инструмент для сравнения и загрузки данных, сочетающий в себе: гибкость запросов (используются для сопоставления объектов); наглядный вывод отличий; удобный отбор загружаемых данных; возможность пообъектной синхронизации двух баз по правилам КД2 с помощью вызова обработки "Универсальный обмен XML" в базе-источнике через COM-соединение.

1 стартмани

27.08.2017    16189    105    vikad    30       

Правила обмена ЗУП 3.1 - БП 2.0 и ЗУП 3.1 - УПП 1.3 (отражение, ведомости и справочники) 97

Инструменты и обработки Программист Документ XML v8 v8::БУ v8::СПР БП2.0 БП3.0 ЗУП3.x Россия БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Перенос данных из 1C8 в 1C8 Обмен через XML

Правила обмена для выгрузки документов "Отражение зарплаты в бухучете", "Ведомость в банк", "Ведомость в кассу", справочников "Сотрудники" и "Физические лица"

1 стартмани

01.08.2017    60185    1476    forseil    191       

Перенос справочников и документов из УТ 10.3 в БП 3.0 7

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 УТ10 БП3.0 Россия БУ НУ УУ Абонемент ($m) Перенос данных из 1C8 в 1C8

Синхронизация справочников и документов из Управление торговлей 10.3 в Бухгалтерию предприятия 3.0. Обработка не затрагивает штатный механизм. Подключение и перенос документов происходит посредством OLE. Без ввода начальных остатков.

10 стартмани

25.07.2017    14235    9    2casp    5       

«Горыныч - то НЕ НАСТОЯЩИЙ!» … или О Конвертации Данных ред.3 (КД 3) и обменах в универсальном формате Enterprise Data… доступным русско-народным языком 58

Инструменты и обработки Программист Архив с данными v8 КД Абонемент ($m) Внешние источники данных Обмен через XML Перенос данных из 1C8 в 1C8

Тем, кто хочет быстро разобраться с темой инструмента Конвертация данных 3.0 и технологией обмена по новому формату 1С, активно применяемому во всех новых конфигурациях от 1С на БСП, расширяющем возможности интеграции, пакет полезных материалов.

1 стартмани

13.06.2017    14060    135    Davlad_A    16       

Обмен данными между программами "1С: Бухгалтерия предприятия" редакция 2.0 и "1С: Зарплата и управление персоналом" редакция 3.1 20

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::БУ БП2.0 Россия БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Перенос данных из 1C8 в 1C8

В связи с отсутствием типовых правил обмена между конфигурациями БП 2.0 и ЗУП 3.1 (3.0) предлагается действующее решение в виде внешней обработки. Алгоритм построен на прямом подключении из базы БП к базе ЗУП. Для переноса данных используется COM-соединение с обработкой COM-объектов базы источника на стороне базы приемника.. Используется односторонний обмен - данные из ЗУП переносятся в БП.

1 стартмани

17.04.2017    20492    236    ivanovmi    36       

Правила обмена ЗУП 3.1(3.1.2.140) - УПП 1.3(1.3.88.2) - документа "Отражение зарплаты в регламентированном учете". Добавлено правило Отражения ERP20->БП30. ***Добавлено правило для ЗУП 3.1.5 и старше с использованием дополнительных реквизитов. 21

Инструменты и обработки Программист Архив с данными v8 УПП1 ЗУП3.x Россия БУ Зарплата Абонемент ($m) Перенос данных из 1C8 в 1C8

Правила обмена для производственных предприятий, где зарплата отдельной программой ЗУП 3.1 (для оперативного поддержания актуальности релиза), а управленческий и регламентированный учет ведется в УПП 1.3.

1 стартмани

24.03.2017    19349    213    bulas    44       

Соответствия объектов обмена 7

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 КА1 Россия Абонемент ($m) Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8

Обработка позволяет проверять, исправлять ошибки, добавлять и удалять соответствия объектов в обменах данными между конфигурациями на основе «Комплексной автоматизации 1.1» или похожими конфигурациям. Подходит для обменов с использованием регистра сведений «СоответствиеОбъектовДляОбмена».

2 стартмани

26.08.2016    14767    3    xxxelaaa    0       

Перенос объектов по OLE из идентичной конфигурации 27

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Перенос данных из 1C8 в 1C8

Перенос по OLE справочников, документов и пользователей из базы источника с идентичной конфигурацией без использования правил обмена, поиск по реквизитам, замена ГУИД, сохранение настроек в файл

1 стартмани

10.07.2016    11315    113    slava_1c    8       

Перенос данных из ЗУП 2.5 в ЗУП 3.1 45

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::СПР ЗУП2.5 ЗУП3.x БУ Windows Зарплата Управление персоналом (HRM) Абонемент ($m) Перенос данных из 1C8 в 1C8

Данная обработка предназначена для переноса некоторых данных из ЗУП 2.5 в ЗУП 3.1 через COM-соединения. Обработка была написана потому, что типовые правила переноса не предоставляют возможности переносить данные по отдельности, а некоторые данные не переносят вовсе. Тестировалась на версии 3.1.9.159 (8.3.12.1790).

1 стартмани

26.05.2016    31469    674    yojeeg    64       

Выгрузка/загрузка данных в формате JSON v 1.0.5 56

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8

Обработка предназначена для обмена данными между схожими конфигурациями в формате JSON. Этот формат обладает рядом существенных преимуществ по сравнению с xml и прочими популярными форматами. В отличие от существующих аналогов, обработка не использует никаких дополнительных библиотек. (де)Сериализация всех объектов происходит средствами встроенного языка и методов ЗаписатьJSON() и ПрочитатьJSON(). Работает на платформе версии не ниже 8.3.6.

3 стартмани

27.01.2016    35613    303    kser87    39       

[COM] Перенос данных через COMConnector 79

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Обработка обмена между двумя информационными базами схожей (не обязательно совпадающей) структуры. Изначально была заточена под бухгалтерию предприятия, сейчас используется для для обменов через COM любых конфигураций с режимом запуска "Управляемое приложение". Ближайший аналог - выгрузка-загрузка XML, но здесь нет промежуточных файлов выгрузки/загрузки, и обмен не прекращается в случае, когда состав реквизитов источника и приёмника различен!!! 27.09.2019 Версия 5.2.3.2 Исправлены исправленыц замеченные ошибки (версия от мая 19 года)

2 стартмани

23.11.2015    40506    595    Alex_E    167       

Интерфейс сопоставления объектов для обмена (для типового регистра СоответствиеОбъектовДляОбмена) 22

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 КА1 БП2.0 ЗУП2.5 УТ10 УПП1 Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки Перенос данных из 1C8 в 1C8

Вы внедряете обмен данными между двумя типовыми или основанными на типовых БД и вам необходим инструмент, чтобы сопоставить между собой справочники этих конфигураций? Вы хотите навести порядок в обмене данными, потому что вам надоело вылавливать дублирующиеся объекты? Вам очень хочется перепоручить сопоставление объектов обменивающихся баз пользователям, но нет подходящего и понятного пользователям интерфейса? Тогда вам нужна именно эта обработка!

4 стартмани

11.11.2015    29403    221    catsam    8       

Штатный перенос данных ЗУП 2.5 -> ЗУП 3.0 в режиме отладки 22

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 ЗУП2.5 ЗУП3.x Windows Зарплата Управление персоналом (HRM) Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

Штатный переход ЗУП 2.5 -> ЗУП 3.0 завершается при наличии ошибок в конвертации данных. Если механизм немного подправить, то можно обойти это ограничение. Назовем это режимом отладки. В итоге получим внешнюю обработку которая осуществит переход и просто сообщит о наличии ошибок конвертации данных.

1 стартмани

24.09.2015    18962    67    duhh    4       

Управление изменениями в планах обмена (Управляемое приложение) v 1.0 6

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Распределенная БД (УРИБ, УРБД) Внешние источники данных Перенос данных из 1C8 в 1C8

Простая в использовании и наглядная обработка для регистрации изменений или отмены регистрации в планах обмена используя гибкие возможности отбора СКД.

2 стартмани

15.08.2015    24451    46    kser87    3       

Перенос документов УТ 10.3 - УТ 11.1 19

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 УТ11 Россия УУ Windows Банковские операции Оптовая торговля Учет ТМЦ Абонемент ($m) Перенос данных из 1C8 в 1C8

Обработка переноса документов за любой период из УТ 10.3 (Управление торговлей 10.3) в УТ 11. Осуществляет перенос следующих документов: - Заказ покупателя - Поступление товаров и услуг - Реализация товаров и услуг - Перемещение товаров - Платежные поручения входящие - Платежные поручения исходящие - Отчеты о розничных продажах - Счета фактуры выданные - Счета фактуры полученные - Приходные кассовые ордера

5 стартмани

06.05.2015    32054    350    asdfgcom    68       

Перенос объектов 1С 255

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Простой и наглядный перенос объектов между любыми базами 1С 8 с предварительным анализом на возможные различия в данных (через файл, через интернет, через буфер обмена). Интерактивная настройка правил обмена на стороне источника и получателя. В обработке есть удобный обзор по подсистемам, поиск и обработка данных по заданному фильтру. Сравнение объектов, поиск ссылок. Конструктор кода по созданию объектов, написание скриптов и отладка мини-функций в УФ. Отключение/включение регламентных заданий. Регистрация/снятие с регистрации объектов в планах обмена. И многое другое.

1 стартмани

16.03.2015    77869    1980    moolex    189       

Правила переноса остатков и справочников из БП 2.0 в БП 3.0 21

Инструменты и обработки no Документ XML v8 БП2.0 БП3.0 Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Правила конвертации справочников и остатков по бух. счетам, между БП 2.0 и БП 3.0

3 стартмани

22.01.2015    23507    273    Alexez    31       

Перенос данных из Бухгалтерии 2.0 в Бухгалтерию 3.0 15

Инструменты и обработки Системный администратор Программист Документ XML v8 БП2.0 БП3.0 Россия БУ Windows Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

Перенос данных и остатков с Бухгалтерии 2.0 в Бухгалтерию 3.0 с помощью универсального обмена данными XML.

1 стартмани

30.12.2014    38655    308    sergeyzhuravlev    8       

Выгрузка данных из УТ 10.3 в БП 3.0 (своими руками) 34

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 УТ10 БП3.0 Россия Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Старая добрая, позабытая многими выгрузка из УТ 10.3 в БП 1.6. Ее еще можно оживить, и она послужит на благо всем желающим, всем уставшим от автоматических обменов.

3 стартмани

30.10.2014    33261    309    TESL    40       

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) 411

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Перенос данных из 1C8 в 1C8 Универсальные обработки Распределенная БД (УРИБ, УРБД)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    189781    4177    ekaruk    174       

Инструкция по интеграции «1С:Управление производственным предприятием» с «1С:Документооборот» 29

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 УПП1 ДО Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

В данной публикации описано как сделать, чтобы было возможным настроить интеграцию «1С:Управление производственным предприятием» и «1С:Документооборот»

1 стартмани

13.08.2014    36289    77    simich    18       

Контроль регистра сведений "Соответствие объектов информационных баз" 17

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Перенос данных из 1C8 в 1C8

Регистр сведений "Соответствие объектов информационных баз", в БСП. Анализ и очистка от неверных записей.

1 стартмани

01.08.2014    28704    208    Buхter    14