Проверка заполненности реквизитов через подписку на событие

Публикация № 204001

Разработка - Практика программирования

Подписка на событие Проверка реквизитов в документах

7
Навеяло от...http://infostart.ru/public/203664/ но с другого бока. Пришли пингвины, заявили... (а база перекурочена предшественниками как черепаха богом) хотим чтоб если есть в документе такой то реквизит, чтоб он всегда был заполнен... или же никогда там не выбирались группы и перечислили наименования справочников при ссылке на которые не должно быть пустот. И что? Я рыжий сидеть дня два прсматривать каждый из почти двух сотен доков? Потому и уродились три подписки на события. Описание в тексте Выбор групп проверяется на событие ПередЗаписью а проверка реквизитов на событии ОбработкаПроверкиЗаполнения
//{СИБ проверяется чтобы не были выбраны группы в реквизитах документа
//или в реквизитах таб частей документа для перечисленных в массиве справочников
Процедура кс_ПередЗаписьюДокументаПроверитьВыборГруппВРеквизитах(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
Если Источник.ОбменДанными.Загрузка Тогда
Возврат;
КонецЕсли;
//{ПроверитьВыборГруппВРеквизитах
Реквизиты = Источник.ЭтотОбъект.Метаданные().Реквизиты;
ТабличныеЧасти = Источник.ЭтотОбъект.Метаданные().ТабличныеЧасти;

Массив = Новый Массив;
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.СтатьиЗатрат"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.ПрочиеДоходыИРасходы"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.НоменклатурныеГруппы"));
Для каждого Реквизит Из Реквизиты Цикл

Для й=0 По Массив.Количество()-1 Цикл

Если Реквизит.Тип = Массив[й] Тогда
Если Источник[Реквизит.Имя].ЭтоГруппа Тогда
Сообщить("Реквизит документа """+Источник.ЭтотОбъект.Метаданные()+"."+Реквизит+"""
| Содержит группу, а не элемент справочника """+Массив[й]+""".", СтатусСообщения.Важное);
Отказ = Истина;
КонецЕсли;
КонецЕсли;


КонецЦикла;


КонецЦикла;

Для Каждого ТабличнаяЧасть Из ТабличныеЧасти Цикл

Для Каждого Реквизит Из ТабличнаяЧасть.Реквизиты Цикл
Для й=0 По Массив.Количество()-1 Цикл

Если Реквизит.Тип = Массив[й] Тогда
Для Каждого Стр Из Источник[ТабличнаяЧасть.Имя] Цикл
Если Стр[Реквизит.Имя].ЭтоГруппа Тогда
Сообщить("Реквизит табличной части """+ТабличнаяЧасть+""" документа """+Источник.ЭтотОбъект.Метаданные()+"."+Реквизит+"""
| в строке """+Стр.НомерСтроки+"""
| содержит группу, а не элемент справочника """+Массив[й]+".""", СтатусСообщения.Важное);
Отказ = Истина;
КонецЕсли;


КонецЦикла;


КонецЕсли;
КонецЦикла;

КонецЦикла;

КонецЦикла;
//Проверка групп}

КонецПроцедуры //СИБ}

//{СИБ - проверяется чтобы не были пустые реквизиты в шапке для перечисленных в массиве справочников
//
Процедура кс_ПроверитьНаЗаполненностьВыбранныеРеквизиты(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
//Процедура на тестировании заявителя
Если Источник.ОбменДанными.Загрузка Тогда
Возврат;
КонецЕсли;

Реквизиты = Источник.ЭтотОбъект.Метаданные().Реквизиты;

//{СИБ проверить ЗаполненностьРеквизитов
//1. Статьи ДДС
//2. Типы договоров
//3. Статьи затрат
//4. Номенклатурные группы
//5. Виды расчетов с сотрудниками

Массив = Новый Массив;
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.СтатьиДвиженияДенежныхСредств"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.КС_ТипыДоговоров"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.СтатьиЗатрат"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.НоменклатурныеГруппы"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.КС_ВидыРасчетовССотрудниками"));

Для каждого Реквизит Из Реквизиты Цикл

Для й=0 По Массив.Количество()-1 Цикл

Если Реквизит.Тип = Массив[й] Тогда
//Если Источник[Реквизит.Имя].Ссылка = Неопределено ИЛИ Источник[Реквизит.Имя].Ссылка = Источник[Реквизит.Имя].ПустаяСсылка Тогда
Если НЕ ЗначениеЗаполнено(Источник[Реквизит.Имя].Ссылка) Тогда
Сообщить("Реквизит документа """+Источник.ЭтотОбъект.Метаданные()+"."+Реквизит+"""
| НЕ ЗАПОЛНЕН! """+Массив[й]+".""", СтатусСообщения.Важное);
Отказ = Истина;
КонецЕсли;
КонецЕсли;
КонецЦикла;


КонецЦикла;

//СИБ}

КонецПроцедуры //СИБ}

//{СИБ - проверяется чтобы не были пустые реквизиты таб. частей документа для перечисленных в массиве справочников
//
Процедура кс_ПроверитьНаЗаполненностьВыбранныеРеквизитыВТабЧастях(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
Если Источник.ОбменДанными.Загрузка Тогда
Возврат;
КонецЕсли;

ТабличныеЧасти = Источник.ЭтотОбъект.Метаданные().ТабличныеЧасти;

//{СИБ проверить ЗаполненностьРеквизитов
//1. Статьи ДДС
//2. Типы договоров
//3. Статьи затрат
//4. Номенклатурные группы
//5. Виды расчетов с сотрудниками

Массив = Новый Массив;
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.СтатьиДвиженияДенежныхСредств"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.КС_ТипыДоговоров"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.СтатьиЗатрат"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.НоменклатурныеГруппы"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.КС_ВидыРасчетовССотрудниками"));

Для Каждого ТабличнаяЧасть Из ТабличныеЧасти Цикл
Для Каждого Реквизит Из ТабличнаяЧасть.Реквизиты Цикл
Для й=0 По Массив.Количество()-1 Цикл

Если Реквизит.Тип = Массив[й] Тогда
Для Каждого Стр Из Источник[ТабличнаяЧасть.Имя] Цикл
Если НЕ ЗначениеЗаполнено(Стр[Реквизит.Имя].Ссылка) Тогда
Сообщить("Реквизит табличной части"""+ТабличнаяЧасть+""" документа """+Источник.ЭтотОбъект.Метаданные()+"."+Реквизит+"""
| в строке """+Стр.НомерСтроки+"""
| НЕ ЗАПОЛНЕН """+Массив[й]+".""", СтатусСообщения.Важное);
Отказ = Истина;
КонецЕсли;
КонецЦикла;


КонецЕсли;
КонецЦикла;

КонецЦикла;

КонецЦикла;
//СИБ}

КонецПроцедуры
//СИБ}



//А МОЖНО УПРОСТИТЬ И УЛУЧШИТЬ ПРОВЕРКУ НА ЗАПОЛНЕННОСТЬ, ЕСЛИ ДЕЛАТЬ ЕЕ В ПРОВОДКАХ - коллеги посоветовали

//При проведении документа проверяем на заполненность обязательные реквизиты
//если в проводках не заполнено, то Отказ=Истина и запускаем проверку заполненности по шапке и по ТЧ (для вывода сообщению пользователю)
Процедура кс_ПроверитьНаЗаполненностьВыбранныеРеквизитыПриПроведении(Источник, Отказ, РежимПроведения) Экспорт
//Процедура на тестировании заявителя
Если Источник.ОбменДанными.Загрузка Тогда
Возврат;
КонецЕсли;

ПроводкиДок = Источник.ЭтотОбъект.Движения.Хозрасчетный;

//1. Статьи ДДС
//2. Типы договоров
//3. Статьи затрат
//4. Номенклатурные группы
//5. Виды расчетов с сотрудниками

Массив = Новый Массив;
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.СтатьиДвиженияДенежныхСредств"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.КС_ТипыДоговоров"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.СтатьиЗатрат"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.НоменклатурныеГруппы"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.КС_ВидыРасчетовССотрудниками"));

Для Каждого Проводка Из ПроводкиДок Цикл
Для й=0 По Массив.Количество()-1 Цикл
Для Каждого Субк Из Проводка.СубконтоДт Цикл
Если Субк.Ключ.ТипЗначения = Массив[й] Тогда
Если НЕ ЗначениеЗаполнено(Субк.Значение) Тогда
Отказ = Истина;
КонецЕсли;
КонецЕсли;
КонецЦикла;
Для Каждого Субк Из Проводка.СубконтоКт Цикл
Если Субк.Ключ.ТипЗначения = Массив[й] Тогда
Если НЕ ЗначениеЗаполнено(Субк.Значение) Тогда
Отказ = Истина;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЦикла;
КонецЦикла;

//Теперь, если мы обнаружили не заполненные реквизиты, проверяем документ
//единственное - эта проверка может быть избыточной
//(пр: документ "Поступление на р/с" реквизит "СтатьяДДС" есть и в шапке, и в ТЧ, но по факту заполняется только в одном месте)
Если Отказ = Истина Тогда

Реквизиты = Источник.ЭтотОбъект.Метаданные().Реквизиты;
ТабличныеЧасти = Источник.ЭтотОбъект.Метаданные().ТабличныеЧасти;

Для каждого Реквизит Из Реквизиты Цикл
Для й=0 По Массив.Количество()-1 Цикл
Если Реквизит.Тип = Массив[й] Тогда
//Если Источник[Реквизит.Имя].Ссылка = Неопределено ИЛИ Источник[Реквизит.Имя].Ссылка = Источник[Реквизит.Имя].ПустаяСсылка Тогда
Если НЕ ЗначениеЗаполнено(Источник[Реквизит.Имя].Ссылка) Тогда
Сообщить("Реквизит документа """+Источник.ЭтотОбъект.Метаданные()+"."+Реквизит+"""
| НЕ ЗАПОЛНЕН! """+Массив[й]+".""", СтатусСообщения.Важное);
Отказ = Истина;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЦикла;

Для Каждого ТабличнаяЧасть Из ТабличныеЧасти Цикл
Для Каждого Реквизит Из ТабличнаяЧасть.Реквизиты Цикл
Для й=0 По Массив.Количество()-1 Цикл
Если Реквизит.Тип = Массив[й] Тогда
Для Каждого Стр Из Источник[ТабличнаяЧасть.Имя] Цикл
Если НЕ ЗначениеЗаполнено(Стр[Реквизит.Имя].Ссылка) Тогда
Сообщить("Реквизит табличной части"""+ТабличнаяЧасть+""" документа """+Источник.ЭтотОбъект.Метаданные()+"."+Реквизит+"""
| в строке """+Стр.НомерСтроки+"""
| НЕ ЗАПОЛНЕН """+Массив[й]+".""", СтатусСообщения.Важное);
Отказ = Истина;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЦикла;
КонецЦикла;
КонецЦикла;

КонецЕсли; //Если Отказ = Истина

КонецПроцедуры

========================================================================================

//Текст процедуры для подписки при проведении Так будет более правильно делать методологически

Процедура кс_ПроверитьНаЗаполненностьВыбранныеРеквизитыПриПроведении(Источник, Отказ, РежимПроведения) Экспорт





Если Источник.ОбменДанными.Загрузка Тогда
Возврат;
КонецЕсли;

ПроводкиДок = Источник.ЭтотОбъект.Движения.Хозрасчетный;

// В целях контроля аналитического учета сделать обязательной к заполнению (во всех документах, где это применимо), следующую аналитику:
//1. Статьи ДДС
//2. Типы договоров
//3. Статьи затрат
//4. Номенклатурные группы
//5. Виды расчетов с сотрудниками

Массив = Новый Массив;
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.СтатьиДвиженияДенежныхСредств"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.ТипыДоговоров"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.СтатьиЗатрат"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.НоменклатурныеГруппы"));
Массив.Добавить(Новый ОписаниеТипов("СправочникСсылка.ВидыРасчетовССотрудниками"));

Для Каждого Проводка Из ПроводкиДок Цикл
Для й=0 По Массив.Количество()-1 Цикл
Для Каждого Субк Из Проводка.СчетДт.Ссылка.ВидыСубконто Цикл
Если Субк.ВидСубконто.ТипЗначения = Массив[й] Тогда
Если НЕ ЗначениеЗаполнено(Проводка.СубконтоДт[Субк.ВидСубконто]) Тогда
Сообщить("НЕ ЗАПОЛНЕНА аналитика по Дт """+Субк.ВидСубконто.ТипЗначения+""".", СтатусСообщения.Важное);
Отказ = Истина;
КонецЕсли;
КонецЕсли;
КонецЦикла;
Для Каждого Субк Из Проводка.СчетКт.Ссылка.ВидыСубконто Цикл
Если Субк.ВидСубконто.ТипЗначения = Массив[й] Тогда
Если НЕ ЗначениеЗаполнено(Проводка.СубконтоКт[Субк.ВидСубконто]) Тогда
Сообщить("НЕ ЗАПОЛНЕНО аналитика по Кт """+Субк.ВидСубконто.ТипЗначения+""".", СтатусСообщения.Важное);
Отказ = Истина;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЦикла;
КонецЦикла;

//Теперь, если мы обнаружили не заполненные реквизиты, проверяем документ
//единственное - эта проверка может быть избыточной
//(пр: документ "Поступление на р/с" реквизит "СтатьяДДС" есть и в шапке, и в ТЧ, но по факту заполняется только в одном месте)
Если Отказ = Истина Тогда

Реквизиты = Источник.ЭтотОбъект.Метаданные().Реквизиты;
ТабличныеЧасти = Источник.ЭтотОбъект.Метаданные().ТабличныеЧасти;

Для каждого Реквизит Из Реквизиты Цикл
Для й=0 По Массив.Количество()-1 Цикл
Если Реквизит.Тип = Массив[й] Тогда
//Если Источник[Реквизит.Имя].Ссылка = Неопределено ИЛИ Источник[Реквизит.Имя].Ссылка = Источник[Реквизит.Имя].ПустаяСсылка Тогда
Если НЕ ЗначениеЗаполнено(Источник[Реквизит.Имя].Ссылка) Тогда
Сообщить("Реквизит документа """+Источник.ЭтотОбъект.Метаданные()+"."+Реквизит+"""
| НЕ ЗАПОЛНЕН! """+Массив[й]+".""", СтатусСообщения.Важное);
Отказ = Истина;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЦикла;

Для Каждого ТабличнаяЧасть Из ТабличныеЧасти Цикл
Для Каждого Реквизит Из ТабличнаяЧасть.Реквизиты Цикл
Для й=0 По Массив.Количество()-1 Цикл
Если Реквизит.Тип = Массив[й] Тогда
Для Каждого Стр Из Источник[ТабличнаяЧасть.Имя] Цикл
Если НЕ ЗначениеЗаполнено(Стр[Реквизит.Имя].Ссылка) Тогда
Сообщить("Реквизит табличной части"""+ТабличнаяЧасть+""" документа """+Источник.ЭтотОбъект.Метаданные()+"."+Реквизит+"""
| в строке """+Стр.НомерСтроки+"""
| НЕ ЗАПОЛНЕН """+Массив[й]+".""", СтатусСообщения.Важное);
Отказ = Истина;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЦикла;
КонецЦикла;
КонецЦикла;

КонецЕсли; //Если Отказ = Истина

КонецПроцедуры

7

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Дата
1. ser6702 70 23.10.13 07:01 Сейчас в теме
Это дело можно улучшить и избежать некоторых проблем, если данную проверку засунуть в проверку движений - может вечером выложу новую подписку. И тогда вместо двух точно удобней обойтись одной подпиской при проверке реквизитов на заполненность
2. help1Ckr 23.10.13 11:09 Сейчас в теме
такой вариант не прокатит, если нужен реквизит, в зависимости от заполненности которого работает какой нибудь алгоритм. То есть пользователь создал документ, не записывая нажимает заполнить, а реквизит то не заполнен.
3. ser6702 70 25.10.13 09:15 Сейчас в теме
Такая задача и не ставилась - задача ставилась только с точки зрения заполненности важных субконто в проверках
4. mikhailovaew 126 05.12.13 16:38 Сейчас в теме
Текст кода в публикации неплохо бы раскрасить, будет читабельнее.
Gendalf_beliy; +1 Ответить
5. lesenoklenok 23 14.02.14 10:41 Сейчас в теме
Спасибо за информацию, но не читабельно вообще.
6. shoy 19 22.08.14 12:16 Сейчас в теме
Да уж! Трудно прочесть, и к тому же если хоть один раз Отказ = Истина, то стоит ли дальше проверять?
Оставьте свое сообщение

См. также

Полезные процедуры и функции для программиста 143

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования Универсальные функции

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    9563    HostHost    23       

Агрегатные функции СКД, о которых мало кто знает 343

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    13762    ids79    44       

Три костыля. Сказ про фокусы в коде 123

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    9515    YPermitin    68       

Отслеживание выполнения фонового задания 142

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    11049    ids79    16       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 256

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    15105    ids79    30       

Фоновое выполнение кода в 1С - это просто 120

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    11722    avalakh    21       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 133

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    13639    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 151

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    11923    ids79    27       

Регистры сведений. За кулисами 129

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    9302    YPermitin    12       

"Меньше копипаста!", или как Вася универсальную процедуру писал 183

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    8303    SeiOkami    49       

Создание отчетов с помощью СКД - основные понятия и элементы 210

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    21752    ids79    17       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 179

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    12954    dmurk    134       

Регистры накопления. Структура хранения в базе данных 176

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    19590    YPermitin    27       

Выполнение внешней обработки в фоновом задании 149

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    11660    Eret1k    23       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    6430    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    9076    m-rv    16       

О расширениях замолвите слово... 194

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    18105    ellavs    125       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 202

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    14236    ellavs    83       

Трюки с внешними источниками данных 166

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    14741    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 167

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    17829    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    14135    ids79    27       

Новый подход к обмену данными EnterpriseData 207

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    23584    ids79    72       

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации 119

Статья Программист Нет файла v8 v8::УФ БП3.0 УТ11 Россия Windows Бесплатно (free) Практика программирования Обмен через XML

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    20746    ids79    20       

Программное заполнение пользовательских параметров и отборов СКД 136

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    22698    Unk92    19       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 127

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    22583    ids79    40       

Вспомогательные инструкции в коде 1С 106

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    21742    tormozit    100       

Произвольный код в фоновом режиме 166

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    16041    nikita0832    42       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 147

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    23310    Rain88    42       

Повышаем эффективность разработки правил обмена 125

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    20515    olegtymko    47       

Введение в механизм представлений в ЗУП ред. 3 157

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    25920    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    22457    m-rv    21       

Строим графы средствами 1С (без GraphViz) 43

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    18223    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    12248    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 130

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    27016    avfed@rambler.ru    19       

Минимализмы 3 356

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    37502    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 109

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    26784    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    22177    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 738

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    143842    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    24037    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 67

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    22320    unichkin    18       

Разбираемся с настройками компоновки данных 161

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    25459    json    9       

Работа с Excel 299

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    27636    arakelyan    39