Кривенок Александра | Разработчик мобильных приложений | 1С-Рарус

«Монетизация. Как заставить приложение приносить прибыль раньше, чем вы потратите на него все деньги»

Кажется, что самое сложное в работе над тиражными приложениями - это этап разработки. Вроде бы "родили" конкурентоспособный продукт, и все , можно расслабиться, пить коктейли на пляже и ждать, пока пользователи выстроятся в очередь за подписками на ваше детище. Но нет...тут как раз и начинается все самое интересное. Оказалось, что так тщательно продуманная вами схема монетизации совсем не работает. Или работает, но далеко не так эффективно, как вы ожидали. Подписки не продаются, количество платников не растет, а график роста выручки похож на кардиограмму трупа. Жизнь - боль, а коктейли пьют ваши конкуренты. Так как же найти ее - оптимальную схему монетизации именно для вашего продукта? Как заставить приложение приносить деньги? За годы работы над Boss мы попробовали, наверное, все возможные варианты. Провели массу экспериментов. И кое-чему научились. - За что будем требовать деньги? Главные ошибки при выборе схемы монетизации. - Подписки vs покупки : кто круче? Основные плюсы и минусы обоих вариантов. - Триальный период. А надо ли? - Так за что же все таки готов платить ваш пользователь? Поиск оптимальной схемы. - Главное не спугнуть или как интерфейс влияет на рост продаж. Это и еще много чего интересного я расскажу в своем докладе. P.S. На основе реальных событий.

Подсистема настройки отображения штрих-кода

Программирование - Инструментарий

При работе сталкивался с задачей настройки отображения штрих-кодов в нескольких ситуациях, например, этикетках и ценниках, произвольных печатных формах клиентов для их поиска сканером. При этом необходимо учесть множество нюансов - размер, кодировка, макет. Например для кодирования договоров клиент очень не хотел цифры и тысячи раз просил "немного" подвинуть и поменять шрифт.

Для упрощения реализован справочник для настройки отображения штрих-кода и процедура получения изображения по настройке.

Далее этот шаблон можно использовать в обработке печати этикеток и ценников, для печати в любом вашем макете. Легко интеигрируется  и адаптируется под любые конфигурации.

Я всего лишь программист, поэтому поставляется "как есть" и способы использования и применение полностью на ваше усмотрение. Надеюсь, пригодится для основы.

 

UPD 2013/11/01

Версия для управляемых форм. Мелкие правки для удобства использования. Добавлен пример использования.

 

Как же все таки этим воспользоваться? Очень просто. Объедините три объекта приложенной конфигурации с вашей и в необходимых местах и печатных формах добавьте картинку. Код для вывода изображения штрих-кода картинки:

 

&НаСервере
Процедура УстановитьШтрихкод(Знач Штрихкод, Рисунок, ВнешняяКомпонента)

	Если НЕ ЗначениеЗаполнено(Штрихкод) Тогда 
		Возврат;
	КонецЕсли;	
	
	Справочники.ШаблоныШтрихкодов.УстановитьРисунокШтрихкода(Рисунок, Объект.ШаблонШтрихкода, ВнешняяКомпонента, Штрихкод);

КонецПроцедуры

&НаСервере
Процедура СформироватьСервер(ТабДок = Неопределено)
	
	Если ТабДок = Неопределено Тогда 
		ТабДок = Новый ТабличныйДокумент;
	КонецЕсли;	
....

// шаблон искать по наименованию или где-то хранить в разрезе ПФ
	Если ЗначениеЗаполнено(Объект.ШаблонШтрихкода)
Тогда 
		
		ВнешняяКомпонента = Неопределено;
		Для Каждого Рисунок Из ТабДок.Рисунки Цикл 
			Если Найти(Рисунок.Имя, "Штрихкод") > 0 Тогда 
				Штрихкод = ""; // его надо хранить для печатной формы
				УстановитьШтрихкод(Штрихкод, Рисунок, ВнешняяКомпонента);
			КонецЕсли;	
		КонецЦикла;
		
	КонецЕсли;


КонецПроцедуры// СформироватьРисунок()

 

Скачать файлы

Наименование Файл Версия Размер
НастройкаШтрихкода.cf
.cf 4,85Mb
14.11.17
8
.cf 4,85Mb 8 Скачать
Демо настройка ШК 0.2.dt
.dt 8,85Mb
14.11.17
8
.dt 8,85Mb 8 Скачать

См. также

Комментарии
Сортировка: Древо
1. seermak 658 31.10.13 12:40 Сейчас в теме
Уже рисунки за стартмани пошли? Круто....
2. fuxic 291 31.10.13 14:26 Сейчас в теме
3. Vyacheslav56 11 01.11.13 07:35 Сейчас в теме
Будет ли работать в УНФ?
4. kovaleks78 3 01.11.13 07:51 Сейчас в теме
(3) Vyacheslav56, без доработки, как я понимаю - не будет.
5. fuxic 291 05.11.13 10:40 Сейчас в теме
(3) Интегрируется с помощью программиста. Квалификация не играет большой роли, в публикации и демо-базе приведен пример и описание.

(4) Не будет. Но на основании этого можно встроить в систему механизм штрих-кодирования любых печатных форм в вашей учетной системе.
Оставьте свое сообщение