Организация контроля за кассирами на удаленных точках в управлении торговлей 8.1

Публикация № 21338

Разработка - Практика программирования

17
Вот решил поделиться своим опытом - может кому пригодится :)

Проблема стояла следующая:

Есть более десяти удаленных магазинов (распределенная Управление торговлей),

в каждом магазине есть ККМ, подключенная к базе. Иногда возникали сложности с тем, что не совпадали суммы по отчету о розничных продажах
и Z-отчету. Иногда умудрялись так пробить, что и не сообразишь сразу, что, да как Smile В связи с этим пришлось организовать небольшой контроль по кассе ККМ и вот что из этого получилось...

Картина: Кассир FULL CONTROL

Создаем регистр сведений (периодичность - секунда)
    Измерения:
            - КассаККМ (Справочник "Кассы ККМ");
    Ресурсы:
            - ТипСобытия (Перечисление "Типы событий ККМ");
            - Событие (Строка)

Состав регистра сведений

Не забываем включить данный регистр в план обмена РБД.

Перечисление "Типы событий ККМ" может принимать следующие значения:
    - Продажа;
    - Ошибка;
    - Z-отчет;
    - Z-отчет (ошибка);
    - X-отчет;
    - X-отчет (ошибка);
    - Возврат;

Вид перечисления

Немного правим пробитие чека ККМ

РасшифровкаОшибки = "";
// Запишем событие "Начало пробития чека"
ТипСобытия = ?(ВидОперации = Перечисления.ВидыОперацийЧекККМ.Продажа, Перечисления.АП_ТипыСобытийККМ.Продажа, Перечисления.АП_ТипыСобытийККМ.Возврат);
АП_Наработки.ЗаписатьСобытиеККМ(КассаККМ, Товары.Выгрузить(), "Начало пробития чека...", , ТипСобытия);
// Организуем задержку в одну секунду, на всякий случай
ТекВремя = ТекущаяДата();
Пока ТекВремя = ТекущаяДата() Цикл
        ОбработкаПрерыванияПользователя();   
    КонецЦикла;
    Если Не ПровестиИРаспечататьЧек(Ответ, Паника, ЭтаФорма, РасшифровкаОшибки) Тогда
        ОбщегоНазначения.СообщитьОбОшибке(Ответ);
        ТекстПаники = "Возможны расхождения ИБ и ленты ФР!";
        ТекстЗаголовка = "Внимание! Критическая ошибка!!!";
        Если Паника Тогда
            Предупреждение(ТекстПаники, , ТекстЗаголовка);
        КонецЕсли;
        Если ЗначениеЗаполнено(РасшифровкаОшибки) Тогда
            ТекстЗаголовка = ТекстЗаголовка + Символы.ПС + РасшифровкаОшибки;
        КонецЕсли;
        // Запишем событие ККМ
        ТекстСобытия = ОбщегоНазначения.СформироватьТекстСообщения(Ответ);
        АП_Наработки.ЗаписатьСобытиеККМ(КассаККМ, , ТекстСобытия, ТекстПаники + " " + ТекстЗаголовка, Перечисления.АП_ТипыСобытийККМ.Ошибка);               
    Иначе
        АП_Наработки.ЗаписатьСобытиеККМ(КассаККМ, , "Чек успешно пробит на ККМ" , , ТипСобытия);
    КонецЕсли;

 

Процедура ЗаписатьСобытиеККМ выглядит так:


Процедура ЗаписатьСобытиеККМ(КассаККМ, ТабличнаяЧасть = Неопределено, ТекстСобытия = Неопределено,
                            ДопТекстСобытия = Неопределено, ТипСобытия) Экспорт
   
    Если ЗначениеЗаполнено(ТекстСобытия) Тогда
        Событие = ТекстСобытия;
        Если ЗначениеЗаполнено(ДопТекстСобытия) Тогда
            Событие = Событие + Символы.ПС + ДопТекстСобытия;   
        КонецЕсли;
        Если ТабличнаяЧасть <> Неопределено Тогда
            // Добавим к тексту ошибки то, что было в чеке, когда она произошла
            Событие = Событие Символы.ПС + СформироватьТекстСобытияПоТЧ(ТабличнаяЧасть);
        КонецЕсли;
    Иначе   
        // Регистрируем продажу
        Событие = СформироватьТекстСобытияПоТЧ(ТабличнаяЧасть);
    КонецЕсли;
    // Записываем в регистр

    ЗаписьСобытия = РегистрыСведений.АП_СобытияККМ.СоздатьМенеджерЗаписи();
    ЗаписьСобытия.КассаККМ = КассаККМ;
    ЗаписьСобытия.Период = ТекущаяДата();
    ЗаписьСобытия.ТипСобытия = ТипСобытия;
    ЗаписьСобытия.Событие = Событие;
    ЗаписьСобытия.Записать(Истина);
   
КонецПроцедуры

Функция СформироватьТекстСобытияПоТЧ(ТабличнаяЧасть)
   
    Событие = "Сумма по чеку: " + Строка(ТабличнаяЧасть.Итог("Сумма"));
    Событие = Событие + Символы.ПС + "Список товаров:";
    Для Каждого Обход Из ТабличнаяЧасть Цикл
        // Номер строки
        Событие = Событие + Символы.ПС + "Строка " + Обход.НомерСтроки + ": ";
        // Наименование
        Событие = Событие + Обход.Номенклатура.Артикул + " " + Обход.Номенклатура.Наименование + " ";
        // Количество
        Событие = Событие + "Количество:" + Обход.Количество + " ";
        // Единица измерения
        Событие = Событие + Обход.ЕдиницаИзмерения.Наименование + " ";
        // Цена
        Событие = Событие + "Цена:" + Обход.Цена + " ";
        // Сумма
        Событие = Событие + "Сумма:" + Обход.Сумма + " ";
        // Скидки
        Событие = Событие + Обход.ПроцентАвтоматическихСкидок + " ";
        Событие = Событие + Обход.ПроцентСкидкиНаценки;
    КонецЦикла;
   
    Возврат Событие;
   
КонецФункции

Теперь в обработку закрытия смены добавляем вызов регистрации

Результат = ПолучитьСерверТО().ОтчетСГашением(ФР, Пароль);
    Если ЗначениеЗаполнено(Результат) Тогда
    ТекстОшибки = ПолучитьСерверТО().ПолучитьТекстОшибкиФРТО(Результат);
    Сообщить(ТекстОшибки, СтатусСообщения.Важное);
    // Вставка -(
    АП_Наработки.ЗаписатьСобытиеККМ(КассаККМ, , ТекстОшибки, , , Перечисления.АП_ТипыСобытийККМ.ZОтчетОшибка);


В обработку обслуживания ККМ (у нас во всех магазинах стоят Меркурии) добавляем следующее

Перем СписокСчетчиков;
Перем ЗначенияСчетчиков;

Процедура ЗаполнитьЗначениеСчетчика(Значение, НомерСчетчика)
   
    Если НомерСчетчика = 0 Тогда
        ЗначенияСчетчиков.СуммаПродаж = Значение;
    ИначеЕсли НомерСчетчика = 4 Тогда
        ЗначенияСчетчиков.СуммаСкидок = Значение;
    ИначеЕсли НомерСчетчика = 9 Тогда
        ЗначенияСчетчиков.СуммаВнесений = Значение;
    ИначеЕсли НомерСчетчика = 10 Тогда
        ЗначенияСчетчиков.СуммаИзъятий = Значение;
    ИначеЕсли НомерСчетчика = 11 Тогда
        ЗначенияСчетчиков.СуммаНаличных = Значение;
    ИначеЕсли НомерСчетчика = 12 Тогда
        ЗначенияСчетчиков.НарастающийИтог = Значение;
    ИначеЕсли НомерСчетчика = 36 Тогда
        ЗначенияСчетчиков.СуммаВозвратов = Значение;
    КонецЕсли;
   
КонецПроцедуры

ЗначенияСчетчиков = Новый Структура();
ЗначенияСчетчиков.Вставить("СуммаПродаж", 0);
ЗначенияСчетчиков.Вставить("СуммаСкидок", 0);
ЗначенияСчетчиков.Вставить("СуммаВнесений", 0);
ЗначенияСчетчиков.Вставить("СуммаИзъятий", 0);
ЗначенияСчетчиков.Вставить("СуммаНаличных", 0);
ЗначенияСчетчиков.Вставить("НарастающийИтог", 0);
ЗначенияСчетчиков.Вставить("СуммаВозвратов", 0);


Правим функцию Z-отчет

Функция ZОтчет(Объект, Пароль, НомерЧека, НомерСмены) Экспорт
   
    Результат = мНетОшибки;

    // Печать Z-отчета
    Попытка
        // Без открытия смены (регистрации кассира) ФР не печатает отчеты
        ОткрытьСмену(Объект, "");
        // Печатаем краткий Z-отчет. Нулевые значения счетчиков не печатаются.
        // Объект.Драйвер.ZОтчет(1);
        // Получим значения со счетчиков ККМ

        Для Каждого Обход Из СписокСчетчиков Цикл
            НомерСчетчика = Обход.Значение;
            ЗаполнитьЗначениеСчетчика(Объект.Драйвер.ЗапроситьСчетчик(НомерСчетчика,0), НомерСчетчика);
        КонецЦикла;
        НомерОтчета = Объект.Драйвер.ZОтчет(1);
        АП_Наработки.ЗаписатьСобытиеККМОтчет(ЗначенияСчетчиков, НомерОтчета, Перечисления.АП_ТипыСобытийККМ.ZОтчет);
    Исключение
        // Получение текстового описания ошибки
        ПолучитьТекстОшибки(Объект);
        Результат = мОшибкаНеизвестно;
    КонецПопытки;

    Возврат Результат;

КонецФункции

Тоже самое делаем и с X-отчет.
Модели кассовых машин, конечно, могут быть разные, поэтому тут нужен индивидуальный подход.

Осталось написать только еще одну процедуру, которая сохранить данные об отчетах ККМ. Выглядеть она может примерно так


Процедура ЗаписатьСобытиеККМОтчет(ЗначениеСчетчиков, НомерОтчета, ТипОтчета) Экспорт
   
    Форм = "ЧЦ=15; ЧДЦ=2; ЧН=-";
   
    СуммаПродаж        = Формат(ЗначениеСчетчиков.СуммаПродаж        , Форм);
    СуммаВнесений    = Формат(ЗначениеСчетчиков.СуммаВнесений    , Форм);
    СуммаИзъятий    = Формат(ЗначениеСчетчиков.СуммаИзъятий        , Форм);
    СуммаСкидок        = Формат(ЗначениеСчетчиков.СуммаСкидок        , Форм);
    СуммаВозвратов    = Формат(ЗначениеСчетчиков.СуммаВозвратов    , Форм);
    СуммаНаличных    = Формат(ЗначениеСчетчиков.СуммаНаличных    , Форм);
    НарастающийИтог    = Формат(ЗначениеСчетчиков.НарастающийИтог    , Форм);
   
    // Получим представление отчета
    ТекстОтчета = "     " + ?(ТипОтчета = Перечисления.АП_ТипыСобытийККМ.XОтчет, "X-ОТЧЕТ СВОДНЫЙ ", "Z-ОТЧЕТ ") + " " + НомерОтчета;
    ТекстОтчета = ТекстОтчета + Символы.ПС + "ПРОДАЖИ                        " + СуммаПродаж;
    ТекстОтчета = ТекстОтчета + ?(ЗначениеСчетчиков.СуммаВозвратов <> 0, Символы.ПС + "ВОЗВРАТЫ                        " + СуммаВозвратов, "");
    ТекстОтчета = ТекстОтчета + ?(ЗначениеСчетчиков.СуммаСкидок <> 0, Символы.ПС + "СКИДКИ                            " + СуммаСкидок, "");
    ТекстОтчета = ТекстОтчета + ?(ЗначениеСчетчиков.СуммаВнесений <> 0, Символы.ПС + "ВНЕСЕНИЕ НАЛИЧНЫХ        " + СуммаВнесений, "");
    ТекстОтчета = ТекстОтчета + ?(ЗначениеСчетчиков.СуммаИзъятий <> 0, Символы.ПС + "ИЗЪЯТИЕ НАЛИЧНЫХ        " + СуммаИзъятий, "");   
    ТекстОтчета = ТекстОтчета + Символы.ПС + "CУММА НАЛИЧНЫХ            " + СуммаНаличных;
    ТекстОтчета = ТекстОтчета + Символы.ПС + Символы.ПС + "НАРАСТАЮЩИЙ ИТОГ        " + НарастающийИтог;
       
    // Кассу ККМ возьмем из настроек пользователя
    КассаККМ = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "ОсновнаяКассаККМ");
    ЗаписатьСобытиеККМ(КассаККМ, , ТекстОтчета, ,ТипОтчета);

КонецПроцедуры

Ну и для разнообразия подкрасим строки при выводе в списке нашего регистра сведений

Если ДанныеСтроки.ТипСобытия = Перечисления.АП_ТипыСобытийККМ.Ошибка Или ДанныеСтроки.ТипСобытия = Перечисления.АП_ТипыСобытийККМ.ZОтчетОшибка Тогда
            ОформлениеСтроки.ЦветФона = Новый Цвет(225, 165, 165);   
        ИначеЕсли ДанныеСтроки.ТипСобытия = Перечисления.АП_ТипыСобытийККМ.Возврат Тогда
            ОформлениеСтроки.ЦветФона = Новый Цвет(175, 255, 175);   
        ИначеЕсли ДанныеСтроки.ТипСобытия = Перечисления.АП_ТипыСобытийККМ.XОтчетОшибка Тогда
            ОформлениеСтроки.ЦветФона = Новый Цвет(225, 195, 195);   
        ИначеЕсли ДанныеСтроки.ТипСобытия = Перечисления.АП_ТипыСобытийККМ.ZОтчет Тогда
            ОформлениеСтроки.ЦветФона = Новый Цвет(205, 255, 255);   
        ИначеЕсли ДанныеСтроки.ТипСобытия = Перечисления.АП_ТипыСобытийККМ.XОтчет Тогда
            ОформлениеСтроки.ЦветФона = Новый Цвет(240, 255, 255);   
        КонецЕсли;



В итоге мы получаем полную, ну или практически полную, картину того, что творят наши кассиры.
Осталось только сидеть и наслаждаться жизнью Smile

Запись о начале пробития чека ККМ

Расшифровка Z-отчета

Список событий ККМ

Очень надеюсь, что хоть кому-нибудь моя статья поможет Smile

http://shkuraev.ru

17

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. AleksGlbux 24.07.09 07:17 Сейчас в теме
2. salexdv 24.07.09 07:22 Сейчас в теме
3. PowerBoy 2921 24.07.09 08:13 Сейчас в теме
8. salexdv 28.07.09 20:53 Сейчас в теме
Спасибо! Жизнь заставляет :)
9. Serg O. 178 03.12.09 14:05 Сейчас в теме
Классная статья...
предлагаю добавить еще одно измерение в регистр - Кассир (тип Справочники.Пользователи),

тогда по этим данных будет легко построить отчеты "Продажи кассиров", "Действия кассира" и т.п. с отборами по Кассе и Кассиру...
и за любой период.

так как на одной кассе может работать (в разные дни или в один день!) несколько кассиров (продавцов).
10. salexdv 03.12.09 17:49 Сейчас в теме
(9) Все в твоих руках :) У меня просто много-много точек, а кассир на каждой только один
11. MYRZILKA123 2 14.11.11 11:22 Сейчас в теме
прикольно буду пробывать )))
Оставьте свое сообщение

См. также

Полезные процедуры и функции для программиста 143

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования Универсальные функции

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    9573    HostHost    23       

Агрегатные функции СКД, о которых мало кто знает 343

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    13781    ids79    44       

Три костыля. Сказ про фокусы в коде 123

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    9520    YPermitin    68       

Отслеживание выполнения фонового задания 142

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    11059    ids79    16       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 256

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    15136    ids79    30       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 133

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    13683    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 151

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    11937    ids79    27       

Регистры сведений. За кулисами 129

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    9316    YPermitin    12       

"Меньше копипаста!", или как Вася универсальную процедуру писал 183

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    8316    SeiOkami    49       

Создание отчетов с помощью СКД - основные понятия и элементы 210

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    21769    ids79    17       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 179

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    12962    dmurk    134       

Регистры накопления. Структура хранения в базе данных 176

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    19609    YPermitin    27       

Выполнение внешней обработки в фоновом задании 149

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    11672    Eret1k    23       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    6442    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    9087    m-rv    16       

О расширениях замолвите слово... 194

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    18110    ellavs    125       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 202

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    14244    ellavs    83       

Трюки с внешними источниками данных 166

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    14749    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 167

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    17840    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    14143    ids79    27       

Новый подход к обмену данными EnterpriseData 207

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    23591    ids79    72       

Программное заполнение пользовательских параметров и отборов СКД 136

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    22721    Unk92    19       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 127

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    22593    ids79    40       

Вспомогательные инструкции в коде 1С 106

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    21749    tormozit    100       

Произвольный код в фоновом режиме 166

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    16048    nikita0832    42       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 147

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    23317    Rain88    42       

Повышаем эффективность разработки правил обмена 125

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    20523    olegtymko    47       

Введение в механизм представлений в ЗУП ред. 3 157

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    25928    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    22462    m-rv    21       

Строим графы средствами 1С (без GraphViz) 43

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    18227    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    12254    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 130

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    27031    avfed@rambler.ru    19       

Минимализмы 3 356

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    37508    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 109

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    26789    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    22181    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 738

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    143868    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    24042    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 67

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    22332    unichkin    18       

Разбираемся с настройками компоновки данных 161

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    25467    json    9       

Работа с Excel 299

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    27647    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 145

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    49361    bugtester    44       

Отказ от работы с временными файлами при работе с двоичными данными или Потоки как простая замена ADODB.Stream и временным файлам 128

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

В платформе начиная с версии 3.8.9 (как я понял по документации) появился расширенный функционал средств работы с двоичными данными. Если раньше простой и очевидный способ преобразования данных строился на использовании временных файлов, то теперь благодаря новым средствам можно уйти от их использования.

12.09.2017    19204    vardeg    31       

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере 128

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    35379    tormozit    72       

Ускоряем 1С: модули с повторным использованием возвращаемых значений 137

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    44613    m-rv    60