IE2017

Материальный отчет

Отчеты - Бухгалтерские

Материальный отчет и реестр материалов по счету: 10-"Материалы"

Материальный отчет и реестр материалов по счету: 10-"Материалы" с отбором по складу.

Для Конфигурации: Бухгалтерия Предприятия (ред. 3.0)

Скачать файлы

Наименование Файл Версия Размер
МатОтчет.erf
.erf 23,13Kb
31.01.17
80
.erf 23,13Kb 80 Скачать

См. также

Комментарии
1. anry mc (AnryMc) 714 12.02.14 18:05 Сейчас в теме
Я понимаю: "Краткость - сестра таланта..,", но не до такой же степени...

Хоть напишите (если не указываете конфигурацию) - как называется план счетов из которого беруться данные (в разных конфигурациях - могут отличаться, например, для хозрасчетных и бюджетных)...
2. Елена Миловицкая (milka12371) 19.02.14 21:11 Сейчас в теме
Добрый вечер! Подскажите пожалуйста, как настроить страничку на печать с закладкой "материалы"? Шапка на одной странице а весь отчет на других. Через Таблицу-настройка печати- неактивно.
3. Василий Майоров (WasiliyMay) 8 19.02.14 22:19 Сейчас в теме
(2) milka12371, Необходимо в модуле объекта, в процедуре "СформироватьОтчет" Заменить:
		ОбластьМакета = Макет.ПолучитьОбласть("Строка");
		ОбластьМакетаСчет = Макет.ПолучитьОбласть("Счет");
		ОбластьМакетаШапка = Макет.ПолучитьОбласть("Шапка");
		ВыборкаДетальныеЗаписи = Результат.Выбрать();
		ПредСчет = "";
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
			Если ПредСчет<>ВыборкаДетальныеЗаписи.Счет Тогда
				ОбластьМакетаСчет.Параметры.Счет = ВыборкаДетальныеЗаписи.Счет.Код+": "+ВыборкаДетальныеЗаписи.Счет.Наименование;	
				ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
				ТабличныйДокумент.Вывести(ОбластьМакетаШапка);
				ТабличныйДокумент.Вывести(ОбластьМакетаСчет);						
			КонецЕсли;
...Показать Скрыть


на:

		ОбластьМакета = Макет.ПолучитьОбласть("Строка");
		ОбластьМакетаСчет = Макет.ПолучитьОбласть("Счет");
		ОбластьМакетаШапка = Макет.ПолучитьОбласть("Шапка");
		ТабличныйДокумент.Вывести(ОбластьМакетаШапка);		
		ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();		
		ВыборкаДетальныеЗаписи = Результат.Выбрать();
		ПредСчет = "";
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
			Если ПредСчет<>ВыборкаДетальныеЗаписи.Счет Тогда
				ОбластьМакетаСчет.Параметры.Счет = ВыборкаДетальныеЗаписи.Счет.Код+": "+ВыборкаДетальныеЗаписи.Счет.Наименование;	
				ТабличныйДокумент.Вывести(ОбластьМакетаСчет);						
			КонецЕсли;
...Показать Скрыть
4. Елена Миловицкая (milka12371) 20.02.14 00:53 Сейчас в теме
&НаКлиенте
Процедура СформироватьОтчет(Команда)
	
	ОчиститьСообщения();
	
	ОтключитьОбработчикОжидания("Подключаемый_ПроверитьВыполнениеЗадания");
	
	РезультатВыполнения = СформироватьОтчетНаСервере();
	Если Не РезультатВыполнения.ЗаданиеВыполнено Тогда
		ДлительныеОперацииКлиент.ИнициализироватьПараметрыОбработчикаОжидания(ПараметрыОбработчикаОжидания);
		ПодключитьОбработчикОжидания("Подключаемый_ПроверитьВыполнениеЗадания", 1, Истина);
		ОбщегоНазначенияКлиентСервер.УстановитьСостояниеПоляТабличногоДокумента(Элементы.Результат, "ФормированиеОтчета");
	КонецЕсли;

КонецПроцедуры
...Показать Скрыть
5. Елена Миловицкая (milka12371) 20.02.14 00:54 Сейчас в теме
Вот что у меня, может не там ищу(((
6. Василий Майоров (WasiliyMay) 8 20.02.14 10:49 Сейчас в теме
(5) milka12371, Вы точно смотрите в модуле объекта?
7. Sergei (kauksi) 195 08.04.14 23:51 Сейчас в теме
отчет классный по своей задумке, нету Итого по материалам

и с какой радости отбор Членов комиссии установлен в ДоступныНеПринятые(Истина)
у меня кадровый учет ведется в другой базе... может не надо было...
8. Василий Майоров (WasiliyMay) 8 11.04.14 14:05 Сейчас в теме
(7) kauksi,Без этой настройки программа позволяла выбирать только принятых на работу сотрудников
9. Константин Марков (markovki) 17 15.08.14 16:09 Сейчас в теме
К сожалению не формирует табличную часть, только шапка и подвал, да и не печатает - "Ошибка печати".
Использую БП 3.0.34.17, платформа 8.3.4.482
10. Василий Майоров (WasiliyMay) 8 18.08.14 16:55 Сейчас в теме
(9) markovki, Проверил на типовой конфигурации (Бухгалтерия предприятия, редакция 3.0 (3.0.34.18)). Все работает нормарьно
11. Вал Егоров (egvv) 15 13.01.17 13:41 Сейчас в теме
БП 3,0 релиз 3,0,44,200 - Метод объекта не обнаружен (ПереключитьТекущуюСтраницуВыбораПериода)
12. Василий Майоров (WasiliyMay) 8 31.01.17 14:10 Сейчас в теме
(11) Спасибо за сообщение. Отчет поправил
Оставьте свое сообщение