Отключение интернет-поддержки пользователей БП 3.0 / ЗУП 3.1 / УТ 11.3 / КА 2.2 / ERP 2.2...

Администрирование - Системное

Позволяет отключить в настройках всех пользователей вывод окошка интернет-поддержки пользователей для БП 3.0 / ЗУП 3.1 / УТ 11.3 / КА 2.2 / ERP 2.2... и других конфигураций на базе БСП.

Собственно, ничего особенно. Обычная обработка, которую можно зарегистрировать в составе внешних обработок или открывать через главное меню тонкого/толстого клиента.

Она просто прописывает каждому пользователю настройку, которую тот по сути может сделать сам, но это еще попасть в нужную галочку нужно, а тут всем юзерам за один пресест отрубается и прощай.

Реализует следующий алгоритм.

&НаКлиенте
Процедура ОтключитьИнтернетПоддержкуУВсехПользователей(Команда)
	ОтключитьИнтернетПоддержкуУВсехПользователейНаСервере();
КонецПроцедуры

&НаСервере
Процедура ОтключитьИнтернетПоддержкуУВсехПользователейНаСервере()
	
	Перем Пользователи;
	
    Пользователи = ПользователиИнформационнойБазы.ПолучитьПользователей();
    Для Каждого Пользователь Из Пользователи Цикл
        ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Ложь, , Пользователь.Имя);
        Сообщить("Для пользователя " + Пользователь.Имя + " интернет-поддержка отключена");
	КонецЦикла;
	
КонецПроцедуры

UPD 20/04/2014

Сильно переработал функционал обработки, пока нечем было заняться, да и моск тренировать нужно.

UPD 25/10/2016

Скачивания обработки идут, сам шибко не пользуюсь ею, решил проверить, работает ли она еще на современных конфигурациях.

Все работает. Проверено с парой конфигураций на базе БСП 2.3.4 так что смело могу утверждать, что обработка пригодна не только для БП 3.0

Скачать файлы

Наименование Файл Версия Размер
ОтключениеВключениеИнтернетПоддержкиПользователей_БП30_УФ.epf
.epf 12,42Kb
25.10.16
441
.epf 12,42Kb 441 Скачать

См. также

Комментарии
1. Андрей Долгополов (bankir1982) 10 10.04.14 17:03 Сейчас в теме
спасибо большое, а то бесит это подвисание в бухгалтерии при открытии. В 2.0 пользовался аналогичной обработкой.
Зачем ее только вообще прикрутили автостартом?
2. Игорь Фелькер (Brawler) 324 10.04.14 19:16 Сейчас в теме
(1) bankir1982, не спорю! они видно не допирают, что у людей могут быть проблемы с тем же инетом, а тогда запуск программы вообще затягивается, так как идет обращение к внешке...
3. mikle vedekhin (MikleVV) 17.04.14 16:12 Сейчас в теме
Спасибо за обработку.

Не подскажите, а где-нибудь в меню это возможно отключить?
4. Игорь Фелькер (Brawler) 324 17.04.14 19:21 Сейчас в теме
(3) MikleVV, точно помню что видел галочку отключения, но забыл где.

Поискал, нашел. Для отдельно взятого пользователя можно отключить сие чудо только, если в момент запуска этого чуда у вас не будет доступа к интернету у базы данных/сервера. Тогда появится окно ИнтернетПоддержкаПользователейОшибкаДоступаКИнтернету, в котором нужно снять галочку ЗапускатьПриСтарте.

Такие дела, так что проще всего обработкой отрубить для всех юзеров в одно нажатие.

А можно и просто для одного текущего юзера выполнить.

ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Ложь);
5. mikle vedekhin (MikleVV) 23.04.14 16:41 Сейчас в теме
Да, Вы правы. Обработкой проще.

Спасибо!
6. Станислав (audion) 29.04.14 12:25 Сейчас в теме
Большое спасибо! Отличная обработка!
7. Vladimir Grigoryev (vggrigoryev) 11.05.14 12:28 Сейчас в теме
Данная обработка удобна, тем кто работает в сервисе и обновление конфигураций, не входит в пакет клиентского обслуживания.
Меня она очень выручила, это снизило даже нагрузку при запуске конфигураций в частном облаке.
Спасибо большое.
8. Константин Купрюхин (BlackStar) 27.06.14 13:29 Сейчас в теме
Удобно! Было бы здорово добавить отключение рекламы тоже. Это все есть в отдельных обработках, но хорошо иметь все в одном месте, эдакий центр управления навязчивыми сообщениями
9. Александр Турчанинов (Santilla) 5 24.04.15 20:44 Сейчас в теме
Супер! Отличная и очень полезная обработка. Огромное Вам спасибо!
10. Сергей Самсонов (user643908_0445353) 23.11.16 11:44 Сейчас в теме
Добрый день! Данная обработка не работает!!! Версия программы Бухгалтерия предприятия, редакция 3.0 (3.0.44.199)
Хочу знать почему??
11. Игорь Фелькер (Brawler) 324 23.11.16 12:26 Сейчас в теме
(10) user643908_0445353, вечером постараюсь глянуть. Неплохо бы получить описание того, что у вас происходит.
12. Сергей Самсонов (user643908_0445353) 23.11.16 15:17 Сейчас в теме
(11) Brawler, Да все как обычно сделал! Загрузил обработку -выполнить-отключить тех поддержку для всех пользователей!
больше ничего не делал!!
13. Елена _ (citicat) 116 23.11.16 15:33 Сейчас в теме
14. Игорь Фелькер (Brawler) 324 23.11.16 16:56 Сейчас в теме
(12) user643908_0445353, ошибка выдается какая нить?
15. Игорь Фелькер (Brawler) 324 23.11.16 16:57 Сейчас в теме
16. Игорь Фелькер (Brawler) 324 23.11.16 20:51 Сейчас в теме
Для более корректного поведения обработки в модуле формы нужно изменить код

&НаСервере
Процедура ПоказатьТекущееСостояниеИнтернетПоддержкиНаСервере(ДляВсехПользователей)
	
	Перем Пользователи;
	
	Если ДляВсехПользователей Тогда
		Пользователи = ПользователиИнформационнойБазы.ПолучитьПользователей();
		Сообщить("Состояние интернет поддержки у пользователей:");
		Для Каждого Пользователь Из Пользователи Цикл
			ЗапускатьПриСтарте = ХранилищеОбщихНастроек.Загрузить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", , Пользователь.Имя);
			Сообщить(Символы.Таб + ?(ЗапускатьПриСтарте = Истина, "Включена", "Выключена") + " - " + Пользователь);
		КонецЦикла;
	Иначе
		ЗапускатьПриСтарте = ХранилищеОбщихНастроек.Загрузить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы");
		Сообщить("Состояние интернет поддержки у текущего пользователя: " + ?(ЗапускатьПриСтарте = Истина, "включена", "отключена"));
	КонецЕсли;
	
КонецПроцедуры
...Показать Скрыть


на этот

&НаСервере
Процедура ПоказатьТекущееСостояниеИнтернетПоддержкиНаСервере(ДляВсехПользователей)
	
	Перем Пользователи;
	
	Если ДляВсехПользователей Тогда
		Пользователи = ПользователиИнформационнойБазы.ПолучитьПользователей();
		Сообщить("Состояние интернет поддержки у пользователей:");
		Для Каждого Пользователь Из Пользователи Цикл
			ЗапускатьПриСтарте = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Истина,, Пользователь.Имя) = Истина;
			Сообщить(Символы.Таб + ?(ЗапускатьПриСтарте = Истина, "Включена", "Выключена") + " - " + Пользователь);
		КонецЦикла;
	Иначе
		ЗапускатьПриСтарте = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Истина) = Истина;
		Сообщить("Состояние интернет поддержки у текущего пользователя: " + ?(ЗапускатьПриСтарте = Истина, "включена", "отключена"));
	КонецЕсли;
	
КонецПроцедуры
...Показать Скрыть


И этот код

&НаСервере
Процедура КомандаОбновитьСписокПользователейНаСервере()
	
	Перем Пользователи;
	
	Объект.ИнтернетПоддержкаПоПользователям.Очистить();
	
	Пользователи = ПользователиИнформационнойБазы.ПолучитьПользователей();
	Для Каждого Пользователь Из Пользователи Цикл
		НоваяСтрока = Объект.ИнтернетПоддержкаПоПользователям.Добавить();
		НоваяСтрока.Пользователь = Пользователь;
		НоваяСтрока.УникальныйИдентификатор = Пользователь.УникальныйИдентификатор;
		НоваяСтрока.ЗапускатьПриСтарте = ХранилищеОбщихНастроек.Загрузить(
			"ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", , Пользователь.Имя);
		НоваяСтрока.СтароеЗначениеЗапускатьПриСтарте = НоваяСтрока.ЗапускатьПриСтарте;
	КонецЦикла;
	
КонецПроцедуры
...Показать Скрыть


на



Суть в том, что при первом запуске конфигурации у нее нет сохраненной настройки "ВсегдаПоказыватьПриСтартеПрограммы", и в этом случае программа трактует ее как Истина (Возможно это стало так с некоторых версий БСП.).
Обработка ранее в этом случае считала это значение равным Ложь и вводила в заблуждение в Расширенном режиме.
17. Игорь Фелькер (Brawler) 324 23.11.16 20:56 Сейчас в теме
чет сайт глюкует, не могу исправить раннее сообщение.
второй кусок кода нужно заменить на

Код
&НаСервере
Процедура КомандаОбновитьСписокПользователейНаСервере()
   
   Перем Пользователи;
   
   Объект.ИнтернетПоддержкаПоПользователям.Очистить();
   
   Пользователи = ПользователиИнформационнойБазы.ПолучитьПользователей();
   Для Каждого Пользователь Из Пользователи Цикл
      НоваяСтрока = Объект.ИнтернетПоддержкаПоПользователям.Добавить();
      НоваяСтрока.Пользователь = Пользователь;
      НоваяСтрока.УникальныйИдентификатор = Пользователь.УникальныйИдентификатор;
      НоваяСтрока.ЗапускатьПриСтарте = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить(
         "ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Истина,, Пользователь.Имя) = Истина;
      НоваяСтрока.СтароеЗначениеЗапускатьПриСтарте = НоваяСтрока.ЗапускатьПриСтарте;
   КонецЦикла;
   
КонецПроцедуры
Показать полностью
18. Игорь Фелькер (Brawler) 324 23.11.16 21:07 Сейчас в теме
Обработка обновлена.
Проверена на БП 3.0.44.200
19. Сергей Самсонов (user643908_0445353) 25.11.16 07:23 Сейчас в теме
Добрый день! скачал обработку с изменениями но она все равно не работает!!!
Может проблема в том что в колонке расписание стоит: "не применимо для команд с вариантом запуска открытие формы"???
Прикрепленные файлы:
20. Игорь Фелькер (Brawler) 324 25.11.16 08:17 Сейчас в теме
(19) на управляемых формах в механизмах БСП заложена возможность, что у внешних обработок может быть объявлена команда, которая может быть вызвана как регламентное задание, которому можно настроить расписание.
Эта же обработка не описывает никакой такой команды, которую можно запускать как регламентное задание.
В ней только есть одна команда и та открывает окно обработки, в которой уже работает пользователь.

Что у вас не работает мне не понятно.
Данная обработка прекрасно работает на последней версии БП 3.0.44.200.
Искал в БП используется ли еще настройка "ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", как оказалось используется и проверяется при запуске конфигурации.
21. Сергей Самсонов (user643908_0445353) 30.11.16 15:39 Сейчас в теме
Я уже писал что Ваша обработка не работает!! И проблема не в базе, а проблема в обработке!! Видно вы что-то не учли!!
Хотя сообщение появляется реже !
Прикрепленные файлы:
23. Игорь Фелькер (Brawler) 324 30.11.16 23:08 Сейчас в теме
(21) странно. ответ давал. наверное модераторы из-за ссылок потерли.
Короче у вас это сообщение носит совершенно иной характер, его не заблокировать.
Если вы добросовестный покупатель, то у вас вероятно и подписка ИТС оплаченная есть, а значит вы можете ввести все то, что от вас просит программа, а иначе вы типа как бы ее украли, и это сообщение будет лезть всегда, так как оно генерируется платформой.

Из документов 1С про платформу 8.3.7+.

Реализована проверка легальности использования прикладного решения на уровне платформы «1С:Предприятие». Проверка выполняется для прикладных решений, развернутых в файловом варианте или на сервере в версии МИНИ. При использовании прикладного решения, использующего базовую лицензию, проверка легальности использования не выполняется. Проверка выполняется при обращении платформы через Интернет в Центр защиты обновлений.
Информация о результатах проверки отображается в диалоге О программе.
В интерфейсе конфигуратора включены дополнительные команды для работы данного механизма.
24. Галина Злобина (gala2009) 8 13.01.17 08:40 Сейчас в теме
платформа 8.3.8.1747 БП 3.0.44.202
пользователь единственный admin
запускаю обработку, отключаю интернет-поддержку, по кнопке Показать текущее состояние - поддержка отключена
но.. сообщение Для работы с программой требуется подключить Интернет-поддержку пользователей. Для этого введите логин и пароль, которые вы используете на Портале 1С:ИТС
все равно всплывает!
Прикрепленные файлы:
25. Игорь Фелькер (Brawler) 324 13.01.17 09:28 Сейчас в теме
(24) Прошу не путать понятия интернет-поддержка и проверка легальности.
Обработка позволяет избавиться от окошек назойливой интернет-поддержки, а проверка легальности это уже вообще из другой области граничащей с буквой закона и обработка тут ничем не помогает. Читайте (23).
26. Галина Злобина (gala2009) 8 13.01.17 10:30 Сейчас в теме
Игорь, вы мой прикрепленный файл посмотрели? там про назойливую интернет-поддержку лезет как раз
27. Галина Злобина (gala2009) 8 13.01.17 10:36 Сейчас в теме
или вас смутило, что вылезло сразу 2 сообщения? одно про интернет-поддержку а другое про правомерность? ну не смотрите на второе
28. Галина Злобина (gala2009) 8 13.01.17 10:38 Сейчас в теме
а еще лучше прикрепите скрин - какое назойливое сообщение предотвращает ваша обработка. пожалуйста
29. Елена _ (citicat) 116 13.01.17 11:33 Сейчас в теме
Интернет-поддержка у конечного пользователя (бухгалтера) отрывает время от работы. Тем более, что количество отозванных релизов не уменьшается.
Проверка легальности - совсем другая проверка.
Поскольку работать с устаревшими релизами можно, особенно в оперативном учете.

30. Галина Злобина (gala2009) 8 13.01.17 11:58 Сейчас в теме
Елена, вы про что?
если про автоматическую проверку обновлений (релизов) - то она отключается переключателем в пользовательском режиме легко

а интернет-поддержка и тормозит, и достает, и не отключается!
31. Светлана Фаризова (user723405) 31.03.17 11:22 Сейчас в теме
32. zavsom1 zavsomovich (zavsom) 47 19.04.17 15:31 Сейчас в теме
(24) все правильно - у меня тоже не работает
33. zavsom1 zavsomovich (zavsom) 47 19.04.17 15:33 Сейчас в теме
релиз 3-0-49-22 все равно лезут те же самые картинки только уже раз в минуту. И пропало окно отложить на 7 дней. Раньше хоть оно было, но когда запустил обработку перестало появляться впору хоть свой логин и пароль раздавать.
34. Игорь Фелькер (Brawler) 324 19.04.17 21:17 Сейчас в теме
(24)(32) Посмотрите видео.
Лучше скачайте, а то при просмотре в браузере первые секунды могут пикселить.
https://yadi.sk/i/uY_699d_3H9PAv

База 100% типовая БП 3.0.49.23 ПРОФ
Надеюсь по видео вам станет понятно какое окно блокируется данной обработкой ПРИ СТАРТЕ и что оно действительно блокируется.
Никакие иные окна данной обработкой не блокируются и такое поведение у нее планировалось изначально.

(33) Если у вас там что-то каждую минуту лезет, то это думаю уже из другой оперы.
Не плохо бы увидеть, что у вас там лезет такого.
Не исключаю, что может даже и это окно, которое блокирует моя обработка.
Тогда что-то вероятно пытается в базе установить подключение к сервисам 1С и сперва вызывает окно подключения, так как в базе не занесены эти данные ранее.
Всегда можно установить точку останова в коде программы и проследить причину из-за которой было вызвано это окно.
Для примера на картинке, точка останова стоит в событии при создании на сервере в модуле общей формы ПодключениеИнтернетПоддержки.
https://yadi.sk/i/Ddqp4GVp3H9RGV
По стеку вызовов видно, что форма создается при старте системы.
А чтобы она при старте не открывалась, тут помогает моя обработка.
Ищущий да найдет причину.
35. Espert Espert (user785057) 04.07.17 10:42 Сейчас в теме
Подходит ли данная обработка для УТ 11.3.4.19 ?
36. Игорь Фелькер (Brawler) 324 04.07.17 11:20 Сейчас в теме
(35) В теории должна, так как УТ это производная от ERP, вернее ее часть, а раз работает в ERP, то и в УТ должна работать.
37. Игорь Фелькер (Brawler) 324 04.07.17 19:51 Сейчас в теме
(35) Проверил на Комплексной автоматизации 2.2.4.19, работает.
38. Андрей (user597053_pronko92) 28.07.17 11:46 Сейчас в теме
Если с лицензированием проблема , то я так видел делают, комментируют содержимое процедуры модуля КлиентЛицензированияКлиент
Прикрепленные файлы:
39. Игорь Фелькер (Brawler) 324 28.07.17 12:22 Сейчас в теме
(38) Мне данный вопрос мало интересен, так как все же пытаюсь жить при наличии ИТС подписки, а там с лицензиями проблем нет.
Оставьте свое сообщение