Перевод десятичного числа в HEX, BIN, OCT, _IdToStr и другие системы

Публикация № 286357

Разработка - Инструментарий разработчика

алгоритм перевод числа HEX BIN OCT _IdToStr по основанию система исчисления

Два алгоритма перевода десятичного числа в другую систему исчисления от 2 до 36 только средствами 1С (без ВК)

Задача вроде бы тривиальная.

Но не нашел БЫСТРОГО ответа на вопрос :

 

Как перевести средствами встроенного языка 1С 10-ное число в HEX ?

Ну и заодно - в BIN, в OCT и в другие системы исчисления ?

 

Пришлось достать учебники по математике Laughing и написать эту статью.

В результате - получил 2ва алгоритма:

- первый : с рекурсивными вызовами после остатка от деления по основанию Х

- второй : через логарифмы с циклом

 

Коротко о главном:

1) первый алгоритм - получился быстрее. Вот результаты:

   

	//Вариант 1: время = 77.697 сек , Обработано чисел = 1 000 000
	//65535 (HEX) = FFFF
	//65535 (BIN) = 1111111111111111
	//65535 (OCT) = 177777
	//65535 (_IdToStr) = 1EKF
	//на одно вычисление = 0,000077697 сек для случая _IdToStr

	//Вариант 2: время = 85.547 сек, Обработано чисел = 1 000 000
	//65535 (HEX) = FFFF
	//65535 (BIN) = 1111111111111111
	//65535 (OCT) = 177777
	//65535 (_IdToStr) = 1EKF	
	// на одно вычисление = 0,000085547 сек для случая _IdToStr
 

 

2) второй алгоритм (если честно) был подсмотрен в реализации SQL-функции для _IdToStr
и модифицирован для универсальности (не только для основания 36, а для любого основания).
Эта SQL-функция широко используется в сообществе 1С++
(К сожалению, автора-первооткрывателя : не знаю, поэтому - поклон ему и всем участникам проекта Laughing )

 

Алгоритмы (что во вложении) написаны для 1С.7.7

Алгоритмы универсальные: поэтому легко переделать для 1С8.* с учетом особенностей языков.

Скачать файлы

Наименование Файл Версия Размер
АлгоритмПеревода10числаВДругуюСистемуИсчисления

.ert 35,50Kb
04.06.14
12
.ert 2014.06.04 35,50Kb 12 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Ветер в поле 3 21.07.15 00:18 Сейчас в теме
Понадобилась функция для перевода из одного основания в другое.
Сначала написал свою, потом скачал это.

Вариант 2 содержит ошибку.
Когда число = Основание в степени Н, то происходит лишняя итерация.
Ошибка тут:
Знч = цел(Ln(ч10)/Ln(чОснование)) +1
Для i=1 По Знч-1 Цикл
чСтепень = чСтепень*чОснование;
КонецЦикла;

Вот демонстрация:
Вариант 1: время = 0.475, КвоИтераций=10000
1679616 = 19A100
1679616 = 110011010000100000000
1679616 = 6320400
1679616 = 10000

Вариант 2: время = 0.465, КвоИтераций=10000
1679616 = 19A100
1679616 = 110011010000100000000
1679616 = 6320400
1679616 = 000

Вариант 3: время = 0.046, КвоИтераций=10000
1679616 = 19A100
1679616 = 110011010000100000000
1679616 = 6320400
1679616 = 10000

Благо это самый тормозной алгоритм и его вряд ли кто использовал.
Просто будьте внимательнее.

P.S. 3-й вариант мой, но он использует еще и внешние компоненты.
К сожалению, в 1С++ используется сильно ограниченная версия перевода числа из одной системы в другую.
Она только для чисел до 2^31 - 1. Это чуть больше 2 миллиардов.
2. Ветер в поле 3 21.07.15 00:22 Сейчас в теме
Ну и мой вариант, может кому пригодится:

Используются объекты из 1С++
глМД = СоздатьОбъект("MetaDataWork");
глМатематика = СоздатьОбъект("Математика");

Функция глПеревестиСтрИзОдногоОснованияВДругое(Знач СтрЧисло, ОснованиеИз, ОснованиеВ) Экспорт
	
	СтрСимволов = "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ";
	
	//сначала переведем в число
	Если ОснованиеИз = 10 Тогда
		Число10 = Число(СтрЧисло); //небольшая оптимизация
		
	Иначе
		СтрЧисло = СокрЛП(СтрЧисло);
		
		//оптимизация: вычислим макс. кол-во знаков, кот. сможет осилить функция глМД.СтрокуВЧисло
		Число10 = 0;
		МощностьПозиции = 0;
		МаксКолвоСимволов = Цел(Лог(2147483646) / Лог(ОснованиеИз));
		
		Пока СтрДлина(СтрЧисло) > 0 Цикл
			Если МощностьПозиции = 0  Тогда
				МощностьПозиции = 1;
				
			Иначе				
				МощностьПозиции = МощностьПозиции * глМатематика.POW(ОснованиеИз, МаксКолвоСимволов);
			КонецЕсли;
			
			Число10 = Число10 + глМД.СтрокаВЧисло(Прав(СтрЧисло, МаксКолвоСимволов), ОснованиеИз) * МощностьПозиции;
			СтрЧисло = Лев(СтрЧисло, СтрДлина(СтрЧисло) - МаксКолвоСимволов);
		КонецЦикла;
	КонецЕсли;
	
	СтрРезультата = "";
	Пока Число10 > 2147483646 Цикл
		СтрРезультата = Сред(СтрСимволов, Строка(1 + (Число10 % ОснованиеВ)), 1) + СтрРезультата;
		Число10 = Цел(Число10 / ОснованиеВ);
	КонецЦикла;
	
	Возврат глМД.ЧислоВСтроку(Число10, ОснованиеВ) + СтрРезультата;
	
КонецФункции //глПеревестиСтрИзОдногоОснованияВДругое
Показать
3. webester 33 07.06.20 07:47 Сейчас в теме
Тем кто ищет для 8ки
Функция Из_10_В_Любую(Знач Значение=0,Нотация=36) Экспорт
	Если Нотация<=0 Тогда Возврат("") КонецЕсли;
	Значение=Число(Значение);
	Если Значение<=0 Тогда Возврат("0") КонецЕсли;
	Значение=Цел(Значение);
	Результат="";
	Пока Значение>0 Цикл
		Результат=Сред("0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ",Значение%Нотация+1,1)+Результат;
		Значение=Цел(Значение/Нотация) ;
	КонецЦикла;
	Возврат Результат;
КонецФункции

Функция Из_Любой_В_10(Знач Значение="0",Нотация=36) Экспорт
	Если Нотация<=0 Тогда Возврат(0) КонецЕсли;
	Значение=СокрЛП(Значение);
	Если Значение="0" Тогда Возврат(0) КонецЕсли;
	Результат=0;
	Длина=СтрДлина(Значение);
	Для Х=1 По Длина Цикл
		М=1;
		Для У=1 По Длина-Х Цикл М=М*Нотация КонецЦикла;
		Результат=Результат+(Найти("0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ",Сред(Значение,Х,1))-1)*М;
	КонецЦикла;
	Возврат Окр(Результат);
КонецФункции

Показать
Оставьте свое сообщение

См. также

Консоль прямых запросов для 1С++ (1С 7.7) Промо

Консоль запросов v7.7 1cv7.md Абонемент ($m)

Консоль прямых запросов для 1С 7.7, под компоненту 1Сpp.dll. Особенности: 1. Печать результата запроса. 2. Сохранение результата в файл в виде внутреннего представления таблицы значений 3. Формирование запроса как для SQL, так и для DBF вариантов, с разными вариантами драйверов. 4. Сортировка по произвольной колонке результата таблицы

1 стартмани

25.04.2012    33668    49    Aristo_    9    

Установка принтера по умолчанию для 1С 7.7

Практика программирования Разработка v7.7 1cv7.md Абонемент ($m)

Установка принтера по умолчанию в 1С 7.7. Обработка может быть полезна в том случае, когда нужно установить принтер по умолчанию, а доступа к рабочему столу нет (например, терминальный режим без рабочего стола или remoteApp)

1 стартмани

13.02.2019    6043    2    alsen    2    

Пример QR кода для Сбербанка в квитках ТСЖ (1с77)

Практика программирования Банковские операции Банковские операции v7.7 1cv8.cf Россия Абонемент ($m)

Формирование Штрихкода по ГОСТ 56042-2014 для Сбербанка.

1 стартмани

26.12.2018    6376    11    bob_    1    

Методы для группировки данных по полю,полям в Таблице Значений на примере универсального метода списания по партиям, а также отбора строк в ТЗ по произвольному условию. Для 8.x и 7.7 Промо

Универсальные функции Практика программирования v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Я очень часто использую группировку данных по полю и полям, как в восьмерке, так и в семерке. Это аналог запроса Итоги, но там строится дерево, а в большинстве случаев нужны "плоские данные". Да и делать запрос в большинстве случаев более накладный процесс, чем работа с ТЗ. Все достоинства такого подхода приведены на примере метода универсального списания по париям, а так же отбора строк в ТЗ по произвольному условию. Для 7.7 еще отчеты сравнения двух ТЗ. Работая с различными базами для упрощения сравнения номенклатуры, или как аналог джойнов(join), сделал сравнение двух таблиц значений по нескольким полям. Пока группировки полей должны быть уникальны. Часто приходится искать дубли, для универсального поиска есть ДублиВТзПоПолю и пример в Тест.ert.

1 стартмани

25.06.2015    28157    3    Serginio    1    

Несколько табличных частей в 1С:7.7 - это просто

Практика программирования v7.7 1cv7.md Абонемент ($m)

При программировании на платформе V7 достаточно часто возникает задача создать несколько табличных частей документа (или справочника). Традиционно эта задача имеет несколько решений..

1 стартмани

01.05.2018    12015    19    Gkmy    8    

Сравнение конфигураций на платформе 1Сv7.7

Инструментарий разработчика v7.7 1cv7.md Абонемент ($m)

Обработка позволяет сравнивать структуру полей разных баз данных на платформе 1Сv7.7, что, в случае объединения конфигураций, поможет избежать разрушения базы.

1 стартмани

12.11.2016    10187    12    citicat    7    

Как создать индикатор в 1С:Предприятии 7.7

Универсальные функции Работа с интерфейсом v7.7 1cv7.md Россия Абонемент ($m)

В статье дано описание создания индикатора на форме в среде разработки 1С:Предприятие 7.7 исключительно типовыми средствами.

1 стартмани

27.09.2016    12701    2    HAMMER_59    6    

Как получить номер и дату договора из наименования справочника договоров? Промо

Обработка справочников Практика программирования v7.7 1cv7.md Абонемент ($m)

В типовых конфигурациях платформы "1С:Предприятие 7.7" часто номер и дата договора указаны в самом наименовании договора. Что создает сложности в тех случаях, когда эти реквизиты надо знать, например, при конвертации данных в конфигурации платформы "1С:Предприятие 8", где номер и дата договора - отдельные реквизиты.

1 стартмани

24.09.2015    21128    2    SiAl    7    

Подсветка кода 1С в Visual Studio (2012, 2013)

Инструментарий разработчика v7.7 1cv7.md Абонемент ($m)

Для тех, кто использует GСomp и TFS в качестве системы контроля версий, не очень удобно сравнивать модули без подсветки кода. Этот плагин призван исправить несправедливость.

1 стартмани

06.06.2016    13437    10    MadDAD    6    

Для платформы 7.7. Отчёт по видам документов, двигавших регистр за период

Статистика базы данных Инструментарий разработчика v7.7 1cv7.md Россия Абонемент ($m)

Отчёт по видам документов, двигавших регистр за период.

1 стартмани

31.03.2016    12193    0    vendim    1    

Суммирование выделенных ячеек в столбце для 1С:Предприятие 7.7

Практика программирования v7.7 Абонемент ($m)

Суммирование чисел в столбце, выделенных мышкой, для 1С:Предприятие 7.7. В любом отчете, печатной форме или текстовом документе выделяете мышкой столбец с числами или группу ячеек в колонке таблицы, нажимаете на кнопку панели инструментов и в строке состояния получаете сумму. Пользоваться очень просто, удобно и быстро.

1 стартмани

09.03.2016    11173    4    электра    9    

1С: 7.7. Функции-обертки, функторы, отложенный вызов, карринг параметров на примере функции чтения табличных данных

Практика программирования v7.7 1cv7.md Абонемент ($m)

Человек, работающий в 1С, в силу своей практики и опыта может нуждаться в средствах программирования, в 1С не представленных. В публикации описаны средства отложенного вызова функций, каринга параметров, композиции и др., в основе которых лежит вызов функции посредством функции Шаблон. Несмотря на простоту, созданный за несколько лет работы в 1С 7.7 набор функций обрел мощь, достаточную для лаконичной реализации указанных целей.

1 стартмани

17.09.2015    9815    3    rozhkovdmitriy    21    

Технологическая проверка кода конфигурации (7.7)

Инструментарий разработчика Практика программирования v7.7 1cv7.md Абонемент ($m)

1С 7.7 не имеет практически никаких средств, предназначенных для контроля правильности кода. В синтаксически правильном, с точки зрения 1С, коде можно, например, определить переменную НомерДок в модуле документа. Эта обработка может помочь найти некоторые "плохие решения" в коде.

1 стартмани

03.09.2015    9906    5    vcv    6    

Структура модуля с выводом комментариев

Инструментарий разработчика v7.7 1cv7.md Абонемент ($m)

Отчет показывает структуру программного модуля на языке 1С:Предприятие 7.7.

1 стартмани

06.08.2015    11033    0    корум    1    

Секретный релиз платформы v77.27.7 Промо

Инструментарий разработчика v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Исправления платформы, позволяющие запустить 1cv77 в клиент-серверном варианте на СУБД MS SQL 2005-2014 без понижения режима совместимости.

10 стартмани

07.03.2011    268048    627    spock    914    

Быстрое попроцедурное сравнение модулей конфигураций 7.7

Инструментарий разработчика v7.7 1cv7.md Абонемент ($m)

Утилита для быстрого формирования отчета о различиях в конфигурациях 7.7

1 стартмани

18.06.2015    11367    5    MadDAD    3    

Компоновщик прямых запросов 7.7 (Выборка документов)

Инструментарий разработчика v7.7 openconf 1cv7.md Абонемент ($m)

Компоновщик прямых запросов позволяет делать выборки документов из SQL базы данных 1C 7.7 любой конфигурации

1 стартмани

18.06.2015    10888    0    942644    3    

Консоль прямых запросов для 1С++ (1С 7.7) + ToySQL

Консоль запросов v7.7 1cv7.md Абонемент ($m)

Консоль прямых запросов для 1С 7.7, под компоненту 1Сpp.dll. Особенности: 1. Печать результата запроса. 2. Сохранение результата в файл в виде внутреннего представления таблицы значений 3. Формирование запроса как для SQL, так и для DBF вариантов, с разными вариантами драйверов. 4. Сортировка по произвольной колонке результата таблицы Консоль подпилена для работы с ToySQL

1 стартмани

04.06.2015    12026    16    qeos    5    

Консоль (7.7) Промо

Инструментарий разработчика v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Предлагаю вашему вниманию консоль для программирования в среде 1С. Теперь для выполнения коротких разовых задач необязательно заходить в конфигуратор. 1.Запускаешь консоль 2.Пишешь свой код 3.Нажимаешь Выполнить. Требование: 1С++ (со встроеным FormEx) должна быть уже загружена 1sci.dll грузится ПриОткрытии() В архиве на всякий случай выложил все необходимое: 1cpp.dll (от 5 декабря 2008 г., 1:30:26) 1sci.dll (от 5 августа 2008 г., 13:32:42) Ссылки: 1sci.dll http://infostart.ru/projects/4443/ 1cpp.dll http://www.1cpp.ru/ Огромное спасибо steban http://infostart.ru/profile/1746/

1 стартмани

24.06.2009    21321    8    mdbm    26    

Подсветка синтаксиса 1C (в том числе языка запросов) в EmEditor

Инструментарий разработчика v7.7 1cv7.md Абонемент ($m)

Данная доработка возможностей EmEditor в первую очередь будет очень интересна людям, которые за долгие годы программирования привыкли к этому редактору, но вынуждены были использовать другие редакторы при работе с 1С, из-за отсутствия соответствующей подсветки текста. Теперь в этом нет необходимости, т.к. представляю вашему вниманию подсветку текста и языка запросов для EmEditor.

1 стартмани

17.05.2015    9941    3    Mopsik    2    

Консоль запросов

Консоль запросов v7.7 1cv7.md Абонемент ($m)

Консоль запросов к базе SQL, не требующая внешних компонент

1 стартмани

29.04.2015    13502    25    Gvozdod    8    

Написание SQL запросов с использованием метапарсера 1с++ прямо из 1С предприятия (пользовательский режим)

Инструментарий разработчика v7.7 1cv7.md Абонемент ($m)

Обработка для написания запросов. Большая часть взята отсюда http://www.1cpp.ru/forum/YaBB.pl?num=1157967835/all

1 стартмани

06.03.2015    126245    1    born85    6    

[Разработчику] Любая таблица значений в OLAP Промо

Инструментарий разработчика Универсальные обработки Практика программирования v7.7 1cv7.md Абонемент ($m)

Анализируем различные данные в 1С, используя OLAP-технологии со всеми прелестями. Т.е. наглядное отображение данных, быстрые расчеты, горизонтальные и вертикальные группировки любой вложенности, удобная фильтрация, Drag'n'Drop и ещё много приятных вещей от MS. Обработка на входе принимает практически любую таблицу значений (ТЗ в которой колонкам указаны типы значений, строка, число и т.п.), на выходе имеем на форме 1С сводную таблицу и график по этой ТЗ, с которой работаем, как и в Excel со сводной таблицей и диаграммой. Взял за основу разработку «OLAP Анализ счёта» ( http://infostart.ru/public/14964/ ) от JohnyDeath и переделал под любую ТЗ. Опционально используется «Прогресс бар для 1С 77» (http://infostart.ru/public/14061/ ) от Gmix.

1 стартмани

21.12.2012    28058    17    venger    7    

Оптимизация количества журналов документов в 1С:7.7

Практика программирования v7.7 1cv7.md Абонемент ($m)

Один из вариантов оптимизации количества журналов документов в 1С:7.7 без использования внешних компонент

1 стартмани

24.02.2015    8567    1    voha    8    

Формирование EAN-13 при помощи шрифта EANGNIVC.ttf Code128 шрифтом Barcode.ttf

Инструментарий разработчика v7.7 1cv8.cf Абонемент ($m)

Формирование EAN-13 шрифтом Eangnivc.ttf; Формирование Code128 шрифтом Barcode.ttf; Кнопка Рестарт; Генератор случайных чисел;

1 стартмани

08.12.2014    14869    21    EdGreen    1    

Все про картинки в 1С 7.7, ну или почти все...

Практика программирования v7.7 1cv7.md Абонемент ($m)

В 1С 8 наличие картинок товаров предусмотрено изначально, а в 7.7 такого нет. Проблема существует и ее исправляют, но это, как правило, частные случаи, касающиеся, например, печати прайса http://infostart.ru/public/289876/ , показу картинок в справочнике номенклатура http://infostart.ru/public/17125/, файловый менеджер картинок товара http://infostart.ru/public/15239/ или просто конфигурации работы с картинками http://infostart.ru/public/21142/ (не стремился дать полный обзор, поэтому не попавшие не обижайтесь :). Что не устроило – информация разбросана по статьям, необходимость дополнительно напрягаться, чтобы это заработало. Здесь я попытался собрать все «до кучи», а так же дать необходимые ссылки для желающих «копнуть вглубь».

1 стартмани

18.11.2014    34164    56    kitminsk    9    

Сравнение и объединение диалогов форм МД файла Промо

Инструментарий разработчика Работа с интерфейсом v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Обработка анализирует диалоги форм двух мдшников и показывает изменения в них в удобоваримом виде. Авmop: Peуmoв Дмumpuй, e-mail: dimoff66@mail.ru, icq: 177067865 Автору огромное спасибо!

1 стартмани

09.09.2008    26059    20    WiseSnake    27    

Класс для формирования штрих-кодов при помощи свободной библиотеки Zint

Инструментарий разработчика v7.7 1cv7.md Абонемент ($m)

Библиотека Zint позволяет формировать штрих-коды различных стандартов (более 100) в виде .png, .eps или .svg Данный класс предназначен для того, чтобы использовать данную библиотеку под 1С 7.7

1 стартмани

02.10.2014    17308    25    Amel2010    10    

Запуск php програм в 1С 7.7

Универсальные функции v7.7 1cv7.md Абонемент ($m)

Запуск программ PHP на сервере по прямому адресному запросу. Дополнительная возможность - передавать параметры методом GET-запросов.

1 стартмани

15.09.2014    7145    3    kwadro    1    

Шаблон внешней компоненты для Lazarus (FreePascal)

Инструментарий разработчика Разработка внешних компонент v7.7 v8 Абонемент ($m)

Шаблон внешней компоненты COM для Lazarus (FreePascal)

1 стартмани

16.05.2014    16514    19    v77    5    

Процесс бар (индикатор состояния выполнения цикла) Промо

Практика программирования v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Полезная "красотулька" в вашем документе. Будет очень полезна для медленных компьютеров, где не всегда понятно, работает-ли обработка или 1с-ка тупо "зависла"

14.04.2008    24794    2    ded00786    38    

Пример получения остатков по складу по запросу по почте из программы 1С 7.7.

Практика программирования v7.7 1cv7.md Абонемент ($m)

Пример получения остатков по складу по запросу по почте из программы 1С 7.7. Для получения остатков необходимо пользователю с любого почтовика (с любого "мыла") отправить текст сообщения GiveMyStockBalance_ForAnalize на почтовый адрес определенный в Константа.СерверПолучения. Программа выдаст остатки (можно переписать функцию для выдачи любых данных) в формате xls на почту указанную в константе Константа.СерверОтправки. Программа может быть полезна в тех организациях где трудно или невозможно осуществить прямой доступ к 1С сотрудников для просмотра необходимых данных. Также можно организовать некий почтамт - запрос для клиентов - при посылке определенного логина клиентом на его почту будет автоматически выслана информация, например, акт сверки с клиентов, или процент выполнения его заказа и т.д.

3 стартмани

25.03.2014    18403    1    protexprotex    3    

Ленивые запросы SQL (1С++) для 7.7 на русском

Инструментарий разработчика v7.7 1cv7.md Абонемент ($m)

Так сложилось, что приходится часто писать прямые запросы для 1С 7.7 используя 1С++. И так сложилось, что я столкнулся с регулярными выражениями, и, как водится, был ошеломлен. Пришлось написать несколько процедур для того, чтобы запросы было составлять удобнее, дабы переключение раскладки языков не сломать :) Получилось в итоге так, что раскладку переключать вообще не требуется. Запрос набирается просто в русской раскладке :) Почти как в 1С 8.Х! Операторы и названия таблиц, которые я пропустил, просто добавляются в функции запросПравилаЗаменыИменПолей, запросПравилаЗаменыИменТаблиц, запросПравилаЗаменыОператоров. Строки, заключенные в кавычки, обрабатываются корректно.

1 стартмани

12.03.2014    11742    1    mismak    3    

Зачеркнутый шрифт Palatino Linotype - 1C 7, 8, и др.

Инструментарий разработчика v7.7 v8 Россия Абонемент ($m)

Шрифт с зачеркнутыми латинскими, кириллическими символами, а также цифрами.

1 стартмани

21.02.2014    19570    7    etmarket    2    

Библиотека кода 1С 7.7 (накопленная за 8 лет) Промо

Практика программирования v7.7 1cv7.md Абонемент ($m)

Весь код на 1С 7.7, собранный для повторного использования за 8 лет работы.

10 стартмани

25.11.2012    27054    6    adhocprog    51    

Новые сказки о старом или как поймать событие «При активизации строки» в 1С: 7.7

Практика программирования v7.7 1cv7.md Абонемент ($m)

Давным-давно, в 1344152635 секунде по времени Unix, жил был один добрый, сильный и очень умный программист… Осилим царь-батюшка! — воскликнул наш добрый молодец и открыл пофигуратор однаэски 8.2… Там можно только прописать процедуры для реквизитов табличной части и реализовать событие ПриИзменении…

1 стартмани

29.01.2014    18990    5    majmyl    6    

1C7.7 парсер JSON

Универсальные функции v7.7 1cv7.md Россия Абонемент ($m)

РАБОТОСПОСОБНЫЙ парсер JSON встраивается в глобальный модуль в виде 3х функций. Для достижения положительного результата активно используется regexp.

1 стартмани

23.01.2014    17180    54    pit201201    16    

Подсветка синтаксиса 1Cv7.7 в Notepad++

Инструментарий разработчика v7.7 1cv7.md Абонемент ($m)

1. Открываем Notepad++. 2. В меню «Синтаксис» выбираем параметр «Задать свой язык ...» 3. В появившемся окне выбираем «Импорт ...» и выбираем Файл шаблона.

1 стартмани

22.01.2014    9835    2    leov-001    4    

Подготовка сведений для ПФР - исправление некорректного формирования отрицательных сумм взносов с сумм превышения максимального предела. Конфигурация: ЗИК 7.70.328 Промо

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия ФОМС, ПФ, ФСС Абонемент ($m)

Подготовка сведений для ПФР - исправление в формирование сведений персонифицированного учета, при превышении максимального предела

1 стартмани

22.10.2012    19459    0    u_n_k_n_o_w_n    9    

Компонента "Быстрый регистр" для 1С 7.7 (на прямых запросах SQL 1c++)

Универсальные функции v7.7 Абонемент ($m)

Ускорение операций с регистрами 1с 7.7 через объектную модель, за счет доступа через прямые запросы SQL (1c++). Существует возможность добавления произвольных подзапросов соединений c другими таблицами и отборов WHERE, гибкой настройки вывода полей в результат

1 стартмани

13.01.2014    12652    2    victor_goodwill    7    

Поворот картинки

Практика программирования Работа с интерфейсом v7.7 v8 Абонемент ($m)

Иногда возникает необходимость повернуть картинку из 1С.

1 стартмани

16.12.2013    17020    17    bborisko    14    

Tray Informer

Инструментарий разработчика Разработка внешних компонент Работа с интерфейсом v7.7 v8 Россия Абонемент ($m)

Согласитесь, что окно стандартное сообщений в 1С иногда приносит больше неудобств, чем пользы. И тем более разные "Предупредить"... Что с этим окном только не делают! Его отцепают от формы, делают маленьким, умудряются спрятать за границы экрана. А потом звонят программистам с претензией, что документ почему-то не проводится, отя ничего и не пишет. У вас такого не было? А вот у нас было и не раз )))

1 стартмани

04.09.2013    26243    6    O-Planet    78    

Вывод и перенумерация отчета с заранее неизвестным количеством группировок. Промо

Практика программирования Работа с интерфейсом openconf v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

1C v.7.7 Пример вывода отчета с заранее неизвестным количеством группировок, с возможностью изменять уровень вложенности группировок из списка значений на форме, с нумерацией конечного отчета, с выводом структуры вложенности группировок (с помощью внешней компоненты Йоксель - http://yoksel.net.ru/Hotfixes). В приложенном файле показан пример вывода отчета из сформированной таблицы значений. Код я старался закомментировать как можно подробней. Хоть семерка и вымирающая платформа, думаю еще есть люди, которые только начинают ей заниматься, и им это может пригодиться.

1 стартмани

21.03.2012    27313    6    unichkin    11    

Отчет "Дерево справочника"

Инструментарий разработчика Практика программирования v7.7 1cv7.md Абонемент ($m)

Зарядка для ума: вывод сворачиваемого дерева справочника в 1С v.7.7.

1 стартмани

20.07.2013    13004    1    uus    12    

Вывод таблицы ASCII

Инструментарий разработчика v7.7 1cv7.md Абонемент ($m)

Вывод таблицы символов ASCII для любого шрифта, установленного в системе.

1 стартмани

12.07.2013    18183    0    uus    3    

1С7: Галерея изображений для любого справочника

Инструментарий разработчика Универсальные обработки Работа с интерфейсом v7.7 1cv7.md Абонемент ($m)

В публикации представлена конфигурация "Галерея изображений". В конфигурации показан метод связки любого элемента любого справочника с изображением, хранящемся в внешнем файле в галерее ИБ. - Хранение изображений в структуре каталогов, сходной с иерархией элемента; - Использование Active-x броузера для отображения связанного рисунка; Используемые компоненты: 1SQLite, 1CPP, Formex. Используемые классы: УправлениеФормой.Привязки (из набора классов http://www.1cpp.ru/forum/YaBB.pl?num=1273512019)

1 стартмани

10.07.2013    19772    1    unichkin    11    

Функция Случайное число, RANDOM, RND для 1С 7.7 Промо

Практика программирования v7.7 1cv7.md Россия Абонемент ($m)

В 1С нет функции случайного числа. представляю Вам свою. основана на получении идентификатора и из него случайного числа. от 0 до 10, от 0 до 100 и от 0 до 1000.

1 стартмани

28.09.2011    22910    2    dnikolaev    19    

1Cv77. Исправление поведения множественного фильтра (МФ) типовых отчетов в части сохранения/восстановления настроек.

Практика программирования Работа с интерфейсом v7.7 1cv7.md Россия Абонемент ($m)

В большинстве российских типовых конфигураций для 1Сv7.7 (ТиС, ПУБ, Комплекс и др.) в отчетах используется множественный фильтр (МФ). Впервые он появился, более 10 лет назад, еще в ТиС 8.7, придя на смену МФ ТиС 8.6. С тех пор, аж до сего дня (24.03.2013) типовой механизм МФ содержит глюк связанный с восстановлением сохраненных настроек, хотя разработчики поют нам об обратном.

1 стартмани

26.03.2013    10871    0    piloturs    8