Оповещение пользователей 1С (сообщения между пользователями, уведомления, управляемое и обычное приложение)

Администрирование - Системное

В организации около 300 пользователей 1С и 6 конфигураций 1С управляемых и обычных. При работе иногда возникают ситуации когда нужно уведомить пользователей о технических работах, обновлениях и доработках, о необходимости завершить работу, сразу или например вечером к 20:00. Обзванивать или писать письма не эффективно. Оповещение через Active Directory очень маленькое его легко не заметить, так же отвлекает пользователей домена не использующих в работе 1С. Поэтому возникла необходимость разработать систему оповещений пользователей с минимальными изменениями всех конфигураций, подходящую для управляемых и обычных форм, и сообщениями, которые нельзя пропустить.

Разработка предназначена для уведомления пользователей как выборочно так и всех, так же можно просто писать сообщения или вести переписку между пользователями.

Разработка представляет собой регистр сведений и изменение в модуле управляемого или обычного приложения.
Для запуска оповещения необходимо добавить запись в регистр сведений, пользователи будут получать уведомления в период указанный между началом и концом времени оповещения.

УПРАВЛЯЕМОЕ ПРИЛОЖЕНИЕ


ОБЫЧНОЕ ПРИЛОЖЕНИЕ



Окно оповещения показываемое в программе пользователя блокирует весь интерфейс и пользователи работающие в данный момент в программе не пропустят оповещение и соответственно прочитают.

УПРАВЛЯЕМОЕ ПРИЛОЖЕНИЕ


ОБЫЧНОЕ ПРИЛОЖЕНИЕ


Список регистра

В списке оповещений можно просмотреть кому доставлено оповещение и кто прочитал.

УПРАВЛЯЕМОЕ ПРИЛОЖЕНИЕ



ОБЫЧНОЕ ПРИЛОЖЕНИЕ




Для внедрения разработки в свою конфигурацию необходимо:

  1. Установить возможность редактирования конфигурации.
  2. Сравнить с конфигурацией поставляемой в данной публикации. Будет добавлен регистр сведений "ОповещенияПользователей" и запись в модуле обычного или управляемого приложения, в зависимости от основного режима запуска приложения.

    Запись модуля обычного или управляемого приложения различаются:


    УПРАВЛЯЕМОЕ ПРИЛОЖЕНИЕ
Процедура ПриНачалеРаботыСистемы()
    //Модификация типовой конфигурации для оповещению пользователей программы (отправке сообщению любому пользователю)
    //Подходить для всех конфигураций
    ПодключитьОбработчикОжидания("modОбработчикОбработкиОповещения", 60);
КонецПроцедуры // ПриНачалеРаботыСистемы()

//Модификация типовой конфигурации для оповещению пользователей программы (отправке сообщению любому пользователю)
//Подходить для всех конфигураций
//Вызов обработчика ожидания продолжается пока форма не будет закрыта 
//или пока не будет вызван метод формы
Процедура modОбработчикОбработкиОповещения() Экспорт
    
    СообщениеПользователю = ПолучитьФорму("РегистрСведений.ОповещенияПользователей.Форма.ФормаОтправкиУпр").ПолучитьСообщенияОбработкиОповещения();
       
    Если Не СообщениеПользователю = Неопределено Тогда
        
        Форма = ПолучитьФорму("РегистрСведений.ОповещенияПользователей.Форма.ОповещениеУпр");
        Если Не Форма.Открыта() Тогда
            ЗаполнитьЗначенияСвойств(Форма,СообщениеПользователю,,"ТолькоПросмотр");
            Форма.Открыть();
        Иначе
            Форма.Активизировать(); 
        КонецЕсли; 
        
    КонецЕсли;           
                            
КонецПроцедуры 


ОБЫЧНОЕ ПРИЛОЖЕНИЕ

Процедура ПриНачалеРаботыСистемы()

    //Модификация типовой конфигурации для оповещению пользователей программы (отправке сообщению любому пользователю)
    //Подходить для всех конфигураций
    ПодключитьОбработчикОжидания("modОбработчикОбработкиОповещения", 60);

КонецПроцедуры // ПриНачалеРаботыСистемы()

//Модификация типовой конфигурации для оповещению пользователей программы (отправке сообщению любому пользователю)
//Подходить для всех конфигураций
//Вызов обработчика ожидания продолжается пока форма не будет закрыта 
//или пока не будет вызван метод формы
Процедура modОбработчикОбработкиОповещения() Экспорт
    
    СообщениеПользователю = РегистрыСведений.ОповещенияПользователей.ПолучитьСообщенияОбработкиОповещения();
    
    Если Не СообщениеПользователю = Неопределено Тогда
        
        Форма = ПолучитьФорму("РегистрСведений.ОповещенияПользователей.Форма.ОповещениеОбыч");
        Если Не Форма.Открыта() Тогда      
            ЗаполнитьЗначенияСвойств(Форма,СообщениеПользователю,,"ТолькоПросмотр");
            Форма.ОткрытьМодально();
        Иначе
            Форма.Активизировать();
        КонецЕсли;
    КонецЕсли;
    
КонецПроцедуры 

Внедрение разработки бесплатно, производиться в течении 10 минут.

Бесплатная техподдержка в течении 30 дней.

В 
Разработка предназначена для платформы 8.3, различных типовых и  нетиповых конфигураций, в режиме тонкого, толстого клиента и веб-клиента.

Возможна самостоятельная доработка, код открыт для редактирования.

Причины купить

Очень удобный вариант для оповещения, уведомления пользователей 1С об технических работах, доработках конфигураций, обновлениях, возможность вести переписку между пользователями 1С в рамках 1-й программы.

Достоинства

1) 100% доставка оповещений ко всем пользователям, в отличие от аналогов. 
2) Возможность отправки картинок.
3) Просмотр активности пользователей в списке сообщений (кому доставлено, кто прочитал).
4) Возможность написать ответ отправившему оповещение.
5) Не влияет на другие объекты, при обновлениях конфигураций, с установленной возможностью редактирования.

Гарантия возврата денег

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

Скачать файлы

Наименование Файл Версия Размер
Оповещение пользователей 1С (сообщения между пользователями, уведомления, управляемое и обычное приложение)
16.11.2016
1.11 1000 руб.

Моментальная
доставка

Оповещение пользователей 1С (сообщения между пользователями, уведомления, управляемое и обычное приложение): Техподдержка 1 месяц
25.07.2016
3000 руб.


Новый тикет

E-mail*
Тема (вопрос)*

См. также

PowerTools от 1 000